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2. CLASSIFICATION OF COMUPTERS

Analogy, Digital and Hybrid are the three classes of computers based
on the principle of work. Super, Mainframe, Mini and Micro are the
different classes of computers based on the size.

¥ Supercomputer,

¥ Mainframe computer,
¥ Minicomputer,

¥ Micro Computer.

3. Computer Generation

1

First Generation:
The period of first generation: 1946-1959. Vacuum tube based.

Second Generation:
The period of second generation: 1959-1965. Transistor based.

Third Generation:
The period of third generation: 1965-1971. Integrated Circuit based.

Fourth Generation:
The period of fourth generation: 1971-1980. VLSI microprocessor based.

Fifth Generation:

The period of fifth generation: 1980-onwards. ULSI microprocessor based.
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o o
o o
Ei 4. Differentiate between Volatile & Non —Volatile ;fi;
W PO P
@ memaories: @
@ | . ki - ¥
@ Volatile memory is the type of memory in which data is lost as o
w it is powered-off. Non-volatile memory is the type of memory w
W : : : P W
& in which data remains stored even if it is powered-off. &
W e ¥
w 5. Distinguish among System Software and =
W W
©w  Application Software @
“L;f ”L;f
“L;f ”L;f
4 W
o " B
y System Software Application Software W
“L;f ”L;ﬁ
w System Software maintains the Application software is built w
U U
g Maintains the system resources for specific tasks. g\
Nk i
W : — W
& And gives the path for application 2
? Software to run. @j
W W
}i\ Low-level languages are used to while high-level languages E;
w . . i
& Write the system software. Are used to write the &
P . P
& Application software. I
§ . o ¥
o It is general-purpose software. While it’s a specific purpose o
W W
& Software. @
W Without system software, the while without application W
@ System stops and can’t run. Software system always @
i Runs. W
i ¥
i ¥
i ¥
? o o] o] o] o] o] o] o] o] o] o o o] o] o] @
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i g
i v
W . ) W
& 6. a.) Click FILE > Save, pick or browse to a folder, type a &
it}; name for your document in the File name box, and click Save your ?LE
. y
@ work as you go — hit Curls often. To print, click the FILE tab, and then o
W click print. w
*’L;f ”L;f
U W
0y 6. B) W
*’L;f ”L;f
W Step 2: Click file in the top left-hand corner of the screen. W
*’L;f ”L;f
W Step 3: From the menu, choose Save. w
*’L;f ”L;f
w Step 4: A ‘Save’ dialogue box will come up. W
‘”’L;f ‘”L;f
;E) Step 6: Once you have typed in the name of your g

I
B Document, click Save. i
v @
+ 7.Save your document P
23 > Click FILE > Save, pick browse to folder, type a E;
Nk |
o “misword” for document in the file name box, and click S
“1? Save. “@
v 5 - - v
D If Work is already open, select File > New > Blank P
W document. Open Word. Or, if word is already open, W
}i select File > New. Double- clicks a template to open it. ig
% . W@
& 7. Select the text you want to modify. &
o | . . P
I ® Click on font size box in the Font group on the Home @
W tab. The font size drop-down menu appears. Move w
& your cursor over the various font sizes. Left-click on X
@ font size you want to use. Then it will change font size @
@ in your document. @
W ¥ Select the text you want to modify. Click on increase W
g decrease font size commands in the Font group on the g
? o o] o] o] o] o] o] o] o] o] o o o] o] o] o] /gl;)?\c
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v w
v w
w Home tab. Then font size will change w
U . . W
& (increase/decrease) in the document. &
@ ¥ Select the text you want to modify. Click on font style @
g box on the Home tab. The font style drip-down menu ?L_i\
W appears. Move your cursor over the various font styles. 9P
g Left-click the font style you want to use. Then font style E\
G will change in the document. @
@ ¥ Select the text you want to modify. Click on font style W
! W
& box on the Home tab. The font colour menu appears. @
W Move your cursor over the various font colours. Left- w
U . W
& click the font colour you want to use. Then font colour %—i\
0y will change in the document. oW
: v
U U
© SAVING DOCUMENT f
W » Launch word 2007 and click the Office button. .. W
g{ > Scroll to the first section to edit. .. g
1K A
P » Scroll to another section to edit, this time at a place W
w where you would like to leave a comment for the W
U . U
& document designer. .. @
W » Press the “Ctrl-F” keys to open the “Find and Replace” w
h window v
”L;f ) “/L;ﬁ
“  PRINT DOCUMENT P
v v
g » Click the OFFICE BUTTON. .. g
G » From the OFFICE BUTTON menu, click the next to PRINT. .. W
;L? » In the preview and print the document submenu, click g
& .
& PRINT PREVIEW. @
W » To return to your document without printing, on the print w
& preview command tab, click CLOSE PRINT PREVIEW. &
i ¥
i ¥
? o o] o] o] o] o] o] o] o] o] o o o] o] o] @
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v w
v w
W W
W w
W Click FILE > Save, pick or browse to a folder, type an W
ig “equations” for document in the File name box, and click save. ?L_i\
W Select keyboard shortcuts to apply superscript or subscript W
it}; select the text or number that you want. For superscript, press ?LE
| W
o Ctrl, Shift, and the plus sign (+) at the same time. For subscript, @
W press Ctrl and the Equal sign (=) at the same time. w
“L;f ”L;f
@ Select the text or number that you want. For superscript, press W
! W
& Ctrl, Shift, and the Plus sign (+) at the same time. For subscript, @
W press Ctrl and the Equal sign (=) at the same time. w
i W
i 9. Select the text that you want to convert, and then click Insert ”g
W %
& > Table > Convert Text to Table. In the convert Text to box, I
@ choose the options you want. Under Table size, make sure the ‘”@
U U
&, numbers match the numbers of columns and rows you want. In &,
oW the Fixed column width box, type or select a value. oW
”L;f “/L;ﬁ
W 10. For a basic table, click Insert > Table and move the cursor W
2% over the grid until you highlight the number of columns and %i
W rows you want. For a larger table, or to customize a table, @
? select Insert > Table > Insert Table. B
v @
U U
@ 11. @
@ » Click the File tab. @
W » Click New. W
E » Under Available Templates, double-click Blank g
WP Workbook. Keyboard shortcut To quickly create a 0
E now, blank workbook, you can also press CTRL+N. g
W 12 W
i ¥
i ¥
& &
? o o] o] o] o] o] o] o] o] o] o o o] o] o] o] ﬁ?
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v @
v @
W If you need to sum a column or row of numbers, let Excel w
U W
& do the math for you. Select a cell next to the numbers you &
@ want to sum, click AutoSum on the Home tab, press Enter, @
g and you’re done. When you click AutoSum, Excel ?L_i\
W automatically enters a formula (that uses the SUM 9P
v function) to sum the numbers. v
g THE average FUNCTION IN Excel is used to find the z_i\
W arithmetic mean of specified numbers. The syntax is as @
g follows: AVERAGE(number 1, [number2], ..) Where g
| W
o number 1, number2, etc. oy
U W
% The MAX function is a premade function in excel, which W
%\ finds the highest in a range. The function ignores cells g
Nk |
& with text. It will only work for cells with numbers. S
W W
G Note: There is another function called MIN, which finds G
w the lowest value in a range, the opposite of MAX. ”g
W %
23 Select a cell below or to the right of the numbers for E;
Nk .
P> which you want to find the smallest number. On the <
w Home tab, in the Editing group, click the arrow next to %};
W . . %
& AutoSum. , click Min (calculates the smallest) or Max &
oW (calculates the largest), and then press ENTER. oW
%;f ﬂ;ﬁ
W 13. v
i @
s Resize columns &
W > Select a column or a range of columns. W
E » On the Home tab, select Format > Column Width (or g
W Column Height). P
g » Type the column width and select OK. g
i @
i @
ﬂé)? o o] o] o] o] o] o] o] o] o] o o o] o] o] o] ﬁ?
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o o
o w
w » Select the row or rows that you want to change. On the w
W . : . W
& Home tab in the Cells group, click format. Under cell size, &
@ row height. In the Row height box, type the value that you @
h want h
W » Delete cells, rows, or columns Right-click, and then select W
g the appropriate delete option, for example, Delete cells & E
W shift up, Delete cells & shift left, Delete Rows, or delete W
W Columns. w
W _ W
o » There two types of cell references: and absolute. Relative &
W and absolute references behave differently when copied Y
U . . WP
& and filled to other cells. Relative references change when %—i\
g a formula is copied to another cell. Absolute references, oW
?ff on the other hand, remain constant no matter where they ?L_Ji
W are copied. i
v v
~14. Presentation Tools for Beautiful
9P : WP
- Presentations 2
1%1 » Tool#1: Templates and Themes. %i
W > Tool#2: Slide Layouts. P
W > Tool#3: Fonts. W
W W
> » Tool#4: Colour Themes. @
W > Tool#5: Icons. W
& . v
o » Tool#6: Shapes. &
W » Tool#7: Stock Photos. W
@ » Tool#8: Charts and Graphs. @
v W
i B. Open PowerPoint. In the left pane, select New. Select an option: W
g To create a presentation from scratch, select Blank Presentation. g
@ Click FILE > Save, pick or browse to a folder, type a name for your @
o 7
o o
@ o o o o o o o o o o o o o o o o ?
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i g
i v
w presentation in the File name box, and click save. Save your work as w
U ) ) ) ) W
& you go. Hit Curls often. There are multiple ways to add titles in &
@ PowerPoint. Use the Layout option to create a standalone title slide ”Lff
U . . W
@ or to add a title to a slide... @\
@ o . . v
+  Outline view to title a slide P
“L;f ”L;f
U . . . . . . . . W
& » Click View > Outline View. A slide without a title will have &
0y no text to the right of the slide number... 4
it}; » Click to the right of the slide number. ?L_i\
W » Type your new title here, or update an existing slide title. W
it}; Your text will appear on the slide as you enter it. g
' W
% : : . @
i Use the Layout option to title a slide 5
g » That it can have a title. Select the slide whose layout g
G you will change so G
W > Click Home > Layout. “@;
U U
S » Select Title Slide for a standalone title page or Title @
W and Content for a slide that contains a title and a full w
”L;f lid b ‘@
D slide text box... o
W » Select the click to add title text box. W
W i W
i 15. Insert a bulleted or numbered list %
W W
o On the View tab, click Normal o>
;L? Click in the text box or placeholder where you want to ?
0 J
I add bulleted or numbered text. IS
@ On the Home tab, in the paragraph group, click Bullets or Tf
@i Numbering. , and begin typing your list. Press Return to &
W create a new list item. W
& &
i ¥
i ¥
? o o] o] o] o] o] o] o] o] o] o o o] o] o] @
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v w
v w
W . W
2 Insert and update Excel data in -
W : Y
i PowerPoint P
4P . _ . 4P
9P > In PowerPoint, on the Insert tab, click or tab Object. W
g > In the Insert Object dialog box, select Create form g
,‘ P
W > Click or tab Browse, and in the Browse box, find the w
U . . . W
N Excel workbook with the data you want to insert link &
0y to. oW
“L;f ”L;f
“L;f ”L;f
‘”L? ‘”L;f
! W
g PART —2 &
W . : W@
& 16. Low-level languages are machine-friendly. They are, &
@ thus, very difficult to understand and learn by any human. @
%i High-level languages do not depend on machines. Low- g
W level languages are machine-dependent and thus very WP
23 difficult to understand by a normal user. E;
Nk .
w 17. 0
“/L;f “/L;ﬁ
“/L;f “/L;ﬁ
“/L;f “/L;ﬁ
U . o U
& Data Type Format Typical Bit Size N
W Specified o
W Unsigned char %cC 8 W
;L? char %cC 8 g
& - .
& Signed char %c 8 @
9GP in %d, %i 16 or 32 W
w Unsigned in %u 16 or 32 w
W : : o o , P
i Signed in %d, %i Same as in P
W 16 or 32 W
i @
i ¥
ﬂé)? o o] o] o] o] o] o] o] o] o] o o o] o] o] o] ﬁ?
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W Short in %had 16 w
g Unsigned short in %Hu 16 E
< Signed short in %had 16 &
W Long in %ld., %li 32 W
W W
W W
W W
W W
W W
& 18. &
& :
z a. 27 b. 17.5 c. 16 g
& :
o 19. Syntax &,
W A. if (condition) W
W W
P True P>
& B. <
W W
W o : W
& For (initiation statement; expression; updatestatement) &,
w Body of the loop w
W C. while (condition) W
W Statement(s); w
B bo 5
W Statement(s); w
W W
o } while (condition); o
W @
W @
W o - W
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