Assignment 1 Fundamental Of It Programing.
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Q1Ans: The four fundamental parts of computer are:
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Q2Ans:

Input device
Output device
CPU

Memory unit

CPU Output

device

Control unit —>

Arithmetic/logic unit

Vo

Memory unit

Based on size and capacity, computers are classified as

Super computers: They have thousands of processors. Because of their extraordinary speed,
accuracy and processing power, supercomputers are well suited for solving highly complex
problems and huge amount of calculations.

e.g. JAGUAR, ROADRUNNER etc.

Mainframe computers: they are very large often filling an entire room and can process
thousands of millions of instructions per second. They are capable of supporting hundreds to
thousands of users simultaneously. Functions performed by mainframes include flight
scheduling, reservations and ticketing for an airline etc.

Minicomputers: they are much smaller than mainframes. They are typically larger, more
powerful and more expensive than desktop computers. Users connect to the server through a
network by using desktop computers.

e.g. apple | pod, CDC 160A.

Microcomputers: they are the most frequently used type of computers. It is also known as
personal computers.
e.g. desktop computers, laptop.



Q3Ans: Generation in computer terminology is a change in technology of a computer which were being
used.

There are four computer generation such as 1% generation, 2"° generation, 3™ generation and 4"
generation.

In the first computer system, Vaccum tubes were used.
Transistors are used in the second generation.
Integrated circuit technology were used in the third generation.

In the fourth generation microprocessors are used.

Q4Ans: volatile memory non- volatile memory
1. Itis a computer storage that only 1. It is a type of computers memory that has the
maintains its data while the device is capability to hold saved data even if the power
Powered. Is turned off.
2. E.g.RAM 2. E.g. ROM, hard disk, floppy disk, etc.
3. Primary memory has limited storage 3. Secondary memory provides permanent
Capacity and is volatile storage of data and in bulk quantity.

Q5Ans: System software: it is a type of software that is designed to run a computer’s hardware and
application programs. Software like operating systems, compilers, editors and drivers etc. come
under this category. A computer cannot function without the presence of system software.

Application software: it is a software created for specific purpose used by end users. It can be called
an application or simply an app.

Examples: word processors, accounting app etc.

Open source software: it is a type of computer software in which source code is released under a
license in which the copyright holder grants users rights to study, change and distribute the software
to anyone and for any purpose.

E.g. the Linux operating system.
Q6a) Ans. “Yourself”

My name is Parbati. | am 21 years old. | love to sing and dance. | am a student of science
at IMPHAL COLLEGE, IMPHAL, MANIPUR. Currently | am learning computer CCA course at RGlI
TRAINING INSTITUTION.

The steps involved are:




We click the Microsoft office button.

We select new. The new document dialog box appears.

We select blank document under the blank and recent section. It will be highlighted by default.
We click create. A new blank documents appear in the word window.

To save the document, we click again the Microsoft office button.

We select save as —p word document. The save as dialog box appears.

We select the location where we want to save the document using the drop down menu.

We enter the file name “yourself” for the document.

We click the save button.
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b)Ans: steps to change the font style:

1. we select the text we want to modify.

2. left click the drop-down arrow next to the font style box on the home tab. The font style
drop-down menu appears.

3. we move cursor over the various font styles. A live preview of the font will appear in the
document.

4. left click the font style we want to use. The font style will change in the document.

Steps to change the font size

1. We select the text we want to modify.

2. Leftclick the drop-down arrow next to the font size box on the home tab. The font size
drop-down menu appears.

3. We move cursor over the various font sizes. A live preview of the font size will appear on the
document.

4. Left click the font size we want to use. The font size will change in the document.

Steps to change the font color

1. We select the text we want to modify.

2. Left click the drop-down arrows next to the font color box on the home tab. The font
color menu appears.

3. We move cursors on various font colors. A live preview of the color will appear in the
document.

4. Left click the font color we want to use. The font color will change in the document.

Steps to highlight the line

1. We select the line that reads “needs to get IMS’s address”

2. We click the highlight command and select yellow color in the font group on the
home tab.

Q7.Ans: MS Word

MS word is a widely used commercial word processor developed by Microsoft.

MS word is application software, which is capable of



creating

editing

saving, and

printing any type of document

The steps involved are:
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10.
11.

12.

13.

14.
15.

we click the Microsoft office button.

We select new. The new document dialog box appears.

We select blank document under the blank and recent section.it will be highlighted by default.
We click create. A new blank document appears in the word window.

We create the given documents from the question

We select the text “MS word” and change the font size by clicking on the font size box on the
home tab.

We select the text “MS word” to change the font the font color into red by clicking on the font
color menu.

We select the text word processor and underline it by clicking the underline command in the font
group the home tab.

We select the text “MS word” to change the font style into italic by clicking italic command.

We select the text we want to format as a list and click on the bullets command on the home tab.
We change the font color of the text “creating” and “saving” into blue and red resp. by clicking on
the font color command, again we select the text “and” and click on strikethrough command.
We select the text “printing any type of document” and change the font style into bold by clicking
on the font style command.

We save the file name as “ms-word” by clicking the Microsoft office button and select save as
We select the location where we want to save the document using drop-down menu

We click the save button.

Q8.Ans _Equations

X2 +Ys=30

2 +Q*=50

A2+38:X2+Y8

The steps are:

1.
2.

A

We create the given documents in MS-word

We select the text where we want to format and click on the subscript and superscript
command on the home tab

We save the file name as “equations” by clicking the Microsoft office button and select save as
we select the location where we want to save the document using the drop down menu

we click the save button



Q9.Ans. To convert existing text to a table:

1.we select the existing highlight text that we want to convert.

2.We select the insert tab

3.We click the table command

4.We select convert text to table from the menu. A dialog box appears

5.We click ok. Then the text appears in a table.

Q10.Ans

the steps are:

1.We place our insertion point in the document where we want our table to appear

IN

. we select the insert tab

3. we click the table command

I

. we drag our mouse over the diagram squares to select the numbers of columns and rows in the table.
5. left click our mouse and the table appears in the document.

6. we enter the text into the table

Q11) Ans:
No Name Marks
1 nl 60
2 n2 70
3 n3 80
4 n4 90
5 n5 40
6 nb6 50
7 n7 77
8 n8 44
9 n9 88
10 nl0 55



Q12) Ans:

No. Name Marks Sum Average Maximum Minimum
1 nl 60 654 65.4 90 40
2 n2 70
3 n3 80
4 n4 90
5 n5 40
6 nb6 50
7 n7 77
8 n8 44
9 n9 88
10 nl10 55
Q13. (a) Ans.

» To modify column width of a worksheet:
i.  Selectacolumn or arange of columns.
ii. Select a Home tab and in the Cells group, select Format.
iii. Click on Column width and type the width for column.
iv.  Select OK.
» To modify the row height of a worksheet.
i.  Selectarow or arange of rows.
ii. Select a Home tab and in the Cells group, select Format.
iii.  Click on Row Height and type the height for row.
iv.  Select OK.
» To delete rows and columns of a worksheet.
i.  Select the cell you want to delete within the column or row.
ii.  Select Home tab. And in cells group click on Delete Sheet Column or Row.
OR
i Select the desire row or column.

Q13. (b) Ans.

> Absolute Reference:
An absolute reference in Excel means there is a fixed point of reference applied to a cell or a
formula. This is so the return value will always stay the same no matter where the cell or
formula moves to — within the same sheet or across different sheet.



This refers to a fixed point of reference is a constant, and involves the use of dollar sign $ in the
formula (i.e., everyone is to receive the same bonus payout, so the amount $1500 is constant in
this situation).

Microsoft Excel
97-2003 Worksheet

> Relative Reference:
It is the default cell reference in Excel. It is simply the combination of column name and row
number without any dollar (S) sign. When you copy the formula from one cell to another the
relative cell address changes depending on the relative position of column and row. C1, D2, E4,
etc. are examples of relative cell references. Relative references are used when we want to
perform a similar operation on multiple cells and the formula must change according to the
relative address of column and row.

Microsoft Excel
97-2003 Worksheet

This refers to a relative point of reference, is constantly changing and dollar sign (S) is absent in
the formula (i.e., when each unit price and quantity are difference variables, there’s no constant
in the calculation).

» Cell Address:
A cell address is a combination of column letter and a row number that identifies a cell
on a worksheet.
For example, Al refers to the cell at the intersection of column A and row 1; B2 refers to
the second cell in column B, and so on.
When used in formula, cell references help Excel find the values the formula should
calculate. For instance,
e To pull the value of Al to another cell, you use this simple formula:
=Al
e To add up the values in cells A1 and A2, you use this one:
=A1+A2

Q14. (a) Ans.
Tools available to customize our PowerPoint presentation are:

a) Perspector
b) Pivot Viewer



c) Autodesk 3DS Max

d) VisualBee PowerPoint Add-in
e) SmartArt

f) Animations and Transition

g) Wordle

h) CA coo

i) Oomfo

j) Clip champ

(b). Ans.

» To open blank presentation:
I.  Open PowerPoint presentation using ‘Run’ command (window key + R).
II.  Select the ‘Blank Presentation’. It is opened.
» Save the Presentation as Labl.pptx.:
I.  Select the ‘File’ on Tab bar.
II.  Click on ‘Save As’ option.
lll.  Click on document/Desktop as your choice.
IV.  Type the name ‘Labl.pptx’.
V.  Click the ‘Save’ button.

» Add a Title to the first slide: the name of your college.
i. Leftclick on the ‘Click to Add Title’ section on the first slide.
ii. Type the name of your college.
» Type your first name and last name in the subtitle section:
i. Leftclick on the ‘Click to Add Subtitle’ section.
ii.  Type your first name and last name.
» Add a New slide which has a Title and content.
i.  Select the Home tab.
ii.  Click on the dropdown button of the ‘New Slide’ on toolbar.
iii.  Select the slide having ‘Title and Content’. It is added.

Q15. Ans.

» Title slide and bullet list:
i.  Open PowerPoint Presentation.
ii. Select the Home tab.
iii.  Click at the dropdown button on ‘New Slide’ at toolbar.
iv.  Select the slide having Title slide and Bullet list.



» Inserting Excel sheet:

iv.

Open the slide where you want to insert the Excel Sheet.
Select the ‘Insert tab’. And click on ‘Object’ on tool bar.
Select the ‘Microsoft Excel Worksheet’ object type.

Click the ‘OK’ button.

» ClipArt and Text:

i

ii.
iii.
iv.

Select the Insert Tab.

Select the ‘Pictures’ or ‘Online pictures’ on tool bar.
Choose the appropriate art for the topic.

Click on the ‘Insert’ button.

> Slide show effects:

Select ‘Design Tab’ for Themes, Variants and Slide size.
Select ‘Transition Tab’ for Cut, Fade, Push, Wipe, Split, Reveal, Shape, Flash, etc.
for slide effects.

Q16. Ans,
Machine language High level language

1. A computer programming language 1. Itis a programming language that enables
consisting of binary instructions which a development of a program ina much
computer can respond to directly more user friendly programming context

2. It requires no translator to translate the 2. It takes additional translation time to
code. It is directly understood by the translate the source code to machine code
computer 3. They are programmer friendly

3. This language makes fast and efficient use of
the computer.

Q17.Ans. The different data types of C programming language are:

Char: the most basic data type in C.it store a single character and requires a single bite of memory in
almost all compilers.

Int: as the name suggests, an int variable is used to store an integer.

Float: it is used to store decimal numbers

Double: it is used to store decimal numbers (number with floating point value but its range of values is
high in comparison to float)

Q18. Ans. A) X=33

B) Y=30

c)C=16




a)

b)

d)

Q19. Ans. a) if- else statement:

If statements can be followed by an optional else block of statements, which executes when
the Bootcan expression is false.
Syntax
If (expression)
{

true block of statements;

}

else
{
else block of statements;

}
For loop is similar to while loop. Basic syntax of for loop is as follows:

For (expression 1; expression 2; expression3)
{
Block of statement
}
In the above syntax
Expressionl-initializes variables.
Expression2 — conditional expression as long as this condition is true, loop will keep
executing.
Expression3- it is the modifier which will increase or decrease the value of the variable.
While loop.
Basic syntax of while loop is as follows
While (condition)
Single statement.
OR while (condition)
{

Block of statements

1
Do- while loop.
Do-while loop is just like a while loop except that the text condition is checked at the end of the
loop rather than the start. This has the effect that the body of the loop are always executed at
least once
Basic syntax of do-while loop is as follows
Do
{
Single statement

Or

Block of statements
} while (condition);



Q20.Ans. A) 1

B) 2

C)b =100

No.

Name
1nl
2 n2
3 n3
4 n4
5n5
6 n6
7 n7
8 n8
9 n9

10 n10

Marks

60
70
80
90
40
50
77
44
88
55

Sum

654

Average Maximum Minimum

65.4

90

40



