
                          CCA-101: Fundamentals of IT & Programming                                           

                                            Assignment -1 

1) What are the four fundamental parts of computer? Explain it with the help of diagram. 

▪ Monitor   

A display screen used to provide visual output from a                                                    

computer 

▪ Keyboard  

 
A keyboard is a input device that allows users to enter letters, numbers and 

other symbols into the computer. 

▪ Central processing unit (CPU) & 

   
The brain of the computer is CPU. 

▪ Mouse 

 
 A mouse is a input device moving along the flat surface to move the cursor 

to different items on the screen or to select the items by pressing the 

mouse. 

 

2) Discuss about the classification of computers based on size and capacity.    

                 Computer is classified into four based on their size and capacity, 

▪ Super computers 

▪ Mainframe computers 

▪ Mini computers 

▪ Micro computers 

3)What is the meaning of computer generation? How many Computer Generations are 

defined? What technologies were/are used?   

                    The evaluation of digital computing often divided into generations. Each 

generation is characterized by dramatic improvements over the previous generation in the 

technology used to build computers, in terms of the internal organization of computers and 

programming languages. 



 There are five generation of computers is as follows: 

• First generation (1941-56) 

• Second generation (1956-63) 

• Third generation (1964 – 71) 

• Fourth generation (1971-Present) 

• Fifth generation (Present- Beyond) 

                             First generation computer systems used vacuum tubes for circuitry and magnetic 

drums for memory. These computers were very expensive to operate. It consumes lot of electricity. 

                          Examples: UNIVAC ( Universal Automatic Computer) 

                                              ENIAC ( Electronic Numerical integer and computer) 

                          In second generation computers, transistors replaced vacuum tubes. The transistors is 

far superior to the vacuum tube, allowing computers to become smaller, faster, cheaper, more energy 

efficient and reliable than the first generation computers. 

                    The development of integrated circuits is the hallmark of the third generation of 

computers. Transistors were replaced by integrated circuits which drastically increased the speed and 

efficiency of computers. 

                    In fourth generation computers, the microprocessor brought thousands of integrated 

circuits into a single silicon chip. These computers also covered the development of Graphical User 

Interface (GUIs), mouse and handled devices. 

                    Fifth generation computing devices based on artificial intelligence are still in development. 

The use of parallel processing and superconductors is helping to make artificial intelligence a reality. 

There are some applications such as, voice recognition,that are being use today. 

4) Differentiate between volatile and non-volatile memories. 

         

                       Volatile  memory         Non- volatile memory 
 

 
It is a computer storage that only maintains its 
data when the device is powered. 

 
It is a type of memory that has the capability 
to hold saved data even when the power is 
turned off. 

 
Temporary  storage 

 
Permanent storage 

 
Writing data is faster 

 
Writing data is slower. 

 
Example: Random Access Memory(RAM) 

 
Example: Read Only Memory(ROM) 
 

 



5) Distinguish among system software, application software and open source software on the basis 

of their features. 

System software: 

            It is a type of software that is designed to run a computer’s hardware and application software. 

Software like operating systems, compliers, editors and drivers etc., come under this software. A 

computer cannot function without the presence of system software. 

Application software:  

           It is software created for a specific purpose, used by end users. It can be called an application 

or simple app. 

          Example: Word processor, a web browser, an email client etc….. 

Open source software: 

            Open source technology is defined as the development of software for allowing end users and 

developers to not only see the source code of software, but modify it as well. It is a type of computer 

software in which source code is released under the license in which the copyright holder grants users 

right to study, change and distribute the software to anyone and for any purpose. 

            Example: The Linux Operating System (OS) is the best known example for open source software. 

6) a) Create a file in  Ms-Word to insert a paragraph about yourself and save it with file name 

“yourself”. 

                       I am K. Soundarya. My father name is V.Kamalanathan and my mother name is L. 

Kasthuri. My father is working as a teacher in Govt Hr. Sec. School,Indur and  my mother is  a home 

maker. I have two sibilings. My elder sister name is K. Pavithra ,  She is studing her Master degree in 

English and my younger sister name is K. Akshaya , she is studing 11th standard. I have completed my 

graduate degree in Seethalaksmi Ramaswami college, Trichy.  My ambition is to become an IAS 

officer. My hobbies are listening music, playing games etc.. My favourite subject is Maths. I am very 

bold and courageous to do anything. 

To create and save a file: 

       First you should click the Microsoft office word. After completing the text whatever you want to  

make, click the save As button on the Office button. Select the location where you want to save the 

document and give the document as “Your name”.  Then click the save button. 

6) b) Write steps regarding followings 

 To change the font style: 

➢ Select the text you want to modify. 

➢ Click on the font style box on the Home tab. The font style drop-down menu appears. 

➢ Move your cursor over the various font styles. 



➢ Left click the font style you want to use. 

➢ Then font style will change in the document. 

To change the font size: 

➢ Select the text you want to modify. 

➢ Click on the font size box in the font group on the Home tab. The font style drop-down menu 

appears. 

➢ Move your cursor over the various font sizes. 

➢ Left click the font size you want to use. 

➢ Then the font size will change in your document. 

To change the font color: 

➢ Select the text you want to modify. 

➢ Click on the font color box on the Home tab. The font color menu appears. 

➢ Move your cursor over the various font colors. 

➢ Left click the font color you want to use. 

➢ Then the font color will change in your document. 

Text highlight color: 

         Need to get IMS address  

7) Create a file in MS-word for the following document and save it with file name ’ms_word’. 

Describe all steps involved in it. 

Ms Word is a widely used commercial word processor developed by Microsoft. 

Ms Word is application software, which is capable of 

• Creating 

• editing 

• saving and  

• Printing any type of document 

To create and Save the document: 

➢ Click the Microsoft office button or File tab. 

➢ The New dialog box appears. 

➢ Select Blank document. A New document appears in the word window. 

➢ After completing the Text select Save As – Word document. 

➢ Select the location where you want to save the document using the drop-menu. 

➢ Enter a name for the document as “ms_word”. 

➢ Click the save button. 

8) Creae a file in Ms-Word for the following document and save it with file name ‘equations’. 

Describe all steps involved in it. 

                                         1)  X2 + Y5 = 30 



                                         2)  Z3 + Q4 = 50 

                                         3)  A2 + B8 = X2 + Y8 

To create and Save the document: 

➢ Click the Microsoft office button or File tab. 

➢ The New dialog box appears. 

➢ Select Blank document. A New document appears in the word window. 

➢ After completing the Text select Save As – Word document. 

➢ Select the location where you want to save the document using the drop-menu. 

➢ Enter a name for the document as “equations”. 

➢ Click the save button. 

9) Create the file in MS word that convert existing highlight text to table as shown below and save 

it as file name ‘text_to_tab’. Describe all steps involved in it. 

Select the text you want to convert. Select the Insert tab. 

Click on Table command. A dialog box 
appears. 

Click on Convert Text to Table, a new dialog 
box appears.  

here set numbers of columns.  Click on OK Finally Selected text convert 
table. 

10) Create a file in the MS-Word to insert a table in the document. Describe all steps involved in it. 

    To insert a table in the document: 

❖ Place your insertion point in the document where you want to insert table. 

❖ Select the insert tab. 

❖ Click the Table command. 

❖ Drag your mouse over the diagram squares to select the number of columns and rows in the 

table. 

11) Create a following Worksheet in MS-Excel and save it with name ‘book 1’. 

     

ROLL NO NAME MARKS

1 n1 60

2 n2 70

3 n3 80

4 n4 90

5 n5 40

6 n6 50

7 n7 77   

12) Calculate the following things of a range (C2:C11) of data in the worksheet created in Question 

no 11. 

➢ The sum of the marks using AutoSum in a range of cells (C2:C11) = 654 

➢ Average of the marks in a range of cells (C2:C11) = 65.4 

➢ Highest marks in a range of cells (C2:C11) = 90 

➢ Minimum marks in a range of cells (C2:C11) = 40 



13 a) Describe the various steps involved in the following 

 To modify column width of a worksheet: 

❖ Position the cursor over the column line in the column heading. 

❖ A double arrow will appear. 

❖ Left click the mouse,  then drag the cursor to right to increase the column width or to left to 

decrease the column width. 

❖ Release the mouse button. 

To modify the row height of a worksheet: 

❖ Position the cursor over the row line you want to modify and a double arrow will appear. 

❖ Left click the mouse, then drag the cursor to upward to decrease the row height or 

downward  to increase the row height. 

❖ Release the mouse button. 

 To delete rows and columns of a worksheet: 

❖ Select the row or column you want to delete. 

❖ Click the Delete command in the cells group on the Home tab. 

❖ Selected row or column deleted. 

13 b) Describe the following terms in the worksheet 

 Absolute reference: 

       An absolute reference is designated in the formula by the addition of a dollar sign ($). It can 

precede the column reference or the row reference, or both 

       Examples: $A$2: The column and the row do not change when copied. 

                          A$2: The row does not change when copied. 

                          $A2: The column does not change when copied. 

 Relative reference: 

    Cell references in formula automatically adjust to new locations when the formula is pasted into 

different cells. This is called relative reference. Example: =F3 *$C$2 

 Cell address: 

    A cell address is an alphanumeric value used to identify a specific cell in a spread sheet. Each cell 

reference contains one or more letters followed by a number. The letter or letters identify the 

column and the numbers identify the rows.  

14 a) What tools are available to customize our PowerPoint Presentation? 

❖ Visme  

❖ Haiku Deck 



❖ Pitcherific 

❖ Canva  

    14 b) Write the steps for the following action for creation of power point presentation. 

      Open a blank presentation: 

❖ Click the Microsoft Office button and then click new. 

❖ Click Blank or and create option that we want.  

❖ Click the Blank presentation and then click create. 

❖ A Blank slides open in your existing slide. 

      Save the Presentation as Lab1.pptx: 

❖ Locate and select the Save command on the Quick Access Toolbar. 

❖ If you are saving the file for the first time, the save as panel will appear in the backstage 

view. 

❖ You will then need to choose where to save the file and give it to a file name. 

❖ Type the file name as “Lab1.pptx”and then click save option to save the file. 

      Add a title to the first slide: 

❖ Please click the Title on the slide. 

❖ Type the text as “ the name of your college”. 

❖ If necessary press Return or Enter to move to new line. 

       Type your name in subtitle section:  

❖ Please click the Subtitle on the slide. 

❖ Type the text as” your first name and last name” Example: Soundarya kamalanathan     

❖ If necessary press Return or Enter to move to new line. 

      Add a new slide which has a Title and Content: 

❖ On the Home tab, click the New slide Button in the slides group. Powerpoint adds a bland 

slide to the presentation.  (OR) 

❖ Press Ctrl + M (OR) 

❖ Right click in the slides or outline tab on the left and then choose new slide.   

 

15) Write steps for creation of a set of power point slides that demonstrates your skills to use the 

tools of PowerPoint. 

❖ Click the “Blank presentation”  available in the new option. 

❖ Type the text in the Title and subtitle section. 

❖ Press New slide or Ctrl+M or Right click the slide to open a new slides in the presentation. 

❖ Insert templates by clicking the open from the Office tab. 

❖ Insert bullets, underline etc... to the text which in available in the Home tab. 

❖ Set up the slide effect by slide transistion effect. 



❖ Insert clip art in the powerpoint presentation. 

❖ Save the power point presentation on the Microsoft office button. 

❖ Run the presentation. 

 

                                       PART – 2 

1) What is the difference between Machine Language and High Level Language? 

            

                     Machine language                              High-level language 

It consisting of binary instructions which a 
computer can respond directly. 

It is a programming language with strong 
abstraction from the details of computer. 

It is difficult to learn and use. It is easy to learn and use. 

This programming language is machine 
dependent. 

It’s is not machine dependent. 

Program execution is fast.  Program execution is slow. 
 

It can be converted into a machine code 
without a compiler or interpreter. 

It requires compiler or interpreter to convert 
to a machine code. 

 

2) Discuss about different data types of C programming Language. 

      Each data type in C has an associated data type. Each data type requires different amounts of 

memory and has specific operations which can be performed over it. Some commonly used data 

types are as follows, 

Char: It stores a single character and requires a single byte of memory. 

int : It is used to store an integer. 

float: It is used to store decimal numbers. 

double: It is used to store decimal numbers with highest range of floating point values. 

 3) Find the output of the following expressions 

      a) X=20/5*2+30-5  
             = 4*2+30-5 
             = 8+30-5 
             =38-5 
           x=33. 
       
      b) Y=30 – (40/10+6) +10  
             = 30 – (4+6) + 10 
             = 30 – 10 + 10 



             = 30 – 20 
           Y= 10. 
       
      c) Z= 40*2/10-2+10  
             = 40* 0.2 – 2 + 10 
             = 8 – 2 +10 
             = 18 – 2 
           Z= 16. 
 
 4) Describe the syntax of the following statements 
 

a) if – else statement: 
if( expression) 
{ 
 true  Block of statements; 
 } 
else 
{ 
 else Block of statements; 
} 
 

b) for loop: 
for ( expression1;expression2;expression3) 
{ 
 Block of statements; 
} 
 

c) while loop: 
while (condition) 
{ 
 Block of statements; 
} 
 

d) do-while loop: 
do 
{ 
 Single statement; 
or 
 Block of statements; 
} 

5)  Find the output of the following program segments: 
 
a) IMS Ghaziabad 

 
b) IMS Ghaziabad 

 

c) Largest number is 100. 

 

 



 

 

 

 

                  

       

 

                               

 

   

  

  


