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FUNDAMENTAL OF IT & PROGRAMMING 
 
 
 
 
 
 
 
 
 
 
 
  



Q1: What are the four fundamental parts of computer? Explain it with the help of diagram. 

Ans. Keyboard:-Keyboard is a human interface device which is represented as a 

layout of buttons. Each button or key can be used to either input a character to a 

computer, or to call upon a particular function of the

 computer 

 

Mouse: - A mouse is a small handheld input 

device that controls a computer screen's cursor 

or pointer in combination with the way it is 

moved 



on a flat surface. 

 

 
Monitor: - A computer monitor 

is an output device that displays 

information in user 

understandable form 

 
 
 

CPU: - It is the brain of the computer. Computer 

cannot process without it. 

 
 
 
 
 
 
 
 
 

 
Q2: Discuss about the classification of computers based on size and 

capacity. 



Ans. Computers are classified on different parameters, such as, storage capacity, 

processing speed and component (CPU) used in computers. Depending upon the 

components used and features of different computers, they are classified into 

four groups, Microcomputers, Minicomputers, Mainframe 

computers and Supercomputers. 
 

 

 
 

Q3: What is the meaning of computer generation? How many Computer 

Generations are defined ? What technologies were/are used? 

Ans. First Generation: Vacuum Tubes (1940-1956): 

• The first computer systems used vacuum tubes for circuitry and magnetic 

drums for memory 

• These computers were very expensive to operate 

• Computers of this generation consumed a lot of electricity Certificate in 

Computer Applications (CCA) 
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of malfunctions Example: 

The UNIVAC (Universal Automatic Computer) The UNIVAC was the first 

commercial computer delivered to a business client, the U.S. Censu• First 

generation computers relied on machine language, the lowest-level programming 

language understood by computers to perform operations 

• They could only solve one problem at a time. It would take operators days 

or even weeks to set-up a new problem 

• Input was based on punched cards and paper tape, and output was displayed 

on printouts 

• First computers generated a lot of heat ,which was often the s Bureau in 1951 

ENIAC (Electronic Numerical Integrator and Computer) 

computers 

Certificate in Computer Applications (CCA) 
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Generation: Transistors (1956-1963): 



• Transistors replaced vacuum tubes in the second generation of computers. 

• The transistor was far superior to the vacuum tube, allowing computers to 

become smaller, faster, cheaper, more energy- efficient and more reliable than 

their first-generation predecessors 

• Second-generation computers still relied on punched cards for input and 

printouts for output 

• Second-generation computers moved from binary machine language to 

symbolic, or assembly language 
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Third Generation: Integrated Circuits (1964-

1971) 

• The development of the integrated circuit was the hallmark of the third 

generation of computers 

• Transistors were replaced by Integrated circuits, which 

drastically increased the speed and efficiency of computers. 

• Instead of punched cards and printouts, users interacted with third generation 

computers through keyboards and monitors 



• Computers for the first time became accessible to a mass audience because 

they were smaller and cheaper than their predecessors. 
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Fourth Generation: Microprocessors (1971-

Present): 

• The microprocessor brought the fourth generation of computers as thousands 

of integrated circuits were built onto a single silicon chip 

• What in the first generation filled an entire room could now fit in the palm of 

the hand 

• In 1981, IBM introduced its first computer for the home user 

• in 1984, Apple introduced the Macintosh. 

• Microprocessors also moved out to the desktop computers 

• Fourth generation computers also covered the development of Graphical User 

Interface (GUIs), mouse and hand held devices 

Certificate in Computer Applications (CCA) 
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• Quantum computation and nanotechnology will radically change the face of 

computers in years to come 

• The goal of fifth-generation computing is to develop devices that respond to 

natural language input and are capable of learning and self-organization. 

 

 
Q4: Differentiate between Volatile & Non- Volatile memories. 

Ans. Volatile memory:- Volatile memory is a computer storage that only maintains 

its data while the device is powered. 

Non volatile:- Non volatile memory is a type of computer memory that has the 

capability to hold saved data even if the power is turned off. 

Q5: Distinguish among system software, application software and open source 

software on the basis of their features. 

Ans. Software: - Software is a set of instructions used to operate computers and 

execute specific tasks. 

The software is used extensively for different purpose in several domains. It can be 

categorized into different types. Software has mainly divided into two Categories: 

1) System Software 

2) Application Software 



1) System Software 

It is a type of software that is designed to run a computer's hardware and 

application programs. 

• Software like operating systems, compilers , editors and drivers etc., come 

under this category. 

• A computer cannot function without the presence of system software. 

If we think of the computer system as a layered model, the system software is the 

interface between the hardware and user applications. 

2) Application Software 

It is software created for a specific purpose, used by end users. It can be called an 

application or simply an app. 

• Examples: Word processor, accounting application, a web browser, an email 

client, media player etc. 

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with 

file name 

“yourself”. Describe all steps involved in it. Ans. To create a 

new blank document: 

Click the Microsoft Office button. 



Select New. The New Document dialog box appears. 
 
 

Select Blank document under the Blank and recent section. It will be 

highlighted 

by default. 
 

Click Create. A new blank document appears in the Word window 

Click the Microsoft Office button. 
 

Select Save As Word Document. The Save As dialog box appears. 

Select the location where you want to save the document using the drop-down 

menu. 
 

Enter a name for the document. 
 
 

Select Save from the menu. 
 

Click the Save button. 

To use the Save command: 
 

Click the Microsoft Office button. 



Q6 b) Write steps regarding followings 

To change the font style To 

change the font size To change 

the font color 

To highlight (in yellow) the line that reads “need to get IMS’s address”. 

Ans. To change the font style To 

format font size: 

Select the text you want to modify. 
 
 

Left-click the drop-down arrow next to the font size box on the Home tab. 

The 

font size drop-down menu appears. 
 

Move your cursor over the various font sizes. A live preview of the font size 

will 

appear in the document. 
 

Left-click the font size you want to use. The font size will change in the 

document. 

To format font style: 
 

Select the text you want to modify. 



Left-click the drop-down arrow next to the font style box on the Home tab. 

The 

font style drop-down menu appears. 
 

Move your cursor over the various font styles. A live preview of the font will 

appear in the document. 
 

Left-click the font style you want to use. The font style will change in the 

document. 

To format font color: 
 

Select the text you want to modify. 
 
 

Left-click the drop-down arrow next to the font color box on the Home tab. The 

font color menu appears. 
 

Move your cursor over the various font colors. A live preview of the color will 

appear in the document. 



Q7. Create a file in MS-Word for the following document and save it with file 

name ‘ms word’. Describe 

all steps involved in it. Ans 

Ms word 

Ms word is widely used commercial word processor developed by Microsoft 

Ms word is application software, which it capable of 

. Creating 

. editing 

. saving and 

. printing any type of documents. 

Q8. Create a file in MS-word for the following document and save it with file 

name ‘equations’. Describe 

all steps involved in it. 

Ans. Equations X2 + 

Y5 = 30 

Z3 + Q4 = 50 

A2 + B8 = X2 + Y8 



 
 
 
 

 

Q9. Create a file in MS-word that convert existing highlight text to table as 

shown below and save it as 
 

Select the text you want to 

convert 

Select the Insert tab. 

Click on Table command. A 
dialog box appears 

Click on Convert Text to Table, a new 
dialog box appears 

here set number of columns. Click on OK Finally Selected 

text convert in a table 

 

Q10. Create a file in MS-Word to insert a table in the 

document. Describe all steps involved in it. 

Ans Place your insertion point in the document where you want the table to 

appear. 
 

Select the Insert tab. 
 
 

Click the Table command. 
 
 

Drag your mouse over the diagram squares to select the number of columns 

and 

rows in the table. 



Left-click your mouse, and the table appears in the document. 
 
 

Enter text into the table. 
 

to insert a blank spreadsheet in Microsoft excel create a file 

in ms excel 

click here to office button 

click to save button under office button 

Q11. Create a following worksheet in MS-excel and save it 

with name 

‘book1’. 

 
 
 
 
 
 
 
 
 
 

 
Q12. Calculate the following things of a range (C2:C11) of data in the worksheet 

created in question no 

10. 



the sum of the marks using AutoSum in a range of cells (C2:C11) 
 

Ans. 654 

average of the marks in a range of cells (C2:C11) 
 

highest marks in a range of cells (C2:C11) 



 
 

Ans. 90 
 
 
 
 
 
 
 

minimum marks in a range of cells (C2:C11) 



 
 

Ans. 40 
 

 
Q13 a) Describe various steps involved in the following To modify 

column width of a worksheet 



Ans. Set a column to a specific width 

1. Select the column or columns that you want to change. 

2. On the Home tab, in the Cells group, click Format. 

3. Under Cell Size, click Column Width. 

4. In the Column width box, type the value that you want. 

5. Click OK. 

To modify the row height of a worksheet 

Ans. Select the row or rows that you want to change. On the Home tab, in the 

Cells group, click Format. Under Cell Size, click Row Height. In the Row height 

box, type the value that you want. 

To delete rows and columns of a worksheet 

Ans. To do this, select the row or column and then press the Delete key. 

1. Right-click in a table cell, row, or column you want to delete. 

2. On the menu, click Delete Cells. 

3. To delete one cell, choose Shift cells left or Shift cells up. To delete the row, 
click Delete entire row. To delete the column, click Delete entire column. 

Q13 b) Describe following terms in the worksheet 
 

 
 

Absolute reference and relative reference in formula 

Ans. There are two types of cell references: relative and absolute. Relative and 
absolute references behave differently when copied and filled to other cells. 
Relative references change when a formula is copied to another cell. Absolute 
references, on the other hand, remain constant no matter where they are copied. 

Cell address 



Ans. A reference is a cell's address. It identifies a cell or range of cells by 
referring to the column letter and row number of the cell(s). For example, A1 
refers to the cell at the intersection of column A and row 

1. The reference tells Formula One for Java to use the contents of the 
referenced cell(s) in the formula. 

Q14. a) What tools are available to customize our PowerPoint presentation? 

In this guide, we will discuss how you can make the most of some of the 
tools like: 

 Templates and themes. 

 Slide layouts. 

 Fonts. 

 Color themes. 

 Many more. 

Q14 b) Write the steps for the following action for creation of power point 
presentation 

Open a Blank presentation 

Save the presentation as Lab1.pptx 
 

Add a Title to the first slide: the name of your college Type your 

first name and last name in the Subtitle section Add a New Slide 

which has a Title and Content 

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to 
use 

the tools of PowerPoint. It should include the following things 

 Title slide &bullet list 

 Inserting Excel Sheet 

 Clip art and Text 

 Slide show effects 



Q16. What is the difference between Machine Language and High Level 
Language? 

Ans. To conclude, high-level languages are more friendly for the programmer 

because they use English-like statements in the codes, whereas low-level 
languages are more machine-friendly because they use binary language codes to 
write the computer instructions. 

Q17. Discuss about different data types of C programming Language. 

Ans. Types of C programming language 

There are four basic data types in C programming, 
namely Char, Int, Float, and Double. 

 
Q18. Find the output of the following expressions a) 
X=20/5*2+30-5 b) Y=30 – (40/10+6) +10 

c) Z= 40*2/10-2+10 

Ans. A - has symmetry, no lines, order 3. B - has symmetry, 1 

line, no order. C - has symmetry, 1 line, no order. 
 


	Q2: Discuss about the classification of computers based on size and capacity.
	Q3: What is the meaning of computer generation? How many Computer Generations are defined ? What technologies were/are used?
	Q4: Differentiate between Volatile & Non- Volatile memories.
	Q5: Distinguish among system software, application software and open source software on the basis of their features.
	Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with file name
	Q6 b) Write steps regarding followings
	To highlight (in yellow) the line that reads “need to get IMS’s address”.
	Q7. Create a file in MS-Word for the following document and save it with file name ‘ms word’. Describe
	Q8. Create a file in MS-word for the following document and save it with file name ‘equations’. Describe
	Q9. Create a file in MS-word that convert existing highlight text to table as shown below and save it as
	Q11. Create a following worksheet in MS-excel and save it
	Q12. Calculate the following things of a range (C2:C11) of data in the worksheet created in question no
	the sum of the marks using AutoSum in a range of cells (C2:C11)
	average of the marks in a range of cells (C2:C11)
	minimum marks in a range of cells (C2:C11)
	Q13 a) Describe various steps involved in the following To modify column width of a worksheet
	To modify the row height of a worksheet
	To delete rows and columns of a worksheet
	Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to use
	 Title slide &bullet list
	 Clip art and Text
	Q16. What is the difference between Machine Language and High Level Language?
	Q17. Discuss about different data types of C programming Language.

