
CCA-101: Fundamentals of IT & Programming 

Assignment -1 

 

Q1: What are the four fundamental parts of computer? Explain it with the help of diagram. 

ANS. Computer Block Diagram 
Mainly computer system consists of three parts, that are central processing unit 
(CPU), Input Devices, and Output Devices. The Central Processing Unit (CPU) is divided 
into two parts again: arithmetic logic unit (ALU) and the control unit (CU). The set of 
instruction is in the form of raw data. 
A large amount of data is stored in the computer memory with the help of primary and 
secondary storage devices. The CPU is like the heart/brain of the computer. The user does 
not get the desired output, without the necessary option taken by the CPU.  The Central 
processing unit (CPU) is responsible for the processing of all the instructions which are 
given by the user to the computer system. 

 

                                       Fig: Block Diagram of the computer. 
The data is entered through input devices such as the keyboard, mouse, etc. This set of 
instruction is processed by the CPU after getting the input by the user, and then the 
computer system produces the output. The computer can show the output with the help of 
output devices to the user, such as  monitor, printer, etc. 

https://www.tutorialandexample.com/input-devices-of-computer/
https://www.tutorialandexample.com/output-devices-of-computer/


• CPU (Central Processing Unit) 

• Storage Unit 

• ALU(Arithmetic Logic Unit) 

• Control Unit 

Central Processing Unit (CPU) 
The computer system is nothing without the Central processing Unit so, it is also known as 
the brain or heat of computer. The CPU is an electronic hardware device which can perform 
different types of operations such as arithmetic and logical operation. 

 

The CPU contains two parts: the arithmetic logic unit and control unit. We have discussed 
briefly the arithmetic unit, logical unit, and control unit which are given below: 
Control Unit 
The control unit (CU) controls all the activities or operations which are performed inside the 
computer system. It receives instructions or information directly from the main memory of 
the computer. 
When the control unit receives an instruction set or information, it converts the instruction 
set to control signals then; these signals are sent to the central processor for further 
processing. The control unit understands which operation to execute, accurately, and in 
which order. 

Arithmetic and Logical Unit 
The arithmetic and logical unit is the combinational digital electronic circuit that can perform 
arithmetic operations on integer binary numbers.It presents the arithmetic and logical 
operation. The outputs of ALU will change asynchronously in response to the input. The 
basic arithmetic and bitwise logic functions are supported by ALU. 
Storage Unit 
The information or set of guidelines are stored in the storage unit of the computer system. 
The storage unit provides the space to store the data or instruction of processed data. The 

https://en.wikipedia.org/wiki/Central_processing_unit


information or data is saved or hold in computer memory or storage device. The data 
storage is the core function and fundamental of the computer components.   

Components of Computer System 
The hardware and software exist on the computer.  The information which is stored through 
the device is known as computer software. The hardware components of the computer 
system are related to electronic and mechanical parts, and the software component is 
related to data and computer programs. Many elements are connected to the main circuit 
board of the computer system called a “motherboard.” 

 

• Processor. 

• Main Memory. 

• Secondary Memory. 

• Input Devices. 

• Output Devices. 
 

Q2: Discuss about the classification of computers based on size and capacity. 

Ans.   

Introduction 



Classification of computers are based on their architecture, speed of executing commands or 

instructions, peripheral used and also their uses. Microcomputers are usually used in home and 

offices and only a single user can perform the task using a microcomputer. Its storage and data 

handling capacity are limited as per the requirement for home and office work. The another type of 

computer is called minicomputer which has usually larger storage and can handle multiuser at a 

time. This chapter includes the classification of computers. 

  

Computer's Classification 

Computers are classified on different parameters, such as, storage capacity, processing speed and 

component (CPU) used in computers. Depending upon the components used and features of 

different computers, they are classified into four groups, Microcomputers, Minicomputers, Mainframe 

computers and Supercomputers. 

  

Micro Computers 

Micro Computer is a computer whose CPU (Central Processing Unit) is a microprocessor. All the 

components of a microprocessor are on a single integrated circuit chip. Micro computer can be 

categorized as the desktop, programmable and workstation. The microprocessor based computers 

are called third generation computers. They are the backbone of the modern computer era. The first 

and second generation computers are based on vacuum tubes and bipolar junction transistors. 

  

 

  

Desktop Computers 



Desktop computer is a type of microcomputer. A desktop computer has a keyboard for input data, a 

LCD or CRT monitor to display information and Central processing unit tower contains storage, 

memory, different types of drives, such as, CD drive, hard drive, etc. A desktop computer is mainly 

used at home and office applications. 

  

Programmable Computers (PDA) 

Personal digital assistance is a type of hand held programmable digital computer. It is used as 

notepads, address books and can connect to world web wave to share information. A PDA is 

equipped with mobile phone hence, called smallest computer. 

  

  

Workstation 

A workstation computer has greater memory capability and more extensive mathematical abilities. It 

is connected with other workstation computers or personal computer to exchange data and mostly 

used for scientific applications. It also supports multitasking applications. 

  

Mini Computers 

Minicomputers were introduced in early 1960s. They were faster than micro computers. Basically 

these computers were mainly multi-user systems, where many users work on the systems. Generally 

these types of computers had larger memories and greater storage capacity. They had large 

instruction set and address field. These kinds of computers have efficient storage for handling of 

text, in comparison to lower bit machines. Due to more efficient processor, speed and memory size, 

minicomputer was used in variety of applications and could support business applications along with 

the scientific applications. Minicomputer was a multi-user system which means more than one user 

could use this system simultaneously. 

  

Comparison of Micro and Mini computers 

  

Features Microcomputer Minicomputer 

Primary memory  Shall memory Larger memory 



Word length  Small word length  Larger word length 

Cost low Low High 

Processor Low High 

  

Mainframe Computers 

Mainframe computers are large and expensive machines. The word length of mainframe computers 

may be 48, 60 or 64 bits, memory capacity being in some megabytes and storage capacity in some 

terabytes. Generally they handle huge volumes of information and data. In terms of speed, they are 

having significant processing capacity. They are used in research organizations, large industries, 

airlines reservation where a large database has to be maintained. 

  

 

  

Super Computers 

Super Computers are the fastest computer in current era. The processing capabilities of super 

computer lies in the range of GIPS2, word length 64-128 or may be in 256 or so. The memory 

capacity of super computer is in some gigabytes or in terabytes. The storage capacity of this type of 

computer is in exabytes. 

  



 

  

The parallel processing of a super computer makes it very fast because it contains number of CPU 

that operates parallel. They are used at some research centers and government agencies involving 

sophisticated scientific and engineering tasks. 

  

Super computers are used for the followings: 

  

❖  Weapons research and development 

❖  Nuclear and plasma physics 

❖  Rocket research and development 

❖  Atomic research 

❖  Aerodynamics 

  

 

Q3: What is the meaning of computer generation? How many Computer Generations are 

defined? What technologies were/are used? 



Ans. Generation in computer terminology is a change in technology a computer is/was 
being used. Initially, the generation term was used to distinguish between varying 
hardware technologies. Nowadays, generation includes both hardware and software, 
which together make up an entire computer system. 

There are five computer generations known till date. Each generation has been 
discussed in detail along with their time period and characteristics. In the following 
table, approximate dates against each generation has been mentioned, which are 
normally accepted. 

Following are the main five generations of computers. 

S.No Generation & Description 

1 
First Generation 

The period of first generation: 1946-1959. Vacuum tube based. 

2 
Second Generation 

The period of second generation: 1959-1965. Transistor based. 

3 
Third Generation 

The period of third generation: 1965-1971. Integrated Circuit based. 

4 
Fourth Generation 

The period of fourth generation: 1971-1980. VLSI microprocessor based. 

5 
Fifth Generation 

The period of fifth generation: 1980-onwards. ULSI microprocessor based 

 

Following are the main five generations of computers. 

 

S.No Generation & Description 

1 First Generation 

The period of first generation: 1946-1959. Vacuum tube based. 

 

https://www.tutorialspoint.com/computer_fundamentals/computer_first_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_second_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_third_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_fourth_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_fifth_generation.htm


2 Second Generation 

The period of second generation: 1959-1965. Transistor based. 

 

3 Third Generation 

The period of third generation: 1965-1971. Integrated Circuit based. 

 

4 Fourth Generation 

The period of fourth generation: 1971-1980. VLSI microprocessor based. 

 

5 Fifth Generation 

The period of fifth generation: 1980-onwards. ULSI microprocessor based. 

In modern life, we are surrounded by technology. It's integral to everything we do, big or small. We 
can find examples of technology in our homes and personal spaces, in industry, in business, and in 
the medical profession. Most people know technology when they see it, but what exactly is 
technology? 

Technology is the way we apply scientific knowledge for practical purposes. It includes machines 
(like computers) but also techniques and processes (like the way we produce computer chips). It 
might seem like all technology is only electronic, but that's just most modern technology. In fact, a 
hammer and the wheel are two examples of early human technology. 

Q4: Differentiate between Volatile & Non- Volatile memories. 

ANS. Volatile and Non-Volatile Memory are both types of computer memory. Volatile 
Memory is used to store computer programs and data that CPU needs in real time and 
is erased once computer is switched off. RAM and Cache memory are volatile memory. 
Where as Non-volatile memory is static and remains in the computer even if computer is 
switched off. ROM and HDD are non-volatile memory. 

Following are the important differences between Volatile and Non-Volatile Memory. 

Sr. 
No. 

Key Volatile Memory Non-Volatile Memory 

1 
Data 
Retention 

Data is present till power 
supply is present. 

Data remains even after power 
supply is not present. 



Sr. 
No. 

Key Volatile Memory Non-Volatile Memory 

2 
Persistence Volatile memory data is not 

permanent. 
Non-volatile memory data is 
permanent. 

3 
Speed Volatile memory is faster than 

non-volatile memory. 
Non-volatile memory access is 
slower. 

4 
Example RAM is an example of Volatile 

Memory. 
ROM is an example of Non-Volatile 
Memory. 

5 
Data 
Transfer 

Data Transfer is easy in 
Volatile Memory. 

Data Transfer is difficult in Non-
Volatile Memory. 

6 
CPU 
Access 

CPU can access data stored 
on Volatile memory. 

Data to be copied from Non-Volatile 
memory to Volatile memory so that 
CPU can access its data. 

7 
Storage Volatile memory less storage 

capacity. 
Non-Volatile memory like HDD has 
very high storage capacity. 

8 
Impact Volatile memory such as 

RAM is high impact on 
system's performance. 

Non-volatile memory has no impact 
on system's performance. 

9 
Cost Volatile memory is costly per 

unit size. 
Non-volatile memory is cheap per 
unit size. 

Q5: Distinguish among system software, application software and open source software on the 

basis of their features. 

ANS. System Software is a set of programs that control and manage the operations of 
computer hardware. It also helps application programs to execute correctly. 



System Software are designed to control the operation and extend the processing 
functionalities of a computer system. System software makes the operation of a 
computer more fast, effective, and secure. Example: Operating system, programming 
language, Communication software, etc. 

In this tutorial, you will learnApplication Software acts as a mediator between the 
end-user and System Software. It is also known as an application package. 
This type of software is written using a high-level language like C, Java, VB. 
Net, etc. It is a user-specific and is designed to meet the requirements of the 
user. 

You can also install multiple Application Software on a single System 
Software. You can store this kind of software on CDs, DVDs, flash derive, or 
keychain storage devices. Example: Word-processing, Spreadsheet, 
Database, etc. 

Features of System Software 

An important feature of System Software are: 

• System Software is closer to the system 
• Generally written in a low-level language 
• The system software is difficult to design and understand 
• Fast in speed 
• Less interactive 
• Smaller in size 
• Hard to manipulate 

• S.NO SYSTEM SOFTWARE APPLICATION SOFTWARE 

1. 

System Software maintain the 

system resources and give the 

path for application software to 

run. 

Application software is built 

for specific tasks. 

2. 
Low level languages are used to While high level languages 



write the system software. are used to write the 

application software. 

3. Its a general purpose software. 

While its a specific purpose 

software. 

4. 

Without system software, system 

can’t run. 

While without application 

software system always runs. 

5. 

System software runs when 

system is turned on and stop 

when system is turned off. 

While application software 

runs as per the user’s 

request. 

6. 

Example of system software are 

operating system, etc. 

Example of application 

software are Photoshop, VLC 

player etc. 

7. 

System Software programming is 

complex than application 

software. 

Application software 

programming is simpler as 

comparison to system 

software. 

Attention reader! Don’t stop learning now. Get hold of all the important CS Theory 
concepts for SDE interviews with the CS Theory Course at a student-friendly price and 
become industry ready. 

 

 

https://practice.geeksforgeeks.org/courses/SDE-theory?vC=1


Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with file 
name 

“yourself”. Describe all steps involved in it. 

Ans,(A)    If you want the formatting for all paragraphs, including the last one, stored 

with the text in the AutoText entry, select the last paragraph mark. The paragraph mark 

at the end of each paragraph stores the formatting for that paragraph. If you applied any 

character formatting, like bold or italic, it’s automatically stored in the AutoText entry. 

If you don’t see the paragraph marks in your document, click the Home tab. In 

the Paragraph section, click the paragraph symbol. Now you can see the last 

paragraph mark and select it. 

Create a New AutoText Entry 

To create a new AutoText entry, select the text you want to add to your collection of 

AutoText entries. Or, if you don’t have the text available, type the text into a document 

and then select it. 

On the Insert tab, click Quick Parts in the Text section. Then, move your mouse over 

AutoText and select Save Selection to AutoText Gallery from the submenu. 

Make sure AutoText is selected in the Gallery drop-down list. It should be by default. 

General is selected by default in the Category drop-down list. Initially, it’s the only 

choice and we’re going to select the General category for our example. But you can 

create a custom category by selecting Create New Category from the Category drop-

down list. Enter a name for your custom category on the Create New Category dialog 

box and click OK. The new category is added and selected automatically in 

the Category drop-down list. 

You can enter a Description for the AutoText entry if it helps to clarify what the entry is 

for. If the entry is self-explanatory, you don’t have to enter a description. 

AutoText entries are saved in templates, not in documents. That way, they’re available 

in any document based on the template they’re saved in. The Normal template is the 

default selection in the Save in the drop-down list. You can save AutoText entries in 

custom templates, but we’re going to accept the default to save our new entry in the 

“Normal.dotm” template. 



Note: To save an AutoText entry in a custom template, that template must be open to 

be available in the Save in drop-down list. 

Finally, there are a few Options to choose from: 

• To insert the AutoText entry on its own page in a document, select Insert 

content in its own page. This will set the text from the AutoText entry off from 

the rest of your document with page breaks. 

• To insert the AutoText entry into its own paragraph, even if your cursor is in the 

middle of a paragraph, select Insert content in its own paragraph. 

• For all other content, select Insert content only. 

Q6 steps regarding followings b) Write 

 To change the font style 

 To change the font size 

 To change the font color 

 To highlight (in yellow) the line that reads “need to get IMS’s address”. 

Ans. Changing the Font 

The most common way to format text is to change the font. The font defines the uniform style 

and appearance of letters such as Arial, Arial Black, Courier, Old English, or Stencil. To change 

the font, follow these steps: 

1. Click the Home tab and then select the text you want to change. 
2. Click the Font list box. A list of available fonts on your computer appears. 
3. Move the mouse pointer over each font. Word temporarily changes your selected text so you 

can see how the currently highlighted font will look. 
4. Click the font you want to use. Word changes your text to appear in your chosen font. 

As a general rule, try not to use more than three fonts in a document. If you use too many fonts, 

the overall appearance can be annoying and distracting. 

Not all computers have the same lists of fonts, so if you plan on sharing documents with others, 

stick with common fonts that everybody's computer can display. 

Changing the Font Size 

The font changes the appearance of text, but the font size defines how big 

(or small) the text may look. To change the font size, you have two choices: 

• Select a numeric size from the Font Size list box. 



• Choose the Grow Font/Shrink Font commands. 

You can use both methods to change the font size of text. For example, you 
may use the Font Size list box to choose an approximate size for your text, 

and then use the Grow Font/Shrink Font commands to fine-tune the font 

size. To change the font size, follow these steps: 

1. Click the Home tab and then select the text you want to change. 
2. Choose one of the following: 

o Click the Font Size list box and then click a number, such as 12 or 16. 
o Click the Grow Font or Shrink Font icon. 

Changing the Text Style 
The text style defines the appearance of text in one or more of the following ways: 

Bold: 

Press Ctrl+B. 

 

Italic: 

Press Ctrl+I. 

 

Underline: 

Press Ctrl+U. 

 

Strikethrough: 

This formatting draws a line through text. 

 

Subscript: 

Use this to create text that falls below the text line, as in the 2 in H2O. 

 

Superscript: 

Use this to create text that sits higher than the top of the text line, as in the 2 in H = NO2. 

To change the style of text, follow these steps: 

1. Click the Home tab and then select the text you want to change. 
2. Click a Style icon, such as Bold or Underline. 
3. Repeat Step 2 for each additional style you want to apply to your text (such as italic and 

underlining). 



If you select any style change without selecting any text, 

Word applies your style changes to any new text you type 

from the cursor's current position. 

Changing the Font 

The most common way to format text is to change the font. The font defines 

the uniform style and appearance of letters such as Arial, Arial Black, 

Courier, Old English, or Stencil. To change the font, follow these steps: 

1. Click the Home tab and then select the text you want to change. 
2. Click the Font list box. A list of available fonts on your computer appears. 

3. Move the mouse pointer over each font. Word temporarily changes your 
selected text so you can see how the currently highlighted font will look. 

4. Click the font you want to use. Word changes your text to appear in your 
chosen font. 

As a general rule, try not to use more than three fonts in a document. If you 
use too many fonts, the overall appearance can be annoying and distracting. 

Not all computers have the same lists of fonts, so if you plan on sharing 
documents with others, stick with common fonts that everybody's computer 

can display. 

Changing the Font Size 

The font changes the appearance of text, but the font size defines how big 

(or small) the text may look. To change the font size, you have two choices: 

• Select a numeric size from the Font Size list box. 
• Choose the Grow Font/Shrink Font commands. 

You can use both methods to change the font size of text. For example, you 
may use the Font Size list box to choose an approximate size for your text, 

and then use the Grow Font/Shrink Font commands to fine-tune the font 

size. To change the font size, follow these steps: 

1. Click the Home tab and then select the text you want to change. 
2. Choose one of the following: 

o Click the Font Size list box and then click a number, such as 12 or 16. 
o Click the Grow Font or Shrink Font icon. 

Changing the Font Size 



The font changes the appearance of text, but the font size defines how big (or small) the 
text may look. To change the font size, you have two choices: 

 

Select a numeric size from the Font Size list box. 

Choose the Grow Font/Shrink Font commands. 

You can use both methods to change the font size of text. For example, you may use 
the Font Size list box to choose an approximate size for your text, and then use the 
Grow Font/Shrink Font commands to fine-tune the font size. To change the font size, 
follow these steps: 

 

Click the Home tab and then select the text you want to change. 

Choose one of the following: 

Click the Font Size list box and then click a number, such as 12 or 16. 

Click the Grow Font or Shrink Font icon. 

Changing the Text Style 
The text style defines the appearance of text in one or more of the following ways: 

Bold: 

Press Ctrl+B. 

 

Italic: 

Press Ctrl+I. 

 

Underline: 

Press Ctrl+U. 

 

Strikethrough: 

This formatting draws a line through text. 

 

Subscript: 

Use this to create text that falls below the text line, as in the 2 in H2O. 

 

Superscript: 

Use this to create text that sits higher than the top of the text line, as in the 2 in H = NO2. 



To change the style of text, follow these steps: 

1. Click the Home tab and then select the text you want to change. 
2. Click a Style icon, such as Bold or Underline. 
3. Repeat Step 2 for each additional style you want to apply to your text (such as italic and 

underlining). 

If you select any style change without selecting any text, 

Word applies your style changes to any new text you type 

from the cursor's current position. 

Change the default 

text color (font 

color) in Word 

1. Open the template or a document based on the 

template whose default settings you want to change. 

2. Go to Home and select the Font dialog launcher  . 

3. Select the arrow next to Font color, and then choose a 

color. 



 

4. Select Set As Default and then select one of the 

following: 

▪ This document only? 

▪ All document based on the Normal.dotm template? 

 

5. Select OK. 
6. Open the template or a document based on the template whose default settings 

you want to change. 

7. Go to Format > Font > Font. 

You can also press and hold  + D to open the Font dialog box. 

8. Select the arrow next to Font color, and then choose a color. 

 



 

9. Select Default and then select Yes to apply the change to all new documents 

based on the template. 

10. Select OK. 

 

Q7. Create a file in MS-Word for the following document and save it with file name 
‘ms_word’. Describe 



all steps involved in it. 

Create and Save a Document 
 

 

To create and save a document as a .doc file: 
 

(Microsoft Word is being used for this tutorial.) 

  

1.  To open Microsoft Word, click on the Word icon ("W") on the toolbar or desktop. 

If there is no Word icon, click on "START"; follow the menu to "Programs"; follow to Microsoft 

Office (or other Microsoft operating system used), and to "Microsoft Word." (Sometimes the 

menu is set up to go directly from "Programs" to "Microsoft Word.") 

 

2. An open (and blank) Word document will open on the screen. 

 

3. Enter document data. 

 

4. When document is finished, click on "File" on the standard toolbar at the top of screen. 

 

5. Click on "Save As." 

 

A window will open that offers many options. Unless otherwise specified, your document will be 

saved as a . doc file to your "My Documents" file. The "File Name" will be whatever the first 

line (or partial line) of text reads.  

 

You may click on the "Save" box, and your document will be saved as is. Performing this task 

repeatedly will cause your "My documents" file to be highly congested with documents that have 

odd names, each document noted by a "W" icon.  To manage your files and documents capably, 

perform the following tasks: 

 

6.  If you wish to have the file titled with the title that is listed in the "File name" box, omit this 

step. As the file name is already highlighted, tap the delete key on the keyboard. The file name 

will disappear. Type in the desired file name. 

 

Ideally, this name should be a few descriptive words that identify the document clearly. 

 

7. If you have already set up folders (noted by folder-shaped icons in the large textbox below the 

"Save in" box. If you wish to save this document in one of the previously created folders, 

double-click the desired folder. That file name should now appear in the "Save in" text box. 

Click the "Save" button, and your document will automatically be saved in that folder. 

 

8. If you do not wish to place the document in a file created on the "My documents" folder, click 

on the "Save in" box (that currently reads: "My Documents.")  A drop-down menu will suggest 

several other places to save your document. Depending on the status of your document, you may 

store it in one of a number of places. 

 



Suggestions: 

a. If you would like to continue working on this document in the near future, you may save it to 

your desktop, by clicking on "Desktop" on the drop down menu. "Desktop" will appear in the 

"Save in" box. Click "Save" and the document will appear on your desktop screen, with a "W" 

icon. 

 

b. If you wish to temporarily save your document, or wish to work on it on another computer, 

you may save it to your "3 ½ Floppy"; the "Removable Disk," which is the Zip drive; or the drive 

marked with a CD-ROM disk (saving to CD-ROM). (Before saving to a CD-ROM remember: 

most CDs are re-write-able and whatever is saved to a disk will be written over, when material is 

saved to the disk again. 

 

Decide on your location, click it, and click the "Save" box on the screen.  You have now saved 

your document as a .doc file (i.e. "project_document.doc"). 

 

TIP: 

If you re-open a file and edit it, you may save it by just clicking on the "Save" icon (appears as a 

floppy disk near the left side of the standard toolbar). You may also pull down the menu from 

"File" on the Menu bar, and click on "Save." 

 

Most documents may be easily saved by using this technique. Another tutorial will illustrate how 

to save documents in other types. 

•  

 

•  

•  

•  

•  

•  

• Print 

To print a document, your computer needs to be connected to a printer. Being able to print is not 

necessary in order to use Word, but if you want to send a letter in the post or print out a poster, 

you’ll need to have access to a printer. 

You’ll need: 

• A computer with Microsoft Word installed 
• A printer set up and connected to your computer (wireless or connected by cable) 

Follow these step-by-step instructions to print a document from Microsoft Office 365. 
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Step 1: Open an existing Microsoft Word document or start a new document, if you have 

Windows 10 you can use Cortana to search for it. Before you print, type your text in the blank 

document or insert an image.  

Step 2: When you are ready, click on File in the top left-hand corner of your document. Then, 

click on Print.  

 

Alternatively, some older versions of Word may have an Office button instead of a ‘File’ button 

– it’s a round Office icon in the top left-hand corner of the screen, click on this if you have one.  

 

Step 3: For Office 365, click on File then Print in the menu, this will bring up the ‘Print’ 

dialogue box. 



 

Choose how many copies of your document you need and click on the printer you wish to use. 

You will have to have your printer already installed on your computer.  

Step 5: Depending on your printer options, you can choose other printing features such as 

whether you want to print all pages or only certain pages. You can also change the orientation of 

the print from portrait to landscape and tell your computer and printer whether you’re printing on 

a certain size of paper. You’ll also see, on the right, a preview of your printed document will 

look like. 

Step 6: When you’re happy with your settings, click Print. The document will now start printing 

on your printer. 

 

Advanced options  

 



To print in black and white, select Printer Properties in the Print menu, then click on the drop 

down and select Black & White.  

 

If you want to print your document on one side of the page, make sure you select this in the Print 

menu.  

 

Edit a document in Word for the 

web 

Word for the web 

Click Edit Document > Edit in Word for the web to make changes to a document. 

When you open a document from OneDrive, Word for the web displays it in Reading 

view. To make changes to your document, switch to Editing view, where you can add 

and delete content and do other things, such as: 

▪ Add tables and pictures. 



▪ Apply styles. 

▪ Adjust formatting. 

▪ Edit headers and footers. 

You can do these simple tasks in both Reading view and Editing view: 

▪ View and add comments. 

▪ Share a document so you can work together with other people at the same time. 

▪ Download a copy. 

▪ Print. 

Remember, to edit a document in Word for the web, click Edit Document > Edit in 

Word for the web. 

Q9. Create a file in MS-word that convert existing highlight text to 

table as shown below and save it as 

file name ‘text_to_table’. Describe all steps involved in it. 

Ans. Convert text to a table or a 

table to text 

Word for Microsoft 365 Outlook for Microsoft 365 Word 2019 Outlook 2019 More... 

To convert text to a table or a table to text, start by clicking the Show/Hide paragraph 

mark on the Home tab so you can see how text is separated in your document. 

 

javascript:


Convert text to a table 

1. Insert separator characters—such as commas or tabs—to indicate where to divide the 

text into table columns. 

Note: If you have commas in your text, use tabs for your separator characters. 

2. Use paragraph marks to indicate where you want to begin a new table row. 

In this example, the tabs and paragraph marks will produce a table with 3 columns and 2 

rows: 

 

3. Select the text that you want to convert, and then click Insert > Table > Convert Text 

to Table. 

 



4. In the Convert Text to Table box, choose the options you want. 

 

Under Table size, make sure the numbers match the numbers of columns and rows you 

want. 

Under AutoFit behavior, choose how you want your table to look. Word automatically 

chooses a width for the table columns. If you want a different column width, choose one 

of these options: 

To do this Choose this option 

Specify a width for all the columns In the Fixed column 

width box, type or select a 

value. 

Resize the columns to fit the width of the text in each column AutoFit to contents 

Resize the table automatically in case the width of the available 

space changes (for example, web layout or landscape orientation) 

AutoFit to window 

Under Separate text at, choose the separator character you used in the text. 

5. Click OK. The text converted to a table should look something like this: 



 

Q10. Create a file in MS-Word to insert a table in the document. 

Describe all steps involved in it. 

Ans. 

Create a document 

1. On the File tab, click New. 

2. In the Search for online templates box, enter the 

type of document you want to create and press 

ENTER. 

 

 

Editing 



Word provides many options to customize the process of editing 

documents. There are several views 

and tools in Word that allow you to make and see changes to your 

document in a preferable method. 

The following Editing articles will also explain how to utilize the Review tab 

of the ribbon, which is 

crucial to personalizing the editing process in Word. 

Q11. Create a following worksheet in MS-excel and save it with name 

‘book1’. 

Ans. Save a worksheet 

When you have multiple worksheets in an Excel workbook, you might 

want to 

save only one worksheet as its own workbook. Use the Move or Copy 

function 

to save one worksheet in Excel 2013 or Excel 2016. 

 

Save a single worksheet 

1. Right-click the worksheet name tab.

 



2. Click select Move or Copy.

 
3.  

Click on the Move selected sheets to Book drop-down menu. 

Select (new book). 

 

 

 

 

 

 

 



4. Click OK. Your new workbook opens with your moved worksheet. 

 
5. Click File &gt; Save in your new workbook.  

 

 

Q12. Calculate the following things of a range (C2:C11) of data in the 

worksheet created in question no 

10. 

 the sum of the marks using AutoSum in a range of cells (C2:C11) 

 average of the marks in a range of cells (C2:C11) 

 highest marks in a range of cells (C2:C11) 

 minimum marks in a range of cells (C2:C11) 

Ans. 1. the sum of the marks using AutoSum in a range of cells 

(C2:C11) 

 

The SUM function adds values. You can add individual values, cell 

references or ranges or a mix of all three. 



=SUM(A2:A10) Adds the values in cells A2:10 

2. average of the marks in a range of cells (C2:C11) 

Returns the average (arithmetic mean) of the arguments. For example, 

if 

the range A1:A20 contains numbers, the 

formula =AVERAGE(A1:A20) returns the average of those numbers 

3. highest marks in a range of cells (C2:C11) 

MAX will return the largest value in a given list of arguments. From a 

given 

set of numeric values, it will return the highest value. Unlike MAXA 

function, 

the MAX function will count numbers but ignore empty cells, text, the 

logical 

values TRUE and FALSE, and text values. 

=MAX(number1, [number2], …) 

4. minimum marks in a range of cells (C2:C11) 

The Microsoft Excel MIN function returns the smallest value from the 

numbers provided. 

=MIN(A2, A3) 

 

Q13 a) Describe various steps involved in the following 

 To modify column width of a worksheet 

 To modify the row height of a worksheet 



 To delete rows and columns of a worksheet 

Ans. 1. To modify column width of a worksheet 

 

If you find yourself needing to expand or reduce Excel&#39;s row 

widths and column heights, 

there are several ways to adjust them. The table below shows the 

minimum, maximum and 

default sizes for each based on a point scale. 

2. To modify the row height of a worksheet 

If you find yourself needing to expand or reduce Excel&#39;s row 

widths and column heights, 

there are several ways to adjust them. The table below shows the 

minimum, maximum and 

default sizes for each based on a point scale. 

 

3. To delete rows and columns of a worksheet 

 

Insert or delete a column 

1. Select any cell within the column, then go 

to Home &gt; Insert &gt; Insert 

Sheet Columns or Delete Sheet Columns. 

2. Alternatively, right-click the top of the column, and then 

select Insert or Delete.  

 



Insert or delete a row 

1. Select any cell within the row, then go 

to Home &gt; Insert &gt; Insert 

Sheet Rows or Delete Sheet Rows. 

2. Alternatively, right-click the row number, and then 

select Insert or Delete. 

Q13 b) Describe following terms in the worksheet 

 

 Absolute reference and relative reference in formula 

 Cell address 

Ans. 1. Absolute reference and relative reference in 

formula 

 

Relative references 

By default, all cell references are relative references. 

When copied across 

multiple cells, they change based on the relative position 

of rows and 

columns. For example, if you copy the 

formula =A1+B1 from row 1 to row 2, 

the formula will become =A2+B2. Relative references are 

especially 



convenient whenever you need to repeat the same 

calculation across 

multiple rows or columns. 

2. Cell address 

What is the Cell ADDRESS Function? 

 

The cell ADDRESS function is categorized under 

Excel Lookup and Reference 

functions. It will provide a cell reference (its “address”) 

by taking the row number 

and column letter. The cell reference will be provided as a 

string of text. The 

function can return an address in a relative or absolute 

format and can be used to 

construct a cell reference inside a formula. 

As a financial analyst, cell ADDRESS can be used to 

convert a column number to a 

letter, or vice versa. We can use the function to address 

the first cell or last cell in 

a range. 

  

Formula 



=ADDRESS(row_num, column_num, [abs_num], [a1], 

[sheet_text 

 

Q14. a) What tools are available to customize our PowerPoint 

presentation? 

Ans. Customize presentation options and views 

Changing page setup options 

Presentations are created mainly to project either on a projector or 

more and more 

frequently to a plasma or TV screen. There are times when a 

presentation can be 

created for delivery in different formats. 

 

·         On-screen show (4:3) 

·         Letter Paper (8.5 x 11 in) 

·         Ledger Paper (11 x 17 in) 

·         A3 Paper (297 x 420 mm) 

·         A4 Paper (210 x 297 mm) 

·         B4 (ISO) Paper (250 x 353 mm) 

·         B5 (ISO) Paper (176 x 250 mm) 

·         35mm Slides 



·         Overhead 

·         Banner 

·         On-screen Show (16:9) 

·         On-screen Show (16:10) 

·         Widescreen 

·         Custom 

 

  

To select a slide size other than the standard one: 

1. In Slide Master View 

2. Click on Slide Size 

3. Select from one of the two options 

4. For more choices, click Custom 

5. Select one of the options 

 

 



Figure 89- standard or widescreen 

 

 

 

 

 

 

 

Changing to view in color/grayscale 

Why change to view the presentation in grayscale? You might want to 

print the 

presentation and to print in colour is more expensive than printing to 

greyscale, so 

you need to see what the presentation looks like in grayscale before 

you print. 

 

 

 



 

 

Figure 91- colour/grayscale options 

On the View Ribbon, click on the option you want, Colour, Grayscale or 

Black and 

White. 

Then from the Grayscale Ribbon select the option you want to see: 

 

 

 

 

Figure 92- grayscale options 

To get back to the colour view, click Back to Colour View. 

Navigating using presentation views 

There are several different views in PowerPoint as we saw earlier and 

you can 

navigate through the presentation in each in different ways. 



In Normal View 

 Click on the thumbnail of the slide you want to see 

 Use the Vertical Scrollbar to move between slides 

 Use the up and down arrow keys on the keyboard to move one slide 

backwards or forwards 

In Slide Sorter View 

 Click on the slide you want to select 

 Use the arrow keys to move up, down, left and right 

In Reading View 

Use the next and back icons in the status bar to move back or forwards 

or use the 

menu which is accessed from the icon in the middle 

 

Figure 94 – icons 

Back and Next icons move between slides. 

 

 

 

 

 



 

Figure 93- reading view 

Pick from the menu – you can use Go to 

Slide to pick the slide number 

  

In Slide Show view 

When presenting you can use the mouse or the arrows on the keyboard 

to move 

through the presentation one slide at a time. 

You can also type the number of the slide you want to see and press 

Enter. 

When you hover the mouse over the bottom left corner of the slide on 

display you 

will notice some faint icons, there is a back arrow and forward arrow 

which move you 

through one slide at a time. 

 

 

Figure 95- slide show icons 

 



Use the fourth icon along to show the slides in a presentation view of 

Slide Sorter 

View. This lays the slides on the screen and you can click on the one you 

want to 

see 

 

 

 

 

 

 

Figure 96- Slide Sorter in presentation view 



Use the back arrow at the top left to get back to the slide you started 

from. 

To end the slide show, press the Escape Key on the keyboard – this 

takes you back 

to PowerPoint in the edit mode which means that your audience will 

see the back 

end of your presentation. 

You can also use the End Presentation option which is on the small 

ellipse icon on 

the bottom left of the slide when you hover the mouse. 

Q14 b) Write the steps for the following action for creation of 

power point presentation 

 Open a Blank presentation 

 Save the presentation as Lab1.pptx 

 

 Add a Title to the first slide: the name of your college 

 Type your first name and last name in the Subtitle section 

 Add a New Slide which has a Title and Content 

Ans. 1. Open a Blank presentation 

 



To create a new presentation: 

When beginning a new project in PowerPoint, you&#39;ll often 

want to start 

with a new blank presentation. 

1. Select the File tab to go to Backstage view. 

 

 

 

2. Select New on the left side of the window, then click Blank 

Presentation. 



 

 

 

 

 

3. A new presentation will appear. 

To create a new presentation from a template: 

 

A template is a predesigned presentation you can use to create 

a new 

slide show quickly. Templates often include custom 



formatting and designs, so they can save you a lot of time and 

effort 

when starting a new project. 

1. Click the File tab to access Backstage view, then select New. 

2. You can click a suggested search to find templates or use 

the search bar to find something more specific. In our 

example, we&#39;ll search for the keyword chalkboard. 

 

 

 

 



2. Select a template to review it. 

 

 

 

 

 

 

 

1. A preview of the template will appear, along with additional 

information on how the template can be used. 

2.Click Create to use the selected template. 

 

 

 

 

 

 

 



 

3. A new presentation will appear with the selected template. 

It&#39;s important to note that not all templates are created 

by Microsoft. 

Many are created by third-party providers and even individual 

users, so 

some templates may work better than others. 

 

To open an existing presentation: 

In addition to creating new presentations, you&#39;ll often 

need to open a 

presentation that was previously saved. To learn more about 

saving 

presentations, visit our lesson on Saving Presentations. 

1. Select the File tab to go to Backstage view, then 

click Open. 

 

 

 



 

 

2. Click Browse. Alternatively, you can choose OneDrive to 

open files stored on your OneDrive. 

 

 

 

 



 

 

 

 

 

3. The Open dialog box will appear. Locate and select 

your presentation, then click Open. 



 

 

 

 

 

 

 

2. Save the presentation as Lab1.pptx 

 

Ans. 

 One of the most basic tasks in PowerPoint is being able to 

save your work; 



this is probably the most important task as well. There are 

many users who 

have burnt their fingers for not saving their work in time and 

losing hours of 

hard work. The following are the basic steps to save a 

presentation. 

 Step 1 − Click on the File tab to launch the Backstage view and 

select Save. 

 

 

 

 



 

 

 

Step 2 − In the Save As dialog, type in the file name and click 

&quot;Save&quot; 

 

 

 

 

 

 

 



 

Step 3 − The default file format is .pptx. If you want to save the 

file with a different name, 

choose one of the file types from the &quot;Save as type&quot; 

dropdown list. 

 

 

 

 

 

 

 



If you are working on an already saved file, the 

&quot;Save&quot; option in the Backstage view will 

directly save the file in the existing format with the existing 

name. If you want to change the 

format or filename of an existing file, use the Save As option 

instead. 

 

 

 

 

 



 

 

 

3. Add a Title to the first slide: the name of your 

college 

Ans. 

1. Open a Blank presentation 

2. Save the presentation as PowerPointLabOne.pptx 

3. Add a Title to the first slide: the name of your college 

4. Type your first name and last name in the Subtitle section 

5. Add a New Slide which has a Title and Content 

6. Add a title to the second slide “My Future Goals” 

7. In the Content section of the second slide, add at least three 

Personal Goals 

8. Right click on the second slide from the left panel, then 

choose Duplicate Slide 

9. Highlight the text in the Content area of the third slide. 

Under the Home tab, 

click Convert to SmartArt, then choose Basic Cycle 



10. Change the SmartArt Colors to Colorful—Accent Colors 

11. Change the SmartArt Styles to 3D Polished 

12. From the left panel, drag the third slide between the first 

and second slide 

13. Change the layout of the third slide, the slide that does not 

have the SmartArt, 

to Comparison 

14. Leave the title “My Future Goals” 

15. In the head of the first column, type “Goals in College,” then 

center the heading 

16. In the head of the second column, type “Goals 

after College,” then center the heading 

 

17. Add at least three goals in each section 

18. Make sure that slide #3 is selected from the left panel, then 

add a New Slide 

19. Change the layout of the new slide to Blank 

20. Insert a Graduation Online Picture from the Office ClipArt—

Choose any image of your 

choice 



21. Change the ClipArt size to 3” X 3” and position it in the 

middle of the slide 

22. Apply the Wisp Design Theme 

23. Save and upload PowerPointLabOne.pptx to your instructor 

 

5. Add a New Slide which has a Title and 

Content 

Ans. Insert a New Slide in PowerPoint: Overview 

            In this tutorial, you will learn how to insert a new slide in 

PowerPoint. When you 

create a new presentation, PowerPoint gives you one default 

slide that contains a “Title 

Slide” layout. You can click into the placeholders shown in the 

title slide. Then type the text 

you want to appear as the title and subtitle of your 

presentation. 

            To add another presentation slide, you must then insert 

a new slide and determine 

which placeholders appear in it. The slide layout you apply 

determines which placeholders 



appear within the new slide. However, you can also change the 

slide layout to change the 

placeholders after it is applied. 

            To insert a new slide in PowerPoint with a “Title and 

Content” slide layout, click the 

“Home” tab in the Ribbon. Then click the “New Slide” button in 

the “Slides” button group. 

            To insert a new slide in PowerPoint with a different slide 

layout, click the drop-down 

 

 

 

Q15. Write steps for creation of a set of PowerPoint slides 

that demonstrates 



your skill to usethe tools of PowerPoint. It should include the 

following 

things 

 Title slide &bullet list 

 Inserting Excel Sheet 

 Clip art and Text 

 Slide show effects 

Ans .      Title a slide 

There are multiple way to add titles to your slides in 

PowerPoint. Use 

the Layout option to create a standalone title slide or to add a 

title to a slide 

that contains other text. You can also use the Outline view to 

create and 

update the titles of your slides 

 

Show each bullet point with a click 

1. Select the text box that contains the slides you want 

to animate.   



 

 

 

2. Click the Animations tab, and then choose a motion 

effect like Appear or Fly In. 

 

 

3. The slide displays the animation sequence in a box to 

the left of each point. 

 

 

Show each bullet point after a delay 



1. Select all the bullet points you want to animate, click 

the Animations tab, and then choose a motion effect 

like Appear or Dissolve In. 

 

2. In the Animations pane, select the second animation in 

the list. 

 

 

 

3. Under Timing, change the Start setting to After Previous, and 

then 



enter the amount of time you want to delay between each 

bullet 

point. 

 

B) Inserting Excel Sheet 

 

Ans. Insert an object in your Excel spreadsheet 

You can use Object Linking and Embedding (OLE) to 

include content from other programs, such as Word 

or Excel. 

OLE is supported by many different programs, and 

OLE is used to make content that is created in one 

program available in another program. For example, 

you can insert an Office Word document in an Office 

Excel workbook. To see what types of content that 

you can insert, click Object in the Text group on 



the Insert tab. Only programs that are installed on 

your computer and that support OLE objects appear 

in the Object type box. 

 

Embed an object in a worksheet 

1. Click inside the cell of the spreadsheet where you 

want to insert the object. 

2.On the Insert tab, in the Text group, click Object  . 

 

 

3. In the Object dialog box, click the Create from 



File tab. 

4. Click Browse, and select the file you want to insert. 

5. If you want to insert an icon into the spreadsheet 

instead of show the contents of the file, select 

the Display as icon check box. If you don’t select 

any check boxes, Excel shows the first page of the 

file. In both cases, the complete file opens with a 

double click. Click OK. 

 

Insert a link to a file 

 

You might want to just add a link to the object rather 

than fully embedding it. You can do that if your 

workbook and the object you want to add are both 

stored on a SharePoint site, a shared network drive, 

or a similar location, and if the location of the files will 

remain the same. This is handy if the linked object 

undergoes changes because the link always opens 



the most up-to-date document. 

1. Click inside the cell of the spreadsheet where you 

want to insert the object. 

2. On the Insert tab, in the Text group, click Object  . 

 

 

3. Click the Create from File tab. 

4. Click Browse, and then select the file you want to 

link. 

5. Select the Link to file check box, and click OK. 

 



Create a new object from inside Excel 

 

You can create an entirely new object based on 

another program without leaving your workbook. For 

example, if you want to add a more detailed 

explanation to your chart or table, you can create an 

embedded document, such as a Word or PowerPoint 

file, in Excel. You can either set your object to be 

displayed right in a worksheet or add an icon that 

opens the file. 

 

 

1. Click inside the cell of the spreadsheet where you 

want to insert the object. 

2. On the Insert tab, in the Text group click Object  . 



 

 

3. On the Create New tab, select the type of object you 

want to insert from the list presented. If you want to 

insert an icon into the spreadsheet instead of the 

object itself, select the Display as icon check box. 

4. Click OK. Depending on the type of file you are 

inserting, either a new program window opens or an 

editing window appears within Excel. 

5. Create the new object you want to insert. 

When you’re done, if Excel opened a new program 



window in which you created the object, you can work directly 

within it. 

 

 

When you’re done with your work in the window, you 

can do other tasks without saving the embedded 

object. When you close the workbook your new 

objects will be saved automatically. 

C) Clip art and Text 

Ans. Clip art (also clipart, clip-art), in the graphic arts, is pre-

made images used to illustrate 

any medium. Today, clip art is used extensively. Clip art comes 

in many forms, both electronic 

and printed. However, most clip art today is created, 

distributed, and used in an electronic form. 



Since its inception, clip art has evolved to include a wide variety 

of content, file formats, 

illustration styles, and licensing restrictions. Clip art is generally 

composed exclusively of 

illustrations (created by hand or by computer software), and 

does not include 

Text 

 

the main body of matter in a manuscript, book, newspaper, 

etc., as 

distinguished from notes, appendixes, headings, illustrations, 

etc. 

the original words of an author or speaker, as opposed to a 

translation, 

paraphrase, commentary, or the like: the actual wording of 

anything written 

or printed: 

D) Slide show effects 

Ans. Slide Effect is a presentation tool providing enhanced 

transitions and effects. Using a standard Presentation 



Software user interface, people can create slide presentation 

with movies and images in a simpler way than using a video 

editing software.  

 

 

 

 

 


