
CCA-101: Fundamentals of IT Programming 

Assignment- 1 

Q1: What are the four fundamentals parts of computer? Explain it with the help of diagram. 
Ans: The four fundamentals parts of computer is Central processing unit (CPU), Motherboard, Hard 
drive and Random Access Memory (RAM). 

 Input Devices: In computing, an input device is a piece of equipment used to provide 

data and control signals to an information processing system. 

 CPU: The Central Processing Unit (CPU) is the primary component of a  computer 

that acts as its “control centre.” 

 Output Devices: An output device is any  hardware device used to send data from a 

computer to another device or users. 

 Backing storage :Backup storage refers to a storage device, medium or facility that is 

used foe storing copies and instances of backup data. 

 

   

 

  

 

                  Block Diagram of a Digital Diagram. 

Q2: Discuss about the classification of computers based on size and capacity. 

Ans: Based on size and capacity , computers are classified as follow: 

 Super Computers  

 Mainframe Computer  

 Mini Computers 

 Micro Computers 

 

Super Computers: Super Computers are the most powerful and physically the largest by 

size. The fastest supercomputers can perform over one trillion calculations in a second. 

Super computers have thousands of processors. Because of their extraordinary speed, 

accuracy and processing power, supercomputers are well suited for solving highly complex 

problems & huge amounts of  calculations 

Mainframe Computers:  Mainframe computers are very large often filling an entire room 

and can process thousands of millions of instructions per second. In a mainframe 

environment, users connect to the mainframe through the many terminals wired to the 

mainframe. Mainframes are capable of supporting hundreds to thousands of users 

simultaneously . 
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Minicomputers: Minicomputers are much smaller than mainframes. These computers are 

also less expensive. Sometimes referred to as midrange server or midrange computer. They 

are typically larger, more powerful and more expensive than desktop computers. Midrange 

computers are usually used  by small and medium-sized business as their servers. Users to 

the connect to the server through a network by using desktop computers. 

Microcomputers:  Microcomputers are the most frequently used type of computer .it is also 

, known as personal computer (PC) . A microcomputer is a small computer system designed 

to be used by one person at a time.  

Q3: What is the meaning of computer generation? How many Computer Generations are 
defined? What technologies were/ are used? 

Ans: Generation in computer terminology is a change in technology a computer is / was 

being used. Initially the generation term was used to distinguish between varying hardware 

technologies. Includes both hardware and software. 

 There are five computer generations:. 
First generation of computer technologyvacuum tube based. 
Second generation of computer technology transistor based. 
Third generation  of computer technology  integrated circuits based. 
Fourth generation of computer technology microprocessor based. 
Fifth generation of computer technology natural language input. 
 

Q4: Differentiate between Volatile & Non Volatile memories. 

Ans:                     

 

Q5: Distinguish among system software, application  software and open source software on 

the basis of their features. 

Ans: System Software: It is a type of software that is designed to run a computers hardware 

and application programs. Software like operating systems, computers, editors and drivers 

etc. , come under this category. A computer cannot function without the presence of system 

software. 

 Application Software: It is software created for a specific purpose, used by end 

users. It can be called an application or simply an app. 

Volatile Non-Volatile 
 
Volatile memory is a computer storage that 
only maintains its data while the device is 
powered  
Examples: RAM ( Random access memory) is 
volatile. When we are working on a 
document, it is kept in RAM, and if the 
computer loses power, your  work will be 
lost. 

 
Non-Volatile memory is a type of  computer 
memory that has capability to hold saved 
data even if the power is turned off.  
Examples:Read-only memory (ROM), Hard 
disk, floppy disk, etc. 



 Open Source Software: It is a type of computer software in which sourcecode is 

released under a licences in which the copyright holder grants users rights to study, change 

and distribute the software to anyone and for my purpose.  

Q6.a) Create a file in MS-word to insert a paragraph about yourself and save it with file 

name “yourself”. Describe all steps involved in it. 

Ans:   

 First step- Open a MS Word  

 Second step - Typing the paragraph about myself  

 Third step- Saving the file through the file menu save asand choose location where to save  

 Fourth step- Renaming the file “yourself” 

 Fifth step- Click save . 

Q6.b) Write steps regarding followings. 

 To change the font style :   Ctrl + Shift + F 

 To change the font size:  Ctrl + Shift + P 

 To change the font color: On the Home tab, in the Font group, choose the arrow 

next to Font Color, and then select a color. 

  To Highlight (in yellow) the line that  reads “need to get IMS’s address”. 

Select the text that you want to highlight. Go to Home and, select the arrow next to 

Text Highlight Color. Select the yellow color. 

Q7. Create a file in MS-Word for the following document and save it with file name ‘Ms-

word’. Describe all steps involved in it. 

Ans: MS Word  

MS Word is a widely used commercial word processor development by Microsoft. 

MS Word is  application software , which is capable of 

 creating, 

 editing, 

 saving, and 

 printing any type of document 

The step involved in it are as following: 

(i) Open MS- Word from Microsoft office 

(ii) Type the document  

(iii) On the Home tab, in the Font group, choose the arrow next to Font Color, 

and then select a color. 

(iv) To underline the selected words press Ctrl+U 

(v) To write in italic letter Select ms-word and  press Ctrl+ I  

(vi) To saved the file press Ctrl+S and click on save as and after choosing the file 

location rename the file as  ‘ms_word’ . 

 

 



Q8. Create a file in MS-Word for the following document and save it with file name 

‘equations’. Describe all steps involved in it. 

Ans: Equations 

X2 + Y5=30 

Z3 + Q4=50 

A2 + B8= X2 + Y8 

The step involved in it are as following: 

(i) Type the equation in ms word 

(ii) By pressing Ctrl+=  Subscript is given on X + Y and A,X 

(iii) By pressing Ctrl+ Shift++ = Superscript is given on Z + Q and B,Y  

(iv) The file is saved by pressing Ctrl+ S and giving file name ‘equations’. 

Q9. Create a file in MS-Word that convert existing highlight text to table as shown below 

and save it as file name ‘text_to _table’. Describe all steps involved in it. 

Ans: 

Select the text you want to convert . 

Select the Insert tab  

Click on Table command. A dialog box appears. 

Click on Convert Text to Table, a new dialog box appears 

here set number of columns. 

Click on OK Finally Selected text convert in a table 

 

Select the text you want to convert . Select the Insert tab  

Click on Table command. A dialog box 
appears.  

Click on Convert Text to Table, a new 
dialog box appears 

here set number of columns. Click on OK Finally Selected text convert 
in a table  

 

The step involved in it are as following:  

 Type the text in ms word  
 Select all the words and highlight from home page selecting colour from text 

highlight colour 
 Select all words click on insert table and convert text to table. 

Q10. Create a file in MS-Word to insert a table in the document. Describe all steps involved 

in it. 

Ans: The step involved in it are as following: 

(i) Open a blank  word document   
(ii) In the top ribbon, press insert 
(iii) Click on the table button 
(iv) Either use the diagram to select the number of columns and rows you need, or click insert 

table  
(v) The blank table will now appear on the page 

 



 

 

Q11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

Ans: 

 

Q12. Calculate the following thing of a range (C2:C11) of data in the worksheet created in 

question no 10. 

 The sum of the marks using Auto sum in a range of cells (C2:C11) 

 
 Average of the marks in a range of cells (C2:C11) 

 
 Highest marks in a range of cells (C2:C11) 

 
 Minimum marks in a range of cells (C2:C11) 



 

Q13 a) Describe various steps involved in the following  

 To modify column width of a worksheet :Step 1- Select a column or a range of column 
                     Step 2- On the home tab, select Format > Column Width  

 Step 3- Type the column width and select OK.   

 To modify the row height of a worksheet  

Step 1-  On the Home tab, in the Cells group, click Format.  

Step 2- Under Cell Size, click Row Height.  

Step 3-   In the Row height box, type the value that you 

want. 

 To delete rows and columns of a worksheet  

Step 1- Right-click in a table cell, row, or column   you want 
to delete. 
Step 2- On the menu, click Delete Cells. 
Step 3- To delete one cell, choose Shift cells left or Shift cells 
up. To delete the row, click Delete entire row. To delete the 
column, click Delete entire column. 

 

Q14. a) What tools are available to customize our PowerPoint presentation?   

Ans: To customize power point presentation this are the tools available and used:- 

 Tool 1: Templates and Themes. 

 Tool 2: Slide Layouts. 

 Tool 3: Fonts. 

 Tool 4: Color Themes. 

 Tool 5: Icons. 

 Tool 6: Shapes. 

 Tool 7: Stock Photos. 

 Tool 8: Charts and Graphs. 

Q14. b) Write the steps for the following  action for  creation of power point presentation  

 Open a Blank presentation 

 Save the presentation as Lab1.pptx 

 Add a Title to the first slide: the name of your collage  

 Type your first name and last name in the Subtitle section  

 Add a New Slide which has a Title and Content 

 
 



Ans:  
 Open a Blank presentation : Step – Open Microsoft PowerPoint from Microsoft office and 

           click on blank presentation  
 Save the presentation as Lab1.pptx :1st Step –Left Click Office button from left top corner 

       2nd Step- Left click on Save As  
       3rd Step- click on PowerPoint 97-2003 presentation 
       4th step- Change File name to Lab1 and click the Save       
 button 

 Add a Title to the first slide: the name of your collage : 1st step- click inside of the slide Click 
Add Title and type the words name of college ” Netaji Subhash Mahavidyalaya” 

 
  

 Type your first name and last name in the Subtitle section : 1st step- In the first slide sub title 
section type “Shari Jamatia” 

 Add a New Slide which has a Title and Content: 1st Open New slides from Home Tab and 
select Title and Content Slides 

  

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to 

use the tools of PowerPoint. It should include the following things 

 Title slide & bullet list :- 1st step- Open New slide in Ms Powerpoint select the slide 

      and  edit the title and Bullet list in Sub title  

 Inserting Excel Sheet :-  1st step- open new slide and insert Excel sheet from Insert 

      tab – Table – click on excel speadsheet 

 Clip art and Text  :-    1st step- Open new slide . 

2nd step- Open Insert tab and Click on Clip Art ribbon and         

      windows search option is open up at the right 

corner .  

   3rd step- when you click on Search option picture appear and 

       select the picture as per choice 

 Slide show effects: Slide show effect can be given from Design tab- Effect can be 

   change as per desired. 



    

Part -2 

Q16. What is the difference between Machine Language and High Level Language? 

Ans:  Difference between machine language and high level language: 

Machine language High level language 

Machine language is the language written as 
strings of binary  1’s & 0’s to create instructions 

A Programming language that uses English and 
mathematical symbol in its instruction 

languages are closer to the system hardware and 
require the knowledge of hardware to write the 
instructions 

languages are the machine independent 
languages that do not require the hardware 
knowledge to write instructions 

Q17. Discuss about different data types of C programming Language. 

Ans: 

Types Description 

Primitive Data 
Types 

Primitive data types are the most basic data types that are 
used for representing simple values such as integers, float, 
characters, etc. 

User Defined 
Data Types 

The user-defined data types are defined by the user himself. 

Derived Types 
The data types that are derived from the primitive or built-in 
data types are referred to as Derived Data Types. 

Q18. Find the output of the following expressions 

a) X-20/5*2+30-5    b) Y-30-(40/10+6)+10c) Z=40*2/10-2+10 

Ans:  a) X + 17          b) Y – 30            c) Z = 16 

 

Q19. Describe the syntax of the following statements 

a) If-else statement :- if (test-expression) { True block of statements } Else { False 

block of statements }  

b) for loop  :   A "For" Loop is used to repeat a specific block of code a  

   known number of times. 

c) while loop :   while(condition){ //code to be executed. }     



     d) do-while loop: do { statements} while (expression); 
 

Q20. Find the output of the following program segments 

a) b) c) 
#include <stdio.h> 
 int main() 
{ 
int i; 
 for (i=1; i<2; i++) 
  { 
print("IMS Ghaziabad\n"); 
} 
 } 

 

#include <stdio.h> 
 int main() 
{ 

int i= 1; 
While (i<=2) 
  {  
Printf( 
“IMSGhaziabad\n”); 
i=i+1; 
     } 
} 

#include <stdio.h> 
 void main() 
{ 

int a=10,b=100 
if(a>b) 
printf( “largest number is 
%d\n”,a); 
elseprintf(“largest number is 
%d\n”,b); 
} 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 


