
                        CCA- 101: Fundamentals of IT & Programming 

Assignment-1 

Q1:What are the four fundamental parts of computer ? Explain it with 

the help of diagram. 

Ans. Block Diagram of Computer System :: The Computer system consists 

of mainly three types that are central processing unit (CPU),Input Devices, and 
Output Devices.The Central processing unit (CPU) again consists of ALU 
(Arithmetic Logic Unit) and Control Unit. 

The set of instruction is presented to the computer in the form of raw data which 
is entered through input devices such as keyboard or mouse. 

Later this set of instructions is processed with the help of CPU [Central 
Processing Unit], and the computer system produces an output with the help of 
output devices like printers and monitors. 

A large amount of data is stored in the computer memory with the help of 
primary and secondary storage devices temporarily and permanently. This is 
called as storage devices 

The CPU is the heart | Brain of a computer because without the necessary 
action taken by the CPU the user cannot get the desired output. The Central 
Processing Unit [CPU] is responsible for processing all the Instruction which is 
given to the computer system. 

Below Block Diagram of Computer and Its Components are mentioned for 
better understanding 



Block Diagram of Computer 

The Basic components & parts of computer system are given below :: 

 Input Devices 

 Output Devices 

 CPU (Central Processing Unit) 

 Storage Unit 

 ALU(Arithmetic Logic Unit) 

 Control Unit 

 

Q2: Discuss about the classification of computers based on size and 

capacity . 

Ans.  
Introduction 

Classification of computers are based on their architecture, speed of executing commands or 

instructions, peripheral used and also their uses. Microcomputers are usually used in home and 

offices and only a single user can perform the task using a microcomputer. Its storage and data 

handling capacity are limited as per the requirement for home and office work. The another type of 



computer is called minicomputer which has usually larger storage and can handle multiuser at a 

time. This chapter includes the classification of computers. 

  

Computer's Classification 

Computers are classified on different parameters, such as, storage capacity, processing speed and 

component (CPU) used in computers. Depending upon the components used and features of 

different computers, they are classified into four groups, Microcomputers, Minicomputers, Mainframe 

computers and Supercomputers. 

  

Micro Computers 

Micro Computer is a computer whose CPU (Central Processing Unit) is a microprocessor. All the 

components of a microprocessor are on a single integrated circuit chip. Micro computer can be 

categorized as the desktop, programmable and workstation. The microprocessor based computers 

are called third generation computers. They are the backbone of the modern computer era. The first 

and second generation computers are based on vacuum tubes and bipolar junction transistors. 

  

 

  

Desktop Computers 

Desktop computer is a type of microcomputer. A desktop computer has a keyboard for input data, a 

LCD or CRT monitor to display information and Central processing unit tower contains storage, 

memory, different types of drives, such as, CD drive, hard drive, etc. A desktop computer is mainly 

used at home and office applications. 



  

Programmable Computers (PDA) 

Personal digital assistance is a type of hand held programmable digital computer. It is used as 

notepads, address books and can connect to world web wave to share information. A PDA is 

equipped with mobile phone hence, called smallest computer. 

  

  

Workstation 

A workstation computer has greater memory capability and more extensive mathematical abilities. It 

is connected with other workstation computers or personal computer to exchange data and mostly 

used for scientific applications. It also supports multitasking applications. 

  

Mini Computers 

Minicomputers were introduced in early 1960s. They were faster than micro computers. Basically 

these computers were mainly multi-user systems, where many users work on the systems. Generally 

these types of computers had larger memories and greater storage capacity. They had large 

instruction set and address field. These kinds of computers have efficient storage for handling of 

text, in comparison to lower bit machines. Due to more efficient processor, speed and memory size, 

minicomputer was used in variety of applications and could support business applications along with 

the scientific applications. Minicomputer was a multi-user system which means more than one user 

could use this system simultaneously. 

  

Comparison of Micro and Mini computers 

  

Features Microcomputer Minicomputer 

Primary memory  Shall memory Larger memory 

Word length  Small word length  Larger word length 

Cost low Low High 

Processor Low High 

  

Mainframe Computers 



Mainframe computers are large and expensive machines. The word length of mainframe computers 

may be 48, 60 or 64 bits, memory capacity being in some megabytes and storage capacity in some 

terabytes. Generally they handle huge volumes of information and data. In terms of speed, they are 

having significant processing capacity. They are used in research organizations, large industries, 

airlines reservation where a large database has to be maintained. 

  

 

  

Super Computers 

Super Computers are the fastest computer in current era. The processing capabilities of super 

computer lies in the range of GIPS2, word length 64-128 or may be in 256 or so. The memory 

capacity of super computer is in some gigabytes or in terabytes. The storage capacity of this type of 

computer is in exabytes. 

  



 

  

The parallel processing of a super computer makes it very fast because it contains number of CPU 

that operates parallel. They are used at some research centers and government agencies involving 

sophisticated scientific and engineering tasks. 

  

Super computers are used for the followings: 

  

  Weapons research and development 

  Nuclear and plasma physics 

  Rocket research and development 

  Atomic research 

  Aerodynamics 

 

Q3: What is the meaning of computer generation ? How many 

computer generations are defined? What technologies were/are used? 



Ans. Generation in computer terminology is a change in technology a computer is/was being 

used. Initially, the generation term was used to distinguish between varying hardware 

technologies. Nowadays, generation includes both hardware and software, which together 

make up an entire computer system. 

Computer generations are based on when major 
technological changes in computers occurred, 

like the use of vacuum tubes, transistors, and 
the microprocessor. As of 2020, there are five 

generations of the computer. 

Review each of the generations below for 

more information and examples of computers 

and technology that fall into each generation. 

 First generation (1940 - 1956) 

 Second generation (1956 - 1963) 

 Third generation (1964 - 1971) 

 Fourth generation (1972 - 2010) 

 Fifth generation (2010 to present) 

First generation (1940 - 1956) 

https://www.computerhope.com/issues/ch001921.htm#first
https://www.computerhope.com/issues/ch001921.htm#second
https://www.computerhope.com/issues/ch001921.htm#third
https://www.computerhope.com/issues/ch001921.htm#fourth
https://www.computerhope.com/issues/ch001921.htm#fifth


 

The first generation of computers 

used vacuum tubes as a major piece of 

technology. Vacuum tubes were widely used 

in computers from 1940 through 1956. 

Vacuum tubes were larger components and 

resulted in first generation computers being 

quite large in size, taking up a lot of space in 

a room. Some of the first generation 

computers took up an entire room. 

The ENIAC is a great example of a first 

generation computer. It consisted of nearly 

20,000 vacuum tubes, 10,000 capacitors, 

and 70,000 resistors. It weighed over 30 

tons and took up a lot of space, requiring a 

large room to house it. Other examples of 

first generation computers include 

the EDSAC, IBM 701, and Manchester Mark 

1. 

Second generation (1956 - 1963) 

https://www.computerhope.com/jargon/v/vacuumtu.htm
https://www.computerhope.com/history/1940.htm
https://www.computerhope.com/history/1956.htm
https://www.computerhope.com/jargon/e/eniac.htm
https://www.computerhope.com/jargon/c/capacito.htm
https://www.computerhope.com/jargon/r/resistor.htm
https://www.computerhope.com/jargon/e/edsac.htm
https://www.computerhope.com/jargon/num/701.htm
https://www.computerhope.com/jargon/m/mark-1.htm
https://www.computerhope.com/jargon/m/mark-1.htm


 

The second generation of computers saw the 

use of transistors instead of vacuum tubes. 

Transistors were widely used in computers 

from 1956 to 1963. Transistors were smaller 

than vacuum tubes and allowed computers to 

be smaller in size, faster in speed, and 

cheaper to build. 

The first computer to use transistors was the 

TX-0 and was introduced in 1956. Other 

computers that used transistors include the 

IBM 7070, Philco Transac S-1000, and RCA 

501. 

Third generation (1964 - 1971) 

 

https://www.computerhope.com/jargon/t/transist.htm
https://www.computerhope.com/history/1956.htm
https://www.computerhope.com/history/1963.htm


The third generation of computers introduced 

the use of IC (integrated circuits) in 

computers. Using IC's in computers helped 

reduce the size of computers even more 

compared to second-generation computers, 

and make them faster. 

Nearly all computers since the mid to late 

1960s have utilized IC's. While the third 

generation is considered by many people to 

have spanned from 1964 to 1971, IC's are 

still used in computers today. Over 45 years 

later, today's computers have deep roots 

going back to the third generation. 

Fourth generation (1972 - 2010) 

 

The fourth generation of computers took 

advantage of the invention of 

the microprocessor, more commonly known 

as a CPU. Microprocessors, along with 

integrated circuits, helped make it possible 

https://www.computerhope.com/jargon/i/ic.htm
https://www.computerhope.com/history/1964.htm
https://www.computerhope.com/history/1971.htm
https://www.computerhope.com/jargon/c/cpu.htm


for computers to fit easily on a desk and for 

the introduction of the laptop. 

Some of the earliest computers to use a 

microprocessor include the Altair 8800, IBM 

5100, and Micral. Today's computers still use 

a microprocessor, despite the fourth 

generation being considered to have ended 

in 2010. 

Fifth generation (2010 to present) 

 

The fifth generation of computers is 

beginning to use AI (artificial intelligence), an 

exciting technology that has many potential 

applications around the world. Leaps have 

been made in AI technology and computers, 

but there is still room for much 

improvement. 

https://www.computerhope.com/jargon/a/altair.htm
https://www.computerhope.com/jargon/i/ibm5100.htm
https://www.computerhope.com/jargon/i/ibm5100.htm
https://www.computerhope.com/history/2010.htm
https://www.computerhope.com/jargon/a/ai.htm


One of the more well-known examples of AI 

in computers is IBM's Watson, which was 

featured on the TV show Jeopardy as a 

contestant. Other better-known examples 

include Apple's Siri on the iPhone and 

Microsoft's Cortana on Windows 8 and 

Windows 10 computers. The Google search 

engine also utilizes AI to process user 

searches. 

Q4: Differentiate between volatile & Non- Volatile memories . 

Ans. Volatile and Non-Volatile Memory are both types of computer memory. Volatile 

Memory is used to store computer programs and data that CPU needs in real time and 
is erased once computer is switched off. RAM and Cache memory are volatile memory. 
Where as Non-volatile memory is static and remains in the computer even if computer is 
switched off. ROM and HDD are non-volatile memory. 

Following are the important differences between Volatile and Non-Volatile Memory. 

Sr. 
No. 

Key Volatile Memory Non-Volatile Memory 

1 
Data 
Retention 

Data is present till power 
supply is present. 

Data remains even after power 
supply is not present. 

2 
Persistence Volatile memory data is not 

permanent. 
Non-volatile memory data is 
permanent. 

3 
Speed Volatile memory is faster than 

non-volatile memory. 
Non-volatile memory access is 
slower. 

4 
Example RAM is an example of Volatile 

Memory. 
ROM is an example of Non-Volatile 
Memory. 

https://www.computerhope.com/jargon/s/siri.htm
https://www.computerhope.com/jargon/c/cortana.htm
https://www.computerhope.com/jargon/g/google.htm


Sr. 
No. 

Key Volatile Memory Non-Volatile Memory 

5 
Data 
Transfer 

Data Transfer is easy in 
Volatile Memory. 

Data Transfer is difficult in Non-
Volatile Memory. 

6 
CPU 
Access 

CPU can access data stored 
on Volatile memory. 

Data to be copied from Non-Volatile 
memory to Volatile memory so that 
CPU can access its data. 

7 
Storage Volatile memory less storage 

capacity. 
Non-Volatile memory like HDD has 
very high storage capacity. 

8 
Impact Volatile memory such as 

RAM is high impact on 
system's performance. 

Non-volatile memory has no impact 
on system's performance. 

9 
Cost Volatile memory is costly per 

unit size. 
Non-volatile memory is cheap per 
unit size. 

 

Q5: Distinguish among system software, application software and open 

source software on the basic of their features .  

Ans. Open source software is software with source code that anyone can 

inspect, modify, and enhance. 

"Source code" is the part of software that most computer users don't ever see; 
it's the code computer programmers can manipulate to change how a piece of 
software—a "program" or "application"—works. Programmers who have 
access to a computer program's source code can improve that program by 
adding features to it or fixing parts that don't always work correctly. 



Some software has source code that only the person, team, or organization 
who created it—and maintains exclusive control over it—can modify. People 
call this kind of software "proprietary" or "closed source" software. 

Only the original authors of proprietary software can legally copy, inspect, and 
alter that software. And in order to use proprietary software, computer users 
must agree (usually by signing a license displayed the first time they run this 
software) that they will not do anything with the software that the software's 
authors have not expressly permitted. Microsoft Office and Adobe Photoshop 
are examples of proprietary software. 

Open source software is different. Its authors make its source code 
available to others who would like to view that code, copy it, learn from it, alter 
it, or share it. LibreOffice and the GNU Image Manipulation Program are 
examples of open source software. 

As they do with proprietary software, users must accept the terms of 
a license when they use open source software—but the legal terms of open 
source licenses differ dramatically from those of proprietary licenses. 

Open source licenses affect the way people can use, study, modify, and 
distribute software. In general, open source licenses grant computer 
users permission to use open source software for any purpose they wish. 
Some open source licenses—what some people call "copyleft" licenses—
stipulate that anyone who releases a modified open source program must also 
release the source code for that program alongside it. Moreover, some open 
source licenses stipulate that anyone who alters and shares a program with 
others must also share that program's source code without charging a 
licensing fee for it. 

By design, open source software licenses promote collaboration and sharing 
because they permit other people to make modifications to source code and 
incorporate those changes into their own projects. They encourage computer 
programmers to access, view, and modify open source software whenever 
they like, as long as they let others do the same when they share their work. 

Q6: a) Create a file in MS-word to insert a paragraph about yourself and 

save it with file name “yourself”. Describe all steps involved in it.  

https://opensource.com/business/13/5/open-source-your-code
https://opensource.com/business/13/5/open-source-your-code
https://www.libreoffice.org/
http://www.gimp.org/
https://opensource.com/law/13/1/which-open-source-software-license-should-i-use
https://opensource.com/law/10/10/license-compliance-not-problem-open-source-users
https://opensource.com/law/10/10/license-compliance-not-problem-open-source-users
https://opensource.org/docs/osd
https://opensource.com/law/13/5/does-your-code-need-license
https://opensource.com/law/13/5/does-your-code-need-license


Ans. Every Word project you create—whether it’s a personal letter, a 

TV sitcom script, or a thesis in microbiology—begins and ends the 

same way. You start by creating a document, and you end by saving 

your work. Sounds simple, but to manage your Word documents 

effectively, you need to know these basics and beyond. This chapter 

shows you all the different ways to create a new Word document—like 

starting from an existing document or adding text to a predesigned 

template—and how to choose the best one for your particular project. 

You’ll also learn how to work faster and smarter by changing your 

view of your document. If you want, you can use Word’s Outline view 

when you’re brainstorming, and then switch to Print view when you’re 

ready for hard copy. This chapter gets you up and running with these 

fundamental tools so you can focus on the important stuff—your 

words. 

TIP 

If you’ve used Word before, then you’re probably familiar with opening and saving 

documents. Still, you may want to skim this chapter to catch up on the differences between 

this version of Word and the ghosts of Word past. You’ll grasp some of the big changes just 

by examining the figures. For more detail, check out the gray boxes and the notes and 

tips—like this one! 

Launching Word 

The first time you launch Word after installation, the program asks you 

to confirm your name and initials. This isn’t Microsoft’s nefarious plan 

to pin you down: Word uses this information to identify documents that 

you create and modify. Word uses your initials to mark your edits 

when you review and add comments to Word documents that other 

people send to you (Section 16.3). 

https://www.oreilly.com/library/view/word-2007-the/059652739X/ch16.html#word2007tmm-CHP-16-SECT-3


You have three primary ways to fire up Word, so use whichever 

method you find quickest: 

 Start menu. The Start button in the lower-left corner of your 

screen gives you access to all programs on your PC—Word included. 

To start Word, choose Start → All Programs → Microsoft Office → 

Microsoft Office Word. 

 Quick Launch toolbar. The Quick Launch toolbar at the bottom 

of your screen (just to the right of the Start menu) is a great place to 

start programs you use frequently. Microsoft modestly assumes that 

you’ll be using Word a lot, so it usually installs the Word icon in the 

Quick Launch toolbar. To start using Word, just click the W icon, and 

voilá! 

TIP 

When you don’t see the Quick Launch toolbar, here’s how to display it: On the bar at the 

bottom of your screen, right-click an empty spot. From the menu that pops up, choose 

Toolbars → Quick Launch. When you’re done, icons for some of your programs appear in 

the bottom bar. A single click fires up the program. 

 Opening a Word document. Once you’ve created some Word 

documents, this method is fastest of all, since you don’t have to start 

Word as a separate step. Just open an existing Word document, and 

Word starts itself. Try going to Start → My Recent Documents, and 

then, from the list of files, choose a Word document. You can also 

double-click the document’s icon on the desktop or wherever it lives 

on your PC. 

TIP 

If you need to get familiar with the Start menu, Quick Launch toolbar, and other Windows 

features, then pick up a copy of Windows XP: The Missing Manual, Second Edition or Windows 

Vista: The Missing Manual. 



So, what happens once you’ve got Word’s motor running? If you’re 

a newcomer, you’re probably just staring with curiosity. If you’re 

familiar with previous versions of Word, though, you may be doing a 

double take (Figure 1-1). In Word 2007, Microsoft combined all the old 

menus and toolbars into a new feature called the ribbon. Click one of 

the tabs above the ribbon, and you see the command buttons change 

below. The ribbon commands are organized into groups, with the 

name of each group listed at the bottom. (See Figure 1-1 for more 

detail on the ribbon.) 

Creating a New Document 

When you start Word without opening an existing document, the 

program gives you an empty one to work in. If you’re eager to put 

words to page, then type away. Sooner or later, though, you’ll want to 

start another new document. Word gives you three ways to do so: 

https://www.oreilly.com/library/view/word-2007-the/059652739X/ch01.html#word2007tmm-CHP-1-FIG-1
https://www.oreilly.com/library/view/word-2007-the/059652739X/ch01.html#word2007tmm-CHP-1-FIG-1


 

Figure 1-1. When you start Word 2007 for the first time, it may look a little 

top-heavy. The ribbon takes up more real estate than the old menus and 

toolbars. This change may not matter if you have a nice big monitor. But if 

you want to reclaim some of that space, you can hide the ribbon by double-

clicking the active tab. Later, when you need to see the ribbon commands, 

just click a tab. 

 Creating a new blank document. When you’re preparing a 

simple document—like a two-page essay, a note for the babysitter, or 

a press release—a plain, unadorned page is fine. Or, when you’re just 

brainstorming and you’re not sure what you want the final document to 

look like, you probably want to start with a blank slate or use one of 

Word’s templates (more on that in a moment) to provide structure for 

your text. 



 Creating a document from an existing document. For letters, 

resumes, and other documents that require more formatting, why 

reinvent the wheel? You can save time by using an existing document 

as a starting point (Section 1.2.2). When you have a letter format that 

you like, you can use it over and over by editing the contents. 

 Creating a document from a template (Section 1.2.3). Use a 

template when you need a professional design for a complex 

document, like a newsletter, a contract, or meeting 

minutes. Templates are a lot like forms—the margins, formatting, and 

graphics are already in place. All you do is fill in your text. 

TIP 

Microsoft provides a mind-boggling number of templates with Word, but they’re not the only 

source. You can find loads more on the Internet, as described in Section 5.2.1. Your 

employer may even provide official templates for company documents. 

To start your document in any of the above ways, click the Windows 

logo in the upper-left corner of the screen. That’s Office 2007’s 

new Office button. Click it, and a drop-down menu opens, revealing 

commands for creating, opening, and saving documents. Next to 

these commands, you see a list of your Word documents. This list 

includes documents that are open, as well as those that you’ve 

recently opened. 

The Office button is also where you go to print and email 

your documents (Figure 1-2). 

https://www.oreilly.com/library/view/word-2007-the/059652739X/ch01.html#word2007tmm-CHP-1-SECT-2.2
https://www.oreilly.com/library/view/word-2007-the/059652739X/ch01.html#word2007tmm-CHP-1-SECT-2.3
https://www.oreilly.com/library/view/word-2007-the/059652739X/ch05.html#word2007tmm-CHP-5-SECT-2.1
https://www.oreilly.com/library/view/word-2007-the/059652739X/ch01.html#word2007tmm-CHP-1-FIG-2


 

Figure 1-2. The phrase most frequently uttered by experienced Word fans the 

first time they start Word 2007 is, “Okay, where’s my File menu?” Never 

fear, the equivalent of the File menu is still there—it’s just camouflaged a bit. 

Clicking the Office button (the one that looks like a Windows logo) reveals 

the commands you use to create, open, and save Word documents. 

Creating a New Blank Document 

Say you want a new blank document, just like the one Word shows you when 

you start the program. No problem—here are the steps: 

1. Choose Office button → New. 

The New Document dialog box appears. 



2. In the upper-left corner of the large “Create a new Word 

document” panel, click “Blank document” (Figure 1-3). 

The New Document box presents a seemingly endless number of 

options, but don’t panic. The “Blank document” option you want is on 

the left side of the first line. 

3. At the bottom of the New Document dialog box, click Create. 

The dialog box disappears, and you’re gazing at the blank page of a 

new Word document. 

Better get to work. 

 

Figure 1-3. Open the New Document box (Office button → New, or Alt+F, N), 

and Word gives you several ways to create a new document. Click “Blank 

document” to open an empty document, similar to the one Word shows 

https://www.oreilly.com/library/view/word-2007-the/059652739X/ch01.html#word2007tmm-CHP-1-FIG-3


when you first start the program. Or you can click “New from existing” to 

open a document that you previously created under a new name. 

Creating a New Document from an Existing Document 

A blank Word document is sort of like a shapeless lump of clay. With some 

work, you can mold it to become just about anything. Often, however, you 

can save time by opening an existing document that’s similar to the one you 

want to create. Imagine that you write the minutes for the monthly meetings 

of the Chief Executive Officer’s Surfing Association (CEOSA). When it’s 

time to write up the June minutes, it’s a lot faster to open the minutes from 

May. You keep the boilerplate text and all the formatting, but you delete the 

text that’s specific to the previous month. Now all you have to do is enter the 

text for June and save the document with a new name: JuneMinutes.docx. 

NOTE 

The .docx extension on the end of the filename is Word 2007’s new version of .doc. The 

switch from three-letter to four-letter filename extensions indicates a change in the way 

Word stores documents. (If you need to share documents with folks using earlier versions of 

Word, choose Office button → Save As → Word 97-2003 document when you save the file. 

See the box in Section 1.2.3 for details.) 

Word gives you a “New from existing” document-creation option to satisfy 

your desire to spend more time surfing and less time writing meeting 

minutes. Here’s how to create a new document from an existing document: 

1. Choose Office button → New (Alt+F, N) to open the New 

Document window. Then click “New from existing…” (it sits 

directly below the “Blank document” button). 

The three dots at the end of the button’s title tell you that there’s 

another dialog box to come. And sure enough, when you click “New 

from existing…”, it opens another box, appropriately titled New from 

Existing Document (Figure 1-4). This box looks—and works—like a 

https://www.oreilly.com/library/view/word-2007-the/059652739X/ch01.html#word2007tmm-CHP-1-SECT-2.3
https://www.oreilly.com/library/view/word-2007-the/059652739X/ch01.html#word2007tmm-CHP-1-FIG-4


standard Windows Open File box. It lets you navigate to a specific 

folder and open a file. 

2. On your computer, find the existing document you’re using 

for a model. 

You can use the bar on the left to change the folder view. Word starts 

you in your My Documents folder, but you can switch to your desktop 

or your My Computer icon by clicking the icons on the left. Double-

click folder icons in the large window to open them and see their 

contents. 

3. Click to select the file, and then click Create New (in the 

lower-right corner). (Alternatively, just double-click the file’s icon 

to open it. This trick works in all Open File boxes.) 

Instead of the usual Open button at the bottom of the box, the button 

in the New from Existing Document box reads Create New—your clue 

that this box behaves differently in one important respect: Instead of 

opening an existing file, you’re making a copy of an existing file. Once 

open, the file’s name is something like Document2.docx instead of the 

original name. This way, when you save the file, you don’t overwrite 

the original document. (Still, it’s best to save it with a new descriptive 

name right away.) 



 

Figure 1-4. Use the New from Existing Document box to find an existing 

Word document that you’d like to open as a model for your new document. 

When you click Create New at bottom-right, Word opens a new copy of the 

document, leaving the original untouched. You can modify the copy to your 

heart’s content and save it under a different file name. 

TIP 

Windows’ Open File boxes, like New from Existing Document, let you do a lot more than 

just find files. In fact, they let you do just about anything you can do in Windows Explorer. 

Using keyboard shortcuts, you can cut (Ctrl+X), copy (Ctrl+C), and paste (Ctrl+V) files. A 

right-click displays a shortcut menu with even more commands, letting you rename files, 

view Properties dialog boxes, and much more. You can even drag and drop to move files 

and folders. 



POWER USERS’ CLINIC: WORD’S NEW FILE FORMATS: .DOCX AND 

.DOCM 

With Office 2007, Microsoft took the drastic step of changing its file formats in hopes of 

improving your computer’s security. Malicious programmers were using Office’s macros to 

do nasty things to unsuspecting computers. The .docx format, the new standard for Word 

files, doesn’t permit macros, making it safe from those threats. The .docm format indicates 

that a document contains macros or other bits of programming code. When opening one of 

these files, play it safe: If you don’t know who created the .docm file, then don’t open it. 

The downside of the new file formats is that older versions of Word don’t know how to open 

these .docx and .docm documents. To open Word 2007 files with an older version (even 

Word 2003), you need to install the Microsoft Office Compatibility Pack. 

This software fix gives pre-2007 versions of Word the power to open documents in the new 

formats. Even then, you may not be able to use or edit parts of the file that use new Word 

features (like themes, equations, and content controls). To download the free compatibility 

pack, go to www.office.microsoft.com and type office 2007 compatibility into the search box 

at the top of the page. 

Also, if you’re preparing a Word document for someone who’s using an older Word version, 

then you have to save it in a compatible format, as described in the tip in Section 1.2.2. 

(Fortunately, the compatibility issue doesn’t go both ways: Word 2007 can open old .doc 

docs just fine.) 

Creating a New Document from a Template 

Say you’re creating meeting minutes for the first time. You don’t have an 

existing document to give you a leg up, but you do want to end up with 

handsome, properly formatted minutes. Word is at your service—

with templates. Microsoft provides dozens upon dozens of prebuilt templates 

for everything from newsletters to postcards. Remember all the busy stuff in 

the New Document box in Figure 1-3? About 90 percent of the items in there 

are templates. 

http://www.office.microsoft.com/
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In the previous example, where you use an existing document to create the 

meeting minutes for the Chief Executive Officer’s Surfing Association 

(CEOSA), each month you open the minutes from the previous month. You 

delete the information that pertains to the previous month and enter the 

current month’s minutes. A template works pretty much the same way, 

except it’s a generic document, designed to be adaptable to lots of different 

situations. You just open it and add your text. The structure, formatting, 

graphics, colors, and other doodads are already in place. 

NOTE 

The subject of Word templates is a lengthy one, especially when it comes to creating your 

own, so there’s a whole chapter devoted to that topic—Chapter 20. 

Here’s how to get some help from one of Microsoft’s templates for meeting 

minutes: 

1. Choose Office button → New (Alt+F, N) to open the New 

Document window. 

On the left of the New Document box is a Template Categories list. 

The top entry on this list is Installed Templates—the ones Word has 

installed on your computer. 

You could use any of these, but you also have a world of choice 

waiting for you online. On its Web site, Microsoft offers hundreds 

of templates for all sorts of documents, and you can access them right 

from the New Document box. If you have a fast Internet connection, 

then it’s just as quick and easy to use an online template as it is using 

the ones stored on your computer. In fact, you’ll use an online 

template for this example. 

https://www.oreilly.com/library/view/word-2007-the/059652739X/ch20.html


NOTE 

If you can’t connect to the Internet right now, then simply choose one of 

the installed templates instead. Click Create, and then skip to step 4. 

2. Scroll down the Template Categories list to the Microsoft 

Office Online heading. Under this heading, select Minutes. 

In the center pane, you’ll see all different types of minutes templates, 

from PTA minutes to Annual shareholder’s meeting minutes (Figure 1-

5). When you click a template’s icon, a preview appears in the pane 

on the right. 
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Figure 1-5. The New Document box lists prebuilt templates that live at 

Microsoft Office Online in categories like Agendas, Brochures, Calendars, and 

Minutes. Below the thumbnail you see an estimate of how long it takes to 

download the template from the Microsoft Office Online Web site. A rating, 

from 0 to 5 stars, tells you what other people think of the template (the 

rating system is kind of like the one at Amazon.com). 

3. When you’re done perusing the various styles, click the 

Formal Meeting Minutes icon. (After all, CEOSA is a very formal 

organization.) Then click Download. 

Word downloads and opens the document. 

4. Start writing up the minutes for the CEO Surfers. 

To follow the template’s structure, replace all the words in square 

brackets ([ ]) with text relevant to CEOSA. 

TIP 

If you’d rather not download the Formal Meeting Minutes template every time you use it, 

then you can save the file on your computer as a Word template. The steps for saving files 

are just around the corner in Section 1.5. 

Opening an Existing Document 

If you’ve mastered creating a document from an existing document 

and creating a document from a template, you’ll find that opening an 

existing document is a snap. The steps are nearly identical. 

1. Choose Office button → Open (Alt+F, O). In the Open 

window (Figure 1-6), navigate to the folder and file you want to 

open. 

The Open window starts out showing your My Documents folder, 

since that’s where Word suggests you save your files. When your 
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document’s in a more exotic location, click the My Computer icon, and 

then navigate to the proper folder from there. 

TIP 

When you open a document you’ve used recently, you may see its name right on the Office 

button → Recent Documents menu. If so, simply click to open it without a trip to the Open 

dialog box. 

2. With the file selected, click Open in the lower-right corner. 

The Open box goes away and your document opens in Word. You’re 

all set to get to work. Just remember, when you save this document 

(Alt+F, S or Ctrl+S), you write over the previous file. Essentially, you 

create a new, improved, and only copy of the file you just opened. If 

you don’t want to write over the existing document, use the Save As 

command (Alt+F, A), and then type a new name in the File Name text 

box. 



 

Figure 1-6. This Open dialog box shows the contents of the tale of two cities 

folder, according to the “Look in” box at the top. The file tale of two cities. 

docx is selected, as you can see in the “File name box” at the bottom of the 

window. By clicking Open, Mr. Dickens is ready to go to work. 

TIP 

Opening a file in Word doesn’t mean you’re limited to documents created in Word. You can 

choose documents created in other programs from the Files of Type drop-down menu at the 

bottom of the Open dialog box. Word then shows you that type of document in the main part 

of the window. You can open Outlook messages (.msg), Web pages (.htm or .html), or files 

from other word processors (.rtf, .mcw, .wps). 

Your Different Document Views 



Now that you know a handful of ways to create and open Word 

documents, it’s time to take a look around the establishment. You may 

think a document’s a document—just look at it straight on and get your 

work done. It’s surprising, though, how changing your view of the page 

can help you work faster and smarter. When you’re working with a 

very long document, you can change to Outline view and peruse just 

your document’s headlines without the paragraph text. In Outline view, 

you get a better feeling for the manuscript as a whole. Likewise, when 

you’re working on a document that’s headed for the Web, it makes 

sense to view the page as it will appear in a browser. Other times, you 

may want to have two documents open on your screen at once (or on 

each of your two monitors, you lucky dog), to make it easy to cut and 

paste text from one to the other. 

The key to working with Word’s different view options is to match the 

view to the job at hand. Once you get used to switching views, you’ll 

find lots of reasons to change your point of view. Find the tools you 

need on the View tab (Figure 1-7). To get there, click the View tab 

(Alt+W) on the ribbon (near the top of Word’s window). The tab 

divides the view commands into four groups: 

 Document Views. These commands change the big picture. For 

the most part, use these when you want to view a document in a 

dramatically different way: two pages side by side, Outline view, Web 

layout view, and so on. 

 Show/Hide. The Show/Hide commands display and conceal 

Word tools like rulers and gridlines. These tools don’t show when you 

print your document; they’re just visual aids that help you when you’re 

working in Word. 

 Zoom. As you can guess, the Zoom tools let you choose 

between a close-up and a long shot of your document. Getting in 

close makes your words easier to read and helps prevent eyestrain. 
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But zooming out makes scrolling faster and helps you keep your eye 

on the big picture. 

TIP 

In addition to the Zoom tools on the ribbon, handy Zoom tools are available in the window’s 

lower-right corner. Check out the + (Zoom In) and–(Zoom Out) buttons and the slider in 

between them. See Section 1.4.3 for the details on using them. 

 Window. In the Window group, you’ll find creative ways to 

organize document windows on your screen—like split views of a 

single document or side-by-side views of two different documents. 

All the commands in the View tab’s four groups are covered in the 

following pages. 

NOTE 

This section provides the short course on viewing your Word documents. For even more 

details and options for customizing your Word environment, see Chapter 17. 

 

Figure 1-7. The View tab is your document-viewing control center. Look 

closely, and you see it’s divided into four groups with names at the bottom of 

the ribbon: Document Views, Show/Hide, Zoom, and Window. To apply a 

view command, just click the button or label. 
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Document Views: Five Ways to Look at Your Manuscript 

Word gives you five basic document views. To select a view, go to the View 

tab (Alt+W) and choose one of the Document Views on the left side of the 

ribbon (Figure 1-8). You have another great option for switching from one 

view to another that’s always available in the lower-right corner of Word’s 

window. Click one of the five small buttons to the left of the slider to jump 

between Print Layout, Full Screen Reading, Web Layout, Outline, and Draft 

views. Each view has a special purpose, and you can modify them even more 

using the other commands on the View tab. 

 

Figure 1-8. On the left side of the View tab, you find the five basic document 

views: Print Layout, Full Screen Reading, Web Layout, Outline, and Draft. You 

can edit your document in any of the views, although they come with 

different tools for different purposes. For example, Outline view provides a 

menu that lets you show or hide headings at different outline levels. 

NOTE 

Changing your view in no way affects the document itself—you’re just looking at the same 

document from a different perspective. 

 Print Layout (Alt+W, P). The most frequently used view in 

Word, Print Layout, is the one you see when you first start the 

program or create a new blank document. In this view, the page you 

see on your computer screen looks much as it does when you print it. 

https://www.oreilly.com/library/view/word-2007-the/059652739X/ch01.html#word2007tmm-CHP-1-FIG-8


This view’s handy for letters, reports, and most documents headed for 

the printer. 

 Full Screen Reading (Alt+W, F). If you’d like to get rid of the 

clutter of menus, ribbons, and all the rest of the word-processing 

gadgetry, then use Full Screen Reading view. As the name implies, 

this view’s designed primarily for reading documents. It includes 

options you don’t find in the other views, like a command that 

temporarily decreases or increases the text size. In the upper-right 

corner you see some document-proofing tools (like a text highlighter 

and an insert comment command), but when you want to change or 

edit your document, you must first use the View Options → Allow 

Typing command. For more details on using Word for reviewing and 

proofing, see Chapter 16. 

 Web Layout (Alt+W, L). This view shows your document as if it 

were a single Web page loaded in a browser. You don’t see any page 

breaks in this view. Along with your text, you see any photos or videos 

that you’ve placed in the document—just like a Web page. Section 

13.2 has more details on creating Web pages with Word. 

 Outline (Alt+W, U). For lots of writers, an outline is the first step 

in creating a manuscript. Once they’ve created a framework of 

chapters and headings, they dive in and fill out the document with text. 

If you like to work this way, then you’ll love Outline view. It’s easy to 

jump back and forth between Outline view and Print Layout view 

or Draft view, so you can bounce back and forth between a macro and 

a micro view of your epic. (For more details on using Word’s Outline 

view, see Section 8.1.) 

 Draft (Alt+W, V). Here’s the no-nonsense, roll-up-your-sleeves 

view of your work (Figure 1-9). You see most formatting as it appears 

on the printed page, except for headers and footers. Page breaks are 

indicated by a thin dotted line. In this view, it’s as if your document is 

on one single roll of paper that scrolls through your computer screen. 

This view’s a good choice for longer documents and those moments 
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when you want to focus on the words without being distracted by page 

breaks and other formatting niceties. 

Show and Hide Window Tools 

Word gives you some visual aids that make it easier to work with your 

documents. Tools like rulers and gridlines don’t show up when you print your 

document, but they help you line up the elements on the page. Use the ruler 

to set page margins and to create tabs for your documents. Checkboxes on the 

View tab let you show or hide tools, but some tools aren’t available in all the 

views, so they’re grayed out. You can’t, for example, display page rulers in 

Outline or Full Screen Reading views. 

Use the checkboxes in the Show/Hide group of the View tab (Figure 1-10) to 

turn these tools on and off: 

 Ruler. Use the ruler to adjust margins, set tabs, and position 

items on your page. For more detail on formatting text and 

paragraphs, see Chapter 4. 

 Gridlines. When you click the Gridlines box, it looks like you 

created your document on a piece of graph paper. This effect isn’t too 

helpful for an all-text document, but it sure comes in handy if you’re 

trying to line up photos on a page. 
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Figure 1-9. In Draft view, you see most text and paragraph formatting, but 

headers, footers, and other distracting page formatting features are hidden. 

Your text appears as a continuous scroll, with the margins hidden. Page 

breaks appear as dotted lines. 

 Message Bar. The Message Bar resides directly under the 

ribbon, and it’s where you see alerts about a document’s behavior. For 

example, when a document is trying to run a macro and your Word 

settings prohibit macros, an alert appears in the Message Bar. Click 

the checkbox to show or hide the Message Bar. 

 Document Map. If you work with long documents, you’ll like 

the Document Map. This useful tool appears to the left of your text 

(you can see it in Figure 1-10), showing the document’s headings at 

various levels. Click the little + and–buttons next to a heading to 

https://www.oreilly.com/library/view/word-2007-the/059652739X/ch01.html#word2007tmm-CHP-1-FIG-10


expand or collapse the outline. Click a heading, and you jump to that 

location in your document. 

 Thumbnails. Select the Thumbnails option, and you see little 

icons of your document’s pages in the bar on the left. Click a 

thumbnail to go to that page. In general, thumbnails are more useful 

for shorter documents and for pages that are visually distinctive. For 

longer documents, you’ll find the Document Map easier to use for 

navigation. 

Zooming Your View In and Out 

When you’re working, do you ever find that you sometimes hold pages at 

arm’s length to get a complete view, and then, at other times, you stick your 

nose close to the page to examine the details? Word’s Zoom options (Figure 

1-11) let you do the same thing with your screen—but without looking nearly 

as silly. 
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Figure 1-10. Use the Show/Hide group on the View tab to display or conceal 

Word tools. The Ruler gives you a quick and easy way to set tabs and 

margins. The Document Map is particularly helpful when you work with 

longer documents because it displays headings in the bar on the left of the 

screen. In the left pane, you can see that Mr. Dickens wrote more than his 

fair share of chapters. 



 

Figure 1-11. The Zoom group of options lets you view your document close 

up or at a distance. The big magnifying glass opens the Zoom dialog box with 

more controls for fine-tuning your zoom level. For quick changes, click one of 

the three buttons on the right: One Page, Two Pages, or Page Width. 

NOTE 

Even though the text appears to get bigger and smaller when you zoom, you’re not actually 

changing the document in any way. Zoom is similar to bringing a page closer so you can 

read the fine print. If you want to actually change the font size, then use the formatting 

options on the Home tab (Alt+H, FS). 

On the View tab, click the big magnifying glass to open the Zoom dialog box 

(Figure 1-12). Depending on your current Document View (see Section 1.4), 

you can adjust your view by percentage or relative to the page and text (more 

on that in a moment). The options change slightly depending on which 

Document View you’re using. The Page options don’t really apply to Web 

layouts, so they’re grayed out and inactive if you’re in the Web Layout view. 
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Figure 1-12. The Zoom dialog box lets you choose from a variety of views. 

Just click one of the option buttons, and then click OK. The monitor and text 

sample at the bottom of the Zoom box provide visual clues as you change the 

settings. 

Zooming by percentage 

In the box’s upper-left corner, you find controls to zoom in and out of your 

document by percentage. The view varies depending on your computer 

screen and settings, but in general, 100% is a respectable, middle-of-the-road 

view of your document. The higher the percentage, the more zoomed in you 

are, and the bigger everything looks—vice versa with a lower percentage. 

The three radio buttons (200%, 100%, and 75%) give you quick access to 

some standard settings. For in-between percentages (like 145%), type a 

number in the box below the buttons, or use the up-down arrows to change 

the value. For a quick way to zoom in and out without opening a dialog box, 

use the Zoom slider (Figure 1-13) in the lower-right corner of your window. 

Drag the slider to the right to zoom in on your document, and drag it to the 

left to zoom out. The percentage changes as you drag. 
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Figure 1-13. The Zoom slider at the bottom of the document window gives 

you a quick and easy way to change your perspective. Drag the slider to the 

right to zoom in on your document, and drag it to the left to zoom out. To 

the left of the slider are five View buttons: Print Layout, Full Screen Reading, 

Web Layout, Outline, and Draft (Section 1.4.2). Since the first button is 

selected, this document is in Print Layout view. 

Zooming relative to page or text 

Not everyone’s a number person. (That’s especially true of writers.) So you 

may prefer to zoom without worrying about percentage figures. The Zoom 

dialog box (on the View tab, click the magnifying-glass icon) gives you four 

radio buttons with plain-English zoom settings: 

Page width. Click this button, and the page resizes to fill the screen from one 

side to the other. It’s the fastest way to zoom to a text size that most people 

find comfortable to read. (You may have to scroll, though, to read the page 

from top to bottom.) 

Text width. This button zooms in even farther, because it ignores the 

margins of your page. Use this one if you have a high-resolution monitor (or 

you’ve misplaced your reading glasses). 
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Whole page. When you want to see an entire page from top to bottom and 

left to right, click this button. It’s great for getting an overview of how your 

headings and paragraphs look on the page. 

Many pages. This view is the equivalent of spreading your document out on 

the floor, and then viewing it from the top of a ladder. You can use it to see 

how close you are to finishing that five-page paper, or to inspect the layout of 

a multi-page newsletter. 

WARNING 

When you’re zoomed out to Whole or “Many pages” view, watch those fingers on the 

keyboard. You can still make changes to your text in these views, even though you can’t 

see what you’re doing. 

Changing page view from the ribbon 

The ribbon offers radio buttons for three popular page views. (You can see 

them back in Figure 1-11, to the Zoom tool’s right.) They’re a quick and dirty 

way to change the number of pages you see onscreen without fiddling with 

zoom controls. 

 One Page. This view shows the entire page in Word’s document 

window. If your screen is large enough, you can read and edit text in 

this view. 

 Two Pages. In this view, you see two pages side by side. This 

view’s handy when you’re working with documents that have two-page 

spreads, like booklets. 

 Page Width. This button does the exact same thing as the Page 

Width button in the Zoom dialog box (Section 1.4.3). It’s more 

readable than the One Page and Two Page options, because the 

page fills the screen from edge to edge, making the text appear larger. 
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The Window Group: Doing the Splits 

Back when dinosaurs roamed the earth and people used typewriters (or very 

early word processors), you could work on only one document at a time—the 

one right in front of you. Although Word 2007 has more options for viewing 

multiple documents and multiple windows than ever, some folks forget to use 

them. Big mistake. If you ever find yourself comparing two documents or 

borrowing extensively from some other text, then having two or more 

documents visible on your screen can double or triple your work speed. 

The commands for managing multiple documents, views, and windows are in 

the View tab’s Window group (Figure 1-14). 

 

Figure 1-14. In the Window group, the three commands on the left—New 

Window, Arrange All, and Split—let you open and view your work from 

multiple vantage points. The commands in the middle—View Side by Side, 
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Synchronous Scrolling, and Reset Window Position—are helpful when 

reviewing and comparing documents. The big Switch Windows button lets 

you hop from one document to another. 

 New Window (Alt+W, N). When you’re working on a long 

document, sometimes you want to see two different parts of the 

document at the same time, as if they were two separate documents. 

You may want to keep referring to what you said in the Introduction 

while you’re working in Chapter 5. Or perhaps you want to keep an 

Outline view open while editing in Draft view. That’s where the New 

Window command comes in. When you click this button (or hit this 

keystroke), you’ve got your document open in two windows that you 

can scroll independently. Make a change to one window, and it 

immediately appears in the other. 

 Arrange All (Alt+W, A). Great—now you’ve got documents 

open in two or more windows, but it takes a heck of a lot of mousing 

around and window resizing to get them lined up on your screen at the 

same time. Click Arrange All and, like magic, your open Word 

document windows are sharing the screen, making it easy to work on 

one and then the other. Word takes an egalitarian approach to screen 

real estate, giving all windows an equal amount of property (Figure 1-

15). 

 Split (Alt+W, S). The Split button divides a single window so you 

can see two different parts of the same document—particularly handy 

if you’re copying text from one part of a document to another. The 

other advantage of the Split command is that it gives you more room 

to work than using Arrange All for multiple windows because it doesn’t 

duplicate the ribbon, ruler, and other Word tools (Figure 1-16). 
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Figure 1-15. One downside of Office 2007’s ribbon: It takes up more space on 

your computer’s screen than menus or even the older button bars. When you 

open a couple of windows, you’re not left with much space to do your work, 

especially when you’re working on an ultra-portable laptop or a computer 

with a small screen. You can double-click the active tab to hide the ribbon, 

but in most cases, you’re better off working with a split screen, as shown 

in Figure 1-16. 
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Figure 1-16. When you’re viewing two different parts of a single document, 

use the Split command; it leaves you more room to work than two separate 

windows, as shown in Figure 1-15. Each section of the split window has a 

scroll bar, so you can independently control different parts of your 

document. If you want to fine-tune your split, just drag the middle bar 

exactly where you want it. When you’re done, click Remove Split to return to 

a single screen view. 
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Viewing multiple windows 

One common reason for wanting to see two documents or more on your 

screen at once is so you can make line-by-line comparisons. Imagine you 

have two Word documents that are almost identical, but you have to find the 

spots where there are differences. A great way to make those differences 

jump out is to put both versions on your screen side by side and scroll 

through them. As you scroll, you can see differences in the paragraph lengths 

and the line lengths. Here are the commands to help you with the process: 

 View Side by Side (Alt+W, B). Click the View Side by Side 

command and Word arranges two windows vertically side by side. As 

you work with side-by-side documents, you can rearrange windows on 

your screen by dragging the very top of the Window frame. You can 

resize the windows by pointing to any edge of the frame. When you 

see a double arrow, just drag to resize the window. Synchronous 

Scrolling (described next) is automatically turned on. 

 Synchronous Scrolling (Alt+W, Y). The Synchronous Scrolling 

feature keeps multiple document windows in lock step. When you 

scroll one window, the other windows automatically scroll too. Using 

the same button or keystroke, you can toggle Synchronous Scrolling 

on and off as you work with your documents. 

 Reset Windows Position (Alt+W, T). If you’ve moved or 

resized your document windows as described earlier under View Side 

by Side, then you can click this button to reset your view so the 

windows share the screen equally. 

Saving and Closing Documents 

From the earliest days of personal computing, the watchword has 

been “save early, save often.” There’s nothing more frustrating than 

working half the day and then having the Great American Novel 

evaporate into the digital ether because your power goes out. So, here 



are some tips to protect your work from disasters human-made and 

natural: 

 Name and save your document shortly after you first create it. 

You’ll see the steps to do so later in this section. 

 Get in the habit of doing a quick save with Alt+F, S 

(think File Save) when you pause to think or get up to go to the kitchen 

for a snack. (Note for old-timers: Ctrl+S still works for a quick save 

too.) 

 If you’re leaving your computer for an extended period of time, 

save and close your document with Alt+F, C (think File Close). 

UP TO SPEED: WHERE ARE MY KEYBOARD SHORTCUTS? 

Ribbons, buttons, and menus are all well and good when you’re doing something new or 

complicated. But when you know where you’re going, a good keyboard shortcut can save 

time. Word 2007 has dozens of keyboard shortcuts. If you don’t have your favorites 

memorized, use the Alt key to reveal them. 

Press the Alt key, and you see small badges with letters and numbers pop up next to 

menus and buttons. These are your shortcuts. If you’re looking for the keyboard shortcut to 

close your document, follow these steps: 

1. Press and release the Alt key to show the keyboard shortcut badges. 

When you do this, the badges appear over menu items and ribbon buttons. (The Alt key 

acts as a toggle. If you change your mind and don’t want to use a shortcut, then press the 

Alt key again and you’re back in normal typing mode.) 

2. Press F to open the Office menu. 

Pressing F (which used to stand for File menu) does the same thing as clicking the button 

with your mouse, except that now it sports little keyboard shortcut badges. 

3. Press C to close your document. 



Looking at the bottom of the Office menu, you see the Close command. A small C badge 

indicates that pressing C closes your document. 

As you can guess, most keyboard shortcuts are based on the initial letter of the actual 

command words. This doesn’t always work out for popular letters. As a result, you have 

cases like the References tab, which has the keyboard shortcut S. 

Even if you don’t deliberately work to memorize the keyboard shortcuts, you’ll find that you 

begin to learn your favorites as you use them. Before long, your fingers will tap them out 

automatically. 

If a substantial portion of your brain is occupied by keyboard shortcuts from previous 

versions of Word, never fear. Most of those old commands still work—including Ctrl+B 

for Bold, Ctrl+N for new document, and F7 for spell checking. 

The Many Ways to Save Documents 

It’s the Microsoft Way to give you multiple ways to do most everything. 

Whether that’s because the company’s programmers believe in giving you 

lots of choices, or because they can’t make up their minds about the best way 

to do something is a question best left to the philosophers. But the point is, 

you do have a choice. You don’t have to memorize every keystroke, button, 

and command. Especially with saving, the important thing is to find a way 

you like and stick with it. Here’s a list of some ways you can save the 

document you’re working on: 

Saving by keyboard shortcut 

 Ctrl+S. If you’re an old hand at Word, this keyboard shortcut 

may already be burned in your brain. It still works with Word and other 

Office programs. This command quickly saves the document and lets 

you get back to work. 



 Alt+F, S. This keyboard shortcut does the exact same thing as 

Ctrl+S. Unlike Ctrl+S, though, you get visual reminders of which keys 

to press when you press the Alt key. See the box above. 

Saving by menu command 

 Office button → Save. If you don’t want to use keyboard 

shortcuts, you can mouse your way to the same place using menus. 

Like the options above, this command saves your file with its current 

name. 

 Office button → Save As. The Save As option lets you save 

your file with a new name (Figure 1-17). When you use this command, 

you create a new document with a new name that includes any 

changes you’ve made. (The individual steps are described in the next 

section.) 

 

Q6.b) Writes steps regarding followings  

 To change the font style  

 To change the font size  

 To change the font color  

 To highlight in yellow the line that reads “need to get IMS’s 

address”. 

 Ans. (a)To change the font style  

o Select the text you want to modify. 
o Select the Home tab and locate the Font group. 
o Click the drop-down arrow next to font style box. 
o Font style menu appears. 
o With a left click select the desired font style. 

    (b)To change the font size 

1.      Select the text or cells with text you want to change. To select all text in a Word 
document, press Ctrl + A. 

https://www.oreilly.com/library/view/word-2007-the/059652739X/ch01.html#word2007tmm-CHP-1-FIG-17


2. On the Home tab, click the font size in the Font Size box. You can also type in 
any size you want, within the following limits: 

(c)To change the font color  

To change the font color, follow the steps 

below. 

1. Highlight the text you want to change. 

2. Click the down arrow next to the color icon on the 

format bar or Ribbon. It is usually displayed as the 

letter "A" with a red underline, as shown in the 

example above. 

3. After clicking the down arrow for the color, select 

the color you want to make the text. 

Q7: Create a file in MS-Word for the following  

documents and save it with file name ms-word . 

Describe all steps involved in it . 

MS WORD  

MS WORD is widely used commercial word processor 

developed by Microsoft . 

MS Word is application software , which is capable of  

 Creating , 

 Editing , 

 Saving , 

 Printing any type of document  

          Ans. Creating – 

1. Open Microsoft Word. If you're not sure how to open or 

find Word, skip to the finding Microsoft Word section. 

2. In newer versions of Word, the first screen asks what 

type of Word document you want to create. Select the 

"Blank document" option to create a document from 

scratch. You can also select from one of the Word 

templates provided if you would like to create a specific 

type of document. 

https://www.computerhope.com/issues/ch001729.htm#findword


3. Once the blank document or template is open, any new 

information can be entered using a keyboard or on-screen 

keyboard. 

4. Once complete or while working on the document, you 

can Save through the File tab at the top of the Word 

program window.    

 Editing –   

 

Editing is the process of selecting and preparing writing, photography, visual, audible, 

and film media used to convey information. The editing process can involve correction, 

condensation, organization, and many other modifications performed with an intention of producing a 

correct, consistent, accurate and complete work.[1] 

The editing process often begins with the author's idea for the work itself, continuing as a 

collaboration between the author and the editor as the work is created. Editing can involve creative 

skills, human relations and a precise set of methods.[2][3] 

 

Editors work on producing an issue of Bild, West Berlin, 1977. Previous front pages are affixed to the wall 

behind them. 

There are various editorial positions in publishing. Typically, one finds editorial assistants reporting 

to the senior-level editorial staff and directors who report to senior executive editors. Senior 

executive editors are responsible for developing a product for its final release. The smaller the 

publication, the more these roles overlap. 

 Saving – 

than working half the day and then having the Great American Novel 

evaporate into the digital ether because your power goes out. So, here 

are some tips to protect your work from disasters human-made and 

natural: 

https://www.computerhope.com/jargon/k/keyboard.htm
https://www.computerhope.com/jargon/o/osk.htm
https://www.computerhope.com/jargon/o/osk.htm
https://en.wikipedia.org/wiki/Written_language
https://en.wikipedia.org/wiki/Photography
https://en.wikipedia.org/wiki/Image_editing
https://en.wikipedia.org/wiki/Audio_engineer
https://en.wikipedia.org/wiki/Film_editing
https://en.wikipedia.org/wiki/Editing#cite_note-1
https://en.wikipedia.org/wiki/Editing#cite_note-2
https://en.wikipedia.org/wiki/Editing#cite_note-2
https://en.wikipedia.org/wiki/Bild
https://en.wikipedia.org/wiki/West_Berlin
https://en.wikipedia.org/wiki/File:Editorial_office_of_Bild_newspaper,_West_Berlin,_1977.jpg


 Name and save your document shortly after you first create it. 

You’ll see the steps to do so later in this section. 

 Get in the habit of doing a quick save with Alt+F, S 

(think File Save) when you pause to think or get up to go to the kitchen 

for a snack. (Note for old-timers: Ctrl+S still works for a quick save 

too.) 

 If you’re leaving your computer for an extended period of time, 

save and close your document with Alt+F, C (think File Close). 

 Printing any type of document- 

1 
Open or create a Microsoft Word document. To do so, click on the blue app with a 
white document icon and bold "W," then click on File in the menu bar at the upper-left of 
the screen. Click on Open... to open an existing document or New... to create a new 
one. 

 When you are ready to print, open the Print dialog box. 

2 
Click on File. It's in the menu bar at the upper-left of the screen or a tab at the 

upper-left of the window.  

   3  

       Click on Print.... The Print dialog box will open.  

   4 Select your printing options. Use the selections in the dialog box to select: 

 Your default printer is displayed. Click on its name to select another printer from the 

drop-down menu. 

 The number of copies to print. The default is 1; increase the quantity to print more copies. 

 Which pages to print. The default is to print all the pages in the document, but you can 

choose to print the currently-displayed page, a highlighted selection, specific pages in 

the document, odd-numbered pages only, or even-numbered pages only. 

 The size of paper to print on. 

 The number of pages to print per sheet. 



 Orientation of the paper. Select either Portrait (paper length vertical, width horizontal) or 

Landscape (paper width vertical, length horizontal). 

 Margins. You can adjust the top, bottom, left, and right margins with the labeled up and 

down arrows or by typing numbers in the boxes. 

 

Q8. Create a file in MS-word for the following documents and save it with 

file name ‘equations’ .Describe all steps involved in it.  
EQUATIONS  

X2 + Y5  = 30  

Z3 + Q4  = 50  

A2 + B8 =  X2 + Y8
   

Ans.  
 

Q9. Create a file in MS-word that convert existing highlight text to table 

as shown below and save it as file name text _ to_ table_. Describe all 

steps involved in it . 

Select the text you want to convert .  

Select the insert tab  

Click on table command . A dialog box appears . 

Click on convert text to table a new dialog box appears  

Here set number of columns . 

Click on ok finally selected text convert in a table  

 

Select the text you want to text convert  Select the insert tab  

Click on table command . A dialog box appears  Click on convert text to table a new dialog box 

appears  

Here set number of columns . Click on ok finally selected text convert in a table  

 

1. Ans.  Insert separator characters—such as commas or tabs—to indicate where to divide 

the text into table columns. 

Note: If you have commas in your text, use tabs for your separator characters. 



2. Use paragraph marks to indicate where you want to begin a new table row. 

In this example, the tabs and paragraph marks will produce a table with 3 columns and 2 

rows: 

 

3. Select the text that you want to convert, and then click Insert > Table > Convert Text 

to Table. 

 

4. In the Convert Text to Table box, choose the options you want. 



 

Under Table size, make sure the numbers match the numbers of columns and rows you 

want. 

Under AutoFit behavior, choose how you want your table to look. Word automatically 

chooses a width for the table columns. If you want a different column width, choose one 

of these options: 

To do this Choose this option 

Specify a width for all the columns In the Fixed column 

width box, type or select a 

value. 

Resize the columns to fit the width of the text in each column AutoFit to contents 

Resize the table automatically in case the width of the available 

space changes (for example, web layout or landscape orientation) 

AutoFit to window 

Under Separate text at, choose the separator character you used in the text. 

5. Click OK. The text converted to a table should look something like this: 



 

Convert a table to text 

1. Select the rows or table you want to convert to text. 

2. Under Table Tools, on the Layout tab, click Convert to Text. 

 

3. In the Convert to Text box, under Separate text with, click the separator character you 

want to use in place of the column boundaries. Rows will be separated by paragraph 

marks. 

4. Click OK. 

Q10.   Create a file in MS-word to insert a table in the document. 

Describe all steps involved in it. 

Ans.     

1. Click on Table from the menu bar. Select Insert, and then Table… ... 

2. Enter the desired number of rows and columns. 

3. Choose AutoFit behavior if you want the table's cells to automatically expand to fit the 
text inside them. ... 

4. Click OK to insert your table. 

Q12. Calculate the following things of a range (c2:c11) of data in the 

worksheet created in question no 10. 

 The sun of the marks using auto sum In a range of cells (c2:c11)  



 Average of the marks in a range of cells (c2:c11) 

 Highest marks in a range of cells (c2:c11) 

 Minimum marks in a range of cells (c2:c11) 

The sun of the marks using auto sum In a range of cells (c2:c11)  

Ans. Use the SUM 

function to sum 

numbers in a range 
Excel for Microsoft 365 Excel for the web Excel 2019 Excel 

2016 Excel 2013 

You can use a simple formula to sum numbers in a 

range (a group of cells), but the SUM function is easier 

to use when you’re working with more than a few 

numbers. For example =SUM(A2:A6) is less likely to 

have typing errors than =A2+A3+A4+A5+A6. 

https://support.microsoft.com/en-us/office/use-excel-as-your-calculator-a1abc057-ed11-443a-a635-68216555ad0a
https://support.microsoft.com/en-us/office/sum-function-043e1c7d-7726-4e80-8f32-07b23e057f89


 

Here’s a formula that uses two cell 

ranges: =SUM(A2:A4,C2:C3) sums the numbers in 

ranges A2:A4 and C2:C3. You’d press Enter to get the 

total of 39787. 

To create the formula: 

1. Type =SUM in a cell, followed by an opening 

parenthesis (. 

2. To enter the first formula range, which is called 

an argument (a piece of data the formula needs to run), 

type A2:A4 (or select cell A2 and drag through cell A6). 

3. Type a comma (,) to separate the first argument from 

the next. 

4. Type the second argument, C2:C3 (or drag to select the 

cells). 

5. Type a closing parenthesis ), and then press Enter. 

Each argument can be a range, a number, or single cell 

references, all separated by commas. 

 =SUM(A2:A4,2429,10482) 



 =SUM(4823,A3:A4,C2:C3) 

 =SUM(4823,12335,9718,C2:C3) 

 =SUM(A2,A3,A4,2429,10482) 

Tip:  If you need to sum columns or rows of numbers next to each other, use AutoSum to sum 

numbers. 

Give it a try 

If you want to play around with our sample data, here’s 

some data to use. 

You can see how the SUM function works by copying 

the following table into a worksheet and pasting it into 

cell A1. 

Data   

-5 
  

15 
  

30   

'5 
  

TRUE   

Formula Description Result 

=SUM(3, 2) Adds 3 and 2. 5 

https://support.microsoft.com/en-us/office/use-autosum-to-sum-numbers-543941e7-e783-44ef-8317-7d1bb85fe706
https://support.microsoft.com/en-us/office/use-autosum-to-sum-numbers-543941e7-e783-44ef-8317-7d1bb85fe706


Data 
  

=SUM("5", 15, 

TRUE) 

Adds 5, 15 and 1. The text value "5" is first 

translated into a number, and the logical 

value TRUE is first translated into the 

number 1. 

21 

=SUM(A2:A4) Adds the values in cells A2 through A4. 40 

=SUM(A2:A4, 

15) 

Adds the values in cells A2 through A4, 

and then adds 15 to that result. 

55 

=SUM(A5,A6, 

2) 

Adds the values in cells A5 and A6, and 

then adds 2 to that result. Because non-

numeric values in references are not 

translated — the value in cell A5 ('5) and 

the value in cell A6 (TRUE) are both 

treated as text — the values in those cells 

are ignored. 

 

Q14:(a) What tools are available to customize our 
Powerpoint 

presentation? 

Ans. Customize presentation options and views 

 In Slide Master View. 

 Click on Slide Size. 

 Select from one of the two options. 



 For more choices, click Custom. 

 Select one of the options. 

 

15:Write steps for creation of set of PowerPoint slides that 
demonstrates your 

skill to use the tools of PowerPoint. It should include the 
following things 

 Title slide &amp; bullet list 

 Inserting Excel Sheet 

 Slide show effets 

 

Ans. PowerPoint is a highly innovative and versatile 
program that can ensure you a 

successful communication whether you’re presenting in 
front of potential investors, a 

lecture theatre or simply in front of your colleagues. Below 
are five features you 

should be using – if you aren&#39;t already. Learn 
everything about these tips: they will 

improve your presentation skills and allow you to 
communicate your message 



successfully. 

  

1) Adding Smart Art 

 

Don’t confuse SmartArt with the similarly named WordArt. 
Where WordArt just allows 

you to display text using a wide variety of different formats 
and effects, SmartArt is a 

comprehensive and flexible business diagram tool that 
greatly improves upon the 

‘Diagram Gallery’ feature found in previous versions of 
Office. 

Click the insert SmartChart Graphic to choose from a 
selection of options. 

SmartArt can be used to create professional diagrams that 
include pictures and text 

or combinations of the two. An obvious use of SmartArt 
would be to create an 

organisation chart but it can be used for many different 
kinds of diagrams and even 

to provide some variety to slides using text bullet points. 

  



2) Inserting Shapes 

 

If you need to include some sort of diagram in your 
presentation, then the quickest 

and easiest way is probably to use SmartArt. However, it 
is important to be able to 

include shapes independently of SmartArt and worth being 
familiar with the various 

Drawing Tool format options. 

Not only will they be useful if you do need to manually 
draw a diagram (and SmartArt 

doesn’t suit all diagrams), but they can also be applied to 
objects on a slide that you 

might not immediately think of as shapes. For example the 
box that contains your 

slide title or your content. This can be anything from text to 
a video, or even the 

individual shapes in a SmartArt diagram. 

 

As you can see, the gallery of available shapes is very 
extensive. Once you have 



selected your chosen shape, you can just click in your 
slide to insert a default 

version of the shape or, to set a particular size and 
position, click and drag with the 

mouse to create the shape and size you want.  

  

3) Inserting an Image  

 

Here are two content type icons which appear in new 
content Placeholders for 

inserting pictures. You can Insert Picture from File or 
Insert Clip Art. Alternatively, the 

Illustrations group of the Insert ribbon tab includes the 
same two tools. In 

addition, PowerPoint 2010 has a new ‘Screenshot’ option 
that allows you to capture 

 

an entire window or part of a window for inclusion on a 
slide. You can also copy any 

image and just paste it directly to a slide. 

Insert Picture from File allows you to browse to an image 
file saved somewhere on 



your system whereas Clip Art is held in an indexed gallery 
of different media types. 

Clip Art is not limited to pictures: ‘The Results should be:’ 
box lets you choose 

between: ‘All media file types’ and one or more of the 
following different types: 

 Illustrations 

 Photographs 

 Video 

 Audio 

Once you have found the image you want to use, click on 
it to insert it into the 

current slide. You can now re-size and move the image 
accordingly with further 

editting options available when you right click the desired 
image. 

  

4) Slide Transitions 

 

Properly used, slide transitions can be make your 
presentations clearer and more 



interesting and, where appropriate, more fun. Badly used, 
the effect of slide 

transitions can be closer to irritating or even nauseating. 
Simple animation effects 

 

are often used to add interest to bullet point text. Much 
more extreme animation 

effects are available but, in most cases, should be used 
sparingly if at all. 

Two main kinds of animation are available in a PowerPoint 
presentation: the 

transition from one slide to the next and the animation of 
images/text on a 

specific slide.  

In PowerPoint 2010 &amp; 2013 there is also a separate 
Transitions ribbon tab that 

includes a gallery of different transition effects. These can 
be applied to selected 

slides or all slides. If you want to apply different transition 
effects to different groups 

of slides, then you might want to choose ‘Slide Sorter’ 
view from the Presentation 

Views group of the View ribbon. 



  

5) Adding Animations 

 

Whereas the transition effects are limited to a single event 
per slide, animations can 

be applied to every object on a slide – including titles and 
other text boxes. Many 

objects can even have animation applied to different 
components, for example each 

shape in a SmartArt graphic, each paragraph in a text box 
and each column in a 

chart. Animations can be applied to three separate 
‘events’ for each object: 

Entrance – how the object arrives on the slide 

Emphasis – an effect to focus attention on an object while 
it is visible 

Exit – how the object disappears from the slide 

To apply an animation effect, choose the object or objects 
to be animated, then 

choose Animation Styles or Add Animation from the 
Animations toolbar. 



Where an animation is applied to an object with different 
components (for instance a 

SmartArt graphic made up of several boxes), the Effect 
Options tool becomes 

available to control how each component will be animated. 
So for example, your 

animation can be used to introduce elements of an 
organisation chart to your slide 

one by one. 

*** 

Filtered is an award-winning online training platform which 
personalizes 

learning material for each user. By asking users questions 
about their role, 

aspiration and proficiency, the platform’s machine learning 
algorithm is able to 

pinpoint skills gaps and filter out material that the user 
doesn’t need or already 

knows. This minimises time spent training, maximises the 
impact of learning 

and increases productivity. 

Over 800,000 users have studied our Microsoft and 
Business skills courses and 



our clients include many blue chip firms. We also have 
a learning 

recommendation engine - globalfilter - which connects 
content to learners 

 

based on role, career aspirations and organisational 
priorities, in less than 30 

seconds. 

 

CCA-101 :Fundamentals of IT &amp; Progrming 

 

Assignment-2 

 

Q1:What is the difference between Machine Language 
and high level 

Language? 

Ans. The difference is machine language executed directly 
by CPU whereas machine 

language is first converted to binary by the compiler and 
then executed by CPU. In this 



era, high-level language is widely used by programmers, 
because of their ease of 

code and that&#39;s easy to understand. 

Q2:Discuss about different data types of c programing 
Language. 

 

Ans. .56 seconds)  

Search Results 

Featured snippet from the web 

Data Types in C 

Data Type Memory (bytes) Format Specifier 

 

signed char 1 %c 

unsigned char 1 %c 

 

float 4 %f 

double 8 %lf 

Q3:Find the output of the following expressions 

(a)x=20/5*2+30-5 (b)y=30-(40/10+6)+10 (c)z=40*2/10-
2+10 



Ans.a) How to solve your question 

Your question is 

��=205⋅2+30−5 

 

x=\frac{20}{5} \cdot 2+30-5x=520⋅2+30−5 

Solve 

 

1 

 

Divide the numbers 

 

��=205⋅2+30−5 

 

x={\color{#c92786}{\frac{20}{5}}} \cdot 2+30-5x=520

⋅2+30−5 

 

��=4⋅2+30−5 

 

x={\color{#c92786}{4}} \cdot 2+30-5x=4⋅2+30−5 



2 

 

Multiply the numbers 

 

3 

 

Add the numbers 

Solution 

��=33 

(b) solve 

= 30-(4+6)+10 

=30-10+10 

=30 

Q4:Describe the syntax of the following statement 

(a)If-else statement (b) for loop (c)while loop 

Ans.(a) 

 

 More images 

If-then statements 



Featured snippet from the web 

The if/else statement executes a block of code if a 
specified condition is 

true. If the condition is false, another block of code can be 
executed. The if/else 

statement is a part of JavaScript&#39;s 
&quot;Conditional&quot; Statements, which are used to 
perform 

different actions based on different conditions 

(b) The for-loop follows four steps: 

1. Init. The init code runs once to set things up at the very 
start of the loop. ... 

2. Test. The boolean test is evaluated. ... 

3. Loop-body. If the test was true, the body runs once. ... 

4. Increment. Finally, the increment code executes just 
after the body, and then the 

program loops back to the test, (step 2). 

(c) The While Loop 

The while loop loops through a block of code as long as a 
specified condition 

is true. 



Syntax 

while (condition) { 

  // code block to be executed 

} 

Example 

In the following example, the code in the loop will run, over 
and over again, 

as long as a variable (i) is less than 10: 

Example 

while (i &lt; 10) { 

  text += &quot;The number is &quot; + i; 

  i++; 

 

} 

 

Try it Yourself » 

If you forget to increase the variable used in the condition, 
the loop will 

never end. This will crash your browser. 



 

The Do/While Loop 

The do/while loop is a variant of the while loop. This loop 
will execute the 

code block once, before checking if the condition is true, 
then it will repeat 

the loop as long as the condition is true. 

Syntax 

do { 

  // code block to be executed 

} 

while (condition); 

Example 

The example below uses a do/while loop. The loop will 
always be executed at 

least once, even if the condition is false, because the code 
block is executed 

before the condition is tested: 

Example 

do { 



  text += &quot;The number is &quot; + i; 

  i++; 

} 

while (i &lt; 10); 

 

Q5:Find the output of the following program segments 

 

(a) b) c) 

 

#include &lt;stdio.h&gt; 

Int main() 

{ 

Int I; 

For(i=1;i&lt;2;i++) 

{ 

Printf(“IMS 

Ghaziyabad\n”); 

} 

} 



 

#include &lt;stdio .h&gt; 

Int main () 

{ 

Int i=1; 

While(i&lt;=2) 

{ 

Printf(“IMS 

Ghaziyabad\n”); 

i=i+1; 

} 

} 

 

#include &lt;stdio .h&gt; 

Void main () 

{ 

Int a =10,b=100 

If(a&gt;b) 

Printf(“Largest number is 



%d\n”,a);else 

Printf(“Largest  

 

             

 

 

 

 

 

 

 

 

 

 

 

  

 

 

  



 

  



            


