
CCA-101: Fundamentals of IT & Programming 
 

Assignment -1 
1. Computer Block Diagram System: Mainly computer system consists of three parts, that 

are central processing unit (CPU), Input Devices, and Output Devices. The Central 

Processing Unit (CPU) is divided into two parts again: arithmetic logic unit (ALU) and 

the control unit (CU) 

2. Classification digital Computer based on size and Capability 

Based on size and capability, computers are broadly classified into 

a.                   Microcomputers(Personal Computer) 

 A microcomputer is the smallest general purpose processing system. The older pc started 

8 bit processor with speed of 3.7MB and current pc 64 bit processor with speed  of 4.66 

GB.  

Examples: -     IBM PCs, APPLE computers 

Microcomputer can be classified into 2 types : 

1.       Desktops 

2.       Portables 

The difference is portables can be used while travelling whereas desktops computers 

cannot be carried around. 

The different portable computers are: - 

1)         Laptop 

2)         Notebooks 

3)         Palmtop (hand held) 

4)         Wearable computers 

Laptop: - this computer is similar to a desktop computers but the size is smaller. They are 

expensive than desktop. The weight of laptop is around 3 to 5 kg. 

 
 

Notebook: - These computers are as powerful as desktop but size of these computers are 

comparatively smaller than laptop and desktop. They weigh 2 to 3 kg. They are more 

costly than laptop. 
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Palmtop (Hand held): - They are also called as personal Digital Assistant (PDA). These 

computers are small in size. They can be held in hands. It is capable of doing word 

processing, spreadsheets and hand writing recognition, game playing, faxing and paging. 

These computers are not as powerful as desktop computers. Ex: - 3com palmV. 

 
 

Wearable computer: - The size of this computer is very small so that it can be worn on 

the body. It has smaller processing power. It is used in the field of medicine. For example 

pace maker to correct the heart beats. Insulin meter to find the levels of insulin in the 

blood. 
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b).    Workstations:- It is used in large, high-resolution graphics screen built in network 

support, Engineering applications(CAD/CAM), software development desktop publishing 

Ex: Unix and windows NT. 

b)         Minicomputer: -         A minicomputer is a medium-sized computer. That is 

more powerful than a microcomputer. These computers are usually designed to serve 

multiple users simultaneously (Parallel Processing). They are more expensive than 

microcomputers. 

            Examples:        Digital Alpha, Sun Ultra. 

 
 

c)         Mainframe computers: - Computers with large storage capacities and very high 

speed of processing (compared to mini- or microcomputers) are known as mainframe 

computers. They support a large number of terminals for simultaneous use by a number 

of users like ATM transactions. They are also used as central host computers in 

distributed data processing system. 

            Examples: -     IBM 370, S/390. 
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d)         Supercomputer: -      Supercomputers have extremely large storage capacity and 

computing speeds which are many times faster than other computers. A supercomputer is 

measured in terms of tens of millions Instructions per second (mips), an operation is 

made up of numerous instructions. The supercomputer is mainly used for large scale 

numerical problems in scientific and engineering disciplines such as Weather analysis.  

            Examples: -     IBM Deep Blue 

 

 

 
3. Generation in computer terminology is a change in technology a computer is/was 

being used. ... Nowadays, generation includes both hardware and software, which 

together make up an entire computer system. There are five computer generations 

known till date. 

4. Volatile memory is the type of memory in which data is lost as it is powered-off. Non-

volatile memory is the type of memory in which data remains stored even if it is 

powered-off. ... Contents of Volatile memory is stored temporarily. Contents of 

Non-volatile memory is stored permanently 

5. They both differ in terms of their purpose and design. System software is 

meant to administer the system resources. It also serves as a kind of 

platform for running the application software. On the other hand, application 
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software is meant to enable the user to carry out some specific set of tasks or 
functions. 

6. Every Word project you create—whether it’s a personal letter, a 

TV sitcom script, or a thesis in microbiology—begins and ends 

the same way. You start by creating a document, and you end by 

saving your work. Sounds simple, but to manage your Word 

documents effectively, you need to know these basics and 

beyond. This chapter shows you all the different ways to create a 

new Word document—like starting from an existing document or 

adding text to a predesigned template—and how to choose the 

best one for your particular project. 

You’ll also learn how to work faster and smarter by changing your 

view of your document. If you want, you can use Word’s Outline view 

when you’re brainstorming, and then switch to Print view when you’re 

ready for hard copy. This chapter gets you up and running with these 

fundamental tools so you can focus on the important stuff—your 

words. 

7.Save a Word document in OpenDocument Text format 

1. Click the File tab. 

2. Click Save As. 

3. Click Browse, and then select the location where you want to save your file. 

4. In the Save as type list, click OpenDocument Text. 

5. Give your file a name, and then save it. 

8. Convert text to a table or a 

table to text 

Word for Microsoft 365 Outlook for Microsoft 365 Word 2019 Outlook 2019 More... 

javascript:


To convert text to a table or a table to text, start by clicking the Show/Hide paragraph 

mark on the Home tab so you can see how text is separated in your document. 

 

Convert text to a table 

Insert separator characters—such as commas or tabs—to indicate where to divide the 

text into table columns. 

Note: If you have commas in your text, use tabs for your separator characters. 

Use paragraph marks to indicate where you want to begin a new table row. 

In this example, the tabs and paragraph marks will produce a table with 3 columns and 2 

rows: 

 

Select the text that you want to convert, and then click Insert > Table > Convert Text 

to Table. 



 

9. In the Convert Text to Table box, choose the options you want. 

 



Under Table size, make sure the numbers match the numbers of columns and rows you 

want. 

Under AutoFit behavior, choose how you want your table to look. Word automatically 

chooses a width for the table columns. If you want a different column width, choose one 

of these options: 

To do this Choose this option 

Specify a width for all the columns In the Fixed column 

width box, type or select a 

value. 

Resize the columns to fit the width of the text in each column AutoFit to contents 

Resize the table automatically in case the width of the available 

space changes (for example, web layout or landscape orientation) 

AutoFit to window 

Under Separate text at, choose the separator character you used in the text. 

Click OK. The text converted to a table should look something like this: 

 

Convert a table to text 

Select the rows or table you want to convert to text. 

On the Layout tab, in the Data section, click Convert to Text. 

 



In the Convert to Text box, under Separate text with, click the separator character you 

want to use in place of the column boundaries. Rows will be separated by paragraph 

marks. 

Click OK. 

 

 

 

 

 

 

 

 

 

 

 

Windows 7 support has ended. Get all the features you know and love 

in Windows 10. 
Upgrade Now 

 

   

Need more help? 

Expand your Office skills 
EXPLORE TRAINING 
Get new features first 
JOIN OFFICE INSIDERS   

10. Answer 
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1. Open a blank Word document. 

2. In the top ribbon, press Insert. 

3. Click on the Table button. 

4. Either use the diagram to select the number of columns and rows you need, or click 
Insert Table and a dialog box will appear where you can specify the number of columns 
and rows. 

5. The blank table will now appear on the page. 

11. Every Excel grandmaster needs to start somewhere. In this 

chapter, you’ll learn how to create a basic spreadsheet. First, 

you’ll find out how to move around Excel’s grid of cells, typing in 

numbers and text as you go. Next, you’ll take a quick tour of the 

Excel ribbon, the tabbed toolbar of commands that sits above 

your spreadsheet. You’ll learn how to trigger the ribbon with a 

keyboard shortcut, and collapse it out of the way when you don’t 

need it. Finally, you’ll go to Excel’s backstage view, the file-

management hub where you can save your work for posterity, 

open recent files, and tweak Excel options. 
12. Formulas in Excel are basically mathematical expressions that use cell references (e.g., 

“A5”,” D17”) as arguments.  For example, a formula that adds the contents of cell E5 and E6 
could be written as follows: 

 

= E5+E6 

  

(Note: all formulas in Excel need to be preceded by an “=” sign.) If the values contained in 
E5 and E6 are 6 and 11, respectively, the formula will produce 17 as the value it displays. If 
you change E5 to 7, the result will automatically change to 18. 

13. This facilitates specialisation and coordination in the organisation. Following are 

the various ways of departmentalisation: (i) On the basis of functions:. 
14. Visme. Visme is a cloud-based presentation tool that allows you to create highly 

visual presentations to engage viewers and communicate your ideas. ... 

 Haiku Deck. Haiku Deck is a platform that prioritizes simplicity. ... 

 Pitcherific. ... 

 Canva. ... 

 SlideCamp. ... 

 Microsoft Events. ... 

 Powtoon. ... 



 VideoScribe. 

15. When you open PowerPoint, you’ll see some 

built-in themes and templates. A theme is a slide 

design that contains matching colors, fonts, and 

special effects like shadows, reflections, and more. 

On the File tab of the Ribbon, select New, and then 

choose a theme. 

PowerPoint shows you a preview of the theme, with 

four color variations to choose from on the right side. 

16. Machine language, or machine code, consists of binary code and is the only 
language that is directly understood by the computer. ... Both machine code 
and assembly languages are hardware specific. A high-level language is a 

programming language that uses English and mathematical symbols in its instructions. 
17. Data Types in C 

Data Types Bytes Range 

signed char 1 -128 to 127 

unsigned char 1 0 to 255 

float 4 1.2E-38 to 3.4E+38 

double 8 2.3E-308 to 1.7E+308 

18. (a)𝑥=205⋅2+30−5 

x={\color{#c92786}{\frac{20}{5}}} \cdot 2+30-5x=520⋅2+30−5 

𝑥=4⋅2+30−5 

(b) 𝑦=30−(4010+6)+10 



y=30-({\color{#c92786}{\frac{40}{10}}}+6)+10y=30−(1040+6)+10 

𝑦=30−(4+6)+10 

(c)𝑧=40⋅210−2+10 

z=\frac{{\color{#c92786}{40}} \cdot {\color{#c92786}{2}}}{10}-2+10z=1040⋅2−2+10 

𝑧=8010−2+10 

19. Looping Statements in C execute the sequence of statements 
many times until the stated condition becomes false. A loop in C 
consists of two parts, a body of a loop and a control statement. The 
control statement is a combination of some conditions that direct the 
body of the loop to execute until the specified condition becomes false. 
The purpose of the C loop is to repeat the same 

20. Find the output of the following program 
segments:(i) a = 110 

while a > 100: 
print(a) 
a -= 2 
(ii) for i in range(20,30,2): 
print(i) 
(iii) country = 'INDIA' 
for i in country: 
print (i) 
(iv) i = 0; sum = 0 
while i < 9: 
if i % 4 == 0: 
sum = sum + i 
i = i + 2 
print (sum) 
(v) for x in range(1,4): 
for y in range(2,5): 
if x * y > 10: 
break 
print (x * y) 
(vi) var = 7 
while var > 0: 



print ('Current variable value: ', var) 
var = var -1 
if var == 3: 
break 
else: 
if var == 6: 
var = var -1 
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