
 
Assignment -1 
 
Q1: What are the four fundamental parts of computer? Explain it with the help of diagram. 
Ans.  A computer has four main components: Input Units, the central processing unit or 

CPU, the Primary memory, and Output units. Input Unit - The devices to input 
information, such as a keyboard, and mouse 

 
Q2: Discuss about the classification of computers based on size and capacity. 
Ans. On the basis of size there are four types of computer.  

They are minicomputer, micro computer, mainframe computer and super computer. 

 
Q3: What is the meaning of computer generation? How many Computer Generations are 
defined? What technologies were/are used? 
Ans.  he generation term was used to distinguish between varying hardware technologies. 

Nowadays, generation includes both hardware and software, which together make up an 
entire computer system. There are five computer generations known till date.  

 First Generation (1940-1956) 

 Second Generation (1956-1963) 

 Third Generation (1964-1971) 

 Fourth Generation (1971-2010) 

 Fifth Generation (Present Day) 

 
Q4: Differentiate between Volatile & Non- Volatile memories. 
Ans. Volatile memory is computer storage that only maintains its data while the device is 

powered. ... Volatile memory contrasts with non-volatile memory, which does not lose 
content when power is lost. Non-volatile memory has a continuous source of power and 
does not need to have its memory content periodically refreshed. 
 
Q5: Distinguish among system software, application software and open source software on the 
basis of their features. 
Ans.  System software is used for operating computer hardware. On other hand Application 

software is usedby user to perform specific task. System software are installed on the 
computer when operating system is installed. On other hand Application software are installed 
according to user's requirements. 

 
Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with file name 
“yourself”. Describe all steps involved in it. 
Ans. Step 1: Open Ms word on your system. Step 2: Click on the new file when you open 

the word file when the dialog box appear. Step 3: Once this click on Blank doc under the 
recent section, it will get in bold or highlighted by default. Step 4: Click on the create A 
new blank doc will open. 
Then click ctrl+S, and save the document. 



 
Q6 b) Write steps regarding followings 

 

1. Ans. Select the text you want to modify. 

2. Select the Home tab and locate the Font group. 

3. Click the drop-down arrow next to font style box. 

4. Font style menu appears. 

5. With a left click select the desired font style 

 
 

1. Ans. Select the text that you want to modify. 

2. In Home tab locate the Font group. 

3. In Font group click the drop-down arrow next to font size box. 

4. Font size menu appears. 

5. Select the desired font size with a left click. 

6. Select the text and click the increase or decrease font size buttons. 

 
 

1. Ans. On the Home tab, in the Font group, choose the arrow next to Font Color, and 
then select a color. You can also use the formatting options on the Mini toolbar to 
quickly format text. 

 
 

 
Q7. Create a file in MS-Word for the following document and save it with file name ‘ms_word’. 
Describe 
all steps involved in it. 

1. Ans. Open Word. Or, if Word is already open, select File > New. 

2. In the Search for online templates box, enter a search word like letter, resume, or 
invoice. Or, select a category under the search box like Business, Personal, or 
Education. 

3. Click a template to see a preview. ... 

4. Select Create. 

SAVE THE DOCUMENTS : 

1. Click the File tab. 

2. Click Save As. 

3. Click Browse, and then select the location where you want to save your file. 

4. In the Save as type list, click OpenDocument Text. 

5. Give your file a name, and then save it. 

 
Q8. Create a file in MS-word for the following document and save it with file name ‘equations’. 
Describe 
all steps involved in it. 

1. Ans . Open Word. Or, if Word is already open, select File > New  

2. Then select Insert > Equation or press Alt + =. 



3. To use a built-in formula, select Design > Equation. 

4. To create your own, select Design > Equation > Ink Equation. 

5. Use your finger, stylus, or mouse to write your equation. 

6. Select Insert to bring your equation into the file. 

7. Click on file > save file  

8. Click Browse, and then select the location where you want to save your file. 

9. In the Save list, click OpenDocument Text. 

10. Give your file a name ‘equations’, and then save it. 

Q9. Create a file in MS-word that convert existing highlight text to table as shown below and save 
it as 
file name ‘text_to_table’. Describe all steps involved in it. 

Ans. To convert text to a table or a table to text, start by clicking 

the Show/Hide paragraph mark on the Hometab so you can see how text is separated in 

your document. 

1. Insert separator characters—such as commas or tabs—to indicate where to divide 

the text into table columns. 

2. Use paragraph marks to indicate where you want to begin a new table row. 

3. Select the text that you want to convert, and then click Insert > Table > Convert 

Text to Table. 

4. In the Convert Text to Table box, choose the options you want. 

5. Under Table size, make sure the numbers match the numbers of columns and 

rows you want. 

6. Under AutoFit behavior, choose how you want your table to look. Word 

automatically chooses a width for the table columns. 

7. Under Separate text at, choose the separator character you used in the text. 

8. Click OK. The text converted to a table should look something like this: 

 

SAVE THE DOCUMENTS : 

6. Click the File tab. 

7. Click Save As. 

8. Click Browse, and then select the location where you want to save your file. 

9. In the Save as type list, click OpenDocument Text. 

10. Give your file a name, and then save it. 

 
Q10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in it. 
The basic steps for creating a standard table in Microsoft Word (2013) are: 

1. Open a blank Word document 

2. In the top ribbon, press Insert 

3. Click on the Table button 



4. Either use the diagram to select the number of columns and rows you need, or 
click Insert Table and a dialog box will appear where you can specify the number of 
columns and rows. 

5. The blank table will now appear on the page. Alter it as necessary. Standard features 
like bold, italics, and underline are still available! These items may be helpful for creating 
headings or calling out certain items in the table. 

 
Q11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

 Ans.  How To Generate A List Of Sheet Names From A Workbook Without 

VBA 
1. 1. Go to the Formulas tab. 

2. 2. Press the Define Name button. 

3. 3. Enter SheetNames into the name field. 

4. 4. Enter the following formula into the Refers to field.  

5. =REPLACE(GET.WORKBOOK(1),1,FIND("]",GET.WORKBOOK(1)),"") 

6. 5. Hit the OK button. 

Save a worksheet 
1. 1. Right-click the worksheet name tab. 

2. 2. Click select Move or Copy. 

3. 3. Click on the Move selected sheets to Book drop-down menu. Select (new book). 

4. 4. Click OK. Your new workbook opens with your moved worksheet. ... 

5. 5. Click File > Save in your new workbook. File name is book1 

 
Q12. Calculate the following things of a range (C2:C11) of data in the worksheet created in 
question no. 10. 
(a) the sum of the marks using AutoSum in a range of cells (C2:C11) 

Ans.  If you need to sum a column or row of numbers, let Excel do the math for you. 

Select a cell next to the numbers you want to sum, 
 click AutoSum on the Home tab, press Enter, and you're done. When you click 
AutoSum, 
 Excel automatically enters a formula (that uses the SUM function) to sum the 
numbers. 
 
(b) average of the marks in a range of cells (C2:C11) 

Ans.  Use AutoSum to quickly find the average 

1. Click a cell below the column or to the right of the row of the numbers for which 
you want to find the average. 

2. On the HOME tab, click the arrow next to AutoSum > Average, and then press 
Enter. 

3.  

(c) highest marks in a range of cells (C2:C11) 

Ans. Calculate the smallest or largest number in a range 
1. Select a cell below or to the right of the numbers for which you want to find the 

smallest number. 

2. On the Home tab, in the Editing group, click the arrow next to AutoSum.  

3. click Min (calculates the smallest) or Max (calculates the largest), and then press 
ENTER. 



 
(d) minimum marks in a range of cells (C2:C11) 

Ans. Calculate the smallest number in a range 
1. Select a cell below or to the right of the numbers for which you want to find the 

smallest number. 

2. On the Home tab, in the Editing group, click the arrow next to AutoSum.  
3. click Min (calculates the smallest) or Max (calculates the largest), and then press 

ENTER. 
 
Q13 a) Describe various steps involved in the following 
 To modify column width of a worksheet 

Ans. Set a column to a specific width 
1. 1. Select the column or columns that you want to change. 

2. 2. On the Home tab, in the Cells group, click Format. 

3. 3. Under Cell Size, click Column Width. 

4. 4. In the Column width box, type the value that you want. 

5. 5. Click OK. 

 
orksheet 

Set a row to a specific height 
1. 1. Select the row or rows that you want to change. 

2. 2. On the Home tab, in the Cells group, click Format. 

3. 3. Under Cell Size, click Row Height. 

4. 4. In the Row height box, type the value that you want, and then click OK. 

 
 

 
Ans. If you don't need any of the existing cells, rows or columns, here's how 
to delete them: 

1. Select the cells, rows, or columns that you want to delete. 

2. Right-click, and then select the appropriate delete option 
3.  for example, Delete Cells & Shift Up, Delete Cells & Shift Left, Delete Rows, or 

Delete Columns. 
 
Q13 b) Describe following terms in the worksheet 
 

 
Ans. Relative and absolute references behave differently when copied and filled to other 

cells. Relative references change when a formula is copied to another cell. Absolute 
references, on the other hand, remain constant no matter where they are copied. 
 

 
Ans. A cell reference, or cell address, is an alphanumeric value used to identify a 

specific cell in a spreadsheet. Each cell address contains 'one or more letters' followed 
by a number. The letter or letters identify the column and the number represents the row 
 
Q14. a) What tools are available to customize our PowerPoint presentation? 

Ans.  Go to Slide Show > Custom Slide Show, and then select Custom Shows.  

In the Custom Shows dialog box, select New. Under Slides in presentation, 



click the slides that you want to include in the main custom show, and then click 
Add. 
 
Q14 b) Write the steps for the following action for creation of power point presentation 

 

Ans. When beginning a new project in PowerPoint, you'll often want to start 
with a new blank presentation. 

1. 1. Select the File tab to go to Backstage view. 

2. 2. Select New on the left side of the window, then click Blank Presentation. 

3. 3. A new presentation will appear. 

 
 

Ans. The following are the basic steps to save a presentation. 

1. Step 1 − Click on the File tab to launch the Backstage view and select Save. 

2. Step 2 − In the Save As dialog, type in the file name and click "Save". 

3. Step 3 − The default file format is . pptx. 

 
a Title to the first slide: the name of your college  

Ans. Use the Layout option to title a slide 
1. Select the slide whose layout you will change so that it can have a title. 

2. Click Home > Layout. 

3. Select Title Slide for a standalone title page or select Title and Content for a slide 
that contains a title and a full slide text box. ... 

4. Select the Click to add title text box. 

 
section 

 
Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to use 
the tools of PowerPoint. It should include the following things 

Ans. Create a presentation 

1. Open PowerPoint. 

2. In the left pane, select New. 

3. Select an option: To create a presentation from scratch, select Blank Presentation. 
To use a prepared design, select one of the templates. To see tips for using 
PowerPoint, select Take a Tour, and then select Create, . 

 
 

Ans.TITLE SLIDE :  The Title Slide layout is the default layout when you open a blank 

presentation in PowerPoint. It comprises two text placeholders: the first for the 
presentation title and the second for a subtitle. The Title Only layout is the same as a Title 
Slide except that it doesn't have a subtitle placeholder. 
 
BULLET LIST :  A bulleted list is an unordered list of items where every item has a 
graphical bullet. The bullets may be characters of different fonts, as well as graphical 
icons. Bulleted lists help the author structure the text in a better way - provide a list of 
application components, list of usage scenarios, etc. 
 

 
Ans. Hold down SHIFT, and then select the same number of existing sheet tabs of the 



worksheets that you want to insert in the open workbook. For example, if you want to add 
three new worksheets, select three sheet tabs of existing worksheets. On the Home tab, in 
the Cells group, click Insert, and then click Insert Sheet. 
 

  
Ans. Clip art (also clipart, clip-art) is a type of graphic art. ... However, most clip art today 

is created, distributed, and used in a digital form. Since its inception, clip art has evolved 
to include a wide variety of content, file formats, illustration styles, and licensing 
restrictions. 
 

 
Ans. Slide Effect is a presentation tool providing enhanced transitions and effects. 

Using a standard Presentation Software user interface, people can create slide 
presentation with movies and images in a simpler way than using a video editing software. 
 
Part -2 
 
Q16. What is the difference between Machine Language and High Level Language? 

Ans. We will now understand the differences between High-Level and Low-Level 
programming languages − 

High-Level Language Low-level language 

It can be considered as a programmer-
friendly language. 

It is considered as a machine-friendly 
language. 

It requires a compiler/interpreter to be 
translated into machine code. 

It requires an assembler that would 
translate instructions. 

It can be ported from one location to another. It is not portable. 

It is easy to understand. It is difficult to understand. 

It is easy to debug. It is difficult to debug. 

It is less memory efficient, i.e., it consumes 
more memory in comparison to low-level 
languages. 

It consumes less memory. 

 
Q17. Discuss about different data types of C programming Language. 

Ans.  Variables in C are associated with data type. Each data type requires an 
amount of memory and performs specific operations. 



There are some common data types in C − 

 int − Used to store an integer value. 

 char − Used to store a single character. 

 float − Used to store decimal numbers with single precision. 

 double − Used to store decimal numbers with double precision. 

The following table displays data types in C language − 

Data Types Bytes Range 

short int 2 -32,768 to 32,767 

unsigned short int 2 0 to 65,535 

unsigned int 4 0 to 4,294,967,295 

int 4 -2,147,483,648 to 2,147,483,647 

long int 4 -2,147,483,648 to 2,147,483,647 

unsigned long int 4 0 to 4,294,967,295 

signed char 1 -128 to 127 

unsigned char 1 0 to 255 

float 4 1.2E-38 to 3.4E+38 

double 8 2.3E-308 to 1.7E+308 

Here is the syntax of datatypes in C language, 

data_type variable_name; 

 
Q18. Find the output of the following expressions 
a) X=20/5*2+30-5  
Ans. X=33  



 
b) Y=30 – (40/10+6) +10  
Ans.  Y=30 
 
c) Z= 40*2/10-2+10 
Ans. Z=16 
 
Q19. Describe the syntax of the following statements 
a) If – else statement 
Ans. The if/else statement executes a block of code if a specified condition is true. If 

the condition is false, another block of code can be executed. The if/else statement is a 
part of JavaScript's "Conditional" Statements, which are used to perform different actions 
based on different conditions. 
 
 b) for loop 
Ans. The for/in statement loops through the properties of an object. The block of code 

inside the loop will be executed once for each property. ... for - loops through a block of 
code a number of times. for/in - loops through the properties of an object. 
 
 c) while loop  
Ans. A "While" Loop is used to repeat a specific block of code an unknown number 

of times, until a condition is met. For example, if we want to ask a user for a number 
between 1 and 10, we don't know how many times the user may enter a larger number, so 
we keep asking "while the number is not between 1 and 10". 
 
d) do-while loop 
Ans. iteration-statement: do statement while ( expression ) ; The expression in a do-while 

statement is evaluated after the body of the loop is executed. Therefore, the body of the 
loop is always executed at least once. The expression must have arithmetic or pointer 
type 
 
 
Q20. Find the output of the following program segments 
a) b) c) 
#include <stdio.h> 
int main() 
{ 
int i; 
for (i=1; i<2; i++) 
{ 
printf( "IMS Ghaziabad\n"); 
} 
} 
 
#include <stdio.h> 
int main() 
{ 
int i = 1; 
while ( i <= 2 ) 
{ 
printf( "IMS Ghaziabad\n"); 
i = i + 1; 



} 
} 
 
#include <stdio.h> 
void main() 
{ 
int a = 10, b=100; 
if( a > b ) 
printf( "Largest number is %d\n”, a); 
else 
printf( "Largest number is %d\n”, b); 


