
Q1. What are the four fundamental parts of a computer? Explain it with the help of diagram. 

Ans. The four fundamental parts of a computer are 

• Input Unit. 

• Output Unit. 

•  Processor (CPU). 

• Memory Unit. 

 

 

 

 

 

 

 

 

Input Device : Computer systems use many devices for input purpose. Input devices include the            

mouse, input pen, touch screen and microphone. Regardless of the type of device used, all are 

components for interpretation and communication between people & computer systems. 

 Output Devices : Output device is used to show the result of the instructions. Example: Monitor,      

Printer,      Headphones, etc. 

 Central Processing Unit (CPU) : It is the brain of the computer. Computer can not process without it. 

 Memory Unit : A memory unit is the collection of storage units or devices together. The memory unit          

stores the binary information in the form of bits. 

Q2. Discuss about the classification of computers based on size and capacity. 

Ans.   

1) Super Computer : Super Computer have thousands of processor because of their extra ordinary 

speed, accuracy and processing power, super computers are well suited for solving highly 

complex problems and huge amount of calculations. 

2) Mainframe Computer : Mainframe computers are very large often filling an entire room and 

can process thousands of millions of instructions per seconds. 

3) Minicomputers : Minicomputers are much smaller than mainframes. These computers are also 

less expensive. 

4) Microcomputers : Microcomputers are the most frequently used type of computer. It is also, 

known as Personal Computer (PC). 

Input  Device  Output Device Central Processing Unit 

Memory Unit 

Control Unit 

Arithmetic/Logic Unit 



 Q3. What is the meaning of computer generation? How many Computer Generations are defined? 

What technologies were/are used? 

Ans.  Computer generation is a change in technology a computer is/was being used. 

        Four Computer Generation are defined as; 

1) First Generation: Vacuum Tube (1940-1956) 

    The first computer system used vacuum tube for circuitry and magnetic drums for memory. 

Example: a) UNIVAC (Universal Automatic Computer) 

                    b) ENIAC (Electronic Numerical Integrator and Computer). 

   2) Second Generation; Transistors (1956-1963) 

                Transistor replaced vacuum tube in the second generation of computer. 

3) Third Generation; Integrated Circuits (1964-1971) 

    The development of the integrated circuit was the hallmark of the third generation of 

computers. 

4) Fourth Generation; Microprocessors (1971-Present) 

    The microprocessor brought the fourth generation of computers as thousands of integrated 

circuits were built onto a single silicon chip. 

         Microprocessor technology are used. 

 

Q4. Differentiate between Volatile & Non-Volatile memories. 

Ans.  

Volatile Memory  Non-Volatile Memory 

Volatile memory is a computer storage that only  
Maintains its data while the device is powered. 
                                         
Example:- Random Access Memory(RAM). 

It is a type of computer memory that has the 
capability to hold saved data even if the power is 
turn off. 
Example:-Read Only Memory(ROM). 

 

Q5. Distinguish among system software, application software and open source software on the basis of 

their features. 

Ans. -   System software 

It is a type of software that is designed to run a computer’s hardware and application programs. 

Application software 

It is a software created for a specific purpose, used by end users. It can be called an application or simply 

an application. 



Open Source Software 

It is a type of computer software in which source code is released under a license in which the copyright 

holder grants user’s rights to study, change and distribute the software to any one and for 

any purpose. 

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with file name 

‘’yourself’’. Describe all steps involved in it. 

Ans. The steps involved are: 

1) We click the Microsoft office button. 

2) We select the New. The New Document dialog box appears. 

3) We select blank document under the Blank and recent section. It will be the highlighted by 

default. 

4) We click Create. A new blank document appears in the Word window. 

5) We click the Microsoft office button. 

6) We select Save As (Ctrl + S) Word Document. The Save As dialog box appears. 

7) We select the location where we want to save the document using the drop-down menu. 

8) Then, we enter a name(yourself) for the document. 

9) And we click the save button. 

Q6. b) Write steps regarding followings 

➢ To change the font style 

➢ To change the font size 

➢ To change the font color 

➢ To highlight (in yellow) the line that reads ‘’need to get IMS’s address’’. 

Ans.  To format font style: 

We select the text we want to modify. 

• We click the Left drop-down arrow next to the font style box on the Home tab. 

The font style drop-down menu appears. 

• We move cursor over the various font style. A live preview of the font will 

appear in the document. 

• We click the Left button the font style we want to use. The font style will change 

in the document. 

To format font size: 

• We select the text we want to modify. 

• We click the Left button the drop-down arrow next to the font size box on 

the Home tab. The font size drop-down menu appears. 

• Move we cursor over the various font sizes. A live preview of the font size 

will appear in the document. 

• We click the left button the font size we want to use. The font size will 

change in the document.  



To format the font color: - 

• We select the text we want to modify. 

• We click the Left button the drop-down arrow next to the font color 

box on the Home tab. The font color menu appears. 

• Move our cursor over the various font colors. A live preview of the 

color will appear in the document. 

• We click the Left button the font color we want to use. The font color 

will change in the document. 

Your color choices aren’t limited to the drop-down menu the appears. 

Select more color at the button of the list to access the color dialog box. 

Choose the color we want, then click OK. 

To format the Highlight (in yellow) 

• We select the line that reads need to get IMS’S ADDRESS. 

• We click the highlight command and select the yellow color in the 

font group on the Home tab 

Q7. Create a file in MS-word to insert a paragraph above yourself and save it with file name ‘’yourself’’. 

Describe all steps  involved in it. 

 MS Word 

 MS Word is a widely used commercial word processor developed by Microsoft. 

 MS word is a application software, which is capable of  

• Creating, 

• Editing, 

• Saving, and 

• Printing any type of document 

Ans. - MS Word 

MS Word is a widely used commercial word processor developed by Microsoft. 

MS word is application software, which is capable of 

• creating, 

• editing, 

• saving, and 

• printing any type of document 

The steps involved are 

1. We click the Microsoft document dialog box appears. 

 



2. We select blank document under the blank and recent section. It will be the highlight 

default. 

3. We click create. A new blank document appears in the word window. 

4. We create the given documents the question. 

5. We select the text “MS word” and change the font size by clicking on the font size box on 

the Home tab. 

6. We select the text “MS word” to change the font color into red, by clicking on the font 

color menu. 

7. We select the “word processor” and under line by clicking the underline command in the 

font group on the Home tab. 

  

8. We select the text “MS word” to change the font style into the Italic by clicking Italic 

command. 

9. We select the text we want to format as a list and click the bullet commands on the Home 

tab. 

10. We change the font color of the text “creating and saving “into blue and red respectively, 

by clicking on the font color command, again we select the text “and” and click on strike 

through command. 

11. We select the text “printing any type of document “and change the font style into bold by 

clicking on the font style command.   

12. We save the file name as “MS word “by clicking the Microsoft office button and select 

save as. 

13. Then, we select the location where we want to save the document using the drop – down 

menu.      

14. We click the SAVE button. 

Q8. Create a file in MS-word for the following document and save it with file name ‘equations’. Describe 

all steps involved in it. 

 Equations                                                                                                                                                                                                                                   

X2 + Y5 = 30 

Z3 + Q4  = 50 

A2 + B8 = X2 + Y8 

Ans.  Equations 

                               X2   + Y5 = 30 

                              Z3   +   Q4 = 50 

                              A2    +   B8   = X2 + Y8  

 The steps involved are: -  

❖ We create given document in MS – word. 



❖ We select text where we want to format, and click on the subscript and superscript command 

on the home tab. 

❖ We save the file name as ‘equations’ by clicking the Microsoft office button and select save as. 

❖ We select the location where we want to save the document using the drop – down menu. 

❖ Then, we click ‘SAVE’ button  

Q9. Create a file in MS-word that convert existing highlight text to table as shown below and save it as 

file name ‘text_to_table’. Describe all steps involved in it. 

 Select the text you want to convert. 

 Select the Insert tab. 

 Click on Table command. A dialog box appears.  

 Click on Convert Text to Table, a new dialog box appears 

 here set number of columns. 

 Click on OK Finally Selected text convert in a table. 

Select the text you want to convert. Select the Insert tab. 

Click on Table command. A dialog box appears. Click on Convert Text to Table, a new dialog box 
appears 

Here set number of columns. Click on OK Finally Selected text convert in a table 

 

Ans.       Select the text you want to convert. 

                           Select the Insert tab. 

                           Click on Table command. A dialog box appears. 

                          Click on Convert Text to Table, a new dialog box appears. 

                          Here set number of columns. 

                         Click on OK Finally selected text convert in a table. 

                                                                                           

 

      Select the text you want to convert.       Select the Insert tab. 

      Click on Table command. A dialog box 
appears. 

      Click on Convert Text to Table, a new dialog 
box appears. 

      Here set number of columns.       Click on OK Finally Selected text convert in a 
table.   

 

 The steps involved in it are: - 

✓ We select the existing highlight text that we want to context. 



✓ We select the insert tab. 

✓ We click the table command. 

✓ We select the convert text to table from the menu. It’s dialog box appears. 

✓ We click OK. Then the text appears in a table. 

Q10. Create a file in MS-Word to Insert a table in the document. Describe all steps involve in it. 

Ans. Video provides a powerful way to help you prove your point. When you click Online Video, you can 

paste in the embed code for the video you want to add. You can also type a keyword to search online for 

the video that best fits your document. 

To make your document look professionally produced, Word provides header, footer, cover page, and 

text box designs that complement each other. For example, you can add a matching cover page, header, 

and sidebar. Click Insert and then choose the elements you want from the different galleries. 

          

          

          

          

          

          

          

          

 

Themes and styles also help keep your document coordinated. When you click Design and choose a new 

Theme, the pictures, charts, and SmartArt graphics change to match your new theme. When you apply 

styles, your headings change to match the new theme. 

Save time in Word with new buttons that show up where you need them. To change the way a picture 

fits in your document, click it and a button for layout options appears next to it. When you work on a 

table, click where you want to add a row or a column, and then click the plus sign. 

The Steps are: 

I. We place our cursor point in the document where we want the table to appear. 

II. We select the Insert Tap. 

III. We click the table. 

IV. We drag our mouse over the diagram square to select the no. of columns and rows in 

table. 

V. Left click the mouse and the tables appears in the document. 

VI. We enter the text into the table. 

Q11. Create a following worksheet in MS-excel and save it with name ‘book1’. 



 

Ans. 

           

Q12. Q12. Calculate the following things of a range (C2:C11) of data in the worksheet created in 

question no 

10. 

➢ the sum of the marks using AutoSum in a range of cells (C2:C11) 

➢ average of the marks in a range of cells (C2:C11) 

➢ highest marks in a range of cells (C2:C11) 

➢ minimum marks in a range of cells (C2:C11) 

 

Ans. 



                  

Q13.  a) Describe various steps involved in the following 

➢ To modify column width of a worksheet 

➢ To modify the row height of a worksheet 

➢ To delete rows and columns of a worksheet 

Ans.  A) 

➢ To modify column width of a worksheet: 

i.  Select a column or a range of columns. 

ii. Select a Home tab and in the Cells group, select Format. 

iii. Click on Column width and type the width for column. 

iv. Select OK. 

➢ To modify the row height of a worksheet. 

i. Select a row or a range of rows. 

ii. Select a Home tab and in the Cells group, select Format. 

iii. Click on Row Height and type the height of row. 

iv. Select OK. 

➢ To delete rows and column of a worksheet. 

i. Select the cell we want to delete within the column or row. 

ii. Select Home tab. And in cells group click on Delete Sheet Column or Row. 

                                    OR 

i. Select the desire row or column. 

ii. Right – click and select Delete. 

Q13. b) Describe following terms in the worksheet 

➢ Absolute reference and relative reference in formula 

➢ Cell address 



Ans. B)  

➢ Absolute Reference: 

An absolute reference in Excel means there is a fixed point of reference applied to a cell or a 

formula. This is so the return value will always stay no matter where the cell or formula moves 

to –within the same sheet or across different sheet. 

 

This refers to a fixed point of reference is a constant, and involves the use of dollar sign$ in the 

formula (i.e. Every is to receive the same bonus payout, so the amount $1500 is constant in this 

situation). 

                                                                   

                                                                 Microsoft Excel 

                                                            97-2003 Worksheet 

➢ Relative Reference: 

It is the default cell reference in Excel. It is simply the combination of column name and row 

number without any dollar ($) sign. When you copy the formula from one cell to another the 

relative cell address changes depending on the relative position of column and row. C1, D2,E4, 

etc. are examples of relative cell references. Relative references are used when we want to 

perform a similar operation on multiple cells and the formula must change according to the 

relative address of column and row.  

                            

                                                                          

                                                                        Microsoft Excel 

                                                                    97-2003 Worksheet 

➢ Cell Address: 

A cell address is a combination of column letter and a row number that identifies a cell on a 

worksheet. 

For example, A1 refers to the cell at the intersection of column A and row 1; B2 refers to the 

second cell in column b, and so on. 

               When used in formula, cell references help Excel find the values the formula should 

calculate. For instance, 

• To pull the value of A1 to another cell, you use this simple formula: 

                =A1 



• To add up the values in the cells A1 and A2, you use this one: 

               =A1+A2. 

Q14. a) What tools are available to customize our PowerPoint presentation? 

Ans. a) Tools available to customize our Power Point presentation are: 

                                  I. Prospector 

                                  ii. pivot viewer 

                                  iii. Autodesk 3DS Max 

                                  iv. Visual Bee PowerPoint Add-in 

                                  v. SmartArt 

                                  vi. Animi nation and Transition 

                                  vii. Wardle 

                                   viii. CA coo 

                                    ix. Oomph 

                                    x. Clip champ. 

Q14. b) Write the steps for the following action for creation of power point presentation 

➢ Open a Blank presentation 

➢ Save the presentation as Lab1.pptx 

➢ Add a Title to the first slide: the name of your college 

➢ Type your first name and last name in the Subtitle section 

➢ Add a New Slide which has a Title and Content 

Ans. 

❖  To open blank presentation: 

i. Open PowerPoint presentation using ‘Run ‘command (window key +R). 

ii. Select the ‘Blank Presentation’. It is opened. 

❖ Save the Presentation as Lab1.pptx.: 

i. Select the ‘File’ on Tab bar. 

ii. Click on ‘save As’ potion. 

iii. Click on document/Desktop as your choice. 

iv. Type the name ‘Lab1.pptx’. 

v. Click the ‘Save ‘button. 

❖ Add a Title to the first slide: the name of your college. 

I. Left click on the ‘Click to Add Title’ section on the first slide. 

II. Type the name of your college. 

❖ Type your first name and last name in the subtitle section: 

i. Left click on the ‘Click to Add Subtitle ‘section. 



ii. Type your first name and last name. 

❖ Add a New slide which has a Title and context. 

i. Select the Home tab. 

ii. Click on the dropdown button of the ‘New Slide’ on toolbar. 

iii. Select the slide having ‘Title and Content’. It is added. 

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to use 

the tools of PowerPoint. It should include the following things 

➢ Title slide &bullet list 

➢ Inserting Excel Sheet 

➢ Clip art and Text 

➢ Slide show effects 

Ans. 

➢  Title slide and bullet list: 

i. Open PowerPoint Presentation. 

ii. Select the Home tab. 

iii. Click at the dropdown button on ‘New Slide’ at toolbar. 

iv. Select the slide having Title slide and Bullet list. 

➢ Inserting Excel sheet: 

i. Open the slide where you want to insert the Excel Sheet. 

ii. Select the ‘Insert tab’. And click on ‘Object’ on tool bar. 

iii. Select the ‘Microsoft Excel Worksheet’ object type. 

iv. Click the ‘OK’ button. 

➢ ClipArt and Text: 

i. Select the Insert Tab. 

ii. Select the ‘Pictures’ or ‘Online pictures’ on tool bar. 

iii. Choose the appropriate art for the topic. 

iv. Click on the ‘Insert’ button. 

➢ Slide show effects: 

i. Select ‘Design Tab’ for Themes, Variants and Slide size. 

ii. Select ‘Transition Tab’ for Cut, Fade, Push, Wipe, Split, Reveal, Shape, Flash, etc. 

for slide effects. 

Q16. What is the difference between Machine Language and High Level Language? 

Ans.  

Machine Language High -Level Language 



  A computer programming language consisting  
of binary instructions which a computer can  
respond to directly. 
Example:-  (0,1)  

A high- level language is a programming language 
that enables to development of a program in a 
much more user-friendly programming context. 
Example:- English like language 

 

Q17. Discuss about different data types of C programming Language. 

Ans. The different type of C-programming language are as follows: - 

• Char--- The most basic data type in C-programming language. It stores a single character and 

requires a single byte of memory in almost all compilers. 

• Int. ------As the name suggests an int. variable is used to store an integer. 

• Float-----It is used to store decimal numbers (number with floating point value). 

• Double-----It is used to store decimal numbers (number with floating point value but its range of 

values is high in comparison to float. 

Q18. Find the output of the following expressions 

a) X=20/5*2+30-5 b) Y=30 – (40/10+6) +10 c) Z= 40*2/10-2+10 

Ans.    (a) 33.                          

    (b) 30.   

           (c) 16. 

Q19. Describe the syntax of the following statements 

a) If – else statement b) for loop c) while loop d) do-while loop 

Ans. (a) If……. else statement 

                                  If statement can be followed by an optional else block of statement, which executes  

                        When the Boolean expression is false. 

                        Syntax  

                        If (expression)    

                               { 

                                    True Block of statement; 

                                } 

                              Else 

                                { 

                                     Else Block of statements; 

                                  }  



 

(b) for loop statements: - 

o Looping statements allows us to execute a statement or group of statements multiple 

times. 

(c) while loop statements: 

o Basic syntax of while loop is as follows: 

          While(condition) 

                     Single statement; 

OR 

              While (condition) 

              { 

               Block of statements; 

               

(d) do while – loop statements: 

o Do…… while loop 

o Do ……while is just a while loop except that the test condition is checked at the end of the 

loop rather than the start. This has the effect that the body of the loop are always 

executed at least once. 

o Basic syntax of do …. While loop is as follows; 

           Do  

            { 

             Single statement 

                         Or  

              Block of statements 

            } while (condition); 

Q20. Find the output of the following program segments 

 

Ans.  a) IMS Ghaziabad. 



 

          b) IMS Ghaziabad, 

    IMS Ghaziabad. 

 

c) The largest number is 100. 

 

 

 

 

 

 


