
CCA-101: Fundamentals of IT & Programming 
 

Assignment -1 
 
 

Q1: What are the four fundamental parts of computer? Explain it with the help of diagram. 
Ans :- Basic organization of computer system includes input, processing unit, Memory Unit and output 

devices. 

 
 

Q2: Discuss about the classification of computers based on size and capacity. 
 

Ans :- Based on size and capacity, computers are classified as follows: 

I. Super Computers - Supercomputers are the most powerful and physically the largest by size. 

These are systems designed to process huge amounts of data and the fastest supercomputers can 

perform over one trillion calculations in a second. 

II. Mainframe Computer - Mainframe computers are very large often filling an entire room and 

can process thousands of millions of instructions per second. In a mainframe environment, users 

connect to the mainframe through the many terminals wired to the mainframe. 

III. Mini Computers - Minicomputers are much smaller than mainframes .These computers are also 

less expensive. Sometimes referred to as Midrange Server or Midrange Computer, they are 

typically larger, more powerful and more expensive than desktop computers. 

IV. Micro Computers - Microcomputers are the most frequently used type of computer. Also, 

known as Personal Computer (PC), a microcomputer is a small computer system designed to be 

used by one person at a time. 
 

Q3: What is the meaning of computer generation? How many Computer Generations are 

defined? What technologies were/are used? 

 

Ans :- The evolution of digital computing is often divided into generations. Each generation is 

characterized by dramatic improvements over the previous generation in the technology used to 

build computers, in terms of the internal organization of computer and programming languages. 

Five Generations of Computers: 

I. First Generation -  The first computer systems used vacuum tubes for circuitry and magnetic 

drums for memory. 



II. Second Generation - The world would see transistors replace vacuum tubes in the second 

generation of computers. 

III. Third Generation - Transistors were miniaturized and placed on silicon chips, called 

semiconductors, which drastically increased the speed and efficiency of computers. 

Instead of punched cards and printouts, users interacted with third generation computers through 

keyboards and monitors and interfaced with an operating system. 

IV. Fourth Generation - The microprocessor brought the fourth generation of computers, as 

thousands of integrated circuits were built onto a single silicon chip. 

V. Fifth Generation - Fifth generation computing devices, based on artificial 

intelligence, are still in development. 

Q4: Differentiate between Volatile & Non- Volatile memories. 

Ans :- Both volatile and non-volatile memories are types of computer memories. The volatile memory 
stores data and computer programs that the CPU may need in real-time, and it erases them once a user 
switches off the computer. Cache memory and RAM are types of Volatile memory. Non-volatile 
memory, on the other hand, is static. It remains in a computer even after a user switches it off. HDD 
and ROM are types of non-volatile memory. 

 

Q5: Distinguish among system software, application software and open source software on the 

basis of their features. 

 Ans :- System Software:  It is a type of software that is designed to run a computer's hardware 

and application programs. Software like operating systems, compilers, editors and drivers etc., 

come under this category. A computer cannot function without the presence of these. If we think 

of the computer system as a layered model, the system software is the interface between the 

hardware and user applications. 

 Application software: It is software created for a specific purpose, used by end users. It can 

be called an application or simply an app. Examples: word processor, accounting application, a 

web browser, an email client, media player etc. 

 Open-source software : It is a type of computer software in which source code is released 

under a license in which the copyright holder grants users the rights to study, change, and distribute the 

software to anyone and for any purpose. The Linux operating system(OS) is the best-known examples of 

open source software technology. 

 
Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with file name “yourself”. Describe 
all steps involved in it. 
 
Ans :- My name is Puja Pal. I am 31 years old. I live in Kolkata. I am a student of CCA course. I passed Madhyamik 
examination in the year of 2007 and Higher Secondary in the year 2009. 
 

 
 
 
 



Q6 b) Write steps regarding followings 
➢ To change the font style 
➢ To change the font size 
➢ To change the font color 
➢ To highlight (in yellow) the line that reads “need to get IMS’s address”. 

 

 

Ans : -  

 

To change font style - 
➢ Select the text you want to modify. 

➢ Click on font style box on the Home tab. The font style drop-down menu appears. 

➢ Move your cursor over the various font styles. 

➢ Left-click the font style you want to use. 

➢ Then font style will change in the document. 

 

To change the font size 
➢ Select the text you want to modify. 

➢ Left Click on increase font size and decrease font size commands on Home Tab. 

➢ Then font size will change in the selected document. 

 

To change the font color 
 
➢ Select the text you want to modify. 
➢ Click on the font color box on the Home tab. 
➢ The font color menu appears. 
➢ Move your cursor over the various font colors. 
➢ Left-click the font color you want to use. 

➢ Then font color will change in the document. 
 

 

To change Text Highlight color- 
➢ Select the text 

➢  Click on the Text Highlight color in font group on the Home tab. 

➢  Various colors will appears 

➢  Move your cursor over the various colors. 

➢  Click on color you want to use. 

➢  Then text highlight color will change in the document. 

 

 

Q7. Create a file in MS-Word for the following document and save it with file name ‘ms_word’. Describe 

all steps involved in it. 

 

Ans :- 



 
 

 

To strikethrough text – cross something out by 

drawing line through it 

➢ Select the text 

➢ Click on strikethrough in font group on the Home tab. 

➢ Then it will cross the selected text in the document. 

To change text as Bold: 

➢ Select the text you want to modify. 

➢ Click the Bold command in the Font group on the Home tab. 

➢ Then text will change in the document. 

 
To change the font color 
 
➢ Select the text you want to modify. 
➢ Click on the font color box on the Home tab. 
➢ The font color menu appears. 
➢ Move your cursor over the various font colors. 
➢ Left-click the font color you want to use. 

➢ Then font color will change in the document. 

 
 

Q8. Create a file in MS-word for the following document and save it with file name ‘equations’. Describe 

all steps involved in it. 
 

Ans :- 

 
 

  



Q9. Create a file in MS-word that convert existing highlight text to table as shown below and save it as 

file name ‘text_to_table’. Describe all steps involved in it. 

 

 
Q10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in it.  

 

 

  



Q11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

 
 

Q12. Calculate the following things of a range (C2:C11) of data in the worksheet created in question no 
10. 

 
 
➢ the sum of the marks using AutoSum in a range of cells (C2:C11) : =SUM(C2:C11) 
➢ average of the marks in a range of cells (C2:C11) : =AVERAGE(C2:C11) 
➢ highest marks in a range of cells (C2:C11) : =MAX(C2:C11) 
➢ minimum marks in a range of cells (C2:C11) : =MIN(C2:C11) 

 
Q13 a) Describe various steps involved in the following 
➢ To modify column width of a worksheet 
➢ To modify the row height of a worksheet 
➢ To delete rows and columns of a worksheet  

 



Ans :- To modify column width: 

➢ Position the cursor over the column line in the 

column heading, and a double arrow will 

appear. 

➢ Left-click the mouse, then drag the cursor to 

the right to increase the column 

➢ width or to the left to decrease the column 

width. 

➢ Release the mouse button. 

 

To modify the row height of a worksheet:  
 

➢ Click the Format command in the Cells group 

on the Home tab. A menu will appear. 

➢ Select Row Height to enter a specific row 

measurement. 

➢ Select AutoFit Row Height to adjust the row 

so all of the text will fit. 
 

To delete rows and columns of a worksheet  : 

➢ Select the row or column you’d like to delete. 
➢ Click the Delete command in the Cells group on the Home tab. 

 

 

➢ Q13 b) Describe following terms in the 
worksheet 

➢ Absolute reference and relative reference in formula 
➢ Cell address 

Ans :- Absolute reference :-  
Absolute cell references in a formula always refer to the same cell or cell range in a formula. If a formula is copied to 
a different location, the absolute reference remains the same. 
An absolute reference is designated in the formula by the addition of a dollar sign ($). It can precede the column 
reference or the row reference, or both. Examples of absolute referencing include. 
 

relative reference :- cell references in formulas automatically adjust to new locations when the formula 
is pasted into different cells. This is called a relative reference. 
 
 

 
Q14. a) What tools are available to customize our PowerPoint presentation? 
 Ans –  
➢ Templates and themes. 
➢ Slide layouts. 
➢ Fonts. 
➢ Color themes. 

 

Q14 b) Write the steps for the following action for creation of power point presentation 

➢ Open a Blank presentation 
Ans : 

1. Select Office button → New. The New Presentation window appears. 

2. In the left side of the New Presentation window, click Installed Templates. 

3. Click a template to select it. ... 



4. Click Create 

 

➢ Save the presentation as Lab1.pptx 
 

Locate and select the Save command on the Quick Access Toolbar. 
2.  saving the file for the first time, the Save As pane will appear in 
backstage view. 
3. choose where to save the file and give it a file name. 
4. The Save As dialog box will appear. 
 



➢ Add a Title to the first slide: the name of your college 

Ans : 

1. click on the Title, Subtitle, or Text placeholder. 
2. Type the text as you want. 
3. If necessary, press [Return] or [Enter] to move to a new line. 

4. Click anywhere on the slide outside of the placeholder to deselect it. 

 

➢ Type your first name and last name in the Subtitle section 
 

Ans :  

 

➢ Add a New Slide which has a Title and Content 
Ans : 1. On the Home tab, click the New Slide button in the Slides group. PowerPoint adds a blank slide to 

your presentation. 

or 

2. Press Ctrl+M. And again, PowerPoint adds a blank slide. 

or 

3. Right-click in the Slides or Outline tab on the left and then choose New Slide. And again, PowerPoint 

adds a blank slide. 
 

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to use 
the tools of PowerPoint. It should include the following things- 
Ans : - 

➢ Title slide &bullet list 
 

1. In PowerPoint, select the Home tab & Click the New Slide tab. 
2. Click the  Title slide 
For bullet list 
1. In PowerPoint, select the Home tab & Click the bullet list on paragraph tab. 
2. Click the  bullet type 
 

 

➢ Inserting Excel Sheet :  
1. In PowerPoint, select the Insert tab & Click the Insert tab. 
2. Click the Object command in the Text group. ... 
3. A dialog box will appear. ... 



4. Locate and select the desired Excel file, then click Insert. ... 
 

 

➢ Clip art and Text 
 

1. Click in the slide where you want to place the object. 
2. On the Insert tab, in the Text group, click Object. 
3. Click Create from File. 
4. In the File box, type the name of the file, or click Browse to select from a list. 
5. Select the Link check box. 
6. Press OK 
 

➢ Slide show effects 
To start the presentation at the first slide, in the Start Slide Show group, click From 

Beginning. 

For starting the presentation from where you are, click From Current Slide.) 

 

 
Part -2 

 
 

Q16. What is the difference between Machine Language and High Level Language? 
Ans :  
Machine Language : 
1. This language makes fast and efficient use of the computer. 
2. It requires no translator to translate the code. It is directly understood by the computer. 
 
High Level Language 
           
1. High level languages are programmer friendly. They are easy to write, debug and maintain. 

2. It provide higher level of abstraction from machine languages. 

3. It is machine independent language. 

4. Easy to learn. 
 

Q17. Discuss about different data types of C programming Language. 
 

Ans : C Data Types 
C  support almost the same set of data types, though Java supports additional data 
types. Data types supported in C programming languages − 
Type Keyword Value range which can be represented by this data type 
Character char -128 to 127 or 0 to 255 
Number int -32,768 to 32,767 or -2,147,483,648 to 2,147,483,647 
Small Number short -32,768 to 32,767 
Long Number long -2,147,483,648 to 2,147,483,647 
Decimal Number float 1.2E-38 to 3.4E+38 till 6 decimal places 

 
 

 


