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Q.1. What are the four fundamental parts of computer? Explain it with 

the help of diagram. 

Answer A computer can process data, pictures, sound and graphics. They 

can solve highly complicated problems quickly and accurately. 

A computer as shown in Fig.  performs basically five major 

computer operations or functions irrespective of their size and 

make. These are 

1) it accepts data or instructions by way of input, 

2) it stores data, 

3) it can process data as required by the user, 

4) it gives results in the form of output, and 

5) it controls all operations inside a computer. 

We discuss below each of these Computer operation 

1. Input:  

This is the process of entering data and programs in to the computer 

system. You should know that computer is an electronic machine like any 

other machine which takes as inputs raw data and performs some 

processing giving out processed data. Therefore, the input unit takes data 

from us to the computer in an organized manner for processing. 



2. Storage:  

The process of saving data and instructions permanently is known 

as storage. Data has to be fed into the system before the actual 

processing starts. It is because the processing speed of Central 

Processing Unit (CPU) is so fast that the data has to be provided 

to CPU with the same speed. Therefore, the data is first stored in 

the storage unit for faster access and processing. This storage unit 

or the primary storage of the computer system is designed to do 

the above functionality. It provides space for storing data and 

instructions. 

3. Processing:  

The task of performing operations like arithmetic and logical 

operations is called processing. The Central Processing Unit (CPU) 

takes data and instructions from the storage unit and makes all 

sorts of calculations based on the instructions given and the type 

of data provided. It is then sent back to the storage unit. 

4. Output:  

This is the process of producing results from the data for getting 

useful information. Similarly, the output produced by the 

computer after processing must also be kept somewhere inside the 

computer before being given to you in human readable form. 

Again, the output is also stored inside the computer for further 

processing. 

5. Control:  

The manner how instructions are executed and the above 

operations are performed. Controlling of all operations like input, 

processing and output are performed by control unit. It takes care 

of step-by-step processing of all operations inside the computer. 

 

  



Q.2:  Discuss about the classification of computers based on size and 

capacity. Classification of Computer Based on Size. 

Ans. Computers are classified on different parameters, such as, storage 

capacity, processing speed and component (CPU) used in computers. 

Depending upon the components used and features of different 

computers, they are classified into four groups, Microcomputers, 

Minicomputers, Mainframe computers and Supercomputers. 

 Micro Computers 

Micro Computer is a computer whose CPU (Central Processing Unit) is a 

microprocessor. All the components of a microprocessor are on a single 

integrated circuit chip. Micro computer can be categorized as the 

desktop, programmable and workstation. The microprocessor-based 

computers are called third generation computers. They are the backbone 

of the modern computer era. The first- and second-generation computers 

are based on vacuum tubes and bipolar junction transistors. 

Desktop Computers 

Desktop computer is a type of microcomputer. A desktop computer has a 

keyboard for input data, a LCD or CRT monitor to display information and 

Central processing unit tower contains storage, memory, different types 

of drives, such as, CD drive, hard drive, etc. A desktop computer is mainly 

used at home and office applications. 

 Programmable Computers (PDA) 

Personal digital assistance is a type of hand held programmable digital 

computer. It is used as notepads, address books and can connect to world 

web wave to share information. A PDA is equipped with mobile phone 

hence, called smallest computer. 

 Workstation 

A workstation computer has greater memory capability and more 

extensive mathematical abilities. It is connected with other workstation 



computers or personal computer to exchange data and mostly used for 

scientific applications. It also supports multitasking applications. 

 Mini Computers 

Minicomputers were introduced in early 1960s. They were faster than 

microcomputers. Basically, these computers were mainly multi-user 

systems, where many users work on the systems. Generally, these types 

of computers had larger memories and greater storage capacity. They had 

large instruction set and address field. These kinds of computers have 

efficient storage for handling of text, in comparison to lower bit machines. 

Due to more efficient processor, speed and memory size, minicomputer 

was used in variety of applications and could support business 

applications along with the scientific applications. Minicomputer was a 

multi-user system which means more than one user could use this system 

simultaneously. 

 Comparison of Micro and Mini computers 

 Features Microcomputer Minicomputer 

Primary memory  Shall memory Larger memory 

Word length  Small word length  Larger word length 

Cost low Low High 

Processor Low High 

  

Mainframe Computers 

Mainframe computers are large and expensive machines. The word 

length of mainframe computers may be 48, 60 or 64 bits, memory 

capacity being in some megabytes and storage capacity in some 

terabytes. Generally, they handle huge volumes of information and data. 

In terms of speed, they are having significant processing capacity. They 



are used in research organizations, large industries, airlines reservation 

where a large database has to be maintained. 

 Super Computers 

Super Computers are the fastest computer in current era. The processing 

capabilities of super computer lies in the range of GIPS2, word length 64-

128 or may be in 256 or so. The memory capacity of super computer is in 

some gigabytes or in terabytes. The storage capacity of this type of 

computer is in exabytes. 

The parallel processing of a super computer makes it very fast because it 

contains number of CPU that operates parallel. They are used at some 

research centres and government agencies involving sophisticated 

scientific and engineering tasks. 

 Super computers are used for the 

followings: 

• Weapons research and 

development 

• Nuclear and plasma physics 

• Rocket research and 

development 

• Atomic research 

• Aerodynamics 



Q.3:  What is the meaning of computer generation? How many Computer       

Generations are defined? What technologies were/are used? 

Ans. Generation of Computer – 

1. FIRST GENERATION – 

• Introduction: 

1. 1946-1959 is the period of first-generation computer. 

2. J.P. Eckert and J.W. Mauchy invented the first successful electronic 

computer called ENIAC, ENIAC stands for “Electronic Numeric 

Integrated and Calculator”. 

 

• Advantages: 

1. It made use of vacuum tubes which are the only electronic 

component available during those days. 

2. These computers could calculate in milliseconds. 

 

• Disadvantages: 

1. These were very big in size; weight was about 30 tones. 

2. These computers were based on vacuum tubes. 

3. These computers were very costly. 

4. It could store only a small amount of information due to the 

presence of magnetic drums. 

2. SECOND GENERATION – 

• Introduction: 

1. 1959-1965 is the period of second-generation computer. 

2. Second generation computers were based on Transistor instead 

of vacuum tubes. 

• Advantages: 

1. Due to the presence of transistors instead of vacuum tubes, the 

size of electron component decreased. This resulted in reducing 

the size of a computer as compared to first generation computers. 

2. Assembly language and punch cards were used for input. 

3. Low cost than first generation computers. 



4. Better speed, calculate data in microseconds. 

5. Better portability as compared to first generation 

• Disadvantages: 

1. A cooling system was required. 

2. Constant maintenance was required. 

3. Only used for specific purposes. 

3. THIRD GENERATION – 

• Introduction: 

1. 1965-1971 is the period of third generation computer. 

2. These computers were based on Integrated circuits. 

3. IC was invented by Robert Noyce and Jack Kilby In 1958-1959. 

4. IC was a single component containing number of transistors. 

• Advantages: 

1. These computers were cheaper as compared to second-

generation computers. 

2. They were fast and reliable. 

3. Use of IC in the computer provides the small size of the computer. 

4. IC not only reduce the size of the computer but it also improves 

the performance of the computer as compared to previous 

computers. 

5. This generation of computers has big storage capacity. 

• Disadvantages: 

1. IC chips are difficult to maintain. 

2. The highly sophisticated technology required for the 

manufacturing of IC chips. 

3. Air conditioning is required. 

4.  FOURTH GENERATION – 

• Introduction: 

1. 1971-1980 is the period of fourth generation computer. 

2. This technology is based on Microprocessor. 

3. A microprocessor is used in a computer for any logical and 

arithmetic function to be performed in any program. 



4. Graphics User Interface (GUI) technology was exploited to offer 

more comfort to users. 

• Advantages: 

1. Fastest in computation and size get reduced as compared to the 

previous generation of computer. 

2. Heat generated is negligible. 

3. Small in size as compared to previous generation computers. 

4. Less maintenance is required. 

5. All types of high-level language can be used in this type of 

computers. 

• Disadvantages: 

1. The Microprocessor design and fabrication are very complex. 

2. Air conditioning is required in many cases due to the presence of 

ICs. 

3. Advance technology is required to make the ICs. 

5.  FIFTH GENERATION – 

• Introduction: 

1. The period of the fifth generation in 1980-onwards. 

2. This generation is based on artificial intelligence. 

3. The aim of the fifth generation is to make a device which could 

respond to natural language input and are capable of learning and 

self-organization. 

4. This generation is based on ULSI (Ultra Large-Scale Integration) 

technology resulting in the production of microprocessor chips 

having ten million electronic components. 

• Advantages: 

1. It is more reliable and works faster. 

2. It is available in different sizes and unique features. 

3. It provides computers with more user-friendly interfaces with 

multimedia features. 

• Disadvantages: 

1. They need very low-level languages. 

2. They may make the human brains dull and doomed. 



Q.4:  Differentiate between Volatile & Non- Volatile memories. 

Ans. Below are the differences between volatile and non-volatile memory – 

S. Volatile Memory Non-Volatile Memory 

1. Volatile memory is the type of 

memory in which data is lost as it is 

powered-off. 

Non-volatile memory is the type of 

memory in which data remains 

stored even if it is powered-off. 

2. Contents of Volatile memory is 

stored temporarily. 

Contents of Non-volatile memory is 

stored permanently. 

3. It is faster than non-volatile 

memory. 

It is slower than volatile memory. 

4. RAM (Random Access Memory) is 

an example of volatile memory. 

ROM (Read Only Memory) is an 

example of non-volatile memory. 

5. In volatile memory, data can be 

easily transferred in comparison to 

non-volatile memory. 

In non-volatile memory, data 

cannot be easily transferred in 

comparison to volatile memory. 

6. In Volatile memory, process can 

read and write. 

In Non-volatile memory, process 

can only read. 

7. Volatile memory generally has less 

storage capacity. 

Non-volatile memory generally has 

more storage capacity than volatile 

memory. 



S. Volatile Memory Non-Volatile Memory 

8. In volatile memory, the program’s 

data are stored which are currently 

in process by the CPU. 

In non-volatile memory, any kind of 

data which has to be saved 

permanently are stored. 

9. Volatile memory is more costly per 

unit size. 

Non-volatile memory is less costly 

per unit size. 

10. Volatile memory has a huge impact 

on the system’s performance. 

Non-volatile memory has a huge 

impact on a system’s storage 

capacity. 

 

Q.5:  Distinguish among system software, application software and open-

source software on the basis of their features. 

Ans.  SYSTEM SOFTWARE – 

system software is a type of computer program that is designed to run a 

computer’s hardware and application programs. If we think of the 

computer system as a layered model, the system software is the interface 

between the hardware and user applications. The operating system (OS) 

is the best-known example of system software. The OS manages all the 

other programs in a computer. 

Other examples of system software include: 

• The BIOS (basic input/output system) gets the computer system 

started after you turn it on and manages the data flow between the 

operating system and attached devices such as the hard disk, video 

adapter, keyboard, mouse and printer. 



• The boot program loads the operating system into the computer's 

main memory or random-access memory (RAM). 

• An assembler takes basic computer instructions and converts them 

into a pattern of bits that the computer's processor can use to 

perform its basic operations. 

• A device driver controls a particular type of device that is attached to 

your computer, such as a keyboard or a mouse. The driver program 

converts the more general input/output instructions of the operating 

system to messages that the device type can understand. 

APPLICATION SOFTWARE – 

On other hand Application Software is the type of software which runs as 

per user request. It runs on the platform which is provide by system 

software. While in case of Application software high level language is used 

for their development as they are developed as some specific purpose 

software. 

On other hand Application software is used by user to perform specific 

task. On other hand Application software are installed according to user’s 

requirements. On other hand in application software user can interacts 

with it as user interface is available in this case. On other hand in 

application software can’t run independently. They can’t run without the 

presence of system software. On other hand some examples of 

application software’s are word processor, web browser, media player, 

etc. 

Q6.   a) Create a file in MS-word to insert a paragraph about yourself and save 

it with file name “yourself”. Describe all steps involved in it. 

Ans. Creating a New Document – 

When you start Word without opening an existing document, the 

program gives you an empty one to work in. If you’re eager to put words 

to page, then type away. Sooner or later, though, you’ll want to 

start another new document. Word gives you three ways to do so: 



Creating a New Blank Document – 

Say you want a new blank document, just like the one Word shows you 

when you start the program. No problem—here are the steps: 

• Choose Office button → New. 

The New Document dialog box appears. 

• In the upper-left corner of the large “Create a new Word document” 

panel, click “Blank document”  

The New Document box presents a seemingly endless number of options, 

but don’t panic. The “Blank document” option you want is on the left side 

of the first line. 

• At the bottom of the New Document dialog box, click Create. 

The dialog box disappears, and you’re gazing at the blank page of a new 

Word document. 



Saving and Closing Documents – 

From the earliest days of personal computing, the watchword has been 

“save early, save often.” There’s nothing more frustrating than working 

half the day and then having the Great American Novel evaporate into the 

digital ether because your power goes out. So, here are some tips to 

protect your work from disasters human-made and natural: 

• Name and save your document shortly after you first create it. You’ll see 

the steps to do so later in this section. 

• Get in the habit of doing a quick save with Alt+F, S (think File Save) when 

you pause to think or get up to go to the kitchen for a snack. (Note for old-

timers: Ctrl+S still works for a quick save too.) 

• If you’re leaving your computer for an extended period of time, save and 

close your document with Alt+F, C (think File Close). 

 

Saving by keyboard shortcut – 

• Ctrl+S. If you’re an old hand at Word, this keyboard shortcut may already 

be burned in your brain. It still works with Word and other Office 

programs. This command quickly saves the document and lets you get 

back to work. 



• Alt+F, S. This keyboard shortcut does the exact same thing as Ctrl+S. 

Unlike Ctrl+S, though, you get visual reminders of which keys to press 

when you press the Alt key. See the box above. 

Saving by Menu Command – 

• Office button → Save. If you don’t want to use keyboard shortcuts, you 

can mouse your way to the same place using menus. Like the options 

above, this command saves your file with its current name. 

• Office button → Save As. The Save As option lets you save your file with 

a new name. When you use this command, you create a new document 

with a new name that includes any changes you’ve made. (The individual 

steps are described in the next section.) 

 

Q.6: b) Write steps regarding followings – 

• To change the font style 

• To change the font size 

• To change the font colour 

• To highlight (in yellow) the line that reads “need to get IMS’s address”. 

Ans. To change the font style – 

1. Open a new or existing Microsoft Word document.  

2. Click the [Home] tab > Locate the "Font" group. 



3. From the lower-right corner of the "Font" group, click the small 

arrow. The "Font" dialog box will open. 

4. Choose the font style and size you would like Word to use by 

default (e.g., Times New Roman, Size: 12). 

5. Click [Set As Default] > Select "All documents based on the Normal 

template?" > Click [OK]. 

Ans.  To change the Font Size – 

1. Select the text or cells with text you want to change. To select all 

text in a Word document, press Ctrl + A. 

2. On the Home tab, click the font size in the Font Size box. 

To change the Font Colour – 

• Select the text that you want to change. 

• On the Home tab, in the Font group, choose the arrow next to Font 

Colour, and then select a colour. 

 



To highlight (in yellow) the line that reads “need to get IMS’s address” – 

 

IMS Ghaziabad 

 Address: National Capital Region, GT Road, Industrial Area, Lal 

Kuan, Ghaziabad, Uttar Pradesh 201009 

Phone: 0120 417 0600 

 

Q.7.    Create a file in MS-Word for the following document and save it with 

file name ‘ms_word’. Describe all steps involved in it. 

• Creating 

• Editing 

• Saving 

• Printing any type of document 

Ans.  

Create a blank document – 

• Open Word. Or, if Word is already open, select File > New. 

• Select Blank document. 



Edit a document in Word – 

Click Edit Document > Edit in Word for the web to make changes to a 

document. 

When you open a document from OneDrive, Word for the web displays it in 

Reading view. To make changes to your document, switch to Editing view, where 

you can add and delete content and do other things, such as: 

• Add tables and pictures. 

• Apply styles. 

• Adjust formatting. 

• Edit headers and footers. 

Saving a document in word – 

• Go to File > Save As. 

• Select OneDrive so you can get to your document from anywhere. 

o Save personal files to OneDrive - Personal, and work files to your 

company OneDrive. You can also save to another location in the list 

like This PC. 

• Enter a name, and select Save. 

Printing a document in Word –  

• Click File > Print. 

• To preview each page, click the forward and backward arrows at the 

bottom of the page. 

 



If the text is too small to read, use the zoom slider at the bottom of the 

page to enlarge it. 

 

• Choose the number of copies, and any other options you want, and 

click the Print button. 

 



Q8.  Create a file in MS-word for the following document and save it with file 

name ‘equations. Describe all steps involved in it. 

Equations: 

X2 + Y5 = 30 

Z3 + Q4 = 50 

A2 + B8 = X2 + Y8 

Ans.   

SUPERSCRIPT IN WORD – 

A superscript is a character, symbol or number set slightly above the 

normal line of text. It is always smaller than the usual font and is typically 

found in mathematical or scientific formulas. 

If you need a superscript in your Word document, here's how to go about 

it. 

1.  Place cursor where you want the Superscript to go - 

Click where you'd like the superscript to appear. If you already typed what 

you want in the superscript, highlight that number, character or symbol.  

2.  Click the X2 button - 

You can find the superscript button on the 'Home' tab. It's located near all 

the font options. 

 

Or you can use the keyboard shortcut: press Ctrl and Shift, then hit +.  



3.  Type your Superscript – 

Type whatever you want to be included in your superscript. It should 

immediately be set above the normal text line and be smaller. 

 

4.  Exit out of Superscript – 

If you keep typing, everything will remain in the superscript. To get out of 

that mode, click on the superscript button again (or use the keyboard 

shortcut Ctrl+Shift++ again). Now you should be able to type normally.  

SUBSCRIPT IN WORD – 

A subscript is a character, symbol or number set slightly below the normal 

line of text. It is always smaller than the usual font and is typically found 

in mathematical or scientific formulas. 

If you need a subscript in your Word document, here's how to do it.  

1.  Place cursor where you want the Subscript to go - 

Click where you'd like the subscript to appear. If you already typed what 

you want in the superscript, highlight that number, character or symbol.  

2.  Click the X2 button - 

You can find the subscript button on the 'Home' tab. It's located near all 

the font options. 

 



Or you can use the keyboard shortcut: press and hold Ctrl, then press =.  

3.  Type your Subscript - 

Type whatever you want to be included in your subscript. It should 

immediately be set above the normal text line and be smaller. 

 

4.  Exit out of Subscript - 

If you keep typing, everything will remain in the subscript. To get out of that 

mode, click on the subscript button again (or use the keyboard shortcut Ctrl+= 

again). Now you should be able to type normally. 

 

 

Q.9. Create a file in MS-word that convert existing highlight text to table as 

shown below and save it as file name ‘text_to_table’. Describe all steps 

involved in it. 

Ans. Convert text to a table or a table to text – 

To convert text to a table or a table to text, start by clicking 

the Show/Hide paragraph mark on the Home tab so you can see how text 

is separated in your document. 



 

Convert text to a table – 

1. Insert separator characters—such as commas or tabs—to indicate where 

to divide the text into table columns. 

2. Use paragraph marks to indicate where you want to begin a new table 

row. 

In this example, the tabs and paragraph marks will produce a table with 3 

columns and 2 rows: 

YELLOW GREEN BLUE 

YELLOW GREEN BLUE 

1. Select the text that you want to convert, and then 

click Insert > Table > Convert Text to Table. 



2. In the Convert Text to Table box, choose the options you want. 

Under Table size, make sure the numbers match the numbers of columns 

and rows you want. Under AutoFit behaviour, choose how you want your 

table to look. Word automatically chooses a width for the table columns. If 

you want a different column width, choose one of these options: 

Under Separate text at, choose the separator character you used in the 

text. 

3. Click OK. The text converted to a table should look something like this: 

 

Convert a table to text – 

1. Select the rows or table you want to 

convert to text. 

2. On the Layout tab, in the Data section, 

click Convert to Text. 

3. In the Convert to Text box, 

under Separate text with, click the 

separator character you want to use in 

place of the column boundaries. Rows will 

be separated by paragraph marks. 

4. Click OK. 

Q.10.  Create a file in MS-Word to insert a table in the document. Describe all 

steps involved in it. 

Ans. The basic steps for creating a standard table in Microsoft Word (2013) are: 



1. Open a blank Word document 

2. In the top ribbon, press Insert 

 3. Click on the Table button 

 

 

 

 

 

4. Either use the diagram to select the number of columns and rows you 

need, or click Insert Table and a dialog box will appear where you can 

specify the number of columns and rows. 

 

 

 

 

 

 

 

 

 

 



5. The blank table will now appear on the page. Alter it as necessary. 

Standard features like bold, italics, and underline are still available! These 

items may be helpful for creating headings or calling out certain items in 

the table. 

6. Follow these instructions for ensuring your table meets APA formatting 

guidelines. 

Q.11.  Create a following worksheet in MS-excel and save it with name 

‘book1’. 

Ans. Creating New Worksheet 

Three new blank sheets always open when you start Microsoft Excel. 

Below steps explain you how to create a new worksheet if you want to 

start another new worksheet while you are working on a worksheet, or 

you closed an already opened worksheet and want to start a new 

worksheet. 

Step 1 − Right Click the Sheet Name and select Insert option. 

Step 2 − Now you'll see the Insert dialog with select Worksheet option as 

selected from the general tab. Click the Ok button. 

 



 

 

Now you should have your blank sheet as shown below ready to start 

typing your text. 

You can use a short cut to create a 

blank sheet anytime. Try using 

the Shift+F11 keys and you will see 

a new blank sheet similar to the 

above sheet is opened. 

save it with name ‘book1’.  

 



Q.12.  Calculate the following things of a range (C2:C11) of data in the 

worksheet created in question no 10. 

• the sum of the marks using AutoSum in a range of cells (C2:C11) 

• average of the marks in a range of cells (C2:C11) 

• highest marks in a range of cells (C2:C11) 

• minimum marks in a range of cells (C2:C11) 

Ans.  

SUM – 

AVERAGE – 



Highest Marks – 

 

Minimum Marks – 

 

 



Q.13.  a) Describe various steps involved in the following – 

• To modify column width of a worksheet 

• To modify the row height of a worksheet 

• To delete rows and columns of a worksheet 

Ans. Modify column width of a worksheet – 

1. Select the column or columns that you want to change. 

2. On the Home tab, in the Cells group, click Format. 

 

3. Under Cell Size, click Column Width. 

4. In the Column width box, type the value that you want. 

5. Click OK. 

 

Modify the row height of a worksheet – 

1. Select the rows you want to modify. 

2. Click the Format command on the Home tab. The format drop-down 

menu appears. 

3. Select Row Height. 



 

1. The Row Height dialog box appears. Enter a specific measurement. 

 

 

 

2. Click OK. The selected rows heights will be changed in your 

spreadsheet 

To delete rows and columns of a worksheet – 

To delete rows: 

1. Select the rows you want to delete. 

 



2. Click the Delete command on the Home tab. 

 

3. The rows are deleted from your worksheet. 

 

To delete columns – 

1. Select the columns you want to delete. 

 



2. Click the Delete command on the Home tab. 

 

3. The columns are deleted from your worksheet. 

 

 

Q13. b)  Describe following terms in the worksheet 

• Absolute reference and relative reference in formula 

• Cell address 

Ans. There are two types of cell references: relative and absolute. Relative and 

absolute references behave differently when copied and filled to other 

cells. Relative references change when a formula is copied to another cell. 

Absolute references, on the other hand, remain constant no matter 

where they are copied. 



RELATIVE REFERENCES – 

By default, all cell references are relative references. When copied across 

multiple cells, they change based on the relative position of rows and 

columns. For example, if you copy the formula =A1+B1 from row 1 to row 

2, the formula will become =A2+B2. Relative references are especially 

convenient whenever you need to repeat the same calculation across 

multiple rows or columns. 

To create and copy a formula using relative references: 

In the following example, we want to create a formula that will multiply 

each item's price by the quantity. Rather than create a new formula for 

each row, we can create a single formula in cell D2 and then copy it to the 

other rows. We'll use relative references so the formula correctly 

calculates the total for each item. 

1. Select the cell that will contain the formula. In our example, 

we'll select cell D2. 

 

2. Enter the formula to calculate the desired value. In our 

example, we'll type =B2*C2. 



 

3. Press Enter on your keyboard. The formula will 

be calculated, and the result will be displayed in the cell. 

4. Locate the fill handle in the lower-right corner of the desired 

cell. In our example, we'll locate the fill handle for cell D2. 

 

5. Click, hold, and drag the fill handle over the cells you wish to 

fill. In our example, we'll select cells D3:D12. 



 

6. Release the mouse. The formula will be copied to the 

selected cells with relative references and the values will be 

calculated in each cell. 

 

You can double-click the filled cells to check their formulas for accuracy. 

The relative cell references should be different for each cell, depending 

on its row. 



 

ABSOLUTE REFERENCES – 

There may be times when you do not want a cell reference to change 

when filling cells. Unlike relative references, absolute references do not 

change when copied or filled. You can use an absolute reference to keep 

a row and/or column constant. 

An absolute reference is designated in a formula by the addition of 

a dollar sign ($) before the column and row. If it precedes the column or 

row (but not both), it's known as a mixed reference. 

 

You will use the relative (A2) and absolute ($A$2) formats in most 

formulas. Mixed references are used less frequently. 

When writing a formula in Microsoft Excel, you can press the F4 key on 

your keyboard to switch between relative, absolute, and mixed cell 

references, as shown in the video below. This is an easy way to quickly 

insert an absolute reference. 



To create and copy a formula using absolute references: 

In our example, we'll use the 7.5% sales tax rate in cell E1 to calculate 

the sales tax for all items in column D. We'll need to use the absolute cell 

reference $E$1 in our formula. Because each formula is using the same 

tax rate, we want that reference to remain constant when the formula is 

copied and filled to other cells in column D.  

1. Select the cell that will contain the formula. In our example, 

we'll select cell D3. 

 

2. Enter the formula to calculate the desired value. In our 

example, we'll type =(B3*C3)*$E$1. 

 



3. Press Enter on your keyboard. The formula will calculate, 

and the result will display in the cell. 

4. Locate the fill handle in the lower-right corner of the desired 

cell. In our example, we'll locate the fill handle for cell D3. 

 

5. Click, hold, and drag the fill handle over the cells you wish to 

fill, cells D4:D13 in our example. 

 

6. Release the mouse. The formula will be copied to the 

selected cells with an absolute reference, and the values 

will be calculated in each cell. 



 

You can double-click the filled cells to check their formulas for accuracy. 

The absolute reference should be the same for each cell, while the other 

references are relative to the cell's row. 

 

Be sure to include the dollar sign ($) whenever you're making an absolute 

reference across multiple cells. The dollar signs were omitted in the example 

below. This caused the spreadsheet to interpret it as a relative reference, 

producing an incorrect result when copied to other cells. 



 

 

CELL ADDRESS – 

The cell ADDRESS function is categorized under Excel Lookup and 

Reference functions. It will provide a cell reference (its “address”) by 

taking the row number and column letter. The cell reference will be 

provided as a string of text. The function can return an address in a 

relative or absolute format and can be used to construct a cell reference 

inside a formula. 

As a financial analyst, cell ADDRESS can be used to convert a column 

number to a letter, or vice versa. We can use the function to address the 

first cell or last cell in a range. 

  

FORMULA – 

=ADDRESS(row_num, column_num, [abs_num], [a1], [sheet_text]) 

 The formula uses the following arguments: 

1. Row_num (required argument) – This is a numeric value specifying the 

row number to be used in the cell reference. 



2. Column_num (required argument) – A numeric value specifying the 

column number to be used in the cell reference. 

3. Abs_num (optional argument) – This is a numeric value specifying the 

type of reference to return. 

4. 4. A1(optional argument) – This is a logical value specifying the A1 or R1C1 

reference style. In R1C1 reference style, both columns and rows are 

labeled numerically. It can either be TRUE (reference should be A1) or 

FALSE (reference should be R1C1).  

 When omitted, it will take on the default value TRUE (A1 style). 

5. Sheet_text (optional argument) – Specifies the sheet name. If we omit the 

argument, it will take the current worksheet. 

 How to use the ADDRESS Function in Excel? 

To understand the uses of the cell ADDRESS function, let us consider a few 

examples: 

Example 1: 

Suppose we wish to convert the following numbers into Excel column 

references: 

 

 The formula to use will be: 



 

 We get the results below: 

 

The ADDRESS function will first construct an address containing the column 

number. It was done by providing 1 for row number, a column number from B6, 

and 4 for the abs_num argument.  

After that, we use the SUBSTITUTE function to take out the number 1 and 

replace with “”. 

 Example 2: 

The ADDRESS function can be used to convert a column letter to a regular 

number, e.g., 21, 100, 126, etc. We can use a formula based on the INDIRECT 

and COLUMN functions. 

Suppose we are given the following data: 



 

 The formula to use will be: 

 

 We get the results below: 

 

 The INDIRECT function transforms the text into a proper Excel reference and 

hands the result off to the COLUMN function. Then, the COLUMN function 

evaluates the reference and returns the column number for the reference. 



 A few notes about the Cell ADDRESS Function: 

1. If we wish to change the reference style that Excel uses, we should go to 

the File tab, click Options, and then select Formulas. Under Working with 

formulas, we can select or clear the R1C1 reference style checkbox. 

2. #VALUE! error – Occurs when any of the arguments are invalid. We would 

get this argument if: 

o The row_num is less than 1 or greater than the number of rows in 

the spreadsheet; 

o The column_num is less than 1 or greater than the number of 

columns in the spreadsheet. 

 

Q.14.  a) What tools are available to customize our PowerPoint presentation? 

Ans. What’s on the ribbon tabs? 

The ribbon tabs group tools and features together based on their purpose. 

For example, to make your slides look better, look for options on the 

Design tab. The tools that you use to animate things on your slide would 

be on the Animations tab. 

Here’s a look at what you’ll find in each of the PowerPoint ribbon tabs. 

1. Home - 

 

The Home tab holds the Cut and Paste features, Font and Paragraph options, 

and what you need to add and organize slides. 



2. Insert - 

 

Click Insert to add something to a slide. This includes pictures, shapes, charts, 

links, text boxes, video and more. 

3. Design - 

 

On the Design tab, you can add a theme or colour scheme, or format the slide 

background. 

4. Transitions - 

 

Set up how your slides change from one to the next on the Transitions tab. Find 

a gallery of the possible transitions in the Transition to This Slide group – 

click More  at the side of the gallery to see all of them. 

5. Animations - 

 



Use the Animations tab to choreograph the movement of things on your slides. 

Note that you can see many possible animations in the gallery in the Animation 

group, and see more of them by clicking More  . 

6. Slide Show - 

 

On the Slide Show tab, set up the way that you want to show your presentation 

to others. 

7. Review - 

 

The Review tab lets you add comments, run spell-check, or compare one 

presentation with another (such as an earlier version). 

8. View - 

 

Views allow you to look at your presentation in different ways, depending on 

where you are in the creation or delivery process. 



9. File - 

At one end of the ribbon is the File tab, which you use for the behind-the-scenes 

stuff you do with a file, such as opening, saving, sharing, exporting, printing and 

managing your presentation. Click the File tab to open a new view called the 

Backstage. 

 

Click from the list on the side to do what you want to do; for example, 

click Print to find the options and settings for printing your presentation. Click 

Back  to return to the presentation that you were working on. 

10. Tools tabs – 

When you click some parts of your slides, such as pictures, shapes, SmartArt or 

text boxes, you might see a colourful new tab appear. 

 



In the example above, the Drawing Tools tab appears when you click a shape or 

text box. When you click a picture, the Picture Tools tab appears. Other such 

tabs include SmartArt Tools, Chart Tools, Table Tools and Video Tools. These 

tabs disappear or change when you click something else in your presentation. 

 

Q.14.  b) Write the steps for the following action for creation of power point 

presentation. 

• Open a Blank presentation 

• Save the presentation as Lab1.pptx 

• Add a Title to the first slide: the name of your college 

• Type your first name and last name in the Subtitle section 

• Add a New Slide which has a Title and Content 

 

Ans. To create a New Presentation: 

1. Select the File tab to go to Backstage view 

 

2. Select New on the left side of the window, then click Blank 

Presentation. 

 

3. A new presentation will appear. 



• Save the presentation as Lab1.pptx 

Step 1 −  Click on the File tab to launch the Backstage view and select Save. 

 

Step 2 −  In the Save As dialog, type in the file name and click "Save 

 

 

 



• Add a Title to the first slide: the name of your college - 

 

 

• Type your first name and last name in the Subtitle section - 

 

 

 



• Add a New Slide which has a Title and Content - 

 

 

Q.15.  Write steps for creation of a set of PowerPoint slides that demonstrates 

your skill to use the tools of PowerPoint. It should include the following 

things 

o Title slide &bullet list 

o Inserting Excel Sheet 

o Clip art and Text 

o Slide show effects 

Ans. Creating a simple bulleted list slide – 

• Inserting Excel Sheet 

 

 

https://sites.google.com/a/hojnacki.net/powerpoint/power-point/module-1-1/creating-a-new-presentation/topics/creating-a-new-slide/untitled2.JPG


4. In PowerPoint, on the Insert tab, click or tap Object. 

 

5. In the Insert Object dialog box, select Create from file 

 

 
 

6. Click or tap Browse, and in the Browse box, find the Excel 

workbook with the data you want to insert and link to. 

7. Before you close the Insert Object box, select Link, and click OK. 

 

• Clip art and Text 

Clip Art is a collection of media files (images, videos, audio, and 

animation files) that Microsoft includes with the PowerPoint 

application. If your computer has an Internet connection, then you 

can also access Bing.com to search for images. To insert clip art on 

a PowerPoint slide, follow the steps below. 



1. Click in the slide where you want to insert a clip art file. 

2. On the Insert tab, in the Images group, click Online Pictures. 

 

3. In the Insert Pictures dialog box (Clip Art task pane in PowerPoint 

2007/2010), enter your search terms in the Bing.com field and press 

Enter. 

 

4. Your search results load in the task pane. 

5. Locate the clip art you want to insert in your slide and double-click on it 

or click the item and select Insert. 

 

 

http://bing.com/
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