
 

 

 

Q1. What are the four fundament part of computer ? Explain it with the help of 

diagram. 

Ans : The four fundamental part of computer are :  

1. Input device  

2. Processor (CPU) 

3. Output device  

4. Backing storage 

 

1. Input Device : An input device is any hardware device that sends data to a 

computer, allowing you to interact it and control it. 

2. Output Device : An output device allowed data to transmitted in a human 

friendly form 

3. Processor : It is the portion of the computer that retriesves and execute 

instruction. 

4. Memory Unit : It is a component of a computer system . It is used to store 

data, instruction and information .  
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Q2. Discuss about the classification of computers based on size and capacity? 

Ans: Based on size and capacity , computers are classified as follows :  

1. Super Computers 

2. Mainframe Computers 

3. Mini Computers 

4. Micro Computer 

 

➢ 1. Super Computer : A super computer is the fastest type of computer . 

Supercomputer are very expensive and are employed for specialized 

applications that require large amounts of mathematical calculations 

Eg: JAGUAR,ROADRUNNER etc. 

 

➢ 2. Mainframe Computer : It is a very large often filling an entire room and 

can process thousands of millions of instructions per seconds . In a 

mainframe environment, users connect to the mainframe through the 

many terminals wired to the mainframe . They are capable of supporting 

humdred of thousands of user simultaneously. Eg: IBM mainframe, Z13,IBM 

system . 

➢ 3. Mini Computer : They are much smaller than mainframes. These 

computer are also less expensive . Sometime reffered to Midrange Server 

or Midrange Computer . They are typically larger, more powerful and more 

expensive than desktop computers. Users connect to the server through a 

network by using desktop computers . Eg: Apple ipod , CDC 160A. 

➢ Micro Computers : They are the most frequently used type of computers . 

It is also known as personal computer (PC) . A microcomputer is a small 

computer system designed to be used by one person at a time . Eg: Dekstop 

Computers, Laptops.  

 

 

 



 

 

Q3. What is the meaning of computer generation? How many computer 

generation are defined? What technologies were/are used? 

Ans : Generation is computer technology is a change in computer technology that 

is used: There are four generation in a computer: 

1. In the first computer system, vacuum tubes are used. 

2. Transistors are used in 2nd generation. 

3. Integrated Circuit Technology were used in 3rd generation. 

4. Microprocessors are used in the 4th generation. 

 

Q4. Difference between Volatile and Non – Volatile memories? 

Ans: Volatile Memories: 

1. It is a computer storage the only mountains its data while device is 

powered. 

2. Example: RAM 

3. Primary memory has limit storage capacity and its volatile. 

         Non – Volatile 

1. It is a type of computer memory that has the capacity to hold saved data if 

the power is turned off 

2. Example: ROM, Hard Disk etc. 

3. Secondary memory provides permanent storage of data and in bulk 

capacity. 

 Q5. Distinguish among system software , application software and Open – Source 

software on the basis of their features . 

Ans: 1) System Software: It is a type of software designed to that is designed to 

run a computer hardware and application software like operating system, editors 

and drivers etc. 

2) Application Software: It is a software created for a specific purpose, used by 

end users. It can be called application or simply an app. Example: Word Processor, 

Accounting application, Web browser an email client etc. 



 

 

3) Open – Source Software: It is a type of a computer software in which source 

code is released under a license in which the copyright holder grants users right to 

study, change and distribute the software to anyone and for any purpose. The 

Linux Operating System is the best example of Open – Source Software. 

 

Q6. A) Create a file in MS – Word to insert a paragraph about yourself and save it 

with file name “yourself”. Describe all step involved in it. 

B) Write steps regarding followings  

 To change the font style. 

 To change the font size. 

 To change the font color. 

 To highlight (in yellow) the line that reads need to get “IMS’s address” 

Ans: A) Created a file in MS – Word to insert a paragraph about yourself and save 

it with file name “yourself”. Describe all steps involved in it. B) Write steps 

regarding following *To change the font style*To change the font size*To change 

the font color*To highlight (in yellow) the line that reads need to get “IMS’s 

address” 

Ans: a) The steps involve are: 

I. We click the Microsoft office button. 

II. We select new. The new document dialog box appears. 

III. We select blank document under the blank page and recent select. It will be 

highlight by Default. 

IV. We click created. A new blank document appears in the word window. 

V. To save the document we click again the Microsoft office button. 

VI. We click Ctrl + S. The save as dialog box appears. 

VII. We select the location whereas went to save the document using the drop 

– down menu. 

VIII. We enter the file name “yourself” for the document. 

IX. We click the save button 

 

 



 

 

b) Steps to change the font size: 

1. We select the text or sentence we want to modify. 

2. We Left – Click the drop – down arrow next to the font color box on the 

Home – Tab. The font color menu appears. 

3. We move the cursor over the various font colors. A line preview of the color 

will appear in the document. 

4. We left click the font color we want to use. The font will change in the  

document. 

C) Steps to change the font color: 

1) We select text or sentence we want to modify. 

2) We left – click the drop – down arrow next to the font color box on the 

home tab. The font color menu appears. 

3) We move the cursor over the various font colors. A line preview of the color 

will appear in the document. 

4) We left click the font color we want to use. The font will change in the 

document. 

D) To highlight (in yellow) the line that reads “need to get IMS’s address” 

i. We select the line that reads need to get IMS’s address. 

ii. We click the highlight command and select yellow color in the font group in 

the Home Tab. 

 

Q7. Create a file in MS-Word for the following document and save it with file 

name “ms-word”. Describe all steps involved in it. 

       MS WORD 

       MS WORD is a widely used commercial word processor developed by 

Microsoft. 

        MS word is application software, which is capable of  

• Creating, 

• Editing, 

• Saving, and 



 

 

• Printing any type of document 

• Printing any type of document 

 Ans: MS Word 

MS Word is a wider used commercial word processor developed by Microsoft. 

MS word is application software, which is capable of  

• Creating 

• Editing 

• Saving 

• Printing any type of document 

 

The steps involved are: 

1. We click the Microsoft office button. 

2. We select new. The new document dialog box appears. 

3. We select blank document under the blank and recent section. It will be 

highlighted by default. 

4. We click create. A new blank document appears in the word window.  

5. We create the given document from the question. 

6. We select the text “MS word” to change the font size by clicking on the font 

sixe box on the home tab. 

7. We select the text “MS word” to change the font color into red by clicking on 

the font color menu. 

8. We select the text word processor and underline it by clicking the underline 

command in the font group the home tab. 

9. We select the text “MS word” to change the font style into italic by clicking 

italic command. 

10. We select the text we want to format as a list and click on the bullets 

command on the home tab. 



 

 

rence in Excel. It is simply the combination of column name and row number 

without any dollar $ sign. When you copy the formula from one cell to another 

the relative cell address changes depending on the relative position of column 

and row.C1, D2, E4, etc. are examples of relative cell references are used when 

we want to perform a similar operation on multiple cells the formula must change 

according to the relative address of column and row. 

This refers to a relative point of reference, is constantly changing and dollar sign 

($) is absent in the formula (i.e., when each unit price and quantity are deference 

variables, there’s no constant in the calculation. 

Cell Address: 11. We change the font color of the text “creating” and “saving” into 

blue and red resp. By clicking on the font color command, again we select the text 

“and” and click on strikethrough command. 

12. We select the text “printing any type of document” and change the font style 

into bold by clicking on the font style command. 

13. We save the file name as “ms word” by clicking the Microsoft Office button 

and select save as 

14. We select the location where we want to save the document using drop-down 

menu 

15. We click the save button. 

Q8. Create a file in MS-word for the following document and save it with file 

name ‘equation’. Describe all steps involved in it. 

     Equations 

      X2+y5 =30 

      Z3+Q4 =50 

      A2+B8 =X2+Y8 

Ans: Equations 

X2+Ys=30 

Z3+Q4=50 



 

 

A2+B8=X2+Y8 

The steps are: 

         1. We create the given documents in MS-word 

         2. We select the text where we want to format and click on the subscript and 

subscript command on the home tab 

         3. We save the file name as “equation” by clicking the Microsoft office 

button and select save as 

         4. We select location where we want to save the document using the drop 

down menu 

         5. We click the save button. 

Q9. Create a file in MS-word that convert existing highlight text to able as shown 

below and save it as file name ‘text_to_table’. Describe all steps involved in it. 

 

 

 

 

Select the text you want to convert. Select the Insert tab. 

Click on Table command. A dialog box 
appears. 

Click on Convert Text to Table, a new 
dialog box appears 

here set number of columns. Click on OK Finally Select text convert 
in a table 

 

Ans: To convert existing text to table: 

         1. We select the existing highlight text that we want to convert. 

         2. We select insert tab 

         3. We click the table command 

         4. We select convert text to table from the menu. A dialog box appears 

Select the text you want to convert 

Select the Insert Tab. 

Click on Table command. A dialog box appears. 

Click on Convert Text to Table, a new dialog box appears here set number of columns. 

Click on OK Finally Select text convert in a table. 

 



 

 

       5. We click ok. Then the text appears in a table. 

Q10. Create a file in MS-word to insert a table in the document. Describe all steps 

involved in it. 

Ans:  

          

          
          

          
          

          
          

 

The steps are:  

    1. We place our insertion point in the document where we want our table to 

appear 

    2. We select the insert tab 

    3. We click the table command 

    4. We drag our mouse over the diagram squares to select the number of 

columns and rows in the table. 

    5. Left click our mouse and the table appears in the document. 

    6. We enter the text into the table. 

Q11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

Roll 
No Name Marks 

1 n1 60 
2 n2 70 

3 n3 80 

4 n4 90 
5 n5 40 

6 n6 40 



 

 

    

 

 

 

 

 

 

 

Ans: 

sum 650 

average 65 

Maximum 90 
Minimum 40 

 

Q12. Calculate the following things of a range (C2:C11) of data in the worksheet 

create in question no 10. 

➢ The sum of the marks using AutoSum in a range of cells (C2:C11) 

➢ Average of the marks in a rage of cells (C2:C11) 

➢ Highest marks in a range of cells (C2:C11) 

➢ Minimum marks in a range of cells (C2:C11) 

 

 

 

 

1 n1 60 

2 n2 70 
3 n3 80 

4 n4 90 

7 n7 50 

8 n8 77 
9 n9 88 

10 n10 55 



 

 

5 n5 40 

6 n6 40 
7 n7 50 

8 n8 77 
9 n9 88 

10 n10 55 
 

 

Ans: 

sum 650 
average 65 

Maximum 90 
Minimum 40 

 

 

Q13. a) Describe various steps involved in the following 

➢ To modify column width of a worksheet 

➢ To modify the row height of a worksheet 

➢ To delete rows and columns of a worksheet 

Q13. b) Describe following terms in the worksheet  

➢ Absolute reference and relative reference in formula  

➢ Cell address 

Ans: a) to modify column width of a worksheet: 

I. Select a column or a range of column. 

II. Select a Home tab and in the Cells group, select Format. 

III. Click on Column width and type the width for column. 

IV. Select OK. 

           To modify the row height of a worksheet: 

I. Select a row or a range of rows. 



 

 

II. Select a Home tab and in the Cells group, select format. 

III. Click on Row height And type the height for now. 

IV. Select OK. 

           To delete rows and columns of a worksheet. 

I. Select the cell you want to delete within the column or row. 

II. Select home tab. And in cells group click on Delete Sheet Column or 

Row. 

                                OR 

I. Select the desire row or column. 

b): 

     Absolute Reference: 

      An absolute reference in excel means there is a fix point of reference applied 

to a cell or a formula. This is so the return value will always stay the same no 

matter where the cell or formula moves to – within the same sheet or across 

different sheet. 

 

This refers to a fix point of reference is a constant, and involves the use of dollar 

sign $ in the formula (i.e., everyone is to receive the same bonus payout, so the 

amount $1500 is constant in this situation). 

Absolute reference: 

It is the default cell refe 

A cell address is a combination of column letter and a row number that identifies 

a cell on a worksheet. 

For example, A1 refers to the cell at the intersection of column A and row 1;B2 

refers to the second cell in column B, and so on. 

           When used in formula, cell references help Excel find the value the formula 

should calculate. For instance, 

                   To pull the value of A1 to another cell, you use this simple formula: 



 

 

                     =A1 

                    To add up the value in cells A1 and A2, you use this one: 

                     =A1+A2 

Q14. A) What tools are available to customize our Power Point presentation? 

         B) Write the steps for the following action for creation of power point 

presentation 

➢ Open a Blank presentation 

➢ Save the presentation as Lab1.pptx 

➢ Add a Title to the first slide: the name of your college 

➢ Type your first name and last name in the Subtitle section 

➢ Add a New Slide which has a title and Content 

Ans:  

a) Tools available to customize our Power Point presentation are: 

a) Perspector 

b) Pivot viewer 

c) Autodesk 3DS Max 

d) VisualBee Power Point Add –in 

e) SmartArt 

f) Animation and Transition 

g) Wordle 

h) CA coo 

i) Oomfo 

j) Clip champ 

b) Ans: 

To open blank presentation: 

I.  Open Power point presentation using ‘Run’ command ( window key + R). 



 

 

II. Select the ‘Blank Presentation’. It is opened. 

Save the presentation on Lab1. pptx: 

I. Select the ‘File’ on tab bar. 

II. Click on ‘Save As’ option. 

III. Click on document/Desktop as your choice. 

- Add a Title to the first Slide: the name of your college. 

     I. Left click on the ‘Click to Add Title’ section on the first slide. 

      II. Type the name of your college. 

- Type your first name and last name in the subtitle section: 

     I. Left click on the ‘Click to Add Subtitle’ section. 

     II. Type your first name and last name. 

- Add a new slide which has a title and content: 

     I. Select the Home tab. 

     II. Click on the dropdown button of the ‘New Slide’ on toolbar. 

     III. Select the slide having ‘Title and content’. It is added. 

Q15. Write steps for creation o0f a set of Power Point slide that demonstrates 

your skill to use the tools of PowerPoint. It should include the following things 

➢ Title slide &bullet list 

➢ Insert Excel sheet 

➢ Clip art and Text 

Ans: 

➢ Title slide and bullet list: 

1. Open PowerPoint Presentation. 

2. Select the Home tab. 

3. Click at the dropdown button ‘New Slide’ at toolbar. 

4. Select the slide having Title slide and bullet list. 



 

 

➢ Insert Excel sheet: 

1. Open the slide where you want to insert the Excel sheet. 

2. Select the ‘Insert tab’. And click on ‘Object’ on tool bar. 

3. Select the ‘Microsoft Excel Worksheet’ object type. 

4. Click the ‘OK’ button. 

➢ Clip Art and text: 

1. Select the Insert tab. 

2. Select the ‘Pictures’ or ‘Online Pictures’ on tool bar. 

3. Choose the appropriate art for the topic. 

4. Click on the ‘Insert’ button. 

➢ Slide show effects: 

1. Select ‘Design Tab’ for Themes, Variants and Slide size. 

2. Select ‘ Transition tab’ for Cut, Fade, Push, Wipe, split, Reveal, Shape, 

Flash, etc. for slide effect. 

 

 

 

 

 

Q16. What is the Difference between Machine languages and High Level 

Languages? 

Ans: 

                    Machine Languages                                         High Level 

Languages 

                  

 

 

 

1. A computer programming languages 

consisting of binary instruction which a 

computer can respond to directly 

2. It requires no translator to translate 

the code. It is directly understood by 

the computer 

3. This languages makes fast and 

efficient use of the computer 

1. it is programming languages that 

enables development of a program in a 

much more user friendly programming 

context 

2. It takes additional translation time to 

translate the source code to machine 

code 

3. They are programmer friendly  



 

 

 

 

 

 

 

Q17. Discuss about data type of C programming Languages? 

Ans: The different data type in c programming Languages are: 

Char: the most basic data type in C. It store a single character and requires a 

single bite of memory in almost all compliers. 

Int: as the name suggest, and int variable is used to store an integer. 

Float: it is used to store decimal numbers. 

Double: it is used to store decimal numbers (number with floating point value but 

its range of value is high in comparison to float). 

Q18. Find the output of the following expressions? 

a) X=20/5*2+30-5     b) Y=30 – (40/10+6) + 10        c) Z=40*2/10-2+10 

Ans: a) x=33 

         b) Y=30 

         c) Z=16 

Q19. Describe the syntax of the following statements? 

a) If – else statement     b) for loop     c) white loop      d) do- while loop 

Ans: a) If – else statement: 

      If statement can be followed by an optional else block of statements, which 

executes when the Bootcan expression is false 

Syntax 

If (expression) 



 

 

{ 

True block of statements; 

} 

Else 

{ 

Else block of statement; 

} 

b) For loop is similar to while loop. Basic syntax of for loop is as follows: 

For (expression 1; expression 2; expression3) 

{ 

Block of statement 

} 

In the above syntax 

Expression 1- initializes variables. 

Expression 2- conditional expression as long as this condition is true, loop will 

keep executing. 

Expression 3- it is modifier which increase or decrease the value of the variable. 

c) While loop 

Basic syntax of while loop is as follows 

      While (condition) 

                      Single statements 

OR while (condition) 

{ 

Block of statements 

} 



 

 

d) Do- while loop. 

Do while loop is just like a while loop expert that the text condition is checked at 

the end of the loop rather than the start. This has the effect that the body of the 

loop are always executed at least once 

Basic syntax of do- while loop is as follows 

Do 

{ 

Single statement 

         Or 

Block of statements 

} while (condition) 

Q20. Find the output of the following program segments 

    a) b) c) 

#include <stdio.h> 
Int main() 
{ 
   Int 1; 
     For (i=1;i<2;i++) 
      { 
        Prinft(“IMS 
Ghaziabad\n”); 
        } 
    } 

#include<stdio.h> 
Int main() 
{ 
    Int i=1; 
    While (1<=2) 
{ 
     Prinft(“IMS 
Ghaziabad\n”); 
   } 
} 

#include<stdio.h> 
Void main() 
{ 
   Int a=10, b=100; 
   If(a>b) 
   Prinft(“Largest number 
is %d\n” ,a); 
             Else 
         Prinft(“Largest 
number is %d\n” ,b); 
} 

Ans: a) 1 

         b) 2 

         c) b=100 

 

   



 

 

 

          

    

 

 

 

 

 

 

 

 

 

 


