
                                      Assignment-1 

Q1: What are the four fundamental parts of computer? Explain it with the help of diagram. 

Ans-A computer has four main components: Input Units, the central processing unit or CPU, 

the Primary memory, and Output units. Input Unit - The devices to input information, such as 

a keyboard, and mouse 

2. Explain the Shielded twisted pair (STP) and Unshielded 

 Ans-Shielded twisted pair cable (STP) has the individual pairs of wires wrapped in foil, which 

are then wrapped again for double protection. Unshielded twisted pair cable (UTP) has each 

pair of wires twisted together. Those wires are then wrapped in tubing without any other 

protection. 

Q3: What is the meaning of computer generation? How many Computer Generations are 

defined? What technologies were/are used? 

 Ans-Initially, the generation term was used to distinguish between varying hardware 

technologies. Nowadays, generation includes both hardware and software, which together make 

up an entire computer system. There are five computer generations known till date. 

Q4: Differentiate between Volatile & Non- Volatile memories. 

Ans-Volatile memory is the type of memory in which data is lost as it is powered-off. Non-volatile 

memory is the type of memory in which data remains stored even if it is powered-off. 2. 

Contents of Volatile memory is stored temporarily 

Q5: Distinguish among system software, application software and open source software on the 

basis of their features. 

Ans-System Software is the type of software which is the interface between 

application software and system. Low level languages are used to write the 

system software. System Software maintains the system resources and gives 

the path for application software to run. An important thing is that without 

system software, system can not run. It is a general purpose software. 

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it 

with file name 

“yourself”. Describe all steps involved in it. 

 



Ans-Every Word project you create—whether it’s a personal letter, a TV sitcom script, or a thesis in 

microbiology—begins and ends the same way. You start by creating a document, and you end by saving 

your work. Sounds simple, but to manage your Word documents effectively, you need to know these 

basics and beyond. This chapter shows you all the different ways to create a new Word document—like 

starting from an existing document or adding text to a predesigned template—and how to choose the 

best one for your particular project. 

Q6 b) Write steps regarding followings 

 To change the font style 

To change the font type in a Microsoft Word document, follow the steps below. Highlight the 

text you want to change. Click the down arrow next to the font field on the formatting bar or 

Ribbon. (If you want to change the font to bold, italic, or underlined, click the B, I, or U on the 

format bar.) 

 To change the font size 

To change the font size of selected text in desktop Excel, PowerPoint, or Word: Select the text 

or cells with text you want to change. To select all text in a Word document, press Ctrl + A. On 

the Home tab, click the font size in the Font Size box. 

 To change the font color 

You can change the color of text in your Word document. Select the text that you want to 

change. On the Home tab, in the Font group, choose the arrow next to Font Color, and 

then select a color. 

 To highlight (in yellow) the line that reads “need to get IMS’s address”. 

Word 2016 comes with a digital highlighter pen that lets you mark up and colorize the text in 

your document without damaging the computer's monitor. To highlight text, abide by these 

steps: 

Q7. Create a file in MS-Word for the following document and save it with file name ‘ms_word’. Describe 

all steps involved in it. 

Ans-Every Word project you create—whether it’s a personal letter, a TV sitcom script, or a thesis in 

microbiology—begins and ends the same way. You start by creating a document, and you end by saving 

your work. Sounds simple, but to manage your Word documents effectively, you need to know these 

basics and beyond. This chapter shows you all the different ways to create a new Word document—like 

starting from an existing document or adding text to a predesigned template—and how to choose the 

best one for your particular project. 

Q8. Create a file in MS-word for the following document and save it with file name ‘equations’. Describe 



all steps involved in it. 

Ans-In this tutorial, I’m using a Mac so that's the interface you see. If you’re on Windows, the 

steps will be similar, albeit with different names for different applications and interfaces. For 

example, Finder on a Mac is either Windows Explorer or File Explorer on Windows, depending 

on which version you're using. 

Q9. Create a file in MS-word that convert existing highlight text to table as shown below and save it as 

file name ‘text_to_table’. Describe all steps involved in it. 

 

Ans- 9Insert separator characters—such as commas or tabs—to indicate where to divide the text 

into table columns. 

2-Use paragraph marks to indicate where you want to begin a new table row. 

In this example, the tabs and paragraph marks will produce a table with 3 columns and 2 

rows: 

 

3-Select the text that you want to convert, and then click Insert > Table > Convert Text 

to Table. 

Q10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in it. 

1. Click on Table from the menu bar. Select Insert, and then Table… ... 

2. Enter the desired number of rows and columns. 

3. Choose AutoFit behavior if you want the table's cells to automatically expand to fit the text 
inside them. ... 

4. Click OK to insert your table. 

Q11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

Ans-Every Excel grandmaster needs to start somewhere. In this chapter, you’ll learn how to create a 

basic spreadsheet. First, you’ll find out how to move around Excel’s grid of cells, typing in numbers and 
text as you go. Next, you’ll take a quick tour of the Excel ribbon, the tabbed toolbar of commands that 
sits above your spreadsheet. You’ll learn how to trigger the ribbon with a keyboard shortcut, and 
collapse it out of the way when you don’t need it. Finally, you’ll go to Excel’s backstage view, the file-
management hub where you can save your work for posterity, open recent files, and tweak Excel 
options. 

Q12. Calculate the following things of a range (C2:C11) of data in the worksheet created in question no 



10. 

 the sum of the marks using AutoSum in a range of cells (C2:C11) 

You can use a simple formula to sum numbers in a range (a group of cells), but the SUM 

function is easier to use when you’re working with more than a few numbers. For example 

=SUM(C2:C11) is less likely to have typing errors than =C2:C11) 

 average of the marks in a range of cells (C2:C11) 

 highest marks in a range of cells (C2:C11) 

Formulas in Excel are basically mathematical expressions that use cell references (e.g., “A5”,” 
D17”) as arguments.  For example, a formula that adds the contents of cell E5 and E6 could be 
written as follows: 

 minimum marks in a range of cells (C2:C11) 

 

Q13 a) Describe various steps involved in the following 

 To modify column width of a worksheet 

1. Select the column(s) you want to change. 
2. Home tab → Cells group → Format 
3. Cell size → Column Width 
4. Type the desired value. 

 To modify the row height of a worksheet 

Select cell, a format, a row height a height in numbers. Select cell, a format, a column width a 
width in numbers.Read more on Sarthaks.com - https://www.sarthaks.com/624141/explain-the-
steps-used-to-change-the-row-size-and-columns-width-in-a-worksheet 

 To delete rows and columns of a worksheet 

1. Select the cells, rows, or columns that you want to delete. 

2. Right-click, and then select the appropriate delete option, for example, Delete Cells & Shift Up, 
Delete Cells & Shift Left, Delete Rows, or Delete Columns. 

 

Q13 b) Describe following terms in the worksheet 

 Absolute reference and relative reference in formula 

https://support.microsoft.com/en-us/office/use-excel-as-your-calculator-a1abc057-ed11-443a-a635-68216555ad0a
https://support.microsoft.com/en-us/office/sum-function-043e1c7d-7726-4e80-8f32-07b23e057f89
https://support.microsoft.com/en-us/office/sum-function-043e1c7d-7726-4e80-8f32-07b23e057f89


By default, all cell references are relative references. When copied across multiple cells, 

they change based on the relative position of rows and columns. For example, if you 

copy the formula =A1+B1 from row 1 to row 2, the formula will 

become =A2+B2. Relative references are especially convenient whenever you need 

to repeat the same calculation across multiple rows or columns. 

 Cell address 

1) Cell 

2) Active Cell 

3) Cell Address 

4) Row and Column 

5) Spreadsheets and Workbook 

 

10 Thanks = Follow you in return 

15 Thanks = Follow you + 10 Thanks in return 

 

Q14. a) What tools are available to customize our PowerPoint presentation? 

Ans-PowerPoint presentation designers are termed ‘pro’ for one reason and that’s because they 
can transform an ordinary presentation into an enticing piece of information. Designers make a 
presentation stand out with attractive designs and eye-catching graphics. Ever wondered what 
tools that Powerpoint designers use to create magic in a presentation? Well, read on as we 
discuss them. 

Q14 b) Write the steps for the following action for creation of power point presentation 

 Open a Blank presentation 

A template is a predesigned presentation you can use to create a new slide show 

quickly. Templates often include custom formatting and designs, so they can save you 

a lot of time and effort when starting a new project. 

 Save the presentation as Lab1.pptx 

1. On the File tab, choose Save. 

2. Pick or browse to a folder. 

3. In the File name box, type a name for your presentation, and then choose Save. 

 

 Add a Title to the first slide: the name of your college 

https://www.stinsondesign.com/services


▪ Create presentations from scratch or a template. 

▪ Add text, images, art, and videos. 

▪ Select a professional design with PowerPoint Designer. 

▪ Add transitions, animations, and motion. 

▪ Save to OneDrive, to get to your presentations from your computer, tablet, or phone. 

▪ Share and work with others, wherever they are. 

 

 Type your first name and last name in the Subtitle section 

 

 

 Add a New Slide which has a Title and Content 

1. In the thumbnails on the left pane, select the slide you want your new slide to follow. 

2. In the Home tab, in the Slides section, select New Slide. 

3. In the Slides section, select Layout, and then select the layout you want from the menu. 

 

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to use 

the tools of PowerPoint. It should include the following things 

 Title slide &bullet list 

1. On the slide, select the lines of text in a text placeholder or table that you want to add bullets or 

numbering to.&You can use bulleted or numbered lists to help organize your text or show a 

sequential process in your PowerPoint presentation. 

 Inserting Excel Sheet 

In PowerPoint, on the Insert tab, click or tap Object. In the Insert Object dialog box, select 
Create from file. Click or tap Browse, and in the Browse box, find the Excel workbook with the 
data you want to insert and link to. Before you close the Insert Object box, select Link, and click 
OK. 

 Clip art and Text 

Clip Art is a collection of media files (images, videos, audio, and animation files) that Microsoft 
includes with the PowerPoint application. If your computer has an Internet connection, then you 
can also access Bing.com to search for images. To insert clip art on a PowerPoint slide, follow 
the steps below. 



 Slide show effects 

On the Home tab, click the bottom half of New Slide, and pick a slide layout. 

 

Q16. What is the difference between Machine Language and High Level Language? 

High-level language 

• It can be easily interpreted as well as compiled in comparison to low-level language. 

• It can be considered as a programmer-friendly language. 

• It is easy to understand. 

• It is easy to debug. 

• It is simple in terms of maintenance. 

• It requires a compiler/interpreter to be translated into machine code. 

• It can be run on different platforms. 

• It can be ported from one location to another. 

• It is less memory efficient, i.e it consumes more memory in comparison to low-level 
languages. 

• Examples of high level languages include C, C++, Java, Python. 

• It is used widely in today's times. 

Q17. Discuss about different data types of C programming Language. 

• int – This data type is used to define an integer number (-…. -3,-2,-1,0,1,2,3….). ... 

• char – Used to define characters. A single character occupy 1 byte. 

• float – Used to define floating point numbers (single precision). ... 

• double – Used for double precision floating point numbers(double precision 

 

    Q18. Find the output of the following expressions 

a) X=20/5*2+30-5 b) Y=30 – (40/10+6) +10 c) Z= 40*2/10-2+10 
x=33                         y=30            Z=16 

 

Q19. Describe the syntax of the following statements 

a) If – else statement 

If condition returns true then the statements inside the body of “if” are executed 
and the statements inside body of “else” are skipped. If condition returns false then 
the statements inside the body of “if” are skipped and the statements in “else” are 
executed.  

b) for loop  

The initialization statement describes the starting point of the loop, where the loop 
variable is initialized with a starting value. A loop variable or counter is simply a 



variable that controls the flow of the loop. The test expression is the condition until when 
the loop is repeated.  

c) while loop  

o { statements } while (expression); As we saw in a while loop, the body is executed if 
and only if the condition is true. In some cases, we have to execute a body of the loop at 
least once even if the condition is false.  

c) do-while loop 

The syntax is: do { statements } while (condition); Here's what it does. First, the 
statements are executed, then the condition is tested; if it is true , then the entire loop is 
executed again. 

 

 


