FUNDEMENTALS OF IT & PROGRAMMING

ASSIGNMENT -1

1what are the four fundamental parts of computer? Explain it with the help of diagram.
The four fundamental parts of computer are,

e CPU (CENTRAL PROCESSING UNIT)

e MOUSE

e MONITER

e KEYBOARD
CPU

e The central processing unit is also called as central processor, is the electronic circuit
within a computer that executes instructions yhat make up a computer program.

e |t stores data ,intermediate results and instructions and controls the operaton of all parts
of the computer.

MOUSE

Mouse is an input device used with the computer. Moving the mouse along the flat surface used to
move the curser and clicking the mouse helps to select the different items on the screen .



MONITER

A computer moniter is a output device that displays the information in the pictorial form.

KEYBOARD

The keyboard is an type writer device with the arrangement of keys and buttons as an electronic
switches.

2.Disscuss about the classification of the computer based on the size and capacity .
Based on size and capacity, computers are classified as follows:

e Super Computers

e Mainframe Computer

e Mini Computers

e Micro Computers

SUPER COMPUTERS

Supercomputers are the most powerful and physically the largest by size. These are systems
designed to process huge amounts of data. The fastest supercomputers can perform over one trillion
calculations in a second.they have thousands of processors.

Eg:JAGGUAR & ROAD RUNNER



MAINFRAME COMPUTER

Mainframe computers are very large often filling an entire room and can process thousands of
millions of instructions per second.

Some of the functions performed by a mainframe include: flight scheduling, reservations and
ticketing for an airline etc..

Example: IBM mainframe z13and IBM System z9 mainframe
MINI COMPUTER

Mini computers are smaller than main frame computer .less expensive Midrange computers are
usually used by small and medium-sized businesses as their servers . Users connect to the server through a
network by using desktop computers

Eg:Apple ipod and CDC 160A
MICRO COMPUTER

Microcomputers are the most frequently used type of computer. It is also, known as Personal
Computer (PC) . A microcomputer is a small computer system designed to be used by one person at a time.

Eg: persnol computer and laptops.

3.what is the meaning of coputer generation ? and how many computer generation are defined ?
what technologies were used?

COMPUTER GENERATION

Evolution of the computer is defined as the generation.Each generation is characterized by dramatic
improvements over the previous generation in the technology used to build computers, in terms of
the internal organization of computer and programming

There are 4 generations of computer,

e First generation (1941-56)

e Second generation (1956-63)

e Third generation (1964-71)

e Fourth generation(1971-present)

FIRST GENERATION COMPUTERS

they are based on vaccum tube and magnetic drums for memory.

Eg:UNIVAC &ENIAC

SECOND GENERATION COMPUTER

Second generation is based on the transistors .it helps to change the vaccum tube .

THIRD GENERATION COMPUTER



It is based on the integrated circuit this is the hallmark of this generation.
FOURTH GENERATION COMPUTERS
Thesw are based on the microprocessor,built with the single silicon chip.

4.Diffrencite between volatile and non volatile memory.

VOLATILE MEMORY NON VOLATILE MEMORY
e RANDOM ACCESS MEMORY(RAM)IS called as e READ ONLY MEMORY ( ROM)IS called as a non
volatile memory. volatile memory.
e It stores only a temporary memory e It helps to store a permanent memory
e |t stores many data in MB’s e |t stores datain GB's
e It helps in calculating data faster . e It writes data slower.

5.Distinguish betweensystem software,application software and open sourse software on
the basis of their features.

System software Application software Open sourse software

it is a type of software to design the It is created for specific purpose by In this type sourse code is released
computer hardware and computer the user.it is an application or an app. | under a licence.

programs.

Eg : WORD PROCESSOR

System software is an interface The linux operation system is the
between hardware and user best example.
application.

7.create a file in MS WORD to insert a paragraph about yourself and save it with the file
name “ yourself”. Describe the steps involved in it.
TO CREATE A NEW DOCUMENT
e Click the Microsoft office button or a file tab.
e Select the New option . a new dialogue box appears.
e Select the blank document . the new dialogue box will appear with the default.
e New blank document appears in the window.
e Now create a document by inserting a text.
e Now type a paragraph
e Im kaviya.r from Dharmapuri ,i completed my school with 90percent in sri vijay
vidyalaya matric higher sec. School [girls] in dpi and now i am doing computer
science cource.

e Finally save the document



.TO SAVE THE DOCUMENT USING SAVE AS COMMAND

e Select the Microsoft office buton or file tab

e Select save as WORD DOCCUMENT

e Enter the file name as”YOURSELF”

e Select the location where you have to save the document
e Click the save button.

6.write the steps regarding the following
To change font style

To change font size

To change font colour

To highlight (in yellow)the line that reads “need to get IMS’S address”

TO CHANGE THE FONT STYLE

e Select the text you want to modify.

Click on font style box on the Home tab.

The font style drop-down menu appears.
e Move your cursor over the various font styles.

Left-click the font style you want to use.
e Then font style will change in the document.

TO CHANGE THE FONT SIZE

Select the text you want to modify.

Click on font size box in the Font group on the Home tab.

The font size drop-down menu appears.
e  Move your cursor over the various font sizes.

Left-click on font size you want to use.
e Then it will change font size in your document.

TO CHANGE THE FONT COLOUR

e Select the text u want to modify

e C(Click on the font colour in the font group of the document
e Various font colour appears

e Move on the courser over various font colour.

e Click on the font colour you want to use.

e Then it will change the font colour

TO HIGHLIGHT ( IN YELLOW)THE LINE THAT READS “ need to get IMS’S address”



o Select the text “ need to get IMS’S address”
Click on the Text Highlight colour in font group on the Home tab.

e Various colours will appears Move your cursor over the various colours.

Click on yellow colour

Then text highlight colour will change in the document.
“need to get IM’S address”

8.create a file in the ms word for the following statement and save it with the file name
“equations’describe all steps involved in it.

Equations

X,+Y5=30

2*+Q*=50

A2+B’3=X2+Y8

TO CHANGE THE TEXT IN SUBSCRIPT

e Select the text you want to modify.
e  Click on the subscript command on the Home tab.
e  Then It will change the text as subscript in the document.

TO CHANGE THE TEXT IN SUPERSCRIPT

e Select the text you want to modify.
e Click on the superscript command on the Home tab.
e Then It will change the text as superscript in the document

X,+Y5=30
2>+Q*=50
A, +B3=X,+Y®

9. Create a file in MS-word that convert existing highlight text to table as shown below and save it as
file name ‘text_to_table’. Describe all steps involved in it.

Select the text vou want to convert.

Select the Insert tab.

Click on Table commmand. A dialog box appears.

Click on Convert Text to Table, a new dialog box appears
here set number of columns.

Click on OK Finally Selected text convert in a table

4

Select the text vou want to convert. Select the Imsert tab.

Click on Table command. A dialog box appears. Click on Convert Text to Table, a new dialog box
appears

here set number of columns. Click on OK Finally Selected text convert in a table




e Select the text u want to modify

e Selct the insert tab

e Click on the table command .a dioalog box appears

e Click on convert text into table , a new dialog box appears set a number of column and rows.
e C(Click ok . finally the text is converted into a table

e Now click on the save as option

o Enter the file name as “text to table”

e Finally click on the save option. The file will be saved in the word document

10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in it.

e Click the Microsoft office button or a file tab

e anew dialogue box appears

e select the insert option and select the insert table option
e select the number of rows and colums

o finally select insert .a table will appear in the screen

11. Create a following worksheet in MS-excel and save it with name ‘book1’.
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1nl 60
2 n2 70
3n3 80
4 n4 90
5n5 40
6 n6 50
7 n7 77
8 n8 44
9 n9 88

12. Calculate the following things of a range (C2:C11) of date in the worksheet created in
question number 10.
To sum of the marks using auto sum in the range of cells (C2:C11):

First select the cell where you want to appear function then select the drop down
arrow next to the AUTOSUM on the home tab, then select the sum, formula will appear
where you fixed your arrow then you just enter the columns you calculate, then
automatically cells range will come to that column press ok the result appears.



Average the marks in the range of cells (C1:C11):

Similarly you can calculate the average of that cell, so click on the auto sum symbol
Select average the formulas appear in the selected cells then enter average will appears.

Highest marks in the range of cells (C2:C11):& minimum marks i the range of cells

Similarly you can calculate the minimum and maximum number of the cells, click on the auto

sum in the home tab then click on the minimum or maximum what you want formula will appears in

the cells finally enter total will appear

13 a) Describe the various steps involved in the following

To modify column width of a worksheet:

R/
0’0

R/
0’0

X3

8

0
0'0

Position the cursor over the column line in the column heading.

A double arrow will appear.

Left click the mouse, then drag the cursor to right to increase the column width or to left to
decrease the column width.

Release the mouse button.

To modify the row height of a worksheet:

0
0'0

Position the cursor over the row line you want to modify and a double arrow will appear.
Left click the mouse, then drag the cursor to upward to decrease the row height or
downward to increase the row height.

Release the mouse button.

To delete rows and columns of a worksheet:

@
0.0

0
0'0

O
0'0

Select the row or column you want to delete.
Click the Delete command in the cells group on the Home tab.
Selected row or column deleted.

13 b) Describe the following terms in the worksheet

Absolute reference:

An absolute reference is designated in the formula by the addition of a dollar sign (S$). It can

precede the column reference or the row reference, or both

Examples: SAS2: The column and the row do not change when copied.

AS2: The row does not change when copied.

SA2: The column does not change when copied.



14. What tools are available to customize our PowerPoint presentation?

There are many tools available in Microsoft power point to customize. Power
point is a most excellent way of presenting to an audience in visual form. It is very
different one and different way of presenting your ideas. It helps the speaker and a
participant to understand the topic easily.

b) Write the steps for the following action for creation of power point presentation
Open a Blank presentation

First click on the start button,

Then select the power point in Microsoft office

Then double click then power point page will open.
Save the presentation as Labl.pptx

First you located or select the save command o the access toolbar.

If you are saving the file for first time save as command will appears on the
backstage view.

Then you just choose the folder where you want to save the file and gave thet
file name after words file will be saved on that folder.

Save that file name as lab1.pptx.
Add a Title to the first slide: the name of your college

Open the power point slide show page there is a visual will appears that is “click to

add title” in that place move your cursor over the caption and left click then you can add
your college name as a title .
Type your first name and last name in the Subtitle section

Same as your title creating there is another caption was appears that is click to
add subtitle there you can give your name as a subtitle.
Add a New Slide which has a Title and Content

Here after you want to make a content go to next slide click on the new slide
then new slide will appear there about your college life and your college you can
prepare that as a slide show to present in front of your students.

15) Write steps for creation of a set of PowerPoint slides that demonstrates your skill
to use the tools of PowerPoint. It should include the following things

Title slide &bullet list
In your slide show power point presentation there are many will going to
presented by you in that time if you want to highlight some points you can add a bullets
Click on the home tab there is many bullets are appears click on that to add a bullets.



Inserting Excel Sheet
Click on the insert tab on the home tab then click on the object command on the
text group, than dialogue box will appear finally choose excel left click on that, excel
sheet will appear on the mirror.

Clip art and Text
When you preparing a slide show you want some example pictures to explain
that if you don’t have those pictures in your system you can select that from a clip art
which is a best option to get some pictures.
Click on the clip art command there is a text bar will appears in your right side
mirror there you search those arts. Click on that art that will add to your slide show.

Slide show effects
To start the presentation at the first slide in the start slide show group click from

beginning, this slide show is helps you to explain very clearly about your topics, audience
also can understand easily about your presentation.

PART 2

16.WHAT IS DIFFERENCE BETWEEN MACHINE LANGUAGE AND HIGH LEVEL LANGUAGE.

MACHINE LANGUAGE HIGH LEVEL LANGUAGE
1.Machine language refers to machine code. 1.high level language is used friendly.
2.itis a collection of binary digits or bits 2.it is of two types,complied and interpreted.
That the computer reads. Used to convert high level language to machine

level.

17.DISCUSS ABOUT DIFFERENT TYPES OF C PROGRAMMING LANGUAGE.
CHARACTER YHE MOST BASICTYPEIN C.

INT:USED TO STORE INTEGER.

FLOAT:STORES DECIMAL POINT.

DOUBLE DECIMAL NUMBER.

TYPE KEYBOARD VALUE RANGE

CHAR -12810127 (0R) 0TO255
CHAR INT -32107181032,767
NUMBER SMALL -32,71871032,767
SMALL NUMBER LONG -2.147,483.648

LONG NUMBER FLOAT 1.28-38 103.4...6PLACES



THESE DATA TYPES ARE CALLED PRIMITIVE DATA WE CAN USE THESE DATA TYPES TO BUILD MORE COMPLEX
DATA WHICH ARE CALLED USER DEFINED DATA TYPES .

EXAMPLE:STRING WILL BE THE SEQUENCE OF CHARACTER.
18.FIND OUT THE OUTPUT OF THE FOLLOWING EXPRESSIONS.

A)x=20/5*2+30-5 =ANS: 33
B)Y=30-(40/10+6)+10 =ANs: -10
c)z=40*2/10-2+10 =ANS:16

19.DISCRIBE THE SYNTAX OF THE FOLLOWING STATEMENT.
A)IF —ELSE STATEMENT

IF STATEMENT CAN BE FOLLOWED BY AN OPTIONAL ELSE BLOCK OF STATEMENT ,WHICH EXECUTES
WHEN THE BOOLEAN EXPRESSION OF FALSE STATEMENT IS FALSE.

SYNTAX

IF (EXPRESSION)

TRUE BLOCK OF STATEMENT,

ELSE

ELSE BLOCK OF STATEMENT;

b)FOR LOOP

FOR LOOP IS SIMILAR TO WHILE

FOR (EXPRESSION1,EXPRESSION2,EXPRESSION3)

BLOCK OF STATEMENT

IN THE ABOVE SYNTAX ;

EXPRESSION1:INITIALIZES VARIABLES



EXPRESSION 2:CONDIYIONAL EXPRESSION AS LONG AS THIS CONDITION IS TRUE , LOOP WILL KEEP

EXECUTING.

CONDITION3:IT IS THE MODIFIER WHICH WILL INCREASE OR DECREASE THE VARIABLE.

C)WHILE LOOP
WHILE (CONDITION)
SINGLE STATEMENT;
OR

WHILE( CONDITION)

BLOCK OF STATEMENT,

DO — WHILE LOOP

SINGLE STATEMENT

OR

BLOCK OF STATEMENT ;

20)find out the output of the following statement.

A)INCLUDE<STIDO.H> B)INCLUDE<STDIO.H>
INT MAIN() INT MAIN ()

{ {

INT I; INT I=1;
FOR(1=1;<2;1++) WHILE (1<=2)

{ {

PRINT(“IMS GHAZIZBAD/N’);  PRINT(“IMS GHAZIZBAD/N");

} 1=14+1;

C)INCLUDE<STDIO.H>

VOID MAIN()

INT A=10,8=100;
IF(A>B)
PRINT(“LARGEST NO.IS PERCENT
D/N”,A);ELSE
PRINT(“LARGEST NO. IS %D/N”

,B);



OUTPUT OUTPUT OUTPUT

IMS GHAZIABAD IMS GHAZIABAD IMS GHAZIABAD

IMS GHAZIABAD IMS GHAZIABAD



