Q1. What are the four fundamental parts of computer? Explain it with the help of diagram.

Ans. The four fundamental parts of computers are:

Input units, the central processing unit/CPU, he primary memory and the Output units.

CPU

g‘ Control unit |

Arithmetic & Logical
unit N Output

Input

I

Memory unit

1) Input unit: The devices to input information,such as a keyboard and mouse.

2) CPU:The CPU is further broken up into ALU,Control unit and Instruction Unit.

3) Primary memory:Computer program instructions converted into machin code are
stored in primary storage or memery.

4) Ouput Unit:The devices to output information such as a prints,monitor and speaker.

Q2. Discuss about the classification of computers based on size and capacity.
Ans. The classification of computers based on size and capacity are as follow:
1)Super computer: a) It have thousands of processors.
b)Because of their extraordinary speed,accuracy and processing power, super computer
are well suited for solving high complex problems and huge amounts of calculations.
c)Example :JAGUAR,ROADRUNNER,etc.

2)Mainrframe computer: a)They are very large often filling an entire room & can process
thousands of millions of iinstruction per second.

b) In a mainframe environment, users connect to the mainrframe through the many

Page 1




termminals wired to the mainfram
c)Mainframe are capable of supporting hundreds to thousands of users simultaneously.
d) Some of the functions perfomed by a mainframe include : flight , scheduling, reservation & ticketing
for an airline etc.
Example : IBM mainframe Z13, IBM system z9 mainframe.
3)Mini computers: a)Mini computers are much smaller than mainframes.
b)These computers are also less expensive.
c)Sometimes referred to as Midrange Server or Midrange computer.
d)They are typically larger, more powerful and more expensive than desktop computers.
e)Midrange computers are usually used by small and medium sized business as their servers.
f)Users connect to the server through a network by using desktop computers.
4)Micro computers: a) Micro computers are the most frequently used type of computer.
b)lt is also known as Personal Computer(PC).
¢) A micro computer is a small computer system designed to be used by one person at a time.
Example: Desktop computers,laptops
Q3. What is the meaning of computer generation? How many Computer Generations are defined? What
Technologies were/are used?
Ans. Generation in Computer terminology is a change in technology a computer is being used.There are
Four genaration in computer.
1)In the fisrt computer system,vaccum tubes are used.
2)Transistors are used in 2" Generation.
3)Integrated circuit technology were used in 3" Generation.
4)In the 4™ Generation microprocessors are used.
Q4. Differentiate between Volatile and Non —Volatile memories.

Ans. Volatile memories

1)It is a computer storage that only mountains its data while device is powerd.
2)Example:Ram.
3)Primary Memory has limit storage capacity and its volatile .

Non —Volatile

Page 2




1)It is a type of computer memory that has the capacity to hold saved data if the power is turn
Off.
2)Example: Rom,hard-disk etc.

3)Secondary memory provides permanent storage of data and in bulk capacity.

Q5. Distinguish among system software ,application software and open source software on the basis of
their features.

Ans. 1) System Software:lt is a type of softwre that is designed to run a computers hardware &
Application Software like operating systems,compiters,editors &drivers, etc come under this
Category while

2)Application Software: It is software created for a specific purpose, used by end users . It can be
called an application or simply an app.
Examples: Word processor, accounting application, a web browser, an email client,media player,
Etc. while
3)Open source software: It is a type of computer software in which source code is released under a
License in which the copyright holder grants users right to study, change and distribute the
Software to anyone & for any purpose.The Linux operating system is the best known examples of
Open source software.
Q6. a) Created a file in MS-word to insret a paragraph about yourself and save it with file name
“yourself” . Describe all steps involved in it.
b) Wirte steps regarding followings
*To change the font style
*To change the font size
*To change the font color
*To highlight (in yellow ) the line that reads “need to get IMS’s address”.
Ans. “YOURSELF”

My name is Kongkham Malemnganba singh . lam 20 years old. | love to play game and
sports. | am student of IMPHAL COLLEGE, MANIPUR . Now lam learning computer CCA course at RGlI
Training Institude.

a) The steps involve are:
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1)We click the microsoft office buttom.

2)We select new. The new document dialog box appears.

3)We select blank document under the blank page and recent select. It will be highlight by
Default.

4)We click created. A new blank document appears in the word window.

5)To save the document, we click again the microsoft office button.

6)We click Ctrl+S. The save as dialog box appears.

7)We select the location where as went to save the document using the drop-down menu.

8)We enter the file name “yourslef” for the document.

9)We click the Save Button.

b) Steps to change the font Size:
1)We select the text or sentence. We want to modify.
2)Left-click the drop-down arrow next to the font color box on the Home tab.The font
Color menu appears.
3)We move cursor over the various font colours.A line preview of the colour will appear
in the document.
4)Left click the font colour we want to use.The font will change in the document.

c) Steps to change the font colour:

1) We select the text or Sentence we want to modify.

2) Left click the drop down arrow next to the font colour box on the Home tab.The font
Colour menu appears.
3)We move cursor over the various font colors.
A time preview of the colour will appear in the document.

4)Left click the font colour we want to use.The font colour will change in the document.
d) To highlight (in yellow ) the line that reads “need to get IMS’s address.

1)We select the line that reads needs to get IMS’s address.

2)We click the highlight command and select yellow colour in the font group on the

Home tab.

Q7. Create a file in MS-word for the following document and save it with file name ‘ms-word’. Describe

all steps involved in it.

MS Word
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MS Word is a widely used commercial word processor developed by Microsoft.
MS word is application software,which is capable of

*creating,

* editing,

* saving,

* printing any type of document.

Ans.The Steps involve in it are:

1)We click the microsoft office buttom.
2)We select new. The new document dialog box appears.
3)We select blank document under the blank and recent section .It will be highlighted by defualt.
4)We click create . A new blank document appear in the word window.

5)We create the given documents from the question.

6)We select the text “MS WORD” to change the font size by clicking on the font size box on the

Home tab.

7)We select the text “MS WORD” to change the font colour into red by clicking on the font colour

Menu.

8)We select the text “word processor” and underline it by clicking undreline command in the font

Group on the Home tab.

10)We select the text we want to format as a list and click the bullet commands on the Home

Tab.

11) We save the file name as “MS word” by clicking the microsoft office buttom and select save
As.
12) We select the location where we went to save the document using the dropn down menu.

Q8.Create a file in MS-word for the following document and save it with file name ‘equation’.Describe

All steps involved in it.
__EQUATIONS
X2+Y5:30

Z2+Q*=50
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A2+BS:X2+Y8
Ans. 1)First open the MS-word page then we should write the X, by typing X and pressing (Ctrl + +)
Then type 2/just clicking Insert Tab and then click on the equation tool then select subscript
and filling it.
2)As some process as X, we should write Ys
3)Then when we write Z* first we type Z then preesing (Ctrl+Shift+ +) and type 3/ just clicking
Insert Tab and then selecting subscript and filling it.
4)Again as the some process of Z* we will type Q*.
5)Like the above process we can AZIBS,XZ and Y*
6)After that we save this page by clicking (Ctrl+S)/ selecting “save by clicking file then name it as
‘equation’ and save it.

Q9. Create a file in MS-word that convert exixting highlight text to table as shown below and save it as
file name text_to_table .Describe all steps involved in it.

Select the text you to convert.

Select the insert tab.

Click on table command. Adialog box appears.

Click on convert text to table, a new dialog box appears here set number of columns.

Click on OK Finally Selected text convert in a table.

Select the text you want to convert Select the Insert Tab

Click on Table command .A dialog box appears Click on convert Text to Table,a new dialog box
appears

Here set number of columns Click on OK Finally Selected text in a table

Ans.1)At first we should select the existing highlight words.
2)Then selecting the Insert Tab.
3)Then click on the Table command,then a dialog box appea.

4)Then we click on convert Text to Table,then again dialog box appear.
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5)We will set the column which we want to make for a table.

6)Then finally we selected OK and the word we select will fills on a table automatically.

7)After this we will save it by pressing (Ctrl+S)/ selecting File Tab then select ‘Save’ and name it as

‘text to table’ then save it.

Q10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in it.

Ans. The steps are:

1)We place our cursor point in the document where we want the table to appear.

2)We select the insert Tab.

3)We click the table.

4)We drag our mouse over the diagram square to select the number of columns and rows in table.

5)Left click the mouse, and the table appears in the document.

6)We enter the text into the table.

Q11.Create the following worksheet in MS-excel and save it with name ‘book1’.

Ans:
Rollno Name WETS

1|nl 60

2| n2 70

3| n3 80

4| n4 90

51 n5 40

6 | n6 50

7| n7 77

8| n8 44

91| n9 88

10 | n10 55

SUM 654

AVERAGE 65.4
MAXIMUM 90
MINIMUM 40

Q12.Calculate the following things of a range (C2:C11) of data in the worksheet created in question no

10

» The sum of the marks using AutoSum in a range of cells (C2:C11)
» Average of the marks in a range of cells (C2:C11)
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» Highest marks in a range of cells (C2:C11)
» Minimum marks in arange of cells (C2:11)

Ans:
Rollno Name WETS

1|nl 60

2| n2 70

3| n3 80

4| n4 90

5| n5 40

6| n6 50

7| n7 77

8| n8 44

91 n9 88

10 | n10 55

SUM 654

AVERAGE 65.4
MAXIMUM 90
MINIMUM 40

Q13.a)Describe various steps involved in the following

» To modify column width of a worksheet
» To modify the row height of a worksheet
> To delete rows and columns of a worksheet

b)Describe following tersm in the wprksheet

> Absolute reference and relative reference in formula
» Cell address

Ans.a) To modify the column width of a worksheet
1 Identify the column width you want to resize.
2 However your mouse on the right boundary of that column so that you see across .
3 Hold down the mouse button and drag the right boundary until you reach the desired width.
4 And release the mouse button.
To modify the row height of a worksheet
1 Select the row thst you want to change.

2 On the home tab in the cell group click formate.
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3 Under cell size click row height.
4 In the row height box type the valve that you and then OK.
To delete rows and colums of a worksheet
1 Right click in a table cell, row and column you want to delete.
2 On the menu,click delete cell
b)Absolute reference and relative reference in formula
Relative reference change when a formula is copied to another cell.Absolute reference on the
Cell address.
Cell address is a combination of a column letter and a row number that identifies a cell on a
Worksheet.
Q14.a)What tools are available to customize our Power Point presentation?
b)Write the steps for the following to customize our powerpoint presentation

» Open a Blank presentation
» Save the presentation as Lab1.pptx

Ans.
Tools available to cutomize our PowerPoint presentation are:

a) Perspector

b) Pivot viewer

¢) Autodesk 3DS Max

d) VisualBee PowerPoint Add-in
e) SmartArt

f)  Animations and Transition

g) Wordle
h) CA coo
i) Oomfo
j)  Clip champ

b)Write the steps of the Transition Tools tab.following action for creation of powew point
presentation?

- Open a bank presentation
- Save the presentation as labl.pptx
-Add a title of the first slide : the name in the of your collage

- Type your first name last name in the subtitle section
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-Add a new slide which has a title and content.
Ans.
-To open BLANK PRESENTATION:

i Open powerpoint presentation using ‘Run’ command (window key +R).
ii. Select the Blank Presentation. It is opened.

- Save the presentation Labl.pptx:

i Select the ‘File’ on the Tab bar.

ii. Click on ‘Save As’ option.

iii. Click on document/Desktop as your choice.

iv. Type the name ‘Labl.pptx’.

V. Click the ‘Save’ buttom.

- Add aTittle to the first slide: the name of your college:

i Left click on ‘Click to Add Tittle” section on the first slide.

ii. Type the name of your college.

- Type your first name and last name in the subtittle section:

i Left click on the ‘Click to Add Subtittle’ section.

ii. Type your first name and last name.

- Add a New slide which has a title and content.

i Select the Home tab.

ii. Click on the dropdown button of the ‘New Slide’ on toolbar.
iii. Select the slide having Title and Content It is added.

Q15.Write steps for creat of a set of Power Point slide that demonstrate your skill to use the tools of
Power Point.It should include the following things

Title slide &bullet list
Inserting Excel Sheet
Clip art and Text
Slide show effects

Ans.TITLE SLIDE AND BULLET LIST:On the view tab, click normal.Click in the text box or the place where
you want to add bulleted number text.On the home tab,in the paragraph group,click bullet or
numbering and begin typing your list .Press return to create a new list item.

TITLE SLIDE:To add a slide title to an existing slide go to the home tab and click layout then title
only.Then press your cursor in the click to add title box on the slide and type in your unique slide title.

INSERT EXCEL SHEET:In power Point,on the insert tab click or tab object dialog box select create from
file.Click or tab browse,and in the browse box find the excel workboo with the data you want to
insert.Before you close the insert object box,select link and click ok.

CLICK ART AND TEXT:Click in the slide where you want insert a clip art file.On the insert tab in the
image group click online pictures.In the insert picture dialog box enter your search terms in.
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SLIDE SHOW EFFECT:Selcet the object or text you want to animate.Select animation choose an
animation.Select effect option choose an effect.

Q16.What is the difference between Machine Language and High Level Language?

Ans.The difference between Machine Language and High Level Language are as follows :

Machine Language High Level Language

1.A high level language is a programming
1.A computer programming language consisting of binary langauage that enables development of a program
instruction which a computer can response to directly. in a much more user-friendly programming
2.Sometimes, it is refered to as machine code or object context.
code.Machine language is a collection of binary disits or bits | 2.This language is a programming language with
that the computer reads. strong abstraction about the details of the
3.Example:01001000,01100101,01101100,01101100, programming language.

3.Example:C,C++,Java.
Etc.

Q17.Discuss about difference between data type of C programming language.

Ans.The different data type of C programming language are:Each variable in a C has an associated data
type.Each data type requires different amount of memory & some specific operations which can be
performed over it.Let us briefly describe them one by one.

Following are the example of some very common data types used in C.

1.Char:The most basic data type in C. It store a single character and requires a single byte of memory
in almost all compilers.

2.Int:As the name suggest,an int variable is used to store an integer.
3.Float:lt is used to store decimal numbers(numbers with floating point value).

4.Double:lt is used to store decimal numbers (numbers with floating point value but its range of value
is high in comparison to float).

Q18.Find the output of the following expressions
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a) X=20/5*2+30-5
b) Y=30—(40/10+6)+10
) Z=40*2/10-2+10

Ans. a) X=20/5x2+30-5
X=4x2+30-5 =8+30-5=38-5=33
X=33
b)Y=30-(40/10+6)+10
Y=30-(4+6)+10=30-10+10=30-20
Y=10
€)Z=40x2/10-2+10
Z=40x0.2-2+10=200-2+10=200-12
=320-2+10=320-12

Z=188.16

Q19.Describe the syntax of the following statements
a)If —else statement b)for loop c) while loop d)do-while loop

Ans.a) If-else statement:If statement can be followed by an optinal else block of state-ments,which
executes when the Boolean expression is false.

Syntax
If (expression)
{true Block of statement,
}
Else

{else Block of statements,

}

b)for loop for loop is similar to while.Basic syntax of for loop is as follows
for(expressionl;expression2;expression3)

{

Block of statements;

Page 12




}

In the above syntax:

1 expressionl- Initializes variable.

2 expression2-Conditional expression,as long as this condition is true,loop will keep executing.

3 expression3-Expression3 is the modifies which will increase or decrease the value of the variable.
c)While loop:Basic syntax of while loop is as follows:

While(condition)
Single statement;

d)Do —while loop:do-while is just like a while loop except that the test condition is checked at the
end of the loop rather than the start.This has the effect that the body of the loop are always executed at
least once.

Basic syntax of do —while loop is as follows;
do
{single statements

} while (condition);

Q20. Find the output of the following program segments

Ans.a)IMS Ghaziabad.
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b)IMS Ghaziabad.
IMS Ghaziabad.
IMS Ghaziabad.

c)Laegest number is 100.
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Roll no Name \WETS
1{nl 60
2[n2 70
3[n3 80
4|n4 90
5In5 40
6[n6 50
7|n7 77
8[{n8 44
9(n9 88

10|n10 55
SUM 654
AVERAGE 65.4
MAXIMUM 90
MINIMUM 40
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Tools available to customise our
PowerPoint presentation are:

Perspector

Pivot viewer

Autodesk 3DS Max

Visual Bee PowerPoint Add-in
Smart Art

Animations and Transition
Wordie

CA coo

Oomfo

Clip chmap



Open a bank presentation

Save the presentation as lab1.pptx

Add a title of the first slide : the name in the of
your collage

Type your first name last name in the subtitle
section

Add a new slide which has a title and content.
To open blank presentation:

Open PowerPoint presentation using Run command
( window key + R)

Select the Black Presentation. It is opened.



Save the presentation on Labi. Pptx:

Select the File on Tab bar

Click on ‘Save As option

Click on document/Desktop as your choice
Type the name “Labi. Pptx”

Click the “Save” button



Add a Title to the first slide: the name of your college.

Left click on the “Click to Add Title” section on the
first slide

Type the name of your college






Add a New slide which has a Title and content:
Select the Home tab

Click on the dropdown buttom of the “New Slide” on
toolbar

Select the slide having “Title and Content”. It is added.
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