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Q1. Answer: 

(a) CPU – It is the electronic circuitry within a computer that carries out the instructions of a 

computer program by performing the basic arithmetic, logical, control and input or output 

operations specified by the instructions. It is also called a central processor, main processor 

or just processor, is the electronic circuitry that executes instructions comprising a computer 

program. 

  

(b) Keyboard – It is a peripheral input device which uses an arrangement of buttons or keys to 

act as mechanical level or electronic switches. Keyboard keys typically have a set of 

characters engraved or printed on them and each pair of key typically corresponds to a 

single written symbol. Keyboard is used as a text entry interface for typing text, numbers 

and symbols into application software such as a word processor, web browser or social 

media.   

  

(c) Mouse – A computer mouse is a hand-held pointing device that detects two dimensional 

motion relative to a surface. This motion is typically translated into the motion of a pointer 

on a display. Which allows a smooth control of the Graphical User Interface (GUI) of a 

computer. Computer mouse have one or more buttons to allow operation such as the 

selection of menu item on a display. Mouse often also features other elements, such as 

touch surfaces and scroll wheels, which enables additional control and dimensional input. 



  

(d) Monitor – Monitor is an output device that display information in pictorial or text form. A 

monitor usually comprises a visual display, some circuitry, a casing and a power supply. 

Monitors are connected to all the computers via VGA, Digital Visual Interface (DVI), HDMI, 

DisplayPort, USB-C, Low-voltage Differential Signaling (LVDS) or other proprietary 

connectors and signals. 

  

Q2. Answer:   

Classification of computers based on size and capacity: 

(a) Micro Computers: Microcomputers is a computer whose CPU is a microprocessor. All the 

components of a microprocessor are on a single integrated circuit chip. Micro computer can 

be categorized as the desktop, programmable and workstation. The microprocessor based 

computer are called third generation computers. They are the backbone of the modern 

computer era.   

(b) Mini Computers: Mini computers were introduced in early 1960s. they were faster than 

microcomputers. Basically these computers were mainly multi-user systems, where many 

users work on the systems. Generally, this type of computers had larger memories and 

greater storage capacity. They had large instruction set and address field. These kinds of 

computers have efficient storage for handling of text, in comparison to lower bit machine. 

Due to more efficient processor, speed and memory size, minicomputers was used in 

variety of applications and could support business application along with the scientific 

applications. Minicomputer was a multi-user system which means more than one user 

could use this system simultaneously.  

(c) Mainframe Computers: They are large and expensive machines. The word length of 

mainframe computers may be 48, 60 or 64 bits, memory capacity being in some megabytes 

and storage capacity in some terabytes. Generally, they handle huge volume of information 

and data. In terms of speed, they are having significant processing capacity. They are used 



in research organizations, large industries, airlines reservation where a large data base has 

to be maintain. 

(d) Super Computers: Super computers are the fastest computer in current era. The processing 

capabilities of super computer lies in the range of GIPS2, word length 64-128 or may be in 

256 or so. The memory capacity of super computer is in some gigabytes or in terabytes. The 

storage capacity of this type is in Exabyte. 

 

 

 

Q3. Answer: 

Generation in computer technology is a change in technology a computer is/was being used. Initially, 

the generation term was used to distinguish between varying hardware technologies. Nowadays, 

generation includes both hardware and software, which together make up an entire computer 

system. 

There are main five computer generation defined. Here are the five generation and their 

technologies: 

(a) First Generation: The first generation used Vacuum tube. 

(b) Second Generation: The second generation used Transistor. 

(c) Third Generation:  Third generation used Integrated Circuit. 

(d) Fourth Generation: Fourth generation used VSLI microprocessor. 

(e) Fifth Generation:  Fifth generation used ULSI microprocessor. 

Q4. Answer: 

Sl. 
no 

Key Volatile Memory Non-volatile Memory 

1. Data retention Data is present till power supply is 
present. 

Data remains even after power 
supply is not present. 

2. Persistence Volatile memory is not permanent. Non-volatile memory data is 
permanent. 

3. Speed Volatile memory data is faster than 
non-volatile memory. 

Non-volatile memory access is 
slower. 

4. Data transfer Data transfer is easy in volatile 
memory. 

Data transfer is difficult in non-
volatile memory.  

5. CPU access CPU can access data stored on 
volatile memory. 

Data to be copied from non-
volatile memory to volatile 
memory so that CPU can access its 
data. 

6. Storage Volatile memory has less capacity. Non-volatile memory like HDD has 
very high storage capacity.  

7. Impact Volatile memory such as RAM has 
high impact on system’s 
performance. 

Non-volatile memory has no 
impact on system’s performance. 

8. Cost Volatile memory is costly per unit 
size. 

Non-volatile memory is cheap per 
unit size. 



9. Example RAM ROM 

 

Q5. Answer: 

System Software: 

1. System software is fast in speed. 

2. Written in Low-Level Language. 

3. System software is closed to the system. 

4. They are smaller in size. 

5. They are difficult to design and understand. 

 

 Application Software: 

1. Performed more specialized task life word processing, spreadsheets, email, photo 

editing, etc. 

2. It needs more storage space as it is bigger in size. 

3. Easy to design and more interactive for the user. 

4. Generally written in a High-Level Language. 

Open Source Software: 

1. Flexibility: A programmer can take a standard software package and modify it to better 

suit business needs. You can usually hire a programmer to add a particular function to 

open source software. 

2. Freedom: Open source software offers users the freedom to use the software as they 

please. They can run the software anywhere be it on the cloud or in an on-site data 

center, for absolutely any purpose that serves them. 

3.  Integration: Easy integration with existing infrastructure is a significant consideration 

when it comes to selecting software, and in this area open source software excels. 

Many enterprises agree that this feature often trumps low cost and even performance 

speed. 

Q6. (a) Answer: 

Steps:  

1. Open MS-word. 

2. Select the blank document. 

3. Type [ =rand() ]   Or    Type the require text about Yourself. 

4. Select the ‘File’ on the Tab bar. 

5. Select the ‘Save As’ option. 

6. Select the folder/desktop option. 

7. Type the file name ‘Yourself’ and click ‘Save’ button. 

Q6. (b). Answer: 

1. To change the font style: 

 Select the text and click the font button from the toolbar in the home tab and select the 

style. 



2. To change the font size: 

 Select the text and click the font size button from the toolbar in the home tab and select 

the size. 

3. To change the font color: 

 Select the text and click the font color button from the toolbar in the home tab and 

select the font color. 

4. To highlight (in yellow) the line that reads “need to get IMS’s address”. 

 To highlight in yellow, the line that reads “need to get IMS’s address”, select the text 

and click the text highlight color from the toolbar in the home tab and select the yellow 

color. 

 

Q7. Answer: 

MS Word 

MS Word is a widely used commercial word processor developed by Microsoft. 

MS word is application software, which is capable of 

 creating, 

 editing, 

 saving, and 

 printing any type of document 

 

Ans:     Steps: 

1. Select the text ‘MS Word’ and choose its font style in Font Toolbar in Home Tab. 

2. Select the text ‘MS Word’ and click the ‘Font color’ from Toolbar in Home Tab and select 

the desire color. 

3. Select the text ‘Word processor’ and click on Underline button from the Toolbar in home 

tab and choose the require underline for text. 

4. Select the text ‘MS Word’. Then click on the ‘Italic’ button from Toolbar in Home Tab. 

5. Select the word ‘creating’ and click on the font color from the toolbar in home tab and 

choose the blue color. 

6. Select the word ‘saving’ and click on the font color from the toolbar in home tab and 

choose the red color. 

7. Select the word ‘and’ and click on the Strikethrough command on toolbar in Home Tab. 

8. Select the line ‘printing any type of document’ and click on the Bold icon on Toolbar in 

Home Tab. 

      

 

Q8. Answers: 

Equations 

X2   + Y5 = 30 



Z3   +   Q4 = 50 

A2    +   B8   = X2 + Y8  

 

Steps:
 

 Open MS Word and choose the blank document 

 Type the require text or the equations 

 To make the powers smaller, select the text and click on the Subscript and Superscript on 

the toolbar in the home tab. 

 Click on the file button in home tab and click save as option and save the file as ‘equations’. 

Q9. Answer: 

      Select the text you want to convert. 

      Select the Insert tab. 

      Click on Table command. A dialog box appears. 

      Click on Convert Text to Table, a new dialog box appears. 

      Here set number of columns. 

      Click on OK Finally selected text convert in a table. 

                                                                                  

 

      Select the text you want to convert.       Select the Insert tab. 

      Click on Table command. A dialog box 
appears. 

      Click on Convert Text to Table, a new dialog 
box appears. 

      Here set number of columns.       Click on OK Finally Selected text convert in a 
table.   

 

Steps: 

1. Open MS-word and choose blank document. 

2. Type the require text. 

3. Select the text needed to convert into table. 

4. Select the Insert tab. 

5. Click on Table command. 

6.  Click on ‘Convert Text to Table’ on the dialog box. 

7. Click ‘Ok’ and text converted into table. 

8. Click on Microsoft Office Button. 

9. Click on ‘Save As’ option and type the file name as ‘text-to-table’. 

10. Click the ‘Save’ option and save it.   

 

 



Q10. Answer: 

Video provides a powerful way to help you prove your point. When you click Online Video, you can 

paste in the embed code for the video you want to add. You can also type a keyword to search 

online for the video that best fits your document. 

To make your document look professionally produced, Word provides header, footer, cover page, 

and text box designs that complement each other. For example, you can add a matching cover page, 

header, and sidebar. Click Insert and then choose the elements you want from the different 

galleries. 

          

          

          

          

          

          

          

          

 

Themes and styles also help keep your document coordinated. When you click Design and choose a 

new Theme, the pictures, charts, and SmartArt graphics change to match your new theme. When 

you apply styles, your headings change to match the new theme. 

Save time in Word with new buttons that show up where you need them. To change the way a 

picture fits in your document, click it and a button for layout options appears next to it. When you 

work on a table, click where you want to add a row or a column, and then click the plus sign. 

Steps: 

1. Open MS-word and select the blank document. 

2. Type the require text. 

3. Place the cursor on the position where you want to add table. 

4. Click on the Insert Tab to insert a table. 

5. Then, click the Table command on tool bar. 

6. Click the Insert Table in dialog box. 

7. Choose the require numbers of rows and columns. 

8. Click on OK option and the table is finally inserted 

Q11.Answer: 

Roll No Name Marks 

1 n1 60 

2 n2 70 

3 n3 80 

4 n4 90 

5 n5 40 

6 n6 50 

7 n7 77 

8 n8 44 



9 n9 88 

10 n10 55 

 

Q12. Answer: 

Roll No Name Marks  

1 n1 60  

2 n2 70  

3 n3 80  

4 n4 90  

5 n5 40  

6 n6 50  

7 n7 77  

8 n8 44  

9 n9 88  

10 n10 55  

    

 Total 654  

 Average 65.4  

     Highest 90  

 Minimun 40  
 

 

Q13. (a) Answer: 

 To modify column width of a worksheet: 

i. Select a column or a range of columns. 

ii. Select a Home tab and in the Cells group, select Format. 

iii. Click on Column width and type the width for column. 

iv. Select OK. 

 To modify the row height of a worksheet. 

i. Select a row or a range of rows. 

ii. Select a Home tab and in the Cells group, select Format. 

iii. Click on Row Height and type the height for row. 

iv. Select OK. 

 To delete rows and columns of a worksheet. 

i. Select the cell you want to delete within the column or row. 

ii. Select Home tab. And in cells group click on Delete Sheet Column or Row. 

                                                    OR 

i. Select the desire row or column. 

ii. Right-click and select Delete. 

 

Q13. (b) Answer: 



 Absolute Reference:  

An absolute reference in Excel means there is a fixed point of reference applied to a cell or a 

formula. This is so the return value will always stay the same no matter where the cell or 

formula moves to – within the same sheet or across different sheet. 

 

This refers to a fixed point of reference is a constant, and involves the use of dollar sign $ in 

the formula (i.e., everyone is to receive the same bonus payout, so the amount $1500 is 

constant in this situation). 

 

                        

Microsoft Excel 

97-2003 Worksheet
 

 

 Relative Reference: 

It is the default cell reference in Excel. It is simply the combination of column name and row 

number without any dollar ($) sign. When you copy the formula from one cell to another the 

relative cell address changes depending on the relative position of column and row. C1, D2, 

E4, etc. are examples of relative cell references. Relative references are used when we want 

to perform a similar operation on multiple cells and the formula must change according to 

the relative address of column and row. 

                   

                      

Microsoft Excel 

97-2003 Worksheet
 

This refers to a relative point of reference, is constantly changing and dollar sign ($) is absent 

in the formula (i.e., when each unit price and quantity are difference variables, there’s no 

constant in the calculation).  

 

 Cell Address: 

A cell address is a combination of column letter and a row number that identifies a 

cell on a worksheet. 

For example, A1 refers to the cell at the intersection of column A and row 1; B2 

refers to the second cell in column B, and so on. 

         When used in formula, cell references help Excel find the values the formula 

should calculate. For instance, 

 To pull the value of A1 to another cell, you use this simple formula: 

=A1 

 To add up the values in cells A1 and A2, you use this one: 

=A1+A2 

 

Q14. (a) Answer: 

Tools available to customize our PowerPoint presentation are: 

a) Perspector 



b) Pivot Viewer  

c) Autodesk 3DS Max 

d) VisualBee PowerPoint Add-in 

e) SmartArt 

f) Animations and Transition 

g) Wordle  

h) CA coo 

i) Oomfo  

j) Clip champ  

 

(b). Answer: 

 To open blank presentation: 

I. Open PowerPoint presentation using ‘Run’ command (window key + R). 

II. Select the ‘Blank Presentation’. It is opened. 

 Save the Presentation as Lab1.pptx.: 

I. Select the ‘File’ on Tab bar. 

II. Click on ‘Save As’ option. 

III. Click on document/Desktop as your choice. 

IV. Type the name ‘Lab1.pptx’. 

V. Click the ‘Save’ button. 

 

 Add a Title to the first slide: the name of your college. 

i. Left click on the ‘Click to Add Title’ section on the first slide. 

ii. Type the name of your college. 

 Type your first name and last name in the subtitle section: 

i. Left click on the ‘Click to Add Subtitle’ section. 

ii. Type your first name and last name. 

 Add a New slide which has a Title and content. 

i. Select the Home tab. 

ii. Click on the dropdown button of the ‘New Slide’ on toolbar. 

iii. Select the slide having ‘Title and Content’. It is added. 

 

Q15. Answer: 

 Title slide and bullet list: 

i. Open PowerPoint Presentation. 

ii. Select the Home tab. 

iii. Click at the dropdown button on ‘New Slide’ at toolbar. 

iv. Select the slide having Title slide and Bullet list. 

 Inserting Excel sheet: 

i. Open the slide where you want to insert the Excel Sheet. 



ii. Select the ‘Insert tab’. And click on ‘Object’ on tool bar. 

iii. Select the ‘Microsoft Excel Worksheet’ object type. 

iv. Click the ‘OK’ button. 

 ClipArt and Text: 

i. Select the Insert Tab. 

ii. Select the ‘Pictures’ or ‘Online pictures’ on tool bar. 

iii. Choose the appropriate art for the topic. 

iv. Click on the ‘Insert’ button. 

 Slide show effects: 

i. Select ‘Design Tab’ for Themes, Variants and Slide size. 

ii. Select ‘Transition Tab’ for Cut, Fade, Push, Wipe, Split, Reveal, Shape, Flash, 

etc. for slide effects. 

 

Q16. Answer: 

Differences between Machine Language and High Level Language are: 

 Machine Language: 

i. It is also known as Low Level Language. 

ii. It can be understood easily by the machine. 

iii. It is considered as machine-friendly language. 

iv. It is difficult to understand. 

v. It is difficult to debug. 

vi. Its maintenance is also complex. 

vii. It is not portable. 

viii. It depends on the machine; hence it can’t be run on different platforms. 

ix. It consumes less memory. 

x. It requires an assembler that would translate instructions. 

xi. It is not used widely in today’s times. 

 High-level Language: 

i. It can be easily interpreted as well as compiled in comparison to machine language. 

ii. It can be considered as a programmer-friendly language. 

iii. It is easy to understand. 

iv. It is easy to debug. 

v. It is simple in terms of maintenance. 

vi. It requires a compiler/interpreter to be translated into machine code. 

vii. It can be run on different platforms. 

viii. It can be ported from one location to another. 

ix. It is less memory efficient, i.e. it consumes more memory in comparison to low-level 

languages. 

x. Examples of high level languages include C, C++, Java, Python. 

xi. It is used widely in today’s times. 

 

Q17. Answer: 



Different Data types in C programming: 

1. CHAR: The CHAR data type stores character data in a fixed-length field. Data can be a sting 

of single-byte or multiple letters, numbers, and other characters that are supported by the 

code set of your database locale. It has a value range of -128 to127. Char is a C++ data type 

designed for the storage of letters. Char is an abbreviation for an alphanumeric character. It 

is an integral data type, meaning the value is stored as an integer. A char takes a memory 

size of 1 byte. It also stores a single character. 

2. INT: INT is a data type used to represent real numbers that do not have fractional values. 

Different types of integer data types are stored on machines in different ways. It is a 

functional variable types built into the compiler and used to defined numeric variables 

holding whole numbers. Integers are a commonly used data type in computer programming.                      

It has a memory size of 2 or 4 bytes. And a value range of about -32,768 to 32,767. 

3. Long: The long data type modifier is used when the value to be stored is large and exceeds 

the usual integer range. It can be applied to int and double data type in C. A long integer 

variables takes 4 bytes of memory space in a 32-bit system.  

Syntax: long type Var_name. 

Example: long int Var1;  //or long var1 

                  long long int Var2; // or long long Var2 

                  long double Var3; 

                     In C, “long int” is equivalent to simply “long” and similarly instead of “long long int” you 

can simply write “long long”. This is commonly used in competitive programming as the inputs there 

can be very large. It has a value range of -2,147,483,648 to 2,147,483,647. 

4. Float: Float is datatype which is used to represent the floating point numbers. It is a 32-bit 

IEEE 754 single precision floating point number (1-bit for the sign, 8-bit for exponent, 23*bit 

for the value). It has 6 decimal digits of precision. 

           The float data type is used to store the floating-point numbers. The numbers that have 

a fractional part are called floating-point numbers. For example, 3.0, 5.57, -3.12, etc. are all 

floating numbers. Moreover, it should be noticed carefully that 8 is an integer but 8.0 is a 

floating-point number. Although the value of both the digits is the same, 8.0 has a decimal 

number which differentiates it with 8. 

           The major advantage of floating point numbers over integers is that they can 

represent a much larger and wider range of digits as compared to int data type. It has a 

memory size of 4 bytes. And a range of 1.2E-38 to 3.4E+38. 

5. Double: Double is also a datatype which is used to represent the floating point numbers. It is 

a 64-bit IEEE 754 double precision floating point number for the value. It has 15 decimal 

digits of precision. The float data type is also used to store floating-point numbers. But still, 

it is considered as distinct datatype because of two reasons. The first one is that it occupies 

twice as much memory as float datatype. The second reason is that it is used to store a 

much larger range of floating-point numbers than a float data type. 

           The double stores almost double the number of significant digits after the decimal 

point or precision of the float. However, the double data type consumes more memory and 

it is advisable to use a smaller data type as much as possible for the sake of optimization of 

code. It has a memory size of 8 bytes and a range of 2.3E-308 to 1.7E+308. 

 

Q18.Answer: 



a) X=20/5*2+30-5                  b) Y=30-(40/10+6) +10                 c) Z=40*2/10-2+10 

 

= 33 = 10 =188 

Q19. Answer: 

a) If – else statement: 

The if-else statement is an extended version of If. The if else statement is used to perform 

two operations for a single condition. The if-else statement is an extension to the if 

statement using which, we can perform two different operations, i.e., one is for correctness 

of that condition, and the other is for the incorrectness of the condition. Here, we must 

notice that if and else block cannot be executed simultaneously. Using if-else statement is 

always preferable since it always invokes an otherwise case with every if condition. The 

general form of if-else syntax is given below. 

 

 

 
 

 

 

 

 

 

 

 

          In this type of construct, if the value of test-expression is true, then the true block of 

statements will be executed. If the value of test expression is false, then the false block of statement 

will be executed. In any case, after the execution, the control will be automatically transferred to the 

statements appearing outside the block of If. 

          The if statement specifies a block of code to be executed if a condition is true. And the else 

statement specifies a block of code to be executed if the condition is false.  

 

b) for loop: 
A for loop is a repetition control structure that allows you to efficiently write a loop that 

needs to execute a specific number of times.  The syntax of a for loop in C programming is – 

 

 

 

 

Here is the flow of control in a for loop- 

if  (test-expression) 

{ 

    True block of statements 

}     

Else 

{ 

    False block of statements 

} 

Statements; 

 

 

 

for ( init; condition; increment statement(s); 

} 



 The init step is executed first, and only once. This step allows you to declare and initialize 

any loop control variables. You are not required to put a statement here, as long as a semi-

colon appears. 

 Next, the condition is evaluated. If it is true, the body of the loop is executed. If it is false, the 

body of the loop does not execute and the flow of control jumps to the next statement just 

after the for loop. 

 After the body of the for loop executes, the flow of control jumps back up to the increment 

statement. This statement allows you to update any loop control variables. This statement 

can be left blank, as long as a semicolon appears after the condition. 

 The condition is now evaluated again. If it is true, the loop executes and the process repeats 

itself (body of loop, then increment step, and then again condition). After the condition 

becomes false, the for loop terminates. 

 

C)  while Loop: 

The while loop is used to repeat a section of code an unknown number of many times until a specific 

condition is met. A while loop is the most straightforward looping structure. While loop syntax in C 

programming is as follows: 

 

 

 

 

           It is an entry-controlled loop. In while loop, a condition is evaluated before processing a body 

of the loop. If a condition is true, then and only then the body of a loop is executed. After the body 

of a loop is executed then control again goes back at the beginning, and the condition is checked if it 

is true, the same process is executed until the condition becomes false. Once the condition becomes 

false, the control goes out of the loop. 

          After exiting the loop, the control goes to the statements which are immediately after the loop. 

The body of a loop can contain more than one statement. If it contains only one statement, then the 

curly braces are not compulsory. It is a good practice though to use the curly braces even when we 

have a single statement in the body. In while loop, if the condition is not true, then the body of a 

loop will not be executed, not even once. At most purposes, this loop is more preferable. 

 

D) do-while Loop: 

           Unlike for and while loops, which test the loop condition at the top of the loop, the do-while 

loop in C programming checks its condition at the bottom of the loop. A do-while loop is similar to a 

while loop, except the fact that it is guaranteed to execute at least one time.  

           The syntax of a do-while loop in C programming language is – 

 

while (condition) { 

         statements; 

} 



 

 

              Notice that the conditional expression appears 

at the end of the loop, so the statement(s) in the 

loop executes once before the condition is tested. If 

the condition is true, the flow of control jumps back up to do, and the statement(s) in the loop 

executes again. This process repeats until the given condition becomes false. 

             A do-while loop is a kind of loop, which is a kind of control statement. It is a loop with the 

test at the bottom, rather than the more usual test at the top. This kind of loop is most often used 

when the test doesn’t make any sense until the statement have been performed at least once.  

 

Q20. Answer: 

A) IMS Ghaziabad 

B) IMS Ghaziabad  

IMS Ghaziabad 

C) Largest number is 100 

do { 

   statement(s); 

} while (condition); 


