
CCA-101: Fundamentals of IT & 
Programming 

 Assignment -1 
Q1: What are the four fundamental parts of computer? Explain it with the help of diagram. 

Ans: A computer has four main components: Input Units,CPU, the Primary memory, and 

Output units. 

• Input Unit - The devices to input information, such as a keyboard, and mouse. 

• CPU - The CPU is further broken up into ALU, Control Unit, and Instruction Unit. 

• Primary Memory - Computer program instructions converted into machine code are stored 

in primary storage or memory. 

• Output Unit - The devices to output information, such as a printer, monitor, and speaker. 
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Q2: Discuss about the classification of computers based on size and capacity. 

Ans: Based on size and capacity, computers are classified as follows:  

• Super Computers • Mainframe Computer • Mini Computers • Micro Computers 

Supercomputers are the most powerful and physically the largest by size. 

• Mainframe computers are very large often filling an entire room and can process thousands of 

millions of instructions per second. 



• Minicomputers are much smaller than mainframes. • These computers are also less 

expensive. 

• Microcomputers are the most frequently used type of computer. • It is also, known as 

Personal Computer (PC) 

Q3: What is the meaning of computer generation? How many Computer Generations are 

defined? What technologies were/are used? 

Ans: Generation in computer terminology is a change in technology a computer is/was being 

used. Initially, the generation term was used to distinguish between varying hardware 

technologies. Nowadays, generation includes both hardware and software, which together 

make up an entire computer system. 

 There are five computer generations known till date. 

• First Generation- The period of first generation: 1946-1959. Vacuum tube based. The 

computers in this generation used machine code as the programming language. 

•  Second Generation -The period of second generation: 1959-1965. Transistor based. The 

computers used batch processing and multiprogramming operating system 

•  Third Generation -The period of third generation: 1965-1971. Integrated Circuit based. 

In this generation remote processing, time-sharing, multi-programming operating 

system were used.  

•  Fourth Generation The period of fourth generation: 1971-1980. VLSI microprocessor 

based. In this generation, time sharing, real time networks, distributed operating system 

were used. All the high-level languages like C, C++, DBASE etc., were used in this 

generation. 

•  Fifth Generation The period of fifth generation: 1980-onwards. microprocessor based. 

This generation is based on parallel processing hardware and AI (Artificial Intelligence) 

software. 
 

Q4: Differentiate between Volatile & Non- Volatile memories? 

Ans: 1) Primary memory / Volatile memory: Volatile memory is a computer storage that only 

maintains its data while the device is powered  

Example: RAM (Random access memory) is volatile. When we are working on a document, it is 

kept in RAM, and if the computer loses power, your work will be lost. 



 2)Secondary memory/ non-volatile memory: Nonvolatile memory is a type of computer 

memory that has the capability to hold saved data even if the power is turned off. Example: 

Read-only memory (ROM), Hard disk, floppy disk. 

Q5: Distinguish among system software, application software and open 

source software on the basis of their features? 

Ans: System software: • It is designed to run a computer's hardware and application 

programs. • Software like operating systems, compilers , editors and drivers etc., come under 
this category. • A computer cannot function without the presence of system software. If we 
think of the computer system as a layered model, the system software is the interface between 
the hardware and user applications. 

Application software: • It is software created for a specific purpose, used by end users. It can 
be called an application or simply an app. • Examples: Word processor, accounting application, 
a web browser, an email client, media player etc. 

open source software :It is a type of computer software in which source code is released 

under a license in which the copyright holder grants users rights to study, change and 
distribute the software to anyone and for any purpose. • The Linux operating system (OS) is the 
best-known examples of open source software . 

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with 
file name “yourself”. Describe all steps involved in it? 

Ans: “yourself”.docx 

Steps involve in it: 

Create your file in Microsoft Word: 
 1. Double click on the hard drive icon to open the disk drive.  
2. Locate and double click on the Applications folder.  
3. Locate and double click on the Microsoft Office folder.  
4. Locate and double click on the blue W icon labeled Microsoft Word Document.  

5. With your cursor at the top of the document, enter the following title: “yourself” 
6. Hit the Enter key once.  
7. Enter the following subtitle:  

Researched by“yourself”  

8. Save your document by going to File > Save As. Save the file as “yourself”." Click "Save." 
 9. Hit the Enter key three times. 
Q6 b) Write steps regarding followings 

• To change the font style   

• To change the font size 

• To change the font color 



• To highlight (in yellow) the line that reads “need to get IMS’s 
address”. 

Ans: To change the font style within a Microsoft Word document, follow 

the steps below. 

1.Highlight the text you want to change. 

2.Click on down arrow font field on the format bar or Ribbon. 

3.After clicking the down arrow for the font, you can select from each of the 

installed fonts on your computer. Click the font you want to use and the 

highlighted text changes. 

To change the font size within a Microsoft Word document, follow the 

steps below. 

1. Highlight the text you want to change. 

2.Click the down arrow next to the size box on the format bar or Ribbon. 

3.After clicking the down arrow for the size, you'll have a selection of different 

sizes to choose, then click ok. 

To change the font color, follow the steps below. 

To change the font color within a Microsoft Word document, follow the 

steps below. 

1.Highlight the text you want to change. 

2.Click the down arrow next to the color icon on the format bar or Ribbon. It is 

usually displayed as the letter "A" with a red underline. 

3.After clicking the down arrow for the color, select the color you want to make 

the text. 

• To highlight (in yellow) the line that reads “need to get IMS’s 
address”. 
“need to get IMS’s address”. 

1. To highlight the text , you want to change , first select the text . 

2.Click the down arrow next to the color icon on the format bar or Ribbon. It is 

usually displayed as the letter “ab” with a white underline. 

3.After clicking the down arrow to highlight the color, select the color you want 

to apply on the text. 



Q7. Create a file in MS-Word for the following document and save it with file name 
‘ms_word’. Describe all steps involved in it? 

Ans: ‘ms_word’.docx 

Steps involve in it : 

Create your file in Microsoft Word: 
 1. Double click on the hard drive icon to open the disk drive.  
2. Locate and double click on the Applications folder.  
3. Locate and double click on the Microsoft Office folder.  
4. Locate and double click on the blue W icon labeled Microsoft Word Document.  

5. With your cursor at the top of the document, enter the following title: ‘ms_word’ 
6. Hit the Enter key once.  
7. Enter the following subtitle:  

Researched by‘ms_word’  
8. Save your document by going to File > Save As. Save the file as‘ms_word’." Click "Save." 
 9. Hit the Enter key three times. 
 

Q8. Create a file in MS-word for the following document and save it with file name 
‘equations’. Describe all steps involved in it? 

Equations 
 

X2  +  Y5  =30 

Z3  + Q4  =50 

A2 + B8 =x2
 +Y8 

 
Ans:  ‘equations’.docx 

Steps involve in it : 

Create your file in Microsoft Word: 
 1. Double click on the hard drive icon to open the disk drive.  
2. Locate and double click on the Applications folder.  
3. Locate and double click on the Microsoft Office folder.  
4. Locate and double click on the blue W icon labeled Microsoft Word Document.  

5. With your cursor at the top of the document, enter the following title: ‘equations’ 
6. Hit the Enter key once.  
7. Enter the following subtitle:  

Researched by‘equations’ 
8. Save your document by going to File > Save As. Save the file as‘equations’." Click "Save." 
 9. Hit the Enter key three times. 

‘ms_word’.docx
‘equations’.docx


Q9. Create a file in MS-word that convert existing highlight text to table 
as shown below and save it as file name ‘text_to_table’. Describe all 
steps involved in it? 

Ans: ‘text_to_table’.docx 

Steps involve in it : 

Create your file in Microsoft Word: 
 1. Double click on the hard drive icon to open the disk drive.  
2. Locate and double click on the Applications folder.  
3. Locate and double click on the Microsoft Office folder.  
4. Locate and double click on the blue W icon labeled Microsoft Word Document.  

5. With your cursor at the top of the document, enter the following title: ‘text_to_table’ 
6. Hit the Enter key once.  
7. Enter the following subtitle:  

Researched by‘text_to_table’ 
8. Save your document by going to File > Save As. Save the file as‘text_to_table’." Click 

"Save." 
 9. Hit the Enter key three times. 

 
Q10. Create a file in MS-Word to insert a table in the document. Describe 
all steps involved in it? 
 
Ans: Table Fig: rows:3 
                            Column:10 

          

          

          
 
Steps involve in it : 

Create your file/Table in Microsoft Word: 
 1. Double click on the hard drive icon to open the disk drive.  
2. Locate and double click on the Applications folder.  
3. Locate and double click on the Microsoft Office folder.  
4.Locate Insert option in ribbon bar. 
5.select Insert, you will see table option, Insert/Draw table as you desire/recommended. 
 

Q11. Create a following worksheet in MS-excel and save it with name 
‘book1’? 
Ans: ‘book1’.xlsx 
 

‘text_to_table’.docx
‘book1’.xlsx


Q12. Calculate the following things of a range (C2:C11) of data in the worksheet 
created in question no 10.  

  the sum of the marks using AutoSum in a range of cells (C2:C11) 

  average of the marks in a range of cells (C2:C11) 

  highest marks in a range of cells (C2:C11) 

  minimum marks in a range of cells (C2:C11) 
 
Ans : A          B             C 

Roll No Name Marks 

1 n1 60 

2 n2 70 

3 n3 80 

4 n4 90 

5 n5 40 

6 n6 50 

7 n7 77 

8 n8 44 

9 n9 88 

10 n10 55 

 SUM 654 

 AVERAGE 65.40 

 MAX 90 

 MIN 40 

 

 
Q13 a) Describe various steps involved in the following  

 To modify column width of a worksheet 

 To modify the row height of a worksheet 

 To delete rows and columns of a worksheet 

Q13 b) Describe following terms in the worksheet  

 Absolute reference and relative reference in formula 

 Cell address. 

Ans: (A)Set a column to a specific width 

1. Select the column or columns that you want to change. 
2. On the Home tab, in the Cells group, click Format. 
3. Under Cell Size, click Column Width. 
4. In the Column width box, type the value that you want. 
5. Click OK. 



To set row height with a specific measurement: 

6. Select the rows you want to modify. 

7. Click the Format command on the Home tab. The format drop-down menu appears. 

8. Select Row Height. Increasing the column width. 

9. The Row Height dialog box appears. Enter a specific measurement. ... 

10. Click OK. 

 

To delete rows and columns of a worksheet 

If you don't need any of the existing cells, rows or columns: Select the cells, rows, 
or columns that you want to delete. On the Home tab, click the arrow under Delete, and then click 
the appropriate delete option. 

 

(B) Absolute reference and relative reference in formula 

Relative references change when a formula is copied to another cell. Absolute references, on 
the other hand, remain constant no matter where they are copied. 

 
Cell address : A cell address, is an alphanumeric value used to identify a specific cell in a 

spreadsheet. Each cell reference contains one or more letters followed by a number. The letter or 
letters identify the column and the number represents the row. 

Q14. a) What tools are available to customize our PowerPoint presentation?  

Q14 b) Write the steps for the following action for creation of power point 
presentation   

Open a Blank presentation 

Save the presentation as Lab1.pptx 

Add a Title to the first slide: the name of your college 

 Type your  first name and last name in the Subtitle section 

 Add a New Slide which has a Title and Content 

Ans : A) 1. Open a blank presentation again or start from one you've already 
created. 
2. Choose a "theme" or create your own. 
3.Create a variety of slides for different purposes. 
4. Use the Duplicate Slides feature to save you time. 
5. Add transitions to your slides . 
6. Add animations to your slides . 
7. Save your presentation. 
8. Run your presentation. 
9. Advance the slides. 



B) Open a Blank presentation: 
1.  Select the File tab to go to Backstage view. 

2. Select New on the left side of the window, then click Blank Presentation. 

3. A new presentation will appear. 

Save the presentation as Lab1.pptx : 

Step 1 − Click on the File tab to launch the Backstage view and select Save. 

Step 2 − In the Save As dialog, type in the file name and click "Save". 

Step 3 − The default file format is Lab1.pptx. If you want to save the file with a different name, 

choose one of the file types from the "Save as type" dropdown list. 

 

Add a Title to the first slide: the name of your college 
1. Select the slide whose layout you will change so that it can have a title. 
2. Click Home > Layout. 
3. Select Title Slide for a standalone title page or select Title and Content for a slide that contains 

a title and a full slide text box.  
4. Select the Click to add title text box. 

 

Type your  first name and last name in the Subtitle section 

1.Select the subtitle slide whose layout you will change so that it can have a subtitle. 
3.select Subtitle slide to add Content in a slide and a full slide text box.  
4.Select the Click to add subtitle title text box. 
 

Add a New Slide which has a Title and Content 

• To insert a new slide that contains a “Title and Content” slide layout, click the “Home” tab 
in the Ribbon.  

• Then click the “New Slide” button in the “Slides” button group. 

• To insert a new slide and choose the slide layout, click the drop-down part of this button. 

 
 

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your 
skill to use the tools of PowerPoint. It should include the following things   

Title slide & bullet list 

 Inserting Excel Sheet 

Clip art and Text 

Slide show effects 
 

1. Ans: Title slide & bullet list: Choose Insert > New Slide, click the New Slide button on the 

toolbar, or press the hotkey Ctrl+M. 
2. From the Slide Layout task pane, choose the Bulleted List layout (Figure 2.8). 
3. Click the title placeholder and type the title of your bulleted list. 

Inserting Excel Sheet 
In PowerPoint, on the Insert tab, click or tap Object. In the Insert Object dialog box, select Create 
from file. Click or tap Browse, and in the Browse box, find the Excel workbook with the data you 
want to insert and link to. Before you close the Insert Object box, select Link, and click OK. 



Clip art and Text: 
1. Click in the slide where you want to insert a clip art file. 
2. On the Insert tab, in the Images group. 

3. In the Insert Pictures dialog box (Clip Art task pane in PowerPoint 

2007/2010)appears. 
4. Your search results load in the task pane. 
5. Locate the clip art you want to insert in your slide and double-click on it or click the item and 

select Insert. 

Slide show effects 

Open your PowerPoint slideshow. Click the [Animations] tab > From the "Advanced Animation" 
group, click "Animation Pane". Right-click the first animation > Select "Start With Previous". This 
will cause your first animation to start as soon as the slide appears on the screen. 

Part -2 : 

 Q16. What is the difference between Machine Language and High Level Language? 

Ans: Machine Language : A computer programming language consisting of binary instructions 
which a computer can respond to directly. Sometimes it is referred to as machine code or object 
code, machine language is a collection of binary digits or bits that the computer reads and 
interprets. A computer cannot directly understand the programming languages used to create 
computer programs, so the program code must be compiled. Example: 01001000, 01100101, 
01101100, 01101100 etc. 

High -level language : A high-level language is any programming language that enables 
development of a program in a much more user-friendly programming context. This language 
is a programming language with strong abstraction about the details of the computer in contrast 
to low-level programming language (Assembly Language). Ex: C, C++, Java High level 
languages are grouped in two categories based on execution model – compiled or interpreted 
languages. Compiler and interpreter are used to convert the high level language into machine 
level language. The program written in high level language is known as source program and 
the corresponding machine level language program is called as object program. Both compiler 
and interpreter perform the same task but there working is different. Compiler read the 
program at-a-time and searches the error and lists them. If the program is error free then it is 
converted into object program. When program size is large then compiler is preferred. Whereas 
interpreter read only one line of the source code and convert it to object code. 

Q17. Discuss about different data types of C programming Language? 

Ans : Data types specify how we enter data into our programs and what type of data we enter. C 
language has some predefined set of data types to handle various kinds of data that we can use in 
our program. These data types have different storage capacities. 
C language supports 2 different type of data types: 
1.) Primary data types: 

These are fundamental data types in C namely integer(int), floating point(float), 

character(char) and void. 



2.) Derived data types: 
Derived data types are nothing but primary datatypes but a little twisted or grouped together 
like array, stucture, union and pointer.  

Data type determines the type of data a variable will hold. If a variable x is declared as int. it means 

x can hold only integer values. Every variable which is used in the program must be declared as 
what data-type it is. 

 

Type Keyword Value range which can be represented by this data type 

Character char -128 to 127 or  0 to 255 

Number int -32,768 to 32,767 or -2,147,483,648 to 2,147,483,647 

Small Number short -32,768 to 32,767 

Long Number long -2,147,483,648 to 2,147,483,647 

Decimal Number float 1.2E-38 to 3.4E+38 till 6 decimal places 

 

Q18. Find the output of the following expressions?  

a) X=20/5*2+30-5  b) Y=30 – (40/10+6) +10  c) Z= 40*2/10-2+10 

Ans: A) 33 
           B) 30 
           C) 16 

Q19. Describe the syntax of the following statements ? 

a) If – else statement  b) for loop  c) while loop  d) do-while loop 

Ans: A) if (test expression) { 

    // statements to be executed if the test expression is true 

} 

else { 

    // statements to be executed if the test expression is false 

} 

 

B) for (initializationStatement; testExpression; updateStatement) 

{ 

    // statements inside the body of loop 

} 

 

C) while (testExpression)  

{ 

    // statements inside the body of the loop  

} 

 

 



D) do 

{ 

   // statements inside the body of the loop 

} 

while (testExpression); 

 

Q20. Find the output of the following program segments? 

a) 1,2,3……. 

b) 2,3,4……….. 

c) 100. 


