
        CCA-101: Fundamentals of IT & Programming   

                                                               Assignment -1   

Q1: What are the four fundamental parts of computer? Explain it with the help of diagram? 

Answer: -   1:- Input Device 2:- Central Processing Unit 3:- Memory Unit 4:- Output Device 

          

Q2: Discuss about the classification of computers based on size and capacity? 

Answer:- Computers are classified into four parts as per size and capacity, which are:- 

 1:-Super Computer :- Largest In size and most powerful in terms of speed,accuracy and processing 

power. It can perform over one trillion calculations per second. 

 2:- Mainframe Computer :- Very large in size and can fill a room. These computers are also powerful 

and can perform thosands of millions of instructions per second. Used in railway reservations,flight 

scheduling etc. 

 3:-Mini Computer:- Much smaller in size as compared to mainframe computers bur slightly bigger 

and expensive than desktop computers. Gradually used by small and medium businesses as their 

servers.  

 4:-Micro Computer:-  Microcomputers are the most frequently used type of computer. Also, known 

as Personal Computer (PC), a microcomputer is a small computer system designed to be used by one 

person at a time. 

 

Q3: What is the meaning of computer generation? How many Computer Generations are defined? 

What technologies were/are used? 



Answer:- The evolution of digital computing is often divided into generations. Each generation is 

characterized by dramatic improvements over the previous generation in the technology used to 

build computers, in terms of the internal organization of computer and programming languages. 

  Five Generations of Computers: 

First Generation: Vacuum Tubes (1940-1956): The first computer systems used vacuum tubes for 

circuitry and magnetic drums for memory, and were often enormous, taking up entire rooms. These 

computers were very expensive to operate and in addition to using a great deal of electricity, the 

first computers generated a lot of heat, which was often the cause of malfunctions. First generation 

computers relied on machine language, the lowest-level programming language understood by 

computers, to perform operations, and they could only solve one problem at a time. It would take 

operators days or even weeks to set-up a new problem. Input was based on punched cards and 

paper tape, and output was displayed on printouts. The UNIVAC (Universal Automatic Computer) 

and ENIAC (Electronic Numerical Integrator and Computer) computers are examples of first-

generation computing devices. The UNIVAC was the first commercial computer delivered to a 

business client, the U.S. Census Bureau in 1951. 

Second Generation: Transistors (1956-1963): The world would see transistors replace vacuum tubes 

in the second generation of computers. The transistor was invented at Bell Labs in 1947 but did not 

see widespread use in computers until the late 1950s. The transistor was far superior to the vacuum 

tube, allowing computers to become smaller, faster, cheaper, more energy-efficient and more 

reliable than their first-generation predecessors. Though the transistor still generated a great deal of 

heat that subjected the computer to damage,it was a vast improvement over the vacuum tube. 

Second-generation computers still relied on punched cards for input and printouts for output. 

Second-generation computers moved from cryptic binary machine language to symbolic, or 

assembly, language.  

Third Generation: Integrated Circuits (1964-1971) The development of the integrated circuit was the 

hallmark of the third generation of computers. Transistors were miniaturized and placed on silicon 

chips, called semiconductors, which drastically increased the speed and efficiency of computers. 

Instead of punched cards and printouts, users interacted with third generation computers through 

keyboards and monitors and interfaced with an operating system, which allowed the device to run 

many different applications at one time with a central program that monitored the memory. 

Computers for the first time became accessible to a mass audience because they were smaller and 

cheaper than their predecessors. 

 Fourth Generation:  Microprocessors (1971-Present): The microprocessor brought the fourth 

generation of computers, as thousands of integrated circuits were built onto a single silicon chip. 

What in the first generation filled an entire room could now fit in the palm of the hand. The Intel 

4004 chip, developed in 1971, located all the components of the computer—from the unit and 

memory to input/output controls—on a single chip. In 1981 IBM introduced its first computer for the 

home user, and in 1984 Apple introduced the Macintosh. Microprocessors also moved out of the 

realm of desktop computers and into many areas of life as more and more everyday products began 

to use microprocessors. As these small computers became more powerful, they could be linked 

together to form networks, which eventually led to the development of the Internet. Fourth 

generation computers also saw the development of GUIs, the mouse and handheld devices. 



 Fifth Generation: Artificial Intelligence (Present and Beyond): Fifth generation computing devices, 

based on artificial intelligence, are still in development, though there are some applications, such as 

voice recognition, that are being used today. The use of parallel processing and superconductors is 

helping to make artificial intelligence a reality. Quantum computation and molecular and 

nanotechnology will radically change the face of computers in years to come. The goal of fifth-

generation computing is to develop devices that respond to natural language input and are capable 

of learning and self-organization. 

Q4: Differentiate between Volatile & Non- Volatile memories ? 

Answer:-   

VOLATILE MEMORY NON-VOLATILE MEMORY 

1: Data loses when the power is turned off. 1: Data remains safe if saved even if the power is 
turned off. Always retains its data. 

2: The programs and data that the CPU requires 
during execution of a program are stored in this 
memory. 

2: Stores crucial information essential to operate 
the system, like the program essential to boot 
the computer. 

3: Ex:- Random Access Memory (RAM) 3: Ex:- Read Only Memory (ROM)  

 

Q5: Distinguish among system software, application software and open source software on the 

basis of their features ? 

Answer:-   

System Software Application Software Open Source Software 

1: Designed to run a computer's 
hardware and application 
programs. 

1: Created for a specific 
purpose, used by end users. It 
can be called an application or 
simply an app. 

1: Type of computer software in 
which source code is released 
under a license in which the 
copyright holder grants users the 
rights to study, change, and 
distribute the software to anyone 
and for any purpose. 

2: Ex: Operating systems, 
compilers, editors and drivers 
etc 

2: Ex: Word processor, 
accounting application, a web 
browser, an email client,  media 
player etc 

2: Ex: The Linux operating 
system(OS) 

   

   

 

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with file name 

“yourself”. Describe all steps involved in it ? 

Answer:-   

To create a new blank document: - 

 1:- Click the Microsoft Office button. 



 2:- Select New. The New Document dialog box appears.  

3:- Select Blank document under the Blank and recent section. It will be highlighted by default.  

 4:- Click Create. A new blank document appears in the Word window. 

5:- Now write the paragraph about yourself. 

Now to save it by the name “yourself” :- 

1:- Click the Microsoft Office button.  

2:- Select Save As Word Document. The Save As dialog box appears. 

3:- Select the location where you want to save the document using the drop-down menu.  

4:- Enter a name for the document  i.e  “yourself” . 

5:-  Click the Save button. 

Q6 b) Write steps regarding following 

To change the font style 

To change the font size 

To change the font colour  

To highlight (in yellow) the line that reads “need to get IMS’s address”. 

Answer:-  

To change the font style:- 

1:- Select the text you want to modify. 

2:- Left-click the drop-down arrow next to the font style box on the Home tab. The font style drop-

down menu appears. 

3:- Move your cursor over the various font styles. A live preview of the font will appear in the 

document. 

4:- Left-click the font style you want to use. The font style will change in the document. 

To change the font size:- 

1:- Select the text you want to modify. 

2:- Left-click the drop-down arrow next to the font size box on the Home tab. The font size drop-

down menu appears.  

3:- Move your cursor over the various font sizes. A live preview of the font size will appear in the 

document. 



4:- Left-click the font size you want to use. The font size will change in the document. 

To change the font colour:- 

1:- Select the text you want to modify. 

2:- Left-click the drop-down arrow next to the font colour box on the Home tab. The font colour 

menu appears. 

 3:- Move your cursor over the various font colours. A live preview of the colour will appear in the 

document. 

4:- Left-click the font colour you want to use. The font colour will change in the document. 

To highlight (in yellow) the line that reads “need to get IMS’s address”. :- 

1:- Select the text “need to get IMS’s address” to modify. 

2:- Left-click the drop-down arrow next to the Text Highlight colour box on the Home tab. The text 

colour menu appears. 

 3:- Move your cursor to yellow among various text colours. A live preview of the colour will appear 

in the document. 

4:- Left-click the text colour which is yellow .The text colour will change in the document. 

Q7. Create a file in MS-Word for the following document and save it with file name ‘ms-word’. 

Describe all steps involved in it? 

Answer:-  

Steps involved:- 

1:- Click the Microsoft Office button. 

 2:- Select New. The New Document dialog box appears.  

3:- Select Blank document under the Blank and recent section. It will be highlighted by default.  

 4:- Click Create. A new blank document appears in the Word window. 

5:- Now write the document  given. The font colour, size, text can be selected from font colour, font 

size, bold,italic and underline menu in home tab. 

Now to save it by the name “ms-word” :- 

1:- Click the Microsoft Office button.  

2:- Select Save As Word Document. The Save As dialog box appears. 

3:- Select the location where you want to save the document using the drop-down menu.  

4:- Enter a name for the document  i.e  “ms-word” . 



5:-  Click the Save button. 

Q8. Create a file in MS-word for the following document and save it with file name ‘equations’. 

Describe all steps involved in it ? 

Answer:-  

Steps involved:- 

 1:- Click the Microsoft Office button. 

 2:- Select New. The New Document dialog box appears.  

 3:- Select Blank document under the Blank and recent section. It will be highlighted 

by default.  

 4:- Click Create. A new blank document appears in the Word window. 

 5:- Now write the document  given.The font which is in power and in the base can be 

selected from font menu in home tab. 
 

Now to save it by the name “equations” :- 

 1:- Click the Microsoft Office button.  

 2:- Select Save As Word Document. The Save As dialog box appears. 

 3:- Select the location where you want to save the document using the drop-down 

menu.  

 4:- Enter a name for the document  i.e  “equations” . 

 5:-  Click the Save button. 
 

Q9. Create a file in MS-word that convert existing highlight text to table as shown below and save 

it as file name ‘text_to_table’. Describe all steps involved in it ? 

Answer:-  

 Write down the text you want to convert. 

 Select the text you want to convert. 

 Select the Insert tab. 

 Click on Table command. A dialog box appears 

 Click on Convert Text to Table, a new dialog box appears 

 Here set number of columns. (required 2) 

 Click on OK finally, selected text convert in a table. 

 
Now to save it by the name “text_to_table” :- 

 1:- Click the Microsoft Office button.  

 2:- Select Save As Word Document. The Save As dialog box appears. 

 3:- Select the location where you want to save the document using the drop-down 

menu.  

 4:- Enter a name for the document  i.e  “text_to_table” . 

 5:-  Click the Save button. 



Q10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in 

it ? 

Answer:-   

To insert a table in the document:- 

 Place your insertion point in the document where you want the table to appear. 

 Select the Insert tab.  

 Click the Table command.  

 Drag your mouse over the diagram squares to select the number of columns and rows 

in the table. 

 Left-click your mouse and the table appears in the document. 

Now to save it by the name “Insert a table” :- 

 1:- Click the Microsoft Office button.  

 2:- Select Save As Word Document. The Save As dialog box appears. 

 3:- Select the location where you want to save the document using the drop-down 

menu.  

 4:- Enter a name for the document  i.e  “Insert a table”. 

 5:-  Click the Save button. 

 
Q11.  Create a following worksheet in MS-excel and save it with name ‘book1’? 

Answer: - Saved 

Q12. Calculate the following things of a range (C2:C11) of data in the worksheet created in 

question no 10.  

 the sum of the marks using AutoSum in a range of cells (C2:C11)  

 average of the marks in a range of cells (C2:C11)  

 highest marks in a range of cells (C2:C11) 

 minimum marks in a range of cells (C2:C11) 

 

Answer:-  The sum of the marks using AutoSum in a range of cells (C2:C11) :- 654, SUM(C2:C11) 

                   Average of the marks in a range of cells (C2:C11):- 65.4,  AVERAGE(C2:C11) 

                   Highest marks in a range of cells (C2:C11):- 90, MAX(C2:C11) 

                   Minimum marks in a range of cells (C2:C11):- 4,   MIN(C2:C11) 

 

 

 

 



Q13 a) Describe various steps involved in the following:- 

 To modify column width of a worksheet 

 To modify the row height of a worksheet  

 To delete rows and columns of a worksheet 
 

Answer:-  

To modify column width of a worksheet:- 

Method 1 - How to change Column width by clicking and dragging on boundary 

gridline 

To change the Column width of a single Column by clicking and dragging on Column 

boundary gridline, follow these steps:- 

Step1 - Select the Column you want to change its height by clicking on Column letter. Place the 

mouse pointer on left-side or right-side gridline of the Column letter until the mouse pointer turns to a 

double-sided arrow. You need to place the mouse pointer on left-side or right-side gridline depending 

on to left or right direction you want to change the Column width. Now left click on the double-sided 

arrow. 

Step2 - Drag the mouse till the desired width is reached and then drop the mouse to change the 

Column width. As you drag, Excel will keep displaying the changing Column width as tooltip 

message. 

Similarly, you can change the width of multiple Columns simultaneously by click, drag and 

drop. Select multiple Columns and then click, drag and drop on left-most or right-most gridline of the 

Columns selection for changing the width of multiple Columns simultaneously. 

Method 2 - How to change Column width by entering the exact Column width value 

Sometimes it is difficult to select the exact Column width by using drag and drop method described 

above, because the Column width value keep changing as you drag. Follow below steps to change 

single Column width by entering the exact Column width value. 

Step 1 - Right-click the Column you want to change the column width and click the "Column 

Width" to open "Column Width" dialog box from the context menu. 

You can open the "Column Width" dialog box also from Excel Ribbon > "Home" Tab > "Cells" > 

"Format". 

Step 2 - Enter exact value for Column width in Column width dialog box and click "OK" to change 

the Column width. 

Similarly, you can change the width of multiple Columns simultaneously by typing-in the Column 

width value. Select multiple Columns and then right-click on any Column in the selection. Click the 

"Column Width" from the context menu and type-in the Column width value in dialog box. Click 

"OK" button. 

https://www.omnisecu.com/excel/worksheet/how-to-hide-or-show-excel-worksheet-gridlines.php
https://www.omnisecu.com/excel/worksheet/how-to-hide-or-show-excel-worksheet-gridlines.php
https://www.omnisecu.com/excel/worksheet/how-to-select-range-in-excel-worksheet.php
https://www.omnisecu.com/excel/worksheet/how-to-select-range-in-excel-worksheet.php


To modify the row height of a worksheet:- 

 

Method 1 - How to change Row height by clicking and dragging on boundary 

gridline 

To change the Row height of a single Row by clicking and dragging on Row boundary gridline, 

follow these steps. 

Step1:- Select the Row you want to change its height by clicking on Row number. Place the mouse 

pointer on top or bottom gridline of the Row number until the mouse pointer turns to a double-sided 

arrow. You need to place the mouse pointer on top or bottom gridline depending on to top or bottom 

direction you want to change the Row height. Now left click on the double-sided arrow, 

Step2:- Drag the mouse till the desired height is reached and then drop the mouse to change the Row 

height. As you drag, Excel will keep displaying the changing Row height as tooltip message. 

 

Similarly, you can change the height of multiple Rows simultaneously by click, drag and drop. Select 

multiple Rows and then click, drag and drop on top-most or bottom-most gridline of the Rows 

selection for changing the height of multiple Rows simultaneously. 

Method 2 - How to change Row height by entering the exact Row height value 

Sometimes it is difficult to select the exact Row height by using drag and drop method described 

above, because the Row height value keep changing as you drag. Follow below steps to change single 

Row height by entering the exact Row height value. 

Step1:- Right-click the Row you want to change the height and click the "Row Height" to open "Row 

Height" dialog box from the context menu. 

You can open the "Row Height" dialog box also from Excel Ribbon > "Home" Tab > "Cells" > 

"Format" as shown below. 

Step2:- Enter exact value for Row height in Row height dialog box and click "OK" to change the 

Row height. 

Similarly, you can change the height of multiple Rows simultaneously by typing-in the Row height 

value. Select multiple Rows and then right-click on any Row in the selection. Click the "Row Height" 

from the context menu and type the Row height value in dialog box. Click "OK" button. 

To delete rows and columns of a worksheet:- 

 Method 1 - How to delete a single Row or Column from Excel worksheet 

Step1:- Select the Row or column which you want to delete by clicking on its Row number from the 

context menu. 

Step2:- After selecting the Row/Column number, right-click anywhere on the Row/Column and select 

"Delete"  

https://www.omnisecu.com/excel/worksheet/how-to-hide-or-show-excel-worksheet-gridlines.php
https://www.omnisecu.com/excel/worksheet/how-to-hide-or-show-excel-worksheet-gridlines.php
https://www.omnisecu.com/excel/worksheet/how-to-select-range-in-excel-worksheet.php
https://www.omnisecu.com/excel/worksheet/how-to-select-range-in-excel-worksheet.php
https://www.omnisecu.com/excel/worksheet/how-to-select-range-in-excel-worksheet.php


Step3:- Entire row/column will be deleted. 

 Method 2 - How to delete multiple Rows/Columns from Excel worksheet 

To delete multiple Rows/Columns from Excel worksheet, follow these steps. 

Step1:- Select the Row/Columns you want to delete from Excel worksheet by clicking, dragging and 

releasing mouse pointer on its Row/Column numbers. 

Step2:- After selecting the Rows/Columns, right-click on any of the selected Rows/Columns and 

select "Delete" from context menu. 

Q13 b) Describe following terms in the worksheet:- 

 Absolute reference and relative reference in formula  

 Cell address  

Answer:-  

Relative reference:- 

A relative cell reference is the most widely used cell reference in formulas in Excel. These 

are basic cell references that adjust and change when copied or using the Auto fill function in 

Excel. For Example: If the position of the cell that contains the formula changes, the 

reference is changed. 

Absolute reference:- 

An Absolute cell reference is indicated in your spreadsheet by a $ sign around the cell, for 
example =$A$1 means that when referring to this cell is ALWAYS in that location. If  the 
position of the cell that contains the formula changes, the absolute cell reference remains 
the same. If you copy the formula across rows or down columns, the absolute cell reference 
remains the same unlike the example above. 

Cell address:- 

The cell ADDRESS function is categorized under Excel Lookup and Reference functions. It 
will provide a cell reference (its “address”) by taking the row number and column letter. The 
cell reference will be provided as a string of text. The function can return an address in a 
relative or absolute format and can be used to construct a cell reference inside a formula. 

As a financial analyst, cell ADDRESS can be used to convert a column number to a letter, or 
vice versa. We can use the function to address the first cell or last cell in a range. 

Q14. a) What tools are available to customize our PowerPoint presentation? 

Answer: - Some of the tools are:- 

                    Clipart, Animation, Slide Show etc. 

 

https://corporatefinanceinstitute.com/resources/excel/functions/
https://corporatefinanceinstitute.com/resources/careers/jobs/financial-analyst-job-description/


Q14 b) Write the steps for the following action for creation of power point 

presentation  

 Open a Blank presentation 

 Save the presentation as Lab1.ppt. 

 Add a Title to the first slide: the name of your college 

 Type your first name and last name in the Subtitle section  

 Add a New Slide which has a Title and Content 

Answer:-  

Open a Blank presentation:- 

1. Double click on the Microsoft PowerPoint shortcut on the desktop, or 
Click on the Start menu, click on Programs, and click on Microsoft Power Point. 

2. Click on the Microsoft Office Button and click new.  
3. A new window will appear with several categories of templates to choose from.  
4. Click on the template style that you wish to use and click the Create 

Button.This will allow us to easily a consistent background and style to our presentati
on. 

5. Slides will be added automatically to your slide presentation.Instructios will be include
d on each slide explaining how to add content to your slideshow. 

 

Save the presentation as Lab1.ppt.- 

 Click on the Microsoft Office Button and click “save as”.  

 In the File name field, type the name of the presentation i.e. Lab1.ppt.  

 Click on the Save in: dropdown menu and choose where you would like the 
presentation saved.  

 Click on the Save button.  

 

Add a Title to the first slide: the name of your college:- 

 Click on the text area (Title) of the slide. 

 Start typing the name of college. . 

 To make it look nice click in the clip art area. The clip art gallery will appear.  

 Type a keyword into the clipart gallery search box and click on Go. 

 The title i.e. name of the college will appear on the slide. 

Type your first name and last name in the Subtitle section:- 

 Click on the Subtitle area of the slide. 

 Start typing your first name and last name. . 

 To make it look nice click in the clip art area. The clip art gallery will appear.  

 Type a keyword into the clipart gallery search box and click on Go. 

 The subtitle i.e. your name will appear on subtitle block in the slide.  



Add a New Slide which has a Title and Content:- 

 Click on New Slide on the Slides group of the Home tab. 

 A new slide will be created after your currently selected slide. 

 Write the title and content in the Title and Subtitle section respectively.  

 

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your 

skill to use the tools of PowerPoint. It should include the following things 

 Title slide & bullet list 

 Inserting Excel Sheet 

 Clip art and Text  

 Slide show effects 

Answer:- 

1:- Title slide & bullet list:- 

Title Slide 

 Select the slide whose layout you will change so that it can have a title. 

 Click Home> Layout 

 Select Title Slide for a standalone title page or select Title and Content for a 
slide that contains a title and a full slide text box. 

 Select the Click to add Title text box. 

Bullet list  

 Click in the text box or placeholder where you want to add bulleted or 
numbered text. 

 Now start typing your list. 

 Press return to create a new list item. 

 Select lines of text that are already on your slide. 

 Click Bullets in Home tab to format that text as a list.  

2:- Inserting Excel Sheet:- 

 For the first step, just create Excel spreadsheet as you normally would and 
save it on the hard drive. 

 

 Create a new PowerPoint presentation or open a presentation that the user 
wants to insert the spreadsheet into. 

 Go to the slide to insert the spreadsheet into and choose Insert then Object. 
 

 Once the user has chosen to Insert Object, click on Create from New to 
create a new object from the existing spreadsheet and then browse to the 



hard drive to find the Excel spreadsheet that the user wants to insert. Choose 
and click [OK] twice. 

 Once this is done, the user will have the spreadsheet successfully inserted 
into PowerPoint. 

 

3:- Clip art and Text:- 

Adding and editing text:- 

 Click on the text area of the slide.  

 Start typing. 

 When typing in a bulleted list area, press the Enter key on your keyboard to cr
eate another bulleted line.  

Adding or changing clip art:- 

 Click in the clip art area. The clip art gallery will appear.  

 Type a keyword into the clipart gallery search box and click on Go. 

 Click on the desired clip art that appears in the gallery to insert it into your slid
e.       

Inserting additional text boxes:- 

 On the Insert tab, in the Text group click on Text Box.    

 The cursor will turn into what looks like an upside down “t”. 

 Click on the slide and drag the mouse diagonally on the slide to create a new t
ext box of whatever size and shape you need and release the mouse button.    

 Click on the new text box to begin typing text into it.   

Inserting additional clip art:- 

 On the Insert tab, in the Illustrations group click on Clip Art.    

 The clip art gallery will open in the task pane. 
Type in a keyword and click on Go. 

 Click on the art that you would like to include in your slide. The art will appear 
in your slide and you can drag it with the mouse to wherever you would like it t
o appear on the slide.  

 

4:- Slide show effects:- 

It is a presentation tool providing enhanced transitions and effects. Using a standard Presentation 

Software user interface, people can create slide presentation with movies and images in a simpler 

way than using video editing software. 



 On the left side of the slide window, in the pane that contains the Outline and 

Slides tabs, click the Slides tab. 

 Select any slide thumbnails of the slides on which you want to apply or change a 

Slide transition. 

 On the Animations tab, in the Transition to the Slide group, click a Slide group. 

 Now click a slide transition effect. 
 

                           Part -2 
Q16. What is the difference between Machine Language and High Level Language? 

Answer:- 

Machine Language High Level Language 

1:-A computer programming language 
consisting of binary instructions which a 
computer can respond to directly. 

1:-A high-level language is any programming 
language that enables development of a 
program in a much more user-friendly 
programming context. 

2:- All operation codes have to be remembered. 2:-High level languages are programmer 
friendly. They are easy to write, debug and 
maintain. 

3:-Level of abstraction is lower than high level 
language. 

3:-It provides higher level of abstraction from 
machine languages. 

4:-Its machine language. 4:-It is machine independent language. 

5:-It requires no translator to translate the 
code. It is directly understood by the computer. 

5:-It takes additional translation times to 
translate the source to machine code. 

 

Q17. Discuss about different data types of C programming Language? 

Answer:-  

Following are the Data types in C programming languages − 

DATA TYPE KEYWORD 
Character:- char 

Number:-                                          int 

Small Number:- short 

Long Number:- long 

Decimal Number:- float 

 

Q18. Find the output of the following expressions  

a) X=20/5*2+30-5 

 b) Y=30 – (40/10+6) +10                   c) Z= 40*2/10-2+10 



Answer:-  

(a)X=20/5*2+30-5 

      X=20/10+30-5 

      X=2+30-5 

      X=32-5 

 X=27   (answer) 

(b) Y=30 – (40/10+6) +10    

      Y=30-(4+6) +10 

      Y=30-10+10 

      Y=30-20 

      Y=10    (answer) 

(c) Z= 40*2/10-2+10 

     Z=80/10-2+10 

     Z=8-2+10 

     Z=8+8 

     Z=16     (answer) 

 

 Q19. Describe the syntax of the following statements  

a) If – else statement 

b) for loop  

c) while loop   

d) do-while loop        
 

Answer:- 

(a )If – else statement:- 

                 if (expression) 

                 { 

                       Block of statements; 

                  } 



              else 

              { 

                   Block of statements; 

               } 

(b ) for loop :- 

for( Expression1; Expression2;Expression3) 

 {    

            Single statement   or   Block of statements; 

 } 

In the above syntax:  

 Expression1 :- Initializes variables.  (Ex: i=0) 

 Expression2 :- Conditional expression, as long as this condition is true, loop will 

keep executing.(Ex :  i<=10) 

 Expression3:-  Expression3 is the modifier which may be simple increment of a 

variable (Ex: i++) 
 

(c) while loop  :- 

while ( expression ) 

{  

     Single statement    or   Block of statements; 

} 

 

(d)do-while loop:- 

 

Do 

 {  

     Single statement   or   Block of statements; 

  } while(expression); 

 



Q20. Find the output of the following program segments:- 

(a) 

            #include <stdio.h> 

             int main()  

              {  

                   int i;  

                   for (i=1; i<2; i++)  

                           {        

                                   printf( "IMS Ghaziabad\n");  

                            }  

                  } 

 

Answer: -         IMS Ghaziabad 

 

(b)  

            #include <stdio.h> 

              int main()  

              {     

                   int i = 1;  

                   while ( i <= 2 )       

                           {   

                                  printf( "IMS Ghaziabad\n"); 

                                  i = i + 1;       

                            } 

              } 

 



Answer: -      IMS Ghaziabad 

                        IMS Ghaziabad 

 

(c) 

#include <stdio.h>  

 void main()   

 {      

      int a = 10, b=100;       

       if( a > b )       

               printf( "Largest number is %d\n”, a);    

       else         

               printf( "Largest number is %d\n”, b);     

  } 

 

Answer: -            Largest number is 100 

 


