
 

Q1: What are the four fundamental parts of computer? Explain it with the help of diagram. 

 

1. Input Unit:- The input unit is used to feed any form of data to the computer. Example: 

Keyboard, Mouse etc. 

2. Central Processing Unit:- The CPU is the major component that interprets and executes 

software instructions. It  also controls the operation of all other components such as 

memory, input, and output units. 

3. Arithmetic and Logic Unit: The ALU is a part of the CPU where various computing functions 

are performed on data. The ALU performs arithmetic operations such as addition, 

subtraction, multiplication, division, and logical operations. 

4. Control Unit: The control unit controls the flow of data between the CPU, memory, and I/O 

devices. It also controls the entire operation of a computer. 

5. Output Unit: an output unit is any hardware component that conveys information to users in 

an understandable form. Example Monitor Printer etc 

 

Q2: Discuss about the classification of computers based on size and capacity. 

Answer; Computer Classification 

A computer is a device that transforms unusable data into information. According to the set of instructions the 
user gives it, it processes the input and generates the desired outcome. Modern digital computers are classified 
on the basis of their size and capacity. The size and data handling capabilities of the various types of computers 
may be used to categorize them into two groups. 
 

 
 

Classification of Computers 
Different classifications of Computers are as follows. 

Classification According to Size 

There are four different sorts of computers based on their size and how they are configured to operate: 
 
 
 
1. Supercomputers 



The most efficient computers in terms of processing data and performance are supercomputers. These 
computers are used for research and exploratory purposes. Supercomputers are exceedingly large and highly 
expensive. It can only fit in large, air-conditioned spaces. 
Supercomputers are used for a range of tasks, such as space exploration, seismic research, and the testing of 
nuclear weapons. 
 
Supercomputer Features: 

• They make use of AI (Artificial intelligence) 

• They are the fastest and strongest; 

• They are very costly. 

• They are enormous in size. 

• They are employed by companies that manufacture goods. 

• They process information at a rapid rate. 
 

2. Mainframe Computers 

Despite being less efficient than supercomputers, mainframe computers are nevertheless extremely 
expensive. Large corporations and governmental organizations frequently employ mainframe computers to 
run everyday operations. They have the ability to store and analyze a lot of data. To maintain information on 
their customers, students, and insurance policyholders, banks, colleges, and insurance companies utilize them. 
They may also act as a server in a network environment. Hundreds of users may be managed simultaneously 
by them. 
 
Mainframe Computer Features: 

• They have enormous amounts of memory. 

• They are capable of running several different operating systems. 

• They have a significant number of CPUs with powerful processing speeds. 

• Tightly Coupled Clustering Technology is employed. 
 

3. Minicomputers 

Minicomputers are used by small businesses and industries. They go by the term "Midrange Computers." 
These minicomputers frequently have several users, just as mainframe computers. They are a bit slower than 
mainframe computers For example, the manufacturing department may employ minicomputers to keep an 
eye on specific production processes. 

 

Features of Minicomputers: 

• It is smaller than mainframes or supercomputers in terms of size. 

• In comparison to a mainframe or supercomputer, it is less costly. 

• It is able to perform many jobs at once. 

• It may be utilized by several users simultaneously. 

• It is utilized by small businesses. 
 

 

4. Microcomputers. 

A microcomputer, sometimes referred to as a personal computer (PC), is a type of computer that runs on a 
smaller scale than traditional computers (Personal Computer). A component that is commonly referred to as a 



motherboard houses the central processing unit (CPU), a microprocessor, memory in the form of ROM (Read 
Only Memory), RAM (Random Access Memory), I/O ports, and a bus system of connecting wires. They are the 
most affordable. 
 

Features of Microcomputers: 

• They are extensively employed for personal usage. 

• They are smaller and comparably less expensive. 

• Multi-user functionality is not supported. 

• It has a limited computational capacity. 

• They are quite simple to use. 
 

Based on Capacity 

According to fundamental operating principles, there are three different kinds of computers. They are as follows: 

1. Analogous Computers 

Analog computers process analog data. Temperature, pressure, weight, depth, and voltage are a few examples 
of this type of data. These have an infinite range of values and are continuous quantities. 
The first computers were analog, and they laid the groundwork for today's digital computers. 
 
2. Digital Computers 

In digital computers, letters, numbers, and other special symbols are represented by digits. On-off (ON-OFF) 
inputs are used by digital computers, and ON-OFF signals are also generated by them. 
 
An ON is often represented by a 1 and an OFF by a 0, respectively. A digital computer is capable of processing 
both numerical and non-numerical data. In addition to doing fundamental arithmetic operations like addition, 
subtraction, multiplication, and division, it can also perform logical operations. 
3. Hybrid Computers 

Computers that combine digital and analog components are called hybrid computers. It combines the best 
features of both types, having the speed of an analog computer with the memory and precision of a digital 
computer. Hybrid computers are typically used in specific applications where both forms of data need to be 
processed. As an example, a gas pump contains a processor that converts measurements of fuel flow into 
information about quality and cost. 

 
 

Q3: What is the meaning of computer generation? How many Computer Generations are 

defined? What technologies were/are used? 

Answer:- A computer is an electronic device that manipulates information or data. It can store, 
retrieve, and process data.  
Nowadays, a computer can be used to type documents, send an email, play games, and browse 
the Web. It can also be used to edit or create spreadsheets, presentations, and even videos. But 
the evolution of this complex system started around 1940 with the First Generation of computers 
and evolving ever since.  

Computers have evolved significantly over the years, and the history of computers is often divided 
into generations based on the technology used. Here are the five generations of computers: 

1. First Generation (1940s-1950s): The first computers used vacuum tubes for processing 
and magnetic drums for storage. They were large, expensive, and unreliable. 

2. Second Generation (1950s-1960s): The second generation of computers replaced 
vacuum tubes with transistors, making them smaller, faster, and more reliable. 



Magnetic core memory was also introduced, which was faster and more reliable than 
magnetic drums. 

3. Third Generation (1960s-1970s): The third generation of computers used integrated 
circuits, which allowed for even smaller and faster computers. They also introduced 
magnetic disk storage and operating systems. 

4. Fourth Generation (1970s-1980s): The fourth generation of computers saw the 
introduction of microprocessors, which made personal computers possible. They also 
introduced graphical user interfaces and networking. 

5. Fifth Generation (1980s-Present): The fifth generation of computers is still ongoing, 
and is focused on artificial intelligence and parallel processing. This generation also 
saw the development of mobile computing and the internet. 

 

First Generation Computers 
The technology behind the primary generation computers was a fragile glass device, which was 
called a vacuum tube. These computers were very heavy and really large. These weren’t very reliable 
and programming on them was a tedious task as they used low-level programming language and 
used no OS. First-generation computers were used for calculation, storage, and control purpose. 
They were too bulky and large that they needed a full room and consume a lot of electricity. Punch 
cards were used for improving the information for external storage. Magnetic card used . Machine 
and assembly language is developed. 
Examples of some main first-generation computers are mentioned below. 

• ENIAC: Electronic Numerical Integrator and Computer, built by J. Presper Eckert and 
John V. Mauchly was a general-purpose computer. It had been cumbersome, and 
large, and contained 18,000 vacuum tubes. 

• EDVAC: Electronic Discrete Variable Automatic Computer was designed by von 
Neumann. It could store data also as instruction and thus the speed was enhanced. 

• UNIVAC: Universal Automatic Computer was developed in 1952 by Eckert and 
Mauchly. 

 
Characteristics of First-Generation Computers 

Characteristics Components 

Main electronic component Vacuum tube. 

Programming language Machine language. 

Main memory Magnetic tapes and magnetic drums. 

Input/output devices Paper tape and punched cards. 

Speed and size 
Very slow and very large (often taking up an 

entire room). 

Examples of the first generation IBM 650, IBM 701, ENIAC, UNIVAC1, etc. 

 
 
Second Generation Computers 
Second-generation computers used the technology of transistors rather than bulky vacuum tubes. 
Another feature was the core storage. A transistor may be a device composed of semiconductor 
material that amplifies a sign or opens or closes a circuit. 



Transistors were invented in Bell Labs. The use of transistors made it possible to perform powerfully 
and with due speed. It reduced the dimensions and price and thankfully the warmth too, which was 
generated by vacuum tubes. Central Processing Unit (CPU), memory, programming language, and 
input, and output units also came into the force within the second generation. 
The programming language was shifted from high level to programming language and made 
programming comparatively a simple task for programmers. Languages used for programming 
during this era were FORTRAN (1956), ALGOL (1958), and COBOL (1959). 

 
Characteristics of Second-Generation Computers 

Characteristics Components 

Main electronic component Transistor. 

Programming language Machine language and assembly language. 

Memory Magnetic core and magnetic tape/disk. 

Input/output devices Magnetic tape and punched cards. 

Power and size 
Smaller in size, had low power consumption, 
and generated less heat (in comparison with 

the first-generation computers). 

Examples of the second generation 
PDP-8, IBM1400 series, IBM 7090 and 7094, 

UNIVAC 1107, CDC 3600, etc. 

 
Third Generation Computers 
During the third generation, technology envisaged a shift from huge transistors to integrated 
circuits, also referred to as IC. Here a variety of transistors were placed on silicon chips, called 
semiconductors. The most feature of this era’s computer was speed and reliability. IC was made 
from silicon and also called silicon chips. 
The computer programs was designed to make the machine work. Operating system was a 
program designed to handle a machine completely. Because of the operating system machine 
could execute multiple jobs simultaneously. Integrated circuits were used to replace many 
transistors used in the second generation. 
A single IC has many transistors, registers, and capacitors built on one thin slice of silicon. The value 
size was reduced and memory space and dealing efficiency were increased during this generation. 
Programming was now wiped out Higher level languages like BASIC (Beginners All-purpose Symbolic 
Instruction Code). Minicomputers find their shape during this era. 

 
Characteristics of Third-Generation Computers 

Characteristics Components 

Main electronic component Integrated circuits (ICs). 

Programming language High-level language. 

Memory Large magnetic core, magnetic tape/disk. 



Characteristics Components 

Input/output devices 
Magnetic tape, monitor, keyboard, printer, 

etc. 

Examples of the third generation 
IBM 360, IBM 370, PDP-11, NCR 395, B6500, 

UNIVAC 1108, etc. 

 
Fourth Generation Computers 
In 1971 First microprocessors were used, the large-scale of integration LSI circuits built on one chip 
called microprocessors. The advantage of this technology is that one microprocessor can contain all 
the circuits required to perform arithmetic, logic, and control functions on one chip. LSI placed 
thousands of transistors onto a single chip. 
The computers using microchips were called microcomputers. This generation provided even 
smaller size of computers, with larger capacities. That’s not enough, then Very Large Scale 
Integrated (VLSI) circuits replaced LSI circuits. The Intel 4004 chip, developed in 1971, located all the 
components of the pc from the central processing unit and memory to input/ output controls on 
one chip and allowed the dimensions to reduce drastically. VLSI placed several hundred thousand 
transistors on a single silicon chip. This silicon chip is known as the micro processor. 
Technologies like multiprocessing, multiprogramming, time-sharing, operating speed, and virtual 
memory made it a more user-friendly and customary device. The concept of private computers and 
computer networks came into being within the fourth generation. 

 
Characteristics of Fourth-Generation  Computers 

Characteristics Components 

Main electronic component 
Very-large-scale integration (VLSI) and the 

microprocessor (VLSI has thousands of 
transistors on a single microchip). 

Memory 
semiconductor memory (such as RAM, ROM, 

etc.). 

Input/output devices 
pointing devices, optical scanning, keyboard, 

monitor, printer, etc. 

Examples of the fourth generation 
IBM PC, STAR 1000, APPLE II, Apple 

Macintosh, Alter 8800, etc. 

 
Fifth Generation Computers 
The technology behind the fifth generation of computers is AI. It allows computers to behave like 
humans. It is often seen in programs like voice recognition, area of medicine, and entertainment. 
Within the field of game playing also it’s shown remarkable performance where computers are 
capable of beating human competitors. 
The speed is the highest, size is the smallest and area of use has remarkably increased within the 
fifth generation computers. Though not a hundred percent AI has been achieved to date but keeping 
in sight the present developments, it is often said that this dream also will become a reality very 
soon. 
To summarize the features of varied generations of computers, it is often said that a big 
improvement has been seen so far because of the speed and accuracy of functioning care, but if we 



mention the dimensions, it’s been small over the years. The value is additionally diminishing and 
reliability is increasing. 

 
 

Characteristics of Fifth-Generation Computers 

Characteristics Components 

Main electronic component 

Based on artificial intelligence, uses the Ultra 
Large-Scale Integration (ULSI) technology and 
parallel processing method (ULSI has millions 
of transistors on a single microchip and the 
Parallel processing method use two or more 

microprocessors to run tasks simultaneously). 

Language 
Understand natural language (human 

language). 

Size Portable and small in size. 

Input/output device 

Trackpad (or touchpad), touchscreen, pen, 
speech input (recognize voice/speech), light 
scanner, printer, keyboard, monitor, mouse, 

etc. 

Example of the fifth generation Desktops, laptops, tablets, smartphones, etc. 

 

Q4: Differentiate between Volatile & Non- Volatile memories. 

Answer: Volatile Memory:  
It is the memory hardware that fetches/stores data at a high-speed. It is also referred as 
temporary memory. The data within the volatile memory is stored till the system is capable of, but 
once the system is turned off the data within the volatile memory is deleted automatically. RAM 
(Random Access Memory) and Cache Memory are some common examples of volatile memory. 
Here, data fetch/store is fast and economical.  
Non-Volatile Memory:  
It is the type of memory in which data or information is not lost within the memory even power is 
shut-down. ROM (Read Only Memory) is the most common example of non-volatile memory. It’s 
not economical and slow in fetch/store as compared to volatile memory however stores higher 
volume of data. All such information that needs to be stored for an extended amount of time is 
stored in non-volatile memory. Non-volatile memory has a huge impact on a system’s storage 
capacity.  
Below are the differences between volatile and non-volatile memory: 

S. 
No. Volatile Memory Non-Volatile Memory 

1. 
Volatile memory is the type of memory in 

which data is lost as it is powered-off. 

Non-volatile memory is the type of memory 
in which data remains stored even if it is 

powered-off. 



S. 
No. Volatile Memory Non-Volatile Memory 

2. 
Contents of Volatile memory are stored 

temporarily. 
Contents of Non-volatile memory are stored 

permanently. 

3. It is faster than non-volatile memory. It is slower than volatile memory. 

4. 
RAM(Random Access Memory) is an 

example of volatile memory. 
ROM(Read Only Memory) is an example of 

non-volatile memory. 

5. 
In volatile memory, data can be easily 

transferred in comparison to non-volatile 
memory. 

In non-volatile memory, data can not be 
easily transferred in comparison to volatile 

memory. 

6. 
In Volatile memory, process can read and 

write. 
In Non-volatile memory, process can only 

read. 

7. 
Volatile memory generally has less storage 

capacity. 
Non-volatile memory generally has more 
storage capacity than volatile memory. 

8. 
In volatile memory, the program’s data are 

stored which are currently in process by 
the CPU. 

In non-volatile memory, any kind of data 
which has to be saved permanently are 

stored. 

9. 
Volatile memory is more costly per unit 

size. 
Non-volatile memory is less costly per unit 

size. 

10. 
Volatile memory has a huge impact on the 

system’s performance. 
Non-volatile memory has a huge impact on 

a system’s storage capacity. 

11. 
In volatile memory, processor has direct 

access to data. 
In non-volatile memory, processor has no 

direct access to data. 

12. 
Volatile memory chips are generally kept 

on the memory slot. 
Non-volatile memory chips are embedded 

on the motherboard. 

13. 

Advantages- 
• Fast speed 
• Low power consumption 
• Better system performance as 

it increases speed 

Advantages- 
• More reliable 
• Stores data permanently 
• Inexpensive memory 
• Helps in booting of operating 

system 

14. 

Disadvantages- 
• Expensive 
• Limited storage space 
• Stores data temporarily 

Disadvantages- 
• Slow speed 
• Can only read data 

https://www.geeksforgeeks.org/different-types-ram-random-access-memory/
https://www.geeksforgeeks.org/difference-between-ram-and-rom/


 

Q5: Distinguish among system software, application software and open source software on the 

basis of their features. 

Answer:  Computer Software is a sort of program that allows clients to work on different 
assignments or use them to work on their System. It tells the working and responsibilities of the 
System. Basically, Software is a set of instructions or commands that tells a user how to do and what 
to do. 

Types of Software 
1. System Software 
2. Application Software 

System Software 
System Software is the type of software that is the interface between application software and the 
system. Low-level languages are used to write the system software. System Software maintains the 
system resources and gives the path for application software to run. An important thing is that 
without system software, the system can not run. It is general-purpose software. 

Functions of System Software 

• Memory Management 
• Processor Management 
• File Management 
• Security 
• Error-detecting Aids 
• Scheduling 

Features of System Software 

• System software is written in a low-level language. 
• The size of the system Software is smaller. 
• System software is complex to understand. 
• System software is present near hardware components. 

Types of System Software 

• Operating System: Operating System is the main part of the Computer System. It has 
the responsibility of managing all the resources such as CPU, Printer, Hard Disk, etc. It 
also provides services to many other Computers Softwares. Examples of Operating 
Systems are Linux, Apple, macOS, Microsoft Windows, etc. 

• Language Processor: System Software converts Human-Readable Language into a 
Machine Language and it is done by Language Processor. It converts programs into 
instructions that are easily readable by Machines.  

• Device Driver: A Device Driver is a program or software that helps to perform its 
functions by controlling the device. You first have to install a driver for running the 
program. 

Application Software 
Application Software is the type of software that runs as per user request. It runs on the platform 
which is provided by system software. High-level languages are used to write the application 
software. It’s a specific purpose software. The main difference between System Software and 
Application Software is that without system software, the system can not run on the other hand 
without application software, the Low-level maintenance system always runs. 



Functions of Application Software 

• Information and data management 
• Management of documents (document exchange systems) 
• Development of visuals and video 
• Emails, text messaging, audio, and video conferencing, and cooperation are all options. 
• Management of accounting, finance, and payroll 
• Management of resources (ERP and CRM systems) 

Features of Application Software 

• Application software is written in a high-level language. 
• Application software requires more storage space than system software. 
• Only a single task is performed by each application software. 
• Application Software is easy to build in comparison to system software. 

Types of Application Software 

1. General Purpose Software: This Application Software is used to perform tasks that are 
used for a variety of tasks, just not limited to a specific task only. For Example, MS Word, 
MS Excel, etc. 

2. Customized Software: It is used to perform tasks that are designed for specific 
organizations. For Example, Railway Reservation System, Airline Reservation System, 
etc. 

3. Utility Software: It is used to support the architecture of the Computer. It is designed 
for optimizing and maintaining the system and also taking care of its requirements. 

 

System Software Application Software 

System Software maintains the system resources 
and gives the path for application software to run. 

Application software is built for specific 
tasks. 

Low-level languages are used to write the system 
software. 

While high-level languages are used to 
write the application software. 

It is general-purpose software. While it’s a specific purpose software. 

Without system software, the system stops and 
can’t run. 

While Without application software system 
always runs. 

System software runs when the system is turned 
on and stops when the system is turned off. 

While application software runs as per the 
user’s request. 

Example: System software is an operating system, 
etc. 

Example: Application software is 
Photoshop, VLC player, etc. 

System Software programming is more complex 
than application software. 

Application software programming is 
simpler in comparison to system software. 



System Software Application Software 

The Software that is designed to control, integrate 
and manage the individual hardware components 

and application software is known as system 
software. 

A set of computer programs installed in 
the user’s system and designed to perform 

a specific task is known as application 
software. 

A system software operates the system in the 
background until the shutdown of the computer. 

Application software runs in the front end 
according to the user’s request. 

The system software has no interaction with 
users. It serves as an interface between hardware 

and the end user. 

Application software connects an 
intermediary between the user and the 

computer. 

System software runs independently. 
Application software is dependent on 

system software because they need a set 
platform for its functioning. 

 

 

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with file name 

“yourself”. Describe all steps involved in it. 

Answer: To create a new document: 

1. Click the Microsoft Office button. 
2. Select New. The New Document dialog box appears. 
3. Select Blank document under the Blank and recent section. It will be 

highlighted by default. 
4. Click Create. A new blank document appears in the Word window. 

 

Insert Paragraph 

1. Open Microsoft Word and open or create a document 

2. Place your cursor where you want to insert the text 

3. Type the text you want to insert 

4. Press Enter 

To save a document: 
1. From the File menu, select Save As… 
2. The Save As dialog box will display. 
3. Choose a location on your computer to save your file. ... 
4. Next to File Type is a drop down menu; select Rich Text Format (.rtf) or 

Microsoft Word (*.doc). 
5. Click Save. 

 

Q6 b) Write steps regarding followings 



 To change the font style 

Answer: Changing the Font Style 

1. If you have already started typing before changing the font style, select your text. Click on 
the Home tab. 

2. Look for the Font options. 

3. From the drop down menu select the font you want to use. ... 

4. In the drop down menu next to the font style, you can change the font size. 

 

 To change the font size 

Answer: Change the size of selected text 

1. Select the text or cells with text you want to change. To select all text in a Word document, 
press Ctrl + A. 

2. On the Home tab, click the font size in the Font Size box. You can also type in any size you 
want, within the following limits: 

 

 To change the font color 

Answer: 1. Select the text: Highlight the specific text you want to change the color of. You can select 

a single word, a sentence, a paragraph, or the entire document. 

2. Locate the "Font Color" button:** Navigate to the Home tab in the ribbon menu. Within the Font 
section, you'll find the Font Color button represented by a letter "A" with a colored dropdown 
arrow. 

3. Choose a color:** Click the Font Color button to reveal a palette of pre-selected colors. You can 
choose from Theme Colors that match your document theme or Standard Colors for a wider range. 

 

 To highlight (in yellow) the line that reads “need to get IMS’s address”. 

Answer: Click 'Format' in toolbar. 

1. Click 'Style'. 
2. Click the Gear. 
3. Click the 'Character Fill Color' Button. 
4. Click the yellow crayon from the Colors popup. 

 

Q7. Create a file in MS-Word for the following document and save it with file name ‘ms_word’. 

Describe all steps involved in it. 

Answer: Steps: 

1. Opening MS Word: 

o Click on the Start Menu/Windows icon. 

o Type "Word" in the search bar. 

o Click on the "Microsoft Word" application to launch it. 



2. Creating a Blank Document: 

o By default, a blank document will be created automatically. 

o Alternatively, you can select "File" > "New" > "Blank document" from the top menu. 

3. Adding Content: 

o Start typing your document content. 

o Use the formatting tools on the ribbon to customize the text, fonts, styles, etc. 

o You can insert images, tables, charts, and other elements using the respective buttons on 

the ribbon. 

4. Saving the Document: 

o Click on "File" > "Save As" from the top menu. 

o In the "File name" box, type "ms word" (without quotes). 

o Choose a location to save the file (e.g., Desktop, Documents folder). 

o Click on the "Save" button. 
 

Q8. Create a file in MS-word for the following document and save it with file name ‘equations’. 

Describe all steps involved in it. 

Answer: 1. Open Microsoft Word: 

Locate the Word application on your computer and launch it. 

2. Create a Blank Document: 

On the main screen, select "Blank document" or press Ctrl+N on your keyboard. 

3. Enter the Equations: 

Type or paste the equations you want to include in the document. You can use the 

Equation Editor tool in Word to insert complex mathematical symbols and expressions. To 

access it: 

o Go to the Insert tab. 

o Click on the Equation button. 

o Choose the equation template or symbol you need from the menu. 

4. Format the Equations: 

You can customize the appearance of your equations by changing the font size, style, and 

alignment. 

o Select the equation you want to modify. 

o Use the options available in the Equation Tools Design and Format tabs. 

5. Save the Document: 

o Click on the File tab. 

o Select Save As. 

o In the File name box, type "equations" (without quotes). 

o Choose a location to save the file (e.g., Desktop, Documents folder). 

o Click Save. 



 

Q9. Create a file in MS-word that convert existing highlight text to table as shown below and save it 

as file name ‘text_to_table’. Describe all steps involved in it. 

Answer: I am going to use the example of the comma separated values above. 

1. Highlight the block of text. 

2. Go to the Insert tab and select the Table dropdown. Select Convert Text to Table… 

 

3. Word will guess the delimiter. In my case, Word has caught on that the values are separated by 
commas. Note you could change the delimiter under the Separate text at section, if Word does not 
pick up on it automatically. 

https://itstraining.wichita.edu/wp-content/uploads/2020/06/TT2.png


 

4. Press OK and a simple table will be created with the text values you highlighted. 

 

Don’t forget… you have a lot of options for styles and formatting in the 
Table Design and Layout tabs. 

Make sure you have clicked onto your table for these to appear, as they are contextual tabs. 

 

I always go for green for some reason…

 

https://itstraining.wichita.edu/wp-content/uploads/2020/06/TT3.png
https://itstraining.wichita.edu/wp-content/uploads/2020/06/TT4.png
https://itstraining.wichita.edu/wp-content/uploads/2020/06/TT5.png
https://itstraining.wichita.edu/wp-content/uploads/2020/06/TT9.png


Q10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in it. 

Answer:  Open Microsoft Word: Launch the application on your computer. 

1. Create a New Document: Click "File" > "New" or select the "Blank Document" template. 

2. Position the Cursor: Place your cursor where you want the table to appear in the document. 

3. Insert the Table: 

o Quick Method: Click the "Insert" tab on the ribbon. Hover over the "Table" icon and drag 

your cursor to select the desired number of columns and rows. Click the selected grid to 

insert the table. 

o Custom Method: Click the "Insert" tab > "Table" > "Insert Table...". A dialog box will 

appear. Enter the desired number of columns and rows in the respective fields. You can also 

choose the table's width and AutoFit behavior here. Click "OK" to insert the table. 

4. Customize the Table: 

o Resize: Drag the table borders or cell edges to adjust the size. 

o Add/Remove Rows & Columns: Right-click on a cell and select "Insert" or "Delete" options for 

rows/columns. 

o Merge/Split Cells: Right-click and choose "Merge Cells" or "Split Cells" options. 

o Text Formatting: Select cells and apply formatting options like font size, style, and alignment. 

o Borders & Shading: Click the "Table Design" tab and choose border styles, colors, and 

shading options. 

5. Save the Document: Click "File" > "Save" and choose a file name and location. 
 

Q11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

Answer Step 1: Open MS Excel. 
Step 2: Go to Menu and select New >> Click on the Blank workbook to create a simple worksheet. 
OR – Press Ctrl + N: To create a new spreadsheet. 
Step 3: By default, Sheet 1 will be created as a worksheet in the spreadsheet. The spreadsheet’s 
name will be Book 1 if you open it for the first time. 
 

Q12. Calculate the following things of a range (C2:C11) of data in the worksheet created in question 

no 

 the sum of the marks using AutoSum in a range of cells (C2:C11) 

Answer: To create the formula: 

1. Type =SUM in a cell, followed by an opening parenthesis (. 
2. To enter the first formula range, which is called an argument (a piece of data the 

formula needs to run), type A2:A4 (or select cell A2 and drag through cell A6). 
3. Type a comma (,) to separate the first argument from the next. 
4. Type the second argument, C2:C3 (or drag to select the cells). 
5. Type a closing parenthesis ), and then press Enter. 

 

 average of the marks in a range of cells (C2:C11) 



Answer:- Where number1, number2, etc. are numeric values for which you want to get the average. 
They can be supplied in the form of numeric values, arrays, cell or range references. The first 
argument is required, subsequent ones are optional. In one formula, you can include up to 255 
arguments. 

AVERAGE is available in all versions of Excel 365 though Excel 2007. 

 

 highest marks in a range of cells (C2:C11) 

Answer:-  Here is the function syntax followed by a detailed breakdown of each parameter, 

including examples: 

=MAXIFS(max_range, criteria_range1, criteria1, [criteria_range2, criteria2], …) 

The formula consists of several components that work together to perform the desired MAXIFS 

function. Let’s understand each component in detail: 

1. ‘max_range’ – This is the range of cells from which the maximum value will be determined. It 

is the primary set of data where Excel looks for the highest value based on the given criteria. 

2. ‘criteria_range1, criteria_range2,’ etc. – These are the ranges of cells where the criteria are 

applied. Each ‘criteria_range’ corresponds to a criterion (criteria1, criteria2, etc.) that 

defines what cells in the ‘max_range’ should be considered for finding the maximum value. 

3. ‘criteria1’, ‘criteria2’, etc. – These are the conditions that the corresponding criteria_range 

must meet in order for the cells in max_range to be considered. Conditions can be numeric, 

text (such as names or labels), or date values, and they can include logical operators (like >, 

<, =, etc.). 



Example Formula: 

=MAXIFS(A1:A10, B1:B10, “Electronics”, C1:C10, “North”) 

In this formula: 

• A1:A10 is where the sales figures are stored (‘max_range’). 

• B1:B10 is the range that contains the product categories (criteria_range1). 

• “Electronics” specifies the condition that the category must be “Electronics” (criteria1). 

• C1:C10 is the range that contains the regions (criteria_range2). 

• “North” specifies the condition that the region must be “North” (criteria2) 

This formula will review the sales figures in the range A1:A10, but only consider those figures where 

the corresponding cells in B1:B10 are “Electronics,” and those in C1:C10 are “North”. The result will 

be the highest sales figure meeting these conditions. 

 

 minimum marks in a range of cells (C2:C11) 

Answer:  
What you're describing is "percentile". Excel's percentile function interpolates, so I'm not sure it's 
appropriate for your use case. 

At the very least, you can compute the percentile, then take the minimum score of all values filtered 
to be above the interpolated 50th percentile. 

Here's a slightly clever implementation: 

Assume your data is in the range C2:C11. 
In c13, we'll compute the 50th percentile as =PERCENTILE(C2:C11, 0.5) In column d, we'll use 
an IF statement to either select the adjacent value from column c, or a very large number, 
depending on whether the value is greater than the percentile. E.g., =IF(C2 > $C$13,C2,400000) 
Now we can take the min of column d: =MIN(D2:D11) 
The only clever bit is using a giant number when the value in column c is less than the percentile, so 
that it effectively becomes invisible to the min operation. 
 

 

 

Q13 a) Describe various steps involved in the following 

 To modify column width of a worksheet 



Answer: You can manually adjust the column width or row height or automatically resize columns 

and rows to fit the data 

Resize columns 
1. Select a column or a range of columns. 
2. On the Home tab, select Format > Column Width (or Column Height). 
3. Type the column width and select OK. 

 
 To modify the row height of a worksheet 

Answer: Resize rows 
1. Select a row or a range of rows. 
2. On the Home tab, select Format > Row Width (or Row Height). 
3. Type the row width and select OK. 

 

 To delete rows and columns of a worksheet 

• Answer: Select the cells, rows, or columns that you want to delete. 

• Right-click, and then select the appropriate delete option, for example, Delete Cells & Shift 
Up, Delete Cells & Shift Left, Delete Rows, or Delete Columns. 

 

Q13 b) Describe following terms in the worksheet 

 Absolute reference and relative reference in formula 

Answer:  Relative references 

By default, all cell references are relative references. When copied across multiple cells, they change 

based on the relative position of rows and columns. For example, if you copy the 

formula =A1+B1 from row 1 to row 2, the formula will become =A2+B2. Relative references are 

especially convenient whenever you need to repeat the same calculation across multiple rows or 

columns. 

To create and copy a formula using relative references: 

In the following example, we want to create a formula that will multiply each item's price by 

the quantity. Instead of creating a new formula for each row, we can create a single formula in 

cell D4 and then copy it to the other rows. We'll use relative references so the formula calculates the 

total for each item correctly. 

1. Select the cell that will contain the formula. In our example, we'll select cell D4. 

2. Enter the formula to calculate the desired value. In our example, we'll type =B4*C4. 



 

3. Press Enter on your keyboard. The formula will be calculated, and the result will be 
displayed in the cell. 

4. Locate the fill handle in the bottom-right corner of the desired cell. In our example, 
we'll locate the fill handle for cell D4. 

 

5. Click and drag the fill handle over the cells you want to fill. In our example, we'll 
select cells D5:D13. 

 

6. Release the mouse. The formula will be copied to the selected cells with relative 
references, displaying the result in each cell. 



 

You can double-click the filled cells to check their formulas for accuracy. The relative cell references 

should be different for each cell, depending on their rows. 

 

Absolute references 

There may be a time when you don't want a cell reference to change when copied to other cells. 

Unlike relative references, absolute references do not change when copied or filled. You can use an 

absolute reference to keep a row and/or column constant. 

An absolute reference is designated in a formula by the addition of a dollar sign ($). It can precede 

the column reference, the row reference, or both. 

You will generally use the $A$2 format when creating formulas that contain absolute references. 

The other two formats are used much less frequently. 



When writing a formula, you can press the F4 key on your keyboard to switch between relative and 

absolute cell references, as shown in the video below. This is an easy way to quickly insert an 

absolute reference. 

To create and copy a formula using absolute references: 

In the example below, we'll use cell E2 (which contains the tax rate of 7.5%) to calculate the sales tax 

for each item in column D. To make sure the reference to the tax rate stays constant—even when 

the formula is copied and filled to other cells—we'll need to make cell $E$2 an absolute reference. 

1. Select the cell that will contain the formula. In our example, we'll select 
cell D4. 

 

2. Enter the formula to calculate the desired value. In our example, we'll type 
=(B4*C4)*$E$2, making $E$2 an absolute reference. 

 

3. Press Enter on your keyboard. The formula will calculate, and the result will 
display in the cell. 

4. Locate the fill handle in the bottom-right corner of the desired cell. In our 
example, we'll locate the fill handle for cell D4. 



 

5. Click and drag the fill handle over the cells you want to fill (cells D5:D13 in 
our example). 

 

6. Release the mouse. The formula will be copied to the selected cells with 
an absolute reference, and the values will be calculated in each cell. 

 



You can double-click the filled cells to check their formulas for accuracy. The absolute reference 

should be the same for each cell, while the other references are relative to the cell's row. 

 

Be sure to include the dollar sign ($) whenever you're making an absolute reference across multiple 

cells. The dollar signs were omitted in the example below. This caused Excel to interpret it as 

a relative reference, producing an incorrect result when copied to other cells. 

 

Q14. a) What tools are available to customize our PowerPoint presentation? 

Answer: Here are some tools that can help you customize your PowerPoint presentation: 

• Templates and themes 

• Slide layouts 

• Fonts 

• Color themes 

• Icons 

• Shapes 

• Stock photos 

• Charts and graphs  
 



Q14 b) Write the steps for the following action for creation of power point presentation 

 Open a Blank presentation 

Answer: Create a presentation 

1. Open PowerPoint. 
2. In the left pane, select New. 
3. Select an option: 

▪ To create a presentation from scratch, select Blank Presentation. 
▪ To use a prepared design, select one of the templates. 
▪ To see tips for using PowerPoint, select Take a Tour, and then 

select Create, . 

 Save the presentation as Lab1.pptx 

Answer: - Save your presentation 

▪ Click FILE > Save, pick or browse to a folder, type a name for your presentation in 
the File name box, and click Save. 

▪ Save your work as you go. Hit Ctrl+S often 

 Add a Title to the first slide: the name of your college 

Answer: Click Home > Layout. Select Title Slide for a standalone title page or select Title and Content 

for a slide that contains a title and a full slide text box. 

 Add a New Slide which has a Title and Content 

Answer: Home Tab: Click the "New Slide" dropdown arrow on the Home tab. 

1. Layout Selection: Choose "Title and Content" layout from the gallery. 

2. Adding Title: Click inside the "Click to add title" placeholder and type your title. 

3. Adding Content: Click inside the larger text box below and add your content (text, bullet 

points, etc.). 
 

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to use 

the tools of PowerPoint. It should include the following things 

 Title slide &bullet list 

Answer: On the View tab, in the Presentation Views group, click Normal. 

 



1. On the left side of the PowerPoint window, click a slide thumbnail that you want to add 
bulleted or numbered text to. 

 

2. On the slide, select the lines of text in a text placeholder or table that you want to add 
bullets or numbering to. 

3. On the Home tab, in the Paragraph group, click Bullets   or Numbering  . 

 

 



 Inserting Excel Sheet 

Answer: In Excel, click and drag to highlight the cells you want to copy. 

1. Right-click the copied cells and select Copy. 
2. In your PowerPoint presentation, right-click and select the Paste Options you want: 

▪ Use Destination Styles – Choose to edit your copied cells like a 
PowerPoint table, but with PowerPoint's color scheme and fonts. 

▪ Keep Source Formatting – Choose to keep your table editable in 
PowerPoint while maintaining the same source formatting from Excel. 

▪ Embed – Choose to keep a copy of your table in PowerPoint in case you 
want to edit the data, which will open in Excel. 

Note: If you're working with a large Excel file, it'll inflate your PowerPoint 
presentation to a big size. You may also unintentionally be giving more 
access to your Excel file than you intend to. 

▪ Picture – Choose to paste your table as a picture to get the same benefits 
as embedding except you can format your cells like a picture and add 
effects to it. You won’t be able to edit data once it’s been pasted though. 

▪ Keep Text Only – Choose to paste your table as straight text and to do all 
formatting in PowerPoint. 

3. If you pasted as a picture, on the Picture Tools Format tab, select the quick picture 
style you want to use. Adjust the table to your liking. 

 

 Clip art and Text 

Answer: Select the place in the slide where you want to insert the picture. 

1. On the Insert tab, in the Images group, select Pictures and then select This Device. 

 

2. In the dialog box that opens, browse to the picture that you want to insert, select that 
picture, and then select Insert. 

 

 

 

 



 Slide show effects 

Answer: Add animations and effects 

1. Select the object or text you want to animate. 

2. Select Animations and choose an animation. 

3. Select Effect Options and choose an effect. 

 

 

Part -2 

 

Q16. What is the difference between Machine Language and High Level Language? 

Answer: Both High level language and low level language are the programming languages’s 
types. The main difference between high level language and low level language is that, 
Programmers can easily understand or interpret or compile the high level language in comparison 
of machine. On the other hand, Machine can easily understand the low level language in 
comparison of human beings. Examples of high level languages are C, C++, Java, Python, etc. Let’s 
see the difference between high level and low level languages: 

1. It is programmer friendly language. It is a machine friendly language. 

2. 

High level language is less memory 

efficient. 
Low level language is high memory efficient. 

3. It is easy to understand. It is tough to understand. 

4. Debugging is easy. Debugging is complex comparatively. 

5. It is simple to maintain. It is complex to maintain comparatively. 

6. It is portable. It is non-portable. 

7. It can run on any platform. It is machine-dependent. 

8. 

It needs compiler or interpreter for 

translation. 
It needs assembler for translation. 



1. It is programmer friendly language. It is a machine friendly language. 

9. 
It is used widely for programming. 

It is not commonly used now-a-days in 

programming. 

 

Q17. Discuss about different data types of C programming Language. 

Answer: Each variable in C has an associated data type. It specifies the type of data that the 
variable can store like integer, character, floating, double, etc. Each data type requires different 
amounts of memory and has some specific operations which can be performed over it. The data 
type is a collection of data with values having fixed values, meaning as well as its characteristics. 
The data types in C can be classified as follows: 

Types Description 

Primitive Data 
Types 

Primitive data types are the most basic data types that are used for 
representing simple values such as integers, float, characters, etc. 

User Defined 
Data Types 

The user-defined data types are defined by the user himself. 

Derived Types 
The data types that are derived from the primitive or built-in datatypes 

are referred to as Derived Data Types. 

 

 



Data Type  
  

Size 
(bytes)  

  
Range 

  

Format 
Specifier  

  

short int  
  

2  
  

-32,768 to 32,767  
  

%hd  
  

unsigned short int  
  

2  
  

0 to 65,535  
  

%hu  
  

unsigned int  
  

4  
  

0 to 4,294,967,295  
  

%u  
  

int  
  

4  
  

-2,147,483,648 to 2,147,483,647  
  

%d  
  

long int  
  

4  
  

-2,147,483,648 to 2,147,483,647  
  

%ld  
  

unsigned long int  
  

4  
  

0 to 4,294,967,295  
  

%lu  
  

long long int  
  

8  
  

-(2^63) to (2^63)-1  
  

%lld  
  

unsigned long long 
int  

  

8  
  

0 to 
18,446,744,073,709,551,615  

  

%llu  
  

signed char  
  

1  
  

-128 to 127  
  

%c  
  

unsigned char  
  

1  
  

0 to 255  
  

%c  
  

float  
  

4  
  

1.2E-38 to 3.4E+38 
%f  

  

double  
  

8  
  

1.7E-308 to 1.7E+308 
%lf  

  

long double  
  

16  
  

3.4E-4932 to 1.1E+4932 
%Lf  

  

 

 

 



Q18. Find the output of the following expressions 

X=20/5*2+30-5 b) Y=30 – (40/10+6) +10 c) Z= 40*2/10-2+10 

Answer:-  

Q19. Describe the syntax of the following statements 

a) If – else statement b) for loop c) while loop d) do-while loop 

Answer: If the code inside parenthesis of the if statement is true, everything within the curly braces 
is executed. In this case, true evaluates to true, so the code runs the printf function. 
if..else statements 
In an if...else statement, if the code in the parenthesis of the if statement is true, the code inside its 
brackets is executed. But if the statement inside the parenthesis is false, all the code within 
the else statement's brackets is executed instead. 
Of course, the example above isn't very useful in this case because true always evaluates to true. 
Here's another that's a bit more practical: 

#include <stdio.h> 

 

int main(void) { 

    int n = 2; 

 

    if(n == 3) { // comparing n with 3 

        printf("Statement is True!\n"); 

    }  

    else { // if the first condition is not true, come to this block of code 

        printf("Statement is False!\n"); 

    } 

 

    return 0; 

} 
Output: 

Statement is False! 
There are a few important differences here. First, stdbool.h hasn’t been included. That's okay 
because true and false aren't being used like in the first example. In C, like in other programming 
languages, you can use statements that evaluate to true or false rather than using the boolean 
values true or false directly. 
Also notice the condition in the parenthesis of the if statement: n == 3. This condition 
compares n and the number 3. == is the comparison operator, and is one of several comparison 
operations in C. 
 
For loop  
Answer for(Expression 1; Expression 2; Expression 3){ //code to be executed. } 
 
While loop 

Answer: While Loop in C 

The while loop in C is used to evaluate a test condition and iterate over the loop body until the 
condition returns True. The loop ends when the condition returns False. 

This loop is also known as a pre-tested loop because it is commonly used when the number of 
iterations is unknown to the user ahead of time. 



While Loop Syntax in C 

Here’s the syntax for the while loop in C 

while (condition) { 
    // Code to execute as long as the condition is true 
} 
Here,  

• while: This is the keyword that begins the while loop. 
• condition: This is a Boolean expression that is evaluated before each iteration of the loop. 

If the condition is true, the loop continues; if it is false, the loop ends. 
• The code inside the curly braces {} is the body of the loop. This code is executed 

repeatedly as long as the condition remains true. 
To begin with, the while loop in C checks the test condition and executes the body of the loop when 
the condition is True. This means that the condition is evaluated iteratively. The loop is 
active while the condition is true. This procedure is repeated until the condition returns False. The 
loop is terminated as soon as this occurs. 
Take a look at the while loop flowchart below 

 
While Loop Implementation Example in C 
Example 1: Take a look at the C program that calculates the sum of n-natural numbers 
 
#include  <stdio.h>  
 
int main() { 
    int num, i, sum = 0; 
 
    printf("Enter a positive integer: "); 
    scanf("%d", &num); 
 
    i = 1; 
 
    while (i  <= num) { 
        sum = sum + i; 
        i++; 
    } 
 
    printf("Sum: %d", sum); 



 
    return 0; 
} 
 
 
Do-while loop 
Answer The do…while in C is a loop statement used to repeat some part of the code till the given 
condition is fulfilled. It is a form of an exit-controlled or post-tested loop where the test condition 
is checked after executing the body of the loop. Due to this, the statements in the do…while loop 
will always be executed at least once no matter what the condition is. 
Syntax of do…while Loop in C 
do { 
  
    // body of do-while loop     
     
} while (condition); 
How to Use do…while Loop in C 
The following example demonstrates the use of do…while loop in C programming language. 

• C 

// C Program to demonstrate the use of do...while loop 

#include <stdio.h> 

int main() 

{ 

    // loop variable declaration and initialization 

    int i = 0; 

    // do while loop 

    do { 

        printf("Geeks\n"); 

        i++; 

    } while (i < 3); 

    return 0; 

} 

Output 



Geeks 

Geeks 

Geeks 

 
 
 

Q20. Find the output of the following program segments 

a) b) c) 

#include <stdio.h> 

int main() 

{ 

int i; 

for (i=1; i<2; i++) 

{ 

printf( "IMS Ghaziabad\n"); 

} 

} 

 

#include <stdio.h> 

int main() 

{ 

int i = 1; 

while ( i <= 2 ) 

{ 

printf( "IMS Ghaziabad\n"); 

i = i + 1; 

} 

} 

 

#include <stdio.h> 

void main() 



{ 

int a = 10, b=100; 

if( a > b ) 

printf( "Largest number is %d\n”, a); 

else 

printf( "Largest number is %d\n”, 


