
ASSIGNMENT – 1 

CCA- 101:- Fundamentals of IT & programming 

Q. 1. What are the four fundamental parts of computer? Explain it with the help 

of diagram. 

Answer:- Four fundamental parts of computer are :- 

• Input 

• Output  

• Central processing unit 

• Memory unit 

 

 

 

 

 

Q. 2. Discuss about the classification of computers based on size and capacity. 

Answer:- Microcomputers, Minicomputers, Mainframe computers and 

Supercomputers 

Computers are classified on different parameters, such as, storage capacity 

processing speed and component (CPU) and in computers. Depending upon the 

components used and features of different computers, they are classified into 

four groups, Microcomputers, Minicomputers, mainframe computers and 

supercomputers. 

 

Q. 3. What is the meaning of computers generation? How many computer 

generations are defined? What technologies were/ are used? 



Answer:-  We are using 5th generation of computers.                                                                         

There are fives generation of computers. 

*Generation in computer terminology is a change in technology a computer is/ 

was being used. Initially, the generation term was used to distinguish between 

varying hardware technologies. Nowadays, generation includes both hardware 

and software, which together make up an entire computer system. 

Q. 4.  Differentiate between volatile & Non – volatile memories. 

Answer:- Volatile Memory is used to store computer programs and data that CPU 

needs in real time and is erased once computer is switched off . RAM and Cache 

memory are volatile memory. Where as Non – volatile memory is static and 

remains in the computer even if computer is switched off. ROM and HDD are non 

volatile memory. 

Q. 5. Distinguish among system software, application software and open source 

software on the basis of their features. 

Application software (an application) is a set of computer programs designed to 

permit the user to perform a group of coordinated functions, tasks, or activities. 

Application software cannot run on itself but is dependent on system software to 

execute. Program- A set of instructions telling a computer what to do. 

Q. 6. a). Create a file in MS- word to insert a paragraph about yourself and save 

it with file name “yourself”. Describe all steps in involved in it. 

Answer:- 

“ It is a very simple process if you do it step. Following are the step to save a file: 

Open the File Explorer 

Click on the home tab. 

Click on the new item button.  

Select a file type. 

Enter a name for the file as per your choice or need. 

Press the enter button. 

Your file will be saved on the desired location. 



Q. 6. b). Write steps regarding followings 

• To change the font style 

• To change the font size 

• To change the font color 

• To highlight (in yellow) the line that reads “need to get IMS’s address”. 

 Answer:-  

To change the font style:- 

❖ Select the text you want to modify. 

❖ Click on font style box on the Home tab. The font style drop- down menu 

appears. 

❖ Move your cursor over the various font styles. 

❖ Left click the font style you want use. 

❖ Then font style will change in the document. 

To change the font size:- 

➢ Select the text that you want to modify. 

➢ In Home tab locate the font group. 

➢ In font group click the drop- down arrow next to font size box. 

➢ Font size menu appears. 

➢ Select the desired font size with a left click. 

➢ Select the text and click the increase or decrease font size buttons. 

           To change the font color:-  

❖ Select the text you want to modify. 

❖ Click on the font color box on the Home tab. The font color menu appears. 

❖ Move your cursor over the various font colors. 

❖ Left- Click the font color you want to use. 

❖ Then font color will change in the document. 

To highlight (in yellow) the line that reads “need to get IMS’s 

address”. 



❖ Click the Home tab. 

❖ In the font group, click the text Highlight button. Word in now in 

Highlighting mode. 

❖ Drag the mouse over the text you want to highlight. ….. 

❖ Click the text Highlight button again to return the mouse to normal 

operation. 

Q. 7. Create a file in MS-Word for the following document and save it with file 

name ‘ms-word’. Describe all steps involved in it. 

          MS Word 

 MS Word is a widely used commercial word processor developed by                     

Microsoft. 

MS word is a application software, which is capable of 

• Creating 

• Editing 

• Saving and  

• Printing any type of document 

Answer:- 

Creating and Editing in MS word 

 Click Edit Document > Edit in word for the web to make changes to a document 

when you Open a document from one drive, word for the web displays to your 

in it Reading view. To make changes to your document, switch to Editing view, 

where you can add and delete content and do other things, such as: Add tables 

and pictures. 

To create a new blank document: 

Click the Microsoft office button. 

Select New. The New Document dialog box appears. 

Select Blank document under the blank and recent section. It will be highlighted 

by default. 

Click Create. A New blank document appears in the word window. 

          Saving and printing in MS- Word  

1.  Open a document.  

2. Type some text. 



3. Go to file and save as.  

4. And type a file name. And then create a document. And for printing after 

open document select ctrl+ p. Then it Print and save document. 

 

Q. 8. Create a file in MS- Word for the following document and save it 

with file name ‘equation ‘. Describe all steps involved in it. 

                   Equation 

             X2 + y5 = 30 

             Z3 + Q4 = 50 

            A2 + B8 = X2 + Y8 

Answer:- Save a document as a template                   

Open the Word document that you want to save as a complete. One the file 

menu, click save as box, type the name that you want to use for the new template 

Q. 9. Create a file in MS-Word that convert existing highlight text to 

table as shown below and save it as file name ‘text_ to_ table’. 

Describe all steps involved in it. 

Select the text you want to convert  

Select the insert tab  

Click on Table command. A dialog box appears                                             

Click on convert Text to table, a new dialog box appears  

Here set number of columns. 

Click on OK finally selected text convert in a table 

Select the text you want to convert. Select the Insert tab. 
Click on Table command. A dialog box 
appears 

Click on convert Text to Table, a new 
dialog box appears 

Here set number of command  Click on OK Finally selected text 
convert in table 



Answer:-  There may be times when you want to convert an existing table into 

text. To do this, follow these steps: 

• Select the entire table you want to convert to text.  

• Make sure the layout tab of the ribbon is displayed  

• In the data group, click the convert to Text tool. Word displayed the 

convert table to Text dialog box. (see figure 1.) 

 

 

 

 

 

 

            

 

 

Q.10. Create a file in MS- Word to insert a table in the document. Describe all 

steps involved in it. 

1. Open a blank Word document. 

2. In the top ribbon, press Insert. 

3. Click on the Table button. 

4. Either use the diagram to select the number of columns and rows you need 

, or click insert Table and a dialog box will appear where you can specify the 

number of columns and rows.  

5. The blank table will now appear on the page. 

Q.11. Create a following worksheet in MS- Excel and save it with name ‘book1’. 

Convert Table to Text    ?         x   

Separate text with  

o Paragraph marks 

• Tabs 

o commas 

o Other:  

Convert nested tables 

 

• g

j

j

u

h 
OK cancel 



 

  

  

 

 

 

 

 

 

 

Answer:- Save a Worksheet 

• Right- Click the worksheet name tab. 

• Click Select Move or copy. 

• Click on the Move selected sheet to book drop- down menu. Select (new 

book). 

• Click OK. Your new workbook opens with your moved worksheet. ………. 

• Click file> Save in your new workbook. 

Q. 12. Calculate the following things of a range (C2: C11) of data in the            

worksheet created in question no 10 

➢ The sum of  the marks using AutoSum in a range (C2: C11) 

➢ Average of the marks in a range of cells (C2: C11) 

➢ Highest marks in a range of cells (C2: C11) 

➢ Minimum marks in a range of cells (C2: C11) 

 

Answer:- To create the formula: 

    
    

    
    
  A B C 

1   name Marks 

2                      1 N1 60 

3                      2 N2 70 
4                      3  N3 80 
5                      4 N4 90 

6                      5 N5 40 

7                      6 N6 90 
8                      7 N7 77 

9                      8 N8 44 
10                      9 N9 88 

11                    10 N10 55 

12    
13    
14 Sheet 1 Sheet 2  

R0ll no   name                       Marks 

1 n1                                              60 

2 n2                                              70 

3 n3                                              80 

4 n4                                              90 

5 n5                                              40                                            

6 n6                                             90 

7 n7                                             77 

8 n8                                              44 

9 n9                                             88 

10 n10                                           55 

 

A                 B                               C 



Type = SUM in a cell, followed by an opening parenthesis (To enter the first 

formula range, which is called an argument (a piece of data the formula needs 

to run), type A2:A4 (or select cell A2 and drag through cell A4). 

Type comma (,) to separate the first argument from the next 

Type the second argument, C2:C3 (or drag to select the cells). 

Type a closing, and they press Enter. 

Each argument can be a range, a number, or single cell reference, all separated 

by commas. 

= SUM (A2:A4, 2429 10482) 

= SUM (4823, A3: A4, C2:C3) 

= SUM (4823, 12335, 9718, C2:C3) 

= SUM (A2, A3, A4, 2429, 10482) 

Or  

Quick Grand Total for a range of cells 

Select the range of cells, and the bank row below the range, and the blank cells 

In the column to the right (cells A1:d5 in the example below) 

Click the AutoSum button on the Ribbon’s Home tab. A SUM formula will be 

automatically entered for each Total. 

Q. 13. A) Describe various steps involved in the following 

➢ To modify columns which of a worksheet 

➢ To modify the row height of a worksheet 

➢ To delete rows and columns of a worksheet 

Answer:-   To modify column     

➢ Position the cursor over the column line in the column heading. 



➢ And a double arrow will appears. 

➢ Left- Click the mouse, than drag the cursor to the right to increase the 

column width or to the left decrease the column width. 

➢ Release the mouse button. 

Or 

On the home tab in the Ribbon menu, Click Delete and select delete Sheet 

Columns. You can also right click the highlighted column and select Delete  

Ribbon menu is used to delete a column or row a worksheet 

Q. 13. B) Describe following terms in the worksheet 

➢ Absolute reference and relative reference formula 

➢ Cell address 

Answer:-   

Absolute cell reference 

When a formula appears = A$4 the column is relative and the row is fixed. 

When a formula appears = $A$4 the column is fixed and the row is fixed. Absolute 

cell references do not change when a formula is copied from one cell to another. 

or 

An absolute Reference ; cell references in a formula always refer to the some cell 

or cell range. If a formula is copied a different location the absolute reference 

remains the same. 

Absolute reference  

An absolute reference is designated in the formula by the addition of a dollar sing 

(s). It can precede the column reference or the row reference, or both Examples 

of absolute referencing include:-  

SAS2:- The column and the row do not change when copied.  

AS2:- The row does not change when copied. 

SA2:- The column does not change when copied. 

 

Q. 14. a) What Tools are available to customize our PowerPoint presentation? 

Answer:-  A  



Is 1.a electronic page in a PowerPoint Presentation 

6. edit 

7. PPTX is the default presentation file format for new PowerPoint presentations. 

Support for loading and saving PPT files is built into PPTX. …. The default file 

extension is. PPTX. 

Q. 14. B) Write the steps for the formula action for creation of power point 

presentation 

➢ Open Blank presentation 

➢ Save the presentation as Lab1.pptx 

➢ Add a Title to the first slide: the name of your college 

➢ Type your first name and last name and last in the subtitle section 

➢ Add a new Slide which has a Title and Content 

Answer:-   

 Open blank presentation                                                                                                                                                                                                                                                                                                                                                                                              

1. Choose file New, Backstage view Opens, view opens, displaying this for 

various types of presentations you can create. 

2. Lick the blank presentation tile. A new blank presentation opens. 

3. Choose4 File Close the new presentation. … 

4. Press Ctrl+ N. … 

5. Choose File Close to close the new presentation. 

Save presentation steps 

1. On the file tab, select Save As  

2. Under save As, do one of the following: 

3. Under Recent folders, select Browse, pick a path and file folder, and then 

name the file. 

4. In the save as type list, pick the file format that you want. 

5. Select save. 

Add title steps:- 



• Click to add title  

• Click to add text  

• Title slide 

• Title and content Slide 

Type name steps:- 

• Open Power Point and scroll to the slide to add the signature. 

• Click a text box on the slide or add one by clicking the text box button and 

dragging the mouse to first to form the text box. 

• Type the phrase “created by” in the text box. Proceed to either the “With 

Graphic” or” By Hand” section. 

Add a New Slide  

• In the slide thumbnail pane on the left, click the slide that you want your 

new slide to follow. 

• On the Home tab, click new Slide. Learn more about slide layouts. 

• Select add Slide. 

  Q. 15. Write steps for creation of a set of Power Point slides that demonstrates 

your skill to use the tools of Power Point. It should include the following things 

➢ Title slide and bullet list 

➢ Inserting Excel Sheet 

➢ Clip art and Text 

➢ Slide sow effects 

Answer:- On the slide, select the lines of text in a text placeholder or table that 

you want to add bullets or numbering to HOME tab, in paragraph group, click 

Bullets on Numbering. To change all lines of text, select the outline of the text 

object, and then apply the bullet or numbering. 

Inserting Excel Sheet 

➢ In PowerPoint, Select the insert tab and click the insert tab. 

➢ Click the object command in the Text group. 



➢ A dialog box will appear. 

➢ Locate and select the desired Excel file. 

Then click Insert. 

Clip art and Text 

• Click the insert tab  

• In illustrations group click on the picture button. 

• Insert picture dialog box appears. 

• With a click select the desired picture. 

• Click Insert, the picture will be added to the slide. 

• Click and drag the picture to move it to desired location.  

Slide sow effect steps 

On the left Side on the slide window, in the pane that contains the Outline and 

Slides tabs, click the Slide tab. Select any slide thumbnails of the slides on 

which you want to apply or change a slide transition. On the transitions. On 

the Transitions tab, in the transition to this slide group, click a slide transition 

effect. 

Q. 16. What is the difference between Machine Language and high level 

Language? 

Answer:- Explanation:- 

Machine language, or machine code, it is the only language that is directly 

understood by the computer, and it does not need to be translated. All 

instructions use binary notation and are written as a string of 1s and Os. A 

program instruction in machine language may look something like this: 

100101011001010-01111101010011011100101 

A high- level language is a programming language that use English and 

mathematical symbols, like +, -, % and many others, in its instructions. When 

using the term ‘programming language,’ most people are actually referring to 

high- level languages. High- level languages are the languages most often used by 



programmers to write programs. Examples of high level languages are C++, 

Fortran, java and python. 

To get a flavor of what a high- level language actually look like, consider an ATM 

machine where someone wants  to make a withdrawal of $100. This amount 

needs to be compared to the account balance to make sure there are enough 

funds. The instruction in a high level computer language would look something 

like this: 

X = 100 

If balance x: 

Print ‘insufficient balance’  

else:  

print. ‘please take your money, 

This is not exactly how real people communicate, but it is much easier to follow 

than a series of 1s and Os in binary code.  

 

There are a number of advantages to high- level languages. 

 

The first advantage is that high-level language are much closer to the logic of a 

human language. 

This second advantage is that the code of must high- level languages is portable 

and the some cod can run on different hardware. 

Q. 17. Discuss about different data types of C Programming Language. 

 Answer:-  

Explanation: 

C language is one of the basic computer languages and is quite commonly used. 

There are different things that need to be learned to before programming. Some 

of these are; 

Data types; 

This represents the type of data, whether is a string, integer, floating point etc. 

This is important because without selecting write data type, we might not get 

desired output. 

Q. 18. Find the output of the following expressions 



     a)  X= 20/5*2+30-5    b)   Y=30 - (40/10+6) + 10   c)   Z= 40*2/10 – 2 + 10 

a)   X = 
20

5∗2
 + 30 – 5                          b)   Y = 30 –( 40 10 + 6⁄ ) + 10 

= 
20

5−2
 + 25                                  = 30 - 

40

16
 + 10 

         = 
20+75

3
                                        = 

480−40+160

16
 

  X   = 
95

3
                                               =  

640−40

16
 

C)  Z = 40*
2

10
 - 2 + 10           Y =   

600

16
   =  

75

2
 

          = 40 - 
2

10
 – 2 + 10  

      = 40 - 
1

5
 - 2 + 10 

    =   
200−1−10+50

5
 

    = 
250−11

5
  =  

239

5
 

Q. 19. Describe the syntax of the following statements  

       a).  If – else statement    b).  For loop    c). While loop    d). do - while loop    

Answer:-      a)  If – else statement 

      The general form of if – else is as follows: if (test – expression) { true block of 

statements} Else {False block of statements} Statements; n this type of a 

construct, if the value of test – expression is true, then the true block of 

statements will be executed. 
      Or 

       Syntax of if else statement 

       If condition returns true then the statements inside the body of “if” are 

executed and the statements inside body of “else” are skipped. 

If condition returns false then the statements inside the body of “if” are skipped 

and the statements in “else” are executed. 

  

Flow diagram of if else statement      

 

                                



 

       True 

      

                                       False 

 

 

 

 

           b) For loop 

 

 

The for loop starts with a for statement followed by a set of parameters inside the 

parenthesis. The for statement is in lower case. Please not that this is case 

sensitive, which means the for command always has to be in lower case in C 

programming language. The initialization statement describes the starting point 

of the loop, where the loop variable is initialized with a starting value. A loop 

variable counter is simply a variable that controls the follow of the loop. The test 

expression is the condition until when the loop is repeated. Update statement is 

usually the number by which the loop variable is incremented. 

 

                   

 

 

 

Conditi

on 

Code inside If 

body 

Code inside 

else body 

1       for   (initialization statement;    test    

2    // statements 

3   } 



 

        C) While loop  

        The While construct consists of a book of code and condition/ expression. 

The condition/ expression is evaluated, and if the condition/ expression is true, 

the code with in all of their following in the block is executed. This repeats until 

the condition/expression becomes false. 

 

    d) do – while loop 

    Syntax. Do { statement(s); while ( condition ) ; Notice that the conditional 

expression appears at the end of the loop, so the statement (s) in the loop 

executes one before the condition is true, the flow of control jumps back up to 

do, and the statements (s) in the loop executes again. 

   Q. 20. Find the output of the following program segments 

a) b)     

#Include < stdio.h>                                     #include<stdio.h> 

int main()                                                       int main()        

Int;                                                                   { 

For (i=1; i<2; i++)          int I = 1; 

{          while(i<=2) 

Printf(“IMS Ghaziabad\n”);         { 

    }        printf(“IMS Ghaziabad\n”); 

}        i = i + 1; 

       } 

 } 

C)    #include<stdio.h> 

        Void main() 

       { 

      Int a 10, b= 100; 

      If(a>b) 

     Printf(“Largest number is %d\n”,a); 



     Else 

printf(Largest number is %d\n”,b); 

   } 

Answer:-  The given program outputs the word  

 a)    IMS Ghaziabad\n 

        b)    i + 1; 

        c)   (“Largest number is %d\n”,a);  

 

 

           

   

 

 

 

 

 

 

 

 

 


