
 
1. What are the four fundamental parts of computer? Explain it with the help of diagram. 

 A computer has four main components: Input Units, the central processing unit or 

CPU, the Primary memory, and Output units. Input Unit - The devices to input 

information, such as a keyboard, and mouse. CPU - The CPU is further broken up into 

ALU, Control Unit, and Instruction Unit. 

 
 

 
2. Discuss about the classification of computers based on size and capacity 

Introduction 

Classification of computers are based on their architecture, speed of executing commands or 

instructions, peripheral used and also their uses. Microcomputers are usually used in home 

and offices and only a single user can perform the task using a microcomputer. Its storage 

and data handling capacity are limited as per the requirement for home and office work. The 

another type of computer is called minicomputer which has usually larger storage and can 

handle multiuser at a time. This chapter includes the classification of computers. 

  

Computer's Classification 



Computers are classified on different parameters, such as, storage capacity, processing speed 

and component (CPU) used in computers. Depending upon the components used and features 

of different computers, they are classified into four groups, Microcomputers, Minicomputers, 

Mainframe computers and Supercomputers. 

  

     Micro Computers 

Micro Computer is a computer whose CPU (Central Processing Unit) is a microprocessor. All the 

components of a microprocessor are on a single integrated circuit chip. Micro computer can be 

categorized as the desktop, programmable and workstation. The microprocessor based 

computers are called third generation computers. They are the backbone of the modern 

computer era. The first and second generation computers are based on vacuum tubes and 

bipolar junction transistors. 

  

 

  

Desktop Computers 

Desktop computer is a type of microcomputer. A desktop computer has a keyboard for input 

data, a LCD or CRT monitor to display information and Central processing unit tower 

contains storage, memory, different types of drives, such as, CD drive, hard drive, etc. A 

desktop computer is mainly used at home and office applications. 

  

Programmable Computers (PDA) 

Personal digital assistance is a type of hand held programmable digital computer. It isusedas 

notepads, address books and can connect to world web wave to share information. A PDA is 

equipped with mobile phone hence, called smallest computer. 

  



  

Workstation 

A workstation computer has greater memory capability and more extensive mathematical 

abilities. It is connected with other workstation computers or personal computer to exchange 

data and mostly used for scientific applications. It also supports multitasking applications. 

  

Mini Computers 

Minicomputers were introduced in early 1960s. They were faster than micro computers. 

Basically these computers were mainly multi-user systems, where many users work on the 

systems. Generally these types of computers had larger memories and greater storage 

capacity. They had large instruction set and address field. These kinds of computers have 

efficient storage for handling of text, in comparison to lower bit machines. Due to more 

efficient processor, speed and memory size, minicomputer was used in variety of 

applications and could support business applications along with the scientific applications. 

Minicomputer was a multi-user system which means more than one user could use this 

system simultaneously. 

  

Comparison of Micro and Mini computers 

  

Features Microcomputer Minicomputer 

Primary 
memory  

Shall memory Larger memory 

Word length  Small word 
length  

Larger word 
length 

Cost low Low High 

Processor Low High 

  

Mainframe Computers 

Mainframe computers are large and expensive machines. The word length of mainframe 

computers may be 48, 60 or 64 bits, memory capacity being in some megabytes and storage 

capacity in some terabytes. Generally they handle huge volumes of information and data. In 

terms of speed, they are having significant processing capacity. They are used in research 

organizations, large industries, airlines reservation where a large database has to be 

maintained. 

  

 

  

Super Computers 



Super Computers are the fastest computer in current era. The processing capabilities of 

super computer lies in the range of GIPS2, word length 64-128 or may be in 256 or so. The 

memory capacity of super computer is in some gigabytes or in terabytes. The storage 

capacity of this type of computer is in exabytes. 

  

 

  

The parallel processing of a super computer makes it very fast because it contains number 

of CPU that operates parallel. They are used at some research centers and government 

agencies involving sophisticated scientific and engineering tasks. 

  

Super computers are used for the followings: 

  

  Weapons research and development 

  Nuclear and plasma physics 

  Rocket research and development 

  Atomic research 

  Aerodynamics 

  

Units For Measuring Word Length, Data, And Storage Capacity of a Computer 

Computers are classified on the basis of their data processing speed better known as clock 

speed and the word length. The word length that is processed by a CUP at a time is one of 

the important feature of that CPU. 

  

The followings are the units for the measurement of data volume: 

  

bit bit 0 or 1 

Byte B 8 bite 

Kibibit Kibit 1024 bits 

kilobit Kbit 1000 bits 

kibibyte (binary) KiB 1024 bytes 

kilobyte (decimal) kB 1000 bytes 

megabit Mbit 1000 kilobits 

mebibyte (binary) MiB 1024 kibibytes 

megabyte (decimal) MB 1000 kilobytes 

gigabit Gbit 1000 megabits 

gibibyte (binary) Gibbs 1024 mebibytes 

gigabyte (decimal) GB 1000 megabytes 

terabit Tbit 1000 gigabits 

tebibyte (binary) TIB 1024 gibibytes 



terabyte (decimal) TB 1000 gigabyte 

Petabit Pbit 1000 terabyte  

pebibyte (binary) PiB 1024 tebibytes 

petabyte (decimal) PB 1000 terabytes 

exabit Ebit 1000 petabits 

exbibyte (binary) EiB 1024 pebibytes 

exabyte (decimal) EB 1000 petabytes 

  

 
3. What is the meaning of computer generation? How many Computer Generations are 

defined? What technologies were/are used? 

  

S.No Generation & Description 

1 
First Generation 

The period of first generation: 1946-1959. Vacuum tube based. 

2 
Second Generation 

The period of second generation: 1959-1965. Transistor based. 

3 
Third Generation 

The period of third generation: 1965-1971. Integrated Circuit based. 

4 
Fourth Generation 

The period of fourth generation: 1971-1980. VLSI microprocessor based. 

5 
Fifth Generation 

The period of fifth generation: 1980-onwards. ULSI microprocessor based. 

 

 
4. Differentiate between Volatile & Non- Volatile memories 

    

S.NO Volatile Memory Non-Volatile Memory 

https://www.tutorialspoint.com/computer_fundamentals/computer_first_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_second_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_third_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_fourth_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_fifth_generation.htm


S.NO Volatile Memory Non-Volatile Memory 

1. 

Volatile memory is the type of memory 
in which data is lost as it is powered-
off. 

Non-volatile memory is the type of 
memory in which data remains stored 
even if it is powered-off. 

2. 
Contents of Volatile memory is stored 
temporarily. 

Contents of Non-volatile memory is 
stored permanently. 

3. It is faster than non-volatile memory. It is slower than volatile memory. 

4. 
RAM(Random Access Memory) is 
an example of volatile memory. 

ROM(Read Only Memory) is an 
example of non-volatile memory. 

5. 

In volatile memory, data can be easily 
transferred in comparison to non-
volatile memory. 

In non-volatile memory, data can not 
be easily transferred in comparison to 
volatile memory. 

6. 
In Volatile memory, process can read 
and write. 

In Non-volatile memory, process can 
only read. 

7. 
Volatile memory generally has less 
storage capacity. 

Non-volatile memory generally has 
more storage capacity than volatile 
memory. 

8. 

In volatile memory, the program’s data 
are stored which are currently in 
process by the CPU. 

In non-volatile memory, any kind of 
data which has to be saved 
permanently are stored. 

9. 
Volatile memory is more costly per 
unit size. 

Non-volatile memory is less costly per 
unit size. 

10. 
Volatile memory has a huge impact on 
the system’s performance. 

Non-volatile memory has a huge 
impact on a system’s storage 
capacity. 

11. 
In volatile memory, processor has 
direct access to data. 

In non-volatile memory, processor has 
no direct access to data. 



S.NO Volatile Memory Non-Volatile Memory 

12. 
Volatile memory chips are generally 
kept on the memory slot. 

Non-volatile memory chips are 
embedded on the motherboard. 

 

 

 
5.Distinguish among system software, application software and open source software on 

the basis of their features 

System software is meant to manage 
the system resources. It serves as the 
platform to run application software. 

Application software helps perform 
a specific set of functions for which 
they have been designed. 

System software is developed in a low-
level language (assembly language for 
example) 

Application software is developed 
in a high-level language such as 
Java, C++, .net and VB. 

System software automatically starts 
running once the system is turned on 
and stops when the system is shut 
down. 

Application software runs as and 
when the user requests it. 

A system cannot even start without 
system software 

Application software is user 
specific and it is not needed to run 
the system on the whole. 

System software is endowed with a 
general purpose. 

Application software carries a 
specific purpose. 

A typical example for a system software 
is Windows Operating System 

Some characteristic examples for 
application software is MS Office, 
Photoshop and CorelDraw 

 

 
6.A) Create a file in MS-word to insert a paragraph about yourself and save it with file name 

“yourself”. Describe all steps involved in it. 

 

        NAME                          : Edwin Arul Selvam S 

        DOB                             : 02.11.2001 



       ADDRESS                          : 5/277, Jerome nagar, mela manjampatty, manjampatty (po), 

                                                     Manapparai (Tk) , Trichy (Dt) , 621307 

      QUALIFICATION               :  B.Com 

      SPORTS                              : Athletics, Cricket 

 

6. B)  Health is Wealth 

      Health is Wealth 
      Health is Wealth 

           

MS Word 

Creating  

1. Open Word. Or, if Word is already open, select File > New. 

2. In the Search for online templates box, enter a search word like letter, resume, or 
invoice. Or, select a category under the search box like Business, Personal, or 
Education. 

3. Click a template to see a preview. ... 

4. Select Create 

 

Editing 

  

Click Edit Document > Edit in Word for the web to make changes to a document. 
... 
To make changes to your document, switch to Editing view, where you can add 
and delete content and do other things, such as: 

1. Add tables and pictures. 

2. Apply styles. 

3. Adjust formatting. 

4. Edit headers and footers. 

 

Saving 

  

Click FILE > Save, pick or browse to a folder, type a name for your document in the File 
name box, and click Save. Save your work as you go - hit Ctrl+S 

 

Printing 

    

1.     Select File > Print. 



2. To preview each page, select the forward and backward arrows at the bottom of the 
page. If the text is too small to read, use the zoom slider at the bottom of the page to 
enlarge it. 

3. Choose the number of copies, and any other options you want, and select the Print 
button. 

 

 
8. Create a file in MS-word for the following document and save it with file name ‘equations’. Describe 
all steps involved in it. 

 

   EQUATIONS 

     X2 +Y5=30 
           Z3 +Q4=50 

       A2+B8= X2 +Y8 

 

 

9.Create a file in MS-word that convert existing highlight text to table as shown below and save it as file 
name ‘text_to_table’. Describe all steps involved in it.  
 

 

    

Select the text you want to convert. Select the Insert tab. 

Click on Table command. A dialogue box 

appears. 

Click on Covert to Text Table, a new dialogue 

box appears 

here set a number of columns. Click on OK Finally Selected text converted in a 

table 

 

    
10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in it. 

    

       

        

 

 

16.What is the difference between Machine Language and High Level Language 

 

    



High-Level Language Low-level language 

It can be considered as a programmer-friendly 
language. 

It is considered as a machine-friendly 
language. 

It requires a compiler/interpreter to be translated 
into machine code. 

It requires an assembler that would translate 
instructions. 

It can be ported from one location to another. It is not portable. 

It is easy to understand. It is difficult to understand. 

It is easy to debug. It is difficult to debug. 

It is less memory efficient, i.e., it consumes more 
memory in comparison to low-level languages. 

It consumes less memory. 

 

 

17.Discuss about different data types of C programming Language. 

 

   1.integer 

  2.float 

  3.double 

  4.string 

  5.array 

18.  Find the output of the following expressions  

a) X=20/5*2+30-5 

Solution 
𝑥=33 

 
 b) Y=30 – (40/10+6) +10  
solution 
y=30 
 
c) Z= 40*2/10-2+10  
 



solution 
z=16 
 

19. Describe the syntax of the following statements  
a) If – else statement 
syntax: 
if(condition) 
{ 
Statement; 
} 
 
 b) for loop 
syntax: 

for(initialization;condition;increment) 

{ 

Statement 

} 

  
c) while loop 
syntax: 
while(condition) 
{ 
Statement 
} 
 
 d) do-while loop  
syntax: 

do 

{ 

Statement 

} 

While(condition) 

 

 

 

 

 

 

 



20. Find the output of the following program segments 

a)  b)  c)  
#include <stdio.h>  
int main()  
{  
int i;  
for (i=1; i<2; i++)  
{  
printf( "IMS Ghaziabad\n");  
}  
}  

#include <stdio.h>  
int main()  
{  
int i = 1;  
while ( i <= 2 )  
{  
printf( "IMS Ghaziabad\n");  
i = i + 1;  
}  
}  

#include <stdio.h>  
void main()  
{  
int a = 10, b=100;  
if( a > b )  
printf( "Largest number is %d\n”, 
a);  
else  
printf( "Largest number is %d\n”, 
b);  
}  

 

 

A. Output 
IMS Ghaziabad 
 

B. Output 
IMS Ghaziabad 
IMS Ghaziabad 

C. Output. 

Largest number 100 

 



Roll no Name Marks
1 n1 60
2 n2 70
3 n3 80
4 n4 90
5 n5 40
6 n6 50
7 n7 77
8 n8 44
9 n9 88

10 n10 55
sum 654
avg 65.4
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