
Assignment 1 

Q1: What are the four fundamental parts of a computer? Explain it with the help of a diagram. 

 Answer: The four fundamental parts are: 

• Input Unit: Allows data entry (e.g., keyboard, mouse). 

• Output Unit: Displays results (e.g., monitor, printer). 

• CPU (Central Processing Unit): Executes instructions and processes data. 

• Memory Unit: Stores data temporarily (RAM) or permanently (Hard Disk). 

 

Q2: Discuss the classification of computers based on size and capacity. 

 Answer: Computers are classified as: 

• Microcomputers: Small, for personal use (e.g., PCs). 

• Minicomputers: Medium-sized, used by small businesses. 

• Mainframe Computers: Large, used by large organizations for bulk data processing. 

• Supercomputers: High capacity, used for complex computations. 

 

Q3: What is the meaning of computer generation? How many Computer Generations are defined? What 

technologies were/are used? 

 Answer: Computer generations describe the evolution of technology: 

• 1st Generation: Vacuum tubes. 

• 2nd Generation: Transistors. 

• 3rd Generation: Integrated Circuits. 

• 4th Generation: Microprocessors. 

• 5th Generation: Artificial intelligence (ongoing). 

 

Q4: Differentiate between Volatile & Non-Volatile memories. 

Answer: 

• Volatile Memory: Requires power to retain data (e.g., RAM). 

• Non-Volatile Memory: Retains data without power (e.g., Hard Disk). 

 

Q5: Distinguish among system software, application software, and open-source software based on their 

features. 

Answer: 

• System Software: Manages hardware (e.g., OS). 



• Application Software: Helps users perform tasks (e.g., MS Word). 

• Open-Source Software: Source code available publicly for modification. 

Q6 a) Create a file in MS-Word to insert a paragraph about yourself and save it with the filename “yourself.” 

Describe all steps involved. 

 Answer: 

  1. Open MS Word: Start MS Word by searching for it in the Start menu or selecting it from your applications. 

  2. Insert Paragraph: Click on the blank page and start typing a paragraph about yourself. Write a few 

sentences describing your background, interests, or any other information you’d like to include. 

  3. Save the Document: 

• Click on "File" in the upper-left corner. 

• Select "Save As." 

• Choose the location where you want to save the file. 

• Enter the filename “yourself” in the file name field. 

• Click "Save" to store the file. 

 

Q6 b) Write steps regarding the following actions: 

   To change the font style: 

• Select the text you want to format. 

• Go to the "Home" tab in the toolbar. 

• Click on the font dropdown menu and choose your preferred font style. 

    To change the font size: 

• Select the text. 

• In the "Home" tab, locate the font size dropdown. 

• Choose the font size you want. 

    To change the font color: 

• Select the text. 

• Click on the "Font Color" icon (A with color bar) in the "Home" tab. 

• Select the color you want. 

 

    To highlight text (e.g., in yellow): 

• Select the text that reads “need to get IMS’s address.” 

• Click on the "Text Highlight Color" icon in the "Home" tab. 

• Choose yellow from the dropdown to highlight the text. 



 

Q7: Create a file in MS-Word for the given document and save it with the filename ‘MS word.’ Describe all 

steps involved. 

 Answer: 

  1. Open MS Word: Open a new document in MS Word. 

  2. Enter Document Content: Type the text and structure the document as specified in the question. 

  3. Formatting: Apply any specific formatting, such as headings, bold, italics, etc., as needed. 

  4. Save the Document: 

o Go to "File" > "Save As." 

o Choose a location and enter ‘MS word’ as the file name. 

o Click "Save." 

 

Q8: Create a file in MS-Word for the following document and save it with the filename ‘equations.’ Describe 

all steps involved. 

 Answer: 

  1. Open MS Word: Create a new document in MS Word. 

  2. Insert Text: Type any introductory text or details as specified. 

  3. Insert Equations: 

      - Go to the "Insert" tab. 

      - Click on "Equation" (found in the Symbols group). 

      - You can either type your equation or use pre-defined templates for common equations. 

  4. Save the Document: 

      - Select "File" > "Save As." 

      - Enter ‘equations’ as the filename. 

      - Click "Save." 

 

Q9: Create a file in MS-Word to convert highlighted text to a table and save it as 'text to table.' Describe all 

steps involved. 

 Answer: 

  1. Open MS Word: Open a new document and type or paste the highlighted text. 



  2. Select and Convert Text to Table: 

• Highlight the text you want to convert. 

• Go to the "Insert" tab, then click "Table." 

• Select "Convert Text to Table." 

• Choose the appropriate settings for columns and rows (Word will usually auto-detect based 

on tabs or commas) 

  3. Save the Document: 

      - Click "File" > "Save As." 

      - Enter ‘text to table’ as the filename. 

      - Click "Save."  

 

Q10: Create an MS-Word file to insert a table in the document. Describe all steps involved. 

Answer: 

  1. Open MS Word: Start a new document. 

  2. Insert Table: 

      - Go to the "Insert" tab. 

      - Click on "Table" and choose the number of rows and columns you need. 

      - Enter data into each cell of the table as per your requirements. 

  3. Save the Document: 

      - Select "File" > "Save As." 

      - Name the file appropriately. 

      - Click "Save." 

 

Q11: Create a worksheet in MS-Excel and save it with the name 'book1.' 

Answer: 

  1. Open MS Excel: Open a new Excel workbook. 

  2. Enter Data: Enter the data required for the worksheet. For example, you may need to create columns for 

various items (e.g., names, scores, etc.). 

  3. Save the Workbook: 

      - Click on "File" > "Save As." 



      - Name the file as 'book1' and choose a location. 

      - Click "Save." 

 

Q12: Calculate the following in range (C2:C11): 

   - Sum: Use `=SUM (C2:C11) `. 

   - Average: Use `=AVERAGE (C2:C11) `. 

   - Highest: Use `=MAX (C2:C11) `. 

   - Minimum: Use `=MIN (C2:C11) `. 

 

Q13 a) Describe steps to modify columns and rows in Excel: 

- Modify Column Width: 

     1. Select the column(s) you want to resize. 

     2. Right-click on the column header. 

     3. Choose "Column Width" and enter the desired width. 

 - Modify Row Height: 

     1. Select the row(s) you want to resize. 

     2. Right-click on the row number. 

     3. Choose "Row Height" and enter the desired height. 

- Delete Rows and Columns: 

     1. Select the row or column to delete. 

     2. Right-click and select "Delete" to remove it from the worksheet. 

 

Q13 b) Describe the following terms in the worksheet: 

  - Absolute Reference: In Excel, an absolute reference does not change when copied (e.g., `$A$1`). 

   - Relative Reference: Adjusts when copied to another cell (e.g., `A1`). 

 - Cell Address: Refers to a specific cell location (e.g., B2). 

 

Q14 a) What tools are available to customize a PowerPoint presentation? 

 Answer: PowerPoint offers various customization tools: 



  - Themes and Templates: Pre-designed slide layouts. 

  - Transitions: Animated transitions between slides. 

  - Animations: Effects applied to objects within slides. 

  - Slide Layouts and Backgrounds: Adjust layouts and apply background styles. 

  - SmartArt and Charts: Visual tools for representing information. 

 

Q14 b) Steps to create a PowerPoint presentation: 

   - Open a Blank Presentation: Start PowerPoint > Select “Blank Presentation.” 

   - Save as Lab1.pptx: Go to "File" > "Save As" and save with the name 'Lab1.pptx.' 

   - Add Title: 

     - Click on the title placeholder on the first slide. 

     - Type your college’s name. 

   - Add Subtitle: 

     - Click on the subtitle placeholder and enter your first and last name. 

   - Add a New Slide: 

     - Go to the "Home" tab, click on "New Slide," and select "Title and Content." 

 

Q15: Steps for creating PowerPoint slides demonstrating your skills: 

o Create Title Slide & Bullet List: Add a title slide with a bulleted list. 

o Insert Excel Sheet: Go to "Insert" > "Object" > Select "Excel" to embed a sheet. 

o Add Clip Art & Text: Use the "Insert" tab to add images or clip art and text boxes. 

o Apply Slide Show Effects: Go to the "Transitions" or "Animations" tabs to add effects between 

slides or animate content. 

 

Q16: What is the difference between Machine Language and High-Level Language? 

 Answer: 

o Machine Language: This is the lowest level of programming language, consisting of binary code 

(0s and 1s) directly understood by a computer’s CPU. It is hardware-specific and difficult for 

humans to read and write. 



o High-Level Language: This is a more abstract, user-friendly language that is closer to human 

language, such as Python, C++, or Java. It allows programmers to write instructions in a form 

that is easier to read, write, and maintain. High-level languages are translated into machine 

language using compilers or interpreters. 

 

Q17: Discuss different data types of the C programming language. 

 Answer: In C, data types define the type and size of data a variable can hold. The main data types in C are: 

o int: Stores integer values (whole numbers) without decimal points, e.g., 5, -20. 

o float: Stores floating-point numbers (decimal values), e.g., 3.14, -2.5. 

o char: Stores single characters, e.g., 'A', 'b'. It typically occupies 1 byte. 

o double: Stores larger floating-point numbers with double precision, e.g., 3.141592. It has more 

precision than float. 

 

Q18: Find the output of the following expressions. 

    a) X = 20/5*2+30-5 

      Answer: X = 33. (Explanation: 20/5 = 4, then 4*2 = 8, then 8+30 = 38, and 38-5 = 33.) 

    b) Y = 30 – (40/10+6) +10 

      Answer: Y = 24. (Explanation: 40/10 = 4, then 4+6 = 10, then 30-10 = 20, and 20+10 = 24.) 

   c) Z = 40*2/10-2+10 

      Answer: Z = 16. (Explanation: 40*2 = 80, then 80/10 = 8, then 8-2 = 6, and 6+10 = 16.) 

Q19: Describe the syntax of the following statements. 

• a) If-else statement 
o Answer: The if-else statement allows conditional execution based on whether a condition is 

true or false. 

if (condition) { 

    // Code to execute if condition is true 

} else { 

    // Code to execute if condition is false 

} 

 

• b) for loop 
o Answer: The for loop is used to repeat a block of code a specific number of times. 

Copy code 

for (initialization; condition; increment) { 



    // Code to execute in each iteration 

} 

• c) while loop 
o Answer: The while loop repeats a block of code as long as a specified condition is true 

while (condition) { 

    // Code to execute in each iteration 

} 

• d) do-while loop 
o Answer: The do-while loop executes the code block at least once before checking the condition 

at the end of each iteration. 

do { 

    // Code to execute in each iteration 

} while (condition); 

 

Q20: Find the output of the following program segments. 

• a) 

#include <stdio.h>   

int main ()   

{   

  int i;   

  for (i = 1; i < 2; i++)   

  {   

      printf ("IMS Ghaziabad\n");   

  }   

}   

o Answer: The output is: 

IMS Ghaziabad 

Explanation: The for loop runs once because i starts at 1 and the loop condition is i < 2. 

• b) 

#include <stdio.h>   

int main ()   

{   

  int i = 1;   

  while (i <= 2)   

  {   

      printf ("IMS Ghaziabad\n");   

      i = i + 1;   

  }   

}   

o Answer: The output is: 

IMS Ghaziabad 

IMS Ghaziabad 



Explanation: The while loop runs twice as i takes values 1 and then 2 before the condition i <= 2 
becomes false. 

• c) 

#include <stdio.h>   

void main ()   

{   

  int a = 10, b = 100;   

  if (a > b)   

      printf ("Largest number is %d\n", a);   

  else   

      printf ("Largest number is %d\n", b);   

}   

o Answer: The output is: 

Largest number is 100 

Explanation: The if condition a > b is false, so the else block executes, displaying 100 as the larger 
number. 

 

 

 

 

******************************************************************************** 

 

 

 


