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Question.1:-What are the four fundamental parts of computer? Explain it with the help of diagram.  

Answer:-  A computer has three main components:Input units,The Central Processing Unit or CPUand output 
units. 

Input Unit-The device to input information such as a keyboard and mouse etc. 

Central Processing Unit-The computer system is nothing without the CPU so, it is also known as 
the brain of computer.  The CPU contains two parts: The ALU and Control Unit. 

Output Units-The output devices give us the desired result according to our input, such as printer, 
monitor, etc. 

 

Question.2:-Discuss about the classification of computers based on size and capacity.  

Answer:-   Based on size and capacity the computers are divided into the following- 

 Super computer-The super computer is fastest, most expensive, big in size. It is used to forecast 
the weather and global climates, for researches etc. Ex. ANURAG, CRAY XMP/14 etc.  

 Mainframe Computer-It is large sized computer that covers about1000 sq feet. It is  general 
purpose computer that process large amount of data with very high speed. Ex. IBM S/390,IBM 
S/700. 

Minicomputer- Minicomputers are medium sized computer. So, these are popular as middle 
ranged computer. Ex. PDP-11, VAX etc. 

Microcomputer- These support many higher level application cost and easy in operation. Ex. 
IBM, apple Mac etc. 

 

Question.3:-What is the meaning of computer generation? How many computer generations are defined? what 
technologies were/ are used? 

Answer :-  1st Generation(1946-1959)- The computer of first generation used vacuum tubes as the basic 
components for CPU. Ex. ENIAC, EDVAC. 

2nd Generation (1959-1965)- In this generation, transistors were used as the basic components. Ex. 
FORTON, COBOL. 
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3rd Generation (1965-1971)- The computer of third generation used integrated circuits (ICs) in 
place of transistors. Ex. FORTRAN-II TO IV, BASIC. 

 

 

 

4TH Generation (1971-1980)- Computers of fourth generation used very large scale 
integrated(VLSI) circuits. Ex. DEC 10, STAR 1000.  

5TH Generation (1980-onwards)- In fifth generation, VLSI technology become ULSI(Ultra Large 
Scale Integration) technology. Ex. Desktop, Laptop, Ultrabook. 

Question.4:-Differentiate between volatile & non-volatile memories. 

Answer :-  Volatile memory is the type of memory in which data is lost as it is powered – off. Non- volatile 
memory is the type of memory in which data remains stored even if it is powered – off. Contents 
of volatile memory is stored temporarily. Contents of non – volatile memory is stored 
permanently.  

Question.5:-Distinguish among system software, application software and opensource software on the basis of 
their features.  

Answer :  System Software :- System Software is a set of programs that control and manage the operations of 
computer hardware. It also helps application programs to execute correctly. Ex. Operating 
System, Programming language, Communication Software etc. 

Application Software :- Application Software acts as a mediator between the end-user and 
System Software. Ex. Word-processing, Spreadsheet, Database etc. 

Opensource Software(OSS):- Open-source software is any computer software that’s distributed 
with its source code available for modification. That means it usually includes a license for 
programmers to change to the software in any way they choose. Ex. Linux OS, Android by 
Google, Open office, Firefox etc.  

Question.6:-a) Create a file in MS-word to insert a paragraph about yourself and save it with file name 
“yourself”. Describe all steps involved in it. 

Answer:- Step 1- Open MS-word  
     2-write “yourself” in the word page  
     3- On the Home tab, right-click the Normal style, and choose Modify 
     4- select Format and then choose Paragraph 
     5- choose New document based on this template 
     6- then select Ok. 
     7-ctrl+S to save the document. 
 

Question.6:-b) Write steps regarding followings 
 To change the font style 

Answer:-  Steps 1- Home Tab  2- Go to font Group 3- Then select font / shortcut is ctrl+shift+F. 
 To change the font size 

Answer:-  Steps 1- Click to the Home Tab  2- Go to Font Group  3- And select font size /   Press 
ctrl+Shift+P. 

 To change the font color  
Answer:-  Steps 1- Click to the Home Tab  2- Go to Font Group  3- And select font color option. 

 To highlight(in yellow) the line that reads “need to get IMS’s address”. 
Answer:- Steps 1- write “ need to get IMS’s address” and select  2- Click to the Home Tab  3- Go to Font 

Group  4- And select text highlight color option. 5. Then select yellow color. 
  

Question.7:-Create a file in MS – word for the following documents and save it with file name ‘MS-Word’. 
Describe all steps involved in it.  
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Answer :-Step 1- Open MS-word from start menu  
      2- write “MS Word” in the word page, select it and Press ctrl +B to bold.  
      3-The next line wite “MS Word is a widely used commercial word processor developed” 
by Microsoft. In this line select “MS Word” and go to the font section(Home Tab) then select 
font color (red), and select “word processor” then press ctrl +U for underline. 
      4- write “MS word is application software, which is capable of” in a new line then select 
bullets from the paragraph section (Home Tab) press enter. 
      5- write“creating”, go for font color(Home Tab) and  then select light blue. 
          write “editing”. 
         Write “saving” color (light red), “and” select Strikethrough option from font section 
(Home Tab). 
         Write “printing any type of document” then select ctrl+ B.  
 

Question.8:-Create a file in ms-word for the following document and save it with file name ‘equations’. 
Describe all steps involved in it. 

 

Answer :- Step 1- Open MS Word from the start menu  
      2- write “Equations” ,select it and press ctrt+U for underline 
      3- Write “ X2 +Y5 =30” with the help of subscript (Home Tab) 
      4- In the next “Z3 + Q4 =50” by the help of superscript (Home Tab) 
      5- write “A2 +B8 = X2 +Y8” with the help of sub and superscript (Home Tab) 
      6- Press ctrl+S to save and name the file ‘Equation’. Then again click save. 

 
Question.9 :- Create a file in MS- word that convert existing highlight text to table as shown below and save it 

as file name ‘text_to_table’. Describle all steps involved in it.  
  

 
 

Answer :-               Steps 1- Open MS word  
2- Select the text you want to convert into table.  
3- Go to the Insert Tab, click on the Tables Option.  
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4- Then click convert text to table  
5- Here set number of columns and Separate text at (Paragraph)  
6- Then click Ok to convert into table  
7-  Press Ctrl +S , name the file ‘text_to_table’ and click on Save option.  

 
Question.10:- Create a file in MS-Word to insert a table in the document. Describe all steps involved in it. 

 
Answer :      Step 1- Open MS word   

2- Click on Insert Tab   
3- Select table Option, a dialog box appears.  
 
 
4- Now go the Insert table option 5- Here set number of columns and rows. 
6- Then click OK button to insert table. 

 
Question.11:- Create a following worksheet in MS-excel and save it with name ‘book1’ 

  

Roll No Name Marks
1 n1 60
2 n2 70
3 n3 80
4 n4 90
5 n5 40
6 n6 50
7 n7 77
8 n8 44
9 n9 88

10 n10 55  
 

Answer :-   Step 1- Open MS excel 
       2- write “Roll No” in ‘A1’ , “Name” in ‘B1’ and “Marks” in  ‘C1’ cell.  
       3-  The ‘Roll No’ column contains no.1 to 10, ‘Name’ is n1 to n10 and            ‘Marks’ are 
Respectively 60,70,80,90,40,50,77,44,88 and 55.   
       4- Press Ctrl +S, name the file ‘book1’ and click Save option to save sheet. 
 

Solution.12:-  
 The sum of the marks using(table Q.11) Auto Sum in a range of cell(C2:C11) is 

=sum(C2:C11)=654 
 Average of the marks in a range of cells(C2:C11) is =AVRAGE(C2:C11)=65.4 
 Highest marks in a range of cells (C2:C11) is =MAX(C2:C11)=90 
 Minimum marks in a range of cell(C2:C11) is =MIN(C2:C11)=40 

 
 

Question.13:-a) Describe various steps involved in the following  
Solution :  

 To modify column width of a worksheet 
Steps :1- select the column 2- click Format, in the cells group(Home Tab) 3- Under 
cell size, click column width. 4- In the column width box, type value which you 
want. 5 – Then click Ok. 

 To modify the row height of a worksheet. 
Steps :1- select the row 2- click Format, in the cells group(Home Tab) 3- Under cell 
size, click row height. 4- In the row height box, type value which you want. 5 – 
Then click Ok. 

 To delete rows and columns of a worksheet 
Steps :1- select the rows or columns 2- click Delete, in the cells group(Home Tab) 3- 
Under Delete, click  Delete sheet rows or Delete sheet columns options. 
 

Question.13:-b) Describe following terms in the worksheet 
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 Absolute reference and relative reference in formula 

Solution:- There are two types of cell references. Relative and absolute reference behave 
differently when copied and filled to other cells. Relative references change when a formula is 
copied to another cell. Absolute reference, on the other hand, remain constant no matter where 
they are copied. 

 Cell address 
Solution:- It is an alphanumeric value used to identify a specific cell in a spreadsheet. 
 
 

Question.14:-a) What tools are available to customize our PowerPoint presentation? 
 
 
 

Answer:-  There are many for tools are available to customize our presentation. 
  

1. Choose a theme from PowerPoint’s preloaded themes, found under the Design tab. 
2. Pick a variant if you like, such as a different color, under the Design tab and next to 

the available themes. 
3. Customize your slides by choosing whether you’d like a solid, gradient, picture, 

texture or pattern fill, or whether you want to hide background graphics altogether. 
4. Get even more creative within fills by choosing color, transparency and different 

patterns such as polka dots, diagonal patterns and diamonds 
 

Question.14:-b) Write the steps for the following action for creation of power point presentation. 
 Open a Blank Presentation 

Answer:- Steps 1- Open PowerPoint and click on the files tab 2- select New option 3- Then click 
on Blank Presentation. 

 Save the presentation as Lab1.pptx 
Answer:- Steps 1- Open PowerPoint and click on the files tab 2- Select Save option 3- A new 
dialog box is open, name the file Lab1 and save as type power point presentation(pptx.)  4- 
Then click save option. 
 

 Add a Title to the first slide : the name of your college 
 Type first name and last name in the Subtitle section 

Answer:- Step 1- - Open PowerPoint and click on the files tab 2- select New option 3- Then 
click on Blank Presentation. 3- In the Title section write “VVMIC PATI”. 4- “Prashant 
Garkoti” in the subtitle section.  
 
 

Question.15:- Write steps for creation of a set of PowerPoint slides that demonstrates your skill to use the 
tools of PowerPoint. It should include the following things. 

 Title slide &bullet  
 Inserting Excel Sheet 
 Clip art and Text 
 Slide show effects 

 
Answer:-               For Title slide & bullet list 

 1-Home Tab   2-   slide        3- layout     4-  Title slide      5- bullet (home tab) 
For Inserting Excel sheet 

 1-Insert Tab           2- table        3- Excel spreadsheet 
Clip art and Text 

 1- Insert Tab      2-    clip art 
Slide show effects 

 1- Animation Tab 2- Go Animation Section.  
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Question.16 :- What is the difference between Machine Language and High level Languages? 
Answer :- The main difference between high level language and machine language is that, Programmers can 

easily understand or interpret or compile the high level language in comparison of machine. On 
the other hand, Machine can easily understand the low level language in comparison of human 
beings. 
Examples of high level languages – C, C++, Java, Python, etc. 
 

Question.17 :- Discuss about different data types of C programming Language. 
Answer :-        Data types specify how we enter data into our programs and what type of data we enter. C 

language supports 2 types of data types- 
 
 
 
 

1. Primary data types: 
These are fundamental data types in C namely integer(int), floating point(float), 
character(char) and void. 
 

2. Derived data types: 
Derived data types are nothing but primary datatypes but a little twisted or grouped 
together like array, structure, union and pointers. 
 

Question. 18 :- Find the output of the following expressions 
a. X=20/5*2+30-5 b. Y=30-(40/10+6)+10 c. 40*2/10-2+10 

 
Solution :-         a. X=33  

                  b. Y=13 
        c. Z=10. 
 

Question.19 :-  Describe the syntax of the following statements 
A. If – else statement 

Solution.  The if – else is statement is an extended version of if. The general form of if – else is as follows: 
   if ( test-expression) 
 { 
  True block of statements 
 } 
 else 
 { 
  False block of statements 
 } 
 Statements; 
B.  for loop  
Solution. A for loop is a more efficient loop structure in ‘C’ programming. The general structure 
of for loop syntax is as follows: 
 For (initial value; condition; incrementation or decrementation ) 
 { 
   Statement; 
 } 
 The initial value of the for loop is preformed only once. 
 The condition is a Boolean expression that tests and compares the counter to a fixed value 

after each iteration, stopping the for loop when false is returned.  
 The incrementation/ decrementation increases (or decreases ) the counter by a set value. 

 
C.  while loop 
Solution. A while loop is the most straightforward looping structure. Syntax of while loop in C 
programming language is as follows: 
 While (condition) 
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 { 
  Statements; 
 } 
It is an entry-controlled loop. In while loop, a condition is evaluated before processing a body of 
the loop. If a condition is true then and only then the body of a loop is executed. Once the 
condition becomes false, the control goes out of the loop. 
 
D. do-while loop 
Solution. A do-while loop in C is similar to the while loop except that the condition is always 
executed after the body of a loop. It is also called an exit-controlled loop. 
     Syntax of do-while loop in C programming language is as follows: 
 do { 
 Statements; 
       }while ( expression); 
 

Question .20 :- Find the output of the following program segments- 
 
 
 
 Solution:- 

 
 
#include<stdio.h> 
int main() 
{ 
int i; for (i=1; i<2; i++ ) 
{ 
printf(“IMS Ghazibad\n”); 
} 
} 

 
 

Output is : IMS Ghazibad 
 
 
 

 
#include<stdio.h> 
int main() 
{ 
int i=1; while ( i<=2 ) 
{ 
printf(“IMS Ghazibad\n”); 
i=i+1 
} 
} 
Output is : IMS Ghazibad 
IMS Ghazibad 
 
 
 

 
#include<stdio.h> 
void main() 
{ 
int a=10, b=100; 
if(a>b) 
printf(“Largest number is %d\n”,a); 
 
printf(“ Largest number is %d\n”,b); 
} 
} 
Output is : Largest number is 100. 
 
 

 


