
CCA-101: Fundamentals of IT & Programming 
 

Assignment -1 
 
 

Q1: What are the four fundamental parts of computer? Explain it with the help of diagram. 
The four fundamental parts of a computer are: 

1. Central Processing Unit (CPU): The CPU is the brain of the computer. It performs arithmetic, 

logical, control, and input/output operations specified by the instructions in the program. 

2. Memory: Memory, also known as RAM (Random Access Memory), stores data and instructions 

that the CPU needs during processing. It is volatile, meaning its contents are lost when the 

computer is turned off. 

3. Storage: Storage devices, such as hard drives and solid-state drives, are used to store data and 

programs permanently. Unlike memory, storage is non-volatile, meaning it retains its data even 

when the computer is turned off. 

4. Input and Output (I/O) Devices: These devices allow users to interact with the computer. 

Examples include keyboards, mice, monitors, and printers. 
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Q2: Discuss about the classification of computers based on size and capacity. 

Computers can be classified into four main categories based on size and capacity: 

1. Supercomputers: These are the most powerful and fastest computers. They are used for complex 

scientific and engineering calculations that require immense computational power. 

2. Mainframe Computers: Mainframes are large, powerful computers used by large organizations 

for critical applications like bulk data processing, transaction processing, and database 

management. 

3. Minicomputers: Minicomputers are smaller and less powerful than mainframes but more powerful 

than microcomputers. They are often used as servers for small to medium-sized businesses. 

4. Microcomputers: Also known as personal computers (PCs), microcomputers are the smallest and 

least powerful of the four categories. They are used for personal, educational, and business 

purposes. 

 

Q3: What is the meaning of computer generation? How many Computer Generations are 

defined? What technologies were/are used? 

Computer generations refer to different stages in the evolution of computers, 

characterized by advancements in technology. There are five computer generations: 

1. First Generation (1940s-1950s): Vacuum tubes were used for electronic 

components. These computers were large, expensive, and unreliable. 

2. Second Generation (1950s-1960s): Transistors replaced vacuum tubes, making 

computers smaller, faster, and more reliable. 

3. Third Generation (1960s-1970s): Integrated circuits (ICs) were introduced, further 

reducing the size and cost of computers. 

4. Fourth Generation (1970s-1980s): Microprocessors were developed, leading to the 

creation of personal computers and increasing their capabilities. 

5. Fifth Generation (1980s-Present): This generation is characterized by the use of 

artificial intelligence and parallel processing technologies. 

Q4: Differentiate between Volatile & Non- Volatile memories. 

 Volatile Memory: Volatile memory requires power to maintain the stored information. When the 

power is turned off, the data is lost. Examples include RAM (Random Access Memory). 

 Non-Volatile Memory: Non-volatile memory retains its data even when the power is turned off. 

Examples include ROM (Read-Only Memory) and storage devices like hard drives and SSDs. 

 

Q5: Distinguish among system software, application software and open-source software on the 

basis of their features. 

 System Software: System software is essential for running a computer and managing 

hardware resources. Examples include operating systems (Windows, macOS, Linux), 

device drivers, and utility programs. 

 Application Software: Application software is designed to perform specific tasks or 

applications for users. Examples include word processors, spreadsheets, and web browsers. 

 Open Source Software: Open source software is software with source code that anyone 

can inspect, modify, and enhance. It is often developed in a collaborative manner by a 

community of developers. Examples include the Linux operating system, the Firefox web 

browser, and the LibreOffice office suite. 

 



Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with 

file name “yourself”. Describe all steps involved in it. 

1. Open Microsoft Word. 

2. Click on the "File" menu. 

3. Click on "New" to create a new document. 

4. Type or paste the paragraph about yourself into the document. 

5. Click on the "File" menu again. 

6. Click on "Save As." 

7. In the "Save As" dialog box, choose a location to save the file. 

8. Enter "yourself" as the file name. 

9. Select the file format (e.g., .docx). 

10. Click "Save" to save the file. 

 

Q6 b) Write steps regarding followings 

 To change the font style 

 To change the font size 

 To change the font color 

 To highlight (in yellow) the line that reads “need to get IMS’s address”. 

 

 Steps to Change Font Style in MS Word: 

 Select the text you want to change. 

 Click on the "Home" tab in the toolbar. 

 In the "Font" group, click the drop-down arrow next to the font name. 

 Select the desired font style from the list. 

 Steps to Change Font Size in MS Word: 

 Select the text you want to change. 

 Click on the "Home" tab in the toolbar. 

 In the "Font" group, click the drop-down arrow next to the font size. 

 Select the desired font size from the list. 

 Steps to Change Font Color in MS Word: 

 Select the text you want to change. 

 Click on the "Home" tab in the toolbar. 

 In the "Font" group, click the drop-down arrow next to the font color icon. 

 Select the desired font color from the color palette. 

 Steps to Highlight Text in MS Word: 

 Select the text you want to highlight. 

 Click on the "Home" tab in the toolbar. 

 In the "Font" group, click the arrow next to the Text Highlight Color icon. 

 Select the yellow color (or any other color) from the palette. 

 

 

 

 



Q7. Create a file in MS-Word for the following document and save it with file name ‘ms_word’. 

Describe all steps involved in it. 

 

 

To create a file in MS Word: 

1. Open Microsoft Word. 

2. Type or paste the following document into the document: 

3. Click on the "File" menu. 

4. Click on "Save As." 

5. In the "Save As" dialog box, choose a location to save the file. 

6. Enter "ms_word" as the file name. 

7. Select the file format (e.g., .docx). 

8. Click "Save" to save the file. 

 

Q8. Create a file in MS-word for the following document and save it with file name ‘equations’. 

Describe all steps involved in it. 

 

 

1. Open Microsoft Word. 

2. Click on the "Insert" tab in the toolbar. 

3. Click on the "Equation" button in the "Symbols" group. 

4. Select the type of equation you want to insert (e.g., "Insert New Equation"). 

5. Use the equation tools to create your equation. 

6. Click outside the equation box to finalize it. 

7. Type or paste the following equations into the document: 

8. Click on the "File" menu. 

9. Click on "Save As." 

10. In the "Save As" dialog box, choose a location to save the file. 

11. Enter "equations" as the file name. 

12. Select the file format (e.g., .docx). 

13. Click "Save" to save the file.



Q9. Create a file in MS-word that convert existing highlight text to table as shown below and 

save it as file name ‘text_to_table’. Describe all steps involved in it. 

 

 

1. Type or paste the following text into the document and highlight it. 

2. Click on the "Insert" tab in the toolbar. 

3. Click on the "Table" button. 

4. Select "Convert Text to Table" from the dropdown menu. 

5. In the "Convert Text to Table" dialog box, ensure that "Tabs" is selected as the separator and click 

"OK". 

6. The highlighted text will be converted into a table. 

7. Click on the "File" menu. 

8. Click on "Save As". 

9. In the "Save As" dialog box, choose a location to save the file. 

10. Enter "text_to_table" as the file name. 

11. Select the file format (e.g., .docx). 

12. Click "Save" to save the file. 

 

Q10. Create a file in MS-Word to insert a table in the document. Describe all steps 

involved in it.  

1.Wherever you want the table to go, position the cursor there. 

2. To create a simple table, select Insert > Table and then drag the cursor over the grid to highlight the 

desired number of columns and rows. 

3. Select Insert > Table > Insert Table to create a bigger table or to edit an existing table. 

4. The document will insert a table with the specified number of rows and columns. 

 

By using the tab or arrow keys or by clicking on the necessary cell, you may move the pointer inside a 

table. Tables can be updated as needed after being inserted into a text. The table's columns and rows can 

be added to or eliminated. 

 

Q11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

 
 



1. Enter the data 

2. Click on the "File" menu. 

3. Click on "Save As". 

4. In the "Save As" dialog box, choose a location to save the file. 

5. Enter "book1" as the file name. 

6. Select the file format (e.g., .xlsx). 

7. Click "Save" to save the file. 

 

 

Q12. Calculate the following things of a range (C2:C11) of data in the worksheet created in 

question no 10. 

 the sum of the marks using AutoSum in a range of cells (C2:C11) 
 average of the marks in a range of cells (C2:C11) 

 highest marks in a range of cells (C2:C11) 

 minimum marks in a range of cells (C2:C11) 

 Sum of the Marks using AutoSum: 

1. Select the cell where you want the sum to appear. 

2. Click on the "Formulas" tab in the Excel ribbon. 

3. Click on the "AutoSum" button. 

4. Press Enter to apply the formula. 

Output: 654 

 Average of the Marks: 

1. Select the cell where you want the average to appear. 

2. Enter the formula =AVERAGE (C2:C11) and press Enter. 

Output:65.4 

 Highest Marks: 

1. Select the cell where you want the highest marks to appear. 

2. Enter the formula =MAX (C2:C11) and press Enter. 

Output:99 

 Minimum Marks: 

1. Select the cell where you want the minimum marks to appear. 

2. Enter the formula =MIN (C2:C11) and press Enter. 

Output:44 

 

 

  Q13 a) Describe various steps involved in the following 

 To modify column width of a worksheet 

 To modify the row height of a worksheet 

 To delete rows and 

columns of a worksheet  

 To modify column width of a worksheet 

1. Select the column or columns whose width you want to modify. You can do this by clicking on 

the column header(s). 

2. Right-click on any selected column header. 

3. In the context menu, select "Column Width." 

4. Enter the desired width in the "Column Width" dialog box. 

5. Click "OK" to apply the new width. 

 

 

 

 



 To Modify the Row Height of a Worksheet: 

1. Select the row or rows whose height you want to modify. You can do this by clicking on the row 

number(s). 

2. Right-click on any selected row header. 

3. In the context menu, select "Row Height." 

4. Enter the desired height in the "Row Height" dialog box. 

5. Click "OK" to apply the new height. 

 To Delete Rows and Columns of a Worksheet: 

To Delete Rows: 

1. Select the row or rows you want to delete. You can do this by clicking on the row number(s). 

2. Right-click on any selected row header. 

3. In the context menu, select "Delete." 

4. Choose "Delete Row" to delete the selected row(s). 

 

Q13 b) Describe following terms in the 

worksheet 

 Absolute reference and relative reference in formula 
 Cell address  
 
Absolute Reference: In a formula, an absolute reference refers to a cell or a range of cells that does 
not change when the formula is copied to other cells. It is denoted by adding a dollar sign ($) 
before the column letter and row number (e.g., $A$1). Absolute references are useful when you 
want to keep a specific cell or range constant in your calculations. 
Relative Reference: In contrast, a relative reference in a formula refers to a cell or a range of cells 
that changes based on the relative position of the formula when it is copied to other cells. For 
example, if you have a formula that refers to cell A1 and you copy it to cell B1, the reference will 
automatically adjust to B1. Relative references are useful when you want to apply the same 
calculation to different cells. 
Cell Address:A cell address in a worksheet is a combination of the column letter and row number 
that uniquely identifies a cell. Cell addresses are used in formulas and functions to perform 
calculations or retrieve data from specific cells. They can be either absolute (fixed) or relative 
(changing) references, depending on how you want the formula to behave when copied to other 
cells. 

 

 

Q14. a) What tools are available to customize our PowerPoint presentation? 

1. Themes: Choose from a variety of built-in themes to change the overall look of your 

presentation. 

2. Slide Layouts: Select different slide layouts to arrange content on your slides. 

3. Background Styles: Change the background color or apply a background style to your slides. 

4. Fonts: Choose different fonts for your text and customize the size, color, and style. 

5. Text Boxes: Insert text boxes to add text in different areas of your slides and customize their 

appearance. 

6. Shapes: Insert shapes such as rectangles, circles, arrows, and more to enhance your slides. 

7. Images and Clip Art: Insert images and clip art to make your slides more visually appealing. 

8. Charts and Graphs: Insert charts and graphs to present data in a visual format. 

9. SmartArt: Use SmartArt to create diagrams and organizational charts. 

10. Animations: Add animations to text and objects to make them appear in a dynamic way during 

the presentation. 

11. Transitions: Apply transitions between slides to add visual effects when moving from one 

slide to another. 



Q14 b) Write the steps for the following action for creation of power point presentation 

 Open a Blank presentation 

 Save the presentation as Lab1.pptxz 

 Add a Title to the first slide: the name of your college 

 Type your first name and last name in the Subtitle section 

 Add a New Slide which has a Title and Content 

 

1. Open a Blank Presentation: 

 Click on the "File" tab in the top-left corner of the window. 

 Select "New" from the menu. 

 Click on "Blank Presentation" to open a new, blank presentation. 

2. Save the Presentation as Lab1.pptxz: 

 Click on the "File" tab. 

 Select "Save As" from the menu. 

 Choose a location to save your presentation. 

 Enter "Lab1" as the file name. 

 Select the file format as ".pptxz" from the dropdown menu. 

 Click on "Save" to save the presentation. 

3. Add a Title to the First Slide: the Name of Your College: 

 Click on the first slide in the slide thumbnail pane on the left. 

 Click on the text box that says "Click to add title" and type the name of your college. 

4. Type Your First Name and Last Name in the Subtitle Section: 

 Click on the text box below the title (Subtitle). 

 Type your first name and last name. 

5. Add a New Slide with a Title and Content: 

 Click on the "Home" tab in the toolbar. 

 Click on the "New Slide" button in the Slides group. 

 Select a layout that includes a title and content. 

 In the title placeholder, type a title for the new slide. 

 In the content placeholder, type some content for the new slide. 

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to use the 

tools of PowerPoint. It should include the following things 

 Title slide &bullet list 

 Inserting Excel Sheet 

 Clip art and Text 

 Slide show effects 

 

 Title Slide & Bullet List: 

1. Open PowerPoint and select a new blank presentation. 

2. Go to the "Home" tab and click on "New Slide" to add a title slide. 

3. Enter a title and subtitle for your presentation. 

4. Click on "New Slide" again and choose a layout with a bullet list. 

5. Enter some text for the bullet points. 

 

 Inserting Excel Sheet: 

1. Open an Excel sheet with some data. 

2. Go to the "Insert" tab in PowerPoint. 

3. Click on "Object" in the Text group. 

4. In the Insert Object dialog box, select "Create from file" and browse to select your Excel file. 

5. Click "OK" to insert the Excel sheet into your slide. 



 

 Clip Art and Text: 

1. Go to the "Insert" tab and click on "Pictures" to insert clip art or images. 

2. Select the clip art or image you want to insert and click "Insert." 

3. Resize and position the clip art or image as desired. 

4. Add text boxes using the "Text Box" tool in the "Insert" tab. 

5. Enter text in the text boxes to provide additional information. 

 

 Slide Show Effects: 

1. Select a slide and go to the "Transitions" tab. 

2. Choose a transition effect from the options available. 

3. Set the speed and other options for the transition. 

4. Click on "Apply to All" to apply the same transition to all slides. 

 

 Slide Show: 

1. Click on the "Slide Show" tab. 

2. Click on "From Beginning" to start the slide show from the first slide. 

3. Use the arrow keys or mouse click to navigate through the slides. 

 

 Save and Present: 

1. Click on the "File" tab and select "Save As" to save your presentation. 

2. Choose a location and file format for your presentation and click "Save." 

3. To present your slides, click on the "Slide Show" tab and select "From Beginning." 

 

 

Part -2 

 

 

Q16. What is the difference between Machine Language and High-Level Language? 

1. Machine Language: 

 Machine language is the lowest-level programming language that is directly understood by 

a computer's hardware. 

 It consists of binary code (0s and 1s) that represents instructions and data. 

 Each instruction in machine language corresponds to a specific operation that the computer 

can perform. 

 Machine language is specific to the computer architecture, meaning that different types of 

computers have different machine languages. 

2. High-Level Language: 

 High-level languages are programming languages that are closer to human language and are 

more user-friendly. 

 They are designed to be easier to read, write, and maintain than machine language. 

 High-level languages use statements and expressions that are more abstract and closer to 

natural language, making them easier for programmers to understand. 

 Examples of high-level languages include C, C++, Java, Python, and JavaScript. 



 

Q17. Discuss about different data types of C programming Language. 

1. Integers (int): Used to store whole numbers. It can be signed (positive, negative, or zero) or 

unsigned (non-negative values only). Example: int x = 10; 

2. Floating-point (float, double, long double): Used to store real numbers (numbers with decimal 

points). float is a single-precision floating-point type, double is a double-precision floating-point 

type, and long double provides extended precision. Example: float y = 3.14; 

3. Character (char): Used to store a single character. Example: char c = 'A'; 

4. Void (void): Represents the absence of type. It is used as a return type for functions that do not 

return a value, and as a pointer type to indicate that the pointer does not point to any specific type. 

Example: void func(); 

5. Arrays ([]): Used to store a fixed-size collection of elements of the same data type. Example: int 

arr[5] = {1, 2, 3, 4, 5}; 

6. Pointers (*): Used to store memory addresses. Pointers can point to variables, arrays, or functions. 

Example: int *ptr = &x; 

7. Structures (struct): Used to group different data types together under a single name. Example: 

struct person {char name [50]; int age; }; struct person p1;  

8. Union (union): Similar to a structure, but it only allocates enough memory to hold the largest 

member. All members share the same memory location. Example: 

 

Q18. Find the output of the following expressions 

 

a)   X=20/5*2+30-5 b) Y=30 – (40/10+6) +10 c) Z= 40*2/10-2+10 

 

The outputs are: 

a) X=33 

b) Y=20 

c) Z=16 

 

 

Q19. Describe the syntax of the following statements 

 

a)   If – else statement   b) for loop c) while loop d) do-while  

a) if (condition) 

{ 

/Statement to be executed if the condition is true  

Else 

/Statement to be executed if the condition id false 

} 

 

b) for (initialization; condition; update) 

{ 

    // statements to be executed in each iteration 

} 

 

 

 

 

 



c)while (condition) { 

  statements; 

} 

 

d)do { 

 statements 

} while (expression); 

 

Q20. Find the output of the following program segments 

a) b) c) 

#include <stdio.h> 
int main() 
{ 

int i; 
for (i=1; i<2; i++) 
{ 

printf( "IMS Ghaziabad\n"); 
} 

} 

#include <stdio.h> 
int main() 
{ 

int i = 1; 
while ( i <= 2 ) 
{ 
printf( "IMS Ghaziabad\n"); 
i = i + 1; 
} 

} 

#include <stdio.h> 
void main() 
{ 

int a = 10, b=100; 
if( a > b ) 
printf( "Largest number is %d\n”, a); 
else 

printf( "Largest number is %d\n”, b); 
} 

 

   IMS Ghaziabad IMS Ghaziabad 
IMS Ghaziabad 

Largest number is 100 

 
 

 

 



 


