
CCA-101: Fundamentals of IT & Programming 

 

Assignment -1 
Q1: What are the four fundamental parts of computer? Explain it with the help of diagram. 

ANS. 

 
 Computer Block Diagram 
Mainly computer system consists of three parts, that are central processing unit 
(CPU), Input Devices, and Output Devices. The Central Processing Unit (CPU) is 
divided into two parts again: arithmetic logic unit (ALU) and the control unit (CU). The set 
of instruction is in the form of raw data. 
 

    

The data is entered through input devices such as the keyboard, mouse, etc. This set of 
instruction is processed by the CPU after getting the input by the user, and then the 
computer system produces the output. The computer can show the output with the help 
of output devices to the user, such as  monitor, printer, etc. 

 CPU (Central Processing Unit) 

 Storage Unit 

 ALU(Arithmetic Logic Unit) 

 Control Unit 

Central Processing Unit (CPU) 

https://www.tutorialandexample.com/input-devices-of-computer/
https://www.tutorialandexample.com/output-devices-of-computer/


The computer system is nothing without the Central processing Unit so, it is also known 
as the brain or heat of computer. The CPU is an electronic hardware device which can 
perform different types of operations such as arithmetic and logical operation. 
The CPU contains two parts: the arithmetic logic unit and control unit. We have 
discussed briefly the arithmetic unit, logical unit, and control unit which are given below: 
Control Unit 
The control unit (CU) controls all the activities or operations which are performed inside 
the computer system. It receives instructions or information directly from the main 
memory of the computer. 
When the control unit receives an instruction set or information, it converts the 
instruction set to control signals then; these signals are sent to the central processor for 
further processing. The control unit understands which operation to execute, accurately, 
and in which order 
 

Arithmetic and Logical Unit 
The arithmetic and logical unit is the combinational digital electronic circuit that can 
perform arithmetic operations on integer binary numbers.It presents the arithmetic and 
logical operation. The outputs of ALU will change asynchronously in response to the 
input. The basic arithmetic and bitwise logic functions are supported by ALU. 
Storage Unit 
The information or set of guidelines are stored in the storage unit of the computer 
system. The storage unit provides the space to store the data or instruction of processed 
data. The information or data is saved or hold in computer memory or storage device. 
The data storage is the core function and fundamental of the computer components.   

 
Components of Computer System 
The hardware and software exist on the computer.  The information which is stored 
through the device is known as computer software. The hardware components of the 
computer system are related to electronic and mechanical parts, and the software 
component is related to data and computer programs. Many elements are connected to 
the main circuit board of the computer system called a “motherboard.” 

https://en.wikipedia.org/wiki/Central_processing_unit


  

 

 Processor. 

 Main Memory. 

 Secondary Memory. 

 Input Devices. 

 Output Devices. 
 These are mainly five components of the computer system. The computer 

hardware, computer software, and liveware exist in the element of the computer 
system. 

 Processor 
 The processor is an electric circuitry within the computer system. The Central 

processing unit is the central processor or main processor of the computer 
system. The processor carries out the instructions of the computer program with 
the help of basic arithmetic and logic, input/output operations. 

 Main Memory   
 The Random Access Memory is the main memory of the computer system, which 

is known as RAM.  The main memory can store the operating system software, 
application software, and other information.  The Ram is one of the fastest 
memory, and it allows the data to be readable and writeable. 

 Secondary memory 
  We can store the data and programs on a long-term basis in the secondary 

memory. The hard disks and the optical disks are the common secondary 
devices. It is slow and cheap memory as compare to primary memory. This 
memory is not connected to the processor directly. 

 It has a large capacity to store the data. The hard disk has a capacity of 500 
gigabytes. The data and programs on the hard disk are organized into files, and 



the file is the collection of data on the disk. The secondary storage is direct 
access by the CPU; that’s why it is different from the primary storage. 

The hard disk is about 100 times the capacity of the main memory. The main difference 
between primary and secondary storage is speed and capacity. There are several large 
blocks of data which are copied from the hard disk into the main memory. 
Input Devices 
The user provides the set of instruction or information to the computer system with the 
help of input devices such as the keyboard, mouse, scanner, etc. The data 
representation to the computer system is in the form of binary language after that the 
processor processes the converted data. The input unit implements the data which is 
instructed by the user to the system. 
We can enter the data from the outside world into the primary storage as the input 
through input devices. The input devices are the medium of communication between the 
outside world and the computer system. There are some important features of input 
devices which are given below: 

1. The input devices receive or accept the data or instruction from the user, who exist in the 

outside world. 

2. These devices convert the data or instruction into the machine-readable form for further 

processing. 

3. The input device performs like the connection between the outside world and our 

computer system. 

4. The keyboard and mouse are common examples of input devices. 

5. When the whole procedure is finished, we get the desired output from the output devices 

such as monitor, printer, etc. 
Output Devices 
The output devices produce or generate the desired result according to our input, such 
as a printer, monitor, etc. These devices convert the data into a human-readable form 
from binary code. 
The computer system is linked or connected to the outside world with the help of output 
devices. The primary examples of output devices are a printer, projector, etc. These 
devices have various features which are given below: 

1. These devices receive or accept the data in the binary form. 

2. The output devices convert the binary code into the human-readable form. 

These devices produce the converted result and show to the user. 

Q2: Discuss about the classification of computers based on size and capacity. 

ANS.  
Introduction 

Classification of computers are based on their architecture, speed of executing commands or 

instructions, peripheral used and also their uses. Microcomputers are usually used in home and 

offices and only a single user can perform the task using a microcomputer. Its storage and data 

handling capacity are limited as per the requirement for home and office work. The another type of 

computer is called minicomputer which has usually larger storage and can handle multiuser at a 

time. This chapter includes the classification of computers. 

 



Computer's Classification 

Computers are classified on different parameters, such as, storage capacity, processing speed 
and component (CPU) used in computers. Depending upon the components used and features 
of different computers, they are classified into four groups, Microcomputers, Minicomputers, 
Mainframe computers and Supercomputers. 

   

Micro Computers 

Micro Computer is a computer whose CPU (Central Processing Unit) is a microprocessor. All the 

components of a microprocessor are on a single integrated circuit chip. Micro computer can be 

categorized as the desktop, programmable and workstation. The microprocessor based 

computers are called third generation computers. They are the backbone of the modern 

computer era. The first and second generation computers are based on vacuum tubes and 

bipolar junction transistors. 

 

Desktop Computers 

Desktop computer is a type of microcomputer. A desktop computer has a keyboard for input 

data, a LCD or CRT monitor to display information and Central processing unit tower contains 

storage, memory, different types of drives, such as, CD drive, hard drive, etc. A desktop 

computer is mainly used at home and office applications. 

  

Programmable Computers (PDA) 

Personal digital assistance is a type of hand held programmable digital computer. It is used as 

notepads, address books and can connect to world web wave to share information. A PDA is 

equipped with mobile phone hence, called smallest computer. 

  

  



Workstation 

A workstation computer has greater memory capability and more extensive mathematical 

abilities. It is connected with other workstation computers or personal computer to exchange data 

and mostly used for scientific applications. It also supports multitasking applications. 

  

Mini Computers 

Minicomputers were introduced in early 1960s. They were faster than micro computers. Basically 

these computers were mainly multi-user systems, where many users work on the systems. 

Generally these types of computers had larger memories and greater storage capacity. They had 

large instruction set and address field. These kinds of computers have efficient storage for 

handling of text, in comparison to lower bit machines. Due to more efficient processor, speed and 

memory size, minicomputer was used in variety of applications and could support business 

applications along with the scientific applications. Minicomputer was a multi-user system which 

means more than one user could use this system simultaneously. 

Comparison of Micro and Mini computers 

  

Features Microcomputer Minicomputer 

Primary memory  Shall memory Larger memory 

Word length  Small word length  Larger word length 

Cost low Low High 

Processor Low High 

Mainframe Computers 

Mainframe computers are large and expensive machines. The word length of mainframe 

computers may be 48, 60 or 64 bits, memory capacity being in some megabytes and storage 

capacity in some terabytes. Generally they handle huge volumes of information and data. In 

terms of speed, they are having significant processing capacity. They are used in research 

organizations, large industries, airlines reservation where a large database has to be maintained. 

 



Super Computers 

Super Computers are the fastest computer in current era. The processing capabilities of super 

computer lies in the range of GIPS2, word length 64-128 or may be in 256 or so. The memory 

capacity of super computer is in some gigabytes or in terabytes. The storage capacity of this type 

of computer is in exabytes. 

 

The parallel processing of a super computer makes it very fast because it contains number of 

CPU that operates parallel. They are used at some research centers and government agencies 

involving sophisticated scientific and engineering tasks. 

  

Super computers are used for the followings: 

  

  Weapons research and development 

  Nuclear and plasma physics 

  Rocket research and development 

  Atomic research 

  Aerodynamics 

Units For Measuring Word Length, Data, And Storage Capacity of a Computer 



Computers are classified on the basis of their data processing speed better known as clock 

speed and the word length. The word length that is processed by a CUP at a time is one of the 

important feature of that CPU. 

  

The followings are the units for the measurement of data volume: 

  

bit bit 0 or 1 

Byte B 8 bite 

Kibibit Kibit 1024 bits 

kilobit Kbit 1000 bits 

kibibyte (binary) KiB 1024 bytes 

kilobyte (decimal) kB 1000 bytes 

megabit Mbit 1000 kilobits 

mebibyte (binary) MiB 1024 kibibytes 

megabyte (decimal) MB 1000 kilobytes 

gigabit Gbit 1000 megabits 

gibibyte (binary) Gibbs 1024 mebibytes 

gigabyte (decimal) GB 1000 megabytes 

terabit Tbit 1000 gigabits 

tebibyte (binary) TIB 1024 gibibytes 

terabyte (decimal) TB 1000 gigabyte 

Petabit Pbit 1000 terabyte  

pebibyte (binary) PiB 1024 tebibytes 

petabyte (decimal) PB 1000 terabytes 

exabit Ebit 1000 petabits 

exbibyte (binary) EiB 1024 pebibytes 

exabyte (decimal) EB 1000 petabytes 

Q3: What is the meaning of computer generation? How many Computer Generations are 

defined? What technologies were/are used? 

ANS. Generation in computer terminology is a change in technology a computer 
is/was being used. Initially, the generation term was used to distinguish between 
varying hardware technologies. Nowadays, generation includes both hardware and 
software, which together make up an entire computer system. 

There are five computer generations known till date. Each generation has been 
discussed in detail along with their time period and characteristics. In the following 
table, approximate dates against each generation has been mentioned, which are 
normally accepted. 

Following are the main five generations of computers. 

S.No Generation & Description 



1 
First Generation 

The period of first generation: 1946-1959. Vacuum tube based. 

2 
Second Generation 

The period of second generation: 1959-1965. Transistor based. 

3 
Third Generation 

The period of third generation: 1965-1971. Integrated Circuit based. 

4 
Fourth Generation 

The period of fourth generation: 1971-1980. VLSI microprocessor based. 

5 

Fifth Generation 

The period of fifth generation: 1980-onwards. ULSI microprocessor 
based. 

First Generation of the computer invented between the years 1940 to 

1956. During the Second World War different countries had started 

developing computer to work fast.  

The First generation electronic computer Mark – 1 and other of this time were 

made possible by the invention of Vacuum Tubes which was the triangle glass 

device that could control and amplify electronic signals. 

First generation computers were very large in size, they needed room to keep 

them. 

Those vacuum tubes computers are effort as First Generation of the 

computer.  
 

https://www.tutorialspoint.com/computer_fundamentals/computer_first_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_second_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_third_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_fourth_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_fifth_generation.htm


 

Vacuum Tube 

Advantage of First Generation 
The Some Feature & Characteristics of First Generation. 

Second Generation of Computer ( 1956 - 

1963 ) 
The second generation of the computer invented in the year between 1956 

to 1963 is said to the second-generation computer. 

The second generation of computer was manufactured in using 

a Transistor instead of vacuum tubes. 

The second generations of computer were more powerful, more reliable, and 

less expensive smaller true operated then the first-generation computer. 

The memory of the second generation computer was compared to magnetic 

core. 

Magnetic disk and magnetic tape were the main memory storage media used 

in secondary memory.   

The Transistors were smaller than the vacuum tube, and the Transistors were 

much faster than the vacuum tube in speed. 



The computers used batch processing and multi programming operating 

system. 

 

Third Generation of Computer ( 1964 - 

1971 ) 
Third generation of computer advantage in electronic technology 

communicated and advantage of microelectronics technology may it possible 

to an integrated a large number of circuits elements into the very small surface 

of silicon known as a chip.  

This new technology was called the Integrated Circuit (IC).  

The third generation was test integrated technology and the computer than 

designed with the use of an integrated circuit where called the 

third generation of computer. 

The third generation computer is smaller in size than the second generation of 

computer, and faster than the second generation compared to the speed.  

Integrated circuits are also used in today's computers. 

Integrated circuits ( IC ) was invented by Robert Noyce and Jack Kilby 

Scientist. 

https://www.geeksforgeeks.org/generations-of-computer/


 

Fourth Generation of Computer ( 1972 - 

2010 ) 
Initially, the integrated circuit contained only about 10 to 20 components this 

technology was named small scale integrated (SSI). Latter with an advantage in 

technology for manufacturing Integrated Circuit ( I.C ).  

It becomes possible to integrate up to a hundred components into a single 

chip. This technology can be known as Medium-scale integrated (M.S.I).  

Then the come era of large scale integrated than it was possible to integrate 

over 5000 comments in a single chip. 

It is accepted that more than one million components will be integrated or a 

single chip knows as very large scale integration (VLSI) technology. 

Fourth generation computers became more powerful and smaller in size and 

cheaper with the use of microprocessors. 

The computer speed of this generation is much faster than the first, second 

and third generation computers. 

In a Microprocessor, many transistors, resistors, and diodes work together. 

This generation used  time-sharing, real-time networks, distributed operating 

system. 

This Generation of a computer used high level language like - c, c++, java and 

DBASE and etc. 



 

Fifth Generation of Computer ( 2010 - 

Present ) 
Fifth Generation of computer is based on Artificial Intelligence. This 

generation uses Ultra Large Scale Integration ( ULSI ) technology. It is used 

to make the microprocessor chip. 

This chip contains ten million electronic components. Use of this technology 

will also be in the future, and this technology will be updated from time to 

time. 

This technology works on a parallel processing system, Google search 

engine also uses this technology. This Generation of a computer used high 

level language like - c, c++, java and .Net and etc. 

This Generation made than a very useful of multimedia applications (Text, 

graphics, audio, video and animation).  

Includes the various terms in artificial intelligence which are given below: 

1. Robotics. 

2. Neural Networks. 

3. Game playing. 

4. Natural language processing. 

5. Develop the expert system to decide a real-life situation. 



 
 

 

Q4: Differentiate between Volatile & Non- Volatile memories. 

ANS. Difference between Volatile Memory and Non-Volatile Memory 

Volatile and Non-Volatile Memory are both types of computer memory. Volatile 
Memory is used to store computer programs and data that CPU needs in real time 
and is erased once computer is switched off. RAM and Cache memory are volatile 
memory. Where as Non-volatile memory is static and remains in the computer even 
if computer is switched off. ROM and HDD are non-volatile memory. 

Following are the important differences between Volatile and Non-Volatile Memory. 

Sr. 
No. 

Key Volatile Memory Non-Volatile Memory 

1 
Data 
Retention 

Data is present till power 
supply is present. 

Data remains even after power 
supply is not present. 

2 
Persistence Volatile memory data is 

not permanent. 
Non-volatile memory data is 
permanent. 

3 
Speed Volatile memory is faster 

than non-volatile memory. 
Non-volatile memory access is 
slower. 



Sr. 
No. 

Key Volatile Memory Non-Volatile Memory 

4 
Example RAM is an example of 

Volatile Memory. 
ROM is an example of Non-
Volatile Memory. 

5 
Data 
Transfer 

Data Transfer is easy in 
Volatile Memory. 

Data Transfer is difficult in Non-
Volatile Memory. 

6 

CPU 
Access 

CPU can access data 
stored on Volatile 
memory. 

Data to be copied from Non-
Volatile memory to Volatile 
memory so that CPU can 
access its data. 

7 
Storage Volatile memory less 

storage capacity. 
Non-Volatile memory like HDD 
has very high storage capacity. 

8 
Impact Volatile memory such as 

RAM is high impact on 
system's performance. 

Non-volatile memory has no 
impact on system's 
performance. 

9 
Cost Volatile memory is costly 

per unit size. 
Non-volatile memory is cheap 
per unit size. 

 

Q5: Distinguish among system software, application software and open source 

software on the 

basis of their features. 

ANS.  Difference between System software and Application 

software. 

As we know that software is a set of instructions or programs instructing a computer 
to do specific tasks. Software is basically a generic term used to describe computer 
programs. In general Scripts, applications, programs and a set of instructions are all 
terms often used to describe software. 

Now the basis of language in which software is developed and platform which is 
required for its execution we can classified software as in two divisions which are 



System software and Application software. Following are some basic differences 
between System software and Application software. 

Sr. 
No. 

Key System Software. Application Software. 

1 

Definition System Software is the type 
of software which is the 
interface between 
application software and 
system. 

On other hand Application 
Software is the type of 
software which runs as per 
user request. It runs on the 
platform which is provide by 
system software. 

2 

Development 
Language 

In general System software 
are developed in low level 
language which is more 
compatible with the system 
hardware in order to interact 
with. 

While in case of Application 
software high level language 
is used for their development 
as they are developed as 
some specific purpose 
software. 

3 
Usage System software is used for 

operating computer 
hardware. 

On other hand Application 
software is used by user to 
perform specific task. 

4 

Installation System software are 
installed on the computer 
when operating system is 
installed. 

On other hand Application 
software are installed 
according to user’s 
requirements. 

5 

User 
interaction 

As mentioned in above 
points system software are 
specific to system hardware 
so less or no user 
interaction available in case 
of system software. 

On other hand in application 
software user can interacts 
with it as user interface is 
available in this case. 

6 

Dependency System software can run 
independently. It provides 
platform for running 
application software. 

On other hand in application 
software can’t run 
independently. They can’t 
run without the presence of 
system software.. 



Sr. 
No. 

Key System Software. Application Software. 

7 

Examples Some examples of system 
software’s are compiler, 
assembler, debugger, 
driver, etc. 

On other hand some 
examples of application 
software’s are word 
processor, web browser, 
media player, etc. 

 

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it 

with file name 

“yourself”. Describe all steps involved in it. 

ANS. Q6. a) Create a file in MS-word to insert a paragraph about yourself 

and save it with file name 

Ans. 

“yourself”. Describe all steps involved in it. 

Chapter 1. Creating, Opening, and Saving Documents 

When you start Word without opening an existing document, the 

program gives you an empty one to work in. If you’re eager to put words 

to page, then type away. Sooner or later, though, you’ll want to 

start another new document. Word gives you three ways to do so: 



 

Instead of the usual Open button at the bottom of the box, the 

button in the New from Existing Document box reads Create 

New—your clue that this box behaves differently in one important 

respect: Instead of opening an existing file, you’re making a copy of 

an existing file. Once open, the file’s name is something 

 

like Document2.docx instead of the original name. This way, when 

you save the file, you don’t overwrite the original document. (Still, 

it’s best to save it with a new descriptive name right away.) 



 

The Open box goes away and your document opens in Word. 

You’re all set to get to work. Just remember, when you save this 

document (Alt+F, S or Ctrl+S), you write over the previous file. 

Essentially, you create a new, improved, and only copy of the file 

you just opened. If you don’t want to write over the existing 

document, use the Save As command (Alt+F, A), and then type a 

new name in the File Name text box. 

 

To change the font size of selected text in desktop Excel, PowerPoint, or 



Word: 

Select the text or cells with text you want to change. To select all text in 

a Word document, press Ctrl + A. 

On the Home tab, click the font size in the Font Size box. 

 

Change the font color 

 
You can change the color of text in your Word document. 

1. Select the text that you want to change. 

2. On the Home tab, in the Font group, choose the arrow next 

to Font Color, and then select a color. 

 
Q7. Create a file in MS-Word for the following document and save it with file 

name ‘ms_word’. Describe all steps involved in it.  
 

ANS. 

Create a document 

1. On the File tab, click New. 

2. In the Search for online templates box, enter the 

type of document you want to create and press 

ENTER. 



 

 

Editing 

Word provides many options to customize the process of editing documents. There are 

several views 

and tools in Word that allow you to make and see changes to your document in a preferable 

method. 

The following Editing articles will also explain how to utilize the Review tab of the ribbon, 

which is 

crucial to personalizing the editing process in Word. 

 

 

Q8. Create a file in MS-word for the following document and save it with file 

name ‘equations’. Describe 

all steps involved in it. 

 

ANS. 

Insert Equations in Word: Overview 

            This lesson shows you how to insert equations in Word within a document. This 

lesson 

covers inserting a preset equation and also manually entering an equation. 

            To insert equations in Word from one of the preset equations, first place your cursor 

at 

the insertion point in your document where you want the equation to appear. Then click the 

 

“Insert” tab in the Ribbon. At the right end of the tab is the “Symbols” button group. Click 

the 

drop-down arrow on the “Equation” button in this button group to then open the menu of 



Q9. Create a file in MS-word that convert existing highlight text to table as 

shown below and save it as file name ‘text_to_table’. Describe all steps 

involved in it. 

 

ANS. 

 

Convert text to a table or a table to text 
 
 

To convert text to a table or a table to text, start by clicking 

the Show/Hide paragraph mark on the Home tab so you can 

see how text is separated in your document. 

 

Convert text to a table 

1. Insert separator characters—such as commas or tabs—to indicate where to 

divide the text into table columns. 

2. Use paragraph marks to indicate where you want to begin a new table row. 

3. In this example, the tabs and paragraph marks will produce a table with 3 

columns and 2 rows: 

 

Select the text that you want to convert, and then click Insert &gt; Table &gt; Convert Text to 

Table. 

 

In the Convert Text to Table box, choose the options you want. 



 

 

Under Table size, make sure the numbers match the numbers of columns and rows 

you want. 

Under AutoFit behavior, choose how you want your table to look. Word 

automatically chooses a width for the table columns. If you want a different column 

width, choose one of these options: 

 

1. Under Separate text at, choose the separator character you used in the text. 

2. Click OK. The text converted to a table should look something like this: 

 

 

Q10. Create a file in MS-Word to insert a table in the document. 

Describe all steps involved in it. 

 

ANS.  

 

he basic steps for creating a standard table in Microsoft Word (2013) are: 

1. Open a blank Word document 

2. In the top ribbon, press Insert 



 

4. Either use the diagram to select the number of columns and rows you need, or click Insert 

Table and a dialog box will appear where you can specify the number of columns and rows. 

 

5. The blank table will now appear on the page. Alter it as necessary. Standard features 

like bold, italics, and underline are still available! These items may be helpful for creating 

headings or calling out certain items in the table. 

6. Follow these instructions for ensuring your table meets APA formatting guidelines. 

 

 

Need additional help? The tutoring service has self-paced table and chart 

lessons/tutorials within 



SkillSurfer. Follow these steps to access: 

1. Log into the tutoring service (click on the blue hyperlink to the left to login!) 

2. Click on SkillSurfer 

3. Click on Computers and Technology 

4. Click on Intermediate underneath Microsoft Word 

5. Select Creating Tables and Charts 

6. Choose the exact item(s) you wish to learn about (likely Creating Tables from 

Scratch). 

 

 

Q11. Create a following worksheet in MS-excel and save it 

with name ‘book1L; 

 

Save a worksheet 

 
When you have multiple worksheets in an Excel workbook, you might want to 

save only one worksheet as its own workbook. Use the Move or Copy function 

to save one worksheet in Excel 2013 or Excel 2016. 

 

Save a single worksheet 

1. Right-click the worksheet name tab. 

 

2. Click select Move or Copy. 



 

3. Click on the Move selected sheets to Book drop-down menu. Select (new book). 

 

4. Click OK. Your new workbook opens with your moved worksheet. 

 



 

5. Click File >Save in your new workbook. 

 

Q12. Calculate the following things of a range (C2:C11) of 

data in the worksheet created in question no 

 

ANS. 

1. the sum of the marks using AutoSum in a range of cells (C2:C11) 

 

The SUM function adds values. You can add individual values, cell 

references or ranges or a mix of all three. 

 

=SUM(A2:A10) Adds the values in cells A2:10 

 

2. average of the marks in a range of cells (C2:C11) 
 

 Returns the average (arithmetic mean) of the arguments. For example, if 

the range A1:A20 contains numbers, the 

formula =AVERAGE(A1:A20) returns the average of those numbers 

 

4. highest marks in a range of cells (C2:C11) 

5.  
MAX will return the largest value in a given list of arguments. From a given 

set of numeric values, it will return the highest value. Unlike MAXA function, 



the MAX function will count numbers but ignore empty cells, text, the logical 

values TRUE and FALSE, and text values. 

 

=MAX(number1, [number2], …) 

4. minimum marks in a range of cells (C2:C11) 

 
The Microsoft Excel MIN function returns the smallest value from the 

numbers provided. 

 

 
 

 

Q13 a) Describe various steps involved in the 

Following 

ANS. 

1. To modify column width of a worksheet 
 

If you find yourself needing to expand or reduce Excel&#39;s row 

widths and column heights, 

there are several ways to adjust them. The table below shows the 

minimum, maximum and 

default sizes for each based on a point scale. 

 

2. To modify the row height of a worksheet 
If you find yourself needing to expand or reduce Excel&#39;s row 

widths and column heights, 

there are several ways to adjust them. The table below shows the 

minimum, maximum and 

default sizes for each based on a point scale. 

 

3. To delete rows and columns of a worksheet 

 



Insert or delete a column 

1. Select any cell within the column, then go to Home 

> Insert >Insert 

Sheet Columns or Delete Sheet Columns. 

2. Alternatively, right-click the top of the column, and then 

select Insert or Delete.  

 

Insert or delete a row 

1. Select any cell within the row, then go to Home > Insert > Insert 

Sheet Rows or Delete Sheet Rows. 

2. Alternatively, right-click the row number, and then 

select Insert or Delete. 

 

Q13 b) Describe following terms in the 

Worksheet 
 

ANS. 

1. Absolute reference and relative reference in 

formula 

 

Relative references 

 

By default, all cell references are relative references. When copied across 

multiple cells, they change based on the relative position of rows and 

columns. For example, if you copy the formula =A1+B1 from row 1 to 

row 2, 

the formula will become =A2+B2. Relative references are especially 

convenient whenever you need to repeat the same calculation across 

multiple rows or columns. 

 

2. Cell address 
What is the Cell ADDRESS Function? 



 
The cell ADDRESS function is categorized under Excel Lookup and Reference 

functions. It will provide a cell reference (its “address”) by taking the row number 

and column letter. The cell reference will be provided as a string of text. The 

function can return an address in a relative or absolute format and can be used to 

construct a cell reference inside a formula. 

 

As a financial analyst, cell ADDRESS can be used to convert a column number to a 

letter, or vice versa. We can use the function to address the first cell or last cell in 

a range. 

  

Formula 

 

=ADDRESS(row_num, column_num, [abs_num], [a1], [sheet_text] 

 

Q14. a) What tools are available to customize our PowerPoint 

presentation? 

 

ANS. 

Customize presentation options and views 
 

Changing page setup options 

Presentations are created mainly to project either on a projector or more and more 

frequently to a plasma or TV screen. There are times when a presentation can be 

created for delivery in different formats. 

 

·         On-screen show (4:3) 

·         Letter Paper (8.5 x 11 in) 

·         Ledger Paper (11 x 17 in) 

·         A3 Paper (297 x 420 mm) 

·         A4 Paper (210 x 297 mm) 

·         B4 (ISO) Paper (250 x 353 mm) 

·         B5 (ISO) Paper (176 x 250 mm) 

·         35mm Slides 

·         Overhead 

·         Banner 

·         On-screen Show (16:9) 

·         On-screen Show (16:10) 

·         Widescreen 

·         Custom 



 

  

To select a slide size other than the standard one: 

 

1. In Slide Master View 

2. Click on Slide Size 

3. Select from one of the two options 

4. For more choices, click Custom 

5. Select one of the options 

 
Figure 89- standard or widescreen   

  
 

Figure 90 – other options 

If you change the orientation to Portrait for 

the presentation it will apply to all the 

slides. 

 

Changing to view in color/grayscale 
Why change to view the presentation in grayscale? You might want to print the 

presentation and to print in colour is more expensive than printing to greyscale, so 

you need to see what the presentation looks like in grayscale before you print. 



 
 

Figure 91- colour/grayscale options 

 

On the View Ribbon, click on the option you want, Colour, Grayscale or Black and 

White. 

 

Then from the Grayscale Ribbon select the option you want to see: 

 

 

Figure 92- grayscale options 

 

To get back to the colour view, click Back to Colour View. 

 

Navigating using presentation views 
 

There are several different views in PowerPoint as we saw earlier and you can 

navigate through the presentation in each in different ways. 

 

In Normal View 

 Click on the thumbnail of the slide you want to see 

 Use the Vertical Scrollbar to move between slides 

 Use the up and down arrow keys on the keyboard to move one slide backwards or 

forwards 

 

In Slide Sorter View 

 Click on the slide you want to select 

 Use the arrow keys to move up, down, left and right 



In Reading View 

Use the next and back icons in the status bar to move back or forwards or use the 

menu which is accessed from the icon in the middle 

Figure 94 – icons 

 

Back and Next icons move between slides. 

 
 

Figure 93- reading view 

 

 

Pick from the menu – you can use Go to 

Slide to pick the slide number 

  

In Slide Show view 

When presenting you can use the mouse or the arrows on the keyboard to move 

through the presentation one slide at a time. 

 

You can also type the number of the slide you want to see and press Enter. 

 

When you hover the mouse over the bottom left corner of the slide on display you 

will notice some faint icons, there is a back arrow and forward arrow which move you 

through one slide at a time. 



 

 

Figure 95- slide show icons 

 

Use the fourth icon along to show the slides in a presentation view of Slide Sorter 

View. This lays the slides on the screen and you can click on the one you want to 

See 

 

 

Figure 96- Slide Sorter in presentation view 

 

Use the back arrow at the top left to get back to the slide you started from. 

 

To end the slide show, press the Escape Key on the keyboard – this takes you back 

to PowerPoint in the edit mode which means that your audience will see the back 

end of your presentation. 

 

You can also use the End Presentation option which is on the small ellipse icon on 

the bottom left of the slide when you hover the mouse. 



Q14 b) Write the steps for the following action for creation of 

power point presentation 

ANS. 

1. Open a Blank presentation 

 

To create a new presentation: 
 

When beginning a new project in PowerPoint, you&#39;ll often 

want to start 

with a new blank presentation 

. 

1. Select the File tab to go to Backstage view. 

 

2. Select New on the left side of the window, then click Blank 

Presentation. 



 
 

3. A new presentation will appear. 

To create a new presentation from a template: 

 
A template is a predesigned presentation you can use to create a new 

slide show quickly. Templates often include custom 

formatting and designs, so they can save you a lot of time and effort 

when starting a new project. 

1. Click the File tab to access Backstage view, then select New. 

2. You can click a suggested search to find templates or use 

the search bar to find something more specific. In our 

example, we&#39;ll search for the keyword chalkboard. 



 

3. Select a template to review it. 

 

 

 



1. A preview of the template will appear, along with additional 

information on how the template can be used. 

 

2. 

Click Crea

te to use 

the 

selected 

template. 

 

3. A new presentation will appear with the selected template. 

 

It’s important to note that not all templates are created by Microsoft. 

Many are created by third-party providers and even individual users, so 

some templates may work better than others. 

 

To open an existing presentation: 

In addition to creating new presentations, you’ll often need to open a 

presentation that was previously saved. To learn more about saving 

presentations, visit our lesson on Saving Presentations. 

1. Select the File tab to go to Backstage view, then click Open. 

 



2. Click Browse. Alternatively, you can choose OneDrive to 

open files stored on your OneDrive. 

 

3. The Open dialog box will appear. Locate and select 

your presentation, then click Open. 

 

 

 

2. Save the presentation as Lab1.pptx 



ANS. 

 One of the most basic tasks in PowerPoint is being able to save your work; 

 this is probably the most important task as well. There are many users who 

 have burnt their fingers for not saving their work in time and losing hours 

of 

 hard work. The following are the basic steps to save a presentation. 

 Step 1 − Click on the File tab to launch the Backstage view and 

select Save.  

 
Step 2 − In the Save As dialog, type in the file name and click “Save” 



 
 

Step 3 − The default file format is .pptx. If you want to save the file with a 

different name, 

choose one of the file types from the “Save as type” dropdown list. 

 
 

If you are working on an already saved file, the “Save” option in 

the Backstage view will 

directly save the file in the existing format with the existing name. If you want to 

change the 

format or filename of an existing file, use the Save As option instead. 



 

3. Add a Title to the first slide: the name of your 

college 
Ans. 

 

1. Open a Blank presentation 

2. Save the presentation as PowerPointLabOne.pptx 

3. Add a Title to the first slide: the name of your college 

4. Type your first name and last name in the Subtitle section 

5. Add a New Slide which has a Title and Content 

6. Add a title to the second slide “My Future Goals” 

 

7. In the Content section of the second slide, add at least three Personal Goals 

 

8. Right click on the second slide from the left panel, then choose Duplicate Slide 

9. Highlight the text in the Content area of the third slide. Under the Home tab, 

click Convert to SmartArt, then choose Basic Cycle 

10. Change the SmartArt Colors to Colorful—Accent Colors 

11. Change the SmartArt Styles to 3D Polished 

12. From the left panel, drag the third slide between the first and second slide 

13. Change the layout of the third slide, the slide that does not have the 

SmartArt, 

to Comparison 

14. Leave the title “My Future Goals” 



15. In the head of the first column, type “Goals in College,” then center the 

heading 

16. In the head of the second column, type “Goals after College,” then center 

the heading 

 

17. Add at least three goals in each section 

18. Make sure that slide #3 is selected from the left panel, then add a New Slide 

19. Change the layout of the new slide to Blank 

20. Insert a Graduation Online Picture from the Office ClipArt—Choose any 

image of your 

choice 

21. Change the ClipArt size to 3” X 3” and position it in the middle of the slide 

22. Apply the Wisp Design Theme 

23. Save and upload PowerPointLabOne.pptx to your instructor 

 

5. Add a New Slide which has a Title and 

Content 
 

ANS. Insert a New Slide in PowerPoint: Overview 
In this tutorial, you will learn how to insert a new slide in PowerPoint. When you 

create a new presentation, PowerPoint gives you one default slide that contains a “Title 

Slide” layout. You can click into the placeholders shown in the title slide. Then type the 

text 

you want to appear as the title and subtitle of your presentation. 

 

To add another presentation slide, you must then insert a new slide and determine 

which placeholders appear in it. The slide layout you apply determines which 

placeholders 

appear within the new slide. However, you can also change the slide layout to change the 

placeholders after it is applied. 

 

To insert a new slide in PowerPoint with a “Title and Content” slide layout, click the 

“Home” tab in the Ribbon. Then click the “New Slide” button in the “Slides” button group. 

 

To insert a new slide in PowerPoint with a different slide layout, click the drop-down 



 
 
Q15. Write steps for creation of a set of PowerPoint slides that demonstrates 

your skill to usethe tools of PowerPoint. It should include the following 

things 

   A) Title slide &amp;bullet list 

ANS. 

Title a slide 
There are multiple way to add titles to your slides in PowerPoint. Use 

the Layout option to create a standalone title slide or to add a title to a slide 

that contains other text. You can also use the Outline view to create and 

update the titles of your slides 

 

Show each bullet point with a click 

1. Select the text box that contains the slides you want 

to animate. 

 



 

2. Click the Animations tab, and then choose a motion 

effect like Appear or Fly In. 

 

 

3. The slide displays the animation sequence in a box to 

the left of each point. 

 

 

Show each bullet point after a delay 

 

1. Select all the bullet points you want to animate, click 

the Animations tab, and then choose a motion effect 



like Appear or Dissolve In. 

 
 2.  In the Animations pane, select the second animation in the list. 

 
3. Under Timing, change the Start setting to After Previous, and then 

enter the amount of time you want to delay between each bullet 

point. 

 

B) Inserting Excel Sheet 

Ans. Insert an object in your Excel spreadsheet 

 

You can use Object Linking and Embedding (OLE) to 



include content from other programs, such as Word 

or Excel. 

 

OLE is supported by many different programs, and 

OLE is used to make content that is created in one 

program available in another program. For example, 

you can insert an Office Word document in an Office 

Excel workbook. To see what types of content that 

you can insert, click Object in the Text group on 

the Insert tab. Only programs that are installed on 

your computer and that support OLE objects appear 

in the Object type box. 

 

Embed an object in a worksheet 

 

1. Click inside the cell of the spreadsheet where you 

want to insert the object. 

2. On the Insert tab, in the Text group, click Object  . 



 

3. In the Object dialog box, click the Create from 

File tab. 

4. Click Browse, and select the file you want to insert. 

5. If you want to insert an icon into the spreadsheet 

instead of show the contents of the file, select 

the Display as icon check box. If you don’t select 

any check boxes, Excel shows the first page of the 

file. In both cases, the complete file opens with a 

double click. Click OK. 

 

 

Insert a link to a file 
 

You might want to just add a link to the object rather 

than fully embedding it. You can do that if your 

workbook and the object you want to add are both 

stored on a SharePoint site, a shared network drive, 



or a similar location, and if the location of the files will 

remain the same. This is handy if the linked object 

undergoes changes because the link always opens 

the most up-to-date document 

. 

1. Click inside the cell of the spreadsheet where you 

want to insert the object. 

3. On the Insert tab, in the Text group, click Object  . 

 

3. Click the Create from File tab. 

4. Click Browse, and then select the file you want to 

link. 

5. Select the Link to file check box, and click OK. 

 

Create a new object from inside Excel 
 

You can create an entirely new object based on 

another program without leaving your workbook. 

For 



example, if you want to add a more detailed 

explanation to your chart or table, you can create an 

embedded document, such as a Word or 

PowerPoint 

file, in Excel. You can either set your object to be 

displayed right in a worksheet or add an icon that 

opens the file. 

 
1. Click inside the cell of the spreadsheet where you 

want to insert the object. 

2. On the Insert tab, in the Text group, click Object  . 

 
3. On the Create New tab, select the type of object you 



want to insert from the list presented. If you want to 

insert an icon into the spreadsheet instead of the 

object itself, select the Display as icon check box. 

4. Click OK. Depending on the type of file you are 

inserting, either a new program window opens or an 

editing window appears within Excel. 

 

5. Create the new object you want to insert. 

When you’re done, if Excel opened a new program 

window in which you created the object, you can 

work directly within it. 

 

When you’re done with your work in the window, you 

can do other tasks without saving the embedded 

object. When you close the workbook your new 

objects will be saved automatically. 

 

C) Clip art and Text 

Ans. Clip art (also clipart, clip-art), in the graphic arts, is pre-made images used to illustrate 

any medium. Today, clip art is used extensively. Clip art comes in many forms, both 

electronic 

and printed. However, most clip art today is created, distributed, and used in an electronic 

form. 

Since its inception, clip art has evolved to include a wide variety of content, file 

formats, 



illustration styles, and licensing restrictions. Clip art is generally composed exclusively 

of 

illustrations (created by hand or by computer software), and does not include 

 

Text 

 

the main body of matter in a manuscript, book, newspaper, etc., as 

distinguished from notes, appendixes, headings, illustrations, etc. 

the original words of an author or speaker, as opposed to a translation, 

paraphrase, commentary, or the like: the actual wording of anything written 

or printed: 

 

D) Slide show effects 

Ans. Slide Effect is a presentation tool providing enhanced 

transitions and effects. Using a standard Presentation 

Software user interface, people can create slide presentation 

with movies and images in a simpler way than using a video 

editing software. 

 

 

  



 

  



 

  



 

  



 


