
CCA-101: Fundamentals of IT & Programming 

Assignment-1 

1. What are the four fundamentals parts of computer? Explain it with the help of diagram. 

       There are four fundamental parts of computer 

 CPU ( Central processing unit 

 Monitor 

 Keyboard &  

 Mouse 

              CPU  

              A central processing unit (CPU) is the electronic circuitry within a computer that carries out the 

instructions of a computer program by performing the basic arithmetic, logical, control and  

input/output (I/O) operations specified by the instructions. 

                              

            MONITER 

            A Computer monitor is an output device that displays information in pictorial form.  A monitor   

usually comprises the visual display, circuitry, casing, and power supply. 

 

 

 

 

 

 



 

 

           KEYBOARD 

           As a name implies, a keyboard is a board of keys. Keyboard is one of the primary input devices 
used with a computer.        

           

           

 

 

 

 

 

 

 

 

 

 

 

          MOUSE 

          A Computer mouse is a hand-held pointing device that detects two dimensional motion relative to 

a surface. This motion is typically translated into the motion of a pointer on a display, which allows a 

smooth control of the graphical user interface of a computer. 

 

 

 

          



 

2. Discuss about the classification of the computers based on size and capacity. 

Based on size and capacity there are four types of computer: 
 Super Computers 

 Mainframe Computers 

 Mini Computers   

 Micro Computers 

SUPER COMPUTERS 

 A Super Computers are most powerful and physically large by size. 

 Super computers are fastest computer n current era. 

 A Super computer is a computer with a high level of performance as compared to a 

general purpose computer. 

 The memory capacity of super computer is in some gigabytes or in terabytes. 

 They are used at some research centers and government agencies involving in 

sophisticated scientific and engineering tasks. 

MAINFRAME COMPUTRERS 

 Mainframe computers are large and expensive machines. 

 Memory capacity being in some megabytes and storage capacity in some terabytes. 

 Generally they handle huge volumes of information and data. 

 They are used in research organizations, large industries, airlines reservation where a 

large database has to be maintained. 

              MINI COMPUTERS 

 They were faster than micro computers.  

 Mini computers had larger memories and greater storage capacity. 

 Minicomputer was a multi-user system which means more than one user could use 

system simultaneously. 

             MICRO COMPUTERS 

 Micro computer is a computer whose CPU (Central Processing Unit) is a microprocessor. 

 Micro computer can be categorized as the desktop, programmable and workstation. 

 They are the backbone of the modern computer era. 

 

 

 



3. What is the meaning of computer generation? How many of computer generations are defined?     

What technologies were/are used? 

 Generation in computer terminology is a change in technology a computer is/was being used. 

Initially, the generation term was used to distinguish between varying hardware technologies. 

Nowadays, generation includes both hardware and software, which together make up an entire 

computer system.  

 There are five computer generations are defined.  

FIRST GENERATION (1940-1956) 

 The vacuum tubes are used in first generation computers. These were widely used in the first 

computer systems for circuitry, while magnetic drums were used for memory. 

SECOND GENERATION (1956-1963) 

 There was the introduction of transistors, which came in to replace vacuum tubes. Not only 

were transistors smaller, but they were also cheaper to build, more energy efficient, and worked 

at a faster speed. 

THIRD GENERATION (1964-1971) 

 Third-generation computers the integrated circuits (IC) are used, which are still in use today. 

These reduced the size of the computers. 

FORTH GENERATION (1971-2010) 

 In the fourth generation of computers, the invention of the microprocessor (commonly known 

as CPU) helped to get computers to the desk and later, lap- size that we still know and use 

today. 

FIFTH GENERATION (1980- at present) 

 In the fifth generation, VLSI technology became ULSI (Ultra Large Scale Integration) technology, 

resulting in the production of microprocessor chips heaving ten million electronic components. 

 This generation is based on parallel processing hardware and AI (Artificial Intelligence) software. 

4. Differentiate between volatile and non-volatile memories. 

S. no key Volatile memory Non-Volatile memory 

1 Data Retention Data is present till power 
supply is present. 

Data remains even after 
power supply is not 
present. 

2 Persistence Volatile memory data is 
not permanent. 

Non-volatile memory data 
is permanent. 
 



3 Speed Volatile memory is faster 
than non-volatile memory. 

Non-volatile memory 
access is slower. 

4 Storage  Volatile memory less 
storage capacity. 

Non-volatile memory like 
HDD has very high storage 
capacity. 

5 Cost Volatile memory is costly 
per unit size. 

Non-volatile memory is 
cheap per unit size. 

 

 

 

 

5. Distinguish among system software, application software and open source software on the basis of 

their features. 

System software 

o System software is use for operating computer hardware. 

o System software are installed on the computer when operating system is installed. 

Application software 

o Application software is used by user to perform specific task. 

Open source software 

o Open source software (OSS) is a type of computer software. 

o Open source software is a prominent example of open collaboration. 

 

 6.a)  Create a file in MS-word to insert a paragraph about yourself and save it with file name “Yourself”. 

Describe all steps involved it.   

                                                        Yourself 

             Steps involved in this document “Yourself” 

 First, I click the Microsoft office button. And then to select the new tab then the new 

dialog box appears. 

 And then I selected the blank document. It was highlighted by default. 

 Then I can write my document about myself. And saved a file name by Yourself in word 

window. The save option is get from the file menu.  

 

 



6.b) Write steps regarding followings  

 To change the font style 

 To change the font style 

 To change the font color  

 To highlight (in yellow) the line that reads “needs to get IMS’s address”. 

        TO CHANGE THE FONT STYLE  

 First, select the text you want to modify.  

 Click on font style box on the Home tab. 
 The font style drop-down menu appears.  
 Then move your cursor over the various font styles. 

 Left-click the font style you want to use. 

 Then font style will change in the document. 

        TO CHANGE THE FONT SIZE 

 Select the text you want to modify. 

 Click on font size box in the Font group on the Home tab.  

 The font size drop-down menu appears. 

 Move your cursor over the various font sizes. 

 Left-click on font size you want to use. 

 Then it will change font size in your document. 

          TO CHANGE THE FONT COLOR 

 Select the text you want to modify. 

  Click on the font color box on the Home tab. The font color menu appears. 

  Move your cursor over the various font colors.  

  Left-click the font color you want to use. 

  Then font color will change in the document. 

          TO HIGHLIGHT IN YELLOW 

                 “Need to get IMS’s address” 

 To select the text you want to highlight. 

 Click the text highlight color box on the hoe tab. 

 Move the cursor over the yellow color and click. 

 Then the selected text is highlighted.  

 

 



7.  Create a file in MS-Word for the following document and save it with file name ‘ms-word’. Describe 
all steps involved it.  

MS Word 

MS Word is a widely used commercial word processor developed by Microsoft. 

MS word is application software, which is capable of 

 creating, 

 Editing, 

 Saving, and 

 Printing any type of document 

STEPS INVOLVED IN THIS DOCUMENT: 

 First you select the text want to modify. 

 Click on the font color command on the home tab. 

 After that move your cursor over the different colors.  

 Then you choose color what you want and click on color as you select. 

 Finally the text color will change. 

 To underline the text, select the text you want to modify and click on the underline command in 
the font group. 

 Then the text will change as you want. 

 To strikethrough the text, first you select the text want to modify.  

 Click on the strikethrough command. Then it will change as a Strikethrough. 

 To change the text as a bold form, select the text you want to modify.  

 Click on the bold command in the font group on the home tab. Then text will change as bold 
letters.  

8.  Create a file in MS-word for the following document and save it with file name ‘equations’. Describe 
all steps involved it. 

      Equations 

      X2 + Y2 = 30 

      Z2 + Q4 = 50 

      A2 + B8 = X2 + Y8  

TO CHANGE A TEXT AS SUBSCRIPT 

 First you select the text want to modify. 



 If you want to create small letters below the text baseline, then click on the subscript 
command on the home tab. 

 Then it will change as a subscript in the document or text. 
 If you want to create a small letter just above the baseline of text, again you just click on the 

subscript command on the home tab, finally it will change as a subscript. 

9. Create a file in MS-word that convert existing highlight text to table as shown below save it as file 
name  ‘text _to_ table’. Describe steps involved in it. 

Select the text you want to convert. 

Select the Insert tab. 

Click on Table command. A dialog box appears. 

Click on Convert text to table, a new dialog box appears 

 here set number of columns. 

 Click on OK finally selected text convert in a table 

 

                                                                                  Text to table 

Select the text you want to convert. Select the Insert tab. 

Click on Table command. A dialog box 
appears. 

Click on Convert Text to Table, a new 
dialog box. 

here set number of columns. Click on ok finally selected text 
convert in a table. 

Steps involved in the document 

 If you want to change a text as a table, first you have to select the text you want to modify or 
convert as a table.  

 Then select the insert tab, click on the table command. 

 Then the dialog box will appears.  

 Then click on the convert text to table after that click your left, a new dialog box will appears 
there. 

 Then you have to set a number how many columns you want.  

 After finishing that step click OK. 

 Finally the selected text will convert as a table. 

 

 



10. Create a file in MS-word to insert a table in the document. Describe all steps involved in it. 

       To insert a new table in your work sheet follow these steps 

 First place your insertion point in your document where you want to insert the table,  

 Then select the insert tab click on the table command, then drag your mouse over the diagram 
to select the number of columns and rows as you need,  

 Finally left click your mouse table will appears in your document then you can text inside of the 
table as you want. 

11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

       This is home page if excel where you can click on blank workbook and the screen that appears is  

nothing but is your excel workbook. First thing to notice is the name of the worksheet. Excel by default 

save it as book 1.  

             Book1 

Roll No Name  Marks 

1 n1 60 

2 n2 70 

3 n3 80 

4 n4 90 

5 n5 40 

6 n6 50 

7 n7 77 

8 n8 44 

9 n9 88 

10 n10 55 

 

12. Calculate the following things of a range (C2:C11) of data in the worksheet created in question no 

10.  

 the sum of the marks using AutoSum in a range of cells (C2:C11) 

 average of the marks in a range of cells (C2:C11) 

 highest marks in a range of cells (C2:C11) 

 minimum marks in a range of cells (C2:C11) 

calculation   

 The sum of the marks using AutoSum in a range of cells (C2:C11) 

          Select cells and type formula of the sum of the range of cells = SUM (C2:C11) 

 average of the marks in a range of cells (C2:C11) 

          Select cells marks and select target cell formula = AVG (C2:C11) 

 highest marks in a range of cells (C2:C11) 

          Select cells range and select target cell = MAX (C2:C11) 



 minimum marks in a range of cells (C2:C11) 

          Select cells range and target cells = Min (C2:C11) 

13.a) Describe various steps involved in the following  

 To modify column width of a worksheet  

 To modify the row height of the worksheet  

 To delete rows and columns of a worksheet  

To modify the column width of a worksheet 

 Position the cursor over the column line in the column heading,  And a double arrow will 

appear. 

  Left-click the mouse, then drag the cursor to the right to increase the column width or to the 

left to decrease the column width. 

 Release the mouse button. 

To modify the row height of a worksheet 

 Position the cursor over the row line you want to modify, And a double arrow will appear. 

 Left-click the mouse, then drag the cursor upward to decrease the row height or downward to 

increase the row height. 

  Release the mouse button. 

To delete rows and columns of a worksheet 

 Select the row or column you want to delete. 

  Click the Delete command in the Cells group on the Home tab.  

 Selected column or row deleted. 

13.b)  Describe following terms in the worksheet 

 Absolute reference and relative reference in formula 

 Cell address 

 

 Absolute reference and relative reference in formula 

Absolute reference 

     Absolute references do not change when copied or filled. You can use an absolute reference 

to keep a row and/or column constant. 

Relative reference 

     By default, all cell references are relative references. When copied across multiple cells, they 

change based on the relative position of rows and columns. For example, if you copy the 

formula =A1+B1 from row 1 to row 2, the formula will become =A2+B2. Relative references are 

especially convenient whenever you need to repeat the same calculation across multiple rows 

or columns. 



 Cell address 

     A cell reference in Excel refers to the value of a different cell or cell range on the current 

worksheet or a different worksheet within the spreadsheet. A cell reference can be used as a 

variable in a formula. 

14.a) What tools are available to customize our PowerPoint presentation? 

a) Crop pictures to fit shapes of pictures. 
b) You can play music in the background of your presentation 
c) Combine shapes to create a custom shape  
d) You can add sound effects to Animations  
e) Remove the background from a picture  
f) You can insert a screenshot or screen clipping to presentation  
g) You can also embed other videos 

14.b)  Write the steps for the following action for creation of power point presentation  

 Open a Blank presentation 

 Save the presentation as Lab1.pptx 

 Add Title to the first slide: the name of your college 

 Type your first name and last name in the subtitle section 

 Add a New Slide which has a title and Content 

 

Open a Blank presentation  

a) Select the File tab to go to Back Stage view. 

b) Select New on the left side of the window, click Blank Presentation. 

c) A new presentation will appear. 

Save the presentation as Lab1.pptx 

a) Click on the File tab to launch the Backstage view and select Save. 

b) In the Save As dialog, type in the file name and click "Save". 

The default file format is pptx. If you want to save the file with a different name, choose one of the 

file types from the "Save as type" dropdown list. 

Add a title to the first slide: the name of your college 

a) Select the slide whose layout you will change so that it can have a title. 

b) Click Home > Layout. 

c) Select Title Slide for a standalone title page or select Title and Content for a slide that contains 
a title and a full slide text box. ... 

d) Select the Click to add title text box. 



e) And after that I type name of my college.  

Type your first name and name in the subtitle section 

a) Right-click between slides and select Add Section. An Untitled Section is added in the thumbnail 
pane. 

b) Right-click the Untitled Section and then select Rename Section. 

c) Type a name as my name is Kayalvizhi Marappan in the Section name box. 

d) Select Rename. 

e) To collapse a section, click the triangle next to the section name. 

Add a new slide which has a Title and Content 

a) Right-click between slides and select Add Section. 
b)  An Untitled Section is added in the thumbnail pane. 
c) Right-click the Untitled Section and then select Rename Section.  
d) Type a name in the Section name box. Select Rename. 
e) To collapse a section, click the triangle next to the section name. 

15. Write steps for creation of a Power Point Slides that demonstrates your skill to use the tools of 

PowerPoint. It should include the following things  

 Title slide & bullet list  

 Inserting Excel Sheet  

 Clip art and Text 

 Slide Show effects 

Title slide &bullet list 

 Click on new slide from the home tab. A list of thumbnails appears, outlining your various slide 
content options to choose from. 

 Click once on the appropriate thumbnail to bring up the next slide. 

To enter bullets: 

 Bullets appear automatically on each line. 

 Press Enter to bring a next bullet. 

 To erase an unwanted bullet, click next to the bullet and press the Backspace key. 

 TO indent a bullet ( to make a sub point), press tab 

 To undo an indent, press together with the shift key. 

Inserting Excel Sheet 

 Click once anywhere inside the chart to select it. This launches a chart tools contextual 
command tab that doesn’t appear on the normal editing screen. 

 Make sure the design tab under the chart tools is selected and then click on edit data from the 
group. 



Clip art and Text 

 Right-mouse click inside the shape. 

 Select edit text. 

 Right Enter your text. 

 Click on the insert tab and choose clip art from illustrations group. 

Slide Show Effects 

 Click on the animation tab. 

 Glide your mouse over each of the transition effects located in the transition to this slide group 
to preview them on your slide. 

 Note the vertical scroll bar to the right, there are more effects to preview than are currently in 
the view. 

 Click once on effect to select it. 

 

 

Part-2 

16. What is the difference between the Machine Language and High level Language? 

      

S. No Machine Language High Level Language 

1 It is a machine friendly language. It is programmer friendly language. 

2 Machine language is high memory 
efficient. 

High level language is less memory 
efficient. 

3 It is tough to understand. It is easy to understand. 

4 It is complex to debug. It is simple debug comparatively. 

5 Machine language is a non-portable. High level language is portable. 

6 It is complex to maintain. It is simple to maintain comparatively. 

7 It is machine dependent. It can run on any platform. 

8 It is not commonly used now-a-days in 
programming. 

It is widely for programming. 

 



 

 

17. Discuss about different data types of C programming Language.  

       Data types in C Language 

       Primary data types: 

               These are fundamental data types in C namely integer (int), floating point (float), character 
(char), and void. 

       Derived data types: 

               Derived data types are nothing but primary data types but a little twisted or grouped together 
like array, structure, union or pointer. 

18. Find the output of the following program expressions. 

a)  X = 20/5*2+30-5  

         = 4*2+30-5 

         =8+30-5 

      X =33 

 

b) Y = 30-(40/10+6) +10 

        = 30-(4+6) +10  

        =30-10+10 

    Y = 30 

c) Z = 40*2/10-2+10 

       =80/10-2+10 

       =8-2+10 

       =16 

19. Describe the syntax of the following statements. 

a) If-else statement 

The syntax of an if...else statement in C programming language is 

If (test Expression) 

{ 



      //execute your code 

} 

else 

{ 

     //execute your code 

} 

o The syntax for if statement is as follows: if (condition) instruction;   

o The condition evaluates to either true or false. True is always a non-zero value, and false is a 

value that contains zero. 

 

b) for loop 

o A for loop is a repletion control structure that allows to efficiently write a loop that needs to 

execute a specific number of times. 

Syntax 

for ( init; condition; increment statement(s); 

}  

c) while loop 

A while loop in C programming repeatedly executes a target statement as long as a given condition is 

true. 

Syntax 

     While (condition) { 

             Statement(s); 

     } 

d) do-while loop 

A do… while loop is similar to a while loop, except the fact that is guaranteed to execute at least one 

time. 

 



Syntax 

do { 

      statement(s) ; 

} while (condition) ; 

20. Find the output of the following program segments. 

a) 

#include <stdio.h> 

int main() 

{ 

  int i; 

   for (i=1; i<2; i++) 

   { 

     Printf("IMS Ghaziabad\n"); 

  } 

} 

Output: 

IMS Ghaziabad 

b) 

#include <stdio.h> 

 int main() 

{ 

  int i =1; 

  while (i <=2) 

    { 

      Printf("IMS Ghaziabad\n"); 

      i = i +1; 



     } 

} 

Output: 

IMS Ghaziabad 

IMS Ghaziabad 

IMS Ghaziabad 

c)  

#include <stdil.h> 

Void main() 

{ 

   int a = 10, b = 100; 

     if( a>b ) 

     printf("Largest number is %d\n”, a); 

    else 

       printf("Largest number is %d\n”, b); 

    } 

Output: 

  Largest number is 100 

 

 

 

 

 

 

                                     

 

 


