
CCA-101: Fundamentals of IT & Programming 

             Assignment -1 

 

Q1: What are the four fundamental parts of computer? Explain it with the help of diagram. 

A computer has four main components: the central processing unit or CPU, the primary 

memory, input units and output units. A system bus connects all four components, passing and 
relaying information among them. 

CPU: Computer scientists typically call the CPU the "brain" of the computer because this is 

where programs are executed. A program is a set of instructions that tells the computer how to 
accomplish a specific task, such as sending a file to the printer, opening a browser window, or 

playing music or video. 

Memory: Once the CPU converts a specific set of computer program instructions into machine 
code, it stores that machine code in primary storage or memory. The machine code will be 

treated as either data or instructions. The CPU fetches data and instructions from memory, uses 

an instruction to manipulate the data, and then sends the result and the next set of instructions 

back to memory. 

Input Units: Input units are all the devices you use to feed information to the computer, such as 

a keyboard, a hard drive or a networking card. These devices, in essence, bring data from the 
"outside world" into your computer, in much the same way that your eyes and ears bring 

information to your brain. Each input device has its own hardware controller that connects to the 

CPU and primary memory, and it has a set of instructions that tells the CPU how to use it. 

Output Units: Output units are the devices your computer uses to relay information to the user, 

such as a printer, monitors and speakers. For example, everything you see on your computer 

monitor starts as machine code in memory. The CPU takes that machine code and converts it 

into a format required by your monitor's hardware. Your monitor's hardware then converts that 
information into different light intensities so that you see words or pictures. 

The System Bus: The system bus lets the four components of the computer communicate with 

one another. The system bus transmits data and instructions. It also sends addresses that tell 
the CPU where in primary memory the data and instructions are coming from and where the 

results should go. 

 

 

 



 

 
 

Q2: Discuss about the classification of computers based on size and capacity. 

 

CLASSIFICATION BASED ON SIZE AND CAPABILITY 

Based on size and capability, computers are broadly classified into 

        a) Microcomputers (Personal Computer): A microcomputer is the smallest general purpose 

processing system. The older pc started 8-bit processor with speed of 3.7MB and current pc 

64-bit processor with speed of 4.66 GB.  

Examples: IBM PCs, APPLE computers 

Microcomputer can be classified into 2 types: 

    1. Desktops 

    2. Portables 

 

The difference is portables can be used while travelling whereas desktops computers cannot be 

carried around. 

The different portable computers are: - 

1)         Laptop 

2)         Notebooks 

3)         Palmtop (hand held) 

4)         Wearable computers 

Laptop: this computer is similar to a desktop computer but the size is smaller. They are 

expensive than desktop. The weight of laptop is around 3 to 5 kg. 

 

Notebook: These computers are as powerful as desktop but size of these computers are 

comparatively smaller than laptop and desktop. They weigh 2 to 3 kg. They are more costly 

than laptop. 

Palmtop (Hand held): They are also called as personal Digital Assistant (PDA). These computers 

are small in size. They can be held in hands. It is capable of doing word processing, 

spreadsheets and hand writing recognition, game playing, faxing and paging. These computers 

are not as powerful as desktop computers. Ex: - 3com palm. 

Wearable computer: The size of this computer is very small so that it can be worn on the body. 

It has smaller processing power. It is used in the field of medicine. For example, pace maker to 

correct the heart beats. Insulin meter to find the levels of insulin in the blood. 

http://classificationofcomputers.blogspot.com/2012/09/classification-based-on-size-and_3.html


b) Minicomputer: A minicomputer is a medium-sized computer. That is more powerful than a 

microcomputer. These computers are usually designed to serve multiple users simultaneously 

(Parallel Processing). They are more expensive than microcomputers. 

Examples: Digital Alpha, Sun Ultra. 

 

c) Mainframe computers: - Computers with large storage capacities and very high speed of 

processing (compared to mini- or microcomputers) are known as mainframe computers. They 

support a large number of terminals for simultaneous use by a number of users like ATM 

transactions. They are also used as central host computers in distributed data processing system. 

Examples: IBM 370, S/390. 

 

d) Supercomputer: Supercomputers have extremely large storage capacity and computing 

speeds which are many times faster than other computers. A supercomputer is measured in terms 

of tens of millions of Instructions per second (mips), an operation is made up of numerous 

instructions. The supercomputer is mainly used for large scale numerical problems in scientific 

and engineering disciplines such as Weather analysis. 

Examples: IBM Deep Blue. 

 

 

Q3: What is the meaning of computer generation? How many Computer Generations are 

defined? What technologies were/are used? 

 

A computer is a machine manipulating data or information electronically. It can store, 

retrieve, and analyse the information. A computer can now be used to follow 

instructions, send email messages, play online games, and browse the internet. Editing 

or making spreadsheets, reports, and sometimes even videos can also be used. Yet the 

development of this complex structure began approximately 1940 with the very first 

Computer Generation and has since evolved. The computer revolution is always marked 

as a technological breakthrough that has fundamentally altered the unique way for 

computers work, culminating in ever smaller, cheaper, increasingly efficient, and much 

more efficient machines. Reference is often made to the development of computer 

technology in relation to the various types of computing devices. Computer revolution 

completely changed the way computer’s function, resulting in ever smaller, cheaper, 

more efficient, and much more secure computers. 
 

First Generation: These early computers used vacuum tubes as circuitry and magnetic 

drums for memory. As a result, they were enormous, literally taking up entire rooms and 

costing a fortune to run. These were inefficient materials which generated a lot of heat, 

sucked huge electricity and subsequently generated a lot of heat which caused ongoing 

breakdowns. 

These first-generation computers relied on ‘machine language’ (which is the most basic 

programming language that can be understood by computers). These computers were 

limited to solving one problem at a time. Input was based on punched cards and paper 



tape. Output came out on print-outs. The two notable machines of this era were the 

UNIVAC and ENIAC machines – the UNIVAC is the first every commercial computer 

which was purchased in 1951 by a business – the US Census Bureau. 

 

Second Generation: The replacement of vacuum tubes by transistors saw the advent 

of the second generation of computing. Although first invented in 1947, transistors 

weren’t used significantly in computers until the end of the 1950s. They were a big 

improvement over the vacuum tube, despite still subjecting computers to damaging 

levels of heat. However, they were hugely superior to the vacuum tubes, making 

computers smaller, faster, cheaper and less heavy on electricity use. They still relied on 

punched card for input/printouts. 

The language evolved from cryptic binary language to symbolic (‘assembly’) languages. 

This meant programmers could create instructions in words. About the same time high 

level programming languages were being developed (early versions of COBOL and 

FORTRAN). Transistor-driven machines were the first computers to store instructions 

into their memories – moving from magnetic drum to magnetic core ‘technology’. The 

early versions of these machines were developed for the atomic energy industry. 

 

Third Generation: By this phase, transistors were now being miniaturised and put on 

silicon chips (called semiconductors). This led to a massive increase in speed and 

efficiency of these machines.  These were the first computers where users interacted 

using keyboards and monitors which interfaced with an operating system, a significant 

leap up from the punch cards and printouts. This enabled these machines to run several 

applications at once using a central program which functioned to monitor memory. 

As a result of these advances which again made machines cheaper and smaller, a new 

mass market of users emerged during the ‘60s. 

 

 Fourth Generation: This revolution can be summed in one word: Intel. The chip-maker 

developed the Intel 4004 chip in 1971, which positioned all computer components 

(CPU, memory, input/output controls) onto a single chip. What filled a room in the 1940s 

now fit in the palm of the hand. The Intel chip housed thousands of integrated circuits. 

The year 1981 saw the first ever computer (IBM) specifically designed for home use and 

1984 saw the MacIntosh introduced by Apple. Microprocessors even moved beyond the 

realm of computers and into an increasing number of everyday products. 

The increased power of these small computers meant they could be linked, creating 

networks. Which ultimately led to the development, birth and rapid evolution of the 

Internet. Other major advances during this period have been the Graphical user 

interface (GUI), the mouse and more recently the astounding advances in lap-top 

capability and hand-held devices. 

 



Fifth Generation: Computer devices with artificial intelligence are still in development, 

but some of these technologies are beginning to emerge and be used such as voice 

recognition. 

AI is a reality made possible by using parallel processing and superconductors. Leaning 

to the future, computers will be radically transformed again by quantum computation, 

molecular and nano technology. 

 

Q4: Differentiate between Volatile & Non- Volatile memories. 

Parameter 

 

Volatile Memory 

 

Non-Volatile Memory 

 

Definition It is a temporary type of 
computer memory that 
stores data and information 
only until it gets a 
continuous power supply. 

It is a permanent type of 
computer memory that 
stores and retains the data 
even after a user turns the 
system off. 

Stored Data The volatile memory stores 
data of those programs that 
the CPU is processing in 
real-time. A system stores 
all the frequently used 
information and data in the 
device’s volatile memory. 

The non-volatile memory 
stores data from the basic 
booting process of any 
computer system BIOS. It 
stores all the types of data 
and media that need to 
exist for a longer time or 
permanently on the 
computer 

Effect on Performance Volatile memory does not 
affect a system’s 
performance. A higher 
amount of storage space 
for cache, RAM, and other 
volatile memory increases 
the efficiency of a computer 
system 

Non-volatile memory also 
affects a system’s 
performance and storage. A 
higher amount of storage 
space lets a user save 
more data permanently. 
Thus, the system runs 
comparatively smoother. 

Speed  
The volatile memory is the 
fastest form of memory in 
nature. These memories 
hold the most frequently 

Non-volatile memory is a 
relatively slower form of 
memory. The process of 
accessing data from a 
non-volatile memory is 



used data- and any user 
can access them quickly 
 

comparatively slower 

Data Retention It can only retain data until 
there is a continuous power 
supply. 

It retains data and info even 
after one turns the power 
supply off. 

Data Transfer Transferring data from a 
volatile memory is very 
easy. 

Transferring data from a 
non-volatile memory is very 
difficult. 

 

 

Q5: Distinguish among system software, application software and open-source 
software on the basis of their features. 

System Software Application Software Open-source software 

System software designed 
to provide a platform to 
other software. 

Application software 
designed to perform a 
group of coordinated 
function, task or activities 
for the benefits of users. 

It is referred to the software 
that developed to tested 
through open collaboration. 

It manages resource and 
helps to run hardware and 
application software. 

It performs specific task 
according to type. 

It performs with academic 
knowledge, inspect and 
modify and redistributed 
course code. 

Example: operating system, 
language processer and 
device drive. 

Example: world processer, 
spreadsheet, web browser, 
presentation software, 
graphical presentation. 

Example: Android, Firefox, 
Liber office, Ubuntu, Free 
BSD etc. 

Essential for proper 
functioning of system. 

Not essential for important 
functioning of system. 

Better flexibility which has 
more freedom with 
encourage innovations. 

Developed using language 
like C, C++, Assembly. 

Developed using languages 
like Java, C, C++, Visual 
basics. 

It is not aimed with 
uninstalled users outside of 
programming community. 



It runs when the system 
shorts and runs till the end. 

It runs when the users 
require. 

Its project managed by 
open-source community of 
developers and 
programmers. 

 

 

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it 
with file name “yourself”. Describe all steps involved in it. 

o Go to the start menu and look for Microsoft Word icon 

o Click the icon to open the Microsoft Word 

o You will see a blinking cursor or insertion point in the text area below the ribbon 

o Now, start typing, the words will appear on the screen in the text area 

o To change the location of insertion point press spacebar, Enter or Tab keys. 

o After, typing we can change the change the font size and style, line spacing. 

o Now, save the file.  

 

Q6 b) Write steps regarding followings 

 To change the font style, to change the font size, to change the font colour, to 
highlight (in yellow) the line that reads “need to get IMS’s address”. 

To change the font style  

o Select the text you want to modify 

o Select the Home tab and locate the Font group 

o Click the drop-down arrow next to font style box 

o Font style menu appears 

o With a left click select the desired font style 

To change the font size 



o Select the text that you want to modify 

o In Home tab locate the Font group 

o In Font group click the drop-down arrow next to font size box 

o Font size menu appears 

o Select the desired font size with a left click 

o Select the text and click the increase or decrease font size buttons 

To change the font colour 

o Select the text you want to modify 

o In Home tab locate the Font group 

o Click the drop-down arrow next to Font colour button 

o Font colour menu appears 

o Select the desired font colour with a left click 

o Word will change the Font colour of the selected text. 

 

To highlight (in yellow) the line that reads “need to get IMS’s address”. 

o Open Ms word in computer 

o Select the text that need to be highlight 

o Before that type “need to get IMS’s address”  

o Then select yellow colour in text highlight and drag down the mouse and line will 

get highlighted with yellow. 

 

Q7. Create a file in MS-Word for the following document and save it with file 

name ‘ms_word’. Describe all steps involved in it. 

o Open Ms word in system and type he line as given. 

o Select all the lines and select font style as Times new Roman. 



o Select the first line and change the font size to 18. 

o In second line select “Ms word” alone and give font colour red, and in the same 

line select word “processer” and underline it. 

o In third line select “Ms word” and make inti italic. 

o Select the word “creating” and change font colour into light blue, Select the word 

“saving” and change the font colour into red, Select the word “and” and use strike 

through, select the text “printing any type of document” and use bold. 

o Add bullet to each line. 

o Save the file as “MS Word”. 

 

Q8. Create a file in MS-word for the following document and save it with file name 

‘equations. Describe all steps involved in it. 

o Open Ms word in system 

o Type the given equation given in paper 

o Use subscript and superscript 

o Save the file as “Equation” 

 

Q9. Create a file in MS-word that convert existing highlight text to table as shown 

below and save it as file name ‘text_to_table’. Describe all steps involved in it. 

o Open MS word in system and type the given sentences that given in question 

paper 

o Change the font size to Times new roman and font size to 14 

o Select the insert tab, click table, covert text to table, a new dialogue box will 

appear 

o Give number of columns 2 and Auto lift behaviour, fixed column width “auto” and 

separate text as “paragraph” and click ok 



o Then table will appear remember for “insert, table, convert text to table, a new” 
words should be in bold 

o Finally save it as ‘text_to_table’ 

 

Q10. Create a file in MS-Word to insert a table in the document. Describe all steps 

involved in it. 

o Open MS word in system 

o Select the insert table  

o Select insert 

o Select table 

o Select 5 boxes for columns and select 3 boxes for rows 

o Box will appear on page 

o Save the file as “Q10” 

 

Q11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

o Open MS Excel in system 

o Type the given table as given question paper 

o Rename the sheet as student  

o Save the file as “Book 1”  

 

Q12. Calculate the following things of a range (C2:C11) of data in the worksheet 

created in question no10. 

The sum of the marks using AutoSum in a range of cells (C2:C11) 

o Select C2:C11 from the excel cell 

o Click auto sum in tool bar  



 

Average of the marks in a range of cells (C2:C11) 

o Select C2:C11 from the excel cells 

o Select the sum and click average in tool bar 

 

Highest marks in a range of cells (C2:C11) 

o Select C2:C11 from the excel cells 

o Select the sum and click max from the tool bar 

Minimum marks in a range of cells (C2:C11) 

o Select C2:C11 from the excel cell 

o Select the sum and click Min from the tool bar 

  

Q13 a) Describe various steps involved in the following 

o Open MS excels 

o Select page layout tab 

To modify column width of a worksheet 

o Click the width and apply it on column 

To modify the row height of a worksheet 

o  Click the height and fix it to the row 

To delete rows and columns of a worksheet 

o Select the home tab  

o Click delete to delete the rows 

o And click delete to delete the columns 

 



Q13 b) Describe following terms in the worksheet 

Absolute reference and relative reference in formula 

o Absolute references, on the other hand, remain constant no matter where they 

are copied. 

o Relative references change when a formula is copied to another cell. 

o Absolute reference formulae- =D2*A2 

o Relative reference formulae- =D12*$A$10 

o Open MS excels in system 

o Make a table for absolute and relative reference with unit cost, unit size number, 

package size, inventory, total cost  

o Use the formulae of absolute and relative reference  

o Save the file 

 

Cell Address   

o A cell reference, or cell address, is an alphanumeric value used to identify a 

specific cell in a spreadsheet. Each cell address contains 'one or more letters' 

followed by a number. The letter or letters identify the column and the number 

represents the row.  

Q14. a) What tools are available to customize our PowerPoint presentation?1.  

1. Home: The Home tab holds the Cut and Paste features, Font and Paragraph options, 

and what you need to add and organize slides. 

2. Insert: Click Insert to add something to a slide. This includes pictures, shapes, charts, 

links, text boxes, video and more. 

3. Design: On the Design tab, you can add a theme or colour scheme, or format the slide 

background. 



4. Transitions: Set up how your slides change from one to the next on the Transitions tab. 

Find a gallery of the possible transitions in the Transition to This Slide group – 

click More at the side of the gallery to see all of them. 

5. Animations: Use the Animations tab to choreograph the movement of things on your 

slides. Note that you can see many possible animations in the gallery in the Animation 

group. 

6. Slide Show: On the Slide Show tab, set up the way that you want to show your 

presentation to others. 

7. Review: The Review tab lets you add comments, run spell-check, or compare one 

presentation with another (such as an earlier version). 

8. View: Views allow you to look at your presentation in different ways, depending on 

where you are in the creation or delivery process. 

9. File: At one end of the ribbon is the File tab, which you use for the behind-the-scenes 

stuff you do with a file, such as opening, saving, sharing, exporting, printing and 

managing your presentation. Click the File tab to open a new view called the Backstage. 

Click from the list on the side to do what you want to do; for example, click Print to find 

the options and settings for printing your presentation. Click Back to return to the 

presentation that you were working on. 

10. Tools tabs: When you click some parts of your slides, such as pictures, shapes, 

SmartArt or text boxes, you might see a colourful new tab appear. 

 

Q14 b) Write the steps for the following action for creation of power point 

presentation  

 

Open a Blank presentation 

o Open MS power point presentation in system 

o Click office button, click new, click blank prestation, click create 

o Blank presentation is created 

 



Save the presentation as Lab1.pptx 

o Click office button 

o Click save as, file name “as lab-1 pptx” 
 

Add a Title to the first slide: the name of your college 

o Click click to add title 

o Type college name 

o Select college name, click quick style in home tab, click blue colour  

o Select font style into Times New Roman 

o Select font size 48 

o Select font colour to yellow 

 

Type your first name and last name in the Subtitle section 

o Click click to add subtitle 

o Type first name and last name 

o Select first and last name, click quick style, click green colour 

o Select font style into Times New Roman 

o Select font size to 48 

o Select font colour to red 

 

Add a New Slide which has a Title and Content 

o Click new slide in home tab 

o Add title and content toa the slide 

o Change the design by using design tab 

o Save the power point presentation 

 

 

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your 

skill to use the tools of PowerPoint. It should include the following things 

 



Title slide &bullet list 

o Open power point presentation in system 

o Click new slide, click title slide 

o Click click to add title and subtitle 

o Click bullets 

o Now type the points 

o Save the file 

 

Inserting Excel Sheet 

o Open Ms excel sheet in system 

o Create a table in excel  

o Save the excel sheet 

o Now open power point presentation 

o Go to insert, click hyperlink 

o Hyperlink will open and select the excel sheet that have been created  

o Click ok  

 

Clip art and Text 

o For clip art Type a text and go to insert and now go to clip art and select any 

format 

o For text Change the font style, font size, and font colour 

 

Slide show effects 

o For slide show, click animation and select anything  

o Click ribbon button and save it 

 

 

 

  



            Part -2 

Q16. What is the difference between Machine Language and High-Level Language? 

 

Machine Language High-Level Language 

A machine language is the only language 

that a computer directly understands, it is 

usually written in zeros (0) and ones (1).  

 a high-level language is a programming 

language that uses English and 

mathematical symbols, like +, -, % and 

many others, in its instructions. 

Machine language, or machine code, is the 

only language that is directly understood 

by the computer, and it does not need to 

be translated. All instructions use binary 

notation and are written as a string of 1s 

and 0s. A program instruction in machine 

language may look something like this: 

A high-level language is a programming 

language that uses English and 

mathematical symbols, like +, -, % and 

many others, in its instructions. When 

using the term 'programming languages,' 

most people are actually referring to 

high-level languages. High-level languages 

are the languages most often used by 

programmers to write programs. Examples 

of high-level languages are C++, Fortran, 

Java and Python. 

It can’t understand programming language It can understand programming language 

Machine language are number High value language is near to human 

language 

It can directly understand by computer Need a computer to convert to machine 

language 

 

 

 

Q17. Discuss about different data types of C programming Language. 

Each variable in C has an associated data type. Each data type requires different 
amounts of memory and has some specific operations which can be performed over it. 



Let us briefly describe them one by one: 
Following are the examples of some very common data types used in C: 

 chart: The most basic data type in C. It stores a single character and 
requires a single byte of memory in almost all compilers. 

 int: As the name suggests, an int variable is used to store an integer. 
 float: It is used to store decimal numbers (numbers with floating point value) 

with single precision. 
 double: It is used to store decimal numbers (numbers with floating point 

value) with double precision.  
 
 
 
 
Q18. Find the output of the following expressions  
 
 
A) X=20/5*2+30-5 
 
X=20/5*2+30-5 
X=4*2+30-5 
X=8+30-5 
X=38-5 
X=33 
 
 
B) Y=30 – (40/10+6) +10  
 
Y=30 – (40/10+6) +10 
Y=30-(4+6) +10 
Y=30-10+10 
Y=30-20 
Y=10 
 
 
 
C) Z= 40*2/10-2+10 
 
Z= 40*2/10-2+10 
Z=80/10-2+10 
Z=8-2+10 
Z=6+10 
Z=16 
 
 
 
Q20. Find the output of the following program segments 



 
A) 
 IMS Ghaziabad =0 
 IMS Ghaziabad =1 
 
B) 
 IMS Ghaziabad =0 
 IMS Ghaziabad =1 
 
C)  
 Largest Number =100 

 

  

 

 

 

 

 

 

 

 

 

 

 



COMPUTER DEVICES

.

Q 15 



.

 Keyboard

 Mouse

 Joystick

 Light pen

 Scanner

 Microphone



EXCEL SHEET

S. NO INPUT DEVICES OUTPUT DEVICES

1 Key Board Moniter

2 image Scanner Printer

3 Printers Head Phone

4 Microphone LCD Projection Pannels

5 Mouse Plotters



Q10. 

 

   

   

   

   

   



Q10. 

X2 + Y5 = 30 

Z
3 

+ Q
4 

= 50 

A2 + B
8 

= X2 + Y
8 



ST. JOSEPH’S COLLEGE
K. DHEVI SOWMIYA PUSHPA

Q14 B.





Q9. 

MS Word 

MS Word is a widely commercial word processor developed by Microsoft, 

MS word is application software, which is capable of  

 creating, 

 editing, 

 saving, and 

 printing any type of document 



Roll NO Name Marks
1 n1 60
2 n2 70
3 n3 80 Q11
4 n4 90
5 n5 40
6 n6 50
7 n7 77
8 n8 44
9 n9 88

10 n10 55

SUM 654
AVERAGE 65.4 Q12

MAXIMUM 90
MINIMUM 40



Q9. 

 

 

 

 

 

 

 

 

Select the text you want to convert.  Select the Insert tab. 

 

Click on Table command. A dialog boxes 

appears. 

 

Click on Convert Text to Table, a new 

dialog box appears 

 

here set number of columns. Click on OK Finally Selected text convert in 

a table 

 







Q6. A 

I am K. Dhevi Sowmiya Pushpa. We are four members in my family including me. I am native to 

Trichy. Currently, I am pursuing MSc in Biotechnology at the St. Joseph’s college and I will be 

entering into final year of my graduation studies in the next couple of months. I am a 

self-motivated, and a disciplined soul. I am always keen to up-skill myself by learning new 

things whenever I get a chance. My strengths are my analytical approach, my human touch to 

the situations, my appreciable communication, and presentation skills. I believe upon being 

realistic.In my free time, I enjoy spending time with friends, sometimes cooking, listening to 

music, doing drama, reading, travelling, and playing outdoor sports. 
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