CCA-101: Fundamentals of IT & Programming
Assignment -1

Q1: What are the four fundamental parts of computer? Explain it with the help of
diagram.

e Monitor

e CPU

e Mouse

e Keyboard

Q2: Discuss about the classification of computers based on size and capacity.

Micro, Mini, Mainframe and Super computer.

Micro computers are smallest and based on the use of microprocessors.
Microprocessor is combined or integrated circuit which contains all the elements of
processing. Smaller than mainframe and have low speed, low storage capacity.
Basically, used for small business application are known as home computers.

Minicomputers are little larger than micro computes also use same
microprocessor but with more speed. They can be lined with other systems to form
network.

Q3: What is the meaning of computer generation? How many Computer Generations
are defined? What technologies were/are used?

Generation in computer terminology is a change in technology a computer
is/was being used. Initially, the generation term was used to distinguish between
varying hardware technologies. Nowadays, generation includes both hardware and
software, which together make up an entire computer system.

There are five computer generations known till date. Each generation has
been discussed in detail along with their time period and characteristics. In the
following table, approximate dates against each generation has been mentioned,
which are normally accepted.

S.No Generation & Description

First Generation

The period of first generation: 1946-1959. Vacuum tube based.



Second Generation

The period of second generation: 1959-1965. Transistor based.

Third Generation

The period of third generation: 1965-1971. Integrated Circuit based.

Fourth Generation

4 The period of fourth generation: 1971-1980. VLSI microprocessor
based.

Fifth Generation

5 The period of fifth generation: 1980-onwards. ULSI microprocessor
based.

Q4: Differentiate between Volatile & Non- Volatile memories.
Volatile Memory

Volatile Memory is a type of memory who continuously needs power connection to
function. When the computer’s power is turned off, volatile memory loses its
contents. And the information will get erased when the source is out. The most
common and well-known form of Volatile Memory we are using in our computers is
Random Access Memory (RAM). RAM is necessary to run a program or instruction
on a computer or any other electronic device similar to the computer, but it loses the
data when power is removed.

Non-Volatile Memory

Non-volatile memory, by contrast, does not lose its contents when power is removed
from the computer. Thus, volatile memory is temporary and non-volatile memory is
permanent. RAM is the most common type of volatile memory. Examples of non-
volatile memory include ROM, flash memory, and CMOS. The following sections
discuss these types of memory.

Q5: Distinguish among system software, application software and open source
software on the basis of their features.

S.No. System Software Application Software

1. System software is used for Application software is used by



operating computer hardware. user to perform specific task.

System softwares are installed
on the computer when operating Application softwares are installed
system is installed. according to user’s requirements.

In general, the user does not

interact with system software

because it works in the In general, the user interacts with
background. application sofwares.

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with
file name “yourself”. Describe all steps involved in it.

Creating a new document

To create a new Word document, you simply click on File and then New or the
New Blank Document button on the upper left if you have it available.

If you go to File and New you get more options compared to just clicking on
the New Blank Document toolbar button.

Saving documents

If you need to save your document so you can access it later or send it to
someone else Word makes the process very easy.

If you are used to saving files in other Windows programs then it is pretty
much the same process with Word. There is a Save button on the toolbar
which looks like a floppy disk. You can also get to the save option from the
File menu.

If you want to save a copy of your document with a different name then you
can choose the Save As option from the File menu.

From the save dialog box you can browse to where you want to save your
document. Most of the time the default location is My Documents.

In the yourself.docx box you will type the name of your document. If you want
to make a new folder to store your document then you can click the New
Folder button on the top left.



Q6 b) Write steps regarding followings

1.

To change the font style

. To change the font size

2
3.
4

To change the font colour

. To highlight (in yellow) the line that reads “need to get IMS’s address”.

Open Word.
Click the Home tab in the top left corner.

Under the Fonts block, click the expand button. It's a small arrow icon in the
bottom right corner. This will open the Font settings window.

Select your desired Font.

Select your desired Font style. Your choices are regular, italic, bold, or bold
italic.

Click Set as Default in the bottom left corner.
Select your desired Font Size.

Click Set as Default in the bottom left corner.
Click OK to confirm your changes.

Home tab and then click the Text Highlight Color command in the Font group.
Select the Yellow box. Select text “need to get IMS’s address”.

Q7. Create a file in MS-Word for the following document and save it with file name
‘ms_word'. Describe all steps involved in it.

To create a new Word document, you simply click on File and then New or the
New Blank Document button on the upper left if you have it available.

There is a Save button on the toolbar which looks like a floppy disk. You can
also get to the save option from the File menu.

If you want to save a copy of your document with a different name then you
can choose the Save As option from the File menu.

From the save dialog box you can browse to where you want to save your
document. Most of the time the default location is My Documents.



In the ms_word.docx box you will type the name of your document.

Q8. Create a file in MS-word for the following document and save it with file name
“equations”. Describe all steps involved in it.

To create a new Word document, you simply click on File and then New or the
New Blank Document button on the upper left if you have it available.

Type the given equation.

There is a Save button on the toolbar which looks like a floppy disk. You can
also get to the save option from the File menu.

If you want to save a copy of your document with a different name then you
can choose the Save As option from the File menu.

From the save dialog box you can browse to where you want to save your
document. Most of the time the default location is My Documents.

In the equation.docx box you will type the name of your document.

Q9. Create a file in MS-word that convert existing highlight text to table as shown
below and save it as file name ‘text_to_table’. Describe all steps involved in it.

To create a new Word document, you simply click on File and then New or the
New Blank Document button on the upper left if you have it available.

Type the given text and select the text and click on insert table.

There is a Save button on the toolbar which looks like a floppy disk. You can
also get

to the save option from the File menu.

Q10. Create a file in MS-Word to insert a table in the document. Describe all steps
involved in it.

Open Word or the document where you wish to put a table. You can insert



tables into any version of Word.

e Position the cursor on the area where you want the table to be inserted. Click
the “Table” button that is located under the “Insert” tab.
For best formatting results, place the table between paragraphs or on its own
line.

e Choose your method of inserting your table. In Word 2007, 2010, and 2013,
you have a few different choices when it comes to inserting a table into your
document.

e Use the Grid to make a table. You may insert the table by using the grid where
the squares represent the number of rows or columns you can have on your
table. Simply drag your mouse over the grid and click after highlighting the
number of squares needed.

e Open the “Insert Table” menu. This menu allows you to specify the number of
rows and columns that you want your table to have, as well as the width of the
columns. You can set the width to AutoFit to your cell's contents or have a
fixed width. Click “OK" to insert the table.

e Insert an Excel spreadsheet. Click on Excel Spreadsheet if you want to insert a
table which allows you to manipulate data like Excel (for example: formulas
and filters). Click outside the table if you want to work on the document itself.

e Use prebuilt table templates. On newer versions of Word you can click “Quick
Table” if you want to use built-in table templates. Simply replace the sample
data with your own.

Q11. Create a following worksheet in MS-excel and save it with name ‘book1’.

This is the Home Page of Excel, where you can click on Blank Workbook, and the
screen that appears is nothing but your Excel Workbook.

First thing to notice here, is the Name of the Workbook. Excel by default saves it as
Book1.

In the extreme Right Corner, we have three options:

e Minimize — to minimize your screen
o Restore — Let's see what happens when you press the restore button.



Q12. Calculate the following things of a range (C2:C11) of data in the worksheet
created in question no 10.

e the sum of the marks using AutoSum in a range of cells (C2:C11)
e average of the marks in a range of cells (C2:C11)
e highest marks in a range of cells (C2:C11)
e minimum marks in a range of cells (C2:C11)
1.The sum of the marks using AutoSum in a range of cells (C2:C11)
Select Cells and type formula in =SUM (C2:C11)
2.average of the marks in a range of cells (C2:C11)
Select cells marks and select target cell type formula =avg (C2:C11)
3. highest marks in a range of cells (C2:C11)
Select range and select target cell =Max (C2:C11)
4.minimum marks in a range of cells (C2:C11)

Select range and select target cell =Min (C2:C11)

Q13 a) Describe various steps involved in the following
1. To modify column width of a worksheet
2. To modify the row height of a worksheet
3. To delete rows and columns of a worksheet
1.To modify column width of a worksheet

1. Position the mouse over the column line in the column heading so
the cursor becomes a double arrow.

2. Click and drag the mouse to increase or decrease the column width.
3. Release the mouse. The column width will be changed.
2.To modify the row height of a worksheet

1. Position the cursor over the row line so the cursor becomes a double
arrow.

2. Click and drag the mouse to increase or decrease the row height.
3. Release the mouse. The height of the selected row will be changed.

3.To delete rows and columns of a worksheet



1. Select the row you want to delete.
2. Click the Delete command on the Home tab.

3. The selected row will be deleted, and those around it will shift.

Q13 b) Describe following terms in the worksheet
1. Absolute reference and relative reference in formula
2. Cell address

A cell reference in Excel is a cell address. It tells Microsoft Excel where
to look for the value you want to use in the formula.

A cell reference, or cell address, is an alphanumeric value used to identify a
specific cell in a spreadsheet. Each cell reference contains one or more letters
followed by a number. The letter or letters identify the column and the number
represents the row.

Q14. a) What tools are available to customize our PowerPoint presentation?
1. Crop Pictures to Fit Shapes

2. Play Music in the Background During a Presentation

3. Combine Shapes to Create a Custom Shape

4. Add Sound Effects to Animations

5. Remove the Background from a Picture

6. Insert a Screenshot or Screen Clipping

7. Embed YouTube Videos

Q14 b) Write the steps for the following action for creation of power point
presentation

1. Open a Blank presentation
2. Save the presentation as Lab1.pptx
Open a Blank presentation

Step 1: Launch the PowerPoint Program



Step 2: Choosing a Design

Step 3: Create Title Page

Save the presentation as Lab1.pptx
1. In PowerPoint 2010 (or a newer version), on the File tab, click Save.
2. Inthe Save dialog box, type Lab1.pptx

3. Click save.

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your
skill to use the tools of PowerPoint. It should include the following things

—_—

. Title slide &bullet list
Inserting Excel Sheet

Clip art and Text

Sl N

Slide show effect

1.Create a New Slide

e Click on New Slide from the Home tab. A list of thumbnails appears, outlining
your various slide content options to choose from.

e Click once on the appropriate thumbnail to bring up the next slide.
Entering bullets:

e Bullets appear automatically on each line.

e Pressing Enter brings up the next bullet.

e To erase an unwanted bullet, click next to that bullet and press the Backspace
key.

e Toindent a bullet (to make a sub-point), press Tab.
e Toundo an indent, press Shift together with the Tab key
2.Inserting Excel Sheet

e Click once anywhere inside the chart to select it. This launches a Chart Tools
contextual command tab that doesn’t appear on the normal editing screen.



e Make sure the Design tab under Chart Tools is selected and then click on Edit
Data from the Data group.

Clip art and Text
e Right-mouse click inside the shape.
o Select Edit Text (with the left mouse button).
e Enter your text.

e Click on the Insert tab and choose Clip Art from the lllustrations group.

4 .Slide show effect
e Click on the Animations tab.

e Glide your mouse over each of the transition effects located in the Transition
to This Slide group to preview them on your slide.

¢ Note the vertical scroll bar to the right; there are more effects to preview than
are currently in view.

e Click once on an effect to select it.

e To apply the transition to the entire presentation, click on Apply to All.

Part -2
Q16. What is the difference between Machine Language and High-Level Language?

HIGH-LEVEL
COMPARISON LANGUAGE LOW-LEVEL LANGUAGE
Basic Programmer amiable Machine-friendly
Speed of Fast Slow
execution
Translation Requires compiler or an | Assembler is required while
interpreter. machine language is directly
executed.




HIGH-LEVEL

COMPARISON LANGUAGE LOW-LEVEL LANGUAGE
Memory Low High
efficiency
Comprehensibility | Understandable Hard to understand
Portability and Portable and runnable in | Non-portable and machine
machine any platforms. dependent.
dependency
Debugging and Simple Quite complex
maintenance

Q17. Discuss about different data types of C programming Language.
1. Primary data types:

These are fundamental data types in C namely integer(int), floating
point(float), character(char) and void.

2. Derived data types:

Derived data types are nothing but primary datatypes but a little twisted or
grouped together like array, structure, union and pointer.

Q18. Find the output of the following expressions
a) X=20/5*2+30-5
b) Y=30 - (40/10+6) +10
c) Z= 40*2/10-2+10
a) 33
b) 30
c) 16



Q19. Describe the syntax of the following statements
1. If — else statement

The syntax of the if-then-else statement is: if (expression) { // codes } else { // some
other code }. Here, our program will do one task (task inside if block) if the test
expression is true and another task (task inside else block) if the test expression is
false.

2. forloop

for-loop (or simply for loop) is a control flow statement for specifying iteration,
which allows code to be executed repeatedly.

3. while loop

The while statement, in C#, is an iteration statement that allows for the execution of
an embedded statement conditionally for zero or more times. The embedded
statement implies the code block that contains single or multiple statements to be
executed within the while statement.

4. do-while loop

Definition and Usage The while statement creates a loop that is executed while a
specified condition is true. The loop will continue to run as long as the condition is
true. It will only stop when the condition becomes false.

Q20. Find the output of the following program segments.
1.

#include<stdio.h>

int main()

{

inti;

for(i=1; i<2; i++)

printf( "IMS Ghaziabad\n");

getchar();
return O;

}
Output : IMS Ghaziabad



2.

#include<stdio.h>

int main()

{

inti;

while (i<=2)

{

printf( "IMS Ghaziabad\n");
i=i+1;

}

getchar();

return O,

}
Output:
IMS Ghaziabad
IMS Ghaziabad
IMS Ghaziabad

3.

#include <stdio.h>

void main()

{

inta=10, b=100;

if(a>b)

printf( "Largest number is %d\n”, a);
else

printf( "Largest number is %d\n”, b);
}

Output: Largest number is 100



