
 
 

CCA-101: Fundamentals of IT & Programming 

Assignment-1 

Q1: What are the four fundamental parts of computer? Explain it with the help of 

diagram. 

Ans: Four fundamental parts of computer are as follows:- 

1) Input Devices: This is the process of entering data and programs into the 

computer system. We know that computer is an electronic machine like 

any other machine which takes as inputs raw data and performs some 

processing giving out processed data. Therefore, the input unit takes data 

from us to the computer in an organized manner for processing. 

2) Central Processing Unit (CPU): It is the brain of the computer. Computer 

cannot process without it. CPU takes data and instructions from the storage 

unit and makes all sorts of calculations based on the instructions given and 

the type of data provided. 

3) Output Devices: It is used to show the result of the instructions.  Output 

devices include monitor, printer, headphones, etc. 

4) Memory Unit: A memory unit is the collection of storage units or devices 

together. The memory unit stores the binary information in the form of 

bits. 

 

 

 

 

 

  

 

Q2: Discuss about the classification of computers based on size and capacity. 
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Ans: Classification of computers based on size and capacity are as follows:- 

1) Super Computers: These are most powerful and physically the largest by 

size and are designed to process huge amounts of data. The fastest 

supercomputers can perform over one trillion calculations on a second. 

Supercomputers have thousands of processors. Because of their 

extraordinary speed, accuracy and processing power, supercomputers are 

well suited for solving highly complex problems & huge amounts of 

calculations.  Some examples of supercomputer are JAGUAR, 

ROADRUNNER etc., 

2) Mainframe Computers: These are very large often filling an entire room 

and can process thousands of millions of instructions per second. In a 

mainframe environment, users connect to the mainframe through the 

many terminals wired to the mainframe. Mainframes are capable of 

supporting hundreds to thousands of users simultaneously. Some of the 

functions performed by a mainframe include: flight scheduling by a 

mainframe include: flight scheduling, reservations and ticketing for an 

airline etc. Some examples are IBM mainframes Z13, IBM Systems z9 

mainframe. 

3) Minicomputers: These are much smaller than mainframes. These 

computers are also less expensive. Sometimes referred to as Midrange 

Server or Midrange Computer. They are typically larger, more powerful and 

more expensive than desktop computers. Midrange computers are usually 

used by small and medium-sized businesses as their servers. Users connect 

to the server through a network by using desktop computers. Some 

examples are Apple iPod, CDC 160A. 

4) Microcomputers: These are the most frequently used type of computer. It 

is also, known as Personal Computer (PC). A microcomputer is a small 

computer system designed to be used by one person at a time. Some 

examples are desktop computer, laptops. 

Q3: What is the meaning of computer generation? How many computer 

generations are defined? What technologies were/are used? 



 
 

Ans: Generation in computer terminology is a change in technology a computer 

is/was being used. Initially, the generation term was used to distinguish between 

varying hardware technologies. Nowadays, generation includes both hardware 

and software, which together make up an entire computer system. 

There are five computer generations known till date. Each generation has been 

discussed in detail along with their time period and characteristics. In the 

following table, approximate dates against each generation have been 

mentioned, which are normally accepted. 

Following are the main five generations of computers. 

S. No. Generation & Description 

1 First Generation 
The period of first generation: 1946-1959. Vacuum tube based. 

2 Second Generation 
The period of second generation: 1959-1965. Transistor based. 

3 Third Generation 
The period of third generation: 
1965-1971. Integrated Circuit based. 

4 Fourth Generation 
The period of fourth generation: 1971-1980. VLSI microprocessor based 

5 Fifth Generation 
The period of fifth generation: 1980-onwards. ULSI microprocessor 
based. 

 

Q4: Differentiate between Volatile & Non-Volatile memories. 

Ans: Following are the important differences between Volatile and non-Volatile 

Memory. 

Volatile memory: It is also known as Primary Memory. It is a computer storage 

that only maintains its data while the device is powered. Ex: RAM is volatile. 

When we are working on a document it is kept in RAM and if the computer loses 

power all work will we lost. 

RAM (Random Access Memory) 

It is also called as read write memory or the main memory or the main memory. 

The program and data that the CPU requires during execution of a program are 

stored in this memory. It is volatile memory as the data loses when the power is 

turned off. 



 
 

 

Non-Volatile memory:  It is also known as Secondary Memory.  It is a type of 

computer memory that has the capability to hold saved data even if the power is 

turned off. 

Example: Read-only memory (ROM), Hard disk, floppy disk, etc. 

 

 ROM (Read Only Memory) 

It is nonvolatile. It stores crucial information essential to operate the system like 

the program essential to boot the computer. Always retain its data. Used in 

calculators and peripheral device. Used in embedded systems or where the 

programming needs no change.   

S.no.              RAM      ROM 
1 Temporary storage Permanent storage 

 2                Store data in MB’S Store data in GB’s 

3 Volatile  Non volatile 
4 Used in normal operations Used for startup process 

of computer 
5 Writing data is faster Writing data is slower 

 

Q5: Distinguish among system software, application software and open source 

software on the basis of their features. 

Ans:  

System Software Application Software Open Source Software 

It is a type  of software 
that is designed to run a 
computer’s hardware and 
application 

It is software created for 
a specific purpose, used 
by end users. It can be 
called an application or 
simply an app. 

Open source technology 
is defined as 
development of software 
for allowing end users 
and developers to not 
only see the source code 
of software, but modify it 
as well. 

Software like opera ting 
systems, compilers, 
editors and drives etc., 
come under this category. 

Examples: Word 
processor, accounting 
application, a web 
browser, an e-mail client, 

 In this source code is 
released under a license 
in which the copyright 
holder grants users rights 



 
 

media player etc. to study change and 
distribute the software to 
anyone and for any 
purpose. 

A computer cannot 
function without the 
presence of system 
software. 

 The Linux operating 
system (OS) is the best-
known examples of open 
source software. 

If we think of the 
computer system as a 
layered model, the 
system software is the 
interface between the 
hardware and user 
applications. 

  

 

Q6 (a): Create a file in MS-word to insert a paragraph about yourself and save it 

with file name “yourself”. Describe all steps involved in it. 

Ans: To create a new document: 

❖ Click the Microsoft Office button/File tab. 

❖ Select New. The New Document dialog box appears. 

❖ Select Blank Document. It will be highlighted be default. 

❖ A new blank document appears in the Word window. 

❖ Now write a paragraph about “yourself”. 

❖ Click the Microsoft Office button/File tab. 

❖ Select Save As – Word Document. 

❖ Select the location where you want to save the document using the drop-

down menu. 

❖ Enter the file name as “yourself” for the document. 

❖ Click the Save button. 

Q6 (b): Write steps regarding followings 

➢ To change the font style 



 
 

➢ To change the font size 

➢ To change the font color 

➢ To highlight (in yellow) the line that reads “need to get IMS’s address”. 

Ans: To change font style 

❖ Select the text you want to modify. 

❖ Click on font style box on the Home tab. The font style drop-down menu 

appears. 

❖ Move your cursor over the various font styles. 

❖ Left-click the font style you want to use. 

❖ Then font style will change in the document. 

 

To change the font size 

❖  Select the text you want to modify. 

❖ Click on font size box in the Font group on the Home tab. The font size drop-

down menu appears. 

❖ Move your cursor over the various font sizes. 

❖ Left-click on font size you want to use. 

❖ Then it will change font size in your document. 

 

To change font color: 

❖ Select the text you want to modify. 

❖ Click on the font color box on the Home tab. The font color menu appears. 

❖ Move your cursor over the various font colors. 

❖ Left-click the font color you want to use. 

❖ Then font color will change in the document. 

 

To highlight (in yellow) the line that reads “need to get IMS’s address”. 



 
 

❖ Type the text “need to get IMS’s address”. 

❖ Select the text. 

❖ Click on the Text Highlight color in font group on the Home tab. 

❖ Various colors will appears. 

❖ Move your cursor over the various colors. 

❖ Click on the yellow color. 

❖ Then our highlighted text i.e.  “need to get IMS’s address” will change in the 

document. 

Q7. Create a file in MS-Word for the following document and save it with file 

name ‘ms_word’. Describe all steps involved in it. 

 

Ans: 
❖ Write the above given text in Microsoft office word. 
❖ Select the text “MS Word” in the first row and click on Bold in the Home tab.   
❖ Select the text “MS Word” in the second row and click on the font color box on 

the Home tab. Left click on the red font color. 
❖ Select the text “word processor” in the second row and click on underline in 

the Home tab. 
❖ Select the text “MS Word” in the third row and click on Italic in the Home tab.   
❖ Select the text “creating” in the fourth row. Left click on the blue font color. 
❖ Select the text “saving” in the sixth row. Left click on the red font color. 
❖ Select the text “and” in the sixth row. Left click on the strikethrough option in 

the Home tab. 



 
 

❖ Click on the office button. Select the print option to print the document. 
 

 
 Q8. Create a file in MS-word for the following document and save it with file 
name ‘equations’. Describe all steps involved in it. 

 
Ans: 
❖ Write the above given equation in Microsoft office word. 
❖ For the first row equation click on subscript option in the Home tab. 
❖ For second row equation click on superscript option in the Home tab. 
❖ For third row equation click on superscript & subscript simultaneously option 

in the Home tab. 
Q9: Create a file in MS-word that convert existing highlight text to table as shown 
below and save it as file name ‘text_to_table’. Describe all steps involved in it.  

 
Ans:  
❖ Type the above given text in MS office word. 
❖ Select the given paragraph. 
❖ Click on the Table option in the Insert tab. 
❖ From the given options click on the text to table option 
❖ Select the rows and columns according to the requirement. 



 
 

❖ Click on the office button and click on the save as button. 
❖ Save the file with the name ‘text_to_table. Click on ok option. 
 
Q10: Create a file in MS-Word to insert a table in the document. Describe all steps 
involved in it. 
Ans: 
❖ Open a blank Word document. 
❖ In the top ribbon, press insert. 
❖ Click on the Table button. 
❖ Either uses the diagram to select the number of columns and rows you need, 

or click insert table and a dialog box will appear where you can specify the 
number of columns and rows. 

❖ The blank table will now appear on the page. Alter it as necessary. Standard 
features like bold, italics and underline are still available! These items may be 
helpful for creating headings or calling out certain items in the table. 

 
Q13 a) Describe various steps involved in the following  
➢ To modify column width of a worksheet 

Ans:  
❖ Select the column you want to change its height by clicking on Column letter. 

Place the mouse pointer on left-side or right-side gridline of the column letter 
until the mouse pointer turns to a double-sided arrow. You need to place the 
mouse pointer on left-side or right-side gridline depending on to left or right 
direction you want to change the Column width.  

❖ Drag the mouse till the desired width is reached and then drop the mouse to 
change the Column width. As you drag, Excel will keep displaying the changing 
Column width as tooltip message. 
❖ to modify the row height of a worksheet 

❖ Select the rows whose height you want to change. 
❖ To select an entire row, click on the row number on left. If you want to adjust a 

single row, click any cell in that row. 
❖ To manually change the row height, position the mouse pointer on the bottom 

boundary of the row heading until it turns into a double-sided arrow. Drag 
until the row is the height that you want. 

❖ To set a row height to a specific setting, choose Format- Row Height on the 
Home tab. Type the exact height you want in the Row Height dialog box; then 
click OK. 
➢ to delete rows and columns of a worksheet 



 
 

❖ Right-click in a table cell, row, or column you want to delete. 
❖ On the menu, click Delete Cells. 
❖ To delete one cell, choose Shift cells left or Shift cells up. 
❖ To delete the row, click Delete entire row. 
❖ To delete the column, click Delete entire column. 
 
Q13 b) Describe following terms in the worksheet  
➢ Absolute reference and relative reference in formula  
There are two types of cell references: relative and absolute. Relative and 
absolute references behave differently when copied and filled to other cells. 
Relative references change when formula is copied to another cell. Absolute 
references, on the other hand, remain constant no matter where they are copied. 
➢ Cell address  
A cell reference, or cell address, is an alphanumeric value used to identify a 
specific cell in a spreadsheet. Each cell reference contains one or more letters 
identify the column and the number represents the row 
Q14. a) What tools are available to customize our PowerPoint presentation? 

Ans:  1) Canva 

Canva makes design easy -- even for marketers and salespeople who feel 

like they're design-challenged. The platform gives you a bunch of 

presentation templates to use right away, and it's very easy to customize 

them to your organization and presentation objective. Plus, they have a new 

iPad app that makes it easy to whip up a presentation on the go. 

2) PowToon 

Often, being different is what attracts prospects and PowToon can help you 

do that in your presentations PowToon’s animation software lets you easily 

create animations with props, characters, and more -- which can help you 

differentiate your company when talking with prospects. 

3) PowerPoint 

For years, PowerPoint has been the standard in presentation software, but 

it hasn’t remained static. PowerPoint is full of features to make sales and 

marketing presentations dynamic and engaging. ( 

4) Oomfo 

A PowerPoint add-in, Oomfo helps sales and marketing pros create those 

oh-so-important interactive charts for presentations. Specialized charts, live 

https://twitter.com/canva
http://blog.canva.com/canva-ipad-app
http://blog.canva.com/canva-ipad-app
http://www.powtoon.com/
http://office.microsoft.com/en-us/powerpoint/
http://oomfo.com/


 
 

charts from multiple files, data from cloud applications, interactive options, 

one-click conversions -- it’s all possible, and more, with Oomfo. 

5) Keynote 

Apple’s Keynote allows users to work between their Mac and iOS devices, 

as well as with people who use Microsoft PowerPoint. With easy-to-use 

visual tools, drag and drop functionality, interactive charts, and more, 

Keynote is a popular choice among sales and marketing 

professionals.Sometimes, sales and marketing professionals need help 

creating presentations. Enter, Slide Bureau. With templates tailored to 

various professions, a template boutique with ample designs, and the 

ability to create on your iPad and then present in any browser or on any 

device, Slide Bureau is a perfect choice. 

7) Haiku Deck 

Available for the web or iPad, Haiku Deck has become a favorite of sales 

and marketing pros. With Haiku Deck, professionals can quickly create 

presentations that can be "easily projected, shared, posted, embedded on 

a website or blog, or viewed on any web-enabled device." Though it's 

another tool that helps you create presentations from scratch, it's ease-of-

use sets it apart from the rest. 

8) Projeqt 

Projeqt promotes “dynamic presentations for a real-time world,” because it 

lets you pull in feeds and create shortcuts to your favorite services, link and 

connect presentations, view on any device with a modern browser, and 

embed your presentation everywhere.  

9) emaze 

Busy sales and marketing pros choose emaze because it makes creating 

amazing presentations quick and easy. The options abound with emaze: 

Choose a professionally designed template and then create a slideshow, 

video presentation, or 3D presentation. 

10) Camtasia 

TechSmith’s Camtasia is an amazing tool that helps you create 

professional videos. You can record screen movements, import HD video 

from another source, customize and edit the video, and then share the 

completed video presentation on practically any device.  

11) SlideShare 

SlideShare is a popular choice for sales and marketing professionals 

looking for a way to share their content publicly. Because it already has a 

https://www.apple.com/mac/keynote/
https://www.haikudeck.com/
https://projeqt.com/
http://www.emaze.com/
http://www.techsmith.com/camtasia.html
http://www.slideshare.net/


 
 

built-in audience, you can easily distribute your presentation out to lots of 

people -- and those people can embed your SlideShares on websites and 

blogs, or share them on LinkedIn, Twitter, Facebook, etc. 

12) SlideDog 

Sometimes, sales and marketing professionals need to be able to move 

between presentation tools, but it’s not always possible because of their 

technical limitations. SlideDog is the solution, as it enables users to switch 

between PowerPoint, Prezi, PDF, web pages and others. 

13) Presentation Assistant 

Presentation Assistant lives up to its name: It assists professionals by 

enabling them to annotate, zoom, and more during a presentation. Sales 

and marketing professionals can clarify and emphasize points more clearly 

to their audience with Presentation Assistant. 

14) authorSTREAM 

Sales and marketing pros choose authorSTREAM to make their 

presentations dynamic and engaging. authorSTREAM allows users to 

share their PowerPoint presentations publicly or privately, broadcast them, 

convert them to video, communicate and collaborate about them, and 

more. 

15) Zentation 

With Zentation, salespeople and marketers combine video and slides into a 

simulated live experience. Presentations created with Zentation become 

webinars, webcasts, and virtual events for prospects and customers -- all 

great collateral for marketing and sales. 

16) Prezi 

Sales and marketing professionals love Prezi because it is cloud-based. 

Prezi makes creating, editing, and presenting from your browser, desktop, 

iPad, or iPhone possible anywhere, any time. 

17) Brainshark 

Sales reps and marketers often choose Brainshark, a cloud-based 

presentation tool, because it allows them to create and deliver 

presentations live or on-demand (even using their iPad or iPhone), use on-

demand video content, polls, or surveys for increased engagement, and 

embed presentations in websites and blogs. 

18) Vcasmo 

Vcasmo is a unique presentation tool -- it's a multimedia solution that 

enables users to synchronize a video and slideshow, side by side. Sales 

http://slidedog.com/?utm_expid=57005940-13.DZpOiprHS6eQv4vbII8GFQ.0&utm_referrer=http%3A%2F%2Fslidedog.com%2F
http://www.presentation-assistant.com/index.htm
http://www.authorstream.com/
http://zentation.com/index.php
http://prezi.com/
http://www.brainshark.com/
http://www.vcasmo.com/


 
 

and marketing pros love Vcasmo because it supports playback in three 

forms: browser, mobile, and iPad.  

19) ViewletBuilder 

ViewletBuilder is a different presentation tool; it captures critical screen 

updates and cursor position changes so sales and marketing pros can 

create presentations detailing how their product or sites work. With a 

plethora of features, ViewletBuilder allows for editing and enhancing and 

includes a variety of publishing and sharing options, too. 

20) Zoho Show 

Zoho Show is a top pick for sales and marketing pros because it lives 

online, making it possible to create, access, present, and more from 

anywhere, any time. The simple, intuitive interface and collaboration 

features are just two of its beloved benefits. 

 
Q14 b) Write the steps for the following action for creation of power point 
presentation  
Ans: 
➢ Open a Blank presentation 

1. Select the File tab to go to backstage view. 

2. Select New on the left side of the window, then click Blank 

Presentation or choose a theme. 

3. A new presentation will appear. 

➢ Save the presentation as Lab1.pptx  

Step 1 − Click on the File tab to launch the Backstage view and 
select Save. 

Step 2 − In the Save As dialog, type in the file name and click "Save". 

Step 3 − The default file format is .pptx. If you want to save the file with a 
different name, choose one of the file types from the "Save as type" 
dropdown list. 

Step 4  - Save the file with the name “Lab1.pptx”. 

Q15: Write steps for creation of a set of PowerPoint slides that demonstrates 
your skill to use the tools of PowerPoint. It should include the following things  
➢ Title slide &bullet list  

➢ Inserting Excel Sheet  

➢ Clip art and Text  

http://www.qarbon.com/presentation-software/viewletbuilder/
https://www.zoho.com/docs/presentation/features.html


 
 

➢ Slide show effects  
Ans:         Step 1: Launch the PowerPoint Program 

When you launch the PowerPoint program, you may be prompted to pick 
what kind of document you want to create.  Choose to create a blank 
presentation.  If it does not ask you this, a blank presentation will 
automatically launch. 

Step 2: Choosing a Design 

The next thing you want to do is decide what design you want for the 
presentation. To do this, go to the 'Design' tab at the top of the page. Scroll 
through all the options and decide which one looks best for the 
presentation you want. To get a preview of what the design will look like 
before applying it to the presentation, hover over the design you want to 
preview. This design will be automatically continued throughout the rest of 
your presentation. Once you have more than one slide, you can add a 
different design for just one slide. To do this, select the slide you want to 
change the design on by clicking on it. It will pop-up as the big slide in the 
screen. Then you can right-click the design you want for this slide and 
select 'Apply to Selected Slide'. It will appear on that slide, but will not 
change the design of the other slides. 

Step 3: Create Title Page 

Click the first box that says 'Click to add title' and add the title of your 
presentation.  Click the bottom box to add your name, or any other subtitle 
that you choose.  Once you have your text in the boxes, you can change 
their font, size, color, etc. with the toolbar options at the top.  You can 
change the size of the text box by selecting it, and then dragging the 
corners of the box.  To move the text boxes, select the box, and move your 
arrow over the border of the box.  A four-arrow icon will appear, and 
clicking with this icon will allow you to move the text boxes wherever you 
choose. 

Step 4: Add More Slides 

Chances are, you are going to need more than one slide.  There are a few 
ways you can add more slides.  Notice that there is a separate area to the 
left of the screen where your first slide is located.  The first way to add a 
slide is to right-click the area under where your first slide is located and 



 
 

select 'New Slide'.  A new slide will appear.  The second way to add 
another slide it to click 'New Slide' in the toolbar above the slides.  This 
button is divided into two parts,. The top will insert a new slide with a 
default layout.  You can also click the bottom half of this button, which will 
allow you to choose what type of layout you want.  You can choose a slide 
with two text-boxes and a title, one text-box, only a title, and many other 
options.  You will see your new slide appear to the left under the first, as 
well become the large slide that you can edit.  The design you picked 
earlier will have carried over to this slide.  The design will carry over for the 
rest of the slides you create unless you decide to change just one, like 
described earlier.  The guideline layout you chose will appear, and you can 
then add in your information. 

Step 5: Add Charts, Pictures, Graphs, Etc. 

If you want to insert a chart, picture, graph, or any other graphic, click on 
the 'Insert' tab at the top of the window.  Here you will see buttons of all the 
options of what you can insert into your slide.  Click the designated box and 
insert what it is you want to have on that slide.  A second way you can 
insert pictures and graphs is when you have an empty text or image box. 
 Little pictures of the same options you saw in the toolbox will show up in 
the middle of the box, and you can click any of these to insert as well. 
 Once you have your chart or picture, you can add a border or edit it 
however you want in the 'Format' tab. 

Step 6: Add Transitions 

To add transitions in between your slides, click the 'Animations' tab at the 
top of the page.  Here you can scroll through all the options of transitions, 
and hover over them to see a preview.  Select the slide you want the 
transition applied to, and then click the transition you chose.  You can do 
this for every slide, selecting the same or different transitions. 

Step 7: Changing the Order 

Once you have all your slides made, you can change the order of the 
slides.  To do this, click and drag the slides from where they are to where 
you want them in the order.  Another possibility, which is particularly useful 
if you presentation is longer, is to click the 'Outline' button.  You can find 
this small button above the left area where all your slides are located 
smaller, directly to the right of the 'Slides' button.  Here you will see a list of 



 
 

all your slides and you can click and drag your slides to where you want 
them. 

Step 8: Play the Presentation 

Once you have all your slides completed and in the order you want, view 
your slideshow.  Click the 'Slide Show' tab at the top of the page and select 
'From Beginning'.  You can go through your entire slideshow, and change 
slides by clicking or pressing the right arrow.  A shortcut to this is pressing 
F5.  Congratulations! You have now made a PowerPoint presentation. 

Part -2  

Q16: What is the difference between Machine Language and High Level 
Language? 

Ans: Machine language, or machine code, is the only language that is 

directly understood by the computer, and it does not need to be translated. 

All instructions use binary notation and are written as a string of 1s and 0s. 

A program instruction in machine language may look something like this: 

1. 10010101100101001111101010011011100101  

A high-level language is a programming language that uses English and 

mathematical symbols, like +, -, % and many others, in its instructions. 

When using the term 'programming languages,' most people are actually 

referring to high-level languages. High-level languages are the languages 

most often used by programmers to write programs. Examples of high-level 

languages are C++, Fortran, Java and Python. 

To get a flavor of what a high-level language actually looks like, consider an 

ATM machine where someone wants to make a withdrawal of $100. This 

amount needs to be compared to the account balance to make sure there 

are enough funds. The instruction in a high-level computer language would 

look something like this: 

1. x = 100  
2. if balance x:  
3.  print 'Insufficient balance'  
4. else:  
5.  print 'Please take your money'  



 
 

This is not exactly how real people communicate, but it is much easier to 

follow than a series of 1s and 0s in binary code. 

There are a number of advantages to high-level languages. 

The first advantage is that high-level languages are much closer to the 

logic of a human language. 

The second advantage is that the code of most high-level languages is 

portable and the same code can run on different hardware 

Q17. Discuss about different data types of C programming Language.  
Ans: Data types specify how we enter data into our programs and what 
type of data we enter. C language has some predefined set of data types to 
handle various kinds of data that we can use in our program. These 
datatypes have different storage capacities. 

C language supports 2 different type of data types: 

1. Primary data types: 

These are fundamental data types in C namely integer(int), floating 

point(float), character(char) and void. 

2. Derived data types: 

Derived data types are nothing but primary datatypes but a little twisted 

or grouped together like array, structure, union and pointer. 

 
Q18. Find the output of the following expressions  

a) X=20/5*2+30-5 
Output = 33 

b)  b) Y=30 – (40/10+6) +10 
Output=30 

c)   Z= 40*2/10-2+10  
Output=16 
 

 



 
 

Q19. Describe the syntax of the following statements  
a) If – else statement 

Ans: if(condition) { 
   // Statements inside body of if 
} 
else { 
   //Statements inside body of else 
} 

 
If condition returns true then the statements inside the body of “if” are 
executed and the statements inside body of “else” are skipped. 
If condition returns false then the statements inside the body of “if” are 
skipped and the statements in “else” are executed. 
b) For loop 
Ans: for (initialization statement; test expression; update 
statement) { 

1.  // statements 
2. } 

The for loop starts with a for statement followed by a set of parameters 
inside the parenthesis. The for statement is in lower case. Please note that 
this is case sensitive, which means the for command always has to be in 
lower case in C programming language. The initialization 
statement describes the starting point of the loop, where the loop variable 
is initialized with a starting value. A loop variable or counter is simply a 
variable that controls the flow of the loop. The test expression is the 
condition until when the loop is repeated. Update statement is usually the 
number by which the loop variable is incremented. 

c) While loop  

Ans: The syntax of a while loop in C programming language is − 

while(condition) { 

   statement(s); 

} 

Here, statement(s) may be a single statement or a block of statements. 
The condition may be any expression, and true is any nonzero value. The 
loop iterates while the condition is true. 



 
 

When the condition becomes false, the program control passes to the line 
immediately following the loop. 

 
d) Do-while loop  

Ans: The syntax of a do...while loop in C programming language is − 

do { 

   statement(s); 

} while( condition ); 

Notice that the conditional expression appears at the end of the loop, so 
the statement(s) in the loop executes once before the condition is tested. 

If the condition is true, the flow of control jumps back up to do, and the 
statement(s) in the loop executes again. This process repeats until the 
given condition becomes false. 

Q20. Find the output of the following program segments: 

a)  b)  c)  
#include <stdio.h>  
int main()  
{  
int i;  
for (i=1; i<2; i++)  
{  
printf( "IMS 
Ghaziabad\n");  
}  
}  

#include <stdio.h>  
int main()  
{  
int i = 1;  
while ( i <= 2 )  
{  
printf( "IMS 
Ghaziabad\n");  
i = i + 1;  
}  
}  

#include <stdio.h>  
void main()  
{  
int a = 10, b=100;  
if( a > b )  
printf( " 
else  
printf( "Largest number is 
%d\n”, b);  
}  

Ans:a) IMS Ghaziabad 
b)  IMS GhaziabadIMS GhaziabadIMS Ghaziabad  
c) Largest number is 100 
 
 
 

 
 


