
 

 

CCA-101 Fundamentals of IT & Programming 

Assignment -1 

 

Q1. What are the four fundamental parts of computer? Explain it with the help of diagram. 

Ans: The four fundamental parts of computer are; 

                    Input Unit, Central Processing Unit, Memory Unit, Output Unit. 

                        

                       

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

I. Input Unit: The devices to input information, such as Keyboard and Mouse. 

II. CPU: The CPU is further broken up into ALU, Control Unit and Instruction Unit. 

III. Memory Unit: A Unit for storage of data, instructions and information. 

IV. Output Unit: The devices to output information such as prints monitor and speaker. 

Q2. Discuss about the classification of computers based on size and capacity. 

Ans: The classification of computers based on size and computer are as follows: 

        CPU 

     CONTROL UNIT 

Arithmetic & Logical Unit 

MEMORY UNIT 

 

 

 

 

 

OUTPUT 
INPUT 



 

 

1) Super Computer:  

a) It has thousands of processors. 

b) Because of their extraordinary speed, accuracy and processing power, super computer 

are well suited for solving high complex problems and huge amount of calculations. 

c) Example: JAGUAR, ROADRUNNER, etc. 

2) Mainframe Computer:  

a) They are very large often filling an entire room and can process thousands of millions of 

instructions per second. 

b) In a mainframe environment, users connect to the mainframe through the many 

terminals wired to the mainframe. 

c) Mainframe are capable of supporting hundreds to thousands of users simultaneously. 

d) Some of the functions perform by a mainframe include: Flight, Scheduling, Reservation 

and Ticketing for an airline etc. 

e) Example: IBM mainframe Z13, IBM system z9 mainframe. 

3) Mini Computers: 

a) Mini computers are much more Smaller than mainframes. 

b) These computers are also less expensive. 

c) Sometimes referred to as Midrange Server or Midrange Computer. 

d) They are typically larger, more powerful and more expensive than desktop computers. 

e) Midrange computers are usually used by small and medium sized business as their 

servers. 

f) Users connect to the server through a network by using desktop computers  

4) Micro Computers: 

a) Micro computers are the most frequently used type of computer. 

b) It is known as Personal Computer (PC) 

c) A Micro Computer is a small computer designed to use by one person at a time. 

d) Example: Desktop computers, Laptops. 

Q3. What is the meaning of computer generation? How many computer generations are defined? What 

technologies were/are used? 

Ans: Generation in computer technology is a change in computer technology that is used. There are Four 

Generation in a computer: 

1. In the first computer system, vacuum tubes are used. 

2. Transistors are used in 2nd Generation 

3. Integrated Circuit Technology were used in 3rd Generation 

4. Microprocessors are used in in the 4th Generation. 

Q4. Differentiate between Volatile and Non – Volatile memories. 

Ans: Volatile memories: 

1. It is a computer storage that only mountains its data while device is powered. 

2. Example: RAM 

3. Primary Memory has limit storage capacity and its volatile. 



 

 

Non – Volatile  

1. It is a type of computer memory that has the capacity to hold saved data if the power is turn off 

2. Example: Rom, Hard- Disk, etc. 

3. Secondary memory provides permanent storage of data and in bulk capacity. 

Q5. Distinguish among system software, application software and Open-source software on the basis of 

their features. 

Ans: 1) System Software: It is a type of software designed to that is designed to run a computer hardware 

and application software like operating systems, editors and drivers etc. while 

         2) Application Software: It is a software created for a specific purpose, used by end users. It can be 

called application or simply an app. Example: Word Processor, Accounting application, web browser, an 

email client, etc. While    

         3) Open-source Software: It is a type of computer software in which source code is released under a 

license in which the copyright holder grants users right to study, change and distribute the software to 

anyone and for any purpose. The Linux operating system is the best example of open-source software. 

Q6.a) Created a file in MS-Word to insert a paragraph about yourself and save it with file name  

“yourself”. Describe all steps involved in it. 

b) Write steps regarding followings  

          *To change the font style  

          *To change the font size  

           *To change the font color 

           *To highlight (in yellow) the line that reads “need to get IM’S address”. 

Ans: a) The steps involve are:  

1. We click the Microsoft office button. 

2. We select new. The new document dialog box appears. 

3. We select blank document under the blank page and recent select. It will be highlight by 

Default  

4. We click created. A new blank document appears in the word window 

5. To save the document we click again the Microsoft office button 

6. We click Ctrl + S. The save as dialog box appears  

7. We select the location whereas went to save the document using the drop- down menu  

8. We enter the file name “yourself” for the document  

9. We click the save button. 

b) Steps to change the font size:  

1. We select the text or sentence. We want to modify  

2. We Left-click the drop-down arrow next to the font color box on the Home-Tab. The 

font color menu appears  



 

 

3. We move the cursor over the various font colors. A line preview of the color will appear 

in the document  

4. We left click the font the font color we want to use. The font will change in the 

document  

            C) Steps to change the font color: 

1. We select text or sentence we want to modify. 

2. We left click the Drop-down arrow next to the font color box on the home tab. The font 

color menu appears 

3. We move the cursor over the various font colors. A line preview of the color will appear in 

the document  

4. We left click the font color we want to use. The font will change in the document  

            D) To highlight (in yellow) the line that reads “need to get IMS’s address. 

1. We select the line that reads need to get IMS’s address 

2. We click the highlight command and select yellow color in the font group in the Home Tab  

Q7. Create a file in MS-Word for the following document and save it with files name ‘MS- Word ‘. 

Describe all steps involved in it. 

MS Word  

MS Word is a widely used commercial word processor developed by Microsoft  

MS Word is application software, which is capable of  

*Creating  

*Editing  

*Saving  

*Printing any type of document  

Ans: The steps involve in it are: 

1. We click Microsoft office button  

2. We select New. The new document dialog box appears. 

3. We select blank Document under the blank and recent section. It will be highlighted by defaulted  

4. We click create. A new blank document appears in the word window  

5. We create the given documents from the question  

6. We select the text “MS WORD” to change the font size by clicking on the font size box on the 

Home Tab. 

7. We select the text “MS WORD” to change the font color into red by clicking on the font color 

Menu  

8. We select the text “Word Processor” and underline it by clicking underline Command in the font 

Group on the Home Tab  

9. We select the text we want to format as a list and click the bullet commands on the Home Tab 

10. We save the file name as “MS WORD” by clicking the Microsoft office button and Select Save As  



 

 

11. We select the location where we want to save the document using the drop-down Menu. 

Q8. Create a file in MS- Word for the following document and save it with the file name ‘equations’ 

Describe all steps involved in it. 

 EQUATIONS 

X2 + Y5 = 30 

Z3 + Q4 = 50  

A2 + B8 = X2 + Y8 

Ans: 1) We first open the MS-Word then we should write the X2 by typing X and pressing (Ctrl ++) 

           Then we type 2 by just clicking insert tab and then click on the equation tool then select subscript 

and filling it  

2) Same process as X2 we write Y5  

3) Then when we write Z3, first we type Z then pressing (Ctrl+ Shift + +) and type 3/ just clicking the insert 

Tab and then selecting Subscript and filling it  

4) Again as the same process of Z3 first we type Q4 

5) Like the above process we can A2, B8, X2 and Y8 

6)After that we save the page by clicking (Ctrl +S)/ selecting save by clicking file then name it a ‘equation’ 

and save it. 

Q9. Create a file in MS-Word that convert existing highlight text to table as shown below and save it as 

File name ‘Text to Table’. Describe the steps involve in it. 

          Select the text you want to convert  

          Select the Insert Tab  

         Click on Table Command. A dialog box appears  

         Click on convert text to table, a new dialog box appears 

Select the text you want to convert  Select the Insert tab  

Click on Table Command. A dialog box 
appears  

Click on Convert Text to Table, a new dialog 
box appears  

Here set number of columns   

  

                    Here set no. of columns  

                     Click on Ok finally selected text in a table  

 



 

 

   Ans: 1. At First, we select the existing highlight words 

            2. Then we select the Insert Tab 

            3. Then click on the Table Command, then a dialog box appears  

            4. Then, we click on the table, then again dialog box appears  

            5. We will set the column which we want to make for the table  

            6. Then finally selected Ok and the word we select will fill on the table automatically  

            7. After this we will save it by pressing (Ctrl+ S) selecting file Tab then ‘Save’ and name it as ‘Text 

to Table’ Then we save it.   

Q10. Create a file in MS- Word to Insert a table in the document. Describe all steps involve in it. 

Ans: The Steps are:  

I. We place our cursor point in the document where we want the table to appear  

II. We select the Insert Tab  

III. We click the table  

IV. We drag our mouse over the diagram square to select the no. of columns and rows in table 

V. Left click the mouse and the table appears in the document  

VI. We enter the text into the table  

Q11.Ans:   

   

Roll NO. NAME MARKS 

1 n1  60 

2 n2 70 

3 n3 80 

4 n4 90 

5 n5 40 

6 n6 50 

7 n7 77 

8 n8 44 

9 n9 88 

10 n10 55 

   
 

Q12  
Ans.  

Roll NO. NAME MARKS 

1 n1  60 

2 n2 70 



 

 

3 n3 80 

4 n4 90 

5 n5 40 

6 n6 50 

7 n7 77 

8 n8 44 

9 n9 88 

10 n10 55 

      

  total 654 

  average 65.4 

  highest 90 

  minimum 40 

 

Q13.  
Ans:  

a) To modify the column width of a worksheet 

1.  We identify the column width we want ton resize  

                2.However, the mouse on the right boundary of that column so that we see across 

                 3. We hold down the mouse button and we drag the right boundary until we reach the desired 

width            

                4.And we release the mouse button  

     To modify the row height of a worksheet  

              1.We select the row we want to change  

             2.On the home Tab in the cell group, we click format 

             3.Under cell size, we click row height  

             4. In the row height box type we type the value and then OK  

To delete and columns of a worksheet  

             1.We right click in a table cell, row and column we want to delete 

             2.On the menu, we click delete cell  

     b) Absolute reference and relative reference in formula 

           Relative reference change when a formula is occupied to another cell. Absolute reference on the 

Cell Address. 



 

 

            Cell Address is a combination of a column letter and a row number that identifies a cell on a 

worksheet.  

Q14. a) What tools are available to customize our power point presentation? 

Ans: They are  

1) Home 

2) Insert  

3) Design  

4) Transition  

5) Animation 

6) Slide Show  

7) Review  

8) File  

9) Tools Tab  

b) Write the steps of the following action for creation of power point presentation? 

➢ Open a blank presentation  

➢ Save the presentation as Lab1. Pptx 

➢ Add a title of the first slide: The name of your college  

➢ Type your First Name and Last Name in the subtitle section  

➢ Add a New Slide which has a title and content  

Ans: Blank Presentation:  

1. We Select the file Tab to go backstage view. 

2. We select new on the left side of the screen and then we click blank presentation  

3. A new presentation appears. 

Save the presentation as Lab1.pptx:  

             We click the file tab to access backstage view. We locate and select the convert command. The 

save as dialog box appears. We Select the location where we want to save the presentation enter a file 

name, and we click save. 

Add a tittle to the first slide:  

             To add a tittle to the first slide to an existing, we go to the home tab and we click layout then 

the tittle only. 

Add a new slide which has a tittle and content: 

              In the slide thumbnail on the left, the slide that we want our slide to follow. On the Home Tab, 

we click new slide. 

 

Q15. Write steps for creation of a set power points slides that demonstrates your skill to use the tools 

of PowerPoint. It should include the following things 



 

 

➢ Tittle slide & Bullet list  

➢ Inserting excel sheet  

➢ Clip art & text  

➢ Slide show effects 

Ans: Tittle slide & Bullet list: 

                     On the view Tab, we click normal. Then, we Click in the text box or the place where you want 

to add bulleted number text. On the Home Tab, in the paragraph group, we click bullet or numbering 

and begin typing the list. Then, we press return to create a new list item. 

                      To add a slide title to an existing slide we go to HOME tab and we Click layout then title 

only. Then we press the cursor in the click to add tittle box on the slide and slide and we type in our 

unique slide tittle. 

Insert excel sheet:  

In PowerPoint, on the Insert Tab, we click or Tab object dialog box select create from file. We click or 

Tab browse, and in the browse box we find the excel workbook with the data we want to insert. 

Before we close the Insert object box, select link and click Ok. 

Click Art and Text:   

              We click in the slide where you want insert a clip art file. On the Insert Tab in the image group, 

then click online pictures. In the Insert picture dialog box enter your search terms in.  

Slide show Effect:  

           We select the object or text you want to animate. Select animation choose an animation. We 

select effect option and we choose an effect.   

 

Q16. What is the difference between Machine Language and high-level language? 

Ans:  

Machine Language  High Level Language  

A computer programming language consisting 
of binary instruction which a computer can 
response to directly. 

A high-level language is a programming 
language that enables development of a 
program in a much more user-friendly 
programming context. 

Sometimes it is referred to as machine code or 
object code. Machine Language is a collection 
of binary digits or bits that the computer reads. 

This language is a programming language with 
strong abstraction about the details of the 
programming language. 

Example: 01001000, 011001100, 01101100 Example: C, C++, Java 

 

Q17. Discuss about difference between data type of C programming language. 



 

 

Ans: The different data type of c programming language are: Each variable in a C has an associated data 

type. Each data type requires different amount of memory & some specific operations which can be 

performed over it. Let us briefly describe one by one. 

            Following are the example of some very common data types used in C. 

1. Char: The most basic type in C. It stores a single character and requires a single byte of memory 

in almost all compilers. 

2. Int: As the name suggests, an int variable is used to store an integer. 

3. Float: It is used to store decimal numbers (Numbers with floating point value) 

4. Double: It is used to store decimal numbers (numbers with floating point value but its range of 

value is high in comparison to float. 

 

Q18. Find the output of the following expressions 

a. X=20/5x2+30-5 

b. Y=30-(40/10+6) +10 

c. Z=40x2/10-2+10 

Ans: a) X= 20/5x2+30-5 

              X= 4x2 + 30-5 = 8+30-5 =33 

               X= 33 

            b) Y= 30-(40/10+6) +10 

                 Y= 30-(4+6) + 10 =30-10+10= 30-20 

                 Y=10 

            C) Z=40x2/10-2+10  

                 Z=40x0.2+ 10 = 200-2+10= 200-12 

                  Z=320-2+10 = 320-12 

                 Z= 188.16    

        

  Q19. Describe the syntax of the following statements 

a) If – else statement b) for loop c) While loop d) do-while loop 

Ans: a) If -else statement: If statement can be followed by optional else block of statements, which 

executes when the Boolean expression is false  

           Syntax 

If (expression)  



 

 

{true Block of statements, 

} 

Else  

{else Block of statements) 

}  

b) For Loop is similar to while basic syntax of for is as follows for (expressions1; expression2; expression3) 

{ 

Block of statements; 

} 

In the above syntax: 

{  

Block of statements; 

} 

In the above syntax:  

1. Expression1 – Initializes variable  

2. Expression2 – Conditional expression, as long as this condition is true, loop will keep executing. 

3. Expression3 – It modifies which will increase or decrease the value of the variable. 

C) While loop: Basic syntax of while loop is as follows  

              While(condition) 

                      Single statement; 

d) Do – while loop: -while s just like a while loop except that the test condition is checked at the end of 

the loop rather than the start. This has the effect that the body of the loop are always executed 

at least once. 

               Basic syntax to do – while loop is as follows; 

                       Do  

                 {single statements 

                 } while (condition): 

Q20. 
Ans:  

1. IMS Ghaziabad  

2. IMS Ghaziabad 



 

 

IMS Ghaziabad 

IMS Ghaziabad  

              Largest no is 100 

 

 

 

   

                

 

 

            

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 



 

 

 


