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1.  Four Fundamental Parts of Computer (with Diagram). 

The four fundamental parts of a computer are: 

 Input Unit – Devices like keyboard, mouse used to give data to the computer. 

 Processing Unit – CPU (Central Processing Unit), which processes data. 

 Memory/Storage Unit – Stores data temporarily (RAM) or permanently (Hard Drive, 

SSD). 

 Output Unit – Devices like monitor, printer that display processed data. 

Diagram: 

[Input Unit] → [Processing Unit (CPU)] ↔ [Memory/Storage] 

↓ 

[Output Unit] 

 

2. classification of Computers Based on Size and Capacity 

 microcomputers (Personal Computers): For personal use; low processing power (e.g., 

laptops, desktops). 

 Minicomputers: Mid-range computers; used in small businesses for specific tasks. 

 Mainframe Computers: Large systems for handling big data and multiple users (e.g., in 

banks). 

 Supercomputers: Very powerful; used in research, weather forecasting, etc. 

 Workstations: High-performance systems for technical/scientific tasks. 

 

 

3. Computer Generation Meaning and Technologies 

 Computer Generation refers to the evolution of computer technology over time. 

Five Generations: 



1. 1st Gen (1940–1956): Vacuum Tubes 

2. 2nd Gen (1956–1963): Transistors 

3. 3rd Gen (1964–1971): Integrated Circuits 

4. 4th Gen (1971–Present): Microprocessors 

5. 5th Gen (Present & Beyond): Artificial Intelligence, Quantum Computing 

 

4. Differentiate between Volatile & Non- Volatile memories 

Volatile Memory: 

 Requires power: Needs a constant power supply to store information. 

 Temporary storage: Primarily used for running programs and storing temporary data 

while the computer is operating. 

 Faster access: Generally faster than non-volatile memory but has a limited capacity. 

 Examples: Random Access Memory (RAM) and cache memory. 

Non-Volatile Memory: 

 Retains data without power: Maintains data even when the power is off.  

 Long-term storage: Suitable for storing files, programs, and operating systems. 

 Lower access speed: Generally slower than volatile memory but has a larger storage 

capacity. 

 Examples: Solid State Drives (SSDs), hard disk drives (HDDs), flash drives, and Read-Only 

Memory (ROM). 

 

5. Distinguish among system software, application software and open source software on the 

basis of their features. 

 System software manages the computer's resources and provides a platform for 

application software, while application software performs specific tasks for users. Open-

source software, a type of application software, has its source code publicly available for 

modification and redistribution. 

System Software: 



 Purpose: Manages and controls computer hardware and resources, providing a platform 

for other software to run. 

 Examples: Operating systems, device drivers, and utility programs. 

 Features: 

 Manages memory, CPU usage, and input/output devices. 

 Provides a foundation for application software to function. 

 Works in the background, often unseen by the end user. 

 Requires minimal interaction from the user. 

 Can run independently of application software. 

 Examples include managing file systems, handling network communications, and 

providing a user interface. 

 Application Software: 

 Purpose: Designed to perform specific tasks for users, such as writing documents, 

browsing the web, or playing games. 

 Examples: Word processors, web browsers, photo editors, and game engines. 

 Features: 

 Interacts directly with the user. 

 Provides a user interface for interacting with the software. 

 Dependent on system software for operation. 

 Examples include creating documents, browsing the web, or playing games. 

 Can be categorized into different types, including general-purpose applications (word 

processors, spreadsheets) and specialized applications (accounting software, CRM 

systems). 

 Open Source Software: 

 Purpose: A type of application software where the source code is publicly available for 

anyone to view, modify, and redistribute. 

 Examples: Linux, Firefox, Apache Server. 

 Features: 

 Collaboration: Encourages collaboration and transparency among developers. 

 Flexibility: Users can customize and modify the software to meet their specific needs. 

 Transparency: The source code is open for everyone to see, making it easier to identify 

and fix bugs. 

 Cost-effectiveness: Often free to use, modify, and redistribute, reducing licensing costs.  

 Community Support: Typically has a large community of developers and users who 

contribute to its development and provide support. 

 Examples include operating systems, web browsers, and development 



 

 

6. A). create File in MS Word Named “yourself” 

 

Steps: 

 

 Open MS Word. 

 Type a paragraph about yourself. 

 Click on File > Save As. 

 Choose location. 

 Enter filename as “yourself”. 

 Click Save. 

 

6. b) : Word Formatting Steps 

 

Change Font Style: 

Select text > Home tab > Font dropdown > Choose style. 

 

Change Font Size: 

Select text > Home tab > Size dropdown > Choose size. 

 

Change Font Color: 

Select text > Home tab > Font Color icon > Choose color. 

 

Highlight a Line: 

Select “need to get IMS’s address” > Home tab > Text Highlight Color > Yellow. 

 



 

 

7.  Create a file in MS-Word for the following document and save it with file name ‘sword’. 

Describe 

all steps involved in it. 

 Open MS Word. 

 Create the required document. 

 Click File > Save As. 

 Choose location. 

 Type filename: ms_word. 

 Click Save. 

 

8. Create a file in MS-word for the following document and save it with file name ‘equations. 

Describe 

all steps involved in it. 

 To create an MS Word file named "equations", start by opening a new blank document 

and then save it using the "Save As" option, selecting a desired location and file name, 

and choosing the desired file format (e.g., .docx). Finally, click the "Save" button to 

finalize the process. 

Here's a step-by-step guide: 

1. Open MS Word: 

Launch the Microsoft Word application. 

2. Create a New Document: 

Click on "File" and then select "New" or press Ctrl+N. 

Choose "Blank document" or double-click a template image. 

3. Type or Paste Content: 

Enter your desired text, equations, or other content into the blank document. 

4. Save the Document: 

Click on "File" and then select "Save As" or press Ctrl+S. 



Choose a location (e.g., Documents, Desktop) for saving the file. 

In the "File name" box, type "equations" to name the file. 

Select the desired file format (e.g., .docx, .doc) in the "Save as type" dropdown menu. 

Click the "Save" button to finalize the process. 

 

9. Create a file in MS-word that convert existing highlight text to table as shown below and save 

it as 

file name ‘text_to_table’. Describe all steps involved in it. 

 

Step 1: Create a New Document 

1. Open MS-Word and create a new document. 

2. Type some text and highlight the text that you want to convert to a table. 

 

Step 2: Select the Highlighted Text 

1. Select the highlighted text by dragging your mouse over it. 

2. Make sure that only the highlighted text is selected. 

 

Step 3: Convert Text to Table 

1. Go to the "Insert" tab in the ribbon. 

2. Click on the "Table" button in the "Tables" group. 

3. Select "Convert Text to Table" from the drop-down menu. 

4. In the "Convert Text to Table" dialog box, select the options as follows: 

- Separate text at: Select "Tabs" or "Commas" depending on how your text is separated. 

- Table style: Select a table style from the list. 

- AutoFit behavior: Select "AutoFit to contents" or "AutoFit to window" depending on your 

preference. 



5. Click "OK" to convert the text to a table. 

 

Step 4: Format the Table 

1. Select the table by clicking on it. 

2. Go to the "Table Tools" tab in the ribbon. 

3. Use the tools in the "Table Styles" group to format the table as desired. 

 

Step 5: Save the Document 

1. Go to the "File" tab in the ribbon. 

2. Click on "Save As" and select a location to save the document. 

3. In the "Save as type" field, select "Word Document (.docx)". 

4. In the "File name" field, type "text_to_table". 

5. Click "Save" to save the document. 

 

10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in it.  

 

 

 

 

 

 

 

 

 

 



 

 

11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

 

 To create a new Excel worksheet and save it as "book1", open Excel, select a blank 

workbook or use a template, then save the file with the name "book1". 

Steps to create a new worksheet and save it: 

1. Open MS Excel: 

Launch the application. 

2. Create a new workbook: 

You can either start with a blank workbook or select a template from the "New" option.  

To create a blank workbook, select "Blank workbook" or press Ctrl+N. 

3. Rename the worksheet (optional): 

By default, the first worksheet is named "Sheet1". 

You can rename it by double-clicking on the sheet tab or right-clicking and selecting "Rename". 

4. Save the workbook: 

Click on File > Save As. 

In the "Save As" dialog box, choose a location to save the file. 

Enter the filename as "book1" in 

the "File name" field. 

Click "Save" to save the workbook. 

 

 

 

 

 



 

 

12 . Calculate the following things of a range (C2:C11) of data in the worksheet created in 

question no 

10. 

  the sum of the marks using AutoSum in a range of cells (C2:C11) 

  average of the marks in a range of cells (C2:C11) 

  highest marks in a range of cells (C2:C11) 

  minimum marks in a range of cells (C2:C11) 

 

1. Calculate the Sum Using AutoSum 

Steps: 

 

 Click in cell C12 (just below C11). 

 Go to the Home tab. 

 Click on the AutoSum (Σ) button. 

 Press Enter. 

 Result: It will automatically insert the formula: 

 =SUM (C2:C11) 

 

2. Calculate the Average of Marks 

Steps: 

 Click in cell C13. 

 Type the formula. 

 =AVERAGE(C2:C11) 

 Press Enter. 

 

3. Find the HighestMarks 

Steps: 



 Click in cell C14. 

 Type 

 =MAX(C2:C11) 

 Press Enter. 

 

4. Find the Minimum Marks 

Steps: 

 Click in cell C15. 

 Type: 

 =MIN(C2:C11) 

 Press Enter. 

 

13. a) Describe various steps involved in the following 

  To modify column width of a worksheet 

  To modify the row height of a worksheet 

  To delete rows and columns of a worksheet 

 

1. To Modify Column Width in a Worksheet 

Steps: 

 Open your Excel worksheet. 

 Select the column(s) you want to modify (e.g., click on column header “C”).  

 Go to the Home tab. 

 Click on the Format dropdown in the Cells group. 

 Select Column Width. 

 Enter the desired width (e.g., 15) and click OK. 

 

 

Alternative method: 

Move your mouse pointer to the boundary between two column headers (e.g., between C and 

D), then click and drag to resize. 



 

 

2. To Modify Row Height in a Worksheet 

Steps: 

 Select the row(s) you want to change (e.g., click on row number “3”). 

 Go to the Home tab. 

 Click Format in the Cells group. 

 Choose Row Height. 

 Enter the new height (e.g., 25) and click OK. 

 

Alternative method: 

Drag the boundary between row numbers to resize manually. 

 

3. To Delete Rows and Columns in a Worksheet 

 

To delete a row: 

 Select the entire row by clicking the row number (e.g., “5”). 

 Right-click and select Delete. 

To delete a column: 

 Select the entire column by clicking the column letter (e.g., “B”). 

 Right-click and choose Delete. 

 

Alternatively: 

Use Home > Delete in the ribbon and choose either Delete Sheet Rows or Delete Sheet 

Columns. 

 



 

 

1. Absolute Reference and Relative Reference in Formula: 

 

Relative Reference: 

A relative reference in a formula changes when the formula is copied to another cell. It refers to 

the position of a cell relative to the cell that contains the formula. 

Example: If you write =A1 + B1 in cell C1 and copy it to C2, it will change to =A2 + B2. 

 

Absolute Reference: 

An absolute reference does not change when the formula is copied to another cell. It uses a 

dollar sign ($) to fix the column and/or row. 

Example: =$A$1 + B1 will always refer to cell A1 no matter where the formula is copied. 

 



 

2. Cell Address: 

 

A cell address is the specific location or name of a cell in a worksheet, identified by its column 

letter and row number. 

Example: In cell address B2, "B" is the column and "2" is the row. 

 

 

14. a) What tools are available to customize our PowerPoint presentation? 

 

1. Themes and Templates: 

Pre-designed slide layouts that set colors, fonts, and background styles to give a consistent look 

to your presentation. 

2. Slide Master: 

Allows you to edit the layout, background, fonts, and effects for the entire presentation in one 

place. 

3. Transitions: 

Visual effects applied when moving from one slide to another, helping enhance flow and 

engagement. 

4. Animations: 

Effects applied to text, images, or objects to control how they appear, move, or disappear 

during the presentation. 

5. Design Tools: 

Includes features like background formatting, font styles, color schemes, and alignment tools to 

make slides visually appealing. 

6. Insert Options: 

You can insert images, videos, audio, charts, SmartArt, and shapes to make your slides more 

interactive. 



 

7. Slide Layouts: 

Customize slide content arrangement using predefined or manually adjusted layouts.  

8. Header and Footer: 

Add date, slide numbers, and custom text at the top or bottom of slides. 

9. Slide Show Tools: 

Customize how the presentation runs with options like setting timings, rehearsing, and 

recording narrations. 

 

14. b) Write the steps for the following action for creation of power point presentation Sure! 

Please specify which action you want the steps for in the creation of a PowerPoint presentation. 

For example: 

 

 Inserting a new slide 

 Adding text or images 

 Applying transitions or animations 

 Saving the presentation 

 Running the slideshow 

 

15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to use 

the tools of PowerPoint. It should include the following things 

  Title slide &bullet list 

  Inserting Excel Sheet 

  Clip art and Text 

  Slide show effects 

Create a Title Slide & Bullet List: 

 Open Microsoft PowerPoint. 

 Click on “Blank Presentation”. 

 The first slide is usually a Title Slide. Enter your presentation title and subtitle.  



 To add a bullet list, go to Home > New Slide > Title and Content 

 Click inside the content box and type your points. Use the bullet list option from the 

toolbar. 

 

2. Insert an Excel Sheet: 

 Go to a new slide: Home > New Slide > Title and Content. 

 Click Insert > Table > Excel Spreadsheet. 

 An Excel window will appear inside the slide. Enter your data. 

 Click outside the spreadsheet to close the editing mode. 

 

3. Insert Clip Art and Text: 

 

 Go to a new slide. 

 Click Insert > Pictures or Online Pictures to add clip art. 

 Choose and insert the image. 

 Use Insert > Text Box to add custom text next to the image. 

 

4. Apply Slide Show Effects: 

 Select the slide you want to animate. 

 Go to the Transitions tab and choose a slide transition effect. 

 use the Animations tab to apply effects to text or objects. 

 Use Slide Show > From Beginning to preview your presentation. 

 

 

Part -2 

 

16. What is the difference between Machine Language and High-Level Language? 

Machine Language 



 Binary code: Machine language consists of binary code (0s and 1s) that the computer's 

processor understands directly. 

 Low-level: Machine language is a low-level language, meaning it is closely tied to the 

computer's hardware and architecture. 

 Specific to hardware: Machine language is specific to a particular computer hardware 

platform and is not portable across different platforms. 

 Difficult to program: Machine language is difficult for humans to program and 

understand due to its binary nature. 

 

High-Level Language 

1. Symbolic code: High-level languages use symbolic code, 

[02/05, 12:16 pm] Meta AI: Machine Language and High-Level Language are two types of 

programming languages that differ in their characteristics, usage, and interaction with 

computer hardware. 

 

Machine Language 

 Binary code: Machine language consists of binary code (0s and 1s) that the computer's 

processor understands directly. 

 Low-level: Machine language is a low-level language, meaning it is closely tied to the 

computer's hardware and architecture. 

 Specific to hardware: Machine language is specific to a particular computer hardware 

platform and is not portable across different platforms. 

 Difficult to program: Machine language is difficult for humans to program and 

understand due to its binary nature. 

 

High-Level Language 

 Symbolic code: High-level languages use symbolic code, such as keywords, syntax, and 

semantics, that are easier for humans to understand and program. 

 Platform-independent: High-level languages are platform-independent, meaning they 

can be compiled or interpreted on different computer hardware platforms. 

 Easier to program: High-level languages are easier for humans to program and 

understand due to their symbolic nature and abstraction from hardware details. 



 Requires translation: High-level languages require translation (compilation or 

interpretation) to machine language before they can be executed by the computer's 

processor. 

 

17. Discuss about different data types of C programming Language. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

18. Find the output of the following expressions: 

Let’s solve each one step by step using standard operator precedence: 

(, /, *, +, –) 

 

a) X = 20 / 5 * 2 + 30 - 5 



Step-by-step: 

20 / 5 = 4 

4 * 2 = 8 

8 + 30 = 38 

38 - 5 = 33 

Output: X = 33 

 

b) Y = 30 – (40 / 10 + 6) + 10 

Step-by-step: 

Inside brackets: 40 / 10 = 4 

4 + 6 = 10 

30 - 10 = 20 

20 + 10 = 30 

Output: Y = 30 

 

c) Z = 40 * 2 / 10 - 2 + 10 

Step-by-step: 

40 * 2 = 80 

80 / 10 = 8 

8 - 2 = 6 

6 + 10 = 16 

Output: Z = 16 

 

 

19. Describe the syntax of the following statements 

a) If-else statement b) for loop c) while loop d) do- while loop 



a) If-Else Statement: 

 

if (condition) { 

// code to execute if condition is true 

} else { 

// code to execute if condition is false 

} 

 

Example: 

 

if (a > b) { 

print ("A is greater"); 

} else { 

print ("B is greater"); 

} 

 

 

b) For Loop: 

 

for (initialization; condition; increment/decrement) { 

// code to repeat 

} 

 

Example: 

 

for (int I = 0; I < 5; I++) { 

print ("%d\n", I); 

} 

 

c) While Loop: 

 

while (condition) { 

// code to repeat as long as condition is true 

} 

 

Example: 

 

int I = 0; 



while (I < 5) { 

print ("%d\n", I); 

I++; 

} 

 

d) Do-While Loop: 

 

do { 

// code to execute at least once 

} while (condition); 

 

Example: 

 

int I = 0; 

do { 

print ("%d\n", I); 

I++; 

} while (I < 5); 

 

 

20. find the output of the following program segments 

 

a) # include <studio’s> 

Int main () 

{ 

Int I; 

For (I=<2; I++) 

} 

Print (“IMS Ghaziabad\n”); 

} 

} 

# include <studio’s> 

Int main () 

{ 

Int I; 



For (I=<2; I++) 

} 

Print (“IMS Ghaziabad\n”); 

} 

} 

Explanation: 

 

The for loop runs from I = 0 to I < 2, so it executes 2 times. 

Each time, it prints: IMS Ghaziabad 

  

b) 

 

#include <stdio.h> 

int main() 

{ 

int i = 1 

while (i <= 2) 

{ 

printf("IMS Ghaziabad\n"); 

i = i + 1 

} 

} 

A simple C program! 

Here's the output: 

IMS Ghaziabad 

IMS Ghaziabad 

 



Explanation: 

 

 The program initializes a variable i to 1. 

 The while loop checks if i is less than or equal to 2. Since i is 1, the condition is true.  

 The program prints "IMS Ghaziabad" to the console. 

 The value of i is incremented by 1, making it 2. 

 The while loop checks the condition again. Since I am still less than or equal to 2, the 

condition is true. 

 The program prints "IMS Ghaziabad" to the console again. 

 The value of I is incremented by 1, making it 3. 

 The while loop checks the condition again. Since I am now greater than 2, the condition 

is false, and the loop exits. 

 

Therefore, the program prints "IMS 

Ghaziabad" twice to the console. 

 

 

c) 

##include <stdio.h> 

void main () 

{ 

int a = 10 b = 100 

if(a>b) 

print (“Largest number is %d\n", a); 

else 

print ("Largest number is %d\n", b); 

} 


