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Q1 What are the four fundamental parts of computer? Explain with the help of diagram. 

Answer: Four fundamental parts of computer are: 

       i)Input unit 

      ii)the central processing unit or CPU 

     iii)The primary memory 

     iv)Output unit 

i)INPUT UNIT:  Input unit is used to feed any form of data to the computer which can be stored in the 

memory unit for further processing. 
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ii)Central processing unit or CPU: CPU is the major component which interprets and executes software 

instructions. It also controls the operation of all other component as memory, input and output.  
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iii)The primary memory: Once the CPU convert a specific set of computer program instruction into a 

machine code it stores that machine code in primary storage or memory. 
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iv)output unit: Output unit are the devices of computer uses to relay information  

to the user such as a printer, monitors and speaker . 

 

  

 

 

                                          MONITOR     SPEAKER  



  
Q2. 

Q2. Discuss about the classification of computers based on size and capacity. 

Answer: Classification of computer based on size and capacity by the following: 

         i)Microcomputer: Microcomputer are relatively small and low cost. They 

consist of CPU, an input, an output unit, a storage unit and the software. Although 

it stands alone machine they can be connected together to create a network of 

computer that can serve more than one user. 

     ii) Minicomputer: Minicomputer are digital computer generally used in multi-

user systems. They have high storage capacity than the microcomputer. 

Minicomputer can support up to 4-200 users simultaneously. 

    iii)Mainframe computer: Mainframe computer are multi-user, multi-

programming and high performance computers. They operate at a very high 

speed, have a very large storage capacity and can handle the workload of many 

use. 

    iv)Super computer: Super computer are the fastest and most expensive 

machines. They have high processing speed compared to other computers. 

Q3. What is the meaning of computer generation? How many Computer 

Generation are defined? What technologies were\are used? 

Answer: Computer generation is a change in technology a computer is\was being 

used. Initially the generation term was used to distinguish between varying 

hardware technologies. 

       There are five computer generation till date: 

i)First generation: The period of first generation 1946-1959 vacuum tube based. 

ii)Second generation: The period of second generation 1959-1965. Transistor 

based. 

iii)Third generation: The period of third generation 1965-1971. Integrated   circuit 

based. 



iv)Fourth generation: The period of fourth generation 1971-1980. VLSI 

microprocessor based                                                                                                     v) 

Fifth generation: The period of fifth generation 1980 onwards. ULSI Micro 

Processor based.                                                                                                                                

Artificial Intelligence (AI) is the technology used for equipping computer systems 

with the ability to make decision like humans. 

     1.Data science 2. Internet of things 3. Block chain 4. Robotic Process 

Automation (RPA) 5. Virtual Reality 6. Edge Computing 7. Intelligent Apps 

  

Q4. Differentiate between Volatile & Non-Volatile memories. 

Answer:   Volatile                                                         Non-Volatile 

i)Volatile memory is the type of                i)Non-Volatile memory is the type of                                                                   

memory in which data is lost as it is          memory in which data remains stored  

powered-off.                                                  even if it is powered –off. 

ii)Content of volatile memory is stored   ii) Contents of Non-Volatile memory is  

temporarily.                                                  stored permanently. 

iii)It is faster than non-volatile memory.  iii) It is lower than volatile memory. 

 

Q5. Distinguish among system software, application software and open source 

software on the basis of their features. 

Answer:  System software: System software provides an interface between the 

system hardware and the user. It lets the system understand the command that 

the user input. The user only gets to interact with the GUI that has been created 

by the system software. 

       An application software: An application software as software written on a 

high-level language such as JAVA, C++, net and VB for instance. This software is 

meant to meet some specific needs of the user. There is a specific purpose behind 

every application software.  



      Open source software: Open source software is computer software that is 

released under a license in which the copy right holder grant users right to use, 

study , change  and distribute the software and its source code to anyone and for 

any purpose. 

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it 

with file name “yourself”. Describe all steps involved in it. 

       b) Write step regarding followings  

                    To change the font style   

                    To change the font size 

                     To change the font color  

                     To highlight (in yellow) the line that reads “need to get IM’S address” 

Answer:   To change the font style:           

       1. Select the text you want to modify. 

       2. Select the Home tab and locate the Font Group. 

       3. Click the drop-down arrow next to font style box. 

       4. Font style menu appears. 

       5. With a left click select the desire font style. 

       6. If you want to change the font to bold or italic, click the ‘B’ or ‘I’ icon on the 

format bar. 

          To change the font size: 

      1.Select the text or cells with text you want to change. To select all text in a 

Word document, Press Ctrl+ A. 

      2.On the home tab, click the font size in the Font size box. 

      3. Then it can be type in any size. 

         To change font color: 

      1.Select the text you want to modify. 



      2. In the Home tab locate the font group. 

      3.Click the drop-down arrow next to Font color button. 

      4.Font color menu appears. 

    5.Select the desire font color with a left click. 

    6.Word will change the Font color of the selected text. 

     Yellow Highlight Text: 

    1.Click the Home tab. 

    2. In the font group click the Text Highlight button. Word is now in Highlighting 

mode. 

    3.Drag the mouse over the text you want to highlight. 

    4.Click the Text Highlight button again to return the mouse to normal 

operation. 

 

Q7. Create a file in MS-Word for the following document and save it with file 

name “MS-word”. Describe all steps involved in it. 

Answer:  MS-word is a widely used commercial word processor developed by 

Microsoft. 

MS word is application software, which is capable of  

           creating 

 editing 

 saving and 

    printing any type of document 

The step involved in it are: 

    1.Click the file tab 

    2.Click save as  

    3.Click Browse and then select the location to save the file  



    4. In the save as type list, click Open Document Text 

    5. Give the file name and then save it 

 

Q8. Create a file in MS-word for the following document and save it with file 

name ‘Equations’. Describe all steps involved in it. 

Equations 

X2 + Y5 =30 

Z
3

 + Q
4

 =50 

A2 + B8 =X2 +Y8
 

 

All steps involved in it are: 

1.Click the file tab 

2.Click save as 

3.Click Browse and then select the location to save the file  

4.In the save as type list, click Open Document Text 

5.Give the file a name and then save it 

 

Q9. Create a file in MS-word that convert existing highlight text to table as shown 

below and save it as file name ‘Text-to-table’. Describe all steps involved in it. 

 Select the text you want to convert 

Select the Insert tab  

Click on Table command. A dialog will appear  

Click on Convert Text to Table, a new dialog box appears 

Click on OK Finally Selected text convert in a table  



Select the text you want to convert Select the Insert tab 

Click on Table command. A dialog box 
will appear 

Click on Convert Text To Table, a new 
dialog box appears 

 Click on OK Selected text convert in a 
table 

Answer: 1. Select the text you want to convert. 

         2.Select the Insert tab. 

         3.Click the Table command. 

         4.Select Convert Text to Table from the menu. A dialog will appear. 

         5.  Choose one of the options in the Separate text at section. This is how 

Word knows what text to put in each column. 

        6. Click OK. 

 

Q10. Create a file in MS-Word to insert a table in the document. Describe all steps 

involved in it. 

Answer:  1. Click on table from the menu bar. Select Insert, and then Table. 

          2. Enter the desired numbers of rows and columns. 

          3. Choose Auto Fit behavior if you want the table’s cells to automatically 

expand to fit the text inside them. 

         4. Click OK to insert your table. 

Q11) 

Answer 

Roll No Name Marks 

1 n1 60 

2 n2 70 

3 n3 80 

4 n4 90 

5 n5 40 

6 n6 50 

7 n7 77 



8 n8 44 

9 n9 88 

10 n10 55 

Q12) 

Answer 

Roll No Name Marks 

1 n1 60 

2 n2 70 

3 n3 80 

4 n4 90 

5 n5 40 

6 n6 50 

7 n7 77 

8 n8 44 

9 n9 88 

10 n10 55 

   

 Total 654 

 Average 65.4 

 Highest 90 

 Minimum 40 

   

 

Q13. a) Describe various steps involved in the following 

        To modify column width of a worksheet  

        To modify the row height of a worksheet  

        To delete rows and columns of a worksheet 

Answer: To modify the column width of a worksheet: 

   1. Identify the column width you wish to resize. 

   2. Hover your mouse on the right boundary of that column so that you see 

across or T shape. 

  3. Hold down your mouse button and drag the right boundary until you reach 

the desired pixel width. 



  4.Release the mouse button. 

To modify the row height of a worksheet: 

1.Select the row or rows that you want to change. 

2.On the home tab, in the cell group, click format. 

3.Under Cell Size, click Row height. 

4.In the Row height box, type the valve that you want, and then click OK. 

 

To delete rows and columns of a worksheet: 

1.Right-click in a table cell, row or column you want to delete. 

2.On the menu, Click Delete Cells. 

3.To delete one cell, choose Shift cells left or Shift cell up. To delete the row, click 

Delete entire row. To delete the column, click Delete entire column. 

 

Q13 b) Describe following terms in the worksheet 

               I) Absolute reference and relative reference in formula 

              ii) Cell address 

Answer: I) Relative reference change when a formula is copied to another cell. 

Absolute reference, on the other hand, remain constant no matter where they 

are copied. 

       ii) Cell address is a combination of a column letter and a row number that 

identifies a cell on a worksheet. 

 

Q14. a) What tools are available to customize our Power point presentation? 

Answer: 1.Perspector 

               2.Pivot Viewer 

               3.Autodesk 3DS Max 



        4.Visual Bee Power Point Add-in 

       5.Smart Art 

      6.Animations and Transaction 

      7. Wordle 

      8.CA coo 

      9.Oomfo  

    10.Clip champ 

 

Q14 b) Write the steps for the following action for creation of power point 

presentation 

 i) Open a Blank Presentation 

ii) Save the presentation as Lab1.ppxt 

iii)Add a Title to the first slide: the name of your college  

iv)Type your first name and last name in the Subtitle section 

v)Add a New Slide which has a title and a Content 

Answer:   i)Open a Blank Presentation: 

1.Open PowerPoint presentation using ‘Run’ command (window key+ R)  

2.Select the (Blank Presentation). It is opened. 

        ii)Save the Presentation as Lab1.pptx: 

1. Select the ‘File’ on Tab bar. 

2.Click on ‘Save As’ option. 

3.Click on document \Desktop as your choice. 

4.Type the name ‘Lab1.pptx’ 

5.Click the ‘Save’ button. 

        iii)Add title to the first slide: the name of your college: 



1.Left click on the ‘Click to Add Title’ section on the first slide. 

2.Type the name of your college. 

     iv)Type your first name and last in the subtitle section: 

1.Left Click on the ‘Click to Add Subtitle section’. 

2.Type your first name and last name. 

     v)Add a new slide which has a Title and content: 

1. Select the Home Tab. 

2. Click on the drop down button of the ‘New Slide on toolbar’. 

3. Select the slide having ‘Title and Content’. It is added. 

 

Q15.Write the steps for creation pf a set of PowerPoint slides that demonstrates 

your skill to use the tool of PowerPoint. It should include the following things 

     i) Title slide &bullet list  

    ii)Inserting Excel sheet 

   iii)Clip art and Text 

    iv)Slide show effects 

Answer: I) Title slide and Bullet list: 

1.On the view tab, click Normal. 

2.Click in the text box or placeholder where you want to add bulleted or 

numbered text. 

3.On the Home tab, in the Paragraph group, click bullet or Numbering and begin 

typing your list. Press return to create a new list item. 

4.To add a slide title to an existing slide go to the ‘Home’ tab and click “Layout” 

then “Title Only”. 

5.Then place your cursor in the ‘Click to add title’ box on the slide and type in 

your unique slide title. 



      ii)Insert Excel Sheet: 

1.In PowerPoint on the Insert tab, click or tap Project. 

2.In the Insert Object dialog box, select Create from file. 

3.Click or tap Browse, and in the Browse box, find the Excel workbook with the 

data you want to insert and link to. 

4.Before you close the Insert object box, select Link, and OK. 

    iii)Clip art and Text: 

1.Click in the slide where you want to insert a clip art file. 

2.On the Insert tab, in the Images a group, click Online Picture.  

3.In the Insert Picture dialog box, enter your search items in. 

    iv)Slide Shown Effects: 

1.Select the object or text you want to animate. 

2.Select Animation and choose an animation. 

3.Select Effect Options and choose an effect. 

 

Part-2 

Q16.What is the difference between Machine Language and High Level Language? 

Answer: A Machine Language is the only language that a computer directly 

understands, it is usually written in zeros (0) and ones (1). A program instruction 

in machine language may look something like this 111010110010001. 

        High Level Language is a programming language that uses English and 

mathematical symbols like +, -, % and many other in its instruction. 

 

Q17.Discuss about different data types of C Programming Language. 

Answer: 

                           Type                     Description 



        Int Stores zero, positive and negative 
values without decimal. The value can 
be signed or unsigned. The value 
assigned to int is considered positive 
by default if it is unsigned. 

        Float Stores decimal values with single –
precision. 

       Double       It stores decimal values and double-
precision. 

     Char Stores a single character. 

 

Q18.Find the output of the following expressions: 

a) X=20\5*2+30-5   b) Y=30-(40\10+6) +10 c) Z=40*2\10-2+10 

Answer: a)X=20\5*2+30-5 

                =33 

          b) Y=30-(40\10+6) +10 

                =10 

          c)Z=40*2\10-2+10 

                =16 

Q19.Describe the syntax of the following statements 

   a) If-else statement     b) for loop      c) while loop    d) do-while loop 

Answer: a) If-else statement: 

The if-else statement is an extended version of it. The if-else statement is used to 

perform two operations for a single condition. The if-else statement is an 

extension to the if-else statement using which, we can perform two different 

operations, i.e, one is correctness of that condition and the other is for 

incorrectness of the condition. Here, we must notice that if and else block cannot 

be executed simultaneously. Using if-else statement is always preferable since it 

always invokes an otherwise case with every condition. The general form of if-else 

syntax is given below. 



  If    (test-expression) 

{ 

      True block of statements 

} 

Else 

{ 

       False block of statements 

} 

      Statements 

In this type of construct, if the value of test-expression is true, then the true block 

of statements will be executed. 

{ 

    Statements 

In this type of construct, if the value of test-expression is true, then the true block 

of statement will be executed. If the value of test expression is false, then the 

false block of statement will be executed. In any case, after the execution, the 

control will be automatically transferred to the statements appearing outside the 

block of it. 

  Then if statement specific a block of code to be executed if a condition is true. 

And the else statement specific a block of code to be executed if the condition is 

false. 

b) for loop: 

A for loop is a repetition control structure that allows you to efficiency write a 

loop that needs to execute a specific number of times. The syntax of a For Loop in 

C programming is- 

        For (init; condition increment statement(s): 

} 



c)While Loop: 

The syntax of a While Loop is C programming language is while (condition) 

{statement(s);}. Here, statement(s) may be a single statement or a block of 

statements. The condition may be an expression, and true is any non-zero value. 

The Loop iterates while the condition is true. 

d) do-while loop: 

The syntax of Do While Loop is as follow: 

1.do { 

2.\*statement(s); *\ 

3./*increment loop counter*\ 

4.} while (condition); 

 

Q20. Find the output of the following program segments 

a) b) c) 

#include<stdio.h> 
Int main() 
{ 
    Printf(“IMS 
Ghaziabad\n”); 
  } 
} 

#include <stdio.h> 
Int main() 
{ 
While(i=2) 
{ 
     Printf(IMS 
Ghaziabad\n”); 
       I=i+1; 
    } 
} 
 

#include<stdio.h> 
  Void main() 
{ 
   Int a=10, b=100; 
      If(a>b) 
       printf(“Largest 
number is %d\n”,a); 
    Else 
      Printf(“Largest 
number is %d\n”,b); 
} 
       

 

Answer: a) IMS Ghaziabad. 

         b) IMS Ghaziabad. 

             IMS Ghaziabad 



    c) Largest number is 100. 

              

 

 

 

 

 

 

   

 

  

 

 

            

  

         

 

 

           

   

                                                  


