CCA-101: FUNDAMENTAL of IT & Programing

Assiecnment -1

Q.1: What are the four fundamentals parts of computer ? Explain it with the help of diagram.

Ans:- The four fundamentals parts of computer are: - i) Input devices ,ii) Processor(CPU) ,iii)
Output devices, iv) Backing storage .
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Q.2: Discuss about the classification of computers Based on size and capacity.

Ans:- Based on size and capacity, computers are classified as follows:
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Super computers
Mainframe Computer
Mini Computers
Micro Computers

Super computes

Super computers are the most powerful and physically the largest by size.

These are the systems designed to process huge amounts of data.

The fastest supercomputers can perform over one trillion calculation in a second.
Supercomputer have thousands of processors.

Because of their extraordinary speed, accuracy and processing power, supercomputers are
well suited for solving highly complex problems & huge amounts of calculations.

Example: JAGUAR, ROADRUNNER etc.

Mainframe Computer

e Mainframe computers are very large often filling an entire room and can process thousand

of million of instructions per second.

¢ In a mainframe environment, users connect to the mainframe through the many terminals

wired to the mainframe.



e Mainframes are able of supporting hundreds to thousands of users simultaneously.

e Some of the functions performed by a mainframe include: flight scheduling, reservations and
ticketing for and airline etc
Example: IBM mainframes Z13,IBM System z9 mainframe.

3. Minicomputers

e Minicomputers are much smaller than mainframes.
e These computers are also less expensive.
e Sometimes referred to as Midrange Severor Midrange Computer.
e They are typically larger, more powerful and more expensive than desktop computers.
e Midrange computers are usually used by small and medium-size business as their servers
e Users connect to the saver through a network by using desktop computers.
Example: Apple iPod , CDC 160A

4. Microcomputers

e Microcomputers are the most frequently used type of compouter.
e |tis also, known as Personal Computer system designed to be used by one person at a time .
Example: Desktop computers, laptops.

Q.3: What is the meaning of computer generation? How many Computer Generation are defined ?
What technologies were/ are used?

Ans:- Generation in computer technology is a change in technology of a computer which were
being used.

In the first computer system, Vaccum tubes are used.
Transistor are used in the second generation.
Integrated circuit technology were used in the third generation.

In the fourth generation microprocessors are used.

Q.4: Differentiate between Volatile & Non-Volatile memories.

Non- volatile memory

Ans Volatile memory
1. It is a computer storage that only maintains its data 1. Itis atype of computes memory that
while the device is Powered. has the capability to hold saved data
even if the computer is turn off.
2.E.g. RAM

2. E.g. ROM, hard disk, floppy disk, etc.

3. Primary memory has limited storage Capacity and 3. Secondary memory provides permanent

storage of data and in bulk quantity.
Is volatile .




Q.5: Distinguish among system software, application software and open source software on the
basis of their features.

Ans:- System software : It is a type of software that has designed to run a computer’s hardware
and application programs. Software like operating systems, compliers, editors and drivers etc.
come under this category. A computer cannot function without the presence of system software .

Application software: It is a software created for specific purpose used by end users. It can be
called an application or simply an app.

Example: word processer app etc.

Open source software: It is a type of computer in which source code is released under a lincense
in which the copyright holder grants users rights to study, change and distribute the software to
anyone and for any purpose.

E.g. the Linux operating system.

Q.6: a) Create afile in MS-word to insert a paragraph about yourself and save it while name
éyourself” . Describe all steps involved in it.

b) Write the steps regarding the followings

» To change the font style

» To change the font size

» To change the font color

» To highlight(in yellow) the line that reads “need to get IMS’s address”.

Ans:-a) “Yourself”

My name is Maison Ningombam. | am 19 years old. | love to play and study. | am a
student of Arts at KAKCHING KHUNOU COLLEGE , UMATHEL, MANIOUR. Current | am learning
computer CCA course at RGI TRANING INSTITUTION.

The steps involved are:

1. We click the Microsoft office button.
2. We select new. The new document dialog box appears.
3. We select blank document under the blank and recent section. It will be highlighted by
default.
We click create. A new blank documents appear in the word window.
To save the document, we click again the Microsoft office button.
We select save as —» word document. The save as dialog box appears.
We select the location where we want to save the document using the drop down menu.
We enter the file name “ yourself” for the document.
We click the save button.
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b) steps to change the font style:




1. We select the text we want to modify.

2. Left click the drop-down arrow next to the font style on the home tab. The font style drop-
down menu appears.

3. We move cursor over the various font styles. A live preview of the font size will appear on
the document.

4. Left click the font size we want to us. The font size will change the document.

Steps to change the font color

1. We select the text we want to modify.

2. Left click the drop-down arrows next to the font color box on the home tab.
The font color menu appears.

3. We move cursor on the various font colors. A live preview of the color will appear in the
document.

4. Left click the font color we want to use. The font color will change in the document.

Steps to highlighted the line
We select the line that reads “ needs to gets IMS’s address”
We click the highlight command and select yellow color in the font group on the home tab.
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Q.7: Create a file in MS- Word for the following document and save it with file name “ms-
word”. Describe all steps involved in it.

Ans:- MS word is a wisely used commercial word processor developed by Microsoft.

MS word is application software, which is capable of

e C(Creating
e Editing
e Saving, and

e Printing any type of document
The steps involved are :
1. We click the Microsoft office button.
2. We select new. The new document dialog box appears.
3. We select blank document under the blank and recent section. It will be highlighted by
default.
4. We click created. A new blank document appears in the word window.
We create the given documents from the question.
6. We select the text “MS word” and change the font size by clicking on the font size box
on the home tab.
7. We select the text “ MS word” to change the font the font color into red by clicking on
the font color menu.
8. We select the text word processor and underline command in the font group the home
tab.
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9. We select the text “MS word” to change the font style into by clicking italic command.

10. We change the font we want to format as a list and click on the bullets command on
the home tab.

. We change the font color of the text “creating” and “saving” into blue and red resp by
clicking on the font color command, again we select the text “and” click on
strikethrough command.

. We select the text “printing any type of document” and change the font style into bold
by clicking on the font style command.

. We save the file name as “ms-word” by clicking the Microsoft office button and select
save as
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. We select the location where we want save the document using drop-down memu
. We click the save button.
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Q.8: Create a file in MS- word for the following document and save it with file name ‘equation’.
Describe all steps involved in it.

Equatios
Xz + Y5 =30
Z3+Q*'=50
Az + Bg= Xz + Y8

Ans:- Equations
X 2+ Y5 =30

2> +Q*=50

Az + 58 = Xz + Y8

The steps are :
1. We create the given documents in MS-word

2. We select the text where we want to format and click on the subscript and superscript
command on the home tab.

3. We save the file name as “equation” by clicking the Microsoft office button and select
save as

4. We select the location where we want to save the document using the drop down menu

5. WE click the save button.

Q.9: Create a file in MS- Word that convert existing highlighted text tom the table as shown
below and save it as file name ‘text_to _table’. Describe all steps involved in it.




Select the text you want to convert. Select the Insert tab.

Click on Table command. A dialog box Click on Convert Text to Table, a new

appears. dialog box appears.

Here set number of columns. Click on OK Finally Selected text convert in a
table

Ans:- To convert existing text to ma table:
1. We select the existing highlighted text that we want to convert.
2. We select the insert tab
3. WE click the table command
4. WE select convert text to table from the menu. A dialog box appears
5. We click ok. Then the text appears in a table.
Q.10: Create a file in MS-Word to insert a table in the document. Describe all steps involved in it.
Ans:-

The steps are:
1. We place our insertion point in the document where we want our table to appear

2. We select the insert tab

3. We click the table command

4. We drag our mouse over the diagram squares to the select the numbers of columns and
rows in the table.

5. Left click our mouse and the table appears in the document.

6. We enter the text into the table.

Q.11: Create a following worksheet in MS-excel and save it with name ‘book1’.

Roll No. Name Marks
1 nl 60
2 n2 70
3 n3 80
4 n4 90
5 n5 40
6 n6 50
7 n7 77
8 n8 44
9 n9 88

=
o

nl10 55



Ans:-
Name  Marks

1 nl 60
2 n2 70
3 n3 80
4 n4 90
5 n5 40
6 n6 50
7 n7 77
8 n8 44
9 n9 88
10 nl10 55

Q.12. Calculate the following things of a range (C2:C11) of data in the worksheet created in
question no. 10.
» The sum of the marks using AutoSum in a range of cells (C2:C11)
» Average of the marks in a range of cells (C2: C11)
» Highest marks in a range of cells (C2:C11)
» Minimum marks in a range of cells (C2: C11)

Ans:-
No. Name Marks Sum Average Maximum Minimum
1nl 60 654 65.4 90 40
2 n2 70
3 n3 80
4 n4 90
5n5 40
6 n6 50
7 n7 77
8 n8 44
9 n9 88
10 n10 55

Q.13: a) Describe the various steps involved in the following
» To modify column width of a worksheet
» To modify the row height of a worksheet
» To delete rows and columns of a worksheet

b) Describe following terms in the worksheet
» Absolute reference and relative reference in formula
» Cell address.
Ans:- a)
» To modify width of a worksheet:
i. Select a column or a range of columns.
ii. Select a Home tab and inn the Cells group, select Format.



iii. Click on Column width and type the width for column.
iv. Select OK.
» To modify the row height of a worksheet.

i. Select a row or a range of rows.
ii. Select a Home tab in the Cells group, select Format.

iii. Click on Row Height and in the Cells group, select Format.
iv. Select OK.
> To delete rows and columns of a worksheet.

b) :-

>

Select the cell you want to delete within the column or row.
Select Home tab. And in cells group click on Delete Sheet Column or Row .
OR
Select the desire row and column.

Absolute Reference:

An absolute reference in Excel means there is a fixed point of reference applied to a
cell or a formula. This is so the return value will always stay the same no matter
where the cell or formula moves to — within the same sheet or across different
sheet.

This refers to a fixed point of reference is a constant, and involves the use of dollar
sign S in the formula (i.e., everyone is to receive the same bonus payout, so the
amount $1500 is constant in this situation).

> Relative Reference:
It is the default cell reference in Excel. It is simply the combination of column of
name and row number without any dollar (S) sign. When you copy the formula
from one cell to another the relative cell address changes depending on the
relative cell references. Relative references are used when we want to perform a
similar operation on multiple cells and the formula must change according to the
relative address of column and row.

This refers to a relative point of reference, is constantly changing and dollar sign
(S) is absent in the formula (i.e., when each unit price and quantity are difference
variables, there’s no constant in the calculation).

Cell Address:
A cell address is a combination of column letter and row number that identifies a
cell on a worksheet.
For example, Al refers to the cell at the intersection of column A and row 1; B2
refers to the second cell in column b, and so on.
When sed in formula, cell references help Excel find the values the formula

should calculate. For instance,

e To pull the value of Al to another cell, you use this simple formula : = Al

e To add the value in cells A1 and A2, you use this one: =A1+A2.

Q.14: a) What tools are available to customize our Power Point presentation?



b) Write the steps for the following action creation of power point presentation
» Open a Blank presentation
» Save the presentation as Lab1. Pptx
» Add a Title to the first slide: the name of your college
» Type your first name and last name in the Subtitle section
» Add a New Slide which has a Title and Content.
Ans:- a)

Tools available to customize our Power Point presentation are :
a) Presentation
b) Pivot Viewer
c) Autodesk 3DS max
d) VisualBee Power Point Add-in
e) SmartArt
f) Animations and Transition
g) Wordle
h) CA coo
i) Oomfo
j) Clip champ

b):-

» To open blank presentation:
i. Open PowerPoint presentation using ‘Run’ command (window key + R).
ii. Select the ‘Blank Presentation’. It is Opened.
» Save the presentation as Labl.pptx.:
i. Select the ‘File’ om the Tab bar.
ii. Click on ‘Save As’ option.
iii. Click on the document/Desktop as your choice.
iv. Type the name ‘Labl.pptx’.
v. Click the ‘Save’ button.

» Add a Title to the first slide: the name of your college.
i. Left click on the ‘Click to Add Title’ section on the first slide.
ii. Type the name of your college.
» Type your first name and last name in the subtitle section:
i. Left click on the ‘Click to Add Subtitle’ section
ii. Type your first name and last name.
» Add a New slide which has a Title and content.
i. Select the Home tab.
ii. Click on the dropdown button of the ‘New Slide’ on toolbar.
iii. Select the slide having ‘Title and Content’. It is added.



Q.15: Write steps for creation of a set PowerPoint slide that demonstrates your skill to use the
tools of PowerPoint. It should include the following things
» Title slide & bullet list
» Inserting Excel Sheet
» Clip art and Text
» Slide show effects
Ans:-
» Title slide and bullet list:
i. Open PowerPoint Presentation
ii.Select the Home tab.
iii.Click at the dropdown button on ‘New Slide’ at toolbar.
iv.Select the slide having Title slide and Bullet list.

» Inserting Excel sheet:
i. Open the slide where you want to insert the Excel sheet.
ii. Select the ‘Inert tab’. And click on ‘Object’ on tool bar.
iii. Select the ‘Microsoft Excel Worksheet’ object type.
iv. Click the ‘OK’ button.
» ClipArt and Text:
i. Select the Insert Tab.
ii. Select the 'Pictures’ or ‘Online pictures’ tool bar.
iii. Choose the appropriate art for the topic.
iv. Click on the ‘Insert button.
» Slide show effects:
i. Select ‘Design Tab’ for Themes, Variants and Slide size.
ii.  Select ‘Transition Tab’ for Cut, Fade, push, Wipe, Split, Reveal, Shape, Flash, etc.
for slide effects.
Q.16: What is the difference between Machine Language and High Level Language?
Ans:-

Machine language High level language
1. A computer programming language 1. Itis a programming language that
consisting of binary instructions which enables development of a program in a
a computer can respond to directly much more user friendly programming
2. It requires no translator to translate context.
the code. It is directly understood by 2. It takes additional translation time to
the computer. translate the source code to machine
3. This language makes fast and efficient code
use of the computer. 3. They are programmer friendly.

Q.17: Discuss about difference data type of C programing Language.

Ans:- The different data types of C programming languages are:

Char: the most basic data type in C. it store a single character and requires a single bite of memory
in almost all compilers.



Int: as_the name suggests, an int variable is used to store an integer.

Float: it is used to store decimal numbers

Double: it is used to store decimal numbers(number with floating point value but its range of value

is high in comparison to float)

Q.18: Find the output of the following expression
a) X=20/5*2+30-5 b) Y =30 — (40/10+6) +10 c) Z=40*2/10-2+10
Ans:- A) X=33
B) Y=30
C) =16

Q.19: Describe the syntax of the following statements
a) If —else statement b) for loop c¢) while loop

Ans:- Q) if- else statement:

d) do-while loop

If statement can be followed by an optional else block of statements, which executes when

the Bootcan expression false.
Syntax

If (expression)

{

True block of statements;

}

Else

{

Else block of statements ;

}

b) For loop is similar to while loop. Basic syntax of for loop is as follows:

For (expression 1; expression 2; expression 3)

{

Block of statement

}
In the above syntax

Expression 1-initializes variables.



Expression2 — condition expression as long as this condition is true, loop will keep
executing.

Expression 3- it is the modifier which will increase or decrease the value of the
variable.

c) While loop.
Basic syntax of while loop is as follows
While (condition)
Single statement.
OR while (condition)

{

Block of statements
}
d) Do- while loop.

Do- while loop is just like a while loop except that the text condition is checked at the end
of the loop rather than the start. This has the effect that the body of the loop are always
executed at least once

Basic syntax of do-while loop is as follows
Do
{
Single statement
OR
Block of statements

} while(condition);



Q.20:Find the output of the following program segments

Ans:-

a) b) )

#tinclude <stdio.h> #include <stdio.h> #tinclude <stdio.h>

Void main() Void main() Void main()

{ { {

Int i; Intl=1; Int a =10, b=100;

for (i=1; i<2; i++) While(l <=2) If(a>b)

{ { Printf(“Largest number is

Printf(“ IMS Ghaziabad\n”);

}
}

Printf(“IMS Ghaziabad\n”);
i=i+1;

}
}

%d\n”, a);

Else

Printf(“ Largest number is
%d\n”, b);

}

A) IMS Ghaziabad
B) IMS Ghaziabad

IMS Ghaziabad

C) Largest number is 100




