
Q1: What are the four fundamental parts of computer? Explain it with the help of 
diagram. 

The four fundamental parts of a computer system are typically referred to as the central 
processing unit (CPU), memory (RAM), input devices, and output devices 

1. Central Processing Unit (CPU): Often considered the brain of the computer, the CPU 
is responsible for executing instructions stored in the computer's memory. It 
performs arithmetic and logical operations, controls the flow of data, and manages 
other hardware components. 

 

2. Memory (RAM - Random Access Memory): RAM is a type of volatile memory that 
provides temporary storage for data and instructions that the CPU uses actively 
during operations. It allows for quick access to information, but its contents are lost 
when the computer is powered off. 

 

3. Input Devices: These are peripherals that allow users to input data or commands into 
the computer. Common input devices include keyboards, mice, touchscreens, 
scanners, and more. Input devices facilitate communication between the user and 
the computer system. 

 

4. Output Devices: These devices display or present information processed by the 
computer to the user. Examples of output devices include monitors, printers, 
speakers, and others. Output devices convey the results of the computer's operations 
in a human-readable or usable form. 

 

 
 Q2: Discuss about the classification of computers based on size and capacity. 



Supercomputers: 

Supercomputers are the most powerful and largest computers. They are designed to 
process massive amounts of data and perform complex calculations at extremely high 
speeds. 

Supercomputers are used for scientific and engineering applications, such as weather 
forecasting, climate modeling, nuclear simulations, and advanced scientific research that 
requires immense computational power. 

 

Mainframe Computers: 

   Mainframes are large, powerful computers that can handle extensive data processing and 
manage multiple tasks simultaneously. They are often housed in special data centers due to 
their size. 

   Mainframes are used in large organizations for critical applications like financial 
transactions, airline reservations, and database management where high reliability, data 
integrity, and transaction processing capabilities are essential. 

 

Minicomputers: 

   Minicomputers are smaller and less powerful than mainframes. They offer moderate 
processing power and are capable of supporting multiple users simultaneously. 

   Minicomputers were historically used for tasks such as scientific and engineering 
calculations, business applications, and as servers in smaller organizations. However, 
advancements in microcomputers have diminished the role of minicomputers in recent 
years. 

 

Microcomputers (Personal Computers): 

   Microcomputers are the smallest and least powerful in terms of processing capabilities. 
They are designed for individual use and are commonly found in homes, offices, and small 
businesses. 

   Microcomputers, commonly known as personal computers (PCs), are used for a wide 
range of applications, including word processing, internet browsing, gaming, and various 
productivity tasks. They come in different forms such as desktops, laptops, and tablets. 

 
 Q3: What is the meaning of computer generation? How many Computer Generations are 
defined? What technologies were/are used? 

The term "computer generation" refers to the various phases in the development of 
computer technology, each marked by significant advancements and changes in hardware, 
architecture, and capabilities. These generations represent distinct periods in the evolution 



of computers, with each new generation bringing improvements in speed, size, cost, and 
functionality.  

First Generation (1940s-1950s): 

Big machines that used vacuum tubes. They were slow, expensive, and used punched cards 
for input. 

 

Second Generation (1950s-1960s): 

Computers became smaller and faster with transistors. Magnetic core memory was 
introduced. They still used punch cards, but programming languages like Fortran and 
COBOL were developed. 

 

Third Generation (1960s-1970s): 

   Computers got even smaller with integrated circuits. Operating systems were introduced, 
making them more user-friendly. People started using high-level languages like BASIC and 
Pascal. 

 

Fourth Generation (1970s-1980s): 

Microprocessors (tiny chips) were introduced, making personal computers possible. 
Graphical interfaces appeared, and networking technologies like Ethernet were developed. 
This era saw the birth of the Internet. 

 

Fifth Generation (1980s-Present): 

  Advances in things like artificial intelligence, parallel processing, and high-performance 
computing. Microprocessors kept improving. The focus shifted to things like cloud 
computing, and the Internet became a big part of our lives. 

 Q4: Differentiate between Volatile & Non- Volatile memories 

Volatile Memory Non-Volatile Memory 

Volatile memory is the type of memory in 
which data is lost as it is powered-off. 

Non-volatile memory is the type of memory 
in which data remains stored even if it is 
powered-off. 

Contents of Volatile memory are stored 
temporarily. 

Contents of Non-volatile memory are stored 
permanently. 



Volatile Memory Non-Volatile Memory 

It is faster than non-volatile memory. It is slower than volatile memory. 

In volatile memory, data can be easily 
transferred in comparison to non-volatile 
memory. 

In non-volatile memory, data can not be 
easily transferred in comparison to volatile 
memory. 

Volatile memory generally has less 
storage capacity. 

Non-volatile memory generally has more 
storage capacity than volatile memory. 

Volatile memory is more costly per unit 
size. 

Non-volatile memory is less costly per unit 
size. 

Volatile memory has a huge impact on 
the system’s performance. 

Non-volatile memory has a huge impact on a 
system’s storage capacity. 

RAM (Random Access Memory), cache 
memory. 

ROM (Read-Only Memory), flash memory, 
hard disk drives (HDD), solid-state drives 
(SSD). 

 

 
 Q5: Distinguish among system software, application software and open source software 
on the basis of their features. 

System Software: 

Function: Acts as the intermediary between hardware and application software, managing 
resources and enabling other software to run. 

Features:  

 Low-level access to hardware. 
 Runs in the background (invisible to users). 
 Essential for computer operation (e.g., operating systems, device drivers). 
 Typically not user-friendly (command-line interfaces). 
 Not directly focused on specific tasks. 

 
Application Software: 



Function: Application software is designed to perform specific tasks or functions for end-
users. It helps users complete various activities, such as word processing, graphic design, or 
gaming. 

Features: 

 Tailored to specific user needs and tasks. 
 Provides a user interface for interaction. 
 Relies on system software for hardware interaction. 
 Can be diverse, covering a wide range of functions and purposes. 

 

Open Source Software: 

Function: Open source software is a type of software whose source code is freely available 
to the public. Users can view, modify, and distribute the source code, subject to the terms 
of the open source license. 

Features: 

 Source code is accessible and modifiable by anyone. 
 Users can redistribute modified versions of the software. 
 Encourages collaboration and community-driven development. 
 Typically, open source software is free to use, and its development is transparent. 

 

 

 Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with file 
name “yourself”. Describe all steps involved in it. 

 

Open Microsoft Word: 

 Launch Microsoft Word on your computer. 

 

Create a New Document:** 

 Click on "File" in the upper left corner. 
 Select "New" to create a new document. 

 

Type The Paragraph: 

 In the new document, type a paragraph about yourself.  

 

Format Your Text: 



 Format the text as needed, such as adjusting font size, style, or adding bold or italic 
emphasis. 

 

Save the Document: 

 Click on "File" in the upper left corner. 
 Select "Save As." 

 

Choose a Location: 

 Navigate to the folder where you want to save the document. 

 

Name Your File: 

 In the "File Name" field, type "yourself”. 

 

Select File Type: 

 Choose the file format (usually “.docx”). 

 

Click "Save": 

 Click the "Save" button to save your document with the file name “Yourself”. 

 

 
 Q6 b) Write steps regarding followings  

 To change the font style  
 To change the font size  
 To change the font color  
 To highlight (in yellow) the line that reads “need to get IMS’s address”.  

 

Change the Font Style: 

Select Text: 

 Highlight the text whose font style you want to change. 

 

Go to the "Home" Tab: 

 Click on the "Home" tab in the ribbon at the top. 



 

Locate "Font" Group: 

 In the "Font" group, you will find the "Font" drop-down menu. Click on it. 

 

Choose a Font: 

 From the drop-down menu, select the desired font style. 

 

The Font Style is Changed: 

 Your selected text should now appear in the chosen font style. 

 

Change the Font Size: 

Select Text: 

 Highlight the text you want to resize. 

 

Go to the "Home" Tab: 

 Navigate to the "Home" tab in the ribbon. 

 

Locate "Font Size" Option: 

 In the "Font" group, find the "Font Size" drop-down menu. 

 

Choose a Size: 

 Click on the drop-down menu and select the desired font size. 

 

The Font Size is Changed: 

 Your selected text should now have the chosen font size. 

 

Change the Font Color: 

Select Text: 

 Highlight the text whose font color you want to change. 

 



Go to the "Home" Tab: 

 Move to the "Home" tab on the ribbon. 

 

Locate "Font Color" Button: 

 In the "Font" group, find the "Font Color" button. 

 

Choose a Color: 

 Click on the button, and a color palette will appear. Select the desired font color. 

 

The Font Color is Changed: 

 Your selected text should now display in the chosen font color. 

 

Highlight (in Yellow) a Specific Line: 

 

Select Line: 

 Click at the beginning of the line that reads "need to get IMS’s address" and drag 
your cursor to the end of the line to highlight it. 

 

Go to the "Home" Tab: 

 Move to the "Home" tab on the ribbon. 

 

Locate "Text Highlight Color" Button: 

 In the "Font" group, find the "Text Highlight Color" button. 

 

Choose Yellow Color: 

 Click on the button, and select the yellow color from the palette. 

The Line is Highlighted: 

 The selected line should now be highlighted in the chosen color. 

 Q7. Create a file in MS-Word for the following document and save it with file name 
‘ms_word’. Describe all steps involved in it. 

 



Open Microsoft Word: 

 Launch Microsoft Word on your computer. 

 

Create a New Document: 

 Click on "File" in the upper left corner. 
 Select "New" to create a new document. 

 

Type Some Content: 

 In the new document, type the given content. 

 

Save the Document: 

 Click on "File" in the upper left corner. 

 

Select "Save As": 

 Choose "Save As" from the menu. 

 

Choose a Location: 

 Navigate to the folder where you want to save the document. 

 

Name Your File: 

 In the "File Name" field, type 'ms_word'. 

 

Select File Type: 

 Choose the file format you prefer (usually “.docx”). 

 

Click "Save": 

 Click the "Save" button to save your document with the chosen file name. 
 

Q8. Create a file in MS-word for the following document and save it with file name 
‘equations’. Describe all steps involved in it. 

Open Microsoft Word: 



 Launch Microsoft Word on your computer. 

 

Create a New Document: 

 Click on "File" in the upper left corner. 
 Select "New" to create a new document. 

 

Type Your Equation: 

 Type the equation or text where you want to include superscript or subscript. 

 

Select Text: 

 Highlight the portion of text that you want to format as superscript or subscript. 

 

Go to the "Home" Tab: 

 Move to the "Home" tab in the ribbon at the top. 

 

Locate "Font" Group: 

 In the "Font" group, you'll find options for formatting text. 

 

Format as Superscript: 

 Click the "Superscript" button (usually represented as "x²" in the Font group). 

Format as Subscript: 

 Similarly, if you want to make the text a subscript, click the "Subscript" button 
(usually represented as "x₂" in the Font group).  

Save the Document 

 Click on "File" in the upper left corner. 

 

Select "Save As": 

 Choose "Save As" from the menu. 

 

Choose a Location: 

 Navigate to the folder where you want to save the document. 



 

Name Your File: 

 In the "File Name" field, type 'equations'. 

 

Select File Type: 

 Choose the file format you prefer (usually “.docx”). 

 

Click "Save": 

 Click the "Save" button to save your document with the chosen file name. 

Q9. Create a file in MS-word that convert existing highlight text to table as shown below 
and save it as file name ‘text_to_table’. Describe all steps involved in it. 

Open Microsoft Word: 

 Launch Microsoft Word on your computer. 

 

Open an Existing Document: 

 Open the document containing the highlighted text that you want to convert to a 
table. 

 

Highlight the Text: 

 Use your mouse to select the text that you want to convert into a table. Make sure 
the text is properly highlighted. 

 

Go to the "Insert" Tab: 

 Navigate to the "Insert" tab in the ribbon at the top. 

 

Click on "Table": 

 In the "Tables" group, click on the "Table" option. 

 

Select "Convert Text to Table": 

 From the drop-down menu, choose "Convert Text to Table." 

 



Specify Table Options: 

 In the "Convert Text to Table" dialog box, make sure the options are set according to 
your preferences. For example, you can choose the number of columns and other 
settings. 

 

Click "OK": 

 Once you have set the options, click the "OK" button to convert the highlighted text 
to a table. 

 

Adjust Table if Needed: 

 After conversion, you may need to adjust the table's formatting or make additional 
edits based on your requirements. 

Save the Document 

 Click on "File" in the upper left corner. 

 

Select "Save As": 

 Choose "Save As" from the menu. 

 

Choose a Location: 

 Navigate to the folder where you want to save the document. 

 

Name Your File: 

 In the "File Name" field, type 'text_to_table'. 

 

Select File Type: 

 Choose the file format you prefer (usually “.docx”). 

 

Click "Save": 

 Click the "Save" button to save your document with the chosen file name. 

Q10. Create a file in MS-Word to insert a table in the document. Describe all steps 
involved in it. 

Open a New Document: 



 Launch Microsoft Word. 
 Click on "Blank document" to start a new file. 

Position the Table: 
 Decide where you want the table to appear in your document. Click your cursor at 

that location. 
Insert the Table: 
There are two main ways to do this:  
 Click the "Insert" tab:  

o Locate the "Insert" tab in the top menu bar. In the "Table" group, you'll see various 
options.  

o Predefined Table: Click on a pre-designed table template if it suits your needs. 
o Draw Table: Choose "Draw Table" if you prefer manually drawing your table with the 

desired rows and columns. 
 

 Quick Table Button:  
o Alternatively, on the home screen, you might see a small grid icon called 

"Quick Table." Click and drag your cursor across the desired number of rows 
and columns to create your table. 

 Resize: Click and drag the table borders to adjust its size. 
 Add/Remove Rows/Columns: Right-click within the table and select "Insert Rows 

Above/Below" or "Insert Columns Before/After" as needed. 
 Merge Cells: Select contiguous cells and click "Merge Cells" in the "Table Tools" tab 

appearing at the top. 
 Format: Highlight cells and change font, alignment, borders, and other formatting 

options within the "Table Tools" tab. 
Save the Document: 

 Click on the "File" tab. 
 Select "Save As". 
 In the "File name" field, type a descriptive name. 
 Choose a saving location. 
 Click "Save". 

 
Q11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

 



 
 

Q12. Calculate the following things of a range (C2:C11) of data in the worksheet created 
in question no 10.  

 the sum of the marks using AutoSum in a range of cells (C2:C11)  
 average of the marks in a range of cells (C2:C11)  
 highest marks in a range of cells (C2:C11)  
 minimum marks in a range of cells (C2:C11)  

 



Q13 a) Describe various steps involved in the following  

 To modify column width of a worksheet  
 To modify the row height of a worksheet  
 To delete rows and columns of a worksheet  

 

To Modify Column Width of a Worksheet: 

 

Select the Columns: 

o Click on the column letter at the top of the worksheet to select the entire column or 
drag to select multiple columns. 

 

Adjust Column Width: 

o Move your cursor to the right edge of the selected column(s) until it turns into a 
double-headed arrow. 

o Click and drag to the desired width. 

 

Alternatively, Use Ribbon: 

o Go to the "Home" tab in the ribbon. 
o In the "Cells" group, find the "Format" option. 
o Click on "Format" and select "Column Width." 
o Enter the desired width in the dialog box and click "OK." 

 

To Modify Row Height of a Worksheet: 

 

Select the Row(s): 

o Click on the row number on the left of the worksheet to select the entire row or drag 
to select multiple rows. 

 

Adjust Row Height 

o Move your cursor to the bottom edge of the selected row(s) until it turns into a 
double-headed arrow. 

o Click and drag to the desired height. 

 

Alternatively, Use Ribbon: 



o Go to the "Home" tab in the ribbon. 
o In the "Cells" group, find the "Format" option. 
o Click on "Format" and select "Row Height." 
o Enter the desired height in the dialog box and click "OK." 

 

To Delete Rows and Columns of a Worksheet: 

 

To Delete Rows: 

Select the Rows: 

o Click on the row number on the left of the worksheet to select the entire row or drag 
to select multiple rows. 

o Right-Click and Choose "Delete": 
o Right-click on the selected row(s). 
o Choose "Delete" from the context menu. 

 

To Delete Columns: 

Select the Column(s): 

o Click on the column letter at the top of the worksheet to select the entire column or 
drag to select multiple columns. 

o Right-Click and Choose "Delete": 
o Right-click on the selected columns. 
o Choose "Delete" from the context menu. 

 

Alternatively, Use Ribbon: 

o Go to the "Home" tab in the ribbon. 
o In the "Cells" group, find the "Delete" option. 
o Click on "Delete" and choose either "Delete Sheet Rows" or "Delete Sheet Columns" 

as needed. 

 

Q13 b) Describe following terms in the worksheet  
 Absolute reference and relative reference in formula  
 Cell address  

 
Absolute Reference and Relative Reference in Formula: 

 
Relative Reference: 



 In Excel formulas, by default, cell references are relative. When you copy a formula to 
another cell, the reference is adjusted relative to the new location. 

 For example, if you have a formula in cell B2 as `=A1+B1`, and you copy this formula 
to cell C2, it will automatically adjust to `=B1+C1`. 

 
Absolute Reference: 

 An absolute reference in a formula means that the reference does not change when 
you copy the formula to another cell. It is denoted by adding a dollar sign ($) before 
the column letter and row number. 

 For example, if you have a formula in cell B2 as `=$A$1+B1`, and you copy this 
formula to cell C2, the absolute reference `$A$1` will remain the same, while the 
relative reference `B1` will adjust to `C1`. 

 
Cell Address: 

 
 A cell address in Excel refers to the unique identifier for a cell, and it is a combination 

of the column letter and the row number. For example, the cell address "A1" 
represents the cell in the first column and the first row. 

 In a cell address, the column letter always comes before the row number. Columns 
are labeled with letters (A, B, C, ..., Z, AA, AB, ...) and rows are labeled with numbers 
(1, 2, 3, ...). 

 Examples: 
o Cell in the first column and first row is "A1." 
o Cell in the second column and third row is "B3." 

 
Q14. a) What tools are available to customize our PowerPoint presentation? 
Microsoft PowerPoint offers a variety of tools and features to customize presentations, 
allowing users to create visually appealing and engaging slideshows. Here are some key 
tools available for customization in PowerPoint: 
 
1) Design Themes: 

(i) PowerPoint provides pre-designed themes that include a consistent set 
of fonts, colors, and effects. You can choose a theme that complements 
your presentation style. 

 
2) Slide Layouts: 

(i) Different slide layouts offer various arrangements of text boxes, images, 
and other elements. You can choose the most suitable layout for each 
slide. 

 
3) Background Styles: 



(i) Customize the background of your slides by selecting background styles, 
colors, or adding images. You can access these options in the "Design" 
tab. 

 
4) Transition Effects: 

(i) Apply transition effects to slides to add dynamic visual transitions 
between them. Access transition options in the "Transitions" tab. 

 
5) Animation Effects: 

(i) Add animation effects to individual elements within slides to control 
how they appear or move during a presentation. Access animation 
options in the "Animations" tab. 

 
6) Charts and Graphs: 

(i) Insert charts and graphs to represent data visually. PowerPoint offers 
various chart types that you can customize based on your data. 

 
7) Shapes and Icons: 

(i) Insert shapes and icons to enhance the visual appeal of your slides. 
Customize the color, size, and position of these elements. 

 
8) Text Formatting: 

(i) Format text using various fonts, sizes, colors, and styles. You can also 
adjust paragraph spacing, alignment, and indentation. 

 
9) Image Editing: 

(i) Edit and enhance images directly within PowerPoint. Crop, resize, adjust 
brightness, and apply artistic effects to images. 

 
10) Audio and Video Integration 

(i) Embed audio and video files into your presentation slides. Adjust 
playback options and customize how multimedia elements behave 
during the presentation. 

 
Q14 b) Write the steps for the following action for creation of power point presentation  
 Open a Blank presentation  
 Save the presentation as Lab1.pptx  
 Add a Title to the first slide: the name of your college  
 Type your first name and last name in the Subtitle section  
 Add a New Slide which has a Title and Content  

 
Open a Blank Presentation: 

 Launch Microsoft PowerPoint. 
 Click on "New Blank Presentation" from the main screen. 



Save the Presentation: 

 Click on the "File" tab in the top left corner. 
 Select "Save As". 
 In the "File name" field, type "Lab1.pptx". 
 Choose a saving location, like your Documents folder. 
 Click "Save". 

 
Add a Title to the First Slide: The Name of Your College: 

 In the new presentation, click on the first slide. 
 In the text box that says "Click to add title," type the name of your college. 

 
Type Your First Name and Last Name in the Subtitle Section: 

 Below the title, you'll find a text box that says "Click to add subtitle." 
 Type your first name and last name in this subtitle section. 

 
Add a New Slide with Title and Content: 

 Click on the "Home" tab in the ribbon. 
 Click on the "New Slide" button in the Slides group. 

 
Choose Title and Content Layout: 

 From the dropdown menu, select the "Title and Content" layout. 
 
Enter Title and Content in the New Slide: 

 In the title box of the new slide, type a title for your content. 
 In the content area, type any additional information or content you want to include. 

 
Save the Presentation: 

 Click on "File" in the upper left corner. 
 Select "Save" to save any changes you've made. 

 
Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to 
use the tools of PowerPoint. It should include the following things  
 Title slide &bullet list  
 Inserting Excel Sheet  
 Clip art and Text  
 Slide show effects  

 
Title Slide & Bullet List: 

o Open Microsoft PowerPoint. 
o Click on "File" and select "New" to create a new presentation. 



o Choose a design theme for your presentation. 
o Click on the first slide and enter a title for your presentation. 
o Below the title, click on the subtitle area and enter a bullet list of key points. 

 
Inserting Excel Sheet: 

o Click on the slide where you want to insert the Excel sheet. 
o Go to the "Insert" tab in the ribbon. 
o Click on "Object" in the Text group. 
o In the Object dialog box, select "Microsoft Excel Worksheet." 
o A blank Excel sheet will appear on your slide. 
o Enter or copy-paste your data into the Excel sheet. 

 
Clip Art and Text: 

o Choose a slide where you want to add clip art and text. 
o Click on the "Insert" tab. 
o Click on "Pictures" to insert clip art or images. Choose an image from your computer. 
o Resize and position the image as needed. 
o Add text boxes using the "Text Box" option in the "Insert" tab. 
o Enter relevant text next to the clip art. 

 
Slide Show Effects: 

o Select the slide where you want to apply slide show effects. 
o Go to the "Transitions" tab in the ribbon. 
o Choose a transition effect from the available options. 
o Adjust the transition duration and other settings if needed. 
o Click on "Apply to All" if you want the same transition for all slides. 

 
Q16. What is the difference between Machine Language and High Level Language? 
Machine language and high-level language are two very different ways of communicating 
with computers. Here's a breakdown of their key differences: 
 
Machine Language: 

1. Low-level: Instructions directly understood by the computer's processor. 
2. Binary code: Uses only 0s and 1s to represent instructions and data. 
3. Difficult to understand and write: Requires in-depth knowledge of computer 

architecture. 
4. Fast and efficient: Executes directly by the processor without translation. 
5. Examples: Assembly language (slightly more human-readable than pure binary). 

 
High-Level Language: 

1. Abstracted: Uses keywords and syntax closer to human language. 



2. Easier to learn and write: More intuitive and less error-prone compared to machine 
language. 

3. Less efficient: Requires translation into machine language by a compiler or 
interpreter. 

4. Wide variety of options: Many different languages for various purposes (e.g., Python 
for general-purpose programming, Java for web development). 

5. Examples: Python, Java, C++, C#, JavaScript, etc. 
 
Q17. Discuss about different data types of C programming Language. 
Data Types in C are: 
`char`: 

o Description: The `char` data type is used to represent a single character. It occupies 1 
byte of memory and can store characters from the ASCII character set. 

o Example: `char myChar = 'A';` 
 
`int`: 

o Description: The `int` data type is used to store integer values. It typically occupies 4 
bytes on most modern systems, but the size may vary depending on the platform. 

o Example: `int myInt = 42;` 
 
`short`: 

o Description: The `short` data type is used to store integer values, similar to `int`, but 
it usually occupies 2 bytes of memory. It is often used when memory space is a 
critical consideration. 

o Example: `short myShort = 32767;` 
 
`long`: 

o Description: The `long` data type is used to store larger integer values. It usually 
occupies 4 or 8 bytes, depending on the system. `long` can hold a larger range of 
values than `int`. 

o Example: `long myLong = 123456789L;` 
 
float`: 

o Description: The `float` data type is used to represent floating-point numbers, which 
include decimal values. It typically occupies 4 bytes and provides about 7 decimal 
digits of precision. 

o Example: `float myFloat = 3.14f;` 
 
Q18. Find the output of the following expressions  
a) X=20/5*2+30-5   b) Y=30 – (40/10+6) +10  c) Z= 40*2/10-2+10  
 
Here are the outputs of the given expressions in C: 

A) X = 20/5*2 + 30 - 5 
 



X = 4 * 2 + 30 – 5  

X = 8 + 30 – 5  

X = 38 – 5 

X = 33 
  

B) Y=30 – (40/10+6) +10 

 
Y = 30 – (4 + 6) + 10 
Y = 30 – 10 + 10  
Y = 20 + 10 
Y = 30 
 
C) Z= 40*2/10-2+10 
 
Z = 80 / 10 – 2 + 10 
Z = 8 – 2 + 10 
Z = 6 + 10 
Z = 16 
 
So, the final result: 
A) X = 33 
B) Y = 30 
C) Z = 16 
 
Q19. Describe the syntax of the following statements  
a) If – else statement b) for loop c) while loop d) do-while loop  
 
a) If-else Statement: 
 
The `if-else` statement is used for decision-making in C programming. 
 
Syntax: 
 
if (condition) 
{ 
    // Code to be executed if the condition is true 
} 
else 
{ 
    // Code to be executed if the condition is false 
} 
 
 
 



b) For Loop: 
 
The `for` loop is used for iterative operations in C. 
 
Syntax: 
 
for (initialization; condition; update) 
{ 
    // Code to be executed in each iteration 
} 
 
`initialization`: Executed once at the beginning to initialize variables. 
`condition`: Checked before each iteration. If false, the loop exits. 
`update`: Executed after each iteration to update variables. 
 
c) While Loop: 
 
The `while` loop is another construct for repetitive execution. 
 
Syntax: 
 
while (condition) 
{ 
    // Code to be executed in each iteration 
} 
 
 
d) Do-While Loop: 
 
The `do-while` loop is similar to the `while` loop, but it guarantees that the code inside the 
loop is executed at least once. 
 
Syntax: 
 
do 
{ 
    // Code to be executed in each iteration 
} while (condition); 
 
 
 
 
 
 
 



Q20. Find the output of the following program segments 
 
a)  b)  c)  
#include <stdio.h>  
int main()  
{  
int i;  
for (i=1; i<2; i++)  
{  
printf( "IMS 
Ghaziabad\n");  
}  
} 

#include <stdio.h>  
int main()  
{  
int i = 1;  
while ( i <= 2 )  
{  
printf( "IMS 
Ghaziabad\n");  
i = i + 1;  
}  
} 

#include <stdio.h>  
void main()  
{  
int a = 10, b=100;  
if( a > b )  
printf( "Largest number is %d\n”, 
a);  
else  
printf( "Largest number is %d\n”, 
b);  
}  

 
a) 
#include <stdio.h>  
int main()  
{  
int i;  
for (i=1; i<2; i++)  
{  
printf( "IMS Ghaziabad\n");  
}  
} 
 
Output:- IMS Ghaziabad 
 
Explanation:-This is because the loop runs once (while `i` is less than 2), and the string is 
printed during that single iteration. After the loop, the program exits. 
 
b) 
#include <stdio.h>  
int main()  
{  
int i = 1;  
while ( i <= 2 )  
{  
printf( "IMS Ghaziabad\n");  
i = i + 1;  
}  
} 
 
Output:- IMS Ghaziabad 



Explanation:-This is because the loop runs once (while `i` is less than or equals to 2), and the 
string is printed during each iteration. After the loop, the program exits. 
 
c) 
#include <stdio.h>  
void main()  
{  
int a = 10, b=100;  
if( a > b )  
printf( "Largest number is %d\n”, a);  
else  
printf( "Largest number is %d\n”, b);  
} 
 
Output:- Largest number is 100 
 
Explanation:-This is because the value of `b` (100) is greater than the value of `a` (10). 
Therefore, the program prints "Largest number is 100". 


