CCA-101: Funhdamentals of IT & Programming

Assignment -1

Q1: What are the four fundamental parts of computer? Explain it with the help of diagram.

Ans. A computer has four main components: Input Units, the central processing unit or CPU, the Primary memory,
and Output units.

eInput Unit - The devices to input information, such as a keyboard, and mouse.
*CPU - The CPU is further broken up into ALU, Control Unit, and Instruction Unit.

*Primary Memory - Computer program instructions converted into machine code are stored in primary storage or

memory.

*Qutput Unit - The devices to output information, such as a printer, monitor, and speaker.
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Block diagram of computer system

Q2: Discuss about the classification of computers based on size and capacity.
Ans. Computers are classified on different parameters, such as, storage capacity, processing speed and
component (CPU) used in computers.

Features Microcomputer Minicomputer

Primary memory Shall memory Larger memory
Word length Small word length Larger word length
Cost low Low High

Processor Low High

Q3: What is the meaning of computer generation? How many Computer Generations are
defined? What technologies were/are used?

Ans. There are five computer generations known till date. Each generation has been discussed in
detail along with their time period and characteristics. In the following table, approximate dates



against each generation has been mentioned, which are normally accepted.
Following are the main five generations of computers.

S.N
Generation & Description

o
First Generation

1
The period of first generation: 1946-1959. Vacuum tube based.
Second Generation

2
The period of second generation: 1959-1965. Transistor based.
Third Generation

3
The period of third generation: 1965-1971. Integrated Circuit based.
Fourth Generation

4
The period of fourth generation: 1971-1980. VLSI microprocessor based.
Fifth Generation

5

The period of fifth generation: 1980-onwards. ULSI microprocessor based.

Q4: Differentiate between Volatile & Non- Volatile memories.

Ans. Volatile memory is the type of memory in which data is lost as it is powered-off. Non-volatile memory is the
type of memory in which data remains stored even if it is powered-off. 2. Contents of Volatile memory is stored
temporarily

Q5: Distinguish among system software, application software and open source software on the basis
of their features.

Differences between System Software
and Application Software

System software is meant to manage the Application software helps perform a Open source software (OSS)

system resources. It serves as the specific set of functions for which they have is software that is
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Differences between System Software
and Application Software

platform to run application software. been designed. use, modification, and

distributed with its source
code, making it available for

distribution with its original

rights.
System software is developed in a low-  Application software is developed in a high-
level language (assembly language for  level language such as Java, C++, .net and
example) VB.
System software automatically starts Lo
] . Application software runs as and when the
running once the system is turned on and .
. user requests it.
stops when the system is shut down.
A system cannot even start without Application software is user specific and it is
system software not needed to run the system on the whole.
System software is endowed with a Application software carries a specific
general purpose. purpose.

Some characteristic examples for application
software is MS Office, Photoshop and
CorelDraw

A typical example for a system software
is Windows Operating System

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with file name
“yourself”. Describe all steps involved in it.

1. Open MS Word.

2. Type the required content.

3. Click on file— saveas

4. Browse for the location where | have place a file. Give a name as yourself.

5. Click on save button.

Q6 b) Write steps regarding followings
» To change the font style
» To change the font size
» To change the font color
» To highlight (in yellow) the line that reads “need to get IMS’s address”.
Q7. Create a file in MS-Word for the following document and save it with file name ‘ms_word’.

Describe all steps involved in it.

MS Word
MS Word is a widely used commercial word processor developed by Microsoft.
MSword is application software, which is capable of

® creating,

® editing,

® saving, and

® printing any type of document



Ans. Steps:-

1. Open MS Word.

2. Type the given content.

3. Click on file— saveas

4. Browse for the location where | have place a file. Give a name as ms_word.
5. Click on save button.

Q8. Create a file in MS-word for the following document and save it with file name ‘equations’.
Describe all steps involved in it.

Eguaticoms
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. Open MS Word.

. Type the given content.

. Click on file—> saveas

. Browse for the location where | have place a file. Give a name as equations.
. Click on save button.
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Q9. Create a file in MS-word that convert existing highlight text to table as shown below and save it as
file name ‘text_to_table’. Describe all steps involved in it.

Select the text vou want to convert.
Select the Insert tab.

Click on Table command. A dialog box appears.
Click on Convert Text to Table, a new dialog box appears

here set number of columns.

Click on OK Finally Selected text convert in a table

11

Select the text vou want to convert.

Select the Insert tab.

Click on Table command. A dialog box appears.

Click on Convert Text to Table, a new dialog box
appears

here set number of columns.

Click on OK Finally Selected text convert in a table

Ans. Open MS word— Select the highlighted text that you want to convert, and then click Insert > Table > Convert
Text to Table. In the Convert Text to Table box, choose the options you want. Under Table size, make sure the
numbers match the numbers of columns and rows you want. = file— saveas->text_to_table

Q10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in

it.

Ans. Step 1: Click on insert

step 2: click on table

step 3: select the required number of rows and column.

Q11. Create a following worksheet in MS-excel and save it with name ‘book1’.
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Q12. Calculate the following things of a range (C2:C11) of data in the worksheet created in question

no 10.

YV VYV

Ans.  Formula

=sum( C2:C11)
=avg(c2:c11)
=max(c2:c11)
=min(c2:c11)

YV VVYVYY

the sum of the marks using AutoSum in a range of cells (C2:C11)
average of the marks in a range of cells (C2:C11)

highest marks in a range of cells (C2:C11)

minimum marks in a range of cells (C2:C11)
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Q13 a) Describe various steps involved in the following
» To modify column width of a worksheet
» To modify the row height of a worksheet
» To delete rows and columns of worksheet
Ans. Modify columns
Select a column or a range of columns.

On the Home tab, in the Cells group, select Format > Column Width.
Type the column width and select OK.

Set a row to a specific height

Select the row or rows that you want to change.

On the Home tab, in the Cells group, click Format.

Under Cell Size, click Row Height.

In the Row height box, type the value that you want, and then click OK.
Select the cells, rows, or columns that you want to delete.

1.Right-click, and then select the appropriate delete option, for example, Delete Cells & Shift Up, Delete Cells &
Shift Left, Delete Rows, or Delete Columns.

Q13 b) Describe following terms in the worksheet

> Absolute reference and relative reference in formula

> Cell address
Ans. Relative references change when a formula is copied to another cell. Absolute references, on the other
hand, remain constant, no matter where they are copied.

A cell reference, or cell address, is an alphanumeric value used to identify a specific cell in a spreadsheet. Each cell
address contains 'one or more letters' followed by a number. The letter or letters identify the column and the
number represents the row.

Q14. a) What tools are available to customize our PowerPoint presentation?
Ans. Home. The Home tab holds the Cut and Paste features, Font and Paragraph options, and what you need to
add and organize slides.
eInsert. Click Insert to add something to a slide. ...

*Design. ...
*Transitions. ...
eAnimations. ...
*Slide Show. ...
*Review. ...

*\View.

Q14 b) Write the steps for the following action for creation of power point presentation
> Open a Blank presentation
> Save the presentation as Lab1.pptx




> Add a Title to the first slide: the name of your college
» Type your first name and last name in the Subtitle section
» Add a New Slide which has a Title and Content

Ans. Start a blank presentation.

1.Type text into your title slide.

2.Insert more slides.

3.Add content to slides.

4.Change the design.

5.Add animations & transitions (optional)

6.Save your PowerPoint presentation file—saveas—Lab1.pptx.

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to use the
tools of PowerPoint. It should include the following things

» Title slide &bullet list

» Inserting Excel Sheet

» Clip art and Text

» Slide show effects

Ans. Start a blank presentation.
Type text into your title slide.

Insert more slides. Add content to slides. Select title slide and bullet list from the toolbar.
Click on insert and browse and select the required excel sheet. Insert the clipbox and text.
Click on Animation button for slide show effect.

Part -2

Q16. What is the difference between Machine Language and High Level Language?
Ans.

High-Level Language Low-level language

) ) It is considered as a machine-friendly
It can be considered as a programmer-friendly language.

language.
It requires a compiler/interpreter to be translated into machine It requires an assembler that would
code. translate instructions.
It can be ported from one location to another. It is not portable.
It is easy to understand. It is difficult to understand.

It is easy to debug. It is difficult to debug.




High-Level Language Low-level language

It is less memory efficient, i.e., it consumes more memory in
. It consumes less memory.
comparison to low-level languages.

Q17. Discuss about different data types of C programming Language.
Ans. There are the following data types in C language.

Basic Data Types.

Data Types Memory Size Range

signed shortint 2 byte -32,768 to 32,767

unsigned short int 2 byte 0to 65,535

long int 4 byte -2,147,483,648 to 2,147,483,647
signed long int 4 byte -2,147,483,648 to 2,147,483,647

Q18. Find the output of the following expressions

a) X=20/5*2+30-5 b) Y=30 - (40/10+6) +10 c) Z=40*2/10-2+10
Ans. a)33, b) 30 C) 16

Q19. Describe the syntax of the following statements

a) If - else statement b) for loop c) while loop d) do-while
loop
Ans. The if-else statement in C is used to perform the operations based on some
specific condition. The operations specified in if block are executed if and only if

the given condition is true.

The for loop in C language is used to iterate the statements or a part of the
program several times. It is frequently used to traverse the data structures like

the array and linked list.

C while loops statement allows to repeatedly run the same block of code until a
condition is met. while loop is a most basic loop in C programming. while loop

has one control condition, and executes as long the condition is true.




The C do while statement creates a structured loop that executes as long as a

specified condition is true at the end of each pass through the loop. The syntax

for a do while statement is: ... If the value of the expression is "false" (i.e.,

compares equal to zero) the loop is exited.

Q20. Find the output of the following program segments

#include <stdio.h>
int main()
{
inti=1; while
(i<=2)
{
printf( "IMS Ghaziabad\n");
i=i+1;
}
}

Ans. IMS Ghaziabad
IMS Ghaziabad

#include <stdio.h>
void main()
{
int a = 10, b=100;
iflta>b)
printf( "Largest number is %d\n”, a);
else
printf( "Largest number is %d\n”, b);
}

Ans. Largest number is 100
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