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Question-1: What are the four fundamental parts of computer? Explain it with the help of 
diagram. 
Answer: The four fundamental parts of computer are as follows. 

 Central Processing Unit (CPU) 
 Memory (RAM) 
 Input (Keyboard,mouse,etc) 
 Output (Monitor , printer, etc) 
 

DIAGRAM REPRESENTATION 

 
 
Question-2: Discuss about the classification of computers based on size and capacity. 
Answer: Computer are classified as follows:- 

 Super Computer- They are the most powerful and physically the largest in size. These are 
system designed to process huge amount of data. They have thousands of processors.  
Example- JAGUAR, ROAD RUNNER  

 Main frame computer- They are very large often feeling an entire room and can process 
thousands of millions of instruction per second. They are capable of supporting 
hundreds to thousands of users simultaneously. They are used in reservation and 
ticketing for an airline 
Example- IBM MAIN FRAMES Z13, IBM SYSTEM Z9 MAIN FRAME. 

 Mini Computer- They are much smaller than main frames . These computer are less 
expensive. User connect to the server through a network by using a desktop computer.  
Example- Apple iPod , CDC160A  

 Micro Computer- They are the most frequently used types of computer. It is also known 
aspersonal computer. A micro computer is a small computer system designed to be used 
by one person at a time. 
Example- Desktop computer , Laptops. 

 



 
 
Question-3: What is the meaning of computer generation? How many Computer Generations 
are defined? What technologies were/are used? 
Answer: Generation in computer terminology is a change in technology a computer is/was being used. 
Initially, the generation term was used to distinguish between varying hardware technologies. 
Nowadays, generation includes both hardware and software, which together make up an entire 
computer system 
There are five types of computer generation:  
 
 

1 

First Generation 

The period of first generation: 1946-1959. Vacuum 
tube based. 

2 

Second Generation 

The period of second generation: 1959-1965. 
Transistor based. 

3 

Third Generation 

The period of third generation: 1965-1971. 
Integrated Circuit based. 

4 

Fourth Generation 

The period of fourth generation: 1971-1980. VLSI 
microprocessor based. 

5 

Fifth Generation 

The period of fifth generation: 1980-onwards. ULSI 
microprocessor based. 

 
 
 
Question-4: Differentiate between Volatile & Non- Volatile memories. 
Answer: The important differences between Volatile and Non-Volatile Memory. 

Sr. 
No. 

Key Volatile 
Memory 

Non-Volatile 
Memory 

1 

Data 
Retention 

Data is present 
till power 
supply is 
present. 

Data remains 
even after power 
supply is not 
present. 



Sr. 
No. 

Key Volatile 
Memory 

Non-Volatile 
Memory 

2 
Persistence Volatile 

memory data is 
not permanent. 

Non-volatile 
memory data is 
permanent. 

3 

Speed Volatile 
memory is 
faster than non-
volatile 
memory. 

Non-volatile 
memory access is 
slower. 

4 

Example RAM is an 
example of 
Volatile 
Memory. 

ROM is an 
example of Non-
Volatile 
Memory. 

5 

Data 
Transfer 

Data Transfer is 
easy in Volatile 
Memory. 

Data Transfer is 
difficult in Non-
Volatile 
Memory. 

6 

CPU 
Access 

CPU can access 
data stored on 
Volatile 
memory. 

Data to be copied 
from Non-
Volatile memory 
to Volatile 
memory so that 
CPU can access 
its data. 

7 

Storage Volatile 
memory less 
storage 
capacity. 

Non-Volatile 
memory like 
HDD has very 
high storage 
capacity. 

8 

Impact Volatile 
memory such as 
RAM is high 
impact on 
system's 
performance. 

Non-volatile 
memory has no 
impact on 
system's 
performance. 



Sr. 
No. 

Key Volatile 
Memory 

Non-Volatile 
Memory 

9 

Cost Volatile 
memory is 
costly per unit 
size. 

Non-volatile 
memory is cheap 
per unit size. 

 
 
 
 
Question-5: Distinguish among system software, application software and open source 
software on the basis of their features. 
Answer: System Software: 
System Software is the type of software which is the interface between application software and 
system. Low level languages are used to write the system software. System Software maintain the 
system resources and give the path for application software to run. An important thing is that without 
system software, system can not run. It is a general purpose software. 

Application Software: 
Application Software is he type of software which runs as per user request. It runs on the platform 
which is provide by system software. High level languages are used to write the application software. 
Its a specific purpose software. 

 
Open Source Software: 
It is a type of computer software in which source code is released under a license in which the copy 
right holder grants user rights to study , change and distribute the software to any one for any purpose. 
The linux operating system is the best example of OSS.  
 
 
Question-6:a) Create a file in MS-word to insert a paragraph about yourself and save it with file 
name “yourself”. Describe all steps involved in it. 
Answer: To create a file in Ms-word 

1. Open Word. Or, if Word is already open, select File > New. 

2. In the Search for online templates box, enter a search word like letter, resume, or invoice. Or, select a 
category under the search box like Business, Personal, or Education. 

3. Click a template to see a preview. ... 

4. Select Create. 

 

To save a file in Ms-word 

1. Click FILE > Save, pick or browse to a folder, type a name(Yourself) for your document in 
the File name box, and click Save. 

2. Save your work as you go - hit Ctrl+S often. 
3. To print, click the FILE tab, and then click Print. 



 
 Q7. Create a file in Ms-Word for the following document and save it with file name ‘ms_word’. 
Describe all steps involved in it 
 
Answer: MS WORD 
MS WORD is a widely used commercial word processor developed by Microsoft. 
 MS word is application software, which is capable of 

 Creating, 

 Editing, 
 Saving, and 

 printing and type of document 

 
Question-8:  Create a file in MS-word for the following document and save it with file name 
‘equations’. Describe all steps involved in it. 
Answer: Equations 
                X2+Y5=30 
                Z3+Q4=50 
                A2+B8=X2+Y8 

 
Steps involved in it are: 

 Use strikethrough from front icon for Equation 
 Use subscript for x2 etc 

 
Q9. Create a file in MS-word that convert existing highlight text to table as shown below and 
save it as file name ‘text_to_table’. Describe all steps involved in it. 
Answer: 

Select the text you want to convert. Select the Insert tab. 
Click on Table command. A dialog box appears. 
 

Click on Convert Text to Table, a new dialog 
box appears 

here set number of columns. Click on OK Finally Selected text convert in a 
table 

 

Steps involved it are 
 Click inset icon 
 Click table 
 Select the Row and the column as per need 

 
Question-10: Create a file in MS-Word to insert a table in the document. Describe all steps 
involved in it 
Answer: 
S NO              MRP              DISCOUNT PRICE 
1 5000 4250 
2 6500 5200 
3 2500 2250 
4 4200 3500 
5 1800 1500 
 
Steps involved it are 



 Click inset icon 
 Click table 
 Select the Row and the column as per need 

 
Question-11: Create a following worksheet in MS-excel and save it with name ‘book1’. 
Answer: 
ROLL NO NAME MARKS

1 n1 60
2 n2 70
3 n3 80
4 n4 90
5 n5 40
6 n6 50
7 n7 77
8 n8 44
9 n9 88

10 n10 55  
 
Question-12 . Calculate the following things of a range (C2:C11) of data in the worksheet 
created in question no 10. 

 the sum of the marks using AutoSum in a range of cells (C2:C11) 
 average of the marks in a range of cells (C2:C11) 
 highest marks in a range of cells (C2:C11) 
 minimum marks in a range of cells (C2:C11) 

Answer: 
ROLL NO NAME MARKS

1 n1 60
2 n2 70
3 n3 80
4 n4 90
5 n5 40
6 n6 50
7 n7 77
8 n8 44
9 n9 88

10 n10 55
TOTAL 654
AVERAGE 118.9090909
HIGHEST MARKS 90
MINIMUM MARKS 40  
 
Question-13 a) Describe various steps involved in the following   

 To modify column width of a worksheet 
 To modify the row height of a worksheet 
 To delete rows and columns of a worksheet 

 
Answer: To modify column width of a worksheet 
 



1. Position the mouse over the column line in the column heading so the cursor becomes a double 
arrow. 

2. Click and drag the mouse to increase or decrease the column width. 

3. Release the mouse. The column width will be changed. 

 
To modify the row height of a worksheet 
 

1. Select the row or rows that you want to change. 

2. On the Home tab, in the Cells group, click Format. 

3. Under Cell Size, click Row Height. 

4. In the Row height box, type the value that you want, and then click,  ok 

 

To delete rows and column of a worksheet 

 

1. Select the row(s) or column(s) you want to delete. 

2. Choose Home→Cells→Delete. 
 
 
Question-13 b) Describe following terms in the worksheet  

 1-Absolute reference and relative reference in formula 
 2-Cell address 

 
Answer: 

 1-Absolute Reference-An absolute reference is designated in a formula by the 
addition of a dollar sign ($) before the column and row. If it precedes the column or row (but 
not both), it's known as a mixed reference. You will use the relative (A2) 
and absolute ($A$2) formats in most formulas. 

 Relative Reference-When copied across multiple cells, they change based on 
the relative position of rows and columns. For example, if you copy the formula =A1+B1 
from row 1 to row 2, the formula will become =A2+B2. 

 
 

2-Cell Address-A cell reference or cell address is a combination of a column letter 
and a row number that identifies a cell on a worksheet. 

For example, A1 refers to the cell at the intersection of column A and row 1; B2 refers to the second 
cell in column B, and so on. 

 

 
 
 
Question-14: a) What tools are available to customize our PowerPoint presentation? 
 



 Answer: Visme. Visme is a cloud-based presentation tool that allows you to create highly visual 
presentations to engage viewers and communicate your ideas 

 Haiku Deck. Haiku Deck is a platform that prioritizes simplicity 

 Pitcherific. 

 Canva 

 SlideCam. 

 Microsoft Events 

 Powtoon 

 

Question-14 b) Write the steps for the following action for creation of power point presentation   

 Open a Blank presentation 

 Save the presentation as Lab1.pptx 

 Add a Title to the first slide: the name of your college 

  Type your first name and last name in the Subtitle section   

 Add a New Slide which has a Title and Content 

 

 Answer: Steps for creation of open a blank presentation 

1. Choose File→New. Backstage view opens, displaying tiles for various types of presentations you 
can create. 

2. Click the Blank Presentation tile. A new blank presentation opens. 

3. Choose File→Close to close the new presentation. ... 

4. Press Ctrl+N. ... 

5. Choose File→Close to close the new presentation. 

 

 Steps to save the presentation as Lab1.pptx 

 Step 1 − Click on the File tab to launch the Backstage view and select Save. 

 Step 2 − In the Save As dialog, type in the file name and click "Save". 

 Step 3 − The default file format is  pptx. 

 

 Steps to add to the first slide  

 In the slide thumbnail pane on the left, click the slide that you want your new slide to follow. 

 On the Home tab, click New Slide. 

 In the New Slide dialog box, select the layout that you want for your new slide. Learn more 
about slide layouts. 

 Select Add Slide. 

 

 Steps to type your first and last name in a subtitle section 

 



 

FIRST NAME-KAIF

LAST NAME-SIDDIQUI

 
 

 Step to add a new slide which has a title and content 
 

1. Select the slide whose layout you will change so that it can have a title. 

2. Click Home > Layout. 

3. Select Title Slide for a standalone title page or select Title and Content for a slide that contains a 
title and a full slide text box. ... 

4. Select the Click to add title text box 
 

Question15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill 
to use the tools of PowerPoint. It should include the following things   
 Title slide &bullet list 
 Inserting Excel Sheet   
 Clip art and Text   
 Slide show effects 

 
 

 Answer :Step for creation of title slide & bullet list 
 

 Choose Insert > New Slide, click the New Slide button on the toolbar, or press the hotkey 
Ctrl+M. 

 From the Slide Layout task pane, choose the Bulleted List layout  

 Click the title placeholder and type the title of your bulleted list. 

 

 Steps for inserting excel sheet 
 

 To insert a new worksheet in front of an existing worksheet, select that worksheet and then, 
on the Home tab, in the Cells group, click Insert, and then click Insert Sheet. Tip: You can 
also right-click the tab of an existing worksheet, and then click Insert. On the General tab, 
click Worksheet, and then click OK. 
 
 

 Steps for inserting of clip art and text 



 Open the Word document where you would like to insert the clip art. Click the [Insert] tab 
> From the "Illustrations" group, click [Clip Art]. A clip art pane will open to the right of the 
document. In the "Search for" box, type a term or keyword for the clip art you would like to 
find  

 
 

 Steps for inserting slide show effect 
 

 Select the slide you want to add a transition to. 

 Select the Transitions tab and choose a transition. ... 

 Select Effect Options to choose the direction and nature of the transition. 

 Select Preview to see what the transition looks like. 

 
 

Question16-What is the difference between Machine Language and High Level Language? 
Answer: Machine Language  

 
 

 

 

High level language 



 
 

 

 

Question17- Discuss about different data types of C programming Language. 
Answer: C language supports 2 different type of data types: 

1. Primary data types: 

These are fundamental data types in C namely integer(int), floating point(float), 

character(char) and void. 

2. Derived data types: 

Derived data types are nothing but primary datatypes but a little twisted or grouped together 

like array, stucture, union and pointer. These are discussed in details later. 

Data type determines the type of data a variable will hold. If a variable x is declared as int. it means x 
can hold only integer values. Every variable which is used in the program must be declared as what 
data-type it is. 

 

Question18- Find the output of the following expressions 
 a) X=20/5*2+30-5  
b) Y=30 – (40/10+6) +10 



 c) Z= 40*2/10-2+10 
Answer:   
a) X=33 

b) Y=30 

c)  Z=16 

 

Question-19  Describe the syntax of the following statements 
 a)  If – else statement 
 b)  for loop 
 c)  while loop 
 d)  do-while loop 
Answer: 

 Syntax for  (If –else statement) 
 
If (expression) 
{ 
True block of statement, 
} 
Else 
} 
Else block of statement 
 

 Syntax for (for loop) 
 
For (expression 1, expression 2, expression 3) 
{ 
Block of statement 
} 
 

 Syntax for (while loop) 
 
While (condition) 
Single statement, 
 OR 
While (condition) 
{ 
Block of statement, 
} 
 

 Syntax for (do while loop) 
 
do 
( 
Single statement, 
OR 
Block of statement, 
} 
While (condition), 
 
 



Question-20 Find the output of the following program segments 
 
Answer: 

a) IMS Ghaziabad 
 

b) IMS Ghaziabad 
IMS Ghaziabad 

              
c) Largest  number is 100 

 


