
                                      Assignment-1 

Q.1:- What are the four fundamental parts of computer? Explain it          with the 

help of diagram. 

Ans:- Input unit, CPU, Primary Memory, and Output unit are the       basic 

components of a computer system. 

Explanation: 

A computer has four main components: 

• Input Unit – The devices to input information, such as a Keyboard, and 

mouse. 

• CPU – the CPU is further broken up into ALU, Control Unit, and Instruction 

Unit. 

• Primary Memory – Computer program instructions converted into machine 

code are stored in primary storage or memory. 

• Output Unit – The devices to output information, such as printer, monitor, 

and speaker.  

 

 

 

Q2. Classification of Computer On the Basis of Size 

We can classify computers on the basis of size as below: 



1.Super computer 

 

Super computer is the fastest, most expensive, big in size, and most powerful 

computer that can perform multiple tasks within no second. It has multi-user, 

multiprocessing, very high efficiency and large amount of storage capacity. It is 

called super computer because it can solve difficult and complex problem 

within a nano second. 

 

Application 

 

Used to forecast the weather and global climates 

Used in military research and defense systems 

In automobile, aircraft, and space craft designing 

Used in seismography, plasma and nuclear research 

Study of genetic engineering 

Digital film recording 

Example 

C-DAC (Center for Development of Advanced Computer) of India has 

developed PARAM series of Super Computer. ANURAG is also Indian Super 

Computer. Other Super Computers are CRAY XMP/14, CDC-205 etc. Mr. 

Seymour Cray was a pioneer person in the field of supercomputer production. 

He had developed the first super computer Cray-1 in 1976. 

  

2.Mainframe Computer 

Mainframe Computer is the large sized computer that covers about 1000 sq 

feet. It is general purpose computer that is designed to process large amount 

of data with very high speed. It accepts large amount of data from different 

terminals and multiple users and process them at same time. More than 100 



users are allowed to work in this system. It is applicable for large organization 

with multi-users for example: large business organization, Department of 

examinations, Industries and defense to process data of complex nature. It 

uses several CPU for data processing. 

 

Application Areas 

 

Government and civilian 

Credit card processing 

Back Account management 

Example 

IBM S/390, IBM S/709, ICL 39, CDC 6600 

 

3. Minicomputer 

 

Mini Computers are medium sized computer. So, these are popular as middle 

ranged computer. It is also multiple user computer and supports more than 

dozen of people at a time. It is costlier than microcomputer. 

 

It is also used in university, middle range business organizations to process 

complex data. It is also used in scientific research, instrumentation system, 

engineering analysis, and industrial process monitoring and control etc. 

 

Example 

Languages, multimedia, graphics, 3D graphics and games. These are popular 

among students, professionals and home users due to small size, low price and 

low maintenance. 



 

4.Microcomputer 

 

Most popular general purpose computers which are mostly used on day to day 

work are microcomputers. These are popular as Home PC or Personal 

Computer (PC) because these are single user computers and mostly used for 

personal use and application. These support many higher level application cost 

and easy in operation. 

 

Example 

IBM PCs, Apple Mac, IBM PS/2, All computer available with Pentium Models 

etc. 

 

Q.3 What is the meaning of computer generation ? How many computer 

Generation are defined ? What technologies were/are used? 

Ans. “Generation” in computer talk is a step in technology . It provides a 

framework (structure) for the growth of computer industry . It was used to 

distinguish between various hardware and software technologies in the 

development of computer i.e. due to technological advancement ; different 

changes have come in the computer system. 

Computer Generation : 

 

1. First Generation: {1946-1959} Uses in vacuum tubes / Thermion value , 

large in size  , hard to operate. 

• Input was based on punched cards and paper tape .  

• Only machine and assembly languages were used. 

• The UNIVAC & ENIAC computer are example in 1st generation computing 

devices. 



2. Second Generation:{1959-1964} uses in Transistor .Concept of CPU , Input & 

Output devices & memory unit was introduced + Programming language 

(COBOL, FORTRAN)  

• They were much smaller in size. 

• Faster than the 1st generation computers. 

3. Third Generation: {1964-1971} 

[IC – Integrated circuits] 

IC is also called chips. Transistor & capacitor on thin sheet of silicon.  

• e.g. + IBM – 360, ICL – 1900, IBM – 370, VAX – 750. 

• First to use the OS (Operating system). 

• Uses of HLL. 

4. Fourth Generation: {1971-Onwards} 

• Uses in Microprocessor . 

Use of VLSIC (Very large scale IC) on silicon chip , called microcomputer. 

• VLSIC replaced by LSIC. 

• They are much smaller and cheaper than third generation computers.  

• They had faster and larger primary and secondary storage . 

5. Fifth Generation: [AI – Artificial Intelligence] 

• Computer that can think & work like humans & is called thinking 

machins. 

• Fifth generation computers are several times more powerful than 

fourth generation computers. 

 

 

 

 

 

 

 

 

 



Q.4:- Differentiate between Volatile & Non-Volatile memories. 

 Memory Memory 

 
Volatile 

1. Memory is the type of which 
data is lost as it is powered-
off Contents of Volatile. 

2. Memory is stored 
temporarily. 

3. It is faster than non-volatile 
memory. 

4. RAM (Random access 
memory) is an example of 
volatile memory. 

5. In volatile memory, data can 
be easily transferred in 
comparison to non-volatile 
memory. 

6. In Volatile memory, process 
can read and write. 

7. Volatile memory generally 
has less storage capacity. 

 
 

 
Non-volatile 

1. Memory is the type of 
memory in which data 
remains stored even if it is 
powered-off Non-volatile. 

2. Memory is stored 
permanently. 

3. It is slower than volatile 
memory. 

4. ROM (Read only memory) is 
an non-volatile memory. 

5. In non-volatile memory, data 
can not be easily transferred 
in comparison to volatile 
memory.  

6. In Non-volatile memory, 
process can only read. 

7. Non-volatile memory 
generally has more storage 
capacity than volatile 
memory. 
 

 

       

 

 

 

 

 

 

 



Q5:-                     

SYSTEM SOFTWARE APPLICATION SOFTWARE 

• Computer software designed 
to provide a platform to 
other software. 

• Manages resources and helps 
to run hardware and 
application software. 

• Runs when the system starts 
and runs till the end. 

• Developed using languages 
like c, c++, Assembly.  

• Essential for the proper 
functioning of a system. 

• Ex: operating system, 
language processors and 
device drivers. 

 

• Software designed to 
perform a group of 
coordinated functions, tasks 
or activities for the benefit of 
the user. 

• Performs a specific task 
according to their type. 

• Runs when the user requires. 

• Developed using languages 
like Java, c, c++, Visual Basic. 

• Not extremely important for 
the functioning of the 
system. 

• Ex: Word processor, 
Spreadsheet, Presentation 
software, web browsers, 
graphics software.  

 

open source software:- 

Open source software is software with source code that anyone can 

inspect, modify, and enhance. 

 

"Source code" is the part of software that most computer users don't ever 

see; it's the code computer programmers can manipulate to change how a 

piece of software—a "program" or "application"—works. Programmers 

who have access to a computer program's source code can improve that 

program by adding features to it or fixing parts that don't always work 

correctly. 

 

 

 

 

 

 



 Q6 b) Write steps regarding followings 

➢ To change the font style 

➢ To change the font size 

➢ To change the font color 

➢ To highlight (in yellow) the line that reads “need to get IMS’s address”. 

Ans: - 

➢  Steps to change the font style – Click the (Home) tab > Locate the “Font” 

group. From the lower-right corner of the “Font” dialog box will open. 

Choose the font style and size you would like to use by default. 

➢ Steps to change the font size – 

1. Select the text you want to modify 

2. Click the drop-down arrow next to the Font box on the Home tab. The Font 

drop-down menu appears. 

3. Move the mouse pointer over the various fonts. A live preview of the font 

will appear in the document. 

4. Select the font you want to use. 

➢ Steps to change the font color 

1. Select the text you want to modify 

2. Click the Font Color drop-down arrow on the Home tab. The font color 

menu appears. 

3. Move the mouse pointer over the various font colors. A live preview of the 

color will appear in the document. 

4. Select the font color you want to use. 

   

➢ Steps to highlight the line –  

1. Click the home tab. In the Font group, click the Text highlight button. Word 

is now in highlighting mode. 

2. Drag the mouse over the text you want to highlight. 

3. Click the text highlight button again to return the mouse normal operation. 

 

 

 



Q7:- 

MS Word 

MS Word is widely used commercial word processo  developed Microsoft.  

MS word is application software, which is capable of 

• Creating, 

• Editing, 

• Saving, and 

• Printing any type of document 

 
 

 

Q8: Create a file in Ms-word for the following document and save it with file 

name equation. Describe all steps involve in it.  

Equations: 

X2 + Y2 = 30 

Z3 + Q4 = 50 

A2 + B4 = X2 + Y8 

Steps to involve in it are as follows: 

• Click on the insert tab. 

• In a symbol section choose equation and write these formulas. 

• Then save it as filename ‘Equation’. 

 
 



Q.9 

Select the text you want to convert. 

Select the Insert tab. 

Click on Convert Text to Table, a new dialog box appears  

Here set number of columns. 

Click on OK Finally Selected text convert in table. 

Select the text you want to convert. Select the Insert tab. 

Click on Table command. A 
dialog box appears. 

Click on Convert text Table, a now 
dialog box appears 

Here set number of columns. Click on OK Finally Selected text 
convert in tanle. 

 
 

Q10:- 

      

      

      

      

      

      

      

 

Go to insert > select table > select rows and columns > click ok. 

 

 

 

 



Q11:- 

Roll No Name Marks

1 n1 60

2 n2 70

3 n3 80

4 n4 90

5 n5 40

6 n6 50

7 n7 77

8 n8 44

9 n9 88

10 n10 55  

Q12:- 

Roll No Name Marks

1 n1 60

2 n2 70

3 n3 80

4 n4 90

5 n5 40

6 n6 50

7 n7 77

8 n8 44

9 n9 88

10 n10 55

MINIMUM 40

Roll No Name Marks

1 n1 60

2 n2 70

3 n3 80

4 n4 90

5 n5 40

6 n6 50

7 n7 77

8 n8 44

9 n9 88

10 n10 55

SUM 654

Roll No Name Marks

1 n1 60

2 n2 70

3 n3 80

4 n4 90

5 n5 40

6 n6 50

7 n7 77

8 n8 44

9 n9 88

10 n10 55

AVG 65.4

Roll No Name Marks

1 n1 60

2 n2 70

3 n3 80

4 n4 90

5 n5 40

6 n6 50

7 n7 77

8 n8 44

9 n9 88

10 n10 55

HIGHEST MARK 90  



Q 13. a) : Describe various steps involved in the following  

➢ To modify column width of a worksheet 

➢ To modify the row height of a worksheet 

➢ To delete rows and columns of a worksheet 

Ans:  Select to modify column width of a worksheet- 

• Select the column that you want to change. 

• On the Home tab, in the Cells group, click Format.  

• Under Cell size, click column width 

• In the column width box, type the value that you want. 

• Click OK. 

Steps to modify the row height of a worksheet –  

• Click the Select All button, and then drag the boundary below any row 

heading.  

• To change the row height to fit the contents, double click the boundary 

below the row heading.  

Steps to delete row and columns of a worksheet 

• Right –click in a table cell, row, or column you want to delete 

• On the menu, click deletes Cells. 

• To delete the row, click delete entire row. To delete the column, click 

delete entire column. 

Q13 b): Describe the following terms in the worksheet  

➢ Absolute reference and relative reference in formula 

➢ Cell address 

Ans: Absolute reference and relative reference in formula: - Absolute reference 

is an address or pointer that does not change and remain constant. And Relative 

references change when a formula is copied to another cell. 
 

Q14 A) PowerPoint Tools 

1. Home 

 

The Home tab holds the Cut and Paste features, Font and Paragraph options, 

and what you need to add and organize slides. 



2. Insert 

 

Click Insert to add something to a slide. This includes pictures, shapes, charts, 

links, text boxes, video and more. 

3. Design 

 

On the Design tab, you can add a theme or color scheme, or format the slide 

background. 

4. Transitions 

 

Set up how your slides change from one to the next on the Transitions tab. 

Find a gallery of the possible transitions in the Transition to This Slide group – 

click More  at the side of the gallery to see all of them. 

5. Animations 

 

Use the Animations tab to choreograph the movement of things on your 

slides. Note that you can see many possible animations in the gallery in the 

Animation group, and see more of them by clicking More . 

6. Slide Show 

 

On the Slide Show tab, set up the way that you want to show your 

presentation to others. 

7. Review 

 

The Review tab lets you add comments, run spell-check, or compare one 

presentation with another (such as an earlier version). 

8. View 



 

Views allow you to look at your presentation in different ways, depending on 

where you are in the creation or delivery process. 

9. File 

At one end of the ribbon is the File tab, which you use for the behind-the-

scenes stuff you do with a file, such as opening, saving, sharing, exporting, 

printing and managing your presentation. Click the File tab to open a new view 

called the Backstage. 

 

Click from the list on the side to do what you want to do; for example, 

click Print to find the options and settings for printing your presentation. Click 

Back  to return to the presentation that you were working on. 

10. Tools tabs 

When you click some parts of your slides, such as pictures, shapes, SmartArt or 

text boxes, you might see a colorful new tab appear. 

 

In the example above, the Drawing Tools tab appears when you click a shape 

or text box. When you click a picture, the Picture Tools tab appears. Other 

such tabs include SmartArt Tools, Chart Tools, Table Tools and Video Tools. 

These tabs disappear or change when you click something else in your 

presentation. 



Q.16 What is the difference between Machine language and High level 

language? 

Ans.  

       High level language          Machine language 

1. It can be considered as a 
programmer friendly language. 
2. It is easy to understand.  
3. It is easy to debug. 
4. It is simple in terms of    
maintenance. 
5. It can be run on different 
platforms. 
 
6. It is less memory efficient i.e. it 
consumes more memory in 
comparison to low-level 
languages.  

1. It is considered as a machine 
(Binary) friendly language. 
2. It is not easy to understand. 
3.It is difficult to debug. 
4.  Its maintenance  is  also           
complex. 
5. It depends on the machine; 
hence it can’t be run on different 
platforms. 
6. It requires an assembler that 
would translate instructions. 
 
 

 
         

Q.17 Discuss about different data types of C programming language?                                 

Ans. A data type is a classification of data which tell the compiler or interpreter how the 

programming intends to use the data.  Most programming languages support various 

types of data, including integer, real, character, or string, and Boolean.  

Each variable in C has an associated data type. Each data type requires different 
amounts of memory and has some specific operations which can be performed over it. 
Let us briefly describe them one by one: 
Following are the examples of some very common data types used in C: 

• char: The most basic data type in C. It stores a single character and requires a 
single byte of memory in almost all compilers. 

• int: As the name suggests, an into variable is used to store an integer. 
• float: It is used to store decimal numbers (numbers with floating point value) with 

single precision. 
• double: It is used to store decimal numbers (numbers with floating point value) 

with double precision.  
Different data types also have different ranges upto which they can store numbers. 
These ranges may vary from compiler to compiler. Below is list of ranges along with 
the memory requirement and format specifies on 32 bit gcc compiler. 
  



Data Type  
  

Memory 
(bytes)  
  

Range  
  

Format 
Specifier  
  

short int  
  

2  
  

-32,768 to 32,767  
  

%hd  
  

unsigned short int  
  

2  
  

0 to 65,535  
  

%hu  
  

unsigned int  
  

4  
  

0 to 4,294,967,295  
  

%u  
  

int  
  

4  
  

-2,147,483,648 to 2,147,483,647  
  

%d  
  

long int  
  

4  
  

-2,147,483,648 to 2,147,483,647  
  

%ld  
  

unsigned long int  
  

4  
  

0 to 4,294,967,295  
  

%lu  
  

long long int  
  

8  
  

-(2^63) to (2^63)-1  
  

%lld  
  

unsigned long long 
int  
  

8  
  

0 to 
18,446,744,073,709,551,615  
  

%llu  
  

signed char  
  

1  
  

-128 to 127  
  

%c  
  

unsigned char  
  

1  
  

0 to 255  
  

%c  
  

float  
  

4  
    

%f  
  

double  
  

8  
    

%lf  
  

long double  
  

16  
    

%Lf  
  

 



Q18:- 

1) 

SYNTAX FOR IF-ELSE STATEMENT:- 

if (test expression)  

{ 

   // code 

}  

 

2) for Loop 

A for loop is a repetition control structure which allows us to write a loop that 

is executed a specific number of times. The loop enables us to perform n 

number of steps together in one line. 

Syntax: 

for (initialization expr; test expr; update expr) 

{     

     // body of the loop 

     // statements we want to execute 

} 

3.Syntax For do while loop :- 

The syntax of a do...while loop in C programming language is − 

do { 

   statement(s); 

} while( condition ); 

 


