
Assignment -1 

1. What are the four fundamental parts of computer? Exp;ain it with the help of diagram. 

       Ans: The four fundamental parts of computer are (a) Input device (b) Central Processing Unit 

               (CPU) (c) Output device (d) Memory unit. 

 

 

 

 

                                                                                                                                                                                                                                                                                                                                                          

 

 

 

 

 

 

 

 

 

 

 

 

Input device : Input devices are components for interpretation and communication between people 

and computer systems. Examples of input devices are mouse, input pen, touch screen, microphone. 

Central Processing Unit : It is the brain of the computer. Computer cannot process without it. 

Output device  : It is used to show the result of the instructions. Example of output device are 

Monitor, printer, headphone etc. 

Memory unit  : It is the collection of storage units or devices together. The memory unit stores the 

binary information in the form of bits. 

2.Discuss about classification of computers based on size and capacity. 

 Ans: Based on size and capacity, computers are classified as follows:  

 Super computer 

 Mainframe computer 
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 Mini computer 

 Micro computer 

Super computers are the most powerful and physically the largest by size. 

These are the systems designed to process huge amounts of data. The fastest super 

computers can perform over one trilion calculatios in a second. Examples of super 

computer are JAGUAR,ROADRUNNER etc. 

 

Mainframe Computers are very large often filling one entire room and can process 

thousands of millions per second. In a mainframe environment, users connect to the 

mainfrae through the ma ny terminals wired to the mainframe. Examples IBM 

mainframes Z13, IBM system Z9 mainframe. 

 

Mini computers are much smaller than mainframes. These computers are also less 

expensive. Sometimes reffered to as Midrange Server or Midrange Computers. 

Examples Apple iPod, CDC 160 A. 

 

Micro computers are the most frequently used type computers. It is also known as 

Personal Computers (PC). It is a small computer system designed to be used by one 

person at a time. Example desktop computers, laptop. 

3. What is the meaning of computer generation ? How many Computer Generations are       

defined? What technologyies were/ are used? 

Ans : The evolution of digital computing is often divided into generations.  

           There are five generations of computer: First Generation (1940 ---- 1956 ), Second 

Generation (1956 --- 1963), Third Generation (1964 -----1971), Fourth Generation (1971 --- 

at present), Fifth Generation (present and beyond). 

4. Differentiate between Volatile and Non- Volatile memories. 

Ans : Volatile memory is a computer storage that only maintains its data while the device is 

powered. Example RAM (Random Access Memory) is Volatile. When we are working on a 

document, it is kept in a RAM, and if the computer losses power, your work will be lost.  

On the other hand Non – Volatile memory is a type of computer memory that has the 

capability to hold saved data even if the power is turned off. Exanple ROM (Read Only 

Memory) , Hard disk, Floppy disk etc. 

5. Distinguish among system software , application software and open source software on 

the basis of their features. 

Ans : System software is a type of software that is designed to run a computer’s hardware 

and application programs. Softwares like operating system, compilers, editors and driver etc 

come under this category. A computer cannot function without the presence of system 

software. 

Application Software is a type of software created for a specific purpose, used by end users. 



      It can be called an application or simply an app.  

 6.a) Create a file in MS-word to insert a paragraph about yourself and save it with file name 

“yourself”. Describe all steps involved in it. 

Ans:  My name is Koushik Ray. I am a student of senior secondary. I live in Bongaigaon with 

my mother. I love my mother, she is so loving and caring. I lost my father last year after a 

long time illness. He was so close to me. I really miss him. 

Steps: 1. Open MS word. 

Step: 2. Click on File 

Step: 3. Click on New Blank Document 

Step: 4. Now insert text. 

Step:5. Finally save document. 

6 b) Write steps regarding followings  To change the font style  To change the font size  To 

change the font color  To highlight (in yellow) the line that reads “need to get IMS’s address”.  

Ans: To Change the font Style------------- 

 Select the text that wants to modify. 

 Click on font style box on the Home tab. The font style drop-down menu appears. 

 Move the cursor over the various font styles. 

 Left- click the font style that want to use. 

 Then font style will change in the document. 

       To change font size-------------- 

 Select the text that want to modify. 

 Click on increase/decrease font size commands in the font group on home tab. 

 Then font size will change (increase/decrease) in the document. 

To change font color------------ 

 Select the text that wants to modify. 

 Click on font color box on the Home tab. The color menu appears. 

 Move the cursor over the various font color. 

 Left click the font color that want to use. 

 Then font color will change in the document. 

   To highlight (in yellow) the line that reads “need to get IMS’s address”---------------- 

 Select the text. 

 Click on the Text Highlight color in font group on the Home tab. 

 Various color will appears. 



 Move the cursor over the varios colors. 

 Click on color that want to use. 

 Then text highlight color will change in the document. 

“ need to get IMS’s address”. 
7. Create a file in MS-Word for the following document and save it with file name ‘ms_word’. 

Describe all steps involved in it. 

Ans:  

MS Word 

MS Word is a widely used commercial word processor developed by Microsoft. 

MS word is application sofware, which is capable of 

 creating. 

 editing. 

 saving, and 

 Printing any type of document. 

9. Create a file in MS-word that convert existing highlight text to table as shown below and save it as 

file name ‘text_to_table’. Describe all steps involved in it. 

Ans:  

Select the text you want to convert. Select the Insert tab. 

Click on Table command. A dialog box 
appears. 

Click on Convert Text to Table, a new dialog 
box appears 

here set numbers of columns. Click on OK, Finaly selected text convert in a 
table. 

     

10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in it. 

Ans:To insert a table in a word document. Follow these steps:- 

1) Go to Insert tab from the ribbon. 

2) In the tables group, select the tables option. 

3) Now you will be able to see different options. You can drag your mouse pointer to make a table, you can draw 

a table, you can also select insert table and enter the number columns and rows you want. 

For a basic table click Insert > Table 

and move the cursor 

over the grid until you 

highlight the number of 

or to customize a table select Insert > Table > 

Insert Table. 



columns and rows you 

want. For a larger 

table 

11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

Ans: 

ROLL NO NAME MARKS 

1 n1 60 

2 n2 70 

3 n3 80 

4 n4 90 

5 n5 40 

6 n6 50 

7 n7 77 

8 n8 44 

9 n9 88 

10 n10 55 

 

 

 

 

   

 

13 a) Describe various steps involved in the following  To modify column width of a worksheet  

To modify the row height of a worksheet  To delete rows and columns of a worksheet 

Ans:  

To modify column width of a worksheet -------- 

 Position the cursor over the column line in the column heading. 
 A double arrow will appear 
 Left click the mouse, then drag the cursor to the right to increase the column width 

or to left to decrease the column width. 
 Release the mouse button. 

To modify the row height of a worksheet----------  

 Position the cursor over the row line, you want to modify, and a double arrow will 

appear. 

 Left cick the mouse then drag the cursor upward to decrease the row height or drag 

the cursor to downward to increase the row height. 

 Release the mouse button. 



To delete rows and columns of a worksheet-------- 
 Select the row or column you want to delete. 

 Click the delete command in the cell group in the home tab. 

 Selected column or row deleted. 

13 b) Describe following terms in the worksheet  Absolute reference and relative reference in 

formula  Cell address. 

Ans: Relative reference : Cell reference in formula automatically adjust to new locations 

when the formula is pasted into different cells. This is called a Relative Reference. 

         An Absolute Reference is designated in the formula by the addition of a dollar sign 

($).It can precede the column reference or the row reference or both. 

         A cell reference or cell address is a combination of a column letter and a row 

number that identifies a cell on a worksheet. 

14. a) What tools are available to customize our PowerPoint presentation? 

Ans: Presentation Tools for Beautiful Presentations 

 Tool #1: Templates and Themes 

 Tool #2: Slide Layouts 

 Tool #3: Fonts 

 Tool #4: Color Themes 

 Tool #5: Icons 

 Tool #6: Shapes 

 Tool #7: Stock Photos 

 Tool #8: Charts and Graphs 

 Tool #9: Maps 

 Tool #10: Tables 

 Tool #11: Flowcharts 

 Tool #12: Icon Charts 

 Tool #13: Radials 

 Tool #14: Progress Bars 

 Tool #15: Animation 

 Tool #16: Transitions 

 Tool #17: Interactivity 

 Tool #18: Audio and Video 
 

14 b) Write the steps for the following action for creation of power point presentation  Open a 

Blank presentation  Save the presentation as Lab1.pptx , Add a Title to the first slide: Type your 

first name and last name in the Subtitle section  Add a New Slide which has a Title and Content 

 

https://visme.co/blog/best-presentation-tools/#templates-and-themes
https://visme.co/blog/best-presentation-tools/#slide-layouts
https://visme.co/blog/best-presentation-tools/#fonts
https://visme.co/blog/best-presentation-tools/#color-themes
https://visme.co/blog/best-presentation-tools/#icons
https://visme.co/blog/best-presentation-tools/#shapes
https://visme.co/blog/best-presentation-tools/#stock-photos
https://visme.co/blog/best-presentation-tools/#charts-and-graphs
https://visme.co/blog/best-presentation-tools/#maps
https://visme.co/blog/best-presentation-tools/#tables
https://visme.co/blog/best-presentation-tools/#flowcharts
https://visme.co/blog/best-presentation-tools/#icon-charts
https://visme.co/blog/best-presentation-tools/#radials
https://visme.co/blog/best-presentation-tools/#progress-bars
https://visme.co/blog/best-presentation-tools/#animation
https://visme.co/blog/best-presentation-tools/#transitions
https://visme.co/blog/best-presentation-tools/#interactivity
https://visme.co/blog/best-presentation-tools/#audio-and-video


Ans: Open a Blank presentation  

 Open PowerPoint. 

 In the left pane, select New. 

 Select an option: 

 To create a presentation, select Blank Presentation. 

Save the presentation as Lab1.pptx---------- 

 Locate and select Save Command on the Quick Access Toolbar. 

 If Saving the file for first time the Save as pane will appear in backstage view. 

 You’ll then needto choose where to save the file and give it a file name. 

 The save as dialog box will appear. 

 Save as Lab1.pptx 

Add a Title to the first slide: the name of your college------ 

 Click a slide number and it will display highlighted in the panel on the left side. Click 

next to the number and add a title. 

 Click the drop-down arrow to the right of the slide and select “Add Slide Title.” 

 Select the slide, use the Slide Title drop-down arrow on the Accessibility tab, and 

choose “Add Slide Title.” MY COLLEGE. 

Type your first name and last name in the Subtitle section-------- 

Type desired title in the Click to Add Title text box. Type First Name and Last Name in the 

Click to Add Subtitle text box. 

Add a New Slide which has a Title and Content--------- 

1. Choose the Home tab. 

2. Click the New Slide button  in the Slides group. The Office Theme 
dialog box appears and displays several layout templates.  

3. Click the layout that contain a title and content. The layout appears in the 
Slide pane of the PowerPoint window. 

 

15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to use the 

tools of PowerPoint. It should include the following things  Title slide &bullet list  Inserting Excel 

Sheet  Clip art and Text  Slide show effects 

Ans: Create a presentation 

1. Open PowerPoint. 

2. In the left pane, select New. 



3. Select an option: 

 To create a presentation from scratch, select Blank Presentation. 

 To use a prepared design, select one of the templates. 

 To see tips for using PowerPoint, select Take a Tour, and then select Create, . 

Add a slide 

1. In the thumbnails on the left pane, select the slide you want your new slide to follow. 

2. In the Home tab, in the Slides section, select New Slide. 

3. In the Slides section, select Layout, and then select the layout you want from the 

menu. 

Add a picture, shape, and more 

1. Go to the Insert tab. 

2. To add a picture: 

 In the Images section, select Pictures. 

 In the Insert Picture From menu, select the source you want. 

 Browse for the picture you want, select it, and then select Insert. 

Q16. What is the difference between Machine Language and High Level Language? 

Ans: A machine language is the only language that a computer directly understands, it 

is usually written in zeros (0) and ones (1). A program instruction in machine language 

may look something like this 111010110010001 whereas, a high-level language is a 

programming language that uses English and mathematical symbols, like +, -, % and 

many others, in its instructions. 

Q17. Discuss about different data types of C programming Language. 

Ans: Primary Data types in C 

The C language has 5 basic (primary or primitive) data types, they are: 

1. Character: We use the keyword char for character data type. It is used to store single bit characters and 

occupies 1 byte of memory. We can store alphabets from A-Z(and a-z) and 0-9 digits using char. For 

example, 

2. char a = 'a';  

3. char b = 'A';  

4. char c = '0'; 

char d = 0; //error  



For char datatype, it is necessary to enclose our data in single quotes. We can perform addition and 

subtraction operations on char but the ASCII value should not exceed 127. 

5. Integer: We use the keyword int for integer data type. The int data type is used to store non-fractional 

numbers which includes positive, negative and zero values. The range of int is -2,147,483,648 to 

2,147,483,647 and it occupies 2 or 4 bytes of memory, depending on the system you’re using. For 

example, 

6. int a = 5550;  

7. int b = -90,  

8. int c = 0;  

int d = -0.5; //invalid 

We can perform addition, subtraction, division, multiplication, bitwise and modulo operations on int data 

type. 

9. Floating-point: We use the keyword float for floating-point data type. float is used to store decimal 

numbers. It occupies 4 bytes of memory and ranges from 1e-37 to 1e+37. For example, 

10. float a = 0.05;  

11. float b = -0.005. 

12. float c = 1;  // it will become c = 1.000000 because of type-casting 

We can perform addition, subtraction, division, and multiplication operations on float data type. 

13. Double: We use the keyword double for double data type. double is used to store decimal numbers. It 

occupies 8 bytes of memory and ranges from 1e-37 to 1e+37. 

14. double a = 10.09; 

double b = -67.9; 

double has more precision than flaot so double gives more accurate results as compared to float. We can 

perform addition, subtraction, division and multiplication operations on double data type. 

15. Void: This means no value. This data type is mostly used when we define functions. The void data type is 

used when a function does not return anything. It occupies 0 bytes of memory. We use the void keyword 

for void data type. 

16. void function() { 

17.    //your code goes here 

} 

18. Find the output of the following expressions a) X=20/5*2+30-5 b) Y=30 – (40/10+6) +10  

c) Z= 40*2/10-2+10  

 



Ans: (a) X=20/5*2+30-5 

              ⇒X= 4*2+30-5 

              ⇒X = 8 + 25 

             ⇒X = 33 

(b) Y=30 – (40/10+6) +10 

⇒ Y = 30 – (4+6) +10 

⇒Y = 30 – 10 + 10 

⇒Y = 30 – 20  

⇒Y = 10 

 
c) Z= 40*2/10-2+10  
⇒Z = 4*2 – 2+10 
⇒Z = 8 – 12  
⇒Z = - 4  
 
Q19. Describe the syntax of the following statements  
a) If – else statement b) for loop c) while loop d) do-while loop  

Ans: (a) The if-else statement is used to execute both the true part and the false part of a 
given condition. 
 

(b)    A for loop is a repetition control structure that allows you to efficiently write a loop that 

needs to execute a specific number of times. 

Syntax 

The syntax of a for loop in C programming language is − 

for ( init; condition; increment ) { 

   statement(s); 

} 

 



(d) The syntax for a do while statement is: do loop_body_statement while (cond_exp); 
where: loop_body_statement is any valid C statement or block. 
 
Q20. Find the output of the following program segments 
 

a)  b)  c)  
#include <stdio.h>  
int main()  
{  
int i;  
for (i=1; i<2; i++)  
{  
printf( "IMS Ghaziabad\n");  
}  
}  

#include <stdio.h>  
int main()  
{  
int i = 1;  
while ( i <= 2 )  
{  
printf( "IMS Ghaziabad\n");  
i = i + 1;  
}  
}  

#include <stdio.h>  
void main()  
{  
int a = 10, b=100;  
if( a > b )  
printf( "Largest number is %d\n”, 
a);  
else  
printf( "Largest number is %d\n”, 
b);  
}  

 
Ans: (a) IMS Ghaziabad                           (b) IMS Ghaziabad                                (c) %s a 
                                                                          IMS Ghaziabad                                      %s b 
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