CCA-101: Fundamentals of IT & Programming
Assignment-1
Q1: What are the four fundamental parts of computer? Explain it with the help of diagram

The central The four fundamental parts of computer are

e CPU (CENTRAL PROCESSING UNIT)

e MOUSE
e MONITER
e KEYBOARD
CPU
e

e Processing unit is also called as central processor, is the electronic circuit within a
computer that executes instructions what make up a computer program.

e |t stores data, intermediate results and instructions and controls the operation of all
parts of the computer.

MOUSE



Mouse is an input device used with the computer. Moving the mouse along the flat surface used to
move the curse and clicking the mouse helps to select the different items on the screen

MONITER

A computer MONITER is a output device that displays the information in the pictorial form.

KEYBOARD




The keyboard is an water typing device with the arrangement of keys and buttons as an electronic
switches

2. Discuss about the classification of the computer based on the size and capacity
Based on size and capacity, computers are classified as follows:

e Super Computers

¢ Mainframe Computer

e Mini Computers

e Micro Computers

SUPER COMPUTERS

Supercomputers are the most powerful and physically the largest by size. These are systems
designed to process huge amounts of data. The fastest supercomputers can perform over one trillion
calculations in a second they have thousands of processors.

Eg: JAGGUAR & ROAD RUNNER
MAINFRAME COMPUTER

Some of the functions performed by a mainframe include: flight scheduling, reservations and
ticketing for an airline etc..

Example: IBM mainframe z13and IBM System z9 mainframe
MINI COMPUTER

Mini computers are smaller than main frame computer .less expensive Midrange computers are
usually used by small and medium-sized businesses as their servers. Users connect to the server through a
network by using desktop computers.

Eg: Apple ipad and CDC 160A

MICR Microcomputers are the most frequently used type of computer. It is also, known as Personal
Computer (PC). A microcomputer is a small computer system designed to be used by one person at a time.

Eg: Personal computer and laptops.

3. What is the meaning of computer generation? And how many computer generation are
defined?

what technologies were used?

COMPUTER GENERATION



Evolution of the computer is defined as the generation .Each generation is characterized by dramatic

improvements over the previous generation in the technology used to build computers, in terms of

the internal organization of computer and programming.

There are 4 generations of computer,

e First generation (1941-56)
e Second generation (1956-63)
e Third generation (1964-71)

e Fourth generation(1971-present)

FIRST GENERATION COMPUTERS

They are based on vacuum tube and magnetic drums for memory.

Eg: UNIVAC &ENIAC

SECOND GENERATION COMPUTER

Second generation is based on the transistors .it helps to change the vacuum tube.

THIRD GENERATION COMPUTER

It is based on the integrated circuit this is the hallmark of this generation.

FOURTH GENERATION COMPUTERS

These are based on the micro processor, built with the single silicon chip

Memory differencite between volatile and non volatile

5. Distinguish between system software ,application software and open course software on the

basis of their features.

System software

Application software

Open course software

it is a type of software to design the
computer hardware and computer
programs.

System software is an interface
between hardware and user
application.

It is created for specific purpose by
the user. It is an application or an

app.

Eg : WORD PROCESSOR

In this type course code is released
under a licence.

The operation system is the best
example.




6. create a file in MS WORD to insert a paragraph about yourself and save it with the file
name “ yourself”. Describe the steps involved in it.
TO CREATE A NEW DOCUMENT

Click the Microsoft office button or a file tab.
e Select the New option. A new dialogue box appears.

e Select the blank document. The new dialogue box will appear with the default.

e New blank document appears in the window.

e Now create a document by inserting a text.

o Now type a paragraph

e |AM NAVANITHA SRI.R FROM DHARMAPURI .IAM STUDYING +1 IN AUXILIUM
MATRIC.HIGHER.SEC.SCHOOL.

e Finally save the document

.TO SAVE THE DOCUMENT USING SAVE AS COMMAND

e Select the Microsoft office button or file tab

e Select save as WORD DOCCUMENT

e Enter the file name as "YOURSELF”

e Select the location where you have to save the document
e Click the save button.

7. write the steps regarding the following
To change font style
To change font size

To change font colour

”

To highlight (in yellow) the line that reads “need to get IMS’S address

TO CHANGE THE FONT STYLE

e Select the text you want to modify.

e Click on font style box on the Home tab.

e The font style drop-down menu appears.

e Move your cursor over the various font styles.
o Left-click the font style you want to use.

e Then font style will change in the document.



TO CHANGE THE FONT SIZE

Select the text you want to modify.

Click on font size box in the Font group on the Home tab.
e The font size drop-down menu appears.

e  Move your cursor over the various font sizes.

e Left-click on font size you want to use.

o Then it will change font size in your document.

e Select the text u want to modify

e Click on the font colour in the font group of the document

Various font colour appears TO CHANGE THE FONT COLOU

e Move on the courser over various font colour .
e Click on the font colour you want to use.
e Then it will change the font colour

TO HIGHLIGHT ( IN YELLOW)THE LINE THAT READS “ need to get IMS’S address”

e Select the text “ need to get IMS’S address”
e C(Click on the Text Highlight colour in font group on the Home tab.
e  Various colours will appear Move your cursor over the various colours.
e  C(Click on yellow colour
Then text highlight colour will change in the document

“need to get IM’S address”

8. create a file in the ms word for the following statement and save it with the file name
“equations’ describe all steps involved in it.

Equations
X,+Ys=30
2’+Q"=50
A, +B3=X,+Y®

TO CHANGE THE TEXT IN SUBSCRIPT



Select the text you want to modify.
e  Click on the subscript command on the Home tab.
e  Then It will change the text as subscript in the document.

TO CHANGE THE TEXT IN SUPERSCRIPT

e Select the text you want to modify.
e  Click on the superscript command on the Home tab.
e Then It will change the text as superscript in the document

X,+Ys=30
2’+Q*=50
A+B=X+Y?

9. Create a file in MS-word that convert existing highlight text to table as shown below and
save it as file name ‘text to table’. Describe all steps involved in it.

Select the text vou want to convert.

Select the Insert tab.

Click on Table command. A dialog box appears.

Click on Convert Text to Table, a new dialog box appears
here set number of columns.

Click on OK Finally Selected text convert in a table

4
Select the text vou want to convert. Select the Imsert tab.
Click on Table command. A dialog box appears. Click on Convert Text to Table, a new dialog box
appears
here set number of columns. Click on OK Finally Selected text convert in a table

e Select the text u want to modify

o select the insert tab

e C(Click on the table command box appears

e C(Click on convert text into table , a new dialog box appears set a number of column and rows.
e Click ok . finally the text is converted into a table

e Now click on the save as option

e Enter the file name as “text to table”

e Finally click on the save option. The file will be saved in the word document

10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in it.

e Click the Microsoft office button or a file tab

e anew dialogue box appears

e select the insert option and select the insert table option
e select the number of rows and colums

e finally select insert .a table will appear in the screen



11. Create a following worksheet in MS-excel and save it with name ‘book1’.
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roll number name marks
1nl 60
2 n2 70
3n3 80
4 n4 90
5n5 40
6 n6 50
7 n7 77
8 n8 44
9 n9 88

12. Calculate the following things of a range (C2:C11) of date in the worksheet created in
question number 10.

To sum of the marks using auto sum in the range of cells (C2:C11):

First select the cell where you want to appear function then select the drop down
arrow next to the AUTOSUM on the home tab, then select the sum, formula will appear
where you fixed your arrow then you just enter the columns you calculate, then
automatically cells range will come to that column press ok the result appears.

Average the marks in the range of cells (C1:C11):
Similarly you can calculate the average of that cell, so click on the auto sum symbol
Select average the formulas appear in the selected cells then enter average will appears.

Highest marks in the range of cells (C2:C11):& minimum marks i the range of cells

Similarly you can calculate the minimum and maximum number of the cells, click on the auto
sum in the home tab then click on the minimum or maximum what you want formula will appears in
the cells finally enter total will appear



13 a) Describe the various steps involved in the following

To modify column width of a worksheet:

%+ Position the cursor over the column line in the column heading.

% A double arrow will appear.

% Left click the mouse, then drag the cursor to right to increase the column width or to left to
decrease the column width.

+* Release the mouse button.

To modify the row height of a worksheet:

+* Position the cursor over the row line you want to modify and a double arrow will appear.

+»* Left click the mouse, then drag the cursor to upward to decrease the row height or
downwards to increase the row height.

+* Release the mouse button.

To delete rows and columns of a worksheet:

++ Select the row or column you want to delete.
%+ Click the Delete command in the cells group on the Home tab.

Selected row or column deleted
13 b) Describe the following terms in the worksheet
Absolute reference:

An absolute reference is designated in the formula by the addition of a dollar sign (S$). It can
precede the column reference or the row reference, or both

Examples:
SAS2: The column and the row do not change when copied.
AS2: The row does not change when copied.

SA2: The column does not change when copied

14. What tools are available to customize our PowerPoint presentation?

There are many tools available in Microsoft power point to customize. Power
point is a most excellent way of presenting to an audience in visual form. It is very
different one and different way of presenting your ideas. It helps the speaker and a
participant to understand the topic easily.

b) Write the steps for the following action for creation of power point presentation



Open a Blank presentation
First click on the start button,
Then select the power point in Microsoft office
Then double click then power point page will open.

Save the presentation as Lab1.pptx

First you located or select the save command o the access toolbar.

If you are saving the file for first time save as command will appears on the
backstage view.

Then you just choose the folder where you want to save the file and gave thet
file name after words file will be saved on that folder.

Save that file name as lab1.pptx.

Add a Title to the first slide: the name of your college
Open the power point slide show page there is a visual will appears that is “click to

add title” in that place move your cursor over the caption and left click then you can add
your college name as a title .

Type your first name and last name in the Subtitle section
Same as your title creating there is another caption was appears that is click to
add subtitle there you can give your name as a subtitle.

Add a New Slide which has a Title and Content

Here after you want to make a content go to next slide click on the new slide
then new slide will appear there about your college life and your college you can
prepare that as a slide show to present in front of your students.

15) Write steps for creation of a set of PowerPoint slides that demonstrates your skill to
use the tools of PowerPoint. It should include the following things ?

Title slide &bullet list
In your slide show power point presentation there are many will going to
presented by you in that time if you want to highlight some points you can add a bullets
Click on the home tab there is many bullets are appears click on that to add a bullets.

Inserting Excel Sheet

Click on the insert tab on the home tab then click on the object command on the
text group, than dialogue box will appear finally choose excel left click on that, excel
sheet will appear on the mirror.

Clip art and Text



When you preparing a slide show you want some example pictures to explain
that if you don’t have those pictures in your system you can select that from a clip art
which is a best option to get some pictures.

Click on the clip art command there is a text bar will appears in your right side
mirror there you search those arts. Click on that art that will add to your slide show.

Slide show effects

To start the presentation at the first slide in the start slide show group click from
beginning, this slide show is helps you to explain very clearly about your topics, audience
also can understand easily about your presentation.

PART-2:
Q16. between Machine Language and High Level What is the difference Language?
MACHINE LANGUAGE:

e It consisting of binary instructions which a computer can respond directly.
It is difficult to learn and use.

This programming language is machine dependent.

Program execution

It can be converted into machine code without a compiler or interpreter

HIGH LEVEL LANGUAGE:

e Itis a programming language with strong abstraction from the details of computer.
e Itis easytolearn and use.

e |tis not machine dependent.

e  Program execution is slow.

It requires compiler or interpreter to convert to a machine code.
Q17. Discuss about different data types of C programming Language.

Each data type in C has an associated data type. Each data type requires different amounts of
memory and has specific operations which can be performed over it. Some commonly used data
types are as follows,

Char: It stores a single character and requires a single byte of memory.
int : It is used to store an integer.
float: It is used to store decimal numbers.

double: It is used to store decimal numbers with highest range of floating point values



Q18. Find the output of the following expressions.

a) X=20/5*2+30-5
= 4%2430-5
= 8+30-5
=38-5
X=33.

b) Y=30 — (40/10+6) +10
=30- (4+6) + 10
=30-10+10
=30—20

Y=10.

¢) Z= 40*2/10-2+10
=40%*0.2-2+10
=8-2+10
=18-2
Z= 16.

Q19. Describe the syntax of the following statements.

a) if — else statement:
if ( expression)
{
true Block of statements;
}

else

{

else Block of statements;

}

b) forloop:
for ( expressionl;expression2;expression3)

{

Block of statements;

}

c)  whileloop:
while (condition)
{

Block of statements;

}

d) do-while loop:
do
{
Single statement;
or



Block of statements;

}
Q20. Find the output of the following program segments:
a) IMS Ghaziabad

b) IMS Ghaziabad
c) Largest numberis 100.



