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FUNDAMENTALS  OF  IT  & 
PROGRAMMING 

 
 

 

PUNNYA.S.S 



Q1.What are the four fundamental parts of a computer? Explain it with the help of 

diagram. 

1. INPUT DEVICE 

Input Device is a Device by which we can input our data or instructions into Computer. 

Computer has many Input Devices, it directs the brain to Devices Computer. Input Device is 

available in many different ways and everyone has a specific purpose. 

"Input Device is the device that gives our instructions to the computer's brain, C.P.U. "  

There are several types of Input Device, which are as follows -  

 Keyboard 

 Mouse 

 Trackball 

  Light pen  

 Touch screen  

 Digital Camera  

 Scanner  

       2. C.P.U 

The full form of C.P.U is Central process Unit. This is the main part of the computer. 

That is, without this, the computer system can not be completed, so all the devices are 

connected, such as Keyboard, Mouse, Monitor etc. It is also called Mind of Computer. Its 

main function is to execute the programs (Execute), and in addition to all the components of 

C.P.U Computer, such as Memory, Input, Output Devices also control the functions.  

C.P.U (Central Processing Unit) has three parts -  

 Arithmetic Logical Unit (A.L.U) 

  Memory  

 Control Unit (C.U) 



(a) A.L.U. (Arithmetic Logic Unit) 

The Arithmetic and Logic unit is briefly called A.L.U. This unit uses arithmetic 

functions (add, subtract, multiply, part) and logical operations on data. Takes direction from 

the A.L.U Control Unit. It receives data from memory and returns the information after 

processing to the memory. The speed of the work of A.L.U is very intense. It performs 

approximately 100,000 calculations per second. It contains an electronic circuit that is 

capable of calculating binary arithmetic.  

       (b) Memory 

It stores the instructions received by Input Device in the computer, where it also 

goes to the memory of Computer. In humans, there are many things to remember, so are 

memory. This memory is integral to C.P.U., it is a storage device. Therefore, it is also called 

main memory of computer, internal memory, or primary memory.  

"The location of the computer where all the information, instructions are stored"  

        (c) C.U (Control Unit) 

The full form of the C.U. is control unit. C.U. Controls and operates the functions of 

the hardware. It controls Input, Output, and Memory and A.L.U. intermittently directs the 

exchange of data; this program obtains instructions from the memory to execute the 

program. By converting instructions into Electric Signals, it reaches the appropriate devices. 

       3. OUTPUT DEVICE 

Output Device is a device that provides data input by User as Result. The results 

obtained from the computer are achieved by the Output Device, these results are usually 

presented to the user by the display device (screen) or the printer. Mainly the information 

received in the form of Output, we can either see the screen cross or print from the printer 

to the page or use the speaker as the output to listen to music, Output Device is of several 

types like -  

 Monitor  

 Printer  

 Plotter  

 Projector  

 Sound Speaker 

 

Q2.Discuss about the classification of computers based on size and capacity 

(a) Microcomputers (personal computers) 



Microcomputers became the most common type of computer in the late 20th 

century. The term “microcomputer” was introduced with the advent of systems based on 

single-chip microprocessors. The best-known early system was the Altair 8800, introduced 

in 1975. The term "microcomputer" has practically become an anachronism. 

 

These computers include: 

 Desktop computers – A case put under or on a desk. The display may be optional, 

depending on use. The case size may vary, depending on the required expansion 

slots. Very small computers of this kind may be integrated into the monitor. 

 Rackmount computers – The cases of these computers fit into 19-inch racks, and 

maybe space-optimized and very flat. A dedicated display, keyboard, and mouse may 

not exist, but a KVM switch or built-in remote control (via LAN or other means) can 

be used to gain console access. 

 In-car computers (carputers) – Built into automobiles, for entertainment, navigation, 

etc. 

 Laptop Computers and notebook computers – Portable and all in one case. 

 Tablet computer – Like laptops, but with a touch-screen, entirely replacing the 

physical keyboard. 

 Smartphones, smart books, and Palmtop computers – Small handheld personal 

computers with limited hardware specifications. 

 Programmable calculator– Like small handhelds, but specialized in mathematical 

work. 

 Video game consoles – Fixed computers built specifically for entertainment 

purposes. 

 Handheld game consoles – The same as game consoles, but small and portable. 

 

(b) Minicomputers (mid-range computers) 

Minicomputers (colloquially, minis) are a class of multi-user computers that lie in the 

middle range of the computing spectrum, in between the smallest mainframe computers 

and the largest single-user systems (microcomputers or personal computers). The term 

supermini computer or simply supermini was used to distinguish more powerful 

minicomputers that approached mainframes in capability. Superminis (such as the DEC VAX 

or Data General Eclipse MV/8000) were usually 32-bit at a time when most minicomputers 

(such as the PDP-11 or Data General Eclipse or IBM Series/1) were 16-bit. These traditional 

minicomputers in the last few decades of the 20th Century, found in small to medium-sized 

businesses, laboratories and embedded in (for example) hospital CAT scanners, often would 

be rack-mounted and connect to one or more terminals or tape/card readers, like 

mainframes and unlike most personal computers, but require less space and electrical 



power than a typical mainframe. The contemporary term for minicomputer is midrange 

computer, such as the higher-end SPARC, POWER and Itanium-based systems from Oracle 

Corporation, IBM and Hewlett-Packard, and the size is now typically smaller, such as a tower 

case. 

 

(c) Mainframe computers 

The term mainframe computer was created to distinguish the traditional, large, 

institutional computer intended to service multiple users from the smaller, single-user 

machines. These computers are capable of handling and processing very large amounts of 

data quickly. Mainframe computers are used in large institutions such as government, 

banks, and large corporations. They are measured in MIPS (million instructions per second) 

and can respond to hundreds of millions of users at a time. 

 

(d) Supercomputers 

A Supercomputer is focused on performing tasks involving intense numerical 

calculations such as weather forecasting, fluid dynamics, nuclear simulations, theoretical 

astrophysics, and complex scientific computations. A supercomputer is a computer that is at 

the front-line of current processing capacity, particularly speed of calculation. The term 

supercomputer itself is rather fluid, and the speed of today's supercomputers tends to 

become typical of tomorrow's ordinary computer. Supercomputer processing speeds are 

measured in floating-point operations per second, or FLOPS. An example of a floating-point 

operation is the calculation of mathematical equations in real numbers. In terms of 

computational capability, memory size and speed, I/O technology, and topological issues 

such as bandwidth and latency, supercomputers are the most powerful, are very expensive, 

and not cost-effective just to perform batch or transaction processing. 

 

Q3.What is the meaning of computer generation? How many computer generations are 

defined? What technologies are/were used? 

Generation in computer terminology is a change in technology of a computer 
is/was being used. Initially, the generation term was used to distinguish between 
varying hardware technologies. Nowadays, generation includes both hardware and 
software, which together make up an entire computer system. 

There are five computer generations known till date. Each generation has been 
discussed in detail along with their time period and characteristics. In the following 
table, approximate dates against each generation has been mentioned, which are 
normally accepted. 



Following are the main five generations of computers. 

Generations Period Technology Used 

First Generation 1946-1959 Vacuum tube based 

Second Generation 1959-1965 Transistor based 

Third Generation 1965-1971 Integrated Circuit based 

Fourth Generation 1971-1980 
VLSI microprocessor 

based 

Fifth Generation 1980-till date 
 ULSI microprocessor 

based 

 

(a) First Generation (1946-1959) 

The computers of first generation used vacuum tubes as the basic components 
for memory and circuitry for CPU (Central Processing Unit). These tubes, like electric 
bulbs, produced a lot of heat and the installations used to fuse frequently. Therefore, 
they were very expensive and only large organizations were able to afford it. 

In this generation, mainly batch processing operating system was used. Punch cards, 
paper tape, and magnetic tape was used as input and output devices. The computers 
in this generation used machine code as the programming language. 

The main features of the first generation are − 

 Vacuum tube technology 

 Unreliable 

 Supported machine language only 

 Very costly 

 Generated a lot of heat 

 Slow input and output devices 

 Huge size 

 Need of AC 

 Non-portable 

 Consumed a lot of electricity 

Some computers of this generation were − 

 ENIAC 

 EDVAC 

 UNIVAC 

 IBM-701 



 

(b) Second generation (1959-1965) 

In this generation, transistors were used that were cheaper, consumed less 
power, more compact in size, more reliable and faster than the first generation 
machines made of vacuum tubes. In this generation, magnetic cores were used as 
the primary memory and magnetic tape and magnetic disks as secondary storage 
devices. 

In this generation, assembly language and high-level programming languages like 
FORTRAN, COBOL were used. The computers used batch processing and 
multiprogramming operating system. 

The main features of second generation are − 

 Use of transistors 

 Reliable in comparison to first generation computers 

 Smaller size as compared to first generation computers 

 Generated less heat as compared to first generation computers 

 Consumed less electricity as compared to first generation computers 

 Faster than first generation computers 

 Still very costly 

 AC required 

 Supported machine and assembly languages 

Some computers of this generation were − 

 IBM 1620 

 IBM 7094 

 CDC 1604 

 CDC 3600 

 

(c) Third Generation(1965-1971) 

The computers of third generation used Integrated Circuits (ICs) in place of 
transistors. A single IC has many transistors, resistors, and capacitors along with the 
associated circuitry. 

The IC was invented by Jack Kilby. This development made computers smaller in 
size, reliable, and efficient. In this generation remote processing, time-sharing, 
multiprogramming operating system were used. High-level languages (FORTRAN-II 
TO IV, COBOL, PASCAL PL/1, BASIC, ALGOL-68 etc.) were used during this 
generation. 

The main features of third generation are − 

 



 IC used 

 More reliable in comparison to previous two generations 

 Smaller size 

 Generated less heat 

 Faster 

 Lesser maintenance 

 Costly 

 AC required 

 Consumed lesser electricity 

 Supported high-level language 

Some computers of this generation were − 

 IBM-360 series 

 Honeywell-6000 series 

 PDP (Personal Data Processor) 

 IBM-370/168 

 

(d) Fourth Generation(1971-1980) 

Computers of fourth generation used Very Large Scale Integrated (VLSI) 
circuits. VLSI circuits having about 5000 transistors and other circuit elements with 
their associated circuits on a single chip made it possible to have microcomputers of 
fourth generation. 

Fourth generation computers became more powerful, compact, reliable, and 
affordable. As a result, it gave rise to Personal Computer (PC) revolution. In this 
generation, time sharing, real time networks, distributed operating system were used. 
All the high-level languages like C, C++, DBASE etc., were used in this generation. 

The main features of fourth generation are − 

 VLSI technology used 

 Very cheap 

 Portable and reliable 

 Use of PCs 

 Very small size 

 Pipeline processing 

 No AC required 

 Concept of internet was introduced 

 Great developments in the fields of networks 

 Computers became easily available 

Some computers of this generation were − 

 



 DEC 10 

 STAR 1000 

 PDP 11 

 CRAY-1(Super Computer) 

(e) Fifth Generation(1980-till date) 

In the fifth generation, VLSI technology became ULSI (Ultra Large Scale 
Integration) technology, resulting in the production of microprocessor chips having ten 
million electronic components. 

This generation is based on parallel processing hardware and AI (Artificial 
Intelligence) software. AI is an emerging branch in computer science, which interprets 
the means and method of making computers think like human beings. All the high-
level languages like C and C++, Java, .Net etc., are used in this generation. 

AI includes − 

 Robotics 

 Neural Networks 

 Game Playing 

 Development of expert systems to make decisions in real-life situations 

 Natural language understanding and generation 

The main features of fifth generation are − 

 ULSI technology 

 Development of true artificial intelligence 

 Development of Natural language processing 

 Advancement in Parallel Processing 

 Advancement in Superconductor technology 

 More user-friendly interfaces with multimedia features 

 Availability of very powerful and compact computers at cheaper rates 

Some computer types of this generation are − 

 Desktop 

 Laptop 

 NoteBook 

 UltraBook 

 ChromeBook 

 

Q4. Differentiate between volatile and non-volatile memory 

Volatile and Non-Volatile Memory are both types of computer memory. Volatile 
Memory is used to store computer programs and data that CPU needs in real time and 
is erased once computer is switched off. RAM and Cache memory are volatile 
memory. Whereas Non-volatile memory is static and remains in the computer even if 



computer is switched off. ROM and HDD are non-volatile memory. Following are the 
important differences between Volatile and Non-Volatile Memory. 

 

Q5. Distinguish between system software,application software and open source 

software on the basis of their features 

1. System software: 

  It is a type of software that is designed to run computer’s hardware and 

application programs.Softwares like Operating Systems, Compilers, Editors, and 

drivers etc. come under this category. A computer cannot function without the 

presence of system software. System software is the interface between the hardware 

and the use applications. 

2. Application software: 

Sr. 
No. 

Key Volatile Memory Non-Volatile Memory 

1 
Data 
Retention 

Data is present till power 
supply is present. 

Data remains even after power 
supply is not present. 

2 
Persistence Volatile memory data is not 

permanent. 
Non-volatile memory data is 
permanent. 

3 
Speed Volatile memory is faster 

than non-volatile memory. 
Non-volatile memory access is 
slower. 

4 
Example RAM is an example of 

Volatile Memory. 
ROM is an example of Non-
Volatile Memory. 

5 
Data 
Transfer 

Data Transfer is easy in 
Volatile Memory. 

Data Transfer is difficult in Non-
Volatile Memory. 

6 

CPU 
Access 

CPU can access data 
stored on Volatile memory. 

Data to be copied from Non-
Volatile memory to Volatile 
memory so that CPU can access 
its data. 

7 
Storage Volatile memory less 

storage capacity. 
Non-Volatile memory like HDD has 
very high storage capacity. 

8 
Impact Volatile memory such as 

RAM is high impact on 
system's performance. 

Non-volatile memory has no 
impact on system's performance. 

9 
Cost Volatile memory is costly 

per unit size. 
Non-volatile memory is cheap per 
unit size. 



  It is a software created for a specific purpose used by end users. It can 

be called as application are simply an app. Eg:-Word processor, Accounting 

application, A web browser, an email client, Media player etc. 

3. Open Source Software:- 

It is a type of computer software in which source code is released under  a licence in 

which the copyright holder grants users right to study, change and distribute the 

software to anyone and for any purpose. The Linux operating system is the best 

known examples of open source software. 

 

Q6. (a) Create a file in MS-word to insert a paragraph about yourself and save it 

with file name “yourself”. Describe all steps involved in it. 

 

1. Click Microsoft office button 

2. Select New 

3. Select New document from the dialogue that box appears. 

4. Then select Blank document 

5. Select the Paragraph group’s dialog box launcher and Select the Special menu 

arrow in the Paragraph dialog box. 

6. Select First line in the Special drop-down menu and use the increment arrows 

to adjust the length of the indent .Make any additional adjustments to alignment 

or line spacing. 

7. Select the OK button to save your selection(s) and close the Paragraph dialog 

box. 

8. Type the content. 

9. Save the file by selecting in the order File >save as 

10. Type file name to “yourself” and click save 

  

Q6. (b) Write steps regarding followings 

 To change the font style 

1. Select the text you want to modify 

2. Click the font style box on the home tab and the font style drop down menu will 
appear. 

3. Move the cursor over the various font styles. 

4. Left-click on the required font style and then the font style will be changed on 
the document 



 

 To change the font size 

1. First select the text which the font size is to be changed. 

2. Then click the font size box and change the font size which is required 

 To change the font color 

1. Select text which you want to modify 

2. Click on the font color tab on the home tab and the font color tab will appear. 

3. Move the cursor over various colors that appeared in the menu and select the 
appropriate one by Left-clicking on it 

 To highlight (in yellow) the line that reads “need to get IMS’s 
address”. 

1. Select the text which is to be modified 

2. Click Text Highlight Color from the font group of home tab. 

3. Click on the color you want and the text will be highlighted with the selected 
color 

 

Q7.Create a file in MS-Word for the following document and save it with the file 
name ‘ms_word’. Describe all steps involved. 

 

MS Word 

Ms word is a widely used commercial word processor developed by Microsoft 

MS word is application software which is capable of 

 Typing  

 Editing  

 Saving and 

 Printing any type of document. 

 

1. Open Ms word, select new document and click on blank document. 

2. Now type the word “MS word” and select the text. 

3. Change the font style to Title by selecting it from the font styles menu of home 
tab 

4. Type the two sentences as seen in the above document. 

5. To underline the word “word processor”. Select the text and click the underline 
button on the home tab. 



6. Now we have to type the rest of the content before selecting the bullets and 
numbering button from the paragraph menu of the home tab. Select the 
appropriate bullet and click enter after completing each bullet 

7. Save the file by selecting save as from file menu and type file name as 
“ms_word”. Click save 

Q8.create a file in MS word for the following document and save it with file 
name ‘equations’. Describe all steps involved in it. 

Equations 

X2 + Y5 =30 

Z2 + Q4 =50 

A2 + B8 = X2 + Y8 

1. Type the equation on word and select the text which we want to convert to 
superscript or subscript 

2. Then select superscript button from the font group of home tab to make the 
selected text superscript or select the subscript button from the font group to make 
the text subscript 

 

Q9.Create a file in MS-word that convert existing highlight to table as shown 
below and save it as file name ‘text_to_table’. Describe all steps involved in it. 

Select the text you want to convert. 
Select the insert tab. 
Click on Table command. A dialogue box appears. 
Click on Convert Text to Table,a new dialogue box appears 
Here,set number of columns. 
Click on OK.Finally Selected text convert in a table 
 

Select the text you want to convert. Select the insert tab. 

Click on Table command. A dialogue 
box appears. 

Click on Convert Text to Table, a new 
dialogue box appears 

Here,set number of coloumns. Click on OK.Finally Selected text 
convert in a table 

 

 Select the text you want to convert. 

 Select the insert tab. 

 Click on Table command. A dialogue box appears. 

 Click on Convert Text to Table, a new dialogue box appears 



 Here, set number of columns. 

 Click on OK. 

 Finally Selected text is converted into a table 

 
Q10.Create a file in MS-word to insert a table in the document.Describe all 
steps involved. 
 

1. Place your insertion point in the document where you want to insert table. 
2. Select the insert tab. 
3. Click the table command. 
4. Drag your mouse over the diagram of squares to select the number of 

columns and rows required 
5. Thus table is formed in the point selected. 

Q11.Create following worksheet in MS-excel and save it with name ‘book1’. 

Roll no Name Marks

1 n1 60

2 n2 70

3 n3 80

4 n4 90

5 n5 40

6 n6 50

7 n7 77

8 n8 44

9 n9 88

10 n10 55

654

65.4

90

40

sum of marks

average of marks

highest marks

minimum marks  

Q12.Calculate the following things of a range (C2:C11) of data in the worksheet 
created in the question no.11 

 The sum of the marks using Autosum in a range of cells (C2:C11) 

sum of the marks using Autosum=654 

 Average of the marks in a range of cells (C2:C11) 

Average of the marks=65.4 

 Highest marks in a range of cell (C2:C11) 

 Highest marks=90 

 Minimum marks in a range of cells (C2:C11) 



Minimum marks=40 

Q13. (a)Describe various steps involved in the following  

 To modify column width of a worksheet. 

1. Position the cursor over the column line in the column heading , and a double 
arrow will appear. 

2. Left –click mouse ,then drag the right to increase column width or left to 
decrease the column width. 

3. Release the mouse button. 

 To modify the row height of a worksheet. 

1. Position the cursor over the row line you want to modify , and a double arrow 
will appear. 

2. Left –click mouse ,then drag the cursor downward to increase row height or 
upward to decrease the row height. 

3. Release the mouse button. 

 

 To delete rows and columns of a worksheet. 

1. Select the row or column you want to delete. 
2. Click the Delete command in the cells group on the Home tab. 
3. Selected column or row will be deleted. 

Q13.(b)Describe following terms in worksheet 

 Absolute reference and relative reference in formula. 

1. Relative references:- 

Cell references in formula automatically adjust to new locations when the 
formula is pasted into different cells. This is called relative reference’ 

2. Absolute references:- 

Cell references in a formula always refer to same cell or cell range. If a 
formula is copied to a different location ,the absolute reference remains the same 

 Cell address. 

Each rectangle in the worksheet is called a cell. Each cell has a name, or a 
cell address, based on the column and row where it is located. 

Q14. (a) What tools are available to customise our powerpoint presentation? 



     1.  Home 

The Home tab holds the Cut and Paste features, Font and Paragraph options, 
and what you need to add and organize slides. 

      2. Insert 

Click Insert to add something to a slide. This includes pictures, shapes, 
charts, links, text boxes, video and more. 

      3. Design 

On the Design tab, you can add a theme or color scheme, or format the slide 
background. 

       4. Transitions 

Set up how your slides change from one to the next on the Transitions tab. 
Find a gallery of the possible transitions in the Transition to This Slide group – click 
More button at the side of the gallery to see all of them. 

       5. Animations 

Use the Animations tab to choreograph the movement of things on your 
slides. Note that you can see many possible animations in the gallery in the 
Animation group, and see more of them by clicking More. 

       6. Slide Show 

On the Slide Show tab, set up the way that you want to show your 
presentation to others. 

       7. Review 

The Review tab lets you add comments, run spell-check, or compare one 
presentation with another (such as an earlier version). 

       8. View 

Views allow you to look at your presentation in different ways, depending on 
where you are in the creation or delivery process. 

       9. File 

At one end of the ribbon is the File tab, which you use for the behind-the-
scenes stuff you do with a file, such as opening, saving, sharing, exporting, printing 
and managing your presentation. Click the File tab to open a new view called the 
Backstage.  



Click from the list on the side to do what you want to do; for example, click Print to 
find the options and settings for printing your presentation. Click Back to document to 
return to the presentation that you were working on. 

10. Tools tabs 

When you click some parts of your slides, such as pictures, shapes, SmartArt or text 
boxes, you might see a colorful new tab appear. 

 

Q14.(b) Write the steps for the following action for creation of powerpoint 
presentation 

 Open a blank presentation 

1. Choose File→New. Backstage view opens, displaying 
tiles for various types of presentations you can create. 

2. Click the Blank Presentation tile. A new blank presentation opens. 

 Save the presentation as Lab1.pptx 

1. Locate and select the save command on the Quick Access toolbar. 
2. Then the Save As pane will appear in the backstage view 
3. You’ll then need to choose where to save the file and give it a file name. 
4. The save as dialogue will appear. 

 Add a title to the first slide; the name of your college 

1. Click on the Title, Subtitle, or Text placeholder 
2. Type the name of the college. 
3. If necessary, press [Return] or [Enter] to move to a new line 
4. Click anywhere on the slide outside of the placeholder to deselect it. 

 Type your first name and last name in the suitable section. 

1. Click on the Title, Subtitle, or Text placeholder 
2. Type your first name and last name.. 
3. If necessary, press [Return] or [Enter] to move to a new line 
4. Click anywhere on the slide outside of the placeholder to deselect it. 

 Add a new slide which has a title and content 

1. On the Home tab,click the New Slide button in the slides group,powerpoint 
adds a blank slide to your presentation. 

Or 

2. Press ctrl+M and again,powerpoint adds a blank slide 



Or 

3. Right-click in the slides or Outline tab on the left and then choose New slide. 
And again,Powerpoint adds a blank slide. 

Q15.Write steps for creation of a set of powerpoint slides that demonstrates 
your skill to use the tools of powerpoint.It should include the following things 

 Title slide & bullet list 
 Inserting Excel Sheet 
 Clip art and Text 
 Slide show effects 

To Create a presentation 

1. Open PowerPoint. 
2. Select an option: 

a. Select Blank Presentation to create a presentation from scratch. 
b. Select one of the templates. 
c. Select Take a Tour, and then select Create, to see tips for using 

PowerPoint. 

To Add a slide 

1. Select the slide you want your new slide to follow. 
2. Select Home > New Slide. 
3. Select Layout and the you type want from the drop-down 

To Add and format text 

1. Place the cursor where you want, and type. 
2. Select the text, and then select an option on the Home tab: Font, Font size, 

Bold, Italic, Underline, ... 
3. To create bulleted or numbered lists, select the text, and then select Bullets or 

Numbering. 

To Add a picture, shape, or chart 

Select Insert. 

1. To add a picture: 

a. Select Picture. 
b. Browse for the picture you want and select Insert. 

2. To add a shape, art, or chart: 
a. Select Shapes, Icons, SmartArt, or Chart. 
b. Select the one you want. 

 
Part-2 



Q16.What is the difference between Machine Language and High Level 

Language? 

(a) Machine Language 

Machine language, or machine code, is the only language that is directly 
understood by the computer, and it does not need to be translated. All 
instructions use binary notation and are written as a string of 1s and 0s. A 
program instruction in machine language may look something like this: 

10010101100101001111101010011011100101 

Technically speaking, this is the only language computer hardware understands. 

(b) High Level Language 

A high-level language is a programming language that uses English and 

mathematical symbols, like +, -, % and many others, in its instructions. When using 

the term 'programming languages,' most people are actually referring to high-level 

languages. High-level languages are the languages most often used by 

programmers to write programs. Examples of high-level languages are C++, Fortran, 

Java and Python. 

Consider an ATM machine where someone wants to make a withdrawal of $100. 

This amount needs to be compared to the account balance to make sure there are 

enough funds. The instruction in a high-level computer language would look 

something like this: 

x = 100 

if balance  x: 

 print 'Insufficient balance' 

else: 

 print 'Please take your money' 

This is not exactly how real people communicate, but it is much easier to follow 

than a series of 1s and 0s in binary code. 

Q17. Discuss about different data types of c programming languages 

There are 4 Data types in C: 

 Basic 

 Derived 

 Void 

 Enumeration 



 Basic Data Types 

These are also termed as primary or fundamental data types. Most of the time, 

for small programs, we use the basic fundamental data types in C – int, char, float, 

and double. 

 int Data Type 

Integer types can be signed (with negative values) or unsigned values (only 
positive). Int values are always signed unless specifically mentioned.Integer types 
are further classified as – 

Data type Range 

int   

signed int −32,768 to 32,767 

unsigned int 0 to 65,535 

short int   

signed short int -2,147,483,648 to 2,147,483,647 (4 bytes) 

unsigned short int 0 to 4,294,967,295 (4 bytes) 

long int   

signed long int -2,147,483,648 to 2,147,483,647 (4 bytes) 

unsigned long int 0 to 4,294,967,295 (4 bytes) 

 Char 

Char stores a single character. Char consists of a single byte. Just like the int 
data type, char can be signed (range from -128 to +127) or unsigned (0 to 255). C 
stores the binary equivalent of the Unicode/ASCII value of any character that we type. 

 Float 

The floating point data type allows the user to type decimal values. For 
example, average marks can be 97.665. if we use int data type, it will strip off the 
decimal part and print only 97. To print the exact value, we need ‘float’ data type. 

 Double 

Float, double and long double are similar to short int, int, and long int. Double 

is 8 bytes, which means we can have more precision than float. This is useful in 

scientific programs that require precision. Float is just a single-precision data type; 

double is the double-precision data type. Long Double is treated the same as double 

by most compilers; however, it was made for quadruple data precision. 



 Derived Data Types 

Array, pointers, struct, and union are the derived data types in C. 

 Array 

Same as any other language, Array in C stores multiple values of the same data 

type. That means we can have an array of integers, chars, floats, doubles, etc. The 

array needs to be either initialized, or the size needs to be specified during the 

declaration. 

 Pointers 

Pointers are considered by many to be complex in C, but that is not the case. 

Simply put, a pointer is just a variable that stores the address of another variable. A 

pointer can store the address of variables of any data types. This allows for dynamic 

memory allocation in C. Pointers also help in passing variables by reference. 

 Structs 

 

A struct is a composite structure that can contain variables of different 
data types. For example, all the student data that we declared earlier in basic 
data types can be put under one structure. Instead of having the information 
scattered, when we give it a structure, it is easier to store information about 
more students. 

 Union 

With a union, we can store different data types in the same memory location. The 

union can have many members, but only one member can have a value at one time. 

Union, is thus, a special kind of data type in C. When we assign values to union 

data, union allocates enough memory to accommodate the largest data type 

defined. For example, since the name takes the biggest space in the memory out of 

all the other data types, the union will allocate the space taken by name. 

 Enumeration 

Enumeration data types enhance the readability of the code. If you have integer 

constants in the code that can be reused or clubbed together, we can use enums to 

define the constants. 

 Void 



The void is just an empty data type used as a return type for functions. The absence 

of any other data type is void. When you declare a function as void, it doesn’t have 

to return anything. 

Q18. Find the output of the following expressions 

 (a) x=20/5*2+30-5 

 X= 33 

 (b)y=30-(40/10+6)+10 

 Y=30 

 (c)z=40*2/10-2+10 

 Z=16 

Q19.Describe the syntax of the following statements. 

(a) If-else statement 

An if statement can be followed by an optional else statement, which executes 

when the Boolean expression is false. 

The syntax of an if...else statement in C programming language is − 

if(boolean_expression) { 

   /* statement(s) will execute if the boolean expression is true 

*/ 

} else { 

   /* statement(s) will execute if the boolean expression is 

false */ 

} 

If the Boolean expression evaluates to true, then the if block will be executed, 
otherwise, the else block will be executed. 

(b) For loop 

A loop is used for executing a block of statements repeatedly until a given condition 

returns false. Syntax of for loop: 

for (initialization; condition test; increment or decrement) 
{ 
       //Statements to be executed repeatedly 
} 

 

(c) While loop 

Syntax of while loop: 

while (condition test) 



{ 
      //Statements to be executed repeatedly  
      // Increment (++) or Decrement (--) Operation 
} 

 

(d) Do while loop 

Syntax of do-while loop 

do 
{ 
    //Statements  
 
}while(condition test); 

 

Q20.Find the output of the following program segments 

a) b) c) 

#include,stdio.h> 
Int main() 
{ 
 Int I; 
  For (i=1;i<2;i++) 
{ 
    Printf (“IMS Ghasiabad\n”); 
} 
 

#include<stdio.h> 
Int main() 
{ 
  Int i=1; 
   While (i<=2) 
{ 
  Printf(“IMS Ghasiabad\n”); 
I=i+1; 
} 

#include<stdio.h> 
Void main() 
{ 
  Int a=10,b=100; 
   If (a>b) 
   Printf (“Largest number is%d\n”,a); 
Else 
  Printf(“Largest number is %d\n”,b); 
} 

 

Output of (a) = IMS Ghaziabad 

Output of (b) = IMS Ghaziabad 

   IMS Ghaziabad 

Output of (c) = Largest number is %d 

 b 

 


