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Q1: What are the four fundamental parts of computer? Explain it with the help of diagram.
ANS:-

It is a programmable electronic device designed for storing and processing data, based on
sequence of instruction.

A computer is a fast system that is organized to accept, store, and process data and produce output
results under the direction of a stored program of instructions.

There are four fundamental parts:-

Input devices
Output devices
Processor(CPU)
Banking storage

Input Devices:
e Computer systems use many devices for input purpose.
e Input devices include the mouse, input pen, touch screen and microphone.
o Regardless of the type of device used, all are components for interpretation and
communication between people & computer systems.

Output device
e Output device is used to show the result of the instructions. Example: Monitor,
printer, Headphones, etc.

Input | Processor - Output

devices devices

Banking
storange




Q2: Discuss about the classification of computers based on size and capacity.

ANS:-
Based on size and capacity, computers are classified as follows:

Super Computers
Mainframe Computer
Mini Computers
Micro Computers

1. Super Computers
e Supercomputers are the most powerful and physically the largest by size.
o These are systems designed to process huge amounts of data.
e The fastest supercomputers can perform over one trillion calculations in a
second.
Supercomputers have thousands of processors.
Because of their extraordinary speed, accuracy and processing power,

supercomputers are well suited for solving highly complex problems & huge
amounts of calculations.

Example: JAGUAR, ROADRUNNER etc

2. Mainframe Computer

Mainframe computers are very large often filling an entire room and can
process thousands of millions of instructions per second.

In a mainframe environment, users connect to the mainframe through the
many terminals wired to the mainframe.

Mainframes are capable of supporting hundreds to thousands of users
simultaneously.

Some of the functions performed by a mainframe include: flight scheduling,
reservations and ticketing for an airline etc

Example: IBM mainframes 213, IBM System z9 mainframe

3. Minicomputers

Minicomputers are much smaller than mainframes.
These computers are also less expensive.
Sometimes referred to as Midrange Server or Midrange Computer.




They are typically larger, more powerful and more expensive than desktop
computers.

Midrange computers are usually used by small and medium-sized businesses
as their servers

Users connect to the server through a network by using desktop computers.
Example: Apple iPod, CDC 160A

4. Microcomputers
e Microcomputers are the most frequently used type of computer.
e ltisalso, known as Personal Computer (PC)
e A microcomputer is a small computer system designed to be used by one
person at a time. Example :Desktop computers, laptops

Q3. What is the meaning of computer generation? How many Computer Generations are defined? What
technologies were/are used?

ANS:-

The evolution of digital computing is often

divided into generations. Each generation is characterized by

dramatic improvements over the previous generation in the technology used
to build computers, in terms of the internal organization of computer and
programming languages.

1.First Generation: Vacuum Tubes (1940-1956):

The first computer systems used vacuum tubes for circuitry and magnetic
drums for memory

These computers were very expensive to operate

Computers of this generation consumed a lot of electricity

First generation computers relied on machine language, the lowest-level
programming language understood by computers to perform operations

They could only solve one problem at a time. It would take operators days or

even weeks to set-up a new problem

Input was based on punched cards and paper tape, and output was displayed
on printouts

First computers generated a lot of heat ,which was often the cause of
malfunctions




Example: The UNIVAC (Universal Automatic Computer)

The UNIVAC was the first commercial computer delivered to a business client, the U.S. Census
Bureau in 1951

ENIAC (Electronic Numerical Integrator and Computer) computers

2.Second Generation: Transistors (1956-1963):

Transistors replaced vacuum tubes in the second generation of computers.

The transistor was far superior to the vacuum tube, allowing computers to

become smaller, faster, cheaper, more energy-efficient and more reliable than
their first-generation predecessors

Second-generation computers still relied on punched cards for input and printouts
for output

Second-generation computers moved from binary machine language to symbolic,
or assembly language

3.Third Generation: Integrated Circuits (1964-1971):

The development of the integrated circuit was the hallmark of the third
generation of computers

Transistors were replaced by Integrated circuits, which drastically increased the
speed and efficiency of computers.

Instead of punched cards and printouts, users interacted with third generation
computers through keyboards and monitors

Computers for the first time became accessible to a mass audience because they
were smaller and cheaper than their predecessors.

4.Fourth Generation: Microprocessors (1971-Present):

The microprocessor brought the fourth generation of computers as thousands of
integrated circuits were built onto a single silicon chip

What in the first generation filled an entire room could now fit in the palm of the
hand

In 1981, IBM introduced its first computer for the home user

in 1984, Apple introduced the Macintosh.

Microprocessors also moved out to the desktop computers




Fourth generation computers also covered the development of Graphical User

Interface(GUIs), mouse and handheld devices

Quantum computation and nanotechnology will radically change the face of

computers in years to come

The goal of fifth-generation computing is to develop devices that respond to

natural language input and are capable of learning and self-organization.

Q4: Differentiate between Volatile & Non- Volatile memories.

ANS:-

Volatile memory

Non- Volatile

Volatile memory is a computer
storage that only maintains its data
while the device is powered

Nonvolatile memory is a type of computer
memory that has the capability to hold saved
data even if the power is turned off

Example: RAM (Random access
memory) is volatile. When we are

working on a document, it is kept in
RAM, and if the computer loses
power, your work will be lost.

Example: Read-only memory (ROM), Hard disk,
floppy disk ,etc

Random
Access
Memory
(RAM):

It is also called as read write memory
or the main memory or the primary
memory.

Stores crucial information essential to operate
the system, like the program essential to boot
the computer.

Read Only
Memory
(ROM)

It is a volatile memory as the data
loses when the power is turned off.

It is non volatile.




Q5: Distinguish among system software, application software and open source software on the basis of

their features.
ANS:-
Software:-
Software is a set of instructions used to operate computers and execute specific tasks.
Software has mainly divided into two Categories:
1)System Software
2)Application Software
1)System Software:-

e ltis atype of software that is designed to run a computer's hardware and application
programs.
Software like operating systems, compilers , editors and drivers etc., come under this
category.
A computer cannot function without the presence of system software. If we think of
the computer system as a layered model, the system software is the interface
between the hardware and user applications.

> Operating system
o Itis system software that manages computer hardware and software
resources and provides services
e Operating system acts as manager of all the resources of computer i.e.
resource manager.

Operating System Representation

USER

APPLICATION

OPERATIONG SYSTEM

HARDWARE




APPLICATION SOFTWARE:-

It is software created for a specific purpose, used by end users. It can be called
an application or simply an app.

Examples: Word processor, accounting application, a web browser, an email
client, media player etc

«» Some others types of software

1.

2.
3.
4.

utility software

proprietary software

overview of open source technology
open source software (OSS)

1. utility software

These programs analyze and maintain a computer.

These programs are focused on how OS— works to perform the task to enable the
smooth functioning of computer.

This program may come along with OS like windows defender, windows disk cleanup
tool, Antivirus, backup software, files manager, disk compression tool all are utility
software.

2.proprietary software

It is software that is owned by an individual or a company (generally the one that
developed it).

There are almost always major restrictions on its use, and its source code is almost
always kept secret.

The proprietary Software is a non-free computer software for which the software's
publisher or another person retains intellectual property rights usually copyright of
the source code.

It is also known as ‘closed-source software’.

3. overview of open source technology

Open source technology is defined as the development of software for allowing end users and

developers to not only see the source code of software, but modify it as well.

4. open source software(0SS):-

It is a type of computer software in which source code is released under a license in
which the copyright holder grants users rights to study, change and distribute the
software to anyone and for any purpose.

The Linux operating system (0OS) is the best-known examples of open source software




Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with file name
“yourself”. Describe all steps involved in it.

ANS:-
OPENING MS WORD

Click the Start icon.

Then point to All Programs.
Then click Microsoft Office and
then click Microsoft Word.

CREATING A NEW DOCUMENT
To create a new document:

Click the Microsoft Office button / File tab.
Select New. The New Document dialog box’ appears.
Select Blank document. It will be highlighted’ by default.

A new blank document appears in the Word' window.

Now you can create document by inserting text’
Finally save document’

SAVING DOCUMENTS
To Save document using Save As command:

Click the Microsoft Office button/ File tab.

Select Save As — Word Document

Select the location where you want to save the document using the drop-
down menu.

Enter a name for the document.

Click the Save button.

SAVING DOCUMENTS
Other commands to save document :
First Method

e Click the Microsoft Office button or file tab.
e Select Save from the menu.




Second Method

e Click Save command on Quick access toolbar

Third Method

e press Ctrl + S Key on keyboard

Q6 b) Write steps regarding followings
ANS:-

» To change the font style:
To change font style
o Select the text you want to modify.

e Click on font style box on the Home tab. The font style drop-down menu
appears.

Move your cursor over the various font styles.
Left-click the font style you want to use.
Then font style will change in the document.

> To change the font size

To change size of your text
e Select the text you want to modify.
e Click on font size box in the Font group on the Home tab. The font size
drop-down menu appears.
Move your cursor over the various font sizes.
Left-click on font size you want to use.
Then it will change font size in your document.




» To change the font color
To change font color:

Select the text you want to modify.

Click on the font color box on the Home tab. The font color menu
appears.

Move your cursor over the various font colors.

Left-click the font color you want to use.

Then font color will change in'the document.

» To highlight (in yellow) the line that reads “need to get IMS’s address”
To change Text Highlight color:

Select the text

Click on the Text Highlight color in font group on the Home tab.
Various colors will appears

Move your cursor over the various colors.

Click on color you want to use.

Then text highlight color will change in the document.

Q7. Create a file in MS-Word for the following document and save it with file name ‘ms_word’. Describe
all steps involved in it.

ANS:-OPENING MS WORD

Click the Start icon.

Then point to All Programs.

Then click Microsoft Office and

then click Microsoft Word.

Werite down the paragraph given in Question 7

Then to save word document click on office button to save file, click on save as you
will see save dialog box give name “ms_word” and select location where you want to
save this file and click on save button.




Q8. Create a file in MS-word for the following document and save it with file name ‘equations’. Describe
all steps involved in it

ANS:-

Click the Start icon.

Then point to All Programs.

Then click Microsoft Office and
then click Microsoft Word.

Write down equation given bellow

EQUATIONS

» X+Ys=30 :- this is a subscript equation
> 73+Q*=50 :- this is a superscript equation

> A,+B3=X,+Y® * this is a subscript and superscript equation

Q9. Create a file in MS-word that convert existing highlight text to table as shown below and save it as
file name ‘text_to_table’. Describe all steps involved in it.

ANS:-

Select the text you want to covert.

Select the insert tab.

Click on table command. A dialog box appears
Here set number of columns .

Click on ok finally selected text convert in a table

Q10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in it.
ANS:-
ORKING WITH TABLES
To convert existing text to a table:

e Select the text you want to convert.
e Select the Insert tab.
e Click on Table command. A dialog box appears.




Click on Convert Text to Table, a new dialog box appears
here set number of columns.

Click on OK

Finally Selected text convert in a table.

To add a column:

Place the insertion point in a column adjacent to the location where
you want add new column

Right-click the mouse. A menu appears.

select Insert Columns to the Select Insert Left or Insert Columns to the
Right. A new column appears.

To delete a row or column:

e Select the row or column.
e Right-click your mouse, and a menu appears.
e Select Delete Columns or Delete Rows.

WORKING WITH TABLES
To insert a blank table:

Place your insertion point in the document where you want to insert table
Select the Insert tab.

Click the Table command.

Drag your mouse over the diagram squares to select the number of columns
and rows in the table.

Left-click your mouse, and the table appears in the document.
Enter text into the table.
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Q13 b) Describe following terms in the worksheet
Absolute reference and relative reference in formula:ANS:- ABSOLUTE REFERENCE=($A$1) AND
RELATION REFERENCE=(A1)

Cell address:ANS:- CELL ADDRESS:- cell adreess examples are A1,B1,C1 ETC.

Q14. a) What tools are available to customize our PowerPoint presentation?
ANS:-
Presentation:

The presentation can be defined as the practice of showing the content of a topic
along with explaining it to a specific audience. It is a collection of information and data which
has to be delivered to an audience or learners. It helps both the speaker and the participants
to learn about the topic more easily.

A PowerPoint presentation is an excellent way of presenting information or ideas to
an audience. The software is easy to use and offers a lot of cool effects for your slideshows,
too. Here, contents are helpful to learn about creation of presentation using Microsoft
PowerPoint 2007 and upper version.

To open an existing presentation:

To open a complete presentation in front of audience, please follow the steps mentioned

below:

Select the File tab to go to Backstage view.
Select Open. Clicking Open.
Select Computer, and then click Browse. Alternatively, you can choose
OneDrive to open files stored on your OneDrive.
4. The Open dialog box will appear.

Q14 b) Write the steps for the following action for creation of power point presentation

Open a Blank presentation

Save the presentation as Lab1.pptx

Add a Title to the first slide: the name of your college
Type your first name and last name in the Subtitle section
Add a New Slide which has a Title and Content




ANS:-

Open a Blank presentation:-
To use one of built-in templates to create a new presentation, follow these steps:

1. Select Office button - New. The New Presentation window appears.

2. In the left side of the New Presentation window, click Installed Templates.
3. Click a template to select it. ...

4. Click Create

Save the presentation as Labl.pptx:-

It's a good idea to keep saving our work periodically as we never know when we will
lose power or when our computer is likely to crash. Keep saving it. At the time of creation of new
presentation (first time),please save it with the help of following steps:

1. Locate and select the Save command on the Quick Access Toolbar.

2. If you're saving the file for the first time, the Save As pane will appear in backstage view.

3. You'll then need to choose where to save the file and give it a file name.

4. The Save As dialog box will appear.

3. Add a Title to the first slide: the name of your college

To use one of built-in templates to create a new presentation, follow these steps:

1. Select Office button -> New. The New Presentation window appears.

2. In the left side of the New Presentation window, click Installed Templates.
3. Click a template to select it. ...

4. Click Create

It's a good idea to keep saving our work periodically as we never know when we will

lose power or when our computer is likely to crash. Keep saving it. At the time of
creation of new presentation (first time),please save it with the help of following

steps:

1. Locate and select the Save command on the Quick Access Toolbar.

2. If you're saving the file for the first time, the Save As pane will appear in
backstage view.

3. You'll then need to choose where to save the file and give it a file name.

4. The Save As dialog box will appear.




4. Add a New Slide which has a Title and Content

This part covers how to insert a new slide in PowerPoint. When we create a new presentation,
PowerPoint gives us default slide. For insertion/addition of new slide, we can follow the steps,

mentioned below:

1. On the Home tab, click the New Slide button in the Slides group. PowerPoint adds a blank
slide to your presentation. or

2. Press Ctrl+M. And again, PowerPoint adds a blank slide. or

3. Right-click in the Slides or Outline tab on the left and then choose New Slide. And again,
PowerPoint adds a blank slide. It is also shown in the following slide view of presentation

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to use the tools
of PowerPoint. It should include the following things

> Title slide &bullet list

» Inserting Excel Sheet

» Clip art and Text

> Slide show effects

ANS:-
> Title slide &bullet list

1.0n the Home tab, click the New Slide button in the Slides group.
PowerPoint adds a blank slide to your presentation. or

2. Press Ctrl+M. And again, PowerPoint adds a blank slide. or

3. Right-click in the Slides or Outline tab on the left and then choose New
Slide. And again, PowerPoint adds a blank slide. It is also shown in the
following slide view of presentation

> Inserting Excel Sheet

The great thing about the Microsoft Office Suite is the fluid interaction of each
application type. By embedding the Excel document into your presentation or
document you can use it to make a point more effectively with numbers or
even graphs.

1. In PowerPoint, select the Insert tab & Click the Insert tab.

2. Click the Object command in the Text group. ...

3. A dialog box will appear. ...

4. Locate and select the desired Excel file, then click Insert. ...




» Clip art and Text

1.open the Microsoft power point then a click insert and you show the illustration
And u show the clip art to click and press to a go and you show the all clip art to add the presentation
To add the clipart

> Slide show effects:-

e We can apply slide transition to slide
e We can apply animation effect to slide contend
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Q16. What is the difference between Machine Language and High Level Language?

High Level Language

Machine Language

High level language are easy to learn and
understand

Machine level language are challenging to
learn and understand

hey are executed silower than lower level
languages speed. because they require a
translator program.

They executed with high languages speed.

They allow much more abstraction.

They allow little or no abatraction

They do not provide meny facities at the
hardware level.

They are very close to the hardware and help
to write a program at the hardware level

for writing programs. hardware knowledge is
not required.

For writing programs hardware knowiedge is
a must.

The programs are many to modify.

Modifying programs is dificut

Q17. Discuss about different data types of C programming Language.

ANS:-

e int - Used to store an integer value.

e char - Used to store a single character.

o float - Used to store decimal numbers with single precision.

e double - Used to store decimal numbers with double precision.




a) If — else statement : ANS:-

If the Boolean expression evaluates to true, then the if block will be executed, otherwise, the else block
will be executed. C programming language assumes any non-zero and non-null values as true, and if it is either
zero or null, then it is assumed as false value.




Int. The init code runs once to set things up at the very start of the loop. ...
Test. The boolean test is evaluated. ...
Loop-body. If the test was true, the body runs once. ...

Increment. Finally, the increment code executes just after the body, and then the
program loops back to the test, (step 2).

he syntax of a while loop in C programming language is - while(condition) { statement(s);
Here, statement(s) may be a single statement or a block of statements. The condition may be any expression,
and true is any nonzero value. The loop iterates while the condition is true.

The do/while loop is a variant of the while loop. This loop will execute the code block once, before
checking if the condition is true, then it will repeat the loop as long as the condition is true.




printf( "IMS Ghaziabad\n");
I=i+1;

}

}

ANS:-

IMS Ghaziabad
IMS Ghaziabad

C. #include <stdio.h>
void main()
{
inta =10, b=100;
iflta>b)

{

printf( "Largest number is %d\n”, a);

}

{
printf( "Largest number is %d\n”, b);
}
}

ANS:- Largest number is=100




