
CCA-101: Fundamentals of IT & Programming Assignment -1 

Q1: What are the four fundamental parts of computer? Explain it with 

the help of diagram.  

Ans. 

Basic Components of Computer 

Input Unit. 

tput Unit. 

Memory Unit. 

Control Unit. 

rithmetical and Logical Unit. 

 

 Input Unit 

A computer will only respond when a command is given to the device. These 
commands can be given using the input unit or the input devices.  

For example: Using a keyboard we can type things on a Notepad and the computer 

processes the entered data and then displays the output of the same of the screen. 

The data entered can be in the form of numbers, alphabet, images, etc. We enter the 
information using an input device, the processing units convert it into computer 
understandable languages and then the final output is received by a human-
understandable language. 

 output Unit 

When we command a computer to perform a task, it reverts for the action performed 
and gives us a result. This result is called output. There are various output devices 
connected to the computer. The most basic of which is a monitor. Whatever we write 

using a keyboard or click using a mouse, is all displayed on the monitor. 

Thus, the output unit gives us the final result once the entire processing is done 

within the mechanism of a device. 



For example: when we visit an ATM, we enter our details like language, pin, amount 
to be withdrawn, etc. and then the final money which the cash dispenser releases is 

our outcome. In this case, the cash dispenser acts as an output unit.  

 Memory Unit 

When we enter the data into the computer using an input device, the entered 
information immediately gets saved in the memory unit of the Central Processing 
Unit (CPU). Because of the presence of some existing programming, the Memory 
Unit transmits the data further to the other parts of the CPU. 

Similarly, when the output of our command is processed by the computer, it is saved 
in the memory unit before giving the output to the user. 

 Control Unit 

This is the core unit which manages the entire functioning of the computer device. It 

is one of the most essential components of the computer system.  

The Control Unit collects the data entered using the input unit, leads it on for 
processing and once that is done, receives the output and presents it to the user. It 
can be said to the centre of all processing actions taking place inside a computer 
device.  

Basically, the instructions taken, interpretation of entered data, issuing signals to 
execute the data and then finally retrieving the data is all done in the Control Unit.  

 Arithmetic & Logical Unit 

As the name suggests, all the mathematical calculations or arithmetic operations are 
performed in the Arithmetic and Logical Unit of the CPU.  

It can also perform actions like a comparison of data and decision-making actions. 
The ALU comprises circuits using which addition, subtraction, multiplication, division 
and other numerical based calculations can be performed. 

 

 

Q2: Discuss about the classification of computers based on size and 

capacity.  

One can classify the computer system in the following three classes: 1. Computers on the 

Basis of Size and Capacity include Super, Mainframe, Mini, and Micro Computer. 2. 

Computers on the Basis of Purposes include General purpose and Special Purpose. 3. 

Computers on the Basis of Hardware Design and Data Handling include Analog, Digital, 

and HybridComputer. 



 

Q3: What is the meaning of computer generation? How many 

Computer Generations are defined? What technologies were/are 

used?  

Generation in computer terminology is a change in technology a computer is/was being 
used. Initially, the generation term was used to distinguish between varying hardware 
technologies. Nowadays, generation includes both hardware and software, which 
together make up an entire computer system. 

There are five computer generations known till date. Each generation has been 
discussed in detail along with their time period and characteristics. In the following 
table, approximate dates against each generation has been mentioned, which are 
normally accepted. 

Following are the main five generations of computers. 

S.No Generation & Description 
1 First Generation 

The period of first generation: 1946-1959. Vacuum tube based. 

 

2 Second Generation 

The period of second generation: 1959-1965. Transistor based. 

 

3 Third Generation 

The period of third generation: 1965-1971. Integrated Circuit based. 

 

4 Fourth Generation 

https://www.tutorialspoint.com/computer_fundamentals/computer_first_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_second_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_third_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_fourth_generation.htm


The period of fourth generation: 1971-1980. VLSI microprocessor based. 

 

5 Fifth Generation 

The period of fifth generation: 1980-onwards. ULSI microprocessor based. 

 

 

Q4: Differentiate between Volatile & Non- Volatile memories.  

o. On the basis 

of 

Volatile Memory Non-Volatile Memory 

https://www.tutorialspoint.com/computer_fundamentals/computer_fifth_generation.htm


 

 

 

 

 

1. Basic It is a type of computer memory that 

stores the data temporarily. It 

requires a continuous electric current 

to maintain its saved data. 

It is also a type of computer memory that stores the 

data permanently. It retains the data in the system 

even when the power is gone. 

2. Persistence The data in volatile memory is not 

permanent. 

The data in volatile memory is permanent. 

    

3. Speed It is faster than non-volatile memory. It is slower than volatile memory. 

4. Storage It has less storage capacity. It has high storage capacity. 

5. Data transfer Data transfer in volatile memory is 

easier. 

Data transfer in non-volatile memory is difficult. 

6. Impact Volatile memory has a high impact on 

the performance of the system. 

Non-Volatile memory has no impact on the 

performance of the system. 

7. Read and 

write 

In volatile memory, both read and 

write operations can be performed. 

In non-volatile memory, only a read operation can 

be performed. 

8. Cost Volatile memory is expensive per unit 

size. 

It is less expensive. 

9. Position of 

memory 

The chips of volatile memory are kept 

in the memory slot. 

While chips of the non-volatile memory are 

embedded on the motherboard. 

10. CPU Access In volatile memory, the processor has 

direct access to data. 

In non-volatile memory, the processor does not 

have direct access to data. 

11. Example Some common examples of volatile 

memory are RAM and Cache 

memory. 

The common examples of Non-volatile memory 

are ROM (Random Access Memory) and HDD 

(Hard Disk Drive). 



 

 

Q5: Distinguish among system software, application software and open source software on the basis of   

their features.  

Difference Between System Software and Application Software 

System Software Application Software 

This acts as an interface between the 
system and the applications 

This is designed directly from the 
user perspective 

It is the platform that allows the various 
application software to run on the system 

These are independent 
applications which can be 
download and installed in the 
system 

System Software is generally developed 
in low-level languages. This is so that the 
interaction between the software and 
hardware can be simplified and made 
more compatible 

Each application has a specific 
purpose and thus is developed 
with high-level languages so that 
the purpose can be fulfilled 

Is working is more automated. Once a 
system is turned on, the system software 
starts working 

User action is required to start 
application software. These 
applications can only be work 
when the user commands the 
system to do so 

These are responsible for the working of 
the system 

They have minimum involvement 
in the processing and functioning 
of the computer device 

The system software are installed at the 
time of installing the operating system. A 
computer device cannot work without its 
presence 

The application software can be 
installed as and when the user 
requires them 

It is an independent software. Once this is 
installed the computer will work 

This is a dependent software. 
Applications can only be 
downloaded when the operating 
system is installed 

Since a device cannot work without a 
system software, the user has to have it 

These are designed to be user 
interactive, thus the application 



installed in their devices software can be removed as and 
when required by the user 

Example for System Software includes 
Android, Mac Operating system, MS 
Windows, etc. 

Examples of Application Software 
includes Word Processor, games, 
media player, etc. 

 

Q6. a) Create a file in MS-word to insert a paragraph about yourself 

and save it with file name “yourself”. Describe all steps involved in it. 

Steps to create document in MS WORD 

Step 1: Open Ms word on your system. 

Step 2: Click on the new file when you open the word file when the dialog box appear. 

Step 3: Once this click on Blank doc under the recent section, it will get in bold or 

highlighted by default. 

Step 4: Click on the create A new blank doc will open. 

Step 5: Once it is opened you can write anything you want in the doc for yourself. 

Step 6: You can also edit the text you have written as you can change the background 

color ,or the text and many other things in the docs 

Q6 b) Write steps regarding followings  

 To change the font style   

 To change the font size   

 To change the font color   

 To highlight (in yellow) the line that reads “need to get IMS’s 

address”.  
 

Font type: 

1. Select the text you want to modify. 

2. Select the Home tab and locate the Font group. 

3. Click the drop-down arrow next to font style box. 

4. Font style menu appears. 

5. With a left click select the desired font style. 



 

Font size: 

1. Select the text you want to modify. 
2. Click the drop-down arrow next to the Font Size box on the Home tab. A 

drop-down menu appears. 
3. Select the desired font size from the menu. Alternatively, you can type the 

value you want and then press Enter on your keyboard. Changing the font 
size. 

Font color: 

1. Select the text you want to modify. 

2. In Home tab locate the Font group. 

3. Click the drop-down arrow next to Font color button. 

4. Font color menu appears. 

5. Select the desired font color with a left click. 

6. Word will change the Font color of the selected text. 

To highlight 

he highlight doesn't necessarily need to be yellow. Click the menu button to the 

right of the Text Highlight button, and choose a different . 

Q7. Create a file in MS-Word for the following document and save it 

with file name ‘ms_word’. Describe all steps involved in it. 

 

Q8. Create a file in MS-Word for the following document and save it 

with file name ‘ms_word’. Describe all steps involved in it. 

Equations 

X2=Y5=30 

Z3=Q4=50 

A2+B8=X2+Y8 

4. Step 1: Open Ms word on your system. 
5. Step 2: Click on the new file when you open the word file when the dialog 

box appear. 
6. Step 3: Once this click on Blank doc under the recent section, it will get in 

bold or highlighted by default. 
7. Step 4: Click on the create A new blank doc will open. 



8. Step 5: Once it is opened you can write anything you want in the doc for 
yourself. 

9. Step 6:click on word equations and go on home tab click on underline 

icon(U) 
10. Step 6: write the latter and go on home tab use subscript and superscript  

Q9. Create a file in MS-word that convert existing highlight text to 
table as shown below and save it as file name ‘text_to_table’. 
Describe all steps involved in it. 

Select the text you want to convert 

Select the insert tab 

Click on table command . A dialog box appears 

Click on convert text to table, a new dialog box appears 

Here set the number of columns  

Click on OK Finally selected text convert in a table 

Select the text that you want to convert, and then click Insert > Table > Convert 

Text to Table. In the Convert Text to Table box, choose the options you want. Under 

Table size, make sure the numbers match the numbers of columns and rows you want. 

In the Fixed column width box, type or select a value. 

 

 

 

 

Select the text you want to convert Select the insert tab 



 

 

 

 

 

 

 

 

 

Q10. Create a file in MS-Word to insert a table in the document. 

Describe all steps involved in it. 

Insert a  Table 

1. Place the cursor where you want the table to appear. 

2. Go to Insert. 

3. In the Tables group, select Table. 

4. Select  Tables, then choose a table style. 

5. A pre-formatted table is inserted into the Word document, and the Table Design 
tab is displayed. Replace the text with your content. 

 

Q11. Create a following worksheet in MS-excel and save it with name 
‘book1’. 
 

  

Click on table command . A dialog box appears 

 

Click on convert text to table, a new 

dialog box appears 

 

Here set the number of columns  Click on OK Finally selected text 

convert in a table 

 



2 n2 7

3 n3 80

4 n4 90

5 n5 40

6 n6 50

7 n7 77

8 n8 44

9 n9 88

10 n10 55

 
 

Q12. Calculate the following things of a range (C2:C11) of data in the 
worksheet created in question no 

 the sum of the marks using AutoSum in a range of cells (C2:C11)  
 average of the marks in a range of cells (C2:C11)  
 highest marks in a range of cells (C2:C11)  
 minimum marks in a range of cells (C2:C11) 

 
 

Roll No Name Marks

1 n1 60

2 n2 70

3 n3 80

4 n4 90

5 n5 40

6 n6 50

7 n7 77

8 n8 44

9 n9 88  
 
 
 

 

Q13 a) Describe various steps involved in the following  

 To modify column width of a worksheet  

1. Select the column or columns that you want to change. 

2. On the Home tab, in the Cells group, click Format. 

3. Under Cell Size, click Column Width. 

4. In the Column width box, type the value that you want. 

5. Click OK. 

 



 

 To modify the row height of a worksheet  

 

Select the row or rows that you want to change. On the Home tab, in the Cells group, 

click Format. Under Cell Size, click AutoFit Row Height. Tip: To quickly autofit all 

rows on the worksheet, click the Select All button, and then double-click the boundary 

below one of the row headings. 
 To delete rows and columns of a worksheet 

1. Select the cells, rows, or columns that you want to delete. 

2. Right-click, and then select the appropriate delete option, for example, Delete 
Cells & Shift Up, Delete Cells & Shift Left, Delete Rows, or Delete Columns. 

 

13 b) Describe following terms in the worksheet  

 Absolute reference and relative reference in formula  
 

There are two types of cell references: relative and absolute. Relative and absolute 

references behave differently when copied and filled to other cells. Relative 

references change when a formula is copied to another cell. Absolute 

references, on the other hand, remain constant no matter where they are 

copied. 

 

 Cell address 

 
A cell reference, or cell address, is an alphanumeric value used to identify a 

specific cell in a spreadsheet. Each cell address contains 'one or more letters' 

followed by a number. The letter or letters identify the column and the number 

represents the row. 

 

Q14. a) What tools are available to customize our PowerPoint 

presentation? 

 Tools Used By Pro PowerPoint Presentation Designers 

1. Perspector. Perspector is a tool used by designers to create 3D images on 
PowerPoint presentations. ... 

2. PivotViewer. ... 

3. Autodesk 3DS Max. ... 

4. VisualBee PowerPoint Add-In. ... 



5. SmartArt. ... 

6. Animations and Transitions. ... 

7. Wordle. ... 

8. Cacoo. 

 

Q14 b) Write the steps for the following action for creation of power 
point presentation  

 Open a Blank presentation  
 

1. Select the File tab to go to Backstage view. 

2. Select New on the left side of the window, then click Blank Presentation. 

3. A new presentation will appear. 

 

 Save the presentation as Lab1.pptx 
 

1. Step 1 − Click on the File tab to launch the Backstage view and select Save. 

2. Step 2 − In the Save As dialog, type in the file name and click "Save". 

3. Step 3 − The default file format is Lab1. pptx. 

 

 Add a Title to the first slide: the name of your college  
 

1. Select the slide whose layout you will change so that it can have a title. 

2. Click Home > Layout. 

3. Select Title Slide for a standalone title page or select Title and Content for a slide 
that contains a title and a full slide text box. 

 

 Type your first name and last name in the Subtitle section  
 
Subtitle. First name Last name. Institutional affiliation (in original ... Use arial 10 
to write this part of the text. ... Author's name, Paper Title. 

 

 Add a New Slide which has a Title and Content 
 
To insert a new slide in PowerPoint with a “Title and Content” slide layout, click the 
“Home” tab in the Ribbon. Then click the “New Slide” button in the “Slides” 
button group. Alternatively, to insert a new slide with a different slide layout, click the 
“Home” tab in the Ribbon. 

 



Q15. Write steps for creation of a set of PowerPoint slides that 
demonstrates your skill to use the tools of PowerPoint. It should 
include the following things  

 Title slide &bullet list  
 

1. On the View tab, in the Presentation Views group, click Normal. 

2. On the left side of the PowerPoint window, click a slide thumbnail that you want 

to add bulleted or numbered text to. 

3. On the slide, select the lines of text in a text placeholder or table that you want to 

add bullets or numbering to. 

4. On the Home tab, in the Paragraph group, click Bullets   or Numbering 

 

 

 Inserting Excel Sheet  
 
Hold down SHIFT, and then select the same number of existing sheet tabs of the 
worksheets that you want to insert in the open workbook. For example, if you want 
to add three new worksheets, select three sheet tabs of existing worksheets. On the 
Home tab, in the Cells group, click Insert, and then click Insert Sheet. 

 

 Clip art and Text  
 
Select Insert > Picture > From Online. In the Online Pictures dialog box, type words 
describing the kind of picture you want (such as roses), and then press Enter. and then 
select Clipart under the Type category. Select the image you want to insert, then click 
the Insert button. 

 

 Slide show effects 

o Select the item you want to animate, then go to the Animations tab > 
Animations group > More. Choose an animation. 

o Use Effect Options if you want the animation on multiple items. Use the 
Animation Pane to change the order and timing. 

o Use Play All to preview your animations. 

 
Q16. What is the difference between Machine Language and 
High Level Language?  
 



Parameter High-Level Language Low-Level Language 

Basic These are programmer-friendly languages 
that are manageable, easy to understand, 
debug, and widely used in today’s times. 

These are machine-friendly languages that are 
very difficult to understand by human beings 
but easy to interpret by machines. 

Ease of Execution These are very easy to execute. These are very difficult to execute. 

Process of 
Translation 

High-level languages require the use of a 
compiler or an interpreter for their translation 
into the machine code. 

Low-level language requires an assembler for 
directly translating the instructions of the 
machine language. 

Efficiency of 
Memory 

These languages have a very low memory 
efficiency. It means that they consume more 
memory than any low-level language. 

These languages have a very high memory 
efficiency. It means that they consume less 
energy as compared to any high-level 
language. 

Portability These are portable from any one device to 
another. 

A user cannot port these from one device to 
another. 

Comprehensibility High-level languages are human-friendly. 
They are, thus, very easy to understand and 
learn by any programmer. 

Low-level languages are machine-friendly. 
They are, thus, very difficult to understand and 
learn by any human. 

 
 

Q17. Discuss about different data types of C programming 
Language. 
 

Data Types Memory Size Range 

signed short int 2 byte −32,768 to 32,767 

unsigned short int 2 byte 0 to 65,535 



long int 4 byte -2,147,483,648 to 2,147,483,647 

signed long int 4 byte -2,147,483,648 to 2,147,483,647 

 

 
Q18. Find the output of the following expressions  

a) X=20/5*2+30-5  
Ans X=33 
 

b) Y=30 – (40/10+6) +10  
Ans Y=30 

c) Z= 40*2/10-2+10  
Ans Z=16 
 

Q19 Describe the syntax of the following statements  
 
a) If – else statement  

 
The if/else statement is a part of JavaScript's "Conditional" Statements, which 
are used to perform different actions based on different conditions. In 

JavaScript we have the following conditional statements: Use if to specify a block of 
code to be executed, if a specified condition is true. 
 

b) for loop  
n programming, a loop is used to repeat a block of code until the specified condition is 
met. 

 

c) while loop  
 
While loop is also known as a pre-tested loop. In general, a while loop allows a part 
of the code to be executed multiple times depending upon a given boolean 
condition. It can be viewed as a repeating if statement. 

 

d) do-while loop 
 
do { statement(s); } while( condition );. Notice that the conditional expression appears at 
the end of the loop, so the statement(s) in the loop executes once ... 

Q20. Find the output of the following program segments 

a)  
 #include<stdio.h>  
int main()  

b)  
 #include<stdio.h>  
int main()  

c)  
 #include<stdio.h>  
int main()  



{  
int i;  
for (i=1; i<2;i++) 
{ 
Printf(“IMS Ghaziabad\n”); 
} 
 
 
 
 
 
 
 
Output:- 
1 
IMS Ghaziabad 

{  
int i=1;  
while(i<=2) 
{ 
Printf(“IMS Ghaziabad\n”); 
I=i+1; 
} 
 
 
 
 
 
 
Output:- 
1 
2 
IMS Ghaziabad 
 
 

{  
int a=10,b=20  
if(a>b) 
 
Printf(“the largest number is 
%d\n”,a); 
Else 
Printf(“the largest number is 
%d\n”,b); 
} 
 
 
 
 
 
Output:- 
the largest number is 20 
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