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Q1. Answer: 

(a) CPU – It is the electronic circuitry within a computer that carries out the instructions of a 

computer program by performing the basic arithmetic, logical, control and input or output 

operations specified by the instructions. It is also called a central processor, main processor or 

just processor, is the electronic circuitry that executes instructions comprising a computer 

program. 

  

(b) Keyboard – It is a peripheral input device which uses an arrangement of buttons or keys to act as 

mechanical level or electronic switches. Keyboard keys typically have a set of characters 

engraved or printed on them and each pair of key typically corresponds to a single written 

symbol. Keyboard is used as a text entry interface for typing text, numbers and symbols into 

application software such as a word processor, web browser or social media.   

  

(c)Mouse – A computer mouse is a hand-held pointing device that detects two dimensional  motion 

relative to a surface. This motion is typically translated into the motion of a pointer on a display. 

Which allows a smooth control of the Graphical User Interface (GUI) of a computer. Computer 

mouse have one or more buttons to allow operation such as the selection of menu item on a 

display. Mouse often also features other elements, such as touch surfaces and scroll wheels, which 

enables additional control and dimensional input. 



  

(a)Monitor – Monitor is an output device that display information in pictorial or text form. A 

monitor usually comprises a visual display, some circuitry, a casing and a power supply. Monitors are 

connected to all the computers via VGA, Digital Visual Interface (DVI), HDMI, DisplayPort, USB-C, 

Low-voltage Differential Signaling (LVDS) or other proprietary connectors and signals. 

  

Q2ans The classification of computers based on size and capacity are 

1.Super computer- Super computers have thousands of processors because of their extraordinary 

speed, accuracy, and processing power. Super computers are well suited for solving highly complex 

problems and huge amounts of calculations. 

2. Mainframe- computer- Mainframe- computer are very large often filing an entire room and can 

process thousands of millions of instructions per second. 

3.Minicomputers- Minicomputers are much smaller than mainframes. These Computer are also less 

expensive. 

4.Microcomputers- Microcomputers are the most frequently used type of computer. It is also, known as 

Personal Computer (PC). 

  



Q3 Ans: Computer generation is a change in technology a computer is / was being used. 

 Four types of computer generation are defined. 

1 First Generation – Vacuum Tubes (1940 -1956) 

The First computer system used vacuum tubes for circuitry and magnetic drums for memory. 

2 Second Generation – Transistors (1956 – 1963) 

Transistors replaced Vacuum Tubes in the Second Generation. 

3 Third Generation – Integrated Circuits (1956 -1963) 

The development of the integrated circuit was the hallmark of the Third Generation of computers.  

4 Fourth Generation- Microprocessors (1971- present): 

The microprocessor brought the fourth generation of computers as thousands of integrated circuits 

were built into a single chip. 

Q4Ans: 

         
               VOLATILE MEMORY 

 
               NON – VOLATILE MEMORY 

Volatile memory is a computer storage that only 
maintains its data while the device is power. 

Non- volatile memory is a type of computer 
memory that has the capability to hold saved 
data even the power is turned off. 

 
Example- Random Access Memory (RAM). 

 
   Example- Read Only Memory (ROM). 

 

Q5 ans.           System software 

-System Software is a type of software that is designed to run a computer’s hardware and application 

programs. 

                          Application software 

 – It is software created for a specific purpose, used by end users. It can be called an application or 

simply an app. 

Open- Source software (OSS)  

- It is a type of computer software in which source code is released under a license in which the 

copyright holder grants users rights to study, software to anyone and for any purpose. 

  



Q6 (a)The step involved are: 

1. We click the Microsoft office button. 

2. We select new. The new document dialog box appears. 

3. We select blank document under the blank and recent section. It will be highlighted by default. 

4. We click create. A new document appears in the word. 

5. To save the document, we click again the Microsoft office button. 

6. We select save as word document. The save as dialog box appears. 

7. We select the location whore we want to save the document using the Drop-Down menu. 

8. We enter the file name “yourself” for the document. 

9. We click the save button. 

 

. 

 Q6(B)Answer: T change the font style 

• Select the text we want to modify. 

• Left click the drop-down arrow next to the font style box on the home tab. The font 

style drop-down menu appears. 

• Move the cursor of the various font styles a live preview of the font will appear in the 

document. 

• Left click the font style we want use the font style change will change in the document. 

 

      

To format font size 

• Select the text we want to modify. 

• Left click drop-down arrow next to the font size box on the home tab. The font sized 

drop- down menu appear. 

• Move the cursor over the various font size. A live preview of the font size will appear 

in the document. 

• Left click the font size we want to use. The font size will change in the document. 

                         To change the font colour. 

• Select the text we want to modify. 

• Left click the Drop- Down arrow next to the font colour box on the home tab. The 

font colour menu appears. 

• Move the cursor over the various font colours. A live preview of the colour will 

appear in the document. 

• Left click the font colour we want to use the font colour will change in the document. 

Our colour choices aren’t limited to the Drop- down menu that appears. Some more colours 

at the bottom of the list to access the colour dialog box. Choose the colour we want, then 

click ok. 

To highlight (in yellow) the line reads “need to get IMS’s address are follows. 

• We select the live that reads needs to get “IMS address. 



• We click the highlight command and select yellow colour in the font group on 

the home tab. 

Q7Ans: 

                               MS WORD  

                               MS WORD is widely used commercial word processor developed by Microsoft. 

                                MS word is applications software, which is capable of  

• Creating. 

• Editing 

• Saving, and 

• Printing any type of document. 

  The steps involve in it are- 

1. We click the Microsoft office button. 

2. We select new. The new document dialog box appears. 

3. We select blank document under and recent section. It will be highlighted by default. 

4. We click create. A new blank document appears in the wood window. 

5. We create the given documents from the questions. 

6. We select the text “MS WORD” and change the font size by clicking on the font size on the home 

tab. 

7. We select the text “MS word” to change the font colour into red by clicking on the font colour 

menu. 

8. We select the text “MS Processors” and underline command it by clicking the underline 

command in the font group on the home tab. 

9. We select the text “Ms Word” to change the font style to italic by clicking italic command. 

10. We select the text we want to format as a list and click the bullet commands on the home tab. 

11. We change the font colour of the text “creating and saving” into blue and red respectively by 

clicking on the font colour command, again we select the text “and” and click on strike through 

comm on the font style command. 

12. We save the file name as “MS word” by clicking the Microsoft office button and select save as. 

13. We select the location where we want to save the document using the drop- down menu. 

We click the same button 

 

Q8: Answers: 

Equations 

X2   + Y5 = 30 

Z3   +   Q4 = 50 

A2    +   B8   = X2 + Y8  



 

Steps: 

➢ Open MS Word and choose the blank document 

➢ Type the require text or the equations 

➢ To make the powers smaller, select the text and click on the Subscript and Superscript on the 

toolbar in the home tab. 

Click on the file button in home tab and click save as option and save the file as ‘equations’ 

Q9: Answer: 

      Select the text you want to convert. 

      Select the Insert tab. 

      Click on Table command. A dialog box appears. 

      Click on Convert Text to Table, a new dialog box appears. 

      Here set number of columns. 

      Click on OK Finally selected text convert in a table. 

                                                                                  

 

      Select the text you want to convert.       Select the Insert tab. 

      Click on Table command. A dialog box 
appears. 

      Click on Convert Text to Table, a new dialog 
box appears. 

      Here set number of columns.       Click on OK Finally Selected text convert in a 
table.   

 

Steps: 

1. Open MS-word and choose blank document. 

2. Click on Microsoft Office Button. 

3. Click on ‘Save As’ option and type the file name as ‘text-to-table’. 

4. Click the ‘Save’ option and save it.   

 

Q10: Answer: 

Video provides a powerful way to help you prove your point. When you click Online Video, you can 

paste in the embed code for the video you want to add. You can also type a keyword to search online for 

the video that best fits your document. 

To make your document look professionally produced, Word provides header, footer, cover page, and 

text box designs that complement each other. For example, you can add a matching cover page, header, 

and sidebar. Click Insert and then choose the elements you want from the different galleries. 



          

          

          

 

          

          

          

          

          

 

Themes and styles also help keep your document coordinated. When you click Design and choose a new 

Theme, the pictures, charts, and SmartArt graphics change to match your new theme. When you apply 

styles, your headings change to match the new theme. 

Save time in Word with new buttons that show up where you need them. To change the way a picture 

fits in your document, click it and a button for layout options appears next to it. When you work on a 

table, click where you want to add a row or a column, and then click the plus sign. 

Steps: 

1. Open MS-word and select the blank document. 

2. Type the require text. 

3. Place the cursor on the position where you want to add table. 

4. Click on the Insert Tab to insert a table. 

5. Then, click the Table command on tool bar. 

6. Click the Insert Table in dialog box. 

7. Choose the require numbers of rows and columns. 

8. Click on OK option and the table is finally inserted. 

Q11ans 

Roll No Name Marks 

1 n1 60 

2 n2 70 

3 n3 80 

4 n4 90 

5 n5 40 

6 n6 50 

7 n7 77 

8 n8 44 

9 n9 88 

10 n10 55 

 

 



Q12Ans 

Roll No Name Marks 

1 n1 60 

2 n2 70 

3 n3 80 

4 n4 90 

5 n5 40 

6 n6 50 

7 n7 77 

8 n8 44 

9 n9 88 

10 n10 55 

   

 Total 654 

 Average 65.4 

     Highest 90 

 Minimun 40 

   
 

Q13. (a) Answer: 

➢ To modify column width of a worksheet: 

i. Select a column or a range of columns. 

ii. Select a Home tab and in the Cells group, select Format. 

iii. Click on Column width and type the width for column. 

iv. Select OK. 

➢ To modify the row height of a worksheet. 

i. Select a row or a range of rows. 

ii. Select a Home tab and in the Cells group, select Format. 

iii. Click on Row Height and type the height for row. 

iv. Select OK. 

➢ To delete rows and columns of a worksheet. 

i. Select the cell you want to delete within the column or row. 

ii. Select Home tab. And in cells group click on Delete Sheet Column or Row. 

                                                    OR 

i. Select the desire row or column. 

ii. Right-click and select Delete. 

Q13. (b) Answer: 

➢ Absolute Reference:  

An absolute reference in Excel means there is a fixed point of reference applied to a cell or a 

formula. This is so the return value will always stay the same no matter where the cell or 

formula moves to – within the same sheet or across different sheet. 



 

This refers to a fixed point of reference is a constant, and involves the use of dollar sign $ in the 

formula (i.e., everyone is to receive the same bonus payout, so the amount $1500 is constant in 

this situation). 

 

                        

Microsoft Excel 

97-2003 Worksheet
 

 

➢ Relative Reference: 

It is the default cell reference in Excel. It is simply the combination of column name and row 

number without any dollar ($) sign. When you copy the formula from one cell to another the 

relative cell address changes depending on the relative position of column and row. C1, D2, E4, 

etc. are examples of relative cell references. Relative references are used when we want to 

perform a similar operation on multiple cells and the formula must change according to the 

relative address of column and row. 

                      

Microsoft Excel 

97-2003 Worksheet
 

This refers to a relative point of reference, is constantly changing and dollar sign ($) is absent in 

the formula (i.e., when each unit price and quantity are difference variables, there’s no constant 

in the calculation).  

 

➢ Cell Address: 

A cell address is a combination of column letter and a row number that identifies a cell on a 

worksheet. 

For example, A1 refers to the cell at the intersection of column A and row 1; B2 refers to the 

second cell in column B, and so on. 

         When used in formula, cell references help Excel find the values the formula should 

calculate. For instance, 

• To pull the value of A1 to another cell, you use this simple formula: 

=A1 

• To add up the values in cells A1 and A2, you use this one: 

=A1+A2 

 

Q14. (a) Answer: 

Tools available to customize our PowerPoint presentation are: 

a) Perspector 

b) Pivot Viewer  

c) Autodesk 3DS Max 

d) Visual Bee PowerPoint Add-in 



SmartArt 

e) Animations and Transition 

f) Wordle  

g) CA coo 

h) Oomfo  

i) Clip champ  

 

(b). Answer: 

➢ To open blank presentation: 

I. Open PowerPoint presentation using ‘Run’ command (window key + R). 

II. Select the ‘Blank Presentation’. It is opened. 

➢ Save the Presentation as Lab1.pptx.: 

I. Select the ‘File’ on Tab bar. 

II. Click on ‘Save As’ option. 

III. Click on document/Desktop as your choice. 

IV. Type the name ‘Lab1.pptx’. 

V. Click the ‘Save’ button. 

 

➢ Add a Title to the first slide: the name of your college. 

i. Left click on the ‘Click to Add Title’ section on the first slide. 

ii. Type the name of your college. 

➢ Type your first name and last name in the subtitle section: 

i. Left click on the ‘Click to Add Subtitle’ section. 

ii. Type your first name and last name. 

➢ Add a new slide which has a Title and content. 

i. Select the Home tab. 

ii. Click on the dropdown button of the ‘New Slide’ on toolbar. 

iii. Select the slide having ‘Title and Content’. It is added. 

 

Q15. Answer: 

➢ Title slide and bullet list: 

i. Open PowerPoint Presentation. 

ii. Select the Home tab. 

iii. Click at the dropdown button on ‘New Slide’ at toolbar. 

iv. Select the slide having Title slide and Bullet list. 

➢ Inserting Excel sheet: 

i. Open the slide where you want to insert the Excel Sheet. 

ii. Select the ‘Insert tab’. And click on ‘Object’ on tool bar. 

iii. Select the ‘Microsoft Excel Worksheet’ object type. 

iv. Click the ‘OK’ button. 



➢ ClipArt and Text: 

i. Select the Insert Tab. 

ii. Select the ‘Pictures’ or ‘Online pictures’ on tool bar. 

iii. Choose the appropriate art for the topic. 

iv. Click on the ‘Insert’ button. 

➢ Slide show effects: 

i. Select ‘Design Tab’ for Themes, Variants and Slide size. 

ii. Select ‘Transition Tab’ for Cut, Fade, Push, Wipe, Split, Reveal, Shape, Flash, etc. for slide 

effects. 

 

Q16ans  

 
MACHINE LANGUAGE 

 
HIGH LEVEL LANGUAGE 

A computer programming language consisting of 
binary instructions which a computer can 
respond to directly. 

A High- Level Language is a programming 
language that enables development of a program 
in a much more user- friendly programming 
context. 

 

Q17- The different types of C- programming language are as follows: 

    CHAR: The most basic data type in C. It stores a single character and requires a single of memory in 

almost all compilers. 

INT- As the name suggests, an INT variable is used to store an integer. 

FLOAT: It is used to store decimal numbers (numbers with floating point value). 

DOUBLE: It is used to stored decimal numbers (numbers with floating value but its range of values is 

high in comparison to float 

Q18Ans: 

(a)33. 

(b)30. 

(c)16. 

 

Q19Ans- (a) If- else statement  

                   If statements can be followed by an optional else block of statements, which executes when 

the Boolean expression is false; 

          Syntax 

          If (expression) 



{ 

         True block of statements; 

} 

else  

 

[ 

     Else  

{ 

Else block of statement; 

} 

(B) For- loop 

For-loop is similar to While loop. Basic syntax of for loop is as follows: 

For (expression1; expression2; expression3;) 

{ 

    Block of statement   

} 

In the above syntax  

• Expression 1- Initializes variables. 

• Expression 2- Conditional expression, as long as this condition is true, loop will keep executing. 

• Expression 3- expression 3 is the modifier which will increase or decrease the value of the 

variable. 

 

(C) While loop 

     Basic syntax of while loop is as follows. 

      While (condition) 

          Single Statement. 

OR 

      While condition  

{ 

Block of statements: 

} 

 

(D) Do- while loop. 



• Do while is just like a while loop is excepted that the text condition is checked at the end of the 

loop rather than the start. This has the effect that the body of the loop are always executed at 

least once. 

• Basic syntax of do while. 

Do     

{  

    Single statement  

         Or  

    Block of statements 

} (condition); 

Q20Ans: 

(a) IMS Ghaziabad. 

 

(b) IMS Ghaziabad, 

IMS Ghaziabad, 

IMS Ghaziabad. 

(c) The largest number is 100. 

 

 

 

                   

 

 

  



 

 


