
 

CCA-101: Fundamentals of IT & Programming 

 Assignment -1 

 Q1: What are the four fundamental parts of computer? Explain it with the 

help of diagram. 

 

There are four main computer hardware components that this blog post will cover: input 

devices, processing devices, output devices and memory (storage) devices. Collectively, 

these hardware components make up the computer system. 

 

 Q2: Discuss about the classification of computers based on size and 

capacity? 

Computer's Classification 

Computers are classified on different parameters, such as, storage capacity, processing speed and 

component (CPU) used in computers. Depending upon the components used and features of 

different computers, they are classified into four groups, Microcomputers, Minicomputers, Mainframe 

computers and Supercomputers. 

  

Micro Computers 

Micro Computer is a computer whose CPU (Central Processing Unit) is a microprocessor. All the 

components of a microprocessor are on a single integrated circuit chip. Micro computer can be 

categorized as the desktop, programmable and workstation. The microprocessor based computers 



are called third generation computers. They are the backbone of the modern computer era. The first 

and second generation computers are based on vacuum tubes and bipolar junction transistors. 

Mini Computers 

Minicomputers were introduced in early 1960s. They were faster than micro computers. Basically 

these computers were mainly multi-user systems, where many users work on the systems. Generally 

these types of computers had larger memories and greater storage capacity. They had large 

instruction set and address field. These kinds of computers have efficient storage for handling of 

text, in comparison to lower bit machines. Due to more efficient processor, speed and memory size, 

minicomputer was used in variety of applications and could support business applications along with 

the scientific applications. Minicomputer was a multi-user system which means more than one user 

could use this system simultaneously. 

Mainframe Computers 

Mainframe computers are large and expensive machines. The word length of mainframe computers 

may be 48, 60 or 64 bits, memory capacity being in some megabytes and storage capacity in some 

terabytes. Generally they handle huge volumes of information and data. In terms of speed, they are 

having significant processing capacity. They are used in research organizations, large industries, 

airlines reservation where a large database has to be maintained. 

Super Computers 

Super Computers are the fastest computer in current era. The processing capabilities of super 

computer lies in the range of GIPS2, word length 64-128 or may be in 256 or so. The memory 

capacity of super computer is in some gigabytes or in terabytes. The storage capacity of this type of 

computer is in exabytes. 

 

 

Q3: What is the meaning of computer generation? How many Computer 

Generations are defined? What technologies were/ are used? 

Introduction: 
A computer is an electronic device that manipulates information or data. It has the ability 
to store, retrieve, and process data. 
Nowadays, a computer can be used to type documents, send email, play games, and 
browse the Web. It can also be used to edit or create spreadsheets, presentations, and 
even videos. But the evolution of this complex system started around 1940 with the first 
Generation of Computer and evolving ever since. 



There are five generations of computers. 

1. FIRST GENERATION 
Introduction: 

1. 1946-1959 is the period of first generation computer. 
2. J.P.Eckert and J.W.Mauchy invented the first successful electronic computer 

called ENIAC, ENIAC stands for “Electronic Numeric Integrated And 
Calculator”. 

• Few Examples are: 
1. ENIAC 
2. EDVAC 
3. UNIVAC 

2 SECOND GENERATION 

• Introduction: 
1. 1959-1965 is the period of second-generation computer. 
2. 3.Second generation computers were based on Transistor instead of vacuum 

tubes. 
• Few Examples are: 

1. Honeywell 400 

3 THIRD GENERATION 

• Introduction: 
1. 1965-1971 is the period of third generation computer. 
2. These computers were based on Integrated circuits. 
3. IC was invented by Robert Noyce and Jack Kilby In 1958-1959. 
4. IC was a single component containing number of transistors. 

• Few Examples are: 
1. PDP-8 
2. PDP-11 

1. 4 FOURTH GENERATION 

• Introduction: 
1. 1971-1980 is the period of fourth generation computer. 
2. This technology is based on Microprocessor. 
3. A microprocessor is used in a computer for any logical and arithmetic function 

to be performed in any program. 
4. Graphics User Interface (GUI) technology was exploited to offer more comfort 

to users. 
• Few Examples are: 

1. IBM 4341 

5 FIFTH GENERATION 

• Introduction: 
1. The period of the fifth generation in 1980-onwards. 
2. This generation is based on artificial intelligence. 
3. The aim of the fifth generation is to make a device which could respond to 

natural language input and are capable of learning and self-organization. 



4. This generation is based on ULSI(Ultra Large Scale Integration) technology 
resulting in the production of microprocessor chips having ten million 
electronic component. 

• Few Examples are: 
        AI 

Q4: Differentiate between Volatile & Non- Volatile memories. 

Volatile Memory: 
It is the memory hardware that fetches/stores data at a high-speed. It is also 
referred as temporary memory. The data within the volatile memory is stored 
till the system is capable of, but once the system is turned off the data within 
the volatile memory is deleted automatically. RAM (Random Access 
Memory) and Cache Memory are some common examples of volatile 
memory. Here, data fetch/store is fast and economical. 
 
Non-Volatile Memory: 
It is the type of memory in which data or information is not lost within the 
memory even power is shut-down. ROM (Read Only Memory) is the most 
common example of non-volatile memory. It’s not economical and slow in 
fetch/store as compared to volatile memory however stores higher volume of 
data. All such information that needs to be stored for an extended amount of 
time is stored in non-volatile memory. Non-volatile memory has a huge 
impact on a system’s storage capacity. 
 

Q5: Distinguish among system software, application software and open source 

software on the basis of their features. 

System software is used for operating computer hardware. On other hand Application 

software is used by user to perform specific task. System software are installed on 

the computer when operating system is installed. On other hand Application 

software are installed according to user's requirements. 

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it 

with file name “yourself”. Describe all steps involved in it 

https://www.geeksforgeeks.org/different-types-ram-random-access-memory/
https://www.geeksforgeeks.org/different-types-ram-random-access-memory/
https://www.geeksforgeeks.org/cache-memory/
https://www.geeksforgeeks.org/computer-organization-ram-vs-rom/


 

Q6b.Write steps regarding 

➢ To change the font  

To change the font type within a Microsoft Word 

document, follow the steps below. 

1. Highlight the text you want to change. 

2. Click the down arrow next to the font field on the 
format bar or Ribbon. (If you want to change the 
font to bold, italic, or underlined, click the B, I, or U 
on the format bar.) 

3. After clicking the down arrow for the font, you can 
select from each of the installed fonts on your 
computer. Click the font you want to use and the 
highlighted text changes. 

➢ To change the font size 
 

1. Select the text with text you want to change. To select all text in a Word document, 
press Ctrl + A. 

2. On the Home tab, click the font size in the Font 
Size box. You can also type in any size you want 

https://www.computerhope.com/jargon/h/highligh.htm


➢ To change the font color. 

1.  Select the text that you want to change. 

2. On the Home tab, in the Font group, choose the arrow next to Font Color, and then 
select a color. You can also use the formatting options on the Mini toolbar to quickly 
format text. 

➢ To highlight (in yellow)the line that reads ”need to 
get IMS”s address”. 

➢ Select the text that you want to change. 

➢ On the Home tab, in the Font group, choose the arrow next to Font Color, and 
then select a color. You can also use the formatting options on the Mini toolbar 
to quickly format text. 

  Q7. Create a file in MS-Word for the following document and save it with file 

name ‘ms_word’. Describe all steps involved in it.  

MS Word is a widely used commercial word processor developed by Microsoft. 

 MS word is a application software,which is capable of 

➢ Creating 

 

 
 

➢ Editing 



 
 

➢ Saving, 

 
 

➢ Printing any type of document 

 



 
 

Q8.  Create  a file in Ms_word for the following and save it with 

“equations”. Describe all steps involve in it. 

 

 
 

Q9.Creat a file in MS-Word to insert a table in the document. Describe 

all steps involved in it.  



 
 

STEPS: 
Select the text you want to convert 

Select the Insert tab. 

Click on TABLE command. Adialogs appears . 

Click on Convert Text to Table, a new dialog box appears . 

Here set number of column . 

Click OK  

Finally selected text convert into table. 

 

Q10: Create  a file in MS-Word to insert a table in the document. 

Describe all steps  involved in it. 
 

 
 



Q11: Create  a following work sheet in MS-Excel and save it with 

name’book1’. 

 
 

Q12: Calculate the following things of a range (C2:C11) of data in the work 

sheet created in question no 10 

➢ The sum of the marks using AutoSum in a range (C2:C11) 

 
➢ Average of marks in a range of cell (C2:C11) 



 
➢ Highest marks in a range of cell (C2:C11) 

 
➢  marks in a range of cell (C2:C11) 

 



Q13: a) Describe various steps involve in the following 

➢ To modify column width of a work sheet  

1. Position the mouse over the column line in the column heading so 
the cursor becomes a double arrow. 

2. Click and drag the mouse to increase or decrease the column 
width. 

3. Release the mouse. The column width will be changed. 

 

➢ To modify row height of a work sheet  

1. To change the height of one row, drag the lower boundary 

of the row heading until the row is set to the desired height. 

 

2. To change the height of multiple row, select the rows of 

interest and drag the boundary below any row heading in the 

selection. 

 

➢ To delete row and column of a work sheet  

To delete row 

1. Select a cell in the row to be deleted. 

2. Choose Edit Delete from the menu bar. 

3. Click Entire Row in the Delete dialog box. 

To delete column 

1. Select a cell in the column to be deleted. 
2. Choose Edit Delete from the menu bar. 
3. Click Entire Column in the Delete dialog box. 

Q13.b) Describe the following terms in the worksheet 

➢ Absolute reference and relative reference in formula 

 relative cell references change when you copy the formula to other cells. 

 



Unlike relative cell references, absolute cell references don’t 
change when you copy the formula to other cells. 

 
➢ Cell address 

 
A cell reference, or cell address, is an alphanumeric value 
used to identify a specific cell in a spreadsheet. 

➢ Q14:a)What tools are available to customize our power point 

presentation ? 

Beginning ,custom ,current . 

➢ Q14:b)Write the steps for the following action for creation of power 

point. 

1. Start by opening a "Blank presentation" in PowerPoint. ... 

2. Select the "Title Slide" option. ... 

3. Type in your title and subtitle. ... 

4. Select a background for the entire presentation 

 

➢ Open a Blank presentation 

➢ Save the presentation as Lab1. pptx . 

 

 



➢ Add a title to the first slide the name of your college. 

➢ Type your first name and last name in the subtitle section. 

➢ Add a new slide which has a title and content. 

 
Q15:Write steps for creation of asset of a power point slides that 

demonstrates the tools of power point .It should include the 

foliowing 

➢ Title slide & bullet list 

1. To insert a bullet, place the cursor at the end of 
a bulleted line, press Enter, and start typing. 

2. To create a sub-bullet, place the cursor in front of the text, 
and press Tab. 

 

➢ Inserting Excel  Sheet 

PowerPoint, on the Insert tab, click or tap Object. In 

the Insert Object dialog box, select Create from file. Click or 

tap Browse, and in the Browse box, find the Excel 

workbook with the data you want to insert and link to. 

Before you close the Insert Object box, select Link, and click 

OK. 

➢ Clip art and text 

➢ Click in the slide where you want to insert a clip art file. 



 
 

➢ On the Insert tab, in the pictures  group, 

➢ In the Insert Pictures dialog box and press Enter. 

➢ Locate the clip art you want to insert in your slide and double-click on it or 
click the item and select Insert. 

 

➢ Slide show and effect 

 

 Insert a photo album to your presentation Go to “Insert” → “Photo Album” 

→ “New Photo Album” 

➢ Click on “File Disk”. 
➢ Click “Insert” 
➢ Click “Create” 
Add transitions to your slideshow 

Click the first slide, then hold Shift while clicking the last slide to select the 
whole range of slides. 
Go to “Transitions” → click on the arrow to open up more choices. 
Click on “Random”. 
  Set the slides to advance automatically 

From the “Transitions” tab, check the “Advance Slide” “After” box. 
Set it to 2 seconds (or whatever you want). 
  Set the slideshow to loop continuously 

Go to “Slide Show” → “Set Up Show”. 
Turn on “Loop continuously until ‘Esc’”, then click “OK”. 
 
Q16: What is the difference between Machine language and High Level 

Language ? 

 
➢ Machine language, or machine code, consists of binary code and is the 

only language that is directly understood by the computer. ... Both machine 

code and assembly languages are hardware specific. A high-level 

language is a programming language that uses English and mathematical 

symbols in its instructions. 

Q17:Discuss about difference data types of C programming Language. 



Data type in C language 
There are four basic data types in C programming language. 

• Character (char) 

• Integer (int) 

• Floating Point (float) 

• Double Floating Point (double) 

Q18: Find the output of the following expressions 

a) X=20/5 * 2+30-5 
Ans.33 

b) Y=30+(40/10+6)+10 
Ans.50 

c) Z=40*2/10-2+10 
Ans.16 

 

Q19: Describe the syntax of the following statements 

a) If – else statement 
Syntax. If the Boolean expression evaluates to true, then the if block 
will be executed, otherwise, the else block will be executed. C 
programming language assumes any non-zero and non-null values as 
true, and if it is either zero or null, then it is assumed as false value. 

b) For loop  
A for loop is a repetition control structure that allows you to efficiently 
write a loop that needs to execute a specific number of times. 

c) While loop 
A while loop in C programming repeatedly executes a target statement 
as long as a given condition is true. 

d) Do while-loop 

Unlike for and while loops, which test the loop condition at the top of 
the loop, the do...while loop in C programming checks its condition at 
the bottom of the loop. 

A do...while loop is similar to a while loop, except the fact that it is 
guaranteed to execute at least one time. 

Q20:Find the output of the following program segments. 

a) # include <stdio.h > 



 int main() 

{ 

int i; 

for(i=1;i<2;i++) 

{ 

printf(“ IMS Ghaziabad\n”); 

} 

} 

 

 

 

               

  b)       # include <stdio.h > 

int main() 

{ 

int i=1; 

while (i<=2) 

{ 

printf(“ IMS Ghaziabad\n”); 

i=i+1; 

}} 



 

 

 

c)  # include <stdio.h > 

void main() 

{ 

int a=10, b=100; 

if (a>b) 

{ 

printf(“ Largest number is %d\n”,a); 

else 

 

printf(“ Largest number is %d\n”,b); 

 

}} 



 


