
ASSIGNMENT -1 
FUNDAMENTAL OF IT & PROGRAMMING 

 

QUE- 1- what are the four fundamental parts of computer explain it with the help of diagram. 

ANS- A computer has four main components: the central processing unit or CPU, 

the primary memory, input units and output units. A system bus connects all four 

components, passing and relaying information among them. This type of 

computer organization and architecture is called a "von Neumann machine" after 

John von Neumann, who finalized the theory and design of the first modern 

digital computer 

1- CPU- 

Computer scientists typically call the CPU the "brain" of the computer because this is 

where programs are executed. A program is a set of instructions that tells the computer 

how to accomplish a specific task, such as sending a file to the printer, opening a browser 

window, or playing music or video. 

The CPU is further broken up into three smaller components: the arithmetic unit 

handles all the simple mathematical computations; the control units interpret the 

instructions in a computer program; and the instruction decoding unit converts 

computer programming instructions into machine code. Machine code is the 

basic language understood by all the components in a computer. 

2- Memory 

Once the CPU converts a specific set of computer program instructions into machine 

code, it stores that machine code in primary storage or memory. The machine code will 

be treated as either data or instructions. The CPU fetches data and instructions from 



memory, uses an instruction to manipulate the data, and then sends the result and the next 

set of instructions back to memory. 

3- Input Units 

Input units are all the devices you use to feed information to the computer, such as a 

keyboard, a hard drive or a networking card. These devices, in essence, bring data from 

the "outside world" into your computer, in much the same way that your eyes and ears 

bring information to your brain. Each input device has its own hardware controller that 

connects to the CPU and primary memory, and it has a set of instructions that tells the 

CPU how to use it. 

 

4-  Output Units 

Output units are the devices your computer uses to relay information to the user, such as 

a printer, monitors and speakers. For example, everything you see on your computer 

monitor starts as machine code in memory. The CPU takes that machine code and 

converts it into a format required by your monitor's hardware. Your monitor's hardware 

then converts that information into different light intensities so that you see words or 

pictures. 
 

 

 



QUE- 2 -DISCUSS ABOUT THE CLASSIFICATION OF COMPUTER BASED ON SIZE AND CAPACITY. 

ANS-  

-  

Classification of Computer Based on Size and Capability 

  

Introduction 

Classification of computers are based on their architecture, speed of executing commands or 

instructions, peripheral used and also their uses. Microcomputers are usually used in home and 

offices and only a single user can perform the task using a microcomputer. Its storage and data 

handling capacity are limited as per the requirement for home and office work. The another type of 

computer is called minicomputer which has usually larger storage and can handle multiuser at a 

time. This chapter includes the classification of computers. 

  

Computer's Classification 

Computers are classified on different parameters, such as, storage capacity, processing speed and 

component (CPU) used in computers. Depending upon the components used and features of 

different computers, they are classified into four groups, Microcomputers, Minicomputers, Mainframe 

computers and Supercomputers. 

  



Micro Computers 

Micro Computer is a computer whose CPU (Central Processing Unit) is a microprocessor. All the 

components of a microprocessor are on a single integrated circuit chip. Micro computer can be 

categorized as the desktop, programmable and workstation. The microprocessor based computers 

are called third generation computers. They are the backbone of the modern computer era. The first 

and second generation computers are based on vacuum tubes and bipolar junction transistors. 

  

 

  

Desktop Computers 

Desktop computer is a type of microcomputer. A desktop computer has a keyboard for input data, a 

LCD or CRT monitor to display information and Central processing unit tower contains storage, 

memory, different types of drives, such as, CD drive, hard drive, etc. A desktop computer is mainly 

used at home and office applications. 

 Programmable Computers (PDA) 

Personal digital assistance is a type of hand held programmable digital computer. It is used as 

notepads, address books and can connect to world web wave to share information. A PDA is 

equipped with mobile phone hence, called smallest computer. 

 Workstation 

A workstation computer has greater memory capability and more extensive mathematical abilities. It 

is connected with other workstation computers or personal computer to exchange data and mostly 

used for scientific applications. It also supports multitasking applications. 

  



Mini Computers 

Minicomputers were introduced in early 1960s. They were faster than micro computers. Basically 

these computers were mainly multi-user systems, where many users work on the systems. Generally 

these types of computers had larger memories and greater storage capacity. They had large 

instruction set and address field. These kinds of computers have efficient storage for handling of 

text, in comparison to lower bit machines. Due to more efficient processor, speed and memory size, 

minicomputer was used in variety of applications and could support business applications along with 

the scientific applications. Minicomputer was a multi-user system which means more than one user 

could use this system simultaneously. 

  

Comparison of Micro and Mini computers 

  

Features Microcomputer Minicomputer 

Primary 
memory  

Shall memory Larger memory 

Word length  Small word 
length  

Larger word 
length 

Cost low Low High 

Processor Low High 

  

Mainframe Computers 

Mainframe computers are large and expensive machines. The word length of mainframe computers 

may be 48, 60 or 64 bits, memory capacity being in some megabytes and storage capacity in some 

terabytes. Generally they handle huge volumes of information and data. In terms of speed, they are 

having significant processing capacity. They are used in research organizations, large industries, 

airlines reservation where a large database has to be maintained. 

  

 



  

Super Computers 

Super Computers are the fastest computer in current era. The processing capabilities of super 

computer lies in the range of GIPS2, word length 64-128 or may be in 256 or so. The memory 

capacity of super computer is in some gigabytes or in terabytes. The storage capacity of this type of 

computer is in exabytes. 

  

 

  

The parallel processing of a super computer makes it very fast because it contains number of CPU 

that operates parallel. They are used at some research centers and government agencies involving 

sophisticated scientific and engineering tasks. 

  

 

 



Super computers are used for the followings: 

  

  Weapons research and development 

  Nuclear and plasma physics 

  Rocket research and development 

  Atomic research 

  Aerodynamics 

  

Units For Measuring Word Length, Data, And Storage Capacity of a Computer 

Computers are classified on the basis of their data processing speed better known as clock speed 

and the word length. The word length that is processed by a CUP at a time is one of the important 

feature of that CPU. 

  

The followings are the units for the measurement of data volume: 

  

bit bit 0 or 1 

Byte B 8 bite 

Kibibit Kibit 1024 bits 

kilobit Kbit 1000 bits 

kibibyte (binary) KiB 1024 bytes 

kilobyte (decimal) kB 1000 bytes 

megabit Mbit 1000 kilobits 

mebibyte (binary) MiB 1024 kibibytes 

megabyte (decimal) MB 1000 kilobytes 

gigabit Gbit 1000 megabits 

gibibyte (binary) Gibbs 1024 mebibytes 

gigabyte (decimal) GB 1000 megabytes 

terabit Tbit 1000 gigabits 

tebibyte (binary) TIB 1024 gibibytes 

terabyte (decimal) TB 1000 gigabyte 

Petabit Pbit 1000 terabyte  

pebibyte (binary) PiB 1024 tebibytes 

petabyte (decimal) PB 1000 terabytes 

exabit Ebit 1000 petabits 

exbibyte (binary) EiB 1024 pebibytes 

exabyte (decimal) EB 1000 petabytes 



QUE-3- COMPUTER GENERATION EXPLAINATION. 

ANS- Generation in computer terminology is a change in technology a computer is/was being 

used. Initially, the generation term was used to distinguish between varying hardware 

technologies. Nowadays, generation includes both hardware and software, which together make 

up an entire computer system. 

 

 

 

QUE- 4- VOLATILE AND NON VOLATILE MEMORY . 

ANS- Volatile and Non-Volatile Memory are both types of computer memory. Volatile Memory is 

used to store computer programs and data that CPU needs in real time and is erased once 

computer is switched off. RAM and Cache memory are volatile memory. Where as Non-volatile 

memory is static and remains in the computer even if computer is switched off. ROM and HDD 

are non-volatile memory. 



Following are the important differences between Volatile and Non-Volatile Memory. 

Sr. 
No. 

Key Volatile Memory Non-Volatile Memory 

1 
Data 
Retention 

Data is present till power 
supply is present. 

Data remains even after power 
supply is not present. 

2 
Persistence Volatile memory data is not 

permanent. 
Non-volatile memory data is 
permanent. 

3 
Speed Volatile memory is faster 

than non-volatile memory. 
Non-volatile memory access is 
slower. 

4 
Example RAM is an example of 

Volatile Memory. 
ROM is an example of Non-Volatile 
Memory. 

5 
Data 
Transfer 

Data Transfer is easy in 
Volatile Memory. 

Data Transfer is difficult in Non-
Volatile Memory. 

6 
CPU 
Access 

CPU can access data stored 
on Volatile memory. 

Data to be copied from Non-Volatile 
memory to Volatile memory so that 
CPU can access its data. 

7 
Storage Volatile memory less storage 

capacity. 
Non-Volatile memory like HDD has 
very high storage capacity. 

8 
Impact Volatile memory such as 

RAM is high impact on 
system's performance. 

Non-volatile memory has no impact 
on system's performance. 

9 
Cost Volatile memory is costly per 

unit size. 
Non-volatile memory is cheap per 
unit size. 

 

QUE-5- SYSTEM SOFTWARE ,APPLICATION SOFTWARE, OPEN SOURCE SOFTWARE . 

ANS- 1. Open source Software: Open source software is computer software 

whose source code is available openly on the internet and programmers can 
modify it to add new features and capabilities without any cost. Here the 
software is developed and tested through open collaboration. This software is 
managed by an open-source community of developers. It provides community 
support, as well as commercial support, which is available for maintenance. We 
can get it for free of cost. This software also sometimes comes with a license 
and sometimes does not. This license provides some rights to users. 
 The software can be used for any purpose 
 Allows to study how the software works 

https://www.geeksforgeeks.org/open-source-freeware-and-shareware-softwares/


 Freedom to modify and improve the program 
 No restrictions on redistribution 
Some examples of Open source software include Android, Ubuntu, Firefox, 
Open Office, etc.  
2. Proprietary Software: Proprietary software is computer software where the 
source codes are publicly not available only the company that has created can 
modify it. Here the software is developed and tested by the individual or 
organization by which it is owned not by the public. This software is managed 
by a closed team of individuals or groups that developed it. We have to pay to 
get this software and its commercial support is available for maintenance. The 
company gives a valid and authenticated license to the users to use this 
software. But this license puts some restrictions on users also like. 
 Number of installations of this software into computers 
 Restrictions on sharing of software illegally 
 Time period up to which software will operate 
 Number of features allowed to use 
Some examples of Proprietary software include Windows, macOS, Internet 
Explorer, Google Earth, Microsoft Office, etc.  

Difference between Open-source Software and Proprietary Software: 

S.No. OPEN-SOURCE SOFTWARE PROPRIETARY SOFTWARE 

01. 

Open-source software is computer 

software whose source code is available 

openly on the internet and programmers 

can modify it to add new features and 

capabilities without any cost. 

Proprietary software is computer 

software where the source codes are 

publicly not available only the 

company which has created can 

modify it. 

02. 

Here the software is developed and tested 

through open collaboration. 

Here the software is developed and 

tested by the individual or 

organization by which it is owned 

not by the public. 

03. 
In open-source software the source code is In proprietary software, the source 



S.No. OPEN-SOURCE SOFTWARE PROPRIETARY SOFTWARE 

public. code is protected. 

04. 

Open-source software can be installed on 

any computer. 

Proprietary software can be installed 

into any computer without a valid 

license. 

05. 

Users do not need to have any 

authenticated license to use this software. 

Users need to have a valid and 

authenticated license to use this 

software. 

06. 

Open-source software is managed by an 

open-source community of developers. 

Proprietary software is managed by 

a closed team of individuals or 

groups that developed it. 

07. 

It is more flexible and provides more 

freedom which encourages innovation. 

It is not much flexible so there is a 

very limited innovation scope with 

the restrictions. 

08. 

Users can get open software free of 

charge. 

Users must have to pay to get the 

proprietary software. 

09. 

In open-source software faster fixes of 

bugs and better security are availed due to 

the community. 

In proprietary software, the vendor 

is completely responsible for fixing 

malfunctions. 

10. Limited Intellectual Property Protections Full Intellectual Property Protections 



S.No. OPEN-SOURCE SOFTWARE PROPRIETARY SOFTWARE 

11. 

Usually Developed and Maintained by 

non-profit organizations. 

Usually Developed and Maintained 

by for-profit entities. 

12. 

Examples are Android, Linux, Firefox, Open 

Office, GIMP, VLC Media player, etc. 

Examples are Windows, macOS, 

Internet Explorer, Google Earth, 

Microsoft Office, Adobe Flash Player, 

Skype, etc. 

 

QUE- 6(A) – MS WORD FILE – 

Steps to create document in MS WORD 

Explanation: 

Step 1: Open Ms word on your system. 

Step 2: Click on the new file when you open the word file when the dialog box 

appear. 



Step 3: Once this click on Blank doc under the recent section, it will get in bold 

or highlighted by default. 

Step 4: Click on the create A new blank doc will open. 

Step 5: Once it is opened you can write anything you want in the doc for 

yourself. 

Step 6: You can also edit the text you have written as you can change the 

background color ,or the text and many other things in the docs. 

 

QUE- 6(B)- WRITE STEPS REGRDING FOLLWING . 

ANS- 1- CHANGE THE FONT STYLE – 

Word 

1. Open a new blank document. 

2. On the Home tab, in the Styles group, click the dialog box launcher .. ... 

3. Click the Manage Styles button (third from left at the bottom). 

4. Click the Set Defaults tab and pick the size you want in the Size box. ... 

5. Click the New documents based on this template option. 

6. Close and reopen Word. 

2- TO CHANGE THE FONT SIZE-  

To change the font size of selected text in desktop Excel, PowerPoint, or Word: Select the text 

or cells with text you want to change. To select all text in a Word document, press Ctrl + 

A. On the Home tab, click the font size in the Font Size box. 

3- TO CHANGE THE  FONT COLOUR. 

You can change the color of text in your Word document. Select the text that 
you want to change. On the Home tab, in the Font group, choose the 
arrow next to Font Color, and then select a color. You can also use the 

formatting options on the Mini toolbar to quickly format text. 

4- WRITE STEPS TO HIGHLIGHT (IN YELLOW) THE LINE THAT READS "NEED 

TO GET IMS' S ADDRESS IN MS WORD 2007 



Highlight selected text 

1. Select the text that you want to highlight. 

2. Go to Home and, select the arrow next to Text 

Highlight Color. 

 

3. Select the color that you want. 

Note: Use a light highlight color if you plan to print the document by using a monochrome palette 

or dot-matrix printer. 

Highlight multiple parts of a 

document 

This method is best for highlighting multiple parts of a 

document because the Highlight tool stays on until you 

decide to turn it off. 

1. Go to Home and select the arrow next to Text 

Highlight Color. 

 

2. Select the color that you want. 



The Text Highlight Color button displays the selected 

color, and the mouse pointer becomes a  when you 

point to the area of your document that contains text. 

Note: Use a light highlight color if you plan to print the document by using a monochrome palette 

or dot-matrix printer. 

3. Select the text or graphic that you want to highlight. 

4. To stop highlighting, select the arrow next to Text 

Highlight Color  and select Stop Highlighting, or 

press Esc. 

The mouse pointer becomes a  when you point to 

your document. 

Remove highlighting from part or all 

of a document 

1. Select the text that you want to remove highlighting 

from, or press Ctrl+A to select all of the text. 

2. Go to Home and select the arrow next to Text 

Highlight Color. 

 

3. Select No Color. 



QUE- 10- Insert a table IN MS WORD –  

ANS- For a basic table, click Insert > Table and move the 

cursor over the grid until you highlight the number of 

columns and rows you want. 

 

For a larger table, or to customize a table, 

select Insert > Table > Insert Table. 

 

Tips:  

 If you already have text separated by tabs, you can quickly convert it to a table. 

Select Insert > Table, and then select Convert Text to Table. 

 To draw your own table, select Insert > Table > Draw Table. 

QUE- 13- DIFFERENCE BETWEEN ABSOLUTE REFRENCE AND RELATIVE REFRENCE IN FORMULA 

ANS- There are two types of cell references: relative and absolute. Relative 

and absolute references behave differently when copied and filled to other 

cells. Relative references change when a formula is copied to another cell. 

Absolute references, on the other hand, remain constant no matter where 

they are copied. 

Absolute references 
There may be times when you do not want a cell reference to change when 
filling cells. Unlike relative references, absolute references do not change 
when copied or filled. You can use an absolute reference to keep a row 

and/or column constant. 



An absolute reference is designated in a formula by the addition of a dollar 
sign ($) before the column and row. If it precedes the column or row (but 
not both), it's known as a mixed reference. 

Relative references 
By default, all cell references are relative references. When copied across 
multiple cells, they change based on the relative position of rows and 
columns. For example, if you copy the formula =A1+B1 from row 1 to row 
2, the formula will become =A2+B2. Relative references are especially 
convenient whenever you need to repeat the same calculation across 

multiple rows or columns. 

-)CELL ADDRESS- A cell reference or cell address is a combination of a column 

letter and a row number that identifies a cell on a worksheet. For example, A1 

refers to the cell at the intersection of column A and row 1; B2 refers to the second cell 

in column B, and so on. 

QUE-14- WHAT TOOLS ARE AVAILABLE TO CUSTOMIZE OUR POWERPOINT 

PRESENTATION. 

ANS-  Best Presentation Tools for Beautiful Presentations 

 Tool #1: Templates and Themes 

 Tool #2: Slide Layouts 

 Tool #3: Fonts 

 Tool #4: Color Themes 

 Tool #5: Icons 

 Tool #6: Shapes 

 Tool #7: Stock Photos 

 Tool #8: Charts and Graphs 

 Tool #9: Maps 

 Tool #10: Tables 

https://visme.co/blog/best-presentation-tools/#templates-and-themes
https://visme.co/blog/best-presentation-tools/#slide-layouts
https://visme.co/blog/best-presentation-tools/#fonts
https://visme.co/blog/best-presentation-tools/#color-themes
https://visme.co/blog/best-presentation-tools/#icons
https://visme.co/blog/best-presentation-tools/#shapes
https://visme.co/blog/best-presentation-tools/#stock-photos
https://visme.co/blog/best-presentation-tools/#charts-and-graphs
https://visme.co/blog/best-presentation-tools/#maps
https://visme.co/blog/best-presentation-tools/#tables


 Tool #11: Flowcharts 

 Tool #12: Icon Charts 

 Tool #13: Radials 

 Tool #14: Progress Bars 

 Tool #15: Animation 

 Tool #16: Transitions 

 Tool #17: Interactivity 

 Tool #18: Audio and Video 

PART-2- 

QUE- 16- DIFFERENCE BETWEEN MACHINE LANGUAGE AND HIGH LEVEL 

LANGUAGE 

ANS-  We will now understand the differences between High-Level and Low-Level 
programming languages − 

High-Level Language Low-level language 

It can be considered as a programmer-
friendly language. 

It is considered as a machine-friendly 
language. 

It requires a compiler/interpreter to be 
translated into machine code. 

It requires an assembler that would 
translate instructions. 

It can be ported from one location to 
another. 

It is not portable. 

It is easy to understand. It is difficult to understand. 

It is easy to debug. It is difficult to debug. 

It is less memory efficient, i.e., it consumes 
more memory in comparison to low-level 
languages. 

It consumes less memory. 

QUE- 17 – DISCUSS ABOUT DIFFERENT DATA TYPES OF C LANGUAGE – 

ANS-  

https://visme.co/blog/best-presentation-tools/#flowcharts
https://visme.co/blog/best-presentation-tools/#icon-charts
https://visme.co/blog/best-presentation-tools/#radials
https://visme.co/blog/best-presentation-tools/#progress-bars
https://visme.co/blog/best-presentation-tools/#animation
https://visme.co/blog/best-presentation-tools/#transitions
https://visme.co/blog/best-presentation-tools/#interactivity
https://visme.co/blog/best-presentation-tools/#audio-and-video


Types of Data Types in C 

Here are the five major categories into which data types are divided in C language: 

Data Type Example of Data Type 

Basic Data Type Floating-point, integer, double, character. 

Derived Data Type Union, structure, array, etc. 

Enumerated Data Type  Enums 

Void Data Type Empty Value 

Bool Type True or False 

The basic data types are also known as the primary data types in C programming. 

Primary Data Types in C 

Here are the five primitive or primary data types that one can find in C programming language: 

1. Integer – We use these for storing various whole numbers, such as 5, 8, 67, 2390, etc. 

2. Character – It refers to all ASCII character sets as well as the single alphabets, such as ‘x’, ‘Y’, 

etc. 

3. Double – These include all large types of numeric values that do not come under either floating-

point data type or integer data type. Visit Double Data Type in C to know more. 

4. Floating-point – These refer to all the real number values or decimal points, such as 40.1, 

820.673, 5.9, etc. 

5. Void – This term refers to no values at all. We mostly use this data type when defining the 

functions in a program. 

Various keywords are used in a program for specifying the data types mentioned above. Here are 
the keywords that we use: 

Keyword Used Data Type 

int Integer 

https://byjus.com/gate/basic-data-types-in-c/
https://byjus.com/gate/derived-data-types-in-c/
https://byjus.com/gate/enumerated-data-type-in-c/
https://byjus.com/gate/double-data-type-in-c/


float Floating-point 

void Void 

char Character 

double Double 

The size of every data type gets defined in bytes/ bits. Also, these data types are capable of holding 
a very wide range of values. 

Different Data Type Values 

The size of any given data type in a program depends a lot on the type of processor, as well as the 
compiler. In simpler words, the size of the data type depends entirely on the computer on which we 
run C language along with the version of the C program compiler that we installed in the computer. 

The int data type can be 4 bytes/ 2 bytes. 

Remembering the size of the int data type is very easy. The given size is generally equal to the 
length of the word of the program’s execution environment. In other words, int will be 2 bytes or 16 
bits in the case of an environment that is 16-bit. However, int will be 4 bytes or 32 bits in case of an 
environment that is 32-bit. 

The char data type is 1 byte. 

The size of the char data type is basically 8 bits or 1 byte. No variation would occur with different 
compilers and interpreters. It means that the type of compiler or processor used will have no effect 

on its size whatsoever. 

The double data type is 8 bytes. 

The size of the double data type is basically 64 bits or 8 bytes. It is capable of storing values that are 
comparatively double the size of the bytes that the float data type can store. This is the reason why it 
is known as the double. 

When looking at the 64 bits in total, the program has 1 bit for the sake of sign representation, the 
exponent uses 11 bits, and it uses the remaining 52 bits for the mantissa. 

This data type is capable of holding about 15-17 digits, both after and before the decimal of the data 
type. 

The float data type is 4 bytes. 

The size of the float data type is basically 32 bits or 4 bytes. The float data type is single-precision in 
nature, and we use it for holding the decimal values. It helps in the storage of various large values, 



but the float is comparatively faster than double. It is because double works with comparatively much 
larger data values. Thus, it is slower comparatively. 

The void data type is 0 bytes. 

Since the void data type has no meaning, it has no size at all. 

There is a range of values that come under all of these data types. But before we look into that, let 
us take a look at the modifiers that are used in the data types. 

Data Type Modifiers in C Programming Language 

There are basically four types of modifiers for all data types used in C language. We use these along 

with all the basic data types for categorising them further. 

For instance, if we say that there is a chocolate bar on the table, the person we are speaking to will 
know that a chocolate bar is present on the table. But if we get more specific and say that there is a 
dark chocolate bar on the table or a milk chocolate bar on the table, it will become much more clear 
and specific, to the person who is listening. 

In a very similar manner, the modifiers in C language help in making the primary or primitive data 
types much more specific. 

Here are a few modifiers: 

 short 

 long 

 unsigned 

 signed 

Just like the names suggest here, we use the unsigned and signed modifiers for presenting the 
unsigned (only +) and signed (- and +) values in any given data type. Also, the short and long 
modifiers cause an effect on the value range of any given data type. 

For instance, the long int, short int, unsigned int, signed int, etc., are all very valid data types in the C 
programming language. 

Now, if we combine all the modifiers mentioned above with the five primitive or primary data types, 

then it will result in the formation of the following data types: 

QUE- 19  

SYNTAX OF FOLLOWING  

ANS- 1- IF –ELSE STATEMENT –  



Syntax 

if (condition) { 

  // block of code to be executed if the condition is true 

} 

Syntax 

if (condition1) { 

  // block of code to be executed if condition1 is true 

} else if (condition2) { 

  // block of code to be executed if the condition1 is false and 

condition2 is true 

} else { 

  // block of code to be executed if the condition1 is false and 

condition2 is false 

} 

The else Statement 

Use the else statement to specify a block of code to be executed if the condition 

is false. 

Syntax 

if (condition) { 

  // block of code to be executed if the condition is true 

} else { 

  // block of code to be executed if the condition is false 

} 

B- FOR LOOP SYNTAX-  

for loop in C 

The for loop in C language is used to iterate the statements or a part of the program 

several times. It is frequently used to traverse the data structures like the array and 

linked list. 



Syntax of for loop in C 

The syntax of for loop in c language is given below: 

1. for(Expression 1; Expression 2; Expression 3){   

2. //code to be executed   

3. }   

 

C- WHILE LOOP- 

while loop in C 

While loop is also known as a pre-tested loop. In general, a while loop allows a part of 

the code to be executed multiple times depending upon a given boolean condition. It 

can be viewed as a repeating if statement. The while loop is mostly used in the case 

where the number of iterations is not known in advance. 

Syntax of while loop in C language 

The syntax of while loop in c language is given below: 

1. while(condition){   

2. //code to be executed   

3. }   

 

D- DO WHILE LOOP- 

do while loop in C 

The do while loop is a post tested loop. Using the do-while loop, we can repeat the 

execution of several parts of the statements. The do-while loop is mainly used in the 

case where we need to execute the loop at least once. The do-while loop is mostly used 

in menu-driven programs where the termination condition depends upon the end user. 

do while loop syntax 

The syntax of the C language do-while loop is given below: 

1. do{   



2. //code to be executed   

3. }while(condition);   
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