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Q1: What are the four fundamental parts of computer? Explain it with the help of 
diagram. 

Ans: A four fundamental parts of computer are the central processing unit or CPU, The primary 
memory,input units and output units. 

 

 

    

 

                                               
 
 

                                       
 

Q2: Discuss about the classification of computers based on size and capacity. 
Ans: The classification of computers are 1.super computers 2.mainframe computers 
3.mini computers 4.micro computers . 
 
1. Super computer: > super computers are the most powerful and physically the largest by 

sized. 
>The fastest super computers can perform over one trillion calculation in a second . 
Example: JAGURE. 
 
2. Mainframe computers: >Mainframe computers are very large often feeling on entire room. 

>Mainframe are capable of supporting hundreds to thousands of users simultaneously. 
 Example: IBM mainframe Z13 

 
3.MINI computer: >Mini computers are much smaller then mainframes . 

> They are typically larger, more powerful and more expensive then desktop computers. 
Example: Apple ipod. 

 
4.Micro computer: > A micro computer is a small computer system designed to be used 

by me personal at a time . 
Example: Laptops 

 
Q3: What is the meaning of computer generation? How many Computer Generations are 

defined? What technologies were/are used?  

 

Ans: The meaning of generation in computer terminology is a change in technology a computer 

is/was being used. Initially, the generation term was used to distinguish between varying 

hardware technologies. Nowadays, generation includes both hardware and software, which 

together make up and entire computer system. 

>The evolution of computer technology is often divided into five generation. 
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1. First generation. 2. Second generation. 3. Third generation. 4. Fourth generation. 5. Fifth 

generation. 

>Technology are used that  > Artificial intelligence(AI) and Machine learning…. > Robotic process 

Automation (RPA). … > Edge computing … > Quantum computing. … > Virtual reality and 

Augmented reality. …  > Blockchain. …> Internet of things (IoT). … > 5G. 

Q4: Differentiate between Volatile & Non- Volatile memories. 

Ans: Volatile memory: volatile memory is a computer storage that only maintains its data while 
the device is powered. Example: RAM is volatile. When we are working on a document, it is 
kept in RAM, and if the computer loses power, your work will be lost. 

Non-volatile memory: Non-volatile memory is a type of computer memory that has the 
capability to hold saved data even if the power is turned off. Example: Read-only memory 
(ROM), Hard disk, floppy disk, etc. 

 

Q5: Distinguish among system software, application software and open source 

software on the basis of their features. 

 

Ans: System software: > It is a type of software that is designed to run a computers hardware 

and application programs.  

>Software like operating system, compillers, editors and drives and etc, come under this 

category. 

>A computer cannot funetion without the presence of system software. 

                                            If we think of the computer system as a layered model, the system 

software is the interface between the hardware and user application.  

Application software: > It is software created for a specific purpose, used by end users. It can 

be called an application or simply an app. 

Example: Word processor, accounting application, a web browser, an email eilent, media 

player etc. 

Open source software: >It is a type of computer software in which source  code is released 

under a licence  in which the copyright holder grants users rights to study, change and 

distribute the software                                                       

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it 

with file name “yourself”. Describe all steps involved in it.  

                     

      1st Step                  2nd Step                       3rd Step 

                     

     4th Step                           5th Step                               6th Step 

 

>Create and Save Document: 



                           > Click the Microsoft Office button/file tab 

                          >Select New. The new Document dialog box appears. 

                          >Select blank document. It will be highlighted by default. 

                          >A new blank document appears in the Word windo. 

                              >Now you can create document by inserting text. 

                          >Finally save document. 

 

 
 

Q6 b) Write steps regarding followings 
 To change the font style
 To change the font size
 To change the font color
 To highlight (in yellow) the line that reads “need to get IMS’s address”.
 

Ans: To change the font size: Using increase font size and decrease font size comment. 

 Select the text you want to modify.  
 Click on increase/decrease font size comments in the font group in the home tab. 
 Then font size will change (increase/decrease) in the document. 
>To change the font style: Select the text you want to modify. 

 Click on font style box on the home tab. The font style drop down menu appears. 
 Move your cursor over the various font style. 
 Left click the font style you want to use. 
 Then font style will change in the document. 

>To change the font color:  
  Select the text you want to modify. 
 Click on font color box on the home tab. The font color menu appears. 
 Move your cursor over the various font color. 
 Left click the font color your want to use. 
 Then font color will change in the document. 

 
>To highlight (in yellow) the line that reads “need to get IMS’s address:  

 Select the text 
 Click on the text highlight color in the font group on the home tab. 
 Various colors will appears. 
 Move your cursor over the various colors. 
 Click on color you want to use. 
 Then text  highlight color will change in the document. 
 

Q7. Create a file in MS-Word for the following document and save it with file name 

‘ms_word’. ‘Describe all steps involved in it. 

 

 



 
             MS WORD 

 

 

1.Creating a New Document 

Each time when you open Word, a new blank document appears; however, you will also need to 
know how to create new documents while an existing document is open. In this section, you will 
learn how to create new documents. 
To create a new blank document: 

 Click the Microsoft Office button. 

 Select New. The New Document dialog box appears. 

 Select Blank document under the Blank and recent section. It will be highlighted 

by default. 

 Click Create. A new blank document appears in the Word window. 

2 Editing 

     
 

 
 

The Type equation here.Editing section of the toolbar allows you to find, replace and select items. 
The select option gives you the ability to select all, select objects or select text 
with similar formatting. This last option gives you the ability to quickly change 
everything in your document with one style to another style without having to 

manually find all of that text and change each area separately. 

3. Saving Documents 

In this section, you will learn how to use the Save and Save As commands, how to save as a 
Word 97-2003 compatible document, and how to save as a PDF. 
To use the Save As command: 

 Click the Microsoft Office button. 

 Select Save As Word Document. The Save As dialog box appears. 



 Select the location where you want to save the document using the drop-down 

menu. 

 Enter a name for the document. 

 Click the Save button. 

4. Print Documents 
To print your MS Word document: 
Click ►File ►Print from the Menu Bar and a Print window will pop up on the 

screen. Click ►OK for your document to start printing. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Q8. Create a file in MS-word for the following document and save it with file name 

‘equations’. Describe all steps involved in it. 
 



 8. ANS. “Equations” 

 

 

 

 

𝑋2  +  𝑌5 = 30 

𝑍3  + 𝑄4  = 50 

𝐴2  + 𝐵8  =  𝑋2  + 𝑌8 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

 

 

 

Q9. Create a file in MS-word that convert existing highlight text to table as shown 

below and save it as file name ‘text_to_table’. Describe all steps involved in it. 

 

ANS. 

Select the text you want to convert  Select the Insert tab  

Click on Table command. A dialog box appears  Click on Convert Text to Table a new dialog box 
appears   

here set number of columns.   Click on OK  Finally Selected text convert in a 

table 

                                                           “TEXT TO TABLE’” 

 
Q10. Create a file in MS-Word to insert a table in the document. Describe all steps 

involved in it. 

  Ans :    

 To insert a blank table:  

 Place your insertion point in the document where you want to insert table   

 Select the Insert tab.   

 Click the Table command.   

 Drag your mouse over the diagram squares to select the number of columns and 

rows in the table.  

 Left-click your mouse, and the table appears in the document.   

 Enter text into the table. 

 



 

 

 

 

 

 

 Q11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

ans 

          
 
 
 

Q12. Calculate the following things of a range (C2:C11) of data in the worksheet created 
in question no 10. 

 the sum of the marks using AutoSum in a range of cells (C2:C11)

 average of the marks in a range of cells (C2:C11)

 highest marks in a range of cells (C2:C11)
 minimum marks in a range of cells (C2:C11)

ans. 

 
Q13 a) Describe various steps involved in the following 

 To modify column width of a worksheet
 To modify the row height of a worksheet
 To delete rows and columns of a 

worksheet


Ans: To modify column width of a worksheet: To modify column width:  Position the cursor over the 

column line in the column heading, and a double arrow will appear.  Left-click the mouse, then drag the 

cursor to the right to increase the column width or to the left to decrease the column width.  Release the 
mouse button 
 
To modify the row height of a worksheet: To modify the row height:  Position the cursor over the row line 



you want to modify, and a double arrow will appear.  Left-click the mouse, then drag the cursor upward 

to decrease the row height or downward to increase the row height.  Release the mouse button. 


 To delete rows and columns:  Select the row or 

column you’d like to delete.  Click the Delete 
command in the Cells group on the Home tab. 
 

  Q13 b) Describe following terms in 
the worksheet

 Absolute reference and relative reference in formula 

  

 Absolute reference and relative reference  Relative reference: Cell references in formula 

automatically adjust to new locations when the formula is pasted into different cells. This is called 

a relative reference.  Sometimes when you copy and paste a formula, you don't want one or more 

cell references to change.  An absolute reference solves this problem.  Absolute Reference; cell 

references in a formula always refer to the same cell or cell range . If a formula is copied to a 

different location, the absolute reference remains the same. 

 

 

o Cell address 

 

Cell address  Each rectangle in the worksheet is called a cell. Each cell has a name, or a cell 

address, based on the column and row where it is located. In below diagram name of selected 

cell is C3 because column head is C and row head is 3. 

 

 

 
Q14. a) What tools are available to customize our PowerPoint presentation? 
 
• Click on start • Select MS office PowerPoint option • Double click on it 

 

Q14 b) Write the steps for the following action for creation of power point presentation 

 Open a Blank presentation
 Save the presentation as Lab1.pptx

         Add a Title to the first slide: the name of your college
 Type your first name and last name in the Subtitle section       
 Add a New Slide which has a Title and Content

Ans: 

 Open a Blank presentation: 
• Click on start • Select MS office PowerPoint option • Double click on it 
 

 
 
 
 
 

 Save the presentation as Lab1.pptx: 













 Add a Title to the first slide: the name of your college
 Type your first name and last name in the Subtitle section       
 Add a New Slide which has a Title and Content



 

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates 
your skill to use the tools of PowerPoint. It should include the following things 

 Title slide &bullet list
 Inserting Excel Sheet
 Clip art and Text
 Slide show effects

Ans: 

 Title slide &bullet list:

Microsoft PowerPoint is an interesting and useful program that is widely used to prepare slideshows for 

Public Seminars and Presentations. From an Artistic Perspective, individuals cannot easily understand 

theories alone for hours but can obtain much more within minutes or even seconds, with the use of Visual 

Presentations backing Theory. PowerPoint can solve the Problem in terms of communication technology 

for everyone. There are complicated and sophisticated methods for such; however the simplest and most 

commonly used method which has being used almost everywhere and anywhere in the world during Publi

Presentations & Seminars was the use of PowerPoint applications for seminars. 1. Open Microsoft 

PowerPoint. 2. Go to File at the top of the screen and click New.

 Inserting Excel Sheet:
The great thing about the Microsoft Office Suite is the fluid interaction of each application type. By 
embedding the Excel document into your presentation or document you can use it to make a point more 
effectively with numbers or even graphs. 1. In PowerPoint, select the Insert tab & Click the Insert tab. 2. 
Click the Object command in the Text group. ... 3. A dialog box will appear. ... 4. Locate and select the 
desired Excel file, then click Insert. ...
It is shown in the following slide view 
 

 Clip art and Text:
 Select Insert > Picture > From Online. In the Online Pictures dialog box, type words describing the kind of 

picture you want (such as roses), and then press Enter. and then select Clipart under the Type category. Select 
the image you want to insert, then click the Insert button. 

 

 Slide show effects:  

1. Select the slide you want to add a transition to. 

2. Select the Transitions tab and choose a transition. ... 

3. Select Effect Options to choose the direction and nature of the transition. ... 

4. Select Preview to see what the transition looks like. 







 
Part -2 

 
 

Q16. What is the difference between Machine Language and High Level Language?  

Ans: 

             Machine Language               High Level Language 

Machine language, or machine code, consists of 
binary code and is the only language that is 
directly understood by the computer. ... Both 
machine code and assembly languages are 

hardware specific 

A high-level language is a programming language 
that uses English and mathematical symbols in its 
instructions. 

 
 

Q17. Discuss about different data types of C programming Language. 

Ans: 

           Data types               Bytes                 Range 
              signed char                   1             -128 to 127 

              unsigned char                   1               0 to 255 

               float                   4           1.2E-38 to 3.4E+38 

               double                   8            2.3E-308 to 1.7E+308 

 
 
 
 
 
 
 

 

Q18. Find the output of the following expressions 
 

a)   X=20/5*2+30-5 b) Y=30 – (40/10+6) +10 c) Z= 40*2/10-2+10 
 

Ans: 
 

a) X=20/5*2+30-5 
X=4*2+30-5 
=8+30-5 

             =38-5 
            =33 
 

b) Y=30 – (40/10+6) +1 
Y=30-(4+6)+1 
=30-10+1 
=30-11 
=41 

 
 

c) Z= 40*2/10-2+10 
Z=40*5-2+10 



=200-2+10 
=200-12 
=188 

  

Q19. Describe the syntax of the following statements 
 

a)    If – else statement   b) for loop c) while loop d) do-while 

loop  

a)   If – else statement :  If condition returns true then the statements inside the body of “if” are executed 
and the statements inside body of “else” are skipped. If condition returns false then the statements inside 
the body of “if” are skipped and the statements in “else” are executed. 
 
 
b)  for loop: The initialization statement describes the starting point of the loop, where the loop variable is 

initialized with a starting value. ... The test expression is the condition until when the loop is repeated. 
Update statement is usually the number by which the loop variable is incremented. 
 
 
c)while loop: do { statements } while (expression); As we saw in a while loop, the body is executed if 
and only if the condition is true. In some cases, we have to execute a body of the loop at least once even 
if the condition is false. ... After the body is executed, then it checks the condition. 
 
 
 
d)do-while loop: In most computer programming languages, a do while loop is a control flow statement 

that executes a block of code at least once, and then either repeatedly executes the block, or stops 
executing it, depending on a given boolean condition at the end of the block.  
 

 
 
 
 
 
 

 

 

 

 

 

Q20. Find the output of the following program segments 

 

a) b) c) 



#include 
<stdio.h> int 
main() 
{ 
int i; 
for (i=1; i<2; i++) 
{ 

printf( "IMS 
Ghaziabad\n"); 

} 
} 

#include 
<stdio.h> int 
main() 
{ 

int i = 1; 
while ( i <= 2 
) 
{ 
printf( "IMS 
Ghaziabad\n"); i = i + 1; 

} 

} 

#include 
<stdio.h> void 
main() 
{ 

int a = 10, 
b=100; if( a > b 
) 
printf( "Largest number is 10%d\n”, 
a); else 

printf( "Largest number is100 
%d\n”, b); 

} 
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