
 

                    CCA-101: Fundamentals of IT & Programming  
                                    Assignment -1   

 

 Q1: What are the four fundamental parts of computer? Explain it with the help 

of diagram.    

Ans.   Central Processor Unit (CPU) 

     Memory (RAM) 

     Input (keyboard, mouse, etc) 

     Output (monitor, printer, etc) 

 

  
 Q2: Discuss about the classification of computers based on size and capacity.  

Ans. Based on size and capacity, computers are classified as follows: 
       Super Computers  
Supercomputers are the most powerful and physically the largest by size. 

These are systems designed to process huge amounts of data and the fastest supercomputers can 

perform over one trillion calculations in a second. Supercomputers have thousands of processors.  

      Mainframe Computer 

Mainframe computers are very large often filling an entire room and 

can process thousands of millions of instructions per second. In a mainframe environment,users 

connect to the mainframe through the many terminals wired to the mainframe.  

Mini Computers 

Minicomputers are much smaller than mainframes .These computers are 

also less expensive. Sometimes referred to as Midrange Server or Midrange Computer, theymare 

typically larger, more powerful and more expensive than desktop computers.  

Micro Computers  

Microcomputers are the most frequently used type of computer. Also, known as Personal 

Computer (PC), a microcomputer is a small computer system designed to be used by one person 

at a time.  

Q3: What is the meaning of computer generation? How many Computer 
Generations are defined? What technologies were/are used?  



 
Ans. Generation in computer terminology is a change in technology   

       a computer is/was being used. Initially, the generation term was used to   
       distinguish between varying hardware technologies.  
       
  Five Generations of Computers: 

 First Generation 

 Second Generation 

 Third Generation 

 Fourth Generation 

 Fifth Generation  

  
 Technologies that are used :- 
            First Generation  Vacuum Tubes (1940-1956):  

 Second Generation  Transistors (1956-1963)  

 Third Generation     Integrated Circuits (1964-1971)  

 Fourth Generation   Microprocessors (1971-Present):  
 Fifth Generation      Artificial Intelligence (Present and Beyond) 

 
 

 Q4: Differentiate between Volatile & Non- Volatile memories  
 
Ans.      
Volatile Memory  Non volatile Memory  

1. Data is present till power supply 
is present 

1. Data remains even after power 
supply is not present. 

2. Volatile memory data is not 
permanent. 

2. Non-volatile memory data is 
permanent. 

3. Data Transfer is easy in Volatile 
Memory. 

3. Data Transfer is difficult in Non-
Volatile Memory. 

4. Volatile memory less storage 
capacity. 

4. Non-Volatile memory like HDD 
has very high storage capacity.  

5. Volatile memory such as RAM 
is high impact on system's 
performance. 

5. Non-volatile memory has no 
impact on system's 
performance.  

 
 

 Q5: Distinguish among system software, application software and open source 
software on the basis of their features.  
Ans.  
       System Software: It is a type of software that is designed to run a computer's hardware and 

application programs. Software like operating systems, compilers, editors and drivers etc., 

comemunder this category. A computer cannot function without the presence of these. If we 

think of the computer system as a layered model, the system software is the interface between 

the hardware and user applications.  

 

Application software: It is software created for a specific purpose, used by end users. It can 

becalled an application or simply an app. Examples: word processor, accounting application,a 

web browser, an email client, media player etc  



 

Open-source software (OSS):- 

 It is a type of computer software in which source code is released under a license in which the 

copyright holder grants users the rights to study, change, and distribute the software to anyone 

and for any purpose. The Linux operating system(OS) is the 

best-known examples of open source software technology  

 

 

 Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it 
with file name “yourself”. Describe all steps involved in it.  

 

Ans.  Step 1 

          click on menu bar of window and open MS-Word 

          Step 2 

 Write paragraph about yourself  

 Step 3 

 click on office button 

 Step 4 

 save the document with name yourself 

  

 b) Write steps regarding followings  
  To change the font style  

1. Select the text you want to modify. 
2. Select the Home tab and locate the Font group. 
3. Click the drop-down arrow next to font style box. 
4. Font style menu appears. 
5. With a left click select the desired font style. 

  

  To change the font size  
a. Select the text or cells with text you want to change. To select all text in 

a Word document, press Ctrl + A. 
b. On the Home tab, click the font size in the Font Size box. You can also 

type in  any size you want, within the following limits: 

  

 To change the font color  
1. Select the text you want to modify. 
2. Click the Font Color drop-down arrow on the Home tab. The Font Color menu 

appears. 
3. Move the mouse pointer over the various font colors. A live preview of   

the color will appear in the document.  

           To highlight (in yellow) the line that reads “need to get IMS’s address”.  
 

1. Click the Home tab. 
2. In the Font group, click the Text Highlight button. 
3. Word is now in Highlighting mode.  
4. Drag the mouse over the text you want to highlight.    

 Q7. Create a file in MS-Word for the following document and save it with file 
name ‘ms_word’. Describe all steps involved in it.    



Ans.  
  Creating a New Blank Document 

1) Choose Office button → New. The 
New Document dialog  box appears 

2) In the upper-left corner of the large “Create a 
new Word  document” panel, click 
“Blank document”  

3) .At the bottom of the New Document dialog box, 
click Create. 
 

 
 Edit a document. 

1. Open the file that you want to edit. 
2. Choose from the following tasks: Task. Steps. Edit text. Click   

          the. Edit. tab. Select the text that you want to edit.  

          Using the tools in  the edit toolbar, change the required formatting         

          including font style, paragraph alignment, list formatting, and           

          indentation options.  Insert images 

 

Save a document and print 

Click FILE > Save, pick or browse to a folder, type a name for 
your document in the File name box, and click Save. Save your 
work as you go - hit Ctrl+S often. To print, click the FILE tab, and 
then click Print.  

  
 Q8. Create a file in MS-word for the following document and save it with file 

name ‘equations’. Describe all steps involved in it. 

Ans.  

1. On the File menu, click Save As. 
2. In the File name box, enter a new name for the file.  
3. the Save as type list, and then click the file format that you want 

the file saved in.  

4. Click Save. Type file name equation . 
 

Q9. Create a file in MS-word that convert existing highlight text to table as 
shown below and save it as file name ‘text_to_table’. Describe all steps involved 
in it.  
 
 
 
Ans. 

a. Select the text that you want to convert, and then click Insert    



Table > Convert Text to Table.  
b. In the Convert Text to Table box, choose the options you want.     
c. Under Table size, make sure the numbers match the numbers of    

columns and rows you want. 
d. In the Fixed column width box, type or select a value.  

 

Q10. Create a file in MS-Word to insert a table in the document. Describe all 
steps involved in it.  
Ans.     

1. For a basic table, click Insert > Table and move the cursor over the   
grid until you highlight the number of columns and rows you want. 

2. For a larger table, or to customize a table,    
3. select Insert > Table > Insert Table.  
4. If you already have text separated by tabs, you can quickly convert it to  

a table.  

 
Q11. Create a following worksheet in MS-excel and save it with name ‘book1’.  
 
Ans. 

1) Right-click the worksheet name tab. 
2) Click select Move or Copy. 
3) Click on the Move selected sheets to Book drop-down menu. 

Select   (new book). 
4) Click OK. Your new workbook opens with your 

moved worksheet. ... 
5) Click File > Save with name book 1. 

 
Q12. Calculate the following things of a range (C2:C11) of data in the worksheet 
created in question no 10.  
 
Ans. 

1) The sum of the marks using AutoSum in a range of cells (C2:C11) 
=654 

2) Average of the marks in a range of cells (C2:C11) 
=65.4 

3) Highest marks in a range of cells (C2:C11) 
=90 

4) Minimum marks in a range of cells (C2:C11) 
=40 

Q13 a) Describe various steps involved in the following  
 

 
 
Ans.    
       To modify column width of a worksheet  



1.  Select the columns you want to modify. 

2. Click the Format command on the Home tab. The format drop-down menu   

      appears. 

3. Select Column Width. Increasing the column width. 

4. The Column Width dialog box appears. Enter a specific measurement. ... 

5. Click OK. 

  

        To modify the row height of a worksheet  
1. Select the rows you want to modify.  
2. Click the Format command on the Home tab.  
3. The format drop-down menu appears.  
4. Select Row Height  

 

To delete rows and columns of a worksheet  
1. Select the cells, rows, or columns that you want to delete. 

2. Right-click, and then select the appropriate delete option, for  
example, Delete Cells & Shift Up, Delete Cells & Shift Left, Delete Rows, 
or Delete Columns. 

 Q13 b) Describe following terms in the worksheet  
  
   Ans. 
        Absolute reference and relative reference in formula  
 There are two types of cell references: relative and absolute. Relative and absolute 
references behave differently when copied and filled to other cells. Relative 
references change when a formula is copied to another cell. Absolute references, on 
the other hand, remain constant, no matter where they are copied  
  
B5+$C$4 
B5  = relative refrence 
$C$4 =  absolute refrence 

Cell address  
A cell reference, or cell address, is an alphanumeric value used to 
identify a specific cell in a spreadsheet. Each cell address contains 'one 
or more letters' followed by a number. The letter or letters identify the 
column and the number represents the row.  

 

 Q14. a) What tools are available to customize our PowerPoint presentation? 
 

Ans. 

1. In Slide Master View. 
2. Click on Slide Size. 
3. Select from one of the two options. 
4. For more choices, click Custom. 
5. Select one of the options. 

Q14 b) Write the steps for the following action for creation of power point 
presentation  



  
Ans.   
            Open a Blank presentation  

1. Select the File tab to go to Backstage view. 

2. Select New on the left side of the window, then click Blank Presentation. 

3. A new presentation will appear. 

 

                Save the presentation as Lab1.pptx  
1.  Step 1 − Click on the File tab to launch the Backstage view and   

select Save. 

2. Step 2 − In the Save As dialog, type in the file name Lab1 and click    

"Save". 

3. Step 3 − The default file format is . pptx. If you want to save the file with a  

      different name, choose one of the file types from the "Save as type"    

      dropdown list. 

 

 Add a Title to the first slide: the name of your college 
1. Select the slide whose layout you will change so that it can have  

    a title. 

2. Click Home > Layout. 

3. Select Title Slide for a standalone title page or select Title and  
    Content for a slide that contains a title and a full slide text box. ... 

4. Select the Click to add title text box. 

   

 Type your first name and last name in the Subtitle section  
1. Click and type the title of your presentation in the "Click  

   to add title" area. 

2. Click and type a subtitle in the "Click to add subtitle" area. 

  

    Add a New Slide which has a Title and Content  
1. To insert a new slide that contains a “Title and 

Content” slide layout, click the “Home” tab in the Ribbon. 

2. Then click the “New Slide” button in the “Slides” button group. 
To insert a new slide and choose the slide layout, click the 
drop-down part of this button  
 

  
 
 
 
 
Q15. Write steps for creation of a set of PowerPoint slides that demonstrates 
your skill to use the tools of PowerPoint. It should include the following things. 
 



Ans.  
           Title slide &bullet list 

1. Start Microsoft PowerPoint. 

2. Open arbitrary existing PowerPoint presentation. 

3. Click the New Slide button on the Formatting toolbar. ... 

4. Click the Bulleted List layout, as shown in the above figure. ... 

5. Click the title placeholder (where it says: “Click to Add Title”). ... 

6. Type some text 

  

             Inserting Excel Sheet  
 To insert a new worksheet in front of an existing worksheet, select 
that worksheet and then, on the Home tab, in the Cells group, 
click Insert, and then click Insert Sheet.  

 
            Clip art and Text  

The clip art options appear in the task pane to the right of the 
document. Enter keywords in the Search for: field that are related to 
the image you want to insert.  
  

             Slide show effects  
1.   Open your presentation. 

2. On your Android tablet, tap the Transitions tab. ... 

3. Tap the down arrow to expand the Transition Effects. ... 

4. Choose a transition; for example, tap Morph to have one slide gradually 
turn into the next slide. 

5. Tap Effect Options to choose the direction of the transition. 

   
Part -2  
 
Q16. What is the difference between Machine Language and High Level 
Language?  
 
Ans.   
      
Machine Language  High Level Language  

1. It is a machine friendly language 1. It is not commonly used now-a-
days in programming. 

2. It is tough to understand 2. High level language is less 
memory efficient. 

3. It is complex to debug 
comparatively  

3. It is simple to debug. 
It is easy to understand. 

4. It is non-portable  4. It is simple to maintain. 

5. It is machine-dependent 5. It is portable. 

6. It needs assembler for translation. 6. It needs compiler or interpreter for 
translation 



7. It is not commonly used now-a-
days in programming.  

7. It is used widely for programming.  

 
Q17. Discuss about different data types of C programming Language. 
 
Ans.    Different data types of C programming language are as follow :-  

 

1. int – This data type is used to define an integer number (-…. -3,-2,-
1,0,1,2,3….). ... 

2. char – Used to define characters. A single character occupy 1 byte. 

3. float – Used to define floating point numbers (single precision). 
Occupies 4 bytes. 

4. double – Used for double precision floating point numbers(double 
precision) 

 

Q18. Find the output of the following expressions  
a) X=20/5*2+30-5 
         =  20/5*2+30-5 
 =  4*2+3-5 

= 8+3-5 
= 8+2 
= 10 

 b) Y=30 – (40/10+6) +10  
=  30-(40/10+6)+10 
=  30-(4+6)+10 
=  30-10+10 
= 30 

c) Z= 40*2/10-2+10  
= 40*2/10-2+10 
= 80/10-2+10 
= 8-2+10 
=8-8 
=0 

Q19. Describe the syntax of the following statements  
a) If – else statement 
    if (expression) 
{ 
Block of statements; 
} 
else 
{ 
Block of statements; 
}    
b) for loop 



     for( expression1; expression2; expression3) 
{ 
Single statement 
or 
Block of statements; 
}  
 c) while loop   
   while ( expression ) 
{ 
Single statement 
or 
Block of statements; 
}  
d) do-while loop  
  do 
{ 
Single statement 
or 
Block of statements; 
}while(expression);  
  
Q20. Find the output of the following program segments  
  

a)    
#include <stdio.h>  
int main()  
{  
int i;  
for (i=1; i<2; i++)  
{  
printf( "IMS Ghaziabad\n");  
}  
}  
  
OUTPUT  = 
IMS GAZIABAD 
 
b) 

#include <stdio.h>  
int main()  
{  
int i = 1;  
while ( i <= 2 )  
{  
printf( "IMS Ghaziabad\n");  
i = i + 1;  
}  
}   
 



OUT PUT = 
IMS Gaziabad 
IMS Gaziabad 
  
c) 

#include <stdio.h>  
void main()  
{  
int a = 10, b=100;  
if( a > b )  
printf( "Largest number is %d\n”, a);  
else  
printf( "Largest number is %d\n”, b);  
}   
 
OUT PUT = Largest number is 100 


