» Q1: What are the four fundamental parts of the computer? Explain it with the help of
diagram.

Ans:- The four fundamental parts of the computer are

1) Input devices 2) Processor (CPU) 3) Output Device 4) Backing Storage

Input devices 7 Processor 7 Output devices

Backing Storage

1) Input Device
» Computer systems use many devices for input purpose. Input devices include the mouse,
input pen, touch screen and microphone. Regardless of the type of device used, all are
components for interpretation and communication between people & computer
systems.
2) Processor (CPU)
> Itis the brain of the computer. Computer can not process without it.
3) Output devices
» Output device is used to show the result of the instructions. Example: Monitor, printer,
Headphones, etc.
4) Backing Storage
> Backing storageis the collection of storage units or devices together. The baking storage
unit stores the binary information in the form of bits.

Q2: Discuss about the classification of computers based on size and capacity.
Ans :- Based on size and capacity, computers are classified as follows:
e Super Computers ® Mainframe Computer ¢ Mini Computers ¢ Micro Computers

e Super Computers

These are systems designed to process huge amounts of data.

The fastest supercomputers can perform over one trillion calculations in a second
Supercomputers have thousands of processors.
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Because of their extraordinary speed, accuracy and processing power, supercomputers are
well suited for solving highly complex problems & huge amounts of calculations.



> Example: JAGUAR, ROADRUNNER etc
e Mainframe Computer
» Mainframe computers are very large often filling an entire room and can process
thousands of millions of instructions per second.
» Inamainframe environment, users connect to the mainframe through the many terminals
wired to the mainframe.
» Mainframes are capable of supporting hundreds to thousands of users simultaneously.
» Some of the functions performed by a mainframe include: flight scheduling, reservations
and ticketing for an airline etc
> Example: IBM mainframes 213, IBM System z9 mainframe
e Mini Computer
Minicomputers are much smaller than mainframes.
These computers are also less expensive.
Sometimes referred to as Midrange Server or Midrange Computer.
They are typically larger, more powerful and more expensive than desktop computers.
Midrange computers are usually used by small and medium-sized businesses as their
servers
» Users connect to the server through a network by using desktop computers.
> Example: Apple iPod, CDC 160A
e Micro Computers
» Microcomputers are the most frequently used type of computer.
» ltis also, known as Personal Computer (PC)
» A microcomputer is a small computer system designed to be used by one person at
atime.
» Example: Desktop computers, laptops
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Q3: What is the meaning of computer generation? How many Computer Generation are defined?
What technologies were/are used?

Ans:- Meaning of computer generation is the evolution of digital computing.
Four generation of computer are defined they are

e First Generation: Vacuum Tubes (1940-1956).
> First Generation Computer used Vacuum Tubes for circuitry and Magnetic drums for
memory
» It's relied on machine language
» Input was based on punched cards and paper tape, and output was deplayed on
printouts
e Second Generation: Transistors (1956-1963).
» Second Generation used Transistors
» It's used symbolic, or assembly language
» Punched cards for input and printouts for output
e Third Generation: Integrated Circuits (1964-1971).
» Second Generation used integrated circuit
> Keyboards and monitors start using for inputs and outputs
e Fourth Generation: Microprocessors (1971-Present).
» Fourth Generation start to use microprocessor



> It starts to use Graphical User Interface (GUIS), mouse and handheld devices
» Quantum computation and nanotechnology

Q4: Differentiate between Volatile & Non- Volatile memories.

Ans:-
Volatile Non- Volatile
» acomputer storage that only maintains its > atype of computer memory that has the
data while the device is powered capability to hold saved data even if the
power is turned off.
» Example: RAM (Random access memory) is » Example: Read-only memory (ROM), Hard
volatile. When we are working on a disk, floppy disk ,etc

document, it is kept in RAM, and if the
computer loses power, your work will be lost.

Q5: Distinguish among system software, application software and open source software on the basis
of their features.

Ans:-

e System software
> lItis atype of software that is designed to run a computer's hardware and
application programs.
»  Software like operating systems, compilers , editors and drivers etc., come under
this category.
» A computer cannot function without the presence of system software.
e Application software
» Itis software created for a specific purpose, used by end users. It can be called an
application or simply an app.
» Examples: Word processor, accounting application, a web browser, an email client,
media player etc
e Open source software
> lItis a type of computer software in which source code is released under a license in
which the copyright holder grants users rights to study, change and distribute the
software to anyone and for any purpose.

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with file name
“yourself”’. Describe all steps involved in it.

b) Write steps regarding followings

To change the font style

To change the font size

To change the font colour

To highlight (in yellow) the line that reads “need to get IMS’s address”
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Ans:- a) The steps involved are:

1) We click the Microsoft office button.

2) We select new. The new document dialog box appears.

3) We select blank document under the blank and recent section. It will be highlighted by
default.

4) We click create. A new blank documents appear in the word window.

5) To save the document, we click again the Microsoft office button.

6) We select save as word document. The save as dialog box appears.

7) We select the location where we want to save the document using the drop down
menu.

8) We enter the file name “yourself” for the document.

9) We click the save button.

b) Steps to change the font style:

1. we select the text we want to modify.

2. left click the drop-down arrow next to the font style box on the home tab. The font style
drop-down menu appears.

3. we move cursor over the various font styles. A live preview of the font will appear in the
document.

4. left click the font style we want to use. The font style will change in the document.

Steps to change the font style:

1. we select the text we want to modify.

2. left click the drop-down arrow next to the font style box on the home tab. The font style
drop-down menu appears.

3. we move cursor over the various font styles. A live preview of the font will appear in the
document.

4. left click the font style we want to use. The font style will change in the document.

Steps to change the font colour:

1. We select the text we want to modify.

2. Left click the drop-down arrows next to the font colour box on the home tab. The font
colour menu appears.

3. We move cursors on various font colours. A live preview of the colour will appear in the
document.

4. Left click the font colour we want to use. The font colour will change in the document.



Steps to highlight the line:

1. We select the line that reads “needs to get IMS’s address”

2. We click the highlight command and select yellow colour in the font group on the home
tab.

Q7. Create a file in MS-Word for the following document and save it with file name ‘ms_word’.
Describe all steps involved in it.

MS Word
MS word is a widely used commercial word processor developed by Microsoft.
MS word is a application software, which is capable of

e creating,

o editing,

® saving, and

e printing any type of document

Ans:- The steps involved are:
1. we click the Microsoft office button.
2. We select new. The new document dialog box appears.
3. We select blank document under the blank and recent section.it will be highlighted by default.
4. We click create. A new blank document appears in the word window.
5. We create the given documents from the question
6. We select the text “MS word” and change the font size by clicking on the font size box on the
home tab.

7. We select the text “MS word” to change the font the font color into red by clicking on the
font

color menu.

8. We select the text word processor and underline it by clicking the underline command in the
font group the home tab.

9. We select the text “MS word” to change the font style into italic by clicking italic command.
10. We select the text we want to format as a list and click on the bullets command on the home

tab.



11. We change the font color of the text “creating” and “saving” into blue and red resp. by
clicking

on the font color command, again we select the text “and” and click on strikethrough command.
12. We select the text “printing any type of document” and change the font style into bold by
clicking on the font style command.

13. We save the file name as “ms-word” by clicking the Microsoft office button and select save
as

14. We select the location where we want to save the document using drop-down menu
15. We click the save button.

Q8. Create a file in MS-word for the following document and save it with file name’equations’.
Describe all steps involved in it.

Equations
X5+Ys =30

Z3+Q* =50

A2+ B8 = X2+Y8

Ans:- The steps are:
1. We create the given documents in MS-word
2. We select the text where we want to format and click on the subscript and superscript
command on the home tab

3. We save the file name as “equations” by clicking the Microsoft office button and select save

as
4. we select the location where we want to save the document using the drop down menu

5. we click the save button



Q9. Create a file in MS-word that convert existing highlight text to table as shown below and save it as

file name ‘text_to_table’. Describe all steps involved in it.

Select the text you want to convert.

Select the Insert tab.

Click on Table command. A dialogue box appears.

Click on Convert Text to Table, a new dialogue box appears

Here set number of columns.

Click on OK Finally Selected text convert in a table

Select the text you want to convert. Select the Insert tab

Click on Table command. A dialogue box | Click on Convert Text to Table, a new dialogue

appears

Here set numbers of columns Click on OK Finally Selected text to convert in a

table

Ans:- To convert existing text to a table:

1.we select the existing highlight text that we want to convert.

2.We select the insert tab

3.We click the table command

4.We select convert text to table from the menu. A dialog box appears

5.We click ok. Then the text appears in a table

Q10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in it.

Ans:-



the steps are:

We place our insertion point in the document where we want our table to appear
we select the insert tab

we click the table command

we drag our mouse over the diagram squares to select the numbers of columns and
rows in the table.

left click our mouse and the table appears in the document.

6. we enter the text into the table
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Q11. Create a following worksheet in MS-excel and save it with name ‘book1’.
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Q12. Calculate the following things of a range (C2:C11) of data in the worksheet created in question

no 10
» the sum of the marks using AutoSum in a range of cells (C2:C11)
» average of the marks in a range of cells (C2:C11)
» highest marks in a range of cells (C2:C11)
» minimum marks in a range of cells (C2:C11)
Ans:-
No Name Marks Sum Average Maximum
1 nl 60 654 65.4 90
2 n2 70
3 n3 80
4 n4 90
5 n5 40
6 n6 50
7 n7 77
8 n8 44
9 n9 88
10 ni0 55

Q13 a) Describe various steps involved in the following

» To modify column width of a worksheet
» To modify the row height of a worksheet
» To delete rows and columns of a worksheet

b) Describe following terms in the worksheet

» Absolute reference and relative reference in formula
> Cell address

Ans:-(a)

» To modify column width of a worksheet:
l. Select a column or a range of columns.
Il. Select a Home tab and in the Cells group, select Format.
M. Click on Column width and type the width for column.
IV.  Select OK.
» To modify the row height of a worksheet.
I.  Select arow or arange of rows.
Il. Select a Home tab and in the Cells group, select Format.
Il Click on Row Height and type the height for row.
IV.  Select OK.
» To delete rows and columns of a worksheet.
I Select the cell you want to delete within the column or row.

Minimum
40

Il. Select Home tab. And in cells group click on Delete Sheet Column or Row.



OR

I Select the desire row or column.

(b)
» Absolute Reference:

An absolute reference in Excel means there is a fixed point of reference applied to a cell or a
formula. This is so the return value will always stay the same no matter where the cell or

formula moves to — within the same sheet or across different sheet.

This refers to a fixed point of reference is a constant, and involves the use of dollar sign $ in the

formula (i.e., everyone is to receive the same bonus payout, so the amount $1500 is constant in

this situation).

> Relative Reference:

It is the default cell reference in Excel. It is simply the combination of column name and row
number without any dollar ($) sigh. When you copy the formula from one cell to another the
relative cell address changes depending on the relative position of column and row. C1, D2, E4,
etc. are examples of relative cell references. Relative references are used when we want to

perform a similar operation on multiple cells and the formula must change according to the

relative address of column and row.

This refers to a relative point of reference, is constantly changing and dollar sign ($) is absent in

the formula (i.e., when each unit price and quantity are difference variables, there’s no constant

in the calculation).

> Cell Address:

A cell address is a combination of column letter and a row number that identifies a cell

on a worksheet.

For example, Al refers to the cell at the intersection of column A and row 1; B2 refers to

the second cell in column B, and so on.

When used in formula, cell references help Excel find the values the formula should

calculate. For instance,



e To pull the value of Al to another cell, you use this simple formula:
=Al

e Toadd up the values in cells A1 and A2, you use this one:
=A1+A2

Q14. a) What tools are available to customize our PowerPoint presentation?
b) Write the steps for the following action for creation of power point presentation

Open a Blank presentation

Save the presentation as Labl.pptx

Add a Title to the first slide: the name of your college
Type your first name and last name in the Subtitle section
Add a New Slide which has a Title and Content
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Ans:- (a)
Tools available to customize our PowerPoint presentation are

a) Perspector

b) Pivot Viewer

c) Autodesk 3DS Max

d) VisualBee PowerPoint Add-in
e) SmartArt

f) Animations and Transition

g) Wordle

h) CAcoo

i) Oomfo

j)  Clip champ

(b)

» Toopen blank presentation:
I Open PowerPoint presentation using ‘Run’ command (window key + R).
Il.  Select the ‘Blank Presentation’. It is opened
> Save the Presentation as Lab1.pptx.:
I.  Select the ‘File’ on Tab bar.
1. Click on ‘Save As’ option.
[[ ] Click on document/Desktop as your choice.
IV.  Type the name ‘Labl.pptx’.
V. Click the ‘Save’ button.
> Add a Title to the first slide: the name of your college.
I Left click on the ‘Click to Add Title’ section on the first slide.
Il.  Type the name of your college.
» Type your first name and last name in the subtitle section:
I Left click on the ‘Click to Add Subtitle’ section.
Il.  Type your first name and last name.
» Add a New slide which has a Title and content.
I.  Select the Home tab.
1. Click on the dropdown button of the ‘New Slide’ on toolbar.



Select the slide having ‘Title and Content’. It is added.

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to use the

tools of PowerPoint. It should include the following things

>
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Ans:-

>

Title slide &bullet list
Inserting Excel Sheet
Clip art and Text
Slide show effects

Title slide and bullet list:
l. Open PowerPoint Presentation.
1. Select the Home tab.

. Click at the dropdown button on ‘New Slide” at toolbar.
IV.  Select the slide having Title slide and Bullet list.

Inserting Excel sheet:

. Open the slide where you want to insert the Excel Sheet.
Il Select the ‘Insert tab’. And click on ‘Object’ on tool bar.
lll.  Select the ‘Microsoft Excel Worksheet’ object type.

Iv. Click the ‘OK’ button.
ClipArt and Text:
I Select the Insert Tab.

Il.  Select the ‘Pictures’ or ‘Online pictures’ on tool bar.

1. Choose the appropriate art for the topic.

V. Click on the ‘Insert’ button.
Slide show effects:

I.  Select ‘Design Tab’ for Themes, Variants and Slide size.
. Select ‘Transition Tab’ for Cut, Fade, Push, Wipe, Split, Reveal, Shape, Flash, etc. for

slide effects.

Q16. What is the difference between Machine Language and High Level Language?

Machine language

High level language

A computer programming language
consisting of binary instructions which a
computer can respond to directly

It requires no translator to translate the
code. It is directly understood by the
computer

This language makes fast and efficient use
of the computer.

It is a programming language that enables
development of a program in a much
more user friendly programming context
It takes additional translation time to
translate the source code to machine code
They are programmer friendly

Q17. Discuss about different data types of C programming Language.

Ans:- The different data types of C programming language are:




Char: the most basic data type in C.it store a single character and requires a single bite of memory in
almost all compilers.

Int: as the name suggests, an int variable is used to store an integer.
Float: it is used to store decimal numbers

Double: it is used to store decimal numbers (number with floating point value but its range of values
is high in comparison to float)

Q18. Find the output of the following expressions
a) X=20/5*2+30-5 b) Y=30-(40/10+6) +10 c)Z= 40*2/10-2+10
Ans:-

a) X=33
b) Y=30
¢) C=16

Q19. Describe the syntax of the following statements

a) If — else statement b) for loop c) while loop d) do-while loop
Ans:- a) if- else statement:

If statements can be followed by an optional else block of statements, which executes when

the Bootcan expression is false.
Syntax
If (expression)
{

true block of statements;

}

else

{

else block of statements;

}

b) For loop is similar to while loop. Basic syntax of for loop is as follows:
For (expression 1; expression 2; expression3)

{

Block of statement

}



In the above syntax

Expressionl-initializes variables.

Expression2 — conditional expression as long as this condition is true, loop will keep
executing.

Expression3- it is the modifier which will increase or decrease the value of the variable.
c¢) While loop.

Basic syntax of while loop is as follows

While (condition)

Single statement.

OR while (condition)

{

Block of statements

}

d) Do- while loop.

Do-while loop is just like a while loop except that the text condition is checked at the end of the
loop rather than the start. This has the effect that the body of the loop are always executed at
least once

Basic syntax of do-while loop is as follows

Do
{
Single statement

Or

Block of statements

} while (condition);

Q20. Find the output of the following program segments



#Hinclude <stdio.h> #include <stdio.h>
int main() void main()
{ ¢
inti=1; int a = 10, b=100;
while (i<=2) ifla>b) _
{ printf{ "Largest number is %d\n", a);
printf{ "IMS Ghaziabad\n"); else
i=i+1; printf{ "Largest number is %d\n”, b);
b b
)

a) IMS Ghaziabad
b) IMS Ghaziabad

IMS Ghaziabad
c) 100



