ASSIGNMENT -1

1.WHAT ARE THE FOUR FUNDAMENTAL PARTS OF THE COMPUTER? EXPLAIN
IT WITH THE HELP OF THE DIAGRAM.,
A computer has four main components: The Central Processing unit or CPU, The Primary

Memory, Input Units and Output Units.
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2. Discuss about the classification of computers based on size and capacity.

Computers are classified on different parameters, such as, storage capacity, processing speed
and component (CPU) used in computers. Depending upon the components used and
features of different computers, they are classified into four groups, Microcomputers,
Minicomputers, Mainframe computers and Supercomputers.
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3. What is the meaning of computer generation? How many Computer Generations are
defined? What technologies were/are used?

Initially, the generation term was used to distinguish between varying hardware
technologies. Nowadays, generation includes both hardware and software, which together
make up an entire computer system. There are five computer generations known till date.
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Generation Period  Technology Used
1t Gen. | 1946-1959 : Vacuum Tubes
2nd Gen.: 1959-1965 : Transistors

I PR
4th Gen. | 1971-1980

5th Gen. | 1980-present : Al & ULS|

Generations of Computer

4. Differentiate between Volatile & Non- Volatile memories.

Volatile memory is the type of memory in which data is lost as it is powered-off. Non-
volatile memory is the type of memory in which data remains stored even if it

is powered-off.




S.No Volatile Memory Non Volatile Memory

Volatle memory is the type of Non Volatile Memory is a type of memory
memory where data is lost when where the data is not lost when a computer
power is turned off is switched off.

Data temporarily stored in volatile Data permanently stored in non volatile
memory memory

It is faster than non-volatile memory. | It is slower than volatile memory.

It has less storage capacity It has more storage capacity than volatile
memory

Data can be easily transferred Data can not be easily transferred

It is more costly per unit size. It is less costly per unit size.

CPU has direct access to data. CPU has no direct access to data.

Process can read and write Process can only read.

It has a high impact on the system’s | It has a high impact on a system'’s storage
performance. capacity.

Data and programs that are currently Any kind of data and programs are stored
fetch by CPU are stored in Volatile ' in Non Volatile memory
memory

Example: RAM and Cache Memory | Example: ROM and HDD

5. Distinguish among system software, application software and open source software
on the basis of their features.

System Software:

System Software is the type of software which is the interface between application software
and system. Low level languages are used to write the system software. System Software
maintains the system resources and gives the path for application software to run. An
important thing is that without system software, system cannot run. It is general purpose
software.

Application Software:




Application Software is the type of software that runs as per user request. It runs on the
platform which is provided by system software. High level languages are used to write the
application software. It’s specific purpose software.

The main difference between System Software and Application Software is that without
system software, system cannot run on the other hand without application software, system
always runs.

Open-source software (OSS):

Is computer software that is released under a license in which the copyright holder grants
users the rights to use, study, change, and distribute the software and its source code to
anyone and for any purpose. Open-source software may be developed in a collaborative
public manner.
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Q6 (b). Write the steps regarding followings

1. Tochange font style:

Open your device's Settings app.

Tap Accessibility Text and display.
Tap Font size.

Use the slider to choose your font size.




. To change the font size:

Select the text that you want to modify.

In Home tab locate the Font group.

In Font group click the drop-down arrow next to font size box.
Font size menu appears.

Select the desired font size with a left click.

Select the text and click the increase or decrease font size buttons.

. To change the font color:

Select the text that you want to change.

On the Home tab, in the Font group, choose the arrow next to Font Colour, and then
select a colour. You can also use the formatting options on the Mini toolbar to quickly
format text.

4. To highlight (vellow) the line that reads “need to get IMS’s address”.

“NEED TO GET IMS’S ADDRESSSS”
7.
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MS-WORD

MS-WORD is a widely used commercial word
processor developed by Microsoft.

MS-WORD is application software, which is capable
of

* Creating,

» Editing,

* Saving, and

# Printing any type of document
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13. A) Describe various steps involved in the following
1. To modify column width of a worksheet

e Select a column or a range of columns.
e On the Home tab, in the Cells group, select Format > Column Width.
e Type the column width and select OK

2. To modify the row height of a worksheet

Select the row or rows that you want to change.

On the Home tab, in the Cells group, click Format.

Under Cell Size, click Row Height.

In the Row height box, type the value that you want, and then click OK.

3. To delete rows and columns of a worksheet

e Select the cells, rows, or columns that you want to delete.

e Right-click and then select the appropriate delete option, for example, Delete Cells &
Shift Up, Delete Cells & Shift Left, Delete Rows, or Delete Columns.




13. B) Describe following terms in the worksheet

Absolute reference and relative reference in formula

There are two types of cell references: relative and absolute. Relative references change
when a formula is copied to another cell. Absolute references, on the other hand, remain
constant no matter where they are copied.

Cell address

A cell reference, or cell address, is an alphanumeric value used to identify a specific cell in
a spreadsheet. Each cell address contains ‘one or more letters' followed by a number. The
letter or letters identify the column and the number represents the row.

14.A) What are the tools available to customize our power point presentation?
> Presentation Tools. Microsoft PowerPoint. Google Slides. Beautiful.ai. Prezi. Keynote for

Mac. Which presentation software works best for Citation.
Screen Recording.

Animation.

Best Practices.

Images.

Resources.

15. Write steps for creation of a set Power Point slides, that demonstrates your skill to
use the tools of Power point. It should include the following things.

1. Title slide & bullet list

A bulleted list is one of the most common slide types used in presentations. It helps organize
your information into short, understandable segments. When you create a new bulleted list
slide, the text and title areas display placeholders surrounded by dotted lines.

2. Inserting excel sheets

> Insert multiple worksheets at the same time

» On the Home tab, in the Cells group, click Insert, and then click Insert Sheet. Tip:
You can also right-click the selected sheet tabs, and then click Insert. On the General
tab, click Worksheet, and then click OK.

3. Clip art and text

» Clip art refers to a graphic or a picture that you can insert in your document.
» It comes in different formats and styles. It is used to enhance the appearance of a
document.




» The steps to insert a clip art are given below; Place the cursor where you want to
insert the clip art.

4. Slide show effects

» Slide Effect is a presentation tool providing enhanced transitions and effects.

» Using a standard Presentation Software user interface, people can create slide
presentation with movies and images in a simpler way than using video editing
software.

16. What is the difference between Machine Language and High Level Language?

Machine language or machine code:

is the only language that is directly understood by the computer, and it does not need to be
translated. All instructions use binary notation and are written as a string of 1s and 0s. A
program instruction in machine language may look something like this:

10010101100101001111101010011011100101

Technically speaking, this is the only language computer hardware understands. However,
binary notation is very difficult for humans to understand. This is where assembly languages
come in.

An assembly language is the first step to improve programming structure and make machine
language more readable by humans. An assembly language consists of a set of symbols and
letters. A translator is required to translate the assembly language to machine language. This
translator program is called the 'assembler.’ It can be called the second generation language
since it no longer wuses 1s and O0s to write instructions, but terms
like MOVE, ADD, SUB and END.

Many of the earliest computer programs were written in assembly languages. Most
programmers today don't use assembly languages very often, but they are still used for
applications like operating systems of electronic devices and technical applications, which
use very precise timing or optimization of computer resources. While easier than machine
code, assembly languages are still pretty difficult to understand. This is why high-level
languages have been developed.

High-Level Languages:

A high-level language is a programming language that uses English and mathematical
symbols, like +, -, % and many others, in its instructions. When using the term ‘programming
languages,” most people are actually referring to high-level languages. High-level languages
are the languages most often used by programmers to write programs. Examples of high-level
languages are C++, FORTRAN, Java and Python.




The second advantage is that the code of most high-level languages is portable and the same
code can run on different hardware. Both machine code and assembly languages are hardware
specific and not portable. This means that the machine code used to run a program on one
specific computer needs to be modified to run on another computer. Portable code in a high-
level language can run on multiple computer systems without modification. However,
modifications to code in high-level languages may be necessary because of the operating
system. For example, programs written for Windows typically don't run on a Mac.

A high-level language cannot be understood directly by a computer, and it needs to be
translated into machine code. There are two ways to do this, and they are related to how the
program is executed: a high-level language can be compiled or interpreted.

17. Discuss about different data types of C programming Language.

The C language has 5 basic (primary or primitive) data types, they are:

Character - ASCII character set or generally a single alphabet likes *a’, 'B", etc.

Integer - Used to store whole numbers like 1, 2, 100, 1000, etc.

Floating-point - Decimal point or real numbers values like 99.9, 10.5, etc.

Double - Very large numeric values which are not allowed in Integer or Floating point type

Void - This means no value. This data type is mostly used when we define functions

char

Like 'a’, ‘T, "A’, etc.

Datatype double

Like 150.505050

Datatypes defines type of
data, which means the type
of value it stores.

A) X=20/5*2+30-5




B) Y=30-(40/10+6)=10
Y=30
C) Z=40*2/10-2+10

Z=16

19. Describe the syntax of the following statements
a) If —else statement:

if (conditionl) {
/I block of code to be executed if conditionl is true
} else if (condition2) {
/I block of code to be executed if the conditionl is false and condition2 is true

} else {

/I block of code to be executed if the conditionl is false and condition2 is false

¥

b) For loop

for (initial value; condition; incrementation or decrementation )

{

Statements;

¥

c) while loop

while (condition) {
statements;
}

d) do-while loop

do{
statements
} while (expression);

20. Find the output of the following program segments.
a. IMS Ghaziabad

b. IMS Ghaziabad




IMS Ghaziabad

c. Large Number is 100

a) IMS Ghaziabad

b) IMS Ghaziabad
| IMS cGhaziabad
<€) Large number is 1eq]
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